Subject: RE: [Sigtran] M2PA list of comments on draft version 5 - multiple links on the s

From: "Amish Chana" <[email-masked]>
Date: Sun, 21 Jul 2002 18:23:28 +0100

Tolga,

>[TOLGA] If you think that SCTP blocks the delivery of link status message 
>by
>sending it from the same stream like data, then you probably also think 
>that
>this happens also with MTP2.

I am referring to blocking at the SCTP receiver, if an earlier data message 
was overtaken or corrupted. SCTP will not deliver the link status message to 
M2PA until the data message is successfully received. If the MTP2 receiver 
discards a MSU because it is corrupted, it does not discard or block the 
subsequent LSSU - it processes it!

>What we need to do is to mimic MTP2 behavior.
>It is not blocking, it is just simulating a link in IP domain and 
>preserving
>sequence. If a link status message is received after a data message with
>MTP2, the same should happen with M2PA.

What is the advantage of mimicing MTP2 behaviour with regards to the 
sequencing between MSUs and Link status messages? What do you gain/loose?

You are simply introducing unnecessary delays at the receiving end by using 
a single stream.

BTW, please note that sending a
>message from stream0 might further delay it, IP network does not care about
>streamIDs.

Yes, and sending all the messages on the same stream does not mean the link 
status message will be delivered any faster (it will just take much longer 
if a preceding message is lost).

A.

_________________________________________________________________
MSN Photos is the easiest way to share and print your photos: 
http://photos.msn.com/support/worldwide.aspx

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Mon, 22 Jul 2002 09:36:21 +0100

Michael,

That would require MTP3 to support multiple independent streams on each link.
See Section 4.2.6.1.

Regards,
Amish

Tuexen Michael <[email-masked]> on 22/07/2002 09:10:58

To:   "'Amish Chana'" <[email-masked]>
      [email-masked]
      [email-masked]
cc:    (bcc: Amish CHANA/EN/HTLUK)

Subject:  RE: [Sigtran] M2PA list of comments on draft version 5 - multiple
      links on the s

Dear all,

I understand that you can replace a SS7 link with M2PA using
one association. What I do not understand is why I can not split
MSUs with different routing labels on different streams with
SID > 0. This would allow me to replace a linkset with an IP based
link having the necessary bandwidth (assuming my IP network provides it)
but avoiding the HOL problem.

Best regards
Michael

Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CC SE 7    e-Mail: [email-masked]

> -----Original Message-----
> From: Amish Chana [mailto:[email-masked]]
> Sent: Sunday, July 21, 2002 7:23 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sigtran] M2PA list of comments on draft version 5 -
> multiple links on the s
>
>
> Tolga,
>

*******************************************************************************
Important.
Confidentiality: This communication is intended for the above-named person and
may be confidential and/or legally privileged. Any opinions expressed in this
communication are not necessarily those of the company. If it has come to you
in error you must take no action based on it, nor must you copy or show it to
anyone; please delete/destroy and inform the sender immediately.

Monitoring/Viruses
Orange may monitor all incoming and outgoing emails in line with current
legislation.  Although we have taken steps to ensure that this email and
attachments are free from any virus, we advise that in keeping with good
computing practice the recipient should ensure they are actually virus free.

Orange PCS Limited is a subsidiary of Orange SA and is registered in England No
2178917, with its address at St James Court, Great Park Road, Almondsbury Park,
Bradley Stoke, Bristol BS32 4QJ.
*******************************************************************************

---

From: [email-masked]
Date: Mon, 22 Jul 2002 10:21:18 +0100

Michael,

You could represent multiple SS7 links on a association with a different stream,
i.e. multiplexed M2PA links on a association.
Brian's defence for not having this option was to prevent multiple SS7 links
failing simutaneously - see the threads on "multiplexed M2PA links".
However, M2UA does support this functionality and it has already passed last
call and has been approved by the IESG.

Tom,

You have the following in your list of M2PA comments. Note, SCTP associations
can be multi-homed - i.e. SCTP retransmissions may follow a different path.
The draft should not limit the capabilities of the implementation and deployment
if MTP3 at both endpoints is able to cope with multiple simultaneous link
failures.
It should allow for a deployment with to 2 associations, each with a different
primary and with 8 links multiplexed on each association.

>A: The disadvantage of this is that if the association dies, you lose
>all the links on the association. (According to the SCTP authors, it
>is intended that all the streams in an association follow the same
>physical path.) This is one of the main reasons I did allow for
>multiple links in an association.

Amish

[email-masked] on 22/07/2002 09:36:21

To:   Tuexen Michael <[email-masked]>
cc:   [email-masked] (bcc: Amish CHANA/EN/HTLUK)

Michael,

Regards,
Amish

Dear all,

Best regards
Michael

Monitoring/Viruses

Monitoring/Viruses

---

From: Tuexen Michael <[email-masked]>
Date: Mon, 22 Jul 2002 12:12:37 +0200

Brian, Amish,

thank for clarification. I was not thinking about the
Message retrival stuff. Thank for the hint.

Best regards
Michael

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, July 22, 2002 11:43 AM
> To: Tuexen Michael
> Cc: 'Amish Chana'; [email-masked]; [email-masked]
> Subject: Re: [Sigtran] M2PA list of comments on draft version 5 -
> multiple links on the s
> 
> 
> Michael,
> 
> What exactly don't you understand?
> 
> If you wish to put multiple links on M2PA, then we have
> already discussed this.  Multiple links on M2PA where all
> links live and die together unbeknownst to MTP3 can cause
> thrashing and cascade failures.  This and other reasons
> is why M2PA provides for only one link per association.
> 
> 
> If you wish to merely split the traffic for a single link on
> multiple streams, then the problem is with changeover
> procedures (only one sequence number is permitted for each
> link for changeover).  This is why M2PA uses only one data
> stream.
> 
> --brian
> 
> Tuexen Michael wrote:                       (Mon, 22 Jul 2002 
> 10:10:58)
> > Dear all,
> > 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/