Subject: [Sigtran] m3ua Correlation Id

From: "Nagar, Ashish" <[email-masked]>
Date: Wed, 10 Jul 2002 21:51:56 -0700

Hi ALL

can anybody please clarify the usage of optional parameter correlation Id
in the M3UA transfer message(DATA).

Ashish

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]]
Sent: Wednesday, July 10, 2002 6:44 PM
To: [email-masked]
Subject: RE: [Sigtran] ASP ID

Brian,

From pure protocol point of view, I agree with your explanation but still
personally I would prefer an explanation in IG that ASPID in ASPUP might be
used for assigning dynamic port number or IP addresses to ASPs.

   Tolga

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, July 10, 2002 1:57 AM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] ASP ID
>
>
> Tolga,
>
> That is an operational consideration.  We had a long discussion about
> this.  ASP Id is used to inform other ASPs of an ASP failure.  From a
> protocol perspective the ASP Id needs to be unique within the pool of
> "concerned" ASPs to which a notification may be sent.  Anything more
> is an operational consideration.  It might be convenient for an
> operator to assign a unique ASP Id to each ASP in a network (for
> example).
>
> --brian
>
> Tolga Asveren wrote:                                        (Tue,
> 09 Jul 2002 17:52:14)
> > Brian,
> >
> > Just to clarify, in your opinion, what is the scope of AspId? As stated
> > earlier, my opinion is it should be unique per SGP to be able to support
> > dynamic IP addresses for ASPs.
> >
> >    Tolga
> >
> > > -----Original Message-----
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Brian F. G. Bidulock
> > > Sent: Tuesday, July 09, 2002 3:47 PM
> > > To: [email-masked]
> > > Subject: Re: [Sigtran] ASP ID
> > >
> > >
> > > Tolga,
> > >
> > > Tolga Asveren wrote:                                        (Tue,
> > > 09 Jul 2002 10:01:08)
> > > > John S.,
> > > >
> > > > The case you describe is about assigning AspIds dynamically.
> > > Personally I
> > > > would prefer assigning IP addresses dynamically instead of
> AspId. AspId
> > > > might be preconfigured and I think this was the original
> > > intention. AspId is
> > > > preconfigured at both ASP and SGPs and based on AspId value in
> > > ASPUP message
> > > > SGP recognizes the ASP (because IP address of ASP is
> > > dynamically assigned so
> > > > could not be preconfigured). So, it is not so that ASP
> should "guess" a
> > > > valid AspId value, this value is already preconfigured.
> > > >
> > > > Apart from this, it is also conceptually not very clean, to
> > > send AspId with
> > > > ASPUP -if one wants its scope per AS/SGP- because it is
> > > possible that one
> > > > ASP is serving several AS and so might have different AspIds in
> > > the context
> > > > of each different AS.
> > >
> > > ASP Id is per-ASP not per-AS.  RC already identifies the AS.
> > >
> > > --brian
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 11 Jul 2002 02:14:41 -0600

Ashish,

Correlation Id is used to allow an ASP newly entering a Broadcast
AS to syncrhonize itself to the traffic.  In addition, Correlation
Id could be used as described in draft-bidulock-sigtran-corid-00.txt
to provide lossless failover between associations.

--brian

Nagar, Ashish wrote:                                       (Wed, 10 Jul 2002 21:51:56)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/