Subject: [Sigtran] ASP ID

From: "Nahar,virendra" <[email-masked]>
Date: Fri, 05 Jul 2002 19:06:53 +0530

Hi
The draft Says ASP ID in ASP UP message should be checked for uniqueness.
The optional ASP Identifier parameter contains a unique value that is
locally significant among the ASPs that support an AS.
    But the ASP is part of which AS will be known only when a REG_REQ from
that ASP is received.(assuming no static config)
    So after decoding say REG_REQ  say ASP is going to participate in AS X which
is already having
an ASP with same ASP ID.
    SO an Error message will be sent here saying invalid ASP ID
But what should be sent in the REG_RSP
I guess
1 Unknown Error
2 No Reg Response is needed in this case
    Pls Clarify.

Thanks
Nahar
--
Virendra Nahar
HCL-Technologies Ltd
Networking Technology Lab
HCL Technologies Ltd.,
Ground Floor, Block - 1, Chandamama Building,
184 to 188,190,192 & 196, NSK Road,
Vadapalani, Chennai - 600 026
Phone office      : +91-44-3728366 extn - 1129
Fax               : +91-44-4806640
mailto:[email-masked]
PUTT' LAW
" TECHNOLOGY is dominated by two types of people
1.Those who unserstand what they do not manage !
2.Those who manage what they do not understand !
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 5 Jul 2002 11:21:50 -0400

One of the purposes of  having AspId in ASPUP is to support dynamic IP
adress allocation for ASPs. So, IMO the statement that it is locally
significant among ASPs that support an AS is in conflict with that purpose.
I think, to meet all demands, AspId should be unique per SGP.

  Tolga

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Nahar,virendra
Sent: Friday, July 05, 2002 9:37 AM
To: Sigtran
Subject: [Sigtran] ASP ID

Hi
    So after decoding say REG_REQ  say ASP is going to participate in AS X
which is already having

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran