Subject: [Sigtran] Padding bytes

From: [email-masked]
Date: Mon, 22 Jul 2002 18:17:19 +0530

Hi All,
   What are the factors which led us to add padding bytes in all UA's except
M2PA ?
   When SCTP is also adding padding bytes.

   -manish
    www.hssworld.com

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tuexen Michael <[email-masked]>
Date: Mon, 22 Jul 2002 15:12:02 +0200

Manish,

the UAs have multiple parameters. It is, from a performace point of
view, better if they are aligned at 32-bit boundaries. If the upper
layer does not do this SCTP does this for its chunks. But this forces
not the upper layer parameters to have 32-bit boundaries.

Even M2PA aligns its stuff to 32 bit boundaries. If you look, for example,
at the M2PA Header there are the 'unused' fields. These make sure that 
the BSN, FSN are on 32-bit boundaries.

Best regards
Michael

Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CC SE 7    e-Mail: [email-masked]

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, July 22, 2002 2:47 PM
> To: Tom George
> Cc: [email-masked]
> Subject: [Sigtran] Padding bytes
> 
> 
> 
> 
> Hi All,