Subject: RE: [Sigtran] ASP ID

From: "Schantz, John" <[email-masked]>
Date: Mon, 8 Jul 2002 11:09:32 -0500

So I take it you want the AS to play "20 questions" with the SG until
the SG is happy with the value the AS has selected for the ASP ID?  (Boy
am I glad its OPTIONAL!) It could take a very long time for an ASP to
come up into the Active state if the SG has may ASP connections.

I think ASP ID uniqueness at the AS is all that was expected.

John

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]] 
Sent: Friday, July 05, 2002 10:22 AM
To: [email-masked]
Subject: RE: [Sigtran] ASP ID

One of the purposes of  having AspId in ASPUP is to support dynamic IP
adress allocation for ASPs. So, IMO the statement that it is locally
significant among ASPs that support an AS is in conflict with that
purpose. I think, to meet all demands, AspId should be unique per SGP.

  Tolga

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Nahar,virendra
Sent: Friday, July 05, 2002 9:37 AM
To: Sigtran
Subject: [Sigtran] ASP ID

Hi
The draft Says ASP ID in ASP UP message should be checked for
uniqueness. The optional ASP Identifier parameter contains a unique
value that is locally significant among the ASPs that support an AS.
    But the ASP is part of which AS will be known only when a REG_REQ
from that ASP is received.(assuming no static config)
    So after decoding say REG_REQ  say ASP is going to participate in AS
X which is already having an ASP with same ASP ID.
    SO an Error message will be sent here saying invalid ASP ID But what
should be sent in the REG_RSP I guess 1 Unknown Error 2 No Reg Response
is needed in this case
    Pls Clarify.
Thanks
Nahar
--
Virendra Nahar
HCL-Technologies Ltd
Networking Technology Lab
HCL Technologies Ltd.,
Ground Floor, Block - 1, Chandamama Building,
184 to 188,190,192 & 196, NSK Road,
Vadapalani, Chennai - 600 026
Phone office      : +91-44-3728366 extn - 1129
Fax               : +91-44-4806640
mailto:[email-masked]
PUTT' LAW
" TECHNOLOGY is dominated by two types of people
1.Those who unserstand what they do not manage !
2.Those who manage what they do not understand !
############################################################
"He who has a why for life can put with any how."
                             Frederick Nietzsche
############################################################

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Nahar,virendra" <[email-masked]>
Date: Tue, 09 Jul 2002 09:57:59 +0530

Hi john/all

> I think ASP ID uniqueness at the AS is all that was expected.

    Nahar: Let me know what do u suggest to send in the REG_RSP for the case I
                mentioned in my last mail.i.e start of this thread.
               i.e after decoding rk we find that this ASPID of ASP is already
in use
for this AS/RK by some other ASP.

Thanks
Nahar

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 9 Jul 2002 10:01:08 -0400

John S.,

The case you describe is about assigning AspIds dynamically. Personally I
would prefer assigning IP addresses dynamically instead of AspId. AspId
might be preconfigured and I think this was the original intention. AspId is
preconfigured at both ASP and SGPs and based on AspId value in ASPUP message
SGP recognizes the ASP (because IP address of ASP is dynamically assigned so
could not be preconfigured). So, it is not so that ASP should "guess" a
valid AspId value, this value is already preconfigured.

Apart from this, it is also conceptually not very clean, to send AspId with
ASPUP -if one wants its scope per AS/SGP- because it is possible that one
ASP is serving several AS and so might have different AspIds in the context
of each different AS.

   Tolga

> From: Schantz, John [mailto:[email-masked]]
> Sent: Monday, July 08, 2002 12:10 PM
> To: Tolga Asveren; [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 9 Jul 2002 14:46:34 -0500

Tolga,

Tolga Asveren wrote:                                        (Tue, 09 Jul 2002 10:01:08)
> ASP is serving several AS and so might have different AspIds in the context

ASP Id is per-ASP not per-AS.  RC already identifies the AS.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Tue, 9 Jul 2002 17:52:14 -0400

Brian,

Just to clarify, in your opinion, what is the scope of AspId? As stated
earlier, my opinion is it should be unique per SGP to be able to support
dynamic IP addresses for ASPs.

   Tolga

> Sent: Tuesday, July 09, 2002 3:47 PM
> To: [email-masked]
> Subject: Re: [Sigtran] ASP ID
>
>
> Tolga,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 10 Jul 2002 00:57:19 -0500

Tolga,

That is an operational consideration.  We had a long discussion about
this.  ASP Id is used to inform other ASPs of an ASP failure.  From a
protocol perspective the ASP Id needs to be unique within the pool of
"concerned" ASPs to which a notification may be sent.  Anything more
is an operational consideration.  It might be convenient for an
operator to assign a unique ASP Id to each ASP in a network (for
example).

--brian

Tolga Asveren wrote:                                        (Tue, 09 Jul 2002 17:52:14)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Wed, 10 Jul 2002 09:14:14 -0400

Brian,

From pure protocol point of view, I agree with your explanation but still
personally I would prefer an explanation in IG that ASPID in ASPUP might be
used for assigning dynamic port number or IP addresses to ASPs.

   Tolga

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, July 10, 2002 1:57 AM
> To: Tolga Asveren
> Cc: [email-masked]
> > > From: [email-masked]
> [mailto:[email-masked]]On Behalf Of
> > > Brian F. G. Bidulock