Subject: Re: [Sigtran] M2PA:Questions on sequence number

From: Tom George <[email-masked]>
Date: Tue, 09 Jul 2002 16:51:28 -0500

I agree that it is unnecessary to add the retransmission or T7 timer to
M2PA. IMHO this just duplicates SCTP.

If anyone is interested, we had a short discussion about this before.
The thread subject was 
"[Sigtran] M2PA-04 More Sequence Numbers" and began on 03/04/02.

tomG.

[email-masked] wrote:
> 
> Hello Brian,
> 
> Are you a lawyer, by any chance? ;-)
> 
> The draft should continue to say that the link is taken out of service upon
> the reception of one (1)
> user data message having invalid FSN (no gaps or repeats allowed).
> 
> I remain unconvinced that the procedures described by Q.703 need to be
> added
> to M2PA. Such an addition would unnecessarily duplicate SCTP functionality,
> would
> add complexity, and would provide little added value.
> 
> Regards,
> 
> Jeff
> 
> "Brian F. G. Bidulock" <[email-masked]>@ietf.org on 05/28/2002
> 10:04:13 AM
> 
> Please respond to [email-masked]
> 
> Sent by:  [email-masked]
> 
> To:   [email-masked]
> cc:   [email-masked]
> Subject:  Re: [Sigtran] M2PA:Questions on sequence number
> 
> Jeffrey,
> 
> "Some number" might be one (1).
> 
> --brian
> 
> [email-masked] wrote:                    (Tue, 28 May 2002
> 07:48:50)
> >
> > Brian,
> >
> > Why 'some number' of abnormal FSNs? It is SCTP's job to provide reliable
> > in-sequence
> > transport. Reception of a single bad M2PA FSN should result in link
> > failure.
> >
> > Are the authors now contemplating applying M2PA to non-reliable
> > transport(s)?
> >
> > I think it is a bad idea to add unnecessary complexity to M2PA by
> > duplicating (even more)
> > SCTP functionality.
> >
> > -Jeff
> >
> >
> >
> >
> >
> >
> > "Brian F. G. Bidulock" <[email-masked]>@ietf.org on 05/27/2002
> > 01:35:23 PM
> >
> > Please respond to [email-masked]
> >
> > Sent by:  [email-masked]
> >
> >
> > To:   Lisa Gorgone <[email-masked]>
> > cc:   [email-masked]
> > Subject:  Re: [Sigtran] M2PA:Questions on sequence number
> >
> >
> > Lisa,
> >
> > What I really meant here was that if I receive some number
> > of abnormal FSNs, I put the link out of service.  Negative
> > acknowledgements are not provided for in M2PA at this time.
> >
> > --brian
> >
> > Lisa Gorgone wrote:                                          (Mon, 27 May
> > 2002 15:21:23)
> > >
> > >
> > > "Brian F. G. Bidulock" wrote:
> > >
> > > > >
> > > > > 2)The Forward Sequence Number Received  is used to check the
> correct
> > > > > sequence of frames. If the FSNR is out of order which actions
> should
> > be
> > > > > taken?
> > > > >
> > > > > Since the probability of this event is very low, the link could be
> > > > > immediately failed.
> > > >
> > > > I take the same approach as abnormal FSNR in Q.703.  I believe it is
> > the
> > > > rational approach and should be included in the draft.
> > >
> > > In Q.703 a wrong FSNR invokes retransmission by inverting BIB.
> > > Do you think that Fib, Bib and Retransmission should be added
> > > to the draft?
> > > Thanks and Regards
> > > Lisa & Aldo
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> >
> 
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
* Tom George          972-519-3168           [email-masked]   *
* PB2-1323       Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel USA, Inc.; 1000 Coit Rd, MS PB2-STPA; Plano TX 75075-5813   *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Thu, 11 Jul 2002 15:47:43 +0100

Tom,

Refer to the
"[Sigtran] M2PA Comment: T7 Timer" started on 21 June 2002,
"[Sigtran] M2PA Comment: Timers"  on 21 June 2002 and
"[Sigtran] M2PA Comment: Multi-homing" started on 18 June 2002.

There seems to be agreement by most people that T7 should be included because
SCTP may take too long to detect an association failure.

Amish

Tom George <[email-masked]> on 09/07/2002 22:51:28

To:
cc:   [email-masked] (bcc: Amish CHANA/EN/HTLUK)

tomG.

*******************************************************************************
Important.
Confidentiality: This communication is intended for the above-named person and
may be confidential and/or legally privileged. Any opinions expressed in this
communication are not necessarily those of the company. If it has come to you
in error you must take no action based on it, nor must you copy or show it to
anyone; please delete/destroy and inform the sender immediately.

Monitoring/Viruses
Orange may monitor all incoming and outgoing emails in line with current
legislation.  Although we have taken steps to ensure that this email and
attachments are free from any virus, we advise that in keeping with good
computing practice the recipient should ensure they are actually virus free.

Orange PCS Limited is a subsidiary of Orange SA and is registered in England No
2178917, with its address at St James Court, Great Park Road, Almondsbury Park,
Bradley Stoke, Bristol BS32 4QJ.
*******************************************************************************