Subject: RE: [Sigtran] M2PA list of comments on draft version 5 - multiple links on the s

From: Tuexen Michael <[email-masked]>
Date: Mon, 22 Jul 2002 10:10:58 +0200

Dear all,

I understand that you can replace a SS7 link with M2PA using
one association. What I do not understand is why I can not split
MSUs with different routing labels on different streams with
SID > 0. This would allow me to replace a linkset with an IP based
link having the necessary bandwidth (assuming my IP network provides it)
but avoiding the HOL problem.

Best regards
Michael

Michael Tuexen    Tel.:   +49 89 722 47210
Siemens AG        Fax:    +49 89 722 48212
ICN WN CC SE 7    e-Mail: [email-masked]

> -----Original Message-----
> From: Amish Chana [mailto:[email-masked]]
> Sent: Sunday, July 21, 2002 7:23 PM
> To: [email-masked]; [email-masked]
> Subject: RE: [Sigtran] M2PA list of comments on draft version 5 -
> multiple links on the s
> 
> 
> Tolga,
> 
> >[TOLGA] If you think that SCTP blocks the delivery of link 
> status message 
> >by
> >sending it from the same stream like data, then you probably 
> also think 
> >that
> >this happens also with MTP2.
> 
> I am referring to blocking at the SCTP receiver, if an 
> earlier data message 
> was overtaken or corrupted. SCTP will not deliver the link 
> status message to 
> M2PA until the data message is successfully received. If the 
> MTP2 receiver 
> discards a MSU because it is corrupted, it does not discard 
> or block the 
> subsequent LSSU - it processes it!
> 
> >What we need to do is to mimic MTP2 behavior.
> >It is not blocking, it is just simulating a link in IP domain and 
> >preserving
> >sequence. If a link status message is received after a data 
> message with
> >MTP2, the same should happen with M2PA.
> 
> What is the advantage of mimicing MTP2 behaviour with regards to the 
> sequencing between MSUs and Link status messages? What do you 
> gain/loose?
> 
> You are simply introducing unnecessary delays at the 
> receiving end by using 
> a single stream.
> 
> BTW, please note that sending a
> >message from stream0 might further delay it, IP network does 
> not care about
> >streamIDs.
> 
> Yes, and sending all the messages on the same stream does not 
> mean the link 
> status message will be delivered any faster (it will just 
> take much longer 
> if a preceding message is lost).
> 
> A.
> 
> 
> _________________________________________________________________
> MSN Photos is the easiest way to share and print your photos: 
> http://photos.msn.com/support/worldwide.aspx
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 22 Jul 2002 03:43:18 -0600

Michael,

What exactly don't you understand?

If you wish to put multiple links on M2PA, then we have
already discussed this.  Multiple links on M2PA where all
links live and die together unbeknownst to MTP3 can cause
thrashing and cascade failures.  This and other reasons
is why M2PA provides for only one link per association.

If you wish to merely split the traffic for a single link on
multiple streams, then the problem is with changeover
procedures (only one sequence number is permitted for each
link for changeover).  This is why M2PA uses only one data
stream.

--brian

Tuexen Michael wrote:                       (Mon, 22 Jul 2002 10:10:58)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/