Subject: [Sigtran] Routing Key parameter in M3UA-12

From: "Yiderlin" <[email-masked]>
Date: Thu, 8 Aug 2002 16:24:22 +0800

Dear all,
    In the draft-ietf-sigtran-m3ua-12.txt, the routing key parameter is as follows:
    0                   1                   2                   3

    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                       Local-RK-Identifier                     |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                  Traffic Mode Type (optional)                 |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                     Destination Point Code                    |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                  Network Appearance (optional)                |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                  Service Indicators (optional)                |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |              Originating Point Code List (optional)           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                   Circuit Range List (optional)               |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   \                                                               \

   /                              ...                              /

   \                                                               \

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                     Destination Point Code                    |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                  Service Indicators (optional)                |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |              Originating Point Code List (optional)           |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   |                   Circuit Range List (optional)               |

   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

I'm not sure if it's a typo or not.  That is the repeat part contains:

1. DPC, SI, OPC list, circuit range list?  or  

2. DPC, NA, SI, OPC list, and circuit range list?

It is possible that DPC belongs to different  NA, right?

There is no modification about this part in IG, will this be updated in next version?

Thanks in advance.

Best regards

ydlin

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 8 Aug 2002 09:19:29 -0400

One RK can't span multiple networks, so there will be only one NA. Multiple
DPC in RK is supported for alias point code case. In the IG, alias point
code case  is stated as the reason for multiple OPC in RK but this will be
corrected with the next version of IG.

    Tolga
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of
Yiderlin
  Sent: Thursday, August 08, 2002 4:24 AM
  To: [email-masked]
  Subject: [Sigtran] Routing Key parameter in M3UA-12

  Dear all,
      In the draft-ietf-sigtran-m3ua-12.txt, the routing key parameter is as
follows:
      0                   1                   2                   3

     |                       Local-RK-Identifier                     |

     \                                                               \

     /                              ...                              /

     \                                                               \

  There is no modification about this part in IG, will this be updated in
next version?

  Thanks in advance.

  Best regards

  ydlin

---

From: 廖彥彰 <[email-masked]>
Date: Fri, 9 Aug 2002 10:29:25 +0800

Dear Tolga :

The  M3UA-12 send first DPC before NA , 
Why  not send NA first and then send multiple (DPC+SI+OPCs+CRs)  as following ?

    0                   1                   2                   3
   |                  Network Appearance (optional)                |  <==Send NA before DPC

Yien-Chang Liao

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tolga Asveren
Sent: Thursday, August 08, 2002 9:19 PM
To: [email-masked]
Subject: RE: [Sigtran] Routing Key parameter in M3UA-12

One RK can't span multiple networks, so there will be only one NA. Multiple DPC in RK is supported for alias point code case. In the IG, alias point code case is stated as the reason for multiple OPC in RK but this will be corrected with the next version of IG.

    Tolga
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Yiderlin
Sent: Thursday, August 08, 2002 4:24 AM
To: [email-masked]
Subject: [Sigtran] Routing Key parameter in M3UA-12

Dear all,

Best regards

ydlin

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 8 Aug 2002 23:40:48 -0600

Yien-Chang,

It is normal to place mandatory parameters before optional ones.

Don't ask about Traffic Mode Type !

--brian

??? wrote:                                                                           (Fri, 09 Aug 2002 10:29:25)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/