Subject: [Sigtran] [Sigtran]: M2UA: how to mapping the interface ID to SCTP stream

From: "Lu Jun" <[email-masked]>
Date: Fri, 23 Aug 2002 10:49:57 +0800

Hi all
i want to ask a question about M2UA, what's the relationship between M2UA interface ID and SCTP stream ID.
if the M2UA use integer IID, does the value of IID equal the SCTP stream ID  

lujun

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Aug 2002 21:28:00 -0600

Lu,

Lu Jun wrote:                                                                         (Fri, 23 Aug 2002 10:49:57)
>    M2UA interface ID and SCTP stream ID.

There is no special relationship.  Each Interface Id needs one and only one
Stream Id associated with it so that messages for the link are ordered
correctly and according to MTP3's expectations.

>    if the  M2UA  use  integer  IID,  does the value of IID equal the SCTP

No.  It is up to each M2UA to decide what stream Id it choses to place an
Interface Id.  This most typically will not result in a stream Id numerically
equal to the Interface Id.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Lu Jun" <[email-masked]>
Date: Fri, 23 Aug 2002 13:49:12 +0800

thanks lots
but i have another question about stream ID, when the SGF will negotiate
with the MGC about the IID mapping with stream ID,
does is the best way for set the IID equal with stream ID? but the M2UA tell
the allocating the IID is depend on implementation

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Lu Jun" <[email-masked]>
Cc: "sigtran" <[email-masked]>
Sent: Friday, August 23, 2002 11:28 AM
Subject: Re: [Sigtran] [Sigtran]: M2UA: how to mapping the interface ID to
SCTP stream

> Lu,
>
> Lu Jun wrote:
(Fri, 23 Aug 2002 10:49:57)
> >
> >    Hi all
> >
> >    i  want  to ask a question about M2UA, what's the relationship
between
> >    M2UA interface ID and SCTP stream ID.
>
> >    if the  M2UA  use  integer  IID,  does the value of IID equal the
SCTP
> >    stream ID

---

From: Jakob Heitz <[email-masked]>
Date: Fri, 23 Aug 2002 08:57:04 -0700

In addition, the stream ID could be a different number in
each direction. The Interface ID must be the same number
in both directions.

--
// Jakob Heitz. Tel:510-747-2917