Subject: Re: Re: [Sigtran] Questions About M3UA

From: <[email-masked]>
Date: Tue, 13 Aug 2002 15:53:43 +0800

Ken Morneault,
     I have a question about SCTP described as the following figure.

                 L2                L3
            -------------STP C-------------
          /                                \
        SP A                             SP B
          \            L1                  / 
　　         -----------------------------

      Signalling point A want to transfer messages to B. 
      And there are  2 paths between them.Path 1 is directly by L1, and Path 2 is composed of L2 and L3,using a STP C. 
      As a SS7 endpoint,A have the ability to choose the path 1 or 2 accoring to the SS7 network status or by operator explicitly. Normally A can transfer message by Path1,and when Path1 is unavaliable, A can transfer message by Path2.
      Can this requirement be realized in IP domain by SCTP? And how?

      I think in IP domain we can't choose the routing path explicitly. The choice of path is done by IP automaticly. And as Transport Layer, SCTP just create an association between A and B.
      Maybe We can't solve this question by multi-streams and multi-homes of SCTP, because the stream is only related to user traffic, and the multi-home just assigns a endpoint many IP addresses and can't decide the routing path from Path1 or path2. 
      Then can we solve it by some other way?
       Please give me your idea, and thanks!

Kong zhen
2002-8-13

======= 2002-07-26 09:21:00 您在来信中写道：=======

>Kong,
>
>I think you may be confused about the relationship between these
>objects.  Maybe an example would help.
>
>                 ASP1<-------SCTP assoc1-------> SGP/SG
>               /                                                   ^
>         AS1                                                    |
>               \                                                   |
>                ASP2<---------SCTP assoc2------------
>
>Ken
>
>
>At 04:18 PM 7/25/2002 +0800, [email-masked] wrote:
>>Dear Sir or Madam,
>>     My name is Kong Zhen, I am a software Engineer for FiberHome Technologies in China.I am in charge of 
>>the development of Signalling Gateway used in 3G UMTS network.
>>
>>     In "draft-ietf-sigtran-m3ua-10.txt" page 10,I have some questions about the sentences:
>>     "An Application Server Process may be configured to process signalling 
>>traffic related to more than one Application Server, over a single SCTP 
>>Association."
>>
>>1.     why a SCTP association can be related to more than one AS during an ASP?
>>
>>2.     Is the Association just connected with 2 AS? 
>>       just as  AS1 <===========> AS2, every traffic in the association  is an ASP.
>>
>>3.     If the Association is between the AS and SG,an the ASP can be associated with more than one AS? 
>>
>>Best regards!
>>　　
>>Kong,Zhen
>>9F, Jiandong Intelligent Building, No.6 Minyuan Road,
>>Hongshan District, Wuhan, China, 430074
>>Tel: +86-27-87528183-8088
>>Fax: +86-27-87528185
>>Email: [email-masked]
>>2002-07-25
>>
>>
>>_______________________________________________
>>Sigtran mailing list
>>[email-masked]
>>https://www1.ietf.org/mailman/listinfo/sigtran 

= = = = = = = = = = = = = = = = = = = =

                    致
礼！

               [email-masked]
					2002-08-13 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 13 Aug 2002 20:03:37 -0600

Kong,

M3UA IPSP does not support relay.  That is, in IPSP configuration, STP C
cannot exist: you only have SP A and SP B.

--brian

[email-masked] wrote:                                                            (Tue, 13 Aug 2002 15:53:43)
> ¡¡¡¡         -----------------------------
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/