Subject: [Sigtran] SUA: Filler in Global Title Address

From: Asif Patel <[email-masked]>
Date: Mon, 05 Aug 2002 10:27:17 -0400

Hi All,

Could someone please clarify on the text below concerning filler in the
SUA global title address? Should 'filler', which is added to the end of
the SUA global title parameter to pad the parameter to a 4-byte
boundary, be included in the parameter length?

For example, let's say I have a 9 digit global title address (e.g.
123456789). As per the text below, the SUA global title address would be
coded as follows:

21436587
09000000
  ^^^^^^
  Filler

So, my question is should this "filler" be included in the length of the
global title parameter, or is this considered "padding"?

Thanks in advance for your help.

Best Regards,
Asif

From section 3.10.2.3,

Global Title: 
    
    Octets contain a number of address signals and possibly filler as 
    shown: 
    
      0                   1                   2                   3 
      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |2 addr.|1 addr.|4 addr.|3 addr.|6 addr.|5 addr.|8 addr.|7 addr.| 
     |  sig. | sig.  |  sig. | sig.  |  sig. | sig.  |  sig. | sig.  | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
     |        .............          |filler |N addr.|   filler      | 
     |                               |if req | sig.  |               | 
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ 
    
   All filler bits SHOULD be set to 0. 
    
   Address signals to be coded as defined in ITU-T Q.713 Section 
   3.4.2.3.1.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Tue, 20 Aug 2002 19:15:36 +0300

Hi Vince,

Could you provide some sample text that you think would help?

Thanks,
John

> -----Original Message-----
> From: ext Vince Deters [mailto:[email-masked]]
> Sent: 19 August, 2002 19:55
> To: [email-masked]
> Cc: [email-masked]; Loughney John (NRC/Helsinki);
> [email-masked]; Asif Patel
> Subject: Re: [Sigtran] SUA: Filler in Global Title Address
> 
> 
> Ok, I'm going to graciously cease my participation in this 
> futile discussion. You simply don't want to help when
> help is needed. Thanks.
> Vince
> 
> "Brian F. G. Bidulock" wrote:
> 
> > Vince,
> >
> > Vince Deters wrote:                                         
>                        (Mon, 19 Aug 2002 12:00:44)
> > >
> > > That would not be sufficient? That is the complete address signal
> > > description from Q.713 section 3.4.2.3.1, which is the 
> reference in the
> > > draft that you quoted above. You've just confirmed that 
> the draft is
> > > deficient.
> > >
> >
> > The entire Q.713 document is normative, so it is not deficient.
> >
> > --brian
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> 
>