Subject: RE: [Sigtran] M2PA v6: Two Out of Three Valid BSN

From: "May, Howard" <[email-masked]>
Date: Fri, 4 Oct 2002 17:02:08 +0100

Brian,

> 
> Howard,
> 
> Leaving it at two out of three allows an MTP2 link to be converted
> directly to an M2PA link.  Please leave it at 2 out of 3.

[hmay] I accept the benefits of aligning MTP2 and M2PA procedures if it does not degrade the services offered by M2PA to its user.  I am uncomfortable with arguments that look to align such procedures without addressing how it affects this service, particular if for implementation reasons.  

[hmay] The only likely cause of an invalid BSN I can see is an implementation error.  Under these circumstances failing the link seems appropriate without waiting around for more erroneous BSNs.  It is fair to say that MTP2 only detects such an error if 2/3 are invalid and so this does not represent a change in service offered, though seems like a missed opportunity to arguably improve the service and simplify the protocol.

> 
> --brian
> 
> May, Howard wrote:                                 (Fri, 04 
> Oct 2002 15:13:23)
> > Tolga,
> > 
> > I'm not quite sure I followed all your arguments but 
> suspect we might have
> > some level of agreement.
> > 
> > Would you at this stage support changing the procedure to 
> failing the link
> > on the first occurrence of an invalid BSN?
> > 
> > Regards
> > 
> > Howard
> > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Oct 2002 10:09:35 -0600

May, Howard wrote:                                     (Fri, 04 Oct 2002 17:02:08)
> 
> [hmay] I accept the benefits of aligning MTP2 and M2PA procedures if it does
> not degrade the services offered by M2PA to its user.  I am uncomfortable
> with arguments that look to align such procedures without addressing how it
> affects this service, particular if for implementation reasons.  
> 
> [hmay] The only likely cause of an invalid BSN I can see is an
> implementation error.

See my last note on direct conversion.

> Under these circumstances failing the link seems
> appropriate without waiting around for more erroneous BSNs.  It is fair to
> say that MTP2 only detects such an error if 2/3 are invalid and so this does
> not represent a change in service offered, though seems like a missed
> opportunity to arguably improve the service and simplify the protocol.
> 

Leaving it the same as Q.703 simplifies the protocol.  The noticeable
improvement to M2PA is that it will not fail links on only 1 out of 3
BSN errors.  Keeping a useable link up is always better than failing
a link.

--brian