Subject: RE: [Sigtran] M2PA V6: T7

From: Tolga Asveren <[email-masked]>
Date: Mon, 7 Oct 2002 17:12:55 -0400

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, October 07, 2002 4:51 PM
> To: Tolga Asveren
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M2PA V6: T7
> 
> 
> Tolga,
> 
> What if the receiver trickles out acks instead of stopping them
> altogether.
[TOLGA] IMO, what will happen in this case is the same what would happen for
MTP2 case if receiver trickles out acks.
> 
> --brian
> 
> Tolga Asveren wrote:         (Mon, 07 Oct 2002 16:34:48)
> > Brian,
> > 
> > > -----Original Message-----
> > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > Sent: Monday, October 07, 2002 4:26 PM
> > > To: Tolga Asveren
> > > Cc: [email-masked]'
> > > Subject: Re: [Sigtran] M2PA V6: T7
> > > 
> > > 
> > > Another thought on T7:
> > > 
> > > Consider what would happen if the receiver (for whatever reason)
> > > stops acknowledging messages at M2PA.  SCTP is humming 
> along nicely,
> > > but the sending M2PA has messages stacking up in its retransmit
> > > buffer.  In this case to protect itself the sending M2PA needs to
> > > run a T7 timer, regardless of SCTP protocol parameter settings.
> > > That timer should be per-message because of the points raised at
> > > the onset of this thread.
> > [TOLGA] Why should T7 be a per message timer to handle this 
> case? If it is
> > used like in MTP2(not a per message timer), in the worst case after
> > T7+propogation(like in MTP2 case) T7 will timeout. 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Oct 2002 15:31:55 -0600

Tolga,

Tolga Asveren wrote:               (Mon, 07 Oct 2002 17:12:55)
> MTP2 case if receiver trickles out acks.

Well no, not exactly.  MTP2 Q.703 has a maximum 127 message window.  M2PA
has a much larger window.  MTP2 will eventually generate transmit
congestion on the link because the 127 message window has been exausted
and the TB will fill.  M2PA, like MTP3b, has much larger windows intended
for higher data rates.  Therefore, MTP2 Q.703 will congest quickly in such
a case, where as M2PA will not.

--brian