Subject: Re: [Sigtran] IUA Test Plan for ETSI PlugTest

From: [email-masked]
Date: Mon, 21 Oct 2002 17:21:01 +0530

Hi Brian,

Link establishment and releases is also covered in this test case 2.3.1 and Data
exchange is also covered in this test case (Step 2a and 2b).
Let me know in case in case you wish to see Data Transfer being present in some
other test case also.

Best Regards,
-Sandeep

"Brian F. G. Bidulock" <[email-masked]> on 10/19/2002 06:02:42 AM

Please respond to [email-masked]

To:   Sandeep Mahajan/HSS@HSS
cc:   [email-masked]

Subject:  Re: [Sigtran] IUA Test Plan for ETSI PlugTest

Sandeep,

I notice that the test plan only exchanges "Unit Data" messages and
never exchanges "Data" messages.  I'm sure this is just an oversight.
In the test cases which "Establish" the data link there should be
an appropriate exchange of "Data" messages.

--brian

[email-masked] wrote:                         (Thu, 17 Oct 2002 20:43:15)
>
>
>
> Hi All,
>
> Here is the first draft of IUA Test Plan for Plugtest. Please review the same
> and send me the comments.
>
> Best Regards,
> -Sandeep
>
> (See attached file: iua_interop_plan_draft01_oct17.txt)
>

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 21 Oct 2002 06:38:42 -0600

Sandeep,

Sorry, I missed 2.3.1 on cursory examination.

Should not Data be transferred after the Establish Indication
in test 2.3.2?  Also, what is the purpose of having Unitdata
in test case 2.3.2?  Unitdata exchange should be split into
its own test case.

What about negative test cases?  For example, what happens if
an Establish Confirm is sent with no outstanding Establish
Request?  What happens if Data Request is sent when no DL
connection is established?

--brian

[email-masked] wrote:                      (Mon, 21 Oct 2002 17:21:01)