Subject: RE: [Sigtran] IUA Test Plan for ETSI PlugTest

From: Sujatha Rao <[email-masked]>
Date: Mon, 21 Oct 2002 18:33:20 +0530

Hi Sandeep,

In section 2.1.2, in the expected message sequence, when LM sends ASP-ACTIVE
message with IID(1-5), AS1 and ASP1 go to ACTIVE state. It is mentioned
"AS1/AS2/ASP1 state is now Active". After the next message sequence AS2/ASP2
state is Active.

thanks
Sujatha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 17, 2002 8:43 PM
To: [email-masked]
Subject: [Sigtran] IUA Test Plan for ETSI PlugTest

Hi All,

Here is the first draft of IUA Test Plan for Plugtest. Please review the
same
and send me the comments.

Best Regards,
-Sandeep

(See attached file: iua_interop_plan_draft01_oct17.txt)

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Mon, 21 Oct 2002 20:11:12 +0530

Hi Sujatha ,

Consider it done.

Best Regards,
-Sandeep

Sujatha Rao <[email-masked]> on 10/21/2002 07:33:20 PM

To:   Sandeep Mahajan/HSS@HSS
cc:   [email-masked]

Subject:  RE: [Sigtran] IUA Test Plan for ETSI PlugTest

Hi Sandeep,

thanks
Sujatha

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, October 17, 2002 8:43 PM
To: [email-masked]
Subject: [Sigtran] IUA Test Plan for ETSI PlugTest

Hi All,

Best Regards,
-Sandeep

---

From: [email-masked]
Date: Mon, 21 Oct 2002 20:43:06 +0530

Hi Brian,

Please see comments inline.

Best Regards,
-Sandeep

"Brian F. G. Bidulock" <[email-masked]> on 10/21/2002 07:08:42 PM

Please respond to [email-masked]

Subject:  Re: [Sigtran] IUA Test Plan for ETSI PlugTest

Sandeep,

Sorry, I missed 2.3.1 on cursory examination.

Should not Data be transferred after the Establish Indication in test 2.3.2?
Sandeep >> OK.

Also, what is the purpose of having Unitdata in test case 2.3.2?  Unitdata
exchange should be split into
its own test case.
Sandeep >> OK.

What about negative test cases?  For example, what happens if an Establish
Confirm is sent with no outstanding Establish Request?  What happens if Data
Request is sent when no DL connection is established?
Sandeep >> As IUA does not maintain any status and only sends messages in
responses to upper layer requests, negative test cases will more or less only
test the application and not the core stack functionality. For example in case
NIF at SG asks IUA to send Establish confirm, IUA does not check if a Establish
Confirm is pending.
So basic test cases should be enough to test the inter-operability of
implementation regarding handling of messages.

--brian

[email-masked] wrote:                      (Mon, 21 Oct 2002 17:21:01)
>
>
>
> Hi Brian,
>
> Link establishment and releases is also covered in this test case 2.3.1 and
Data
> exchange is also covered in this test case (Step 2a and 2b).
> Let me know in case in case you wish to see Data Transfer being present in
some
> other test case also.
>
> Best Regards,
> -Sandeep
>
>
>
>
>
> "Brian F. G. Bidulock" <[email-masked]> on 10/19/2002 06:02:42 AM
>
> Please respond to [email-masked]
>
> Subject:  Re: [Sigtran] IUA Test Plan for ETSI PlugTest
>
>
>
>
> Sandeep,
>
> I notice that the test plan only exchanges "Unit Data" messages and
> never exchanges "Data" messages.  I'm sure this is just an oversight.
> In the test cases which "Establish" the data link there should be
> an appropriate exchange of "Data" messages.
>
> --brian
>
> [email-masked] wrote:                         (Thu, 17 Oct 2002
20:43:15)
same
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/