Subject: Re: [Sigtran] M2PA v6: Two Out of Three Valid BSN

From: [email-masked]
Date: Fri, 4 Oct 2002 11:13:12 -0400

Brian,

Please explain what you mean by "converted", and why we are talking about 
conversion.
Also, please explain why "first bad BSN" this would prevent conversion.

Barry Nagelberg

"Brian F. G. Bidulock" <[email-masked]>
Sent by: [email-masked]
 10/04/2002 11:05 AM
 Please respond to bidulock

        To:     "May, Howard" <[email-masked]>
        cc:     [email-masked]
        Subject:        Re: [Sigtran] M2PA v6: Two Out of Three Valid BSN

Howard,

Leaving it at two out of three allows an MTP2 link to be converted
directly to an M2PA link.  Please leave it at 2 out of 3.

--brian

May, Howard wrote:                                 (Fri, 04 Oct 2002 
15:13:23)
> Tolga,
> 
> I'm not quite sure I followed all your arguments but suspect we might 
have
> some level of agreement.
> 
> Would you at this stage support changing the procedure to failing the 
link
> on the first occurrence of an invalid BSN?
> 
> Regards
> 
> Howard
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Oct 2002 09:56:28 -0600

Barry,

[email-masked] wrote:                  (Fri, 04 Oct 2002 11:13:12)
> Please explain what you mean by "converted", and why we are talking about 

Taking MTP2 SUs and stuffing them directly into M2PA.  The reason for
considering conversion is to retrofit legacy SS7 equipment that only
performs traditional SS7 with MTP2-to-M2PA link converters so that
the legacy equipment can take advantage of M2PA.

> Also, please explain why "first bad BSN" this would prevent conversion.

Because the MTP2 link that is being converted generates bad BSNs as a
traditional link that can correct themselves on the next BSN.  For direct
link conversion there is no state machine to catch this (direct MTP2 to
M2PA conversion) and the MTP2 link will be seen by the legacy equipment
to fail in violation of the Q.781/ETSI 300 008-2/GR-905-CORE conformance
and validation cases.  Leaving at 2 out of 3 in the same manner as Q.703
permits conformance.

Direct conversion is preferable to cooked conversion (with a state machine)
because state machines introduce buffering and delay mid-link which violate
the propagation delay requirements for Q.703/ETSI 300 008/ANSI T1.113.

--brian