Subject: RE: [Sigtran] M2PA V6: T7

From: Tolga Asveren <[email-masked]>
Date: Mon, 7 Oct 2002 16:34:48 -0400

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, October 07, 2002 4:26 PM
> To: Tolga Asveren
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M2PA V6: T7
> 
> 
> Another thought on T7:
> 
> Consider what would happen if the receiver (for whatever reason)
> stops acknowledging messages at M2PA.  SCTP is humming along nicely,
> but the sending M2PA has messages stacking up in its retransmit
> buffer.  In this case to protect itself the sending M2PA needs to
> run a T7 timer, regardless of SCTP protocol parameter settings.
> That timer should be per-message because of the points raised at
> the onset of this thread.
[TOLGA] Why should T7 be a per message timer to handle this case? If it is
used like in MTP2(not a per message timer), in the worst case after
T7+propogation(like in MTP2 case) T7 will timeout. 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Oct 2002 14:50:53 -0600

Tolga,

What if the receiver trickles out acks instead of stopping them
altogether.

--brian

Tolga Asveren wrote:         (Mon, 07 Oct 2002 16:34:48)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/