Subject: Re: [Sigtran] m2pa v6: Recovering from a processor outage

From: [email-masked]
Date: Thu, 31 Oct 2002 17:03:43 -0500

Brian,

Multiple sufficient conditions are indicated by "or". 
Multiple necessary conditions are indicated by "and".
We cannot indicate multiple sufficient conditions by using "and". We must 
use "or".

Also, I'm not sure that I completely understand your response. Are you 
saying that the peer M2PA shall resume transmitting messages when _either_ 
it receives FLUSH_BUFFERS/CONTINUE _or_ it receives a Link Status message 
with status Processor Outage Ended?

Barry Nagelberg

"Brian F. G. Bidulock" <[email-masked]>
 10/31/2002 05:01 PM
 Please respond to bidulock

        To:     [email-masked]
        cc:     [email-masked]
        Subject:        Re: [Sigtran] m2pa v6: Recovering from a processor outage

Barry.Nagelberg,

Logically it says that it is a sufficient condition, not a necessary
condition which is quite clear.

--brian

[email-masked] wrote: (Thu, 31 Oct 2002 16:19:29)
> Brian,
> 
> I don't think that it is "normal MTP behavior" that m2pa v6 is unclear. 
I 
> am not asking what should mtp3 do. I am pointing out that there is a 
> contradiction in m2pa v6.
> 
> Section 4.2.4, by using the word "and", says that M2PA _must_ receive 
> either FLUSH_BUFFERS or CONTINUE from mtp3 before it may resume 
> transmitting data.
> 
> Section 4.1.4 suggests that traffic can resume even in the absence of 
> FLUSH_BUFFERS or CONTINUE from mtp3.
> 
> We have to resolve this contradiction.
> 
> I think that the entire existance of section 4.2.4  (Flush Buffers, 
Continue) is redundant and confusing. It is referenced by, and applicable 
to, only 
> section 4.1.4 (Processor Outage). It should simply be merged into 
section 
> 4.1.4.
> 
> Barry Nagelberg
> 
> 
> 
> 
> 
> 
> "Brian F. G. Bidulock" <[email-masked]>
>  10/31/2002 04:24 PM
>  Please respond to bidulock
> 
> 
>         To:     [email-masked]
>         cc:     [email-masked]
>         Subject:        Re: [Sigtran] m2pa v6: Recovering from a 
processor outage
> 
> 
> Barry.Nagelberg,
> 
> This is normal MTP behavior.  If processor outage has been of a short
> duration, then traffic can be immediately restarted.  If processor 
outage
> has been of a long duration, then buffers are flushed before restarting
> traffic.  MTP3 decides.  See Q.704.
> 
> ---brian
> 
> [email-masked] wrote: (Thu, 31 Oct 2002 10:07:13)
> > M2pa v6 draft is very unclear about how to recover from a processor 
> > outage. 
> > 
> > Section 4.1.4 suggests (but does not implicitly state) that once the 
PO 
> > outage ceases, the local M2PA may resume sending and receiving data 
> msgs, 
> > and that the peer M2PA may resume sending data. 
> > 
> > However, section 4.2.4 states that "If M2PA receives either a Flush 
> > Buffers or Continue command from MTP3, _and_ the processor outage 
> condition ceases, M2PA shall resume receiving and 
> > transmitting messages", meaning that either a Flush Buffers or 
Continue 
> > command is a necessary prerequisite for data traffic to restart.
> > 
> > Barry Nagelberg
> > 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 31 Oct 2002 15:36:51 -0700

Barry.Nagelberg,

If MTP3 wants to flush buffers before a processor outage condition
recovers, it does so.  If it does not, MTP2 (and M2PA) is free to
transmit buffered messsages when the remote processsor outage
condition recovers or to deliver received buffered messages when
the local processor outage condition recovers.

Thus M2PA can resume transmitting messages when it receives
FLUSH_BUFFERS/CONTINUE _and_ it receives LS processor outage ended,
and can also resume transmitting messages when it just receives
LS processor outage ended.

--brian

[email-masked] wrote:                                         (Thu, 31 Oct 2002 17:03:43)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/