Subject: AW: [Sigtran] M2PA v6: Two Out of Three Valid BSN

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Mon, 7 Oct 2002 12:53:18 +0200

Dear all,

figure 2 from the m2pa v006 draft shows what m2pa is heading for:                                                                        

    ********  SS7   ***************   IP   ********                       
    * SEP  *--------*     SG      *--------* IPSP *                       
    ********        ***************        ********                       
                                                                          
    +------+                               +------+                       
    | TCAP |                               | TCAP |                       
    +------+                               +------+                       
    | SCCP |                               | SCCP |                       
    +------+        +-------------+        +------+                       
    | MTP3 |        |    MTP3     |        | MTP3 |                       
    +------+        +------+------+        +------+                       
    | MTP2 |        | MTP2 | M2PA |        | M2PA |                       
    +------+        +------+------+        +------+                       
    | MTP1 |        | MTP1 | SCTP |        | SCTP |                       
    |      |        |      +------+        +------+                       
    |      |        |      | IP   |        | IP   |                       
    +------+        +------+------+        +------+                       
                                                                          
               Figure 2 from m2pa-06 draft

The figure below shows my understanding of "direct conversion"                                
                                                                          
    ******** SS7 ***************  IP *************** SS7 *******          
    * SEP  *-----*     SG      *-----*     SG      *----*  SEP *          
    ********     ***************     ***************    ********          
    +------+                                            +------+          
    | TCAP |                                            | TCAP |          
    +------+                                            +------+          
    | SCCP |                                            | SCCP |          
    +------+                                            +------+          
    | MTP3 |                                            | MTP3 |          
    +------+                                            +------+          
    | MTP2 |                                            | MTP2 |          
    |      |     +-------------+     +-------------+    |      |          
    |      |     |     NIF     |     |     NIF     |    |      |          
    |      |     +------+------+     +------+------+    |      |          
    |      |     |mtp2* | M2PA |     | M2PA |mtp2* |    |      |          
    +------+     +------+------+     +------+------+    +------+          
    | MTP1 |     | MTP1 | SCTP |     | SCTP | MTP1 |    | MTP1 |          
    |      |     |      +------+     +------|      |    |      |          
    |      |     |      | IP   |     | IP   |      |    |      |          
    +------+     +------+------+     +------+------+    +------+          
   mtp2*: only a very basic functionality from MTP 2                      
   NIF:   Nodal Interworking function                                     

This scenario allows to replace only some intermediate portion of the "wire" connectiong both SEP's with an IP network. Furthermore the MTP2 procedures are still e2e between both SEP's (this also includes to have the PCR method used between both SEP's). 

My summary is quite simple:
        
 That scenario is not to be considered in M2PA! 
                          
It should go in a separate I-D dealing with this "intelligent tunneling"
method, however, there are other IETF workgroups dealing already with Layer 2 Tunneling protocols and also with "Pseudo Wire Emulation Edge to Edge"  

greetings

HannsJuergen

-----Ursprüngliche Nachricht-----
Von: May, Howard [mailto:[email-masked]]
Gesendet: Montag, 7. Oktober 2002 10:57
An: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [Sigtran] M2PA v6: Two Out of Three Valid BSN

Anshoo,

Brian has suggested a requirement that would be a reason for preserving the 2/3 procedure.  My understanding is M2PA may be used not to offer MTP2 services directly to an MTP2 User but rather convert existing MTP2 messages into M2PA messages.  Preserving the  2/3 procedure supports transparent copying of the MTP2 SNs into M2PA SNs.

It is not clear to me at the moment whether this is an appropriate reason for deciding M2PA Procedures.  I am concerned that  we are introducing new requirements to M2PA that have not been considered during the rest of the design process.  Perhaps the  Authors could comment on this?

Howard

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 05 October 2002 23:00
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sigtran] M2PA v6: Two Out of Three Valid BSN
> 
> 
> Anshoo,
> 
> No.
> 
> --brian
> 
> [email-masked] wrote:                                  
>                    (Sat, 05 Oct 2002 16:26:28)
> > 
> > 
> > 
> > Hi,
> > 
> > Seems like there is an agreement on the list regarding this 
> issue now.
> > Can I safely presume that M2PA v7 would have the text for 
> sending the Link to
> > out of service whenever an out of sequence BSN is received?
> > 
> > Regards
> > Anshoo.
> > 
> > ----- Original Message -----
> > From: "Tolga Asveren" <[email-masked]>
> > To: <[email-masked]>
> > Sent: Friday, October 04, 2002 8:11 PM
> > Subject: RE: [Sigtran] M2PA v6: Two Out of Three Valid BSN
> > 
> > 
> > > Howard,
> > >
> > > > -----Original Message-----
> > > > From: May, Howard [mailto:[email-masked]]
> > > > Sent: Friday, October 04, 2002 10:13 AM
> > > > To: [email-masked]
> > > > Subject: RE: [Sigtran] M2PA v6: Two Out of Three Valid BSN
> > > >
> > > >
> > > > Tolga,
> > > >
> > > > I'm not quite sure I followed all your arguments but suspect
> > > > we might have some level of agreement.
> > > >
> > > > Would you at this stage support changing the procedure to
> > > > failing the link on the first occurrence of an invalid BSN?
> > > [TOLGA] What I explained till now is just a guess to 
> explain the reason
> > > behind that procedure in MTP2. If that is true, and if 32 
> bit checksum is
> > > good enough, I wouldn't feel uncomfortable with that change.
> > > >
> > > > Regards
> > > >
> > > > Howard
> > 
> > DISCLAIMER: This message is proprietary to Hughes Software Systems
> > Limited (HSS) and is intended solely for the use of the individual
> > to whom it is addressed. It may contain  privileged or confidential
> > information  and should not be circulated or used for any 
> purpose other
> > than for what it is intended. If you have received this 
> message in error,
> > please notify the originator immediately. If you are not 
> the intended
> > recipient, you are notified that you are strictly 
> prohibited from using,
> > copying, altering, or disclosing the contents of this 
> message. HSS accepts
> > no responsibility for loss or damage arising from the use 
> of the information
> > transmitted by this email including damage from virus.
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 7 Oct 2002 05:15:08 -0600

Hanns,

How is MTP3 in the first figure and NIF in the
second figure different?

--brian

Schwarzbauer Hanns Juergen wrote:      (Mon, 07 Oct 2002 12:53:18)