Subject: RE: [Sigtran] M2PA V6: T7

From: Tolga Asveren <[email-masked]>
Date: Fri, 4 Oct 2002 10:37:32 -0400

Brian,

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]]
> Sent: Friday, October 04, 2002 10:31 AM
> To: [email-masked]'
> Subject: RE: [Sigtran] M2PA V6: T7
> 
> 
> Brian,
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Friday, October 04, 2002 9:29 AM
> > To: Tolga Asveren
> > Cc: [email-masked]'
> > Subject: Re: [Sigtran] M2PA V6: T7
> > 
> > 
> > Tolga,
> > 
> > RTO.min does nothing to limit the maximum amount of time that SCTP
> > will wait for an acknowledgement.  I think you mean RTO.max.
> [TOLGA] Yes, you are rigth, for the calculation of the 
> maximum time, one has
> to consider RTO.max.
> > 
> > Regardless, what values of RTO.min, RTO.max, Path.MaxRetrans and
> > Association.MaxRetrans do you propose be used to effect the same
> > as T7 of, say, 1 second?
[TOLGA]Just to clarify, I wouldn't consider those values to be used to have
the same affect like T7 in MTP2, but to ensure that propogation delay is
below some value, IMO T7 is not used to monitor propogation delay for MTP2
case.
> [TOLGA] I would say  RTO.min = {A value, which is not too low for the
> underlying IP network} RTO.max = 150ms
> Path.MaxRetrans = 2   Association.MAxRetrans = 4   
> (multihoming with two IP
> addresses)
> > 
> > (Bear in mind that a successful SCTP HEARTBEAT clears the peg
> > counters and increases the delay without bound.)
> > 
> > --brian
> > 
> > Tolga Asveren wrote:                            (Fri, 04 Oct 
> > 2002 08:37:20)
> > > > 
> > > > So how do you propose to do this with SCTP?
> > > [TOLGA] With RTO.min, Path.MaxRetrans and 
> > Association.MaxRetrans. IMO, layer
> > > n+1 sets some requirements on layer n, but does not monitor 
> > it. It is every
> > > layers own responsibility, to guarantee that it meets its 
> > requirements.
> > > > 
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Oct 2002 09:00:56 -0600

Tolga,

  RTO.Max = 150 ms.
  Path.MaxRetrans = 2
  Assoc.MaxRetrans = 4

  A cosmic ray hits the receiver's hardware CRC-32 and burns a junction.
  The CRC calculation at the receive now discards every packet with a
  CRC of 0x0000ffff.  TSN 231 with a single DATA CHUNK has the fateful CRC.
  When TSN 231 is first transmitted, the sender see 4 SACKs with a gap
  report for TSN 231 and performs a fast-retransmit on the TSN.  T3-rtx
  has not expired, so Path.Max.Retrans is not pegged (neither is
  Assoc.Max.Retrans): see Section 8.2 RFC 2960.  As long as TSN 231 is
  sent without bundling, it will have the same fateful CRC.  This can
  continue ad infinitum.  No setting of RTO.Max, Path.Max.Retrans and
  Assoc.Max.Retrans can allow SCTP to guarantee that a packet will not
  be delayed beyond any given bound.

  Q.E.D.

  Therefore, M2PA needs to use T7 to guarantee same.

--brian

Tolga Asveren wrote:                                                                 (Fri, 04 Oct 2002 10:37:32)