Subject: Re: [Sigtran] M3UA Test Plan for ETSI PlugTest

From: [email-masked]
Date: Mon, 21 Oct 2002 19:36:48 +0530

Hi Brian,

Following is the scenario.
A SIGTRAN Node (ASP/SG) is handling only one network appearance and it is
connected to multiple peers. Some of these peer SIGTRAN nodes (SG/ASP) sends NA
in Data message and some does not send NA in DATA message to this node.

The expected behaviour
As NA is a optional parameter,  SIGTRAN Node serving single NA should accept
data message from peer in case a) NA is not present, b) NA is present and value
of NA is correct  c) NA is present and value of NA is incorrect.

Regarding your concern for a SIGTRAN node (ASP) accepting messages not meant for
it, the same will anyway happen for case a). I am not sure if case c) is clearly
allowed/prohibited by M3UA RFC.

Best Regards,
-Sandeep

"Brian F. G. Bidulock" <[email-masked]> on 10/19/2002 06:18:27 AM

Please respond to [email-masked]

To:   Sandeep Mahajan/HSS@HSS
cc:   [email-masked]

Subject:  Re: [Sigtran] M3UA Test Plan for ETSI PlugTest

Sandeep,

Thanks for all the test plans.   In test 3.6.1 a default NA
is sent in a DATA message and the receiver is expected to
process this without error.  Section 3.6 is listed as a level 1
section.  Where in RFC3332 does it say that the NA should be
ignored by the ASP?  Is this a good thing?  What if the SGP
starts directing the wrong traffic at the ASP?  It should ignore
NA values in DATA messages indicating that the message does not
belong to this ASP?

-brian

[email-masked] wrote:                   (Fri, 18 Oct 2002 17:50:26)
>
>
>
> Hi All,
>
> Here is the first draft of M3UA Test Plan for Plugtest. Please review the same
> and send me the comments you have.
>
> Best Regards,
> -Sandeep
>

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 21 Oct 2002 08:25:04 -0600

Sandeep,

An implementation is fully within its rights to dicard (or reply with ERR to)
messages in case (c).  The test case should not expect an ASP to accept all
such messages.

There are actually a number of different cases here (expanding on your list):

 a) NA is not present

 b) NA is present (was configured in the Sg), but the ASP has no NA configured
    for the connection

 c) NA is present (was configured in the SG) and the ASP has an NA configured
    for the connection and the NA values match.

 d) NA is present (was configured in the SG) and the ASP has an NA configured
    for the connection and the NA values don't match.

It appears that the test case expects all 4 of these cases to accept the
message, when certainly (d) demands discard or error.

--brian

[email-masked] wrote:                             (Mon, 21 Oct 2002 19:36:48)