Subject: RE: [Sigtran] M2PA V6: T7

From: Tolga Asveren <[email-masked]>
Date: Thu, 3 Oct 2002 17:45:13 -0400

Brian,
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, October 03, 2002 4:48 PM
> To: Tolga Asveren
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M2PA V6: T7
> 
> 
> Tolga,
> 
> SCTP does not (and will probably never) monitor an association for
> a fixed maximum end-to-end delay.  Therefore, M2PA must perform
> this function itself.
[TOLGA] IMO, propagation delay is important, only as long as one sends data.
And I think SCTP mechanisms like message retransmission and association
failure detection will ensure propogation delay is below certain limits and
otherwise will drop the association. One might argue, in those mechanism,
what counts is end-to-end delay for the message + end-to-end delay for the
acknowledgement of the message but it seems this is the best, which can be
done.For that reason, I don't think M2PA needs to do this check by itself.
How I see things is, for MTP2 one relies to the propogation characteristics
of the wire -no mechanism in the protocol to control it all- and for M2PA,
we rely on SCTP. 
> 
> --brian
> 
> Tolga Asveren wrote:                                    (Thu, 
> 03 Oct 2002 13:32:54)
> > Jeff,
> > 
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Thursday, October 03, 2002 1:01 PM
> > > To: [email-masked]
> > > Cc: [email-masked]
> > > Subject: Re: [Sigtran] M2PA V6: T7
> > > 
> > > 
> > > 
> > > Hello Barry,
> > > 
> > > >Or it could have been
> > > >caused by the accumulation of normal packet delays or losses 
> > > in the IP
> > > >network, which would NOT be a legitimate reason to fail the link.
> > > 
> > > A signaling link that is experiencing ACK delays of 2.7 seconds is
> > > not reliable. The reason for the ACK delay does not matter.
> > [TOLGA] It is not different from MTP2 case. One might argue 
> that propogation
> > delay is  variable for M2PA, but it is SCTPs task to 
> monitor it and if it is
> > more than a maximum, to drop the association. I don't see 
> the reason, why T7
> > should be per message for M2PA, while it is not for MTP2.
> > > The idea with
> > > T7
> > > is to distinguish a link management failure from congestion. 
> > > With excessive
> > > ACK latencies, the transmitter risks congestion.
> > > 
> > > Regards,
> > > 
> > > Jeff
> > > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 3 Oct 2002 17:44:21 -0600

Tolga,

So how do you propose to do this with SCTP?

--brian

Tolga Asveren wrote:                                                               (Thu, 03 Oct 2002 17:45:13)