Subject: [Sigtran] AS has own point code in M3UA?

From: "Insun Kwon" <[email-masked]>
Date: Wed, 23 Oct 2002 19:50:51 +0900

Hi,
 
In M3UA, 
 if SG has two AS and their Point Code is different each other,
 What does MTP3 in SG do?
 
      [ Signaling Gateway ]                          [ Application Server # 1]
 MTP3   <->   NIF    <->   M3UA     ------    M3UA   <->  MTP3-user
                                                    \
                                                      \       [ Application Server # 2]
                                                        \--    M3UA   <->  MTP3-user

 I think that Point Code is associated with MTP3.
SG has own point code, because it is a node in SS7 network and it has MTP3 stack.
But AS has no MTP3, AS's MTP3 is in SG. Is it right?
 
 then SG has three (of itself, and two AS's) Point Code?
so SG's MTP3 manages three Point Code? Is it possible? If possible, how?
Do I have to need modification of MTP3 protocol stack?
Is it possible that there is no any modification of MTP3?
 
I wonder what is proper implementation of NIF. 
 only message encap/decap?
where is the correct routing point? MTP3? NIF? M3UA?
 
 please correct my fault.
thanks.
 
 /kils
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 23 Oct 2002 05:11:20 -0600

Insun,

SG can have multiple point codes.

--brian

Insun Kwon wrote:                                                                    (Wed, 23 Oct 2002 19:50:51)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/