Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

From: [email-masked]
Date: Mon, 13 Jan 2003 11:11:13 +0200

Shrini,
I understood your statement.

The ASP that sends IIDs or doesn't, actually defines the way it likes to
receive a response. If smart ASP wants to receive ACK on per IID base it
would send IID in ASP_ACTIVE.
In many applications misconfiguration is impossible (only one ASP and
common management for ASP and SG) and then exchange of IIDs looks
redundant.
Can you describe the expected problematical scenario with sending ACK
without IID if ASP_ACTIVE came also without IID?

Regards,
Lev

                      ksrinivas                                                                                     
                      <[email-masked]         To:      [email-masked]                             
                      lcatel.com>                       cc:      [email-masked]                                   
                      Sent by:                          Subject: Re: [Sigtran] IUA -  ASP Active and ACTIVE ACK     
                      [email-masked]                                                                        

                      13/01/03 09:35                                                                                

Lev,

>>> - point 4 of you proposal may cause a problem. Suppose ASP has lost the
>>> data and likes to bring all the interfaces back to active state. It
sends
>>> the ASP_ACTIVE without IID. If SG acknowledges just previously inactive
>>> interfaces, the ASP will consider as active just these acknowledged
>>> interfaces, and as inactive all interfaces that already active in SG.
This
>>> is a deadlock.

      Why does SG acknowledges just previously inactive interfaces only?
IMO, it should acknowledge with
all the IIDs that are currently active at the SG, only if the list is
partial. Otherwise, if all the
configured IIDs are Active at the SG, the SG should acknowledge without any
IIDs(meaning, all the IIDs are
Active).

--Srini

[email-masked] wrote:

> Shrini,
>
> - point 4 of you proposal may cause a problem. Suppose ASP has lost the
> data and likes to bring all the interfaces back to active state. It sends
> the ASP_ACTIVE without IID. If SG acknowledges just previously inactive
> interfaces, the ASP will consider as active just these acknowledged
> interfaces, and as inactive all interfaces that already active in SG.
This
> is a deadlock.
> - see IUA implementation guide for point 5 of your proposal
>
> I do not see a reason to change the RFC in this aspect.
>
> Regards,
> Lev
>
>
>                       "Brian F. G.
>                       Bidulock"                To:      ksrinivas
<[email-masked]>
>                       <bidulock@openss         cc:      Latha
<[email-masked]>, [email-masked]
>                       7.org>                   Subject: Re: [Sigtran] IUA
-  ASP Active and ACTIVE ACK
>                       Sent by:
>                       sigtran-admin@ie
>                       tf.org
>
>
>                       13/01/03 07:50
>                       Please respond
>                       to bidulock
>
>
>
> ksrinivas,
>
> Your proposal represents a deviation from the RFC that I do not agree
with.
> The current RFC does not permit the SG to perform a "partial activation"
of
> some IIDs in a set.  Both in the ASPAC and ASPAC Ack, a subset of IIDs
> represents the entire set of IIDs indicated by that subset.
>
> --brian
>
> ksrinivas wrote:
> (Mon, 13 Jan 2003 11:05:43)
> >
> >    IMO, the Active and Active Ack procedures should be as follows:
> >
> >    1. ASP can send Active msg with or without IIDs.
> >    2.  ASP  shall  never  send  multiple concurrent ASPACs as there is
no
> >    correlation identifier.
> >    3.  The ASP should be smart enough to remember whether it has sent
any
> >    IIDs in the Active message.
> >    4. If ASP sends Active without IIDs,
> >           the  SGP  shall respond with Active Ack without IIDs, if the
SG
> >    activates  all  the  IIDs. Also, the SGP shall respond with Active
Ack
> >    with IIDs only that are activated.
> >    5. If ASP sends Active with IIDs,
> >           the  SGP  shall respond with Active Ack with IIDs only that
are
> >    activated.  Also,  the SGP shall respond with Active Ack without
IIDs,
> >    if the SG refuses to activate all the IIDs.
> >
> >    --Srini
> >
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 17:06:36 +0530

Lev,

>> without IID if ASP_ACTIVE came also without IID?

There is no problem at all. If SG sends an Ack without any IIDs as a response to ASPAC without IIDs from ASP, then
all the IIDs are treated to be activated. This is as per my point# 4 below.

--Srini