Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

From: [email-masked]
Date: Mon, 13 Jan 2003 09:13:32 +0200

Shrini,

- point 4 of you proposal may cause a problem. Suppose ASP has lost the
data and likes to bring all the interfaces back to active state. It sends
the ASP_ACTIVE without IID. If SG acknowledges just previously inactive
interfaces, the ASP will consider as active just these acknowledged
interfaces, and as inactive all interfaces that already active in SG. This
is a deadlock.
- see IUA implementation guide for point 5 of your proposal

I do not see a reason to change the RFC in this aspect.

Regards,
Lev

                      "Brian F. G.                                                                         
                      Bidulock"                To:      ksrinivas <[email-masked]>     
                      <bidulock@openss         cc:      Latha <[email-masked]>, [email-masked]          
                      7.org>                   Subject: Re: [Sigtran] IUA -  ASP Active and ACTIVE ACK     
                      Sent by:                                                                             
                      sigtran-admin@ie                                                                     
                      tf.org                                                                               

                      13/01/03 07:50                                                                       
                      Please respond                                                                       
                      to bidulock                                                                          

ksrinivas,

Your proposal represents a deviation from the RFC that I do not agree with.
The current RFC does not permit the SG to perform a "partial activation" of
some IIDs in a set.  Both in the ASPAC and ASPAC Ack, a subset of IIDs
represents the entire set of IIDs indicated by that subset.

--brian

ksrinivas wrote:
(Mon, 13 Jan 2003 11:05:43)
>
>    IMO, the Active and Active Ack procedures should be as follows:
>
>    1. ASP can send Active msg with or without IIDs.
>    2.  ASP  shall  never  send  multiple concurrent ASPACs as there is no
>    correlation identifier.
>    3.  The ASP should be smart enough to remember whether it has sent any
>    IIDs in the Active message.
>    4. If ASP sends Active without IIDs,
>           the  SGP  shall respond with Active Ack without IIDs, if the SG
>    activates  all  the  IIDs. Also, the SGP shall respond with Active Ack
>    with IIDs only that are activated.
>    5. If ASP sends Active with IIDs,
>           the  SGP  shall respond with Active Ack with IIDs only that are
>    activated.  Also,  the SGP shall respond with Active Ack without IIDs,
>    if the SG refuses to activate all the IIDs.
>
>    --Srini
>

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 13:05:20 +0530

Lev,

>>> interfaces, and as inactive all interfaces that already active in SG. This

      Why does SG acknowledges just previously inactive interfaces only? IMO, it should acknowledge with
all the IIDs that are currently active at the SG, only if the list is partial. Otherwise, if all the
configured IIDs are Active at the SG, the SG should acknowledge without any IIDs(meaning, all the IIDs are
Active).

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 01:27:08 -0700

ksrinivas,

Section 3.3.2.5:

"   If no Interface Identifiers are included, the message is for all
"   provisioned Interface Identifiers within the AS(s) in which the ASP
"   is provisioned.  If only a subset of Interface Identifiers are
"   included, the ASP is noted as Active for all the Interface
"   Identifiers provisioned for that AS.

A subset of IIDs merely identifies an AS, for which the AS is activated.
SGs do not activate IIDs, they activate Application Servers.  Application
Servers can consist of one or more IIDs, however, the entiere AS is either
active or inactive.

--brian

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 13:05:20)