Subject: [Sigtran] M3UA Routing Keys partial match

From: ksrinivas <[email-masked]>
Date: Thu, 23 Jan 2003 17:07:16 +0530

Brian,

  Let us assume that the following two RKs are registered with an SGP

  REG REQ (RK1, DPC X, SI = Y)
  REG REQ (RK2, DPC X, SI = Z)

and from SS7 network, say a MSU with DPC X and SI = Z is received.

When M3UA at SGP tries to match DPC X and SI = Z with the first(DPC X,
SI = Y) Routing Key, Does it not treat it as a partial match?.(as DPC
matches).

--Srini

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Jan 2003 05:11:25 -0700

Srini,

Here are the two same routing keys:

  RK1, OPC * DPC X SI Y
  RK1, OPC * DPC X SI Z

A message arrives with OPC A and DPC Q and SI W.  Does it not
partially match the first routing key because OPC A matches
the wildcard on OPC?

No.  When the RFC say partial match it is referring to the
message OPC A, DPC X, SI Y having a partial match to RK1.
(It does not match in OPC because OPC is "wildcarded".)

--brian

ksrinivas wrote:                                                                 (Thu, 23 Jan 2003 17:07:16)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Fri, 24 Jan 2003 10:01:20 +0530

Brian,

What about the following routing keys? Are they valid?

RK1, DPC X
RK2, DPC X, SIO Y
RK3, DPC X, SIO Y, OPC A
RK4, DPC X, SIO Y, OPC B
RK5, DPC X, SIO Y, OPC *

thanks
Chak

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Jan 2003 22:10:58 -0700

PSK,

Depends on the SG.

--brian

PSK Chakravarthi wrote:                                                                (Fri, 24 Jan 2003 10:01:20)

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Fri, 24 Jan 2003 11:33:23 +0530

Brian,

Why I asked is, MSU with DPC X, SIO Y, OPC A will give three full matches,
RK1, RK3 and RK5.  As per RFC we should design RKs such that we will get
only one full/partial match.

[Section 1.4.2.2 says
   Routing Keys SHOULD be unique in the sense that each received SS7
   signalling message SHOULD have a full or partial match to a single
   routing result.]

Similarly when we receive an MSU with DPC X, SIO Y we will have two full
matches, RK1 and RK2. We can derive many cases which will give more than one
full match.  To which AS SGP will route when it finds more than one full
match in the routing key list.

IMO, Routing keys should be designed in such a manner that there will be
only one full match.

I am not getting what is a partial match. Can you please explain what is a
partial match with an example?

thanks
Chak

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 23 Jan 2003 23:20:57 -0700

PSK,

PSK Chakravarthi wrote:                                                                (Fri, 24 Jan 2003 11:33:23)
> only one full/partial match.

One could think of RK5 as a partial match.

One could also think of RK5 as an overlapping routing key with RK3 and RK4
which does not have to be permitted by an SG.

> match in the routing key list.

Again, that sounds like a partial match to me.

> IMO, Routing keys should be designed in such a manner that there will be

What about RK: DPC X OPC A SIO 4 SSN 3?

There can be partial matches here for messages that do not contain SSN.

> partial match with an example?

It is the responsibility of the SG to refuse routing keys that it feels
are "overlapping" in the sense that multiple matches are possible.

--brian

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Fri, 24 Jan 2003 13:51:12 +0530

Brian,

 > There can be partial matches here for messages that do not contain SSN.

Why you are giving an example with SSN?  This is not possible with M3UA.

Anyway as per RFC if the search results only in a partial match then the
message will be routed to default ASP.

There can be many partial matches but search should yield a single full
match unless the overlapping routing keys are permitted.

thanks
Chak

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "PSK Chakravarthi" <[email-masked]>
Cc: "ksrinivas" <[email-masked]>; <[email-masked]>
Sent: Friday, January 24, 2003 11:50 AM
Subject: Re: [Sigtran] Re: M3UA Routing Keys partial match

> > > > > >   Let us assume that the following two RKs are registered with
an
> > SGP
> > > > > > When M3UA at SGP tries to match DPC X and SI = Z with the
first(DPC
> > X,
> > > > > > SI = Y) Routing Key, Does it not treat it as a partial
match?.(as
> > DPC

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 24 Jan 2003 14:24:20 -0700

PSK,

PSK Chakravarthi wrote:                                                                (Fri, 24 Jan 2003 13:51:12)
> Why you are giving an example with SSN?  This is not possible with M3UA.

It is as the RFC stands.

> match unless the overlapping routing keys are permitted.

Have you answered your own question?

--brian

---

From: ksrinivas <[email-masked]>
Date: Mon, 27 Jan 2003 09:29:58 +0530

Brian,

     If a message arrives with OPC A and DPC X and SI W for the Routing Keys you have mentioned, Does it not
partially match with both the Routing Keys?. (Assuming that hierarchical RKs are not allowed by the SGP).

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 26 Jan 2003 22:05:31 -0700

Srini,

No, SI W does not match at all.

--brian

ksrinivas wrote:                                                                 (Mon, 27 Jan 2003 09:29:58)

---

From: ksrinivas <[email-masked]>
Date: Mon, 27 Jan 2003 11:47:18 +0530

Brian,

     If a message arrives with OPC A and DPC X and SI W for the Routing Keys
you have mentioned, Does it not partially match with both the Routing Keys?. (Assuming that hierarchical RKs are
not allowed by the SGP).

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 26 Jan 2003 23:21:42 -0700

Srini,

It is is a mismatch because W != Y && W != Z.

--brian

ksrinivas wrote:                                                                 (Mon, 27 Jan 2003 11:47:18)

---

From: ksrinivas <[email-masked]>
Date: Mon, 27 Jan 2003 14:06:52 +0530

Brian,

    But the DPC X matches. Is it not a partial match?. If not, What is a partial match?.

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 Jan 2003 01:39:44 -0700

Srini,

RK SSN = 5, Message with no SSN.

IMO, that's a partial match.

If one removes SSN from RK, one can remove the words "partial match".

--brian

ksrinivas wrote:                                                                 (Mon, 27 Jan 2003 14:06:52)

---

From: ksrinivas <[email-masked]>
Date: Mon, 27 Jan 2003 14:17:34 +0530

Brian,

   How is it different from partial match?.

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 Jan 2003 02:00:57 -0700

Srini,

Because it is a mismatch.  A partial match matches on
the information available in the message but the routing
key has fields not specified in the message.  The only
case of this is SSN or TID.

--brian

ksrinivas wrote:                                                                 (Mon, 27 Jan 2003 14:17:34)

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Mon, 27 Jan 2003 14:39:46 +0530

Brian,

Thanks, now I got what is a partial match.
What about default ASP?  This was introduced for supporting partial RKs.

Thanks
Chak

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "ksrinivas" <[email-masked]>
Cc: <[email-masked]>
Sent: Monday, January 27, 2003 2:09 PM
Subject: [Sigtran] Re: M3UA Routing Keys partial match

> > > >      If a message arrives with OPC A and DPC X and SI W for the
Routing Keys you have mentioned, Does it not
> > > > partially match with both the Routing Keys?. (Assuming that
hierarchical RKs are not allowed by the SGP).
> > > > > >   Let us assume that the following two RKs are registered with
an SGP
> > > > > > When M3UA at SGP tries to match DPC X and SI = Z with the
first(DPC X,
> > > > > > SI = Y) Routing Key, Does it not treat it as a partial
match?.(as DPC

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 27 Jan 2003 02:11:05 -0700

Chak,

Default ASP is primarily for if there is no match.

--brian

PSK Chakravarthi wrote:                                                                (Mon, 27 Jan 2003 14:39:46)