Subject: Re: [Sigtran] m3ua- IG

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 10 Jan 2003 15:32:07 +0200

Brian,
--- "Brian F. G. Bidulock" <[email-masked]> wrote:
> TOLGA,
>
> TOLGA ASVEREN wrote:
>                                 (Fri, 10 Jan 2003
> 15:05:08)
> >
> > Brian,
> > --- "Brian F. G. Bidulock" <[email-masked]>
> wrote:
> > > TOLGA,
> > >
> > > TOLGA ASVEREN wrote:
> > >                                 (Fri, 10 Jan
> 2003
> > > 14:26:46)
> > > >
> > > > Brian,
> > > >
> > > > Again the last message from me on this thread,
> > > because I think I already
> > > > started repeating the same things.
> > > >
> > > > Please find the comments are below.
> > > >
> > > >    Tolga
> > > > --- "Brian F. G. Bidulock"
> <[email-masked]>
> > > wrote:
> > > > > TOLGA,
> > > > >
> > > > > TOLGA ASVEREN wrote:
> > > > >                                 (Fri, 10 Jan
> > > 2003
> > > > > 13:51:14)
> > > > > >
> > > > > > Samuel,
> > > > > >
> > > > > > The point is, no special management logic
> > > should
> > > > > be necessary on ASP.
> > > > >
> > > > > The point is special management logic is
> > > required on
> > > > > the ASP so that
> > > > > it can know where and when it is receiving
> SCCP
> > > > > management messages.
> > > > [TOLGA] No, this is not necesary.
> > >
> > > It is necessary so that the ASP can route the
> SCCP
> > > management
> > > messages to the correct SCCP user.
> > [TOLGA] M3UA-ASP routes the messages based on RC.
> So, each message will be
> > sent to the entity serving the AS corresponding to
> RC in the message.
> > M3UA-ASP does not need to know -and it does not
> know- that inside DATA
> > there is a SCCP management message. SG takes care
> of everything.
>
> The SG does not send messages to SCCP users.  How
> will the ASP get the
> management messages get to the SCCP user?
[TOLGA] This is responsibility of SCCP. M3UA-ASP will just delşver the
messages to the corresponding entity, taking care of traffic for the AS,
corresponding to RC in the message.
>
> > >
> > > > >
> > > > > > The ASP is just any M3UA compliant ASP,
> > > nothing
> > > > > special there.
> > > > >
> > > > > It is a VERY special ASP.  It's M3UA knows
> about
> > > > > SCCP mangement messages
> > > > > and knows where the particular SG is going
> to
> > > place
> > > > > them, whether it needs
> > > > > to register for an AS with SSN=0, whether it
> > > needs
> > > > > to only act as a default
> > > > > ASP, whether it can expect management
> messages
> > > on
> > > > > each AS corresponding to
> > > > > a subsystem, in fact it needs to know that
> the
> > > SG is
> > > > > performing SSN routing
> > > > > at all (which is not supported by dynamic
> > > > > registration).
> > > > [TOLGA] I think soon you will ask for an ASP,
> > > which can work with any SG
> > > > with no configuration at all. Of course it
> needs
> > > to know, which SG it needs
> > > > to connect for a specific RK in case of static
> > > configurations. Afterall,
> > > > RKs need to be agreed by both sides through
> > > configuration. I think, it is
> > > > the normal operation that each AS gets the
> > > messages, it needs to get
> > > > -including management messages-. But if you
> think
> > > it as necessary, then
> > > > just a few sentences might be added to IG.
> > >
> > > M3UA RFC covers SSNM.  It does not cover SCCP
> > > management messages.
> > [TOLGA] It covers SSNM because it is a MTP3/MTP3
> User interface. SCCP
> > management message are encapsulated in DATA.
>
> M3UA RFC also covers the treatment of DATA.  DATA is
> never sent
> to more than one ASP except in a broadcast mode AS.
> It looks like
> your suggestion (sending SCCP management messages to
> multiple ASPs
> in DATA) is not compliant with the M3UA RFC.
> Valerie's and Joe's
> are compliant.
[TOLGA] I consider it ot as the same DATA replicated to multiple
destinations but as a SCCP management message replicated by the management
functionality on SG. But still I proposed in my former message a new
sentence to clarify this. I think it should be enough to address your this
concern.
>
> > >
> > > If you want to add text to M3UA to allow it to
> > > support SSN routing,
> > > do so.  My point has always been that it does
> not
> > > support SSN routing
> > > as it stands.  What is your proposed text?
> > [TOLGA] 1.4.2.2
> > "For RK types, which are not based on
> MTP3/MTP3-User Interface
> > constructs(DPC, SI) some management functionality
> might be necessary. This
> > functionality should be implemented on SG and is
> implementation dependent.
> > It should be taken care of, that no special
> behavior from the peer is
> > expected.
>
> This does not tell ASP how to expect SCCP management
> (or messages
> not containing SSN) to be kouted differently than
> SCCP messages.
> You proposed text is not a basis for
> interoperability at all.
[TOLGA] ASP does not need to know/care what is going on with SCCP. It just
cares about RC in the message and delivers it to the corresponding user
based on that.
>
> > >
> > > > >
> > > > > > BTW, does M3UA RFC tell to support any
> > > specific RK
> > > > > type? For example if a SG
> > > > > > supports only DPC based RKs, will it be
> > > compliant
> > > > > or not with RFC?  I think
> > > > > > it is totally dependent on the
> implementor,
> > > which
> > > > > types of RKs her/his SG is
> > > > > > going to support.
> > > > >

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 06:39:27 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Fri, 10 Jan 2003 15:32:07)
> [TOLGA] This is responsibility of SCCP. M3UA-ASP will just delºver the

But the only reason for using SSN RK is because SCCP is partitioned
over multiple ASPs.  How can ASP get SCCP management messagess to
the correct SCCP user without knowing where they appear?

> sentence to clarify this. I think it should be enough to address your this

No it is not.  You must say which messages are to be duplicated,
how, and to which ASPs in which AS.

> cares about RC in the message and delivers it to the corresponding user

If that were the case, there would be no need for RK on SSN in the first
place.  It is only by nature of the fact that SCCP users could be split
over ASPs that the RK would be necessary at all.  So, the ASP needs to
know/care what is going on with SCCP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/