Subject: RE: [Sigtran] m3ua- IG

From: "Wung, Joseph" <[email-masked]>
Date: Fri, 10 Jan 2003 14:16:32 -0500

Brian,
Tolga,

I agree that interoperability is not just the 
syntax of messages being exchanged between peers.
It is also about the procedures being executed
by the peers.  If it is implementation dependent,
vendor SG-A can implement in the method A, and
vendor SG-B in method B, the question is that can 
the ASP switch vendor from A to B without 
any changes on ASP?  If changes are needed when 
switching vendors occurs, then there is no 
interoperability.

Joe

> 
> Which standard M3UA ASP?  Yours?
> Valeries?  Joes?  Several? All?
> 
> You cannot acheive interoperability in
> this regard without both the SG and the
> ASP knowing which procedures are used.
> 
> Therefore, you cannot (as you said
> previously) just implement SSN RK on the
> SG without the ASP knowing how it is done.
> 
> Is there anyone else on the list that
> thinks this is basis for interoperability?
> 
> --brian
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Sat, 11 Jan 2003 05:09:54 -0800 (PST)

Joe,
> switching vendors occurs, then there is no 
[TOLGA] I also agree with your understanding of
interoperability but if one does not break
interoperability one should be free to do anything.
This is what I mean with a implementation dependent
management functionality, which does not break
interoperability.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 11 Jan 2003 06:14:59 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Sat, 11 Jan 2003 05:09:54)
> management functionality, which does not break

Such an implementation does not exist for either
SSN or CIC routing keys.

--brian

---

From: Tolga Asveren <[email-masked]>
Date: Sat, 11 Jan 2003 05:30:36 -0800 (PST)

Brian,
--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
> Tolga Asveren wrote:                                
>                                 (Sat, 11 Jan 2003
> 05:09:54)
[TOLGA] IMO, the SSN method discussed ont he list is O.K.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 11 Jan 2003 07:11:55 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Sat, 11 Jan 2003 05:30:36)
> [TOLGA] IMO, the SSN method discussed ont he list is O.K.

Its broken as already demonstrated.

--brian