Subject: [Sigtran] IUA - ASP Active and ACTIVE ACK

From: Latha <[email-masked]>
Date: Fri, 10 Jan 2003 13:17:33 +0530

Hi,
we have a doubt regarding the IIDs exchanged in the ASP Active and
ASP ACTIVE ACK 
If ASP Active is sent with a specific IId/IIds, is it mandatory for the SGF
to send ASP Active Ack with the specified IId/IIds. 
 
Or can it send the Ack without any IId. If that is the case then ASP has to
maintain the list of IIds on which the Active is sent. 
Also what should the action on MGC side if it receives ASP Active Ack
without any IId as a response for ASP Active sent with a specific IId/IIds.
thanks
latha

> -----Original Message-----
> From: TOLGA ASVEREN [mailto:[email-masked]]
> Sent: Friday, January 10, 2003 1:05 PM
> To: [email-masked]
> Subject: Re: [Sigtran] m3ua- IG
> 
> 
> 
> Samuel,
> 
> An implementation dependent management functionality, which 
> is implemented
> without bringing any interoperability problems can decide for 
> the status of
> subsystems. How this funtionality can be implemented is 
> beyond the scope of
> M3UA IMO.
> 
> RK types are flexible means, type of RKs is not limited by M3UA RFC.
> 
>       Tolga
> 
> 
> 
> 
> 
>              Tolga,
> 
>              It means peer M3UA can not recognize whether SSN 
> is available
>              or congested
>              or unavailable...
> 
>              what do you mean by saying "... RK types flexible..."
> 
> 
> 
> 
>         --Samuel
> 
>           Alcatel USA, Inc.                  Internet: <userid>
>         @ssd.usa.alcatel.com
>           1000 Coit Road, Plano, Texas 75075
>           ******* The opinions expressed are not those of 
> Alcatel USA, Inc.
>         *******
> 
>         On Fri, 10 Jan 2003, TOLGA ASVEREN wrote:
> 
>         >
>         > Samuel,
>         >
>         > What does it mean exactly that M3UA supports this 
> or that RK? One
>         can argue
>         > about how suitable it is to use a certain RK type 
> with M3UA but
>         this IMO is
>         > a different thing. I think the best is to leave RK 
> types flexible
>         and maybe
>         > with one sentence to warn people about non-MTP3 RK 
> types, that
>         those might
>         > need some management functionalitiy on SG.
>         >
>         >         Tolga
>         >
>         >
>         >
>         >      I think it would be good if we remove all 
> SSN(sub system
>         number)
>         >      references from RFC or make a global statement 
> in IG as "SSN
>         will not
>         >      be
>         >      supported by RFC 3332 and wherever it is being 
> referred it
>         should be
>         >      ignored"
>         >
>         >      --Samuel
>         >
>         >        Alcatel USA, Inc.                  Internet: <userid>
>         >      @ssd.usa.alcatel.com
>         >        1000 Coit Road, Plano, Texas 75075
>         >        ******* The opinions expressed are not those 
> of Alcatel
>         USA, Inc.
>         >      *******
>         >
>         >
>         >      _______________________________________________
>         >      Sigtran mailing list
>         >      [email-masked]
>         >      https://www1.ietf.org/mailman/listinfo/sigtran
>         >
>         >
>         >
>         >
>         > _______________________________________________
>         > Sigtran mailing list
>         > [email-masked]
>         > https://www1.ietf.org/mailman/listinfo/sigtran
>         >
> 
> 
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 01:08:50 -0700

Latha,

Latha wrote:                                                                         (Fri, 10 Jan 2003 13:17:33)
> without any IId as a response for ASP Active sent with a specific IId/IIds.
Then the ASP could hardly be expected to correlate multiple ASPAC ACK
responses to multiple ASPAC requests.  If IID is placed in ASPAC, then
the SG MUST respond with IID in ASPAC ACK to be sure that the ASP can
correlate the response with the request.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 09:40:02 +0530

Brian,

>>> correlate the response with the request.

If SG is not Active for any of the IIDs received in ASPAC, then how will the SG respond with any IID. Moreover,
since IIDs are a MUST in ASPAC ACK when IIDs are placed in ASPAC, then IIDs in ASPAC ACK should have been
semi-optional.

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 12 Jan 2003 21:38:35 -0700

ksrinivas,

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 09:40:02)
> If SG is not Active for any of the IIDs received in ASPAC, then how
> will the SG respond with any IID.

ERR("Invalid Interface Identifier") containing the IIDs in the ASPAC
for which the SG refuses to activate.

> Moreover, since IIDs are a MUST in ASPAC ACK when IIDs are placed in
> ASPAC, then IIDs in ASPAC ACK should have been semi-optional.

IID is optional in ASPAC Ack.  The smart SG implementation will 
included the interface identifiers in the ASPAC Ack when they were
provided in the ASPAC, whether it is required with a MUST or not.

SGs that don't do so will not support multiple outstanding ASPAC
messages very well (because the ASP cannot necessarily correlate
the ASPAC Acks with the ASPACs).  But there is no requirement for
an ASP to send multiple concurrent ASPACs.  In fact, it is possible
to perform multiple activations in a single ASPAC, so that is not
som much of a limitation.

So the SG implementation would be smart to always put IID in ASPAC Ack
when it was included in ASPAC, and the ASP would be smart to never
send multiple concurrent ASPACs requiring correlation of the
subsequently received ASPAC Acks.

Perhaps it would be a good idea to mention the above in the IUA-IG.

--brian

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 11:05:43 +0530

> for which the SG refuses to activate.

RFC 3057 says,

The "Invalid Interface Identifier" error would be sent by a SG if an ASP sends a message with an invalid (unconfigured)
Interface Identifier value.

So, what the SG refuses to activate be treated as unconfigured?. The "Invalid Interface Identifier" error might mean a
different thing at the ASP.(i.e., IIDs configured at SG and ASP are inconsistent).

IMO, the Active and Active Ack procedures should be as follows:

1. ASP can send Active msg with or without IIDs.
2. ASP shall never send multiple concurrent ASPACs as there is no correlation identifier.
3. The ASP should be smart enough to remember whether it has sent any IIDs in the Active message.
4. If ASP sends Active without IIDs,
      the SGP shall respond with Active Ack without IIDs, if the SG activates all the IIDs. Also, the SGP shall respond
with Active Ack with IIDs only that are activated.
5. If ASP sends Active with IIDs,
      the SGP shall respond with Active Ack with IIDs only that are activated. Also, the SGP shall respond with Active
Ack without IIDs, if the SG refuses to activate all the IIDs.

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 12 Jan 2003 22:50:30 -0700

ksrinivas,

Your proposal represents a deviation from the RFC that I do not agree with.
The current RFC does not permit the SG to perform a "partial activation" of
some IIDs in a set.  Both in the ASPAC and ASPAC Ack, a subset of IIDs
represents the entire set of IIDs indicated by that subset.

--brian

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 11:05:43)
>           the  SGP  shall respond with Active Ack without IIDs, if the SG
>    activates  all  the  IIDs. Also, the SGP shall respond with Active Ack
>    with IIDs only that are activated.
>           the  SGP  shall respond with Active Ack with IIDs only that are
>    activated.  Also,  the SGP shall respond with Active Ack without IIDs,
>    if the SG refuses to activate all the IIDs.
> 
>    --Srini
>

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 12:16:08 +0530

Brian,

     If more than one subset of IIDs are sent in ASP AC to SG, still the SG may wish to activate only a few
subsets fully.

--Sini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sun, 12 Jan 2003 23:50:04 -0700

ksrinivas,

But that is currently not supported.

--brian

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 12:16:08)

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 12:24:50 +0530

Brian,

    If SG has to send the same set of IIDs back to the ASP in an ASPAC Ack, the need for IIDs in ASPAC Ack is
insignificant.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 00:22:19 -0700

ksrinivas,

But it doesn't have to: IIDs in ASPAC Ack is optional in the RFC.

--brian

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 12:24:50)

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 13:24:25 +0530

Brian,

     My meaning of "IIDs in ASPAC Ack is insignificant" is not that IIDs are optional or mandatory. IIDs serve no
purpose in the ASPAC Ack as per this thread.

--Srini.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 01:17:51 -0700

ksrinivas,

Well, they can be used by the ASP to correlate the received
ASPAC Ack with the sent ASPAC: which is not insignificant.

--brian

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 13:24:25)

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Mon, 13 Jan 2003 14:01:09 +0530

Brian,

Consider the following case:

1. ASP sends ASPAC for IIDS 1 to 10.
2. Due to some reason SG can bring up only IIDS 1 to 5.
3. Now, what does SG send in the ASPAC Ack? (w.r.t IIDS)

thanks
Chak

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "ksrinivas" <[email-masked]>
Cc: "Latha" <[email-masked]>; <[email-masked]>
Sent: Monday, January 13, 2003 1:47 PM
Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

> > > >     If SG has to send the same set of IIDs back to the ASP in an
ASPAC Ack, the need for IIDs in ASPAC Ack is
> > > > > >    2.  ASP  shall  never  send  multiple concurrent ASPACs as
there is no
> > > > > >    correlation identifier.
> > > > > >    3.  The ASP should be smart enough to remember whether it has
sent any
> > > > > >    IIDs in the Active message.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 01:44:18 -0700

Chak,

In your example, how are the IIDs configured
into Application Servers at the SG?

--brian

PSK Chakravarthi wrote:                                                                (Mon, 13 Jan 2003 14:01:09)

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Mon, 13 Jan 2003 14:23:54 +0530

Brian,

All the IIDS are configured to one AS.

Thanks
Chak
----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "PSK Chakravarthi" <[email-masked]>
Cc: "ksrinivas" <[email-masked]>; "Latha"
<[email-masked]>; <[email-masked]>
Sent: Monday, January 13, 2003 2:14 PM
Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 02:10:37 -0700

Chak,

Then,

1. ASP sending ASPAC for IIDs 1 to 10, per the description under ASPAC
   is a request to configure all IIDs provisioned for the one big AS.

2. If there are no other AS configured, sending ASPAC without IIDs and
   ASPAC with IIDs 1 to 10 is no different.

To answer your question, answer this one:

If the SG manages to activate all the IIDs, and then, just after sending
ASPAC Ack, IIDs 6-10 fail, what does the SG send to the ASP?

IMO, the answer to the question above is the answer to your question below.
That is, the SG should treat it as though the failure was just after the
AS was activated, return ASPAC Ack, and then send the messages to treat
the failure.

--brian

PSK Chakravarthi wrote:                                                                (Mon, 13 Jan 2003 14:23:54)

---

From: "PSK Chakravarthi" <[email-masked]>
Date: Mon, 13 Jan 2003 17:32:13 +0530

Brian,

> AS was activated, return ASPAC Ack, and then send the messages to treat

How does SG indicate ASP that IIDS are failed?

Is there any message which can be sent from SG to ASP, to indicate IIDS are
failed before Establish request for an IID from ASP?

Thanks
Chak

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "PSK Chakravarthi" <[email-masked]>
Cc: "ksrinivas" <[email-masked]>; "Latha"
<[email-masked]>; <[email-masked]>
Sent: Monday, January 13, 2003 2:40 PM
Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 05:15:55 -0700

PSK,

The point is that IIDs can't fail.  They can only be configured or
unconfigured.  The physical layer upon which the data link is
established can fail, but that is addressed with Release Indication/
Confirmation on an active IID in an AS.

If your phsyical layer fails, send Release Indication with cause
indicating phsyical layer failure to all establsihed signalling
connections: the IID stays active until the ASP sends ASPIA or
ASPDN or the SCTP association is lost.

--brian

PSK Chakravarthi wrote:                                                                (Mon, 13 Jan 2003 17:32:13)