Subject: Re: [Sigtran] I-D ACTION:draft-ietf-sigtran-m3ua-implementors-guide-02.txt

From: Ken Morneault <[email-masked]>
Date: Thu, 02 Jan 2003 09:05:39 -0500

Brian,

Please address your concerns to the entire group as your proposed
change is something for all to discuss.

Regards,

Ken

At 06:21 PM 12/31/2002 -0700, Brian F. G. Bidulock wrote:
>Ken,
>
>Section 3.2.
>
>What does it matter if the SGP sends "Unsupported Message Type" or
>"Unsupported Message Class"?  Acutally, if we ever add a message to the class,
>"Unsupport Message Class" might no longer be correct, whereas "Unsupported
>Message Type" survives the addition of new message types to the class.
>
>Also, as the only necessary piece of information given in the Error message
>is the Message Class and Type, why force an implementation to include the
>first 40 bytes of the message?  That's ridiculous.  All that needs to be
>included a couple bytes of the message header.
>
>Also, there is no more need to correlate this error than others.  The
>ASP is obviously misconfigured (it figures it can register with an SGP
>that does not even supoprt registration), so it really doesn't matter
>what happens to it: there are many ways to misconfigure an ASP so that
>it will not be caught by the protocol.
>
>Please strike section 3.2.
>
>Also note that M2UA and SUA also use the same text.  It makes no sense to
>have M3UA act differently in this regard than M2UA and SUA.
>
>--brian
>
>-- 
>Brian F. G. Bidulock
>[email-masked]
>http://www.openss7.org/
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 07:30:43 -0700

Ken Morneault wrote:                             (Thu, 02 Jan 2003 09:05:39)
> change is something for all to discuss.

SIGTRAN,

Section 3.2.

--brian