Subject: Re: [Sigtran] m3ua- IG

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 10 Jan 2003 11:52:00 +0200

Samuel,
--- "Samuel Dur D. Jeyaseelan" <[email-masked]> wrote:
>
> Tolga,
>
> Agreed.Using flexible RK we support SSN.But How do
> you handle SSN
> congested, SSN unavailable and SSN available ?
> What M3UA message carries these information from ASP
> to SG?
> If you say 'DATA' then what is the need of SUA?
[TOLGA] Management logic in SG can decide for SSN status based on received
DATA and on AS status. In fact also for MTP3 based RK types, it is not a
special management message but the AS state, which helps SG to build the
combined SPMC state. But becase SSN is not a MTP3 based RK, also SCCP
management messages in DATA should be handled properly.

For your final question I guess:
SUA handles SSN based RKs more elegantly and I believe people had in mind
to use it between mobile network nodes in a peer to peer fashion (but last
time I checked 3GPP core network was still preferring M3UA), with one layer
less and possibly by addressing nodes with IP addresses.
>
> --Samuel
>
>
>   Alcatel USA, Inc.                  Internet:
> <userid>@ssd.usa.alcatel.com
>   1000 Coit Road, Plano, Texas 75075
>   ******* The opinions expressed are not those of
> Alcatel USA, Inc. *******
>
> On Fri, 10 Jan 2003, TOLGA ASVEREN wrote:
>
> >
> > Samuel,
> >
> > First of all I consider whether a SG supports this
> or that type of RK as a
> > feature of that SG, not as a property of M3UA
> protocol. M3UA does not work
> > assuming some special RK type.
> > IMO, the only place where RK type comes into play
> is dynamic registration.
> > And this is natural, because there one tells about
> the type of the RK. One
> > has to define some types for registration
> otherwise how can you tell your
> > peer what you want? Also please note, RK type not
> supported case is
> > handled, so it is not a problem if an ASP asks to
> register for a SSN based
> > RK to a SG, which does not support it.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 03:48:23 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Fri, 10 Jan 2003 11:52:00)
> less and possibly by addressing nodes with IP addresses.

SSN based RKs would not help 3GPP as the SCCP used is connection-oriented.
Most connection-oriented messages do not have SSN at all, just the local
reference number.

Fortunately even though M3UA is used between nodes, SUA can still be used
within a node.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/