Subject: [Sigtran] M3UA - ASP UP and ASP DN in Double Exchange

From: "Nagar, Ashish" <[email-masked]>
Date: Thu, 2 Jan 2003 03:47:32 -0800

Hi Brian/Tolga

    From section 5.5.2 (Double Exchange) of M3UA RFC 
    "only one single exchange of ASP Up 
    message can be considered as enough since the response by the other 
    peer can be considered as a notice that it is in ASP_UP state"

    My point is because it is a double ended mode this message should come 
    from both the side. There is no point in keeping ASP UP and ASP DN 
    from another end as optional. This I am asking just for the sake of 
    similarity with ASP AC and ASP IA message and also its behavior will be
same as 
    the name implies (Double Exchange).

    So my suggestion is to change ASP UP and ASP DN as mandatory.

    I know that ASP AC / ASPIA contains RC.

Regards
Ashish
     
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 04:58:25 -0700

Ashish,

Sorry, the concensus was to leave ASPUP/DN (ACK) single ended.

Certainly the IPSP which sends ASPUP ACK has an available local M3UA layer.
Also, whether an IPSP sends ASPDN ACK or ASPDN, the entire relation is down.

There is no need to change it just to make it like ASPAC/IA (ACK).

--brian

Nagar, Ashish wrote:                                 (Thu, 02 Jan 2003 03:47:32)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 2 Jan 2003 05:34:45 -0800 (PST)

Ashish,
>     I know that ASP AC / ASPIA contains RC.
[TOLGA]Personally I don't consider DE as a robust
peer-to-peer communication model (even SE is
questionable IMO, but better than DE). But for your
question, I would think  that the name has "double"
inside does not necessarily mean that everything
should be double. Important is how AS related messages
are exchanged, i.e. with DE each IPSP tells the other
one, which traffic range it can serve (this is also
the reason, why it is still a client/server
relationship, not a peer-to-peer relationship IMO).
ASPUP/ASPDN is not for a specific AS but for the whole
IPSP (so basically relad with all AS). So, I think, it
is the double ASPAC/ASPAC-ACK, which makes this model
to be called DE.
But having double ASPUP/ASPDN might have the
advantage, that one can use ASP/SGP state machines
unmodified (the reason why so many people were
attracted by DE model initially, including me)
> Ashish

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 06:39:18 -0700

Tolga,

Tolga Asveren wrote:                           (Thu, 02 Jan 2003 05:34:45)

-X- snip -X-
> attracted by DE model initially, including me)

Dream.  You cannot reuse the ASP/SGP state machines for DE, only
for SE.  This is because DE only handles half traffic flows,
whereas the normal ASP/SGP state machines handle traffic flow in
both directions, just as does SE.

--brian

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 2 Jan 2003 16:31:37 -0800 (PST)

Brian,
--- "Brian F. G. Bidulock" <[email-masked]>
> both directions, just as does SE.
[TOLGA] This all depends how you model it. If one
thinks DE as ASP+SGP(IMO, this is what DE is), then
between two IPSP there are two bidirectional traffic
flows, but for each of them only one direction is
used. That it is not used does not mean, that it is
not opened.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 17:46:56 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 02 Jan 2003 16:31:37)
> used. That it is not used does not mean, that it is

Take a look back on the SE/DE threads.  It was fairly proven
that DE does not reuse the ASP/SGP state machine.  Instead it
uses half of them an places new requirements for coordinating
the other half-flow with the first.  DE is the criss-crossed
model (there is no other way for it to work).

--brian