Subject: RE: [Sigtran] M3UA default AS

From: "Wung, Joseph" <[email-masked]>
Date: Fri, 17 Jan 2003 10:36:52 -0500

Brian,
Tolga,

Are you suggesting the following steps in creating
a default AS?

1) Configure the SG with ASP IDs that are to be used
   as default ASPs.
2) A default ASP establishes its own SCTP associations.
3) The default ASP sends an ASP Up message with an ASP Id
   that SG has configured.
4) SG responds with ASP Up Ack.
5) Other default ASPs can repeat step 2 thru 4.
6) From now on, any incoming SS7 message that cannot find a 
   matching routing key entry will be routed over to one of 
   default ASPs.
  
How does the SGP know what traffic mode they are running in,
i.e., loadshare, broadcast, or override?

Joe

> > > M3UA section 1.4.2.4 says
> > >
> > >        "When there is no matching Routing Key entry for an
> > >        incoming SS7 message, a default treatment MAY be
> > >        specified.  Possible solutions are to provide a default
> > >        AS at the SGP that directs all unallocated traffic to a
> > >        (set of) default ASP(s), or to drop the message and
> > >        provide a notification to layer management."
> > >
> >
> > Can someone tell me how this default AS is provided in the
> > system where dynamic registrations are used?  Normally,
> > an AS is tied to an SCTP association over which the ASP
> > registers with the AS.  Without a procedure, how could this
> > coupling between the default AS and the "default"
> > SCTP association be established?
> 
> ASP Id ?
> [TOLGA]If the goal is also to provide dynamic behaviour for 
> addressing of
> ASPs I also think AspId should be used. But for the case where dynamic
> behaviour is required only for traffic ranges, one can also use static
> addressing for default ASP.
> 
> 
> 
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 Jan 2003 09:18:11 -0700

Joseph,

I would think that it is a good idea to have the ASPs
activate for the "default" AS.  I thought it would be
a good idea to use, say, RC=0, to indicate the default
AS to the SG.  Then the traffic mode is the traffic mode
of the AS.

--brian

Wung, Joseph wrote:                                                                  (Fri, 17 Jan 2003 10:36:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/