Subject: Re: [Sigtran] Re: Suggested New Test Cases for draft-bidulock-sigtran-m2pa-test-02.ps

From: [email-masked]
Date: Fri, 17 Jan 2003 08:40:56 -0500

Hello Brian,

>Sure, so allow them to be repeated, but don' require or recommend it.
>Use the words MAY or OPTIONAL.

Good recommendation. I agree with this.

Regards,

Jeff

"Brian F. G. Bidulock" <[email-masked]> on 01/17/2003 08:07:53 AM

Please respond to [email-masked]

To:    [email-masked]
cc:    Tom George <[email-masked]>, [email-masked]
Subject:    Re: [Sigtran] Re: Suggested New Test Cases for
       draft-bidulock-sigtran-m2pa-test-02.ps

Jeffrey,

Sure, so allow them to be repeated, but don' require or recommend it.
Use the words MAY or OPTIONAL.

--brian

[email-masked] wrote:
(Fri, 17 Jan 2003 07:43:35)
>
> Hello Tom,
>
> After further consideration of the issue, I have concluded that the
> repeated
> sending of LSR, LSB, LSPO is useful for diagnostics and measurements.
> I don't see how these messages could be lost if the association remains
> established, but nevertheless, I now think that the repetition is useful.
>
> Regards,
>
> Jeff
>
>
>
>
>
> Tom George <[email-masked]>@ietf.org on 01/16/2003 06:08:05 PM
>
> Sent by:    [email-masked]
>
>
> To:    [email-masked]
> cc:    [email-masked]
> Subject:    Re: [Sigtran] Re: Suggested New Test Cases for
>        draft-bidulock-sigtran-m2pa-test-02.ps
>
>
> Brian,
>
> I think there was a concern about what would happen if only one message
> was sent, and it got lost.
>
> Do you think we should not send these messages periodically?
>
>    LS Ready
>    LS Busy
>    LS PO
>
> tomG.
>
>
> "Brian F. G. Bidulock" wrote long ago on 09/19/02:
> >
> > Jeffrey,
> >
> > I don't enjoy burning timers for nothing.  It is easy enough
> > (even trivial) for an implementation to ignore the repetition,
> > but generating and interval requires a timer and introduces
> > additional fodder for race conditions and barriers to scale.
> > Unless someone can come up with a good reason, the intervals
> > should be struck.
> >
> > Can you remember why they were added, Tom?
> >
> > --brian
> >
> > [email-masked] wrote:               (Thu, 19 Sep 2002
> 08:47:34)
> > >
> > > Hello Brian,
> > >
> > > >My preference is that they are struck.  The reason for striking
> > > >is that sending these at an interval serves no purpose whatsoever
> > > >that I can think of.  Can you think of a reason to send any of
> > > >these periodically?  This is SCTP after all and not a lossy link.
> > >
> > > I can think of no reason to periodically send these messages.
> > > My preference for keeping them has to with the fact that I've
> > > implemented them. (Yes, I know, not a good reason.... I'm human).
> > >
> > > Regards,
> > >
> > > Jeff
> > >
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
> --
> * Tom George       PB7-24001 (near B-21)      [email-masked]  *
> * 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
> * Alcatel USA, Inc.; 1000 Coit Rd, MS PB7-SWPRO; Plano TX 75075-5813  *
> * I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
> * to advertise or represent its position,  operations, or activities. *
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>
>
>

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Fri, 17 Jan 2003 10:58:25 -0600

Good idea. For example, I will change this in 4.1.3:

When the proving period timer T4 expires, M2PA changes to the Aligned
Ready state. M2PA SHALL start the timer T1 and send Link Status Ready
messages to its peer at interval Status_Interval. These messages are
used to verify that both ends have completed proving.

to this:

When the proving period timer T4 expires, M2PA changes to the Aligned
Ready state. M2PA SHALL start the timer T1 and send a Link Status
Ready message to its peer. These Link Status Ready message is used to
verify that both ends have completed proving. M2PA MAY send additional
Link Status Ready messages while timer T1 is running.

And I will remove the Status_Interval.

While I am in the neighborhood: Proving_Rate is really an interval, not
a rate. So I was thinking of changing its name to Proving_Interval. 

tomG.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 Jan 2003 10:01:19 -0700

Tom,

Works for me.

--brian

Tom George wrote:                                                                      (Fri, 17 Jan 2003 10:58:25)