Subject: Re: [Sigtran] OPC List renamed as DPC List

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 17 Jan 2003 14:48:32 +0200

Srivats,
--- "Srivats P." <[email-masked]> wrote:
> Hi,
>
> I need a clarification regarding the "OPC List in
> Registration
> Request Message" issue in the M3UA IG.
>
> <quote>
>     ---------
>     New text: (Section 3.6.1)
>     ---------
>
>     DPC List:
>
>     The Destination Point Code List parameter
> contains one or more SS7
>     DPC entries, and its format is the same as the
> Destination Point Code
>     parameter. Multiple DPC values will only be
> valid in the case of
>     Alias Point Code configuration. The absence of
> the DPC List parameter
>     in the Routing Key indicates the use of the DPC
> value as the only
>     posible DPC for the AS.
>
>  3.8.3 Solution description
>
>     Including the scenario where this parameter is
> used (Alias point code
>     configurations), the problem is solved. The
> parameter name has also
>     be changed to "Destination" since it is the way
> that the SG sees it.
>
> </quote>
>
> the OPC List has been renamed as DPC List. So now we
> have a DPC Parameter
> (the point code of the AS which is being registered)
> and a DPC List (
> earlier OPC List) which is a list of SS7 Point Codes
> from which the AS
> can receive messages. Right ?
[TOLGA] No, OPC list is not renamed. It is still there. There were
questions why multiple DPCs are allowed for a RK, and for that a
clarification has been added to IG. But the initial version had a typo
where it was referring to OPC instead of DPC. Still it seems a correction
is necessary. I think it should refer to multiple DPC values instead of a
DPC list, because this is the structure of RK parameter.
>
> Say, SP A in the SS7 network has alias point codes
> 1-1-1 and 1-1-2.
> ASP X registers an AS (DPC = 3-3-3 and DPC List =
> 1-1-1, 1-1-2). Now if the
> SG receives any message with the DPC value as 3-3-3
> in the Routing Label,
> it will check the OPC value in the Routing Label to
> see if it is either
> 1-1-1 or 1-1-2, before sending the message to the
> AS. Right ?
>
> What happens if the DPC List (1-1-1, 1-1-2) was not
> included in the RK ?
> According to the IG -
>
> "The absence of the DPC List parameter in the
> Routing Key indicates the
> use of the DPC value as the only posible DPC for the
> AS."
>           ^^^^^^^^^^^
>
> Which "DPC value" is being referred to here ? 3-3-3
> ? But wasn't it the
> same case even when the "DPC List (formerly OPC
> List)" was included ?
> The ONLY point code of the AS was still 3-3-3. What
> am I misreading here ?

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 17 Jan 2003 06:03:41 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Fri, 17 Jan 2003 14:48:32)
> DPC list, because this is the structure of RK parameter.

It is foolish to use the terms DPC and OPC at all.  DPC only has meaning
in SS7 for a direction of message flow.  Local and Remote would be better
terms that are used throughout the SS7 specifications.

Nevertheless, the IG describes the "DPC List" as  for "alias" point codes
and replaces the OPC List text.  This is absurd.  The section should read
as follows:

 ----------
  Old Text (section 3.6.1)
 ----------

      Note: The Destination Point Code, Service Indicators, Originating
      Point Code List and Circuit Range List parameters MAY be repeated
      as a grouping within the Routing Key parameter, in the structure
      shown above.

 ----------
  New Text (section 3.6.1)
 ----------

      Note: The Destination Point Code, Service Indicators, Originating
      Point Code List and Circuit Range List parameters MAY be repeated
      as a grouping within the Routing Key parameter, in the structure
      shown above.  This could be used where the RK represends multiple
      alias point codes.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ken Morneault <[email-masked]>
Date: Fri, 17 Jan 2003 09:16:08 -0500

All:

It was previously noted that Section 3.8 was incorrect and
that it would be fixed in the next release of the I-G.  

Regards,

Ken