Subject: Re: [Sigtran] OPC List renamed as DPC List

From: "TOLGA ASVEREN" <[email-masked]>
Date: Mon, 20 Jan 2003 09:38:34 +0200

Brian,
> TOLGA,
>
> TOLGA ASVEREN wrote:
>                                 (Mon, 20 Jan 2003
> 09:06:32)
> >
> > Brian,
> > > Srivats,
> > >
> > > No.  The entire RFC stays as it stands.  DPC can
> > > already be repeated
> > > in the RK.  It is the explanation of the
> repetition
> > > which is missing:
> > > i.e., that one might want to repeat DPC (and
> > > associated optional
> > > RK parameters) where the additional DPCs are
> "alias"
> > > point codes for,
> > > say, the first DPC.
> > >
> > > But there are other uses for this as well.  For
> > > example, the same effect
> > > as cluster routing at the SG could be
> accomplished
> > > by placing all the
> > > DPCs in a cluster in the RK.  Of course, the
> entire
> > > cluster will be
> > > accessible or inaccessible, but that's how
> cluster
> > > routing works.
> > [TOLGA] IMO, this might be problematic. This
> violates the principle that
> > one RK should not span SPMC boundaries. For
> example for DUPU, a cluster RK
> > wouldn´t be inline with SS7 UPU semantics. UPU
> from SS7 is received as
> > response for a specific PC but it would map to a
> DUPU for the whole
> > cluster.
>
> It doesn't cause a problem.  In this case the entire
> cluster is an SPMC.
> It is no different than if all the point codes
> except one are aliases.
[TOLGA]IMO a cluster RK and a RK with multiple alias point codes are
different things. With cluster RKs, we have PCs, whose user parts are
totally independent from functional point of view. IMO cluster RKs are
violation of the key principle that RKs shouldn´t span SPMC.
>
> And there is no problem with UPU, if you understand
> how UPU works.  Each
> PC in the cluster would receive UPU if it sent a
> message to the affected
> destination, so there is no problem with them all
> receiving it.  This is
> also the case for "alias" point codes.
[TOLGA] What happens if only one PC in the cluster sends a message to the
affected destination? Because DUPU would be sent for the whole RK, I would
consider this a violation of the UPU semantic of SS7.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Jan 2003 01:04:57 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Mon, 20 Jan 2003 09:38:34)
> totally independent from functional point of view.

Not necessarily.

> IMO cluster RKs are violation of the key principle that RKs shouldn´t span
> SPMC.

They don't span the SPMC if the *are* the SPMC.

> consider this a violation of the UPU semantic of SS7.

Then you don't understand UPU semantics:  See Clause 11/Q.704.  In this
case, the entire cluster has one "local user."  So, the MTP-STATUS is always
delivered to the correct user and there is no problem.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/