Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

From: [email-masked]
Date: Mon, 13 Jan 2003 18:17:47 +0200

Brian,

I mean NOTIFY message exists and must be sent when the AS status is
changed.
I agree that ACTIVE ACK is to be send on response on ACTIVE. If for
internal SG reason the AS is down for certain IID, the SG must send NOTIFY
to the ASPs.
This just to confirm your statement, that inability to answer OK is just
the same as a failure at any moment later.

Thanks,
Lev

                      "Brian F. G.                                                                         
                      Bidulock"                To:      [email-masked]                             
                      <bidulock@openss         cc:      [email-masked],                  
                      7.org>                   [email-masked], [email-masked],        
                                               [email-masked], [email-masked]                    
                      13/01/03 13:53           Subject: Re: [Sigtran] IUA -  ASP Active and ACTIVE ACK     
                      Please respond                                                                       
                      to bidulock                                                                          

Lev.Finkel,

Notify(AS_inactive) is never sent after sending ASPAC Ack because the
AS is active.  Where in the RFC did you think this was stated?

--brian

[email-masked] wrote:
(Mon, 13 Jan 2003 13:33:23)
>
> Notify(AS_inactive) or another corresponding notify is the way provided
in
> RFC.
> Regards, Lev

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 15:31:15 -0700

Lev.Finkel,

[email-masked] wrote:                                                   (Mon, 13 Jan 2003 18:17:47)
> internal SG reason the AS is down for certain IID, the SG must send NOTIFY

The procedure for doing this that was imported into M2UA from the
other UAs by the IG is to send ASPIA Ack.  Notify is only advisory
and will not illicit the correct response in the ASP.  In response
to ASPIA Ack, the ASP must put itself in the ASP-INACTIVE state for
the AS, and then issue ASPAC.  Then the SG can return ERR("Invalid
IID") to the ASPAC if, indeed, the AS has been "unconfigured".  If
the AS has not been "unconfigured" in the first place, the SG should
not be deactivating the AS at all.   It should be clearing the
signalling connection with a Release Indication.

--brian