Subject: RE: [Sigtran] M3UA distributing ISUP group messages

From: "Wung, Joseph" <[email-masked]>
Date: Thu, 2 Jan 2003 14:37:25 -0500

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, January 02, 2003 10:49 AM
> To: Wung, Joseph
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA distributing ISUP group messages
> 
> 
> Joseph,
> 
> Several ways around that:
> 
>  o always configure your ISUP switches for pre-arranged 
> circuit groups.
> 
>  o always configure your ISUP switches for the same circuit groups on
>    both ends of the trunk.
> 
> Then you won't have this spanning problem.

Can you please elaborate using my example below?

> 
> I think that, although one can loadshare on CIC, that routing on CIC
> is a bad idea.  ISUP should be routed on OPC/DPC/SI=5 at maximum
> granularity.  Then if one loadshares CIC over ASPs, it makes 
> more sense.

Can you please elaborate?

> 
> At any rate, there is a lot of description missing from the M3UA spec
> that would allow two implementation to interoperate properly 
> as far as CIC
> routing is concerned.
> 
> --brian
> 
> Wung, Joseph wrote:                        (Thu, 02 Jan 2003 09:39:43)
> > Brian,
> > 
> > It is not up to the ASP or AS.  The SS7 side can choose
> > to opearate on any circuit group as they want.
> > 
> > For example, 
> > ASP-a serves AS-1(CIC=5000~5071) and 
> > 		 AS-2(CIC=5072~5143),
> >  
> > ASP-b serves AS-3(CIC=5144~5215) and
> > 		 AS-4(CIC=5216~5287)
> > 
> > Neither the ASPs nor the ASes are splitting anything here.
> > The SS7 side can send a group related ISUP message, e.g.,
> > CGB, using any 24 circuit range across 5000~5287.  I
> > guess this is legal for them to do so.
> > 
> > But this would cause the SG send the message to ASP-a if 
> > the CIC range in the CGB crosses the ASP boundary, or cause
> > one ASP to send it to AS-1 or AS-3 if crossing the AS 
> > boundary.
> > 
> > Joe 
> > 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 17:59:28 -0700

Wung,,

Wung, Joseph wrote:                                                                  (Thu, 02 Jan 2003 14:37:25)
> Can you please elaborate using my example below?

Well, I presume you are talking about ANSI ISUP, because ITU/ETSI
tends to keep its circuit groups within the E1 span and makes little
provisions for DS0 cross-connect between switches.  Under ANSI, it is
still the case that hardware oriented group reset, blocking and
unblocking is span based: it is just that DSO cross-connect between the
spans causes problems (in both it causes difficulties with CIC assignment
anyway).  The maximum number is 24 for a reason: that's the number of
circuits in a T1 span.

If you configure both the remote switch and the MGC so that CIC are
correctly organized into spans and group messages are generated a span
basis (or by pre-arrangement in ANSI), then you will never get a group
message which straddles a T1 span, and you can arrange your CICs into AS
so that a group message will never span an AS.

> Can you please elaborate?

The AS routing Key would be DPC=PCA, OPC=PCB, SI=ISUP, representing all the
circuits between two switches and the MTP accessibility and User Part
accessibility as well within the same AS.

Make it a load-share AS.  Instead of "routing" to the ASPs within this AS
using the Routing Key, "load-share" over the ASPs in this AS using CIC.
As each AS must be prepared in a Load-share AS to receive any message, there
is no problem with circuit group management, but the load-sharing could use
the above technique to keep from splitting circuit groups across ASPs.
Then SSNM messages (including DUPU) go to the correct place: all the ASPs
in the ASP-ACTIVE state for the AS.

--brian