Subject: Re: [Sigtran] m3ua- IG

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 10 Jan 2003 15:36:56 +0200

Samuel,

Did I say that you or anybody else MUST use M3UA with SSN based RKs?

IMO M3UA does not need much changes to be able to handle this case(just the
concerns Brian has pointed out about handling of DATA must be addressed in
the corresponding sections with a few sentences. The rest is implementation
dependent management functionality on SG).

     Tolga

Tolga,

To the point if we want to support SSN RK with M3UA stack then RFC 3332
should have been writen with much details of SSN, but it was not writen
so.and its too late to update M3UA with SSN RKs.

But on the other hand i have SUA to handle all SSN related issues.
So One will always select SUA to implement SSN RKs.
Nobody will select M3UA to implement SSN RK because i have much better
stack SUA to support SSN RK.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

On Fri, 10 Jan 2003, Brian F. G. Bidulock wrote:

> TOLGA,
>
> Then you would have the SG intercepting and altering DATA sent to it by
the AS?
> This was the same as the problem for CIC.  The ASP has an expectation
(stated
> in the RFC) that DATA messages are transferred unaltered.
>
> --brian
>
> TOLGA ASVEREN wrote:                              (Fri, 10 Jan 2003
14:54:18)
> >
> > Samuel,
> >
> > As you have also pointed out in one of your messages, this will be sent
as
> > a SCCP management message in DATA. Then it is up to management logic in
SG
> > to decide whether the global SSN state should be updated or not
(similar to
> > what happens with SPMC availability/unavailability)
> >
> >       Tolga
> >
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 06:45:52 -0700

TOLGA,

I think you also need to say which SCCP classes, and what SCCP routing
cannot be handled by such an M3UA.  Obviously, M3UA cannot support
SCCP classes 2 or 3, and cannot support messages which are marked
"Route on GT".

--brian

TOLGA ASVEREN wrote:                                                                 (Fri, 10 Jan 2003 15:36:56)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 06:53:09 -0700

TOLGA,

While your at it, I think you should say which SCCP management
messages are intercepted by the SG in performing its SPMC-like
management of SSNs and which are transparently passed to the ASP.
Otherwise, how is the ASP to know when it is responsibile for
SCCP management and when the SG is?

(You have SUA re-specified before your done... ;)

--brian

Brian F. G. Bidulock wrote:                                                          (Fri, 10 Jan 2003 06:45:52)

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 08:09:13 -0600 (CST)

Brian,

Can M3UA support messages which are marked "Route on PC/SSN"

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 07:11:17 -0700

Samuel,

I believe that is what Tolga is proposing.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 08:09:13)

---

From: "Sidney L. Bryson" <[email-masked]>
Date: Fri, 10 Jan 2003 08:19:11 -0600

Is this to say there limitations when using GTT with M3UA?

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Brian F. G. Bidulock
Sent: Friday, January 10, 2003 7:46 AM
To: TOLGA ASVEREN
Cc: [email-masked]
Subject: Re: [Sigtran] m3ua- IG

TOLGA,

--brian

TOLGA ASVEREN wrote:
(Fri, 10 Jan 2003 15:36:56)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 08:11:15 -0700

Sidney,

Just when attempting to use SSN routing keys.

--brian

Sidney L. Bryson wrote:                                                             (Fri, 10 Jan 2003 08:19:11)