Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

From: [email-masked]
Date: Mon, 13 Jan 2003 11:32:30 +0200

Chak,
see implementation guide section 3.20

Regards,
Lev

                      "PSK Chakravarthi"                                                                          
                      <[email-masked]         To:      <[email-masked]>, "ksrinivas"                
                      lcatel.com>                     <[email-masked]>                        
                      Sent by:                        cc:      "Latha" <[email-masked]>, <[email-masked]>      
                      [email-masked]          Subject: Re: [Sigtran] IUA -  ASP Active and ACTIVE ACK     

                      13/01/03 10:31                                                                              

Brian,

Consider the following case:

1. ASP sends ASPAC for IIDS 1 to 10.
2. Due to some reason SG can bring up only IIDS 1 to 5.
3. Now, what does SG send in the ASPAC Ack? (w.r.t IIDS)

thanks
Chak

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "ksrinivas" <[email-masked]>
Cc: "Latha" <[email-masked]>; <[email-masked]>
Sent: Monday, January 13, 2003 1:47 PM
Subject: Re: [Sigtran] IUA - ASP Active and ACTIVE ACK

> ksrinivas,
>
> Well, they can be used by the ASP to correlate the received
> ASPAC Ack with the sent ASPAC: which is not insignificant.
>
> --brian
>
> ksrinivas wrote:
(Mon, 13 Jan 2003 13:24:25)
> > Brian,
> >
> >      My meaning of "IIDs in ASPAC Ack is insignificant" is not that
IIDs
are optional or mandatory. IIDs serve no
> > purpose in the ASPAC Ack as per this thread.
> >
> > --Srini.
> >
> > "Brian F. G. Bidulock" wrote:
> >
> > > ksrinivas,
> > >
> > > But it doesn't have to: IIDs in ASPAC Ack is optional in the RFC.
> > >
> > > --brian
> > >
> > > ksrinivas wrote:
(Mon, 13 Jan 2003 12:24:50)
> > > > Brian,
> > > >
> > > >     If SG has to send the same set of IIDs back to the ASP in an
ASPAC Ack, the need for IIDs in ASPAC Ack is
> > > > insignificant.
> > > >
> > > > "Brian F. G. Bidulock" wrote:
> > > >
> > > > > ksrinivas,
> > > > >
> > > > > Your proposal represents a deviation from the RFC that I do not
agree with.
> > > > > The current RFC does not permit the SG to perform a "partial
activation" of
> > > > > some IIDs in a set.  Both in the ASPAC and ASPAC Ack, a subset of
IIDs
> > > > > represents the entire set of IIDs indicated by that subset.
> > > > >
> > > > > --brian
> > > > >
> > > > > ksrinivas wrote:
(Mon, 13 Jan 2003 11:05:43)
> > > > > >
> > > > > >    IMO, the Active and Active Ack procedures should be as
follows:
> > > > > >
> > > > > >    1. ASP can send Active msg with or without IIDs.
> > > > > >    2.  ASP  shall  never  send  multiple concurrent ASPACs as
there is no
> > > > > >    correlation identifier.
> > > > > >    3.  The ASP should be smart enough to remember whether it
has
sent any
> > > > > >    IIDs in the Active message.
> > > > > >    4. If ASP sends Active without IIDs,
> > > > > >           the  SGP  shall respond with Active Ack without IIDs,
if the SG
> > > > > >    activates  all  the  IIDs. Also, the SGP shall respond with
Active Ack
> > > > > >    with IIDs only that are activated.
> > > > > >    5. If ASP sends Active with IIDs,
> > > > > >           the  SGP  shall respond with Active Ack with IIDs
only
that are
> > > > > >    activated.  Also,  the SGP shall respond with Active Ack
without IIDs,
> > > > > >    if the SG refuses to activate all the IIDs.
> > > > > >
> > > > > >    --Srini
> > > > > >
> > > > >
> > > > > --
> > > > > Brian F. G. Bidulock
> > > > > [email-masked]
> > > > > http://www.openss7.org/
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 02:44:09 -0700

Lev,

[email-masked] wrote:                                                   (Mon, 13 Jan 2003 11:32:30)
> see implementation guide section 3.20

3.20 doesn't handle this case: only the case of misconfigured IIDs
(and not necessarily all in the same AS).

--brian