Subject: [Sigtran] M2PA two out of three

From: ksrinivas <[email-masked]>
Date: Fri, 03 Jan 2003 12:23:54 +0530

Brian,

    In Section 4.2.1 of M2PA Draft version 6, the following is observed.

"M2PA should follow the criterion of [2] Q.703, section 5.3.1 for
incorrect BSNs: If any two BSNs in three consecutively received User
Data messages are not the same as the previous one or any of the FSNs
of the User Data messages in the M2PA transmit buffer at the time they
are received, then MTP3 should be informed that the link is faulty."

The highlighted "or" should have been "and".

The same error "or" is carried from Q.703

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 Jan 2003 01:24:25 -0700

Srini,

"Or" and "and" (or "or" or "and") are not treated as logical or
and logical and when used in English. ;)

Nevertheless in this case, "or" is correct in both senses.

--brian

ksrinivas wrote:                                   (Fri, 03 Jan 2003 12:23:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: ksrinivas <[email-masked]>
Date: Fri, 03 Jan 2003 14:44:16 +0530

Brian,

      I understood the thing. But I still feel there is some relation between
logic and English. This can be felt from the De-Morgans law below.

____    _ _
A+B = A.B

where, A = the same as the previous one(BSNs),
           B = the same as any of the FSNs of the User Data messages in the M2PA
transmit buffer at
                  the time they are received.

Thanks & Regards,
Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 Jan 2003 02:22:25 -0700

Srini,

But there is the difference:
        _   _
I read  A + B.

The "not" in this case only applies to the immediate subject and _not_ the
entire sentence.

--brian

ksrinivas wrote:                                               (Fri, 03 Jan 2003 14:44:16)

---

From: "Manjunath" <[email-masked]>
Date: Fri, 3 Jan 2003 15:34:30 +0530

Brain,
  We  feel what srini observed holds valid,

  M2PA should follow the criterion of [2] Q.703, section 5.3.1 for
incorrect BSNs: If (( any two BSNs in three consecutively received User
Data messages) are not the same ((as the previous one) or (any of the FSNs
of the User Data messages in the M2PA transmit buffer at the time they
are received))), then MTP3 should be informed that the link is faulty."
  If A is not same as B or C then D, it means that A is not same as B and A
is
not same as C then D proving De Morgan's law
           ____           _ _          _       _
     A.( B+C) = A.(B.C) = A.B . A.C

Is not what Srini stated valid??

thanks
manju/sibi

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "ksrinivas" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, January 03, 2003 2:52 PM
Subject: Re: [Sigtran] Re: M2PA two out of three

> > > >         In  Section  4.2.1  of  M2PA  Draft  version  6, the
following is
> > > >    observed.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 3 Jan 2003 15:15:25 -0700

Manjunath,

You miss the efficiency in English of skipping qualifiers on the
second clause:

   If A is not the same as B or C then D.
=> If A is not the same as B or A is not the same as C then D.
=> If ((A is not the same as B) or (A is not the same as C)) then D.

--brian

Manjunath wrote:                                    (Fri, 03 Jan 2003 15:34:30)

---

From: "Manjunath" <[email-masked]>
Date: Mon, 6 Jan 2003 13:00:16 +0530

If I say i dont want coffee or tea doesnot it mean
    that i dont want coffee and i dont want tea....
  in another context
   if i say 5 is not equal to 2 or 3 ,doesnot it mean
   5 is not equal to 3 and 5 is not equal to 2 .
  Is not that what even demorgan proved
  _____      _    _
  A + B  =  A . B,
   If what you state is true the link has
 to be treated as faulty if either of the two
condition is true and the following becomes
apparent

 If any two BSNs in three consecutively received User
 Data messages are not the same as the previous one or if any two BSNs
  in three consecutively received User  Data messages are not the same
as any of the FSNs  of the User Data messages in the M2PA transmit buffer
at the time they are received, then MTP3 should be informed that the link is
faulty.

please clarify..

--manju/sibi

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Manjunath" <[email-masked]>
Cc: "ksrinivas" <[email-masked]>; <[email-masked]>
Sent: Saturday, January 04, 2003 3:45 AM
Subject: Re: [Sigtran] Re: M2PA two out of three

> > > ksrinivas wrote:                                               (Fri,
03
> > Jan 2003 14:44:16)
> > > > Brian,
> > > >
> > > >       I understood the thing. But I still feel there is some
relation
> > between
> > > >            B = the same as any of the FSNs of the User Data messages
in
> > the M2PA
> > > > > ksrinivas wrote:                                   (Fri, 03 Jan
2003
> > 12:23:54)
> > > > > >    incorrect BSNs: If any two BSNs in three consecutively
received
> > User
> > > > > >    Data messages are not the same as the previous one or any of
the
> > FSNs
> > > > > >    of the User Data messages in the M2PA transmit buffer at the
time
> > they

---

From: ksrinivas <[email-masked]>
Date: Mon, 06 Jan 2003 13:00:30 +0530

Brian,
                                                _    _
     If one reads the sentence as A + B, then the following can be interpreted.

Fail the link, if

      either
      any two BSNs in three consecutively received User Data messages are not the same as the
previous one
      or
     not the same as any of the FSNs of the User Data messages in the M2PA transmit buffer at
the time they are received

_  _
But I feel this is mis-leading, We should fail the link only when both the conditions(A.B) are
met.

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Jan 2003 00:54:10 -0700

Srini,

In fact, if the BSNR is outside the range (inclusive) from FSNF-1 to FSNT
twice consecutively, then the link should fail.  Note that FSNT is always
set to the last correct BSNR.  See the SDLs in Q.703 or T1.111.

I would agree that M2PA should not repeat statements from these
specifications, but should merely reference them.  (Particularly as some
corrections were made to SDLs in the Q.703 IG.)

--brian

ksrinivas wrote:                               (Mon, 06 Jan 2003 13:00:30)
>           any two BSNs in three consecutively received User Data messages
>    are not the same as the previous one
>          or
>          not the same as any of the FSNs of the User Data messages in the
>    M2PA transmit buffer at the time they are received
> 
> 
>                                                         _  _
>    But I feel this is mis-leading, We should fail the link only when both
>    the conditions(A.B) are met.
> 
>    --Srini
>

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Mon, 6 Jan 2003 06:04:39 -0600 (CST)

Brian,

According to section 3.4.1
(and in many SSNM messages)

The DUNA message is sent from an SGP in an SG to all concerned ASPs...

What is this concerned ASPs?

Are these the ASPs connected to the SGP?
or
Are these ASPs that have registered with the Affected Point
Codes(mentioned in OPC list of REG message) in SGP?

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Jan 2003 05:51:22 -0700

Samuel,

Concerned ASPs are ASPs which are ASP-ACTIVE for an AS which corresponds to an
MTP-User which needs to be delivered the MTP-PAUSE primitive in accordance
with SS7 MTP Level 3 specifications, or which need to be sent a DUNA message
in response to a valid DAUD message from that ASP.

--brian

Samuel Dur D. Jeyaseelan wrote:                       (Mon, 06 Jan 2003 06:04:39)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Jan 2003 07:33:40 -0700

Manjunath,

Consider that in English `or' can mean:

	logical or
	logical exclusive or
	logical and

If you consider that the `or' means "logical exclusive or"
then:

  ~A (+) ~B => A (+) B

Which is correct.

`Or' means "logical exclusive or" more often in English than
it means "logical or".

--brian

Manjunath wrote:                                   (Mon, 06 Jan 2003 13:00:16)

---

From: Tom George <[email-masked]>
Date: Tue, 07 Jan 2003 17:55:02 -0600

Manju,

I think your coffee-and-tea example is correct. 

My interpretation of the statement is:

If any two BSNs in three consecutively received User
Data messages are not the same as ((the previous one) or (any of the
FSNs
of the User Data messages in the M2PA transmit buffer at the time they
are received)), then MTP3 should be informed that the link is faulty.

If A is not (B or C), then D.

This is equivalent to

If (A is not B) and (A is not C), then D.

Putting the words back in:

If (any two BSNs in three consecutively received User
Data messages are not the same as the previous one) and ([if any two
BSNs in three consecutively received User Data messages are not the same
as] any of the FSNs
of the User Data messages in the M2PA transmit buffer at the time they
are received), then MTP3 should be informed that the link is faulty.

If one wanted to replace "or" with "and" in the current text, it would
be a good idea to add some extra words, such as

If any two BSNs in three consecutively received User
Data messages are not the same as the previous one and *not the same as*
any of the FSNs
of the User Data messages in the M2PA transmit buffer at the time they
are received, then MTP3 should be informed that the link is faulty.

I prefer to leave the text as it is, since it is familiar to those who
have worked with Q.703. 

tomG.

The current text, for the sake of reference:
If any two BSNs in three consecutively received User
Data messages are not the same as the previous one or any of the FSNs
of the User Data messages in the M2PA transmit buffer at the time they
are received, then MTP3 should be informed that the link is faulty.

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel USA, Inc.; 1000 Coit Rd, MS PB7-SWPRO; Plano TX 75075-5813  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: ksrinivas <[email-masked]>
Date: Mon, 13 Jan 2003 19:22:52 +0530

Brian,

For the following

Can you please tell me whether my assumption is correct.

(let us think that all the consecutively received User Data messages are
different and also '0' means valid BSN is received and '1' means invalid BSN is
received)

0  0  0       Do not fail the link
0  0  1       Do not fail the link
0  1  0       Do not fail the link
0  1  1       Fail the link
1  0  0       Do not fail the link
1  0  1       Fail the link
1  1  0       Fail the link
1  1  1       Fail the link

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 07:08:45 -0700

ksrinivas,

ksrinivas wrote:                                                                 (Mon, 13 Jan 2003 19:22:52)
> 1  0  0       Do not fail the link

Write it this way:

0 0 0 0   don't fail
0 0 0 1   don't fail
0 0 1 0   don't fail
0 0 1 1   fail
0 1 0 1   fail

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 13 Jan 2003 07:19:08 -0700

ksrinivas,

Brian F. G. Bidulock wrote:                                                      (Mon, 13 Jan 2003 07:08:45)
> > 1  0  0       Do not fail the link

Err, one more time....

0 0 0 0   don't fail
0 0 0 1   don't fail
0 0 1 0   don't fail
0 1 0 0   don't fail
1 0 0 0   don't fail
1 0 0 1   don't fail
0 0 1 1   fail
0 1 0 1   fail

--brian