Subject: Re: [Sigtran] M3UA default AS

From: "TOLGA ASVEREN" <[email-masked]>
Date: Tue, 14 Jan 2003 11:36:48 +0200

Brian,
> TOLGA,
>
> TOLGA ASVEREN wrote:
> (Tue, 14 Jan 2003 08:29:19)
> >
>
> >                      SG
>
> >                 +-----------+
> +-----------+
> >                 |           |    Assoc 1     |
>       |
> >                 |   SGP1    |----------------|
> ASP1    |
> >                 |           |\   Assoc 2     |
>       |
> >                 +-----------+ \___________
> +-----------+
> >                       |                   \
>
> >                 +-----------+              \
> +-----------+
> >                 |           |    Assoc 3    \|
>       |
> >                 |   SGP2    |----------------|
> ASP2    |
> >                 |           |                |
>       |
> >                 +-----------+
> +-----------+
> >
>
> >
>
> >    [TOLGA]If ASP1 is INACTIVE, why is it used to
> send DATA? If both ASPs
> >    are serving the same AS, shouldn´t the user
> part running on top of them
> >    work as a single entity? In such a case, why is
> SCON arriving via ASP2
> >    not enough to execute necessary procedures on
> user part level? I would
> >    think it is the user part not the M3UA at ASP,
> which throttles traffic
> >    when necessary.
>
>
> No, both ASP1 and ASP2 are ASP-ACTIVE for the AS.
> Its just that SGP2 has
> not association with ASP1 and SSNM is stated as
> being sent on by an SGP
> (not by an SG).
[TOLGA] IMO, should be sent by SG. In fact for the well designed SG, where
there is internal routing between SGPs(when a message can´t be delivered by
a SGP because there is no ACTIVE ASP, it might be checked whether there is
another SGP, which can deliver the message), this won´t cause a problem but
because this is not mandatory still a clarification might be usefull.
>
> If the ASPs deliver SCON to a "combined" view of the
> AS, then when SGP1
> sends SCON to both ASP1 and ASP2 per the procedure,
> MTP-STATUS will appear
> twice at the AS.  For ANSI (with level indicated)
> this might not be a problem,
> but for ITU-T it is: the number of times within an
> interval that MTP-STATUS
> indicating congestion is delivered to an MTP-User
> such as ISUP affects the
> congestion algorithm.  The ASPs cannot correlate the
> SSNM, because it cannot
> due to diagram and the current procedure.
[TOLGA] For that specific case, I wouldn´t expect a big problem considering
that T29 has a range of 300-600 ms (but yes, still not nice).(BTW what
about this, SGP1 sends DUNA, after some time SGP2 sends DAVA for the same
PC. DAVA might arrive before DUNA to the ASP1)
In general I don´t know whether it is a good idea to base M3UA procedures
on the assumption that there will be a distributed entity for an AS over
multiple ASPs, because this distribution(or the lack of it) is a decision
on the upper layer. But this combined view will be most probably the case.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 14 Jan 2003 04:00:16 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Tue, 14 Jan 2003 11:36:48)
> > > +-----------+                +-----------+
> > > |           |    Assoc 1     |           |
> > > |   SGP1    |----------------|   ASP1    |
> > > |           |\   Assoc 2     |           |
> > > +-----------+ \___________   +-----------+
> > >       |                   \ 
> > > +-----------+              \ +-----------+
> > > |           |    Assoc 3    \|           |
> > > |   SGP2    |----------------|   ASP2    |
> > > |           |                |           |
> > > +-----------+                +-----------+
> > >
> >
> > >    [TOLGA]If ASP1 is INACTIVE, why is it used to send
> > >    DATA? If both ASPs are serving the same AS, shouldn´t
> > >    the user part running on top of them work as a single
> > >    entity? In such a case, why is SCON arriving via ASP2
> > >    not enough to execute necessary procedures on user part
> > >    level? I would think it is the user part not the M3UA
> > >    at ASP, which throttles traffic when necessary.
> >
> > No, both ASP1 and ASP2 are ASP-ACTIVE for the AS.  Its just
> > that SGP2 has not association with ASP1 and SSNM is stated
> > as being sent on by an SGP (not by an SG).
>
> [TOLGA] IMO, should be sent by SG. In fact for the well
> designed SG, where there is internal routing between SGPs
> (when a message can´t be delivered by a SGP because there is
> no ACTIVE ASP, it might be checked whether there is another
> SGP, which can deliver the message), this won´t cause a
> problem but because this is not mandatory still a
> clarification might be usefull.

Some well designed SGs would not send messages to an SGP which
was isolated from all ASPs in an AS.  There is no requirement in
M3UA for SGP to route messages between them.

Although sending SSNM on an SG-wide basis seems to solve the
ASPs problem, it causes significant problems for the SG.
Because, for an SGP to determine which ASPs to send a SNMM
message to, it must know the state of all of the ASPs to all of
the other SGPs.  If there are 16 of your low-end SGPs and 16 of
your low-end ASPs, each SGP must keep track of 256 ASP states
for each AS!  There will also be 256 race conditions per AS
when ASPs activate, deactivate or fail.

This is far more complicated that the thought of routing DATA
messages between SGP.

Sending SSNM on an SG-wide basis is a good idea, however, the
specification should not presume how that is accomplished at
the SG.

> >
> > If the ASPs deliver SCON to a "combined" view of the AS,
> > then when SGP1 sends SCON to both ASP1 and ASP2 per the
> > procedure, MTP-STATUS will appear twice at the AS.  For ANSI
> > (with level indicated) this might not be a problem, but for
> > ITU-T it is: the number of times within an interval that
> > MTP-STATUS indicating congestion is delivered to an MTP-User
> > such as ISUP affects the congestion algorithm.  The ASPs
> > cannot correlate the SSNM, because it cannot due to diagram
> > and the current procedure.
>
> [TOLGA] For that specific case, I wouldn´t expect a big
> problem considering that T29 has a range of 300-600 ms (but
> yes, still not nice).(BTW what about this, SGP1 sends DUNA,
> after some time SGP2 sends DAVA for the same PC. DAVA might
> arrive before DUNA to the ASP1) In general I don´t know
> whether it is a good idea to base M3UA procedures on the
> assumption that there will be a distributed entity for an AS
> over multiple ASPs, because this distribution(or the lack of
> it) is a decision on the upper layer. But this combined view
> will be most probably the case.

Reversals of DUNA and DAVA are almost impossible.  The reason is
that it takes a long time in the SS7 network for a signalling
point to restart (even if the inaccessibility was only due to a
link failure).  Also, DUNA and DAVA only apply to the ASP/SG
case. DUNA and DAVA are never used for point-to-point IPSP.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/