Subject: Re: [Sigtran] m3ua- IG

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 10 Jan 2003 14:26:46 +0200

Brian,

Again the last message from me on this thread, because I think I already
started repeating the same things.

Please find the comments are below.

   Tolga
--- "Brian F. G. Bidulock" <[email-masked]> wrote:
> TOLGA,
>
> TOLGA ASVEREN wrote:
>                                 (Fri, 10 Jan 2003
> 13:51:14)
> >
> > Samuel,
> >
> > The point is, no special management logic should
> be necessary on ASP.
>
> The point is special management logic is required on
> the ASP so that
> it can know where and when it is receiving SCCP
> management messages.
[TOLGA] No, this is not necesary.
>
> > The ASP is just any M3UA compliant ASP, nothing
> special there.
>
> It is a VERY special ASP.  It's M3UA knows about
> SCCP mangement messages
> and knows where the particular SG is going to place
> them, whether it needs
> to register for an AS with SSN=0, whether it needs
> to only act as a default
> ASP, whether it can expect management messages on
> each AS corresponding to
> a subsystem, in fact it needs to know that the SG is
> performing SSN routing
> at all (which is not supported by dynamic
> registration).
[TOLGA] I think soon you will ask for an ASP, which can work with any SG
with no configuration at all. Of course it needs to know, which SG it needs
to connect for a specific RK in case of static configurations. Afterall,
RKs need to be agreed by both sides through configuration. I think, it is
the normal operation that each AS gets the messages, it needs to get
-including management messages-. But if you think it as necessary, then
just a few sentences might be added to IG.
>
> > BTW, does M3UA RFC tell to support any specific RK
> type? For example if a SG
> > supports only DPC based RKs, will it be compliant
> or not with RFC?  I think
> > it is totally dependent on the implementor, which
> types of RKs her/his SG is
> > going to support.
>
> Of the proper M3UA routing keys (OPC/DPC/SI) routing
> on DPC must be supported
> at a minimum, otherwise, the implementation will not
> be useful.
[TOLGA] This is what most people would expect, but is a SG, which supports
only DPC+SI RKs -anf not DPC RKs- not compliant with M3UA RFC?

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 05:36:22 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Fri, 10 Jan 2003 14:26:46)
> [TOLGA] No, this is not necesary.

It is necessary so that the ASP can route the SCCP management
messages to the correct SCCP user.

> just a few sentences might be added to IG.

M3UA RFC covers SSNM.  It does not cover SCCP management messages.

If you want to add text to M3UA to allow it to support SSN routing,
do so.  My point has always been that it does not support SSN routing
as it stands.  What is your proposed text?

> only DPC+SI RKs -anf not DPC RKs- not compliant with M3UA RFC?

No. But if it does not support any routing keys, the implementation will
not be useful.  If it supports only SSN routing keys, it will be useless.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/