Subject: Re: [Sigtran] OPC List renamed as DPC List

From: "TOLGA ASVEREN" <[email-masked]>
Date: Mon, 20 Jan 2003 09:06:32 +0200

Brian,
> Srivats,
>
> No.  The entire RFC stays as it stands.  DPC can
> already be repeated
> in the RK.  It is the explanation of the repetition
> which is missing:
> i.e., that one might want to repeat DPC (and
> associated optional
> RK parameters) where the additional DPCs are "alias"
> point codes for,
> say, the first DPC.
>
> But there are other uses for this as well.  For
> example, the same effect
> as cluster routing at the SG could be accomplished
> by placing all the
> DPCs in a cluster in the RK.  Of course, the entire
> cluster will be
> accessible or inaccessible, but that's how cluster
> routing works.
[TOLGA] IMO, this might be problematic. This violates the principle that
one RK should not span SPMC boundaries. For example for DUPU, a cluster RK
wouldn´t be inline with SS7 UPU semantics. UPU from SS7 is received as
response for a specific PC but it would map to a DUPU for the whole
cluster.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 20 Jan 2003 00:19:50 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Mon, 20 Jan 2003 09:06:32)
> response for a specific PC but it would map to a DUPU for the whole

It doesn't cause a problem.  In this case the entire cluster is an SPMC.
It is no different than if all the point codes except one are aliases.

And there is no problem with UPU, if you understand how UPU works.  Each
PC in the cluster would receive UPU if it sent a message to the affected
destination, so there is no problem with them all receiving it.  This is
also the case for "alias" point codes.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/