Subject: Re: [Sigtran] m3ua- IG

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 10 Jan 2003 16:18:36 +0200

Brian,

TOLGA,

While your at it, I think you should say which SCCP management
messages are intercepted by the SG in performing its SPMC-like
management of SSNs and which are transparently passed to the ASP.
Otherwise, how is the ASP to know when it is responsibile for
SCCP management and when the SG is?
(You have SUA re-specified before your done... ;)
[TOLGA]What I am trying is not to define, how management logic in SG can be
implemented for SSN based RKs. I think this is out of the scope of M3UA
RFC(otherwise one could argue that each and every possible RK type should
be explained). What I try is to make it possible/clear using non-MTP3 RK
types with M3UA.

--brian

Brian F. G. Bidulock wrote:
(Fri, 10 Jan 2003 06:45:52)
> TOLGA,
>
> I think you also need to say which SCCP classes, and what SCCP routing
> cannot be handled by such an M3UA.  Obviously, M3UA cannot support
> SCCP classes 2 or 3, and cannot support messages which are marked
> "Route on GT".
>
> --brian
>
> TOLGA ASVEREN wrote:
(Fri, 10 Jan 2003 15:36:56)
> >
> > Samuel,
> >
> > Did I say that you or anybody else MUST use M3UA with SSN based RKs?
> >
> > IMO M3UA does not need much changes to be able to handle this case(just
the
> > concerns Brian has pointed out about handling of DATA must be addressed
in
> > the corresponding sections with a few sentences. The rest is
implementation
> > dependent management functionality on SG).
> >
> >      Tolga

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 08:14:42 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Fri, 10 Jan 2003 16:18:36)
> be explained). What I try is to make it possible/clear using non-MTP3 RK

But you have to say which SCCP management functions are performed where.
You have some at the SG and some at the AS.  Which ones are where?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Sat, 11 Jan 2003 05:07:53 -0800 (PST)

Brian,
--- "Brian F. G. Bidulock" <[email-masked]>
wrote:
>                                 (Fri, 10 Jan 2003
> 16:18:36)
[TOLGA] Neither on M3UA-ASP nor on SCCP on ASP side
any special behavoir is expected. So, SCCP on ASP side
is a regular SCCP as defined by the relevant standard,
and it executes all of the procedures a regular SCCP
executes. That is the whole point I am trying to
explain. Nothing special is necessary there, only on
SG side. Like one has SPMC management on SG one can
implement a SCCP management there -to present a unique
and global view of the SCCP entity to the rest of the
network-, without any additional requirement. 

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 11 Jan 2003 06:14:09 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Sat, 11 Jan 2003 05:07:53)
> network-, without any additional requirement. 

No you can't.  SPMC management does not require the
involvement of the MTP-User.  SCCP management does.
So if you start performing any SCCP management on the
SG, it affects the ASP because it affects the SCCP
user at the AS.

--brian

---

From: Tolga Asveren <[email-masked]>
Date: Sat, 11 Jan 2003 05:28:12 -0800 (PST)

Brian,
wrote:
> Tolga Asveren wrote:                                
>                                 (Sat, 11 Jan 2003
> 05:07:53)
> > >                                 (Fri, 10 Jan
> 2003
> > > > messages are intercepted by the SG in
> performing
> > > its SPMC-like
> > > > implemented for SSN based RKs. I think this is
> out
> > > of the scope of M3UA
> > > > RFC(otherwise one could argue that each and
> every
> > > possible RK type should
> > > But you have to say which SCCP management
> functions
> > > are performed where.
> > > You have some at the SG and some at the AS. 
> Which
> > > ones are where?
[TOLGA] Can you give an example, how the method I
propose affects the SCCP user at the ASP side?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 11 Jan 2003 07:11:26 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Sat, 11 Jan 2003 05:28:12)
> propose affects the SCCP user at the ASP side?

Because the SCCP at the ASP is responsible for SCCP
management.  When you make the SG responsible for
any SCCP management you are affecting the SCCP at the
ASP.

--brian

---

From: Tolga Asveren <[email-masked]>
Date: Sat, 11 Jan 2003 08:56:36 -0800 (PST)

Brian,

[..snip...]
> any SCCP management you are affecting the SCCP at
[TOLGA] Can you give a specific example?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 11 Jan 2003 10:36:56 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Sat, 11 Jan 2003 08:56:36)
> [TOLGA] Can you give a specific example?

Example in previous note where SST is duplicated and
results in erroneous behaviour of conforming SCCP
users at ASP.

--brian