Subject: Re: [Sigtran] m3ua- IG

From: "TOLGA ASVEREN" <[email-masked]>
Date: Fri, 10 Jan 2003 13:20:23 +0200

Brian,
--- "Brian F. G. Bidulock" <[email-masked]> wrote:
> TOLGA,
>
> TOLGA ASVEREN wrote:
>                                 (Fri, 10 Jan 2003
> 11:52:00)
> >
> > Samuel,
> > --- "Samuel Dur D. Jeyaseelan"
> <[email-masked]> wrote:
> > >
> > > Tolga,
> > >
> > > Agreed.Using flexible RK we support SSN.But How
> do
> > > you handle SSN
> > > congested, SSN unavailable and SSN available ?
> > > What M3UA message carries these information from
> ASP
> > > to SG?
> > > If you say 'DATA' then what is the need of SUA?
> > [TOLGA] Management logic in SG can decide for SSN
> status based on received
> > DATA and on AS status. In fact also for MTP3 based
> RK types, it is not a
> > special management message but the AS state, which
> helps SG to build the
> > combined SPMC state. But becase SSN is not a MTP3
> based RK, also SCCP
> > management messages in DATA should be handled
> properly.
> >
> > For your final question I guess:
> > SUA handles SSN based RKs more elegantly and I
> believe people had in mind
> > to use it between mobile network nodes in a peer
> to peer fashion (but last
> > time I checked 3GPP core network was still
> preferring M3UA), with one layer
> > less and possibly by addressing nodes with IP
> addresses.
>
> SSN based RKs would not help 3GPP as the SCCP used
> is connection-oriented.
[TOLGA] I think connectionless mode is also still there in 3GPP.
> Most connection-oriented messages do not have SSN at
> all, just the local
> reference number.
>
> Fortunately even though M3UA is used between nodes,
> SUA can still be used
> within a node.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 04:58:44 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Fri, 10 Jan 2003 13:20:23)
> > > > Agreed.Using flexible RK we
> > > > support SSN.But How do you
> > > > handle SSN congested, SSN
> > > > unavailable and SSN available ?
> > > > What M3UA message carries these
> > > > information from ASP to SG?  If
> > > > you say 'DATA' then what is the
> > > > need of SUA?
> > > [TOLGA] Management logic in SG can
> > > decide for SSN status based on
> > > received DATA and on AS status. In
> > > fact also for MTP3 based RK types,
> > > it is not a special management
> > > message but the AS state, which
> > > helps SG to build the combined
> > > SPMC state. But becase SSN is not
> > > a MTP3 based RK, also SCCP
> > > management messages in DATA should
> > > be handled properly.
> > >
> > > SUA handles SSN based RKs more
> > > elegantly and I believe people had
> > > in mind to use it between mobile
> > > network nodes in a peer to peer
> > > fashion (but last time I checked
> > > 3GPP core network was still
> > > less and possibly by addressing
> > > nodes with IP addresses.
> >
> > SSN based RKs would not help 3GPP as
> > the SCCP used is
> > connection-oriented.
I uses both... and together serving the
same user.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/