Subject: RE: [Sigtran] M3UA distributing ISUP group messages

From: "Wung, Joseph" <[email-masked]>
Date: Thu, 2 Jan 2003 09:39:43 -0500

Brian,

It is not up to the ASP or AS.  The SS7 side can choose
to opearate on any circuit group as they want.

For example, 
ASP-a serves AS-1(CIC=5000~5071) and 
		 AS-2(CIC=5072~5143),
 
ASP-b serves AS-3(CIC=5144~5215) and
		 AS-4(CIC=5216~5287)

Neither the ASPs nor the ASes are splitting anything here.
The SS7 side can send a group related ISUP message, e.g.,
CGB, using any 24 circuit range across 5000~5287.  I
guess this is legal for them to do so.

But this would cause the SG send the message to ASP-a if 
the CIC range in the CGB crosses the ASP boundary, or cause
one ASP to send it to AS-1 or AS-3 if crossing the AS 
boundary.

Joe 

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, December 27, 2002 5:08 PM
To: Wung, Joseph
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA distributing ISUP group messages

Joseph,

That would be up to the ASP.  If you want to make things easier
for the ASP, don't split circuit groups across AS either.

--brian

Wung, Joseph wrote:
(Fri, 27 Dec 2002 16:30:23)
> Brian,
> 
> "don't split up your circuit groups across ASPs" would
> solve the problem of distributing group messages for the
> SG.  What if an ASP serves multiple ASes, which cover
> a spectrum of contiguous CICs.  For example, an ASP
> serves AS1(CIC=5000~5071), AS2(CIC=5072~5143).  Now
> the ASP receives a message about CICs(5060~5083).
> How would the ASP distribute the received message to
> the ASes it serves?
> 
> Thanks,
> Joe
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, December 27, 2002 3:59 PM
> To: Wung, Joseph
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA distributing ISUP group messages
> 
> 
> Joseph,
> 
> Section A.2.1 says:
> 
>   "For example, where Application Servers are defined using ranges of
>    ISUP CIC values, the Operator is implicitly splitting up control of
>    the related circuit groups.  Some CIC value range assignments may
>    interfere with ISUP circuit group management procedures."
> 
> 
> The solution is: don't split up your circuit groups across ASPs: which
> makes sense anyway.
> 
> --brian
> 
> Wung, Joseph wrote:                              (Fri, 27 Dec 2002
15:14:38)
> > Each of the ISUP group related messages, i.e., CGB, CGU, GRS, GRA, etc.,
> has
> > a range field in addition to the CIC parameter that together specify a
> range
> > of circuits to operate on.  I would assume that the SGP that receives
> those
> > message would distribute them toward an ASP based on the CIC parameter
in
> > the messages without looking at the range field.  This may be ok if the
> > entire range fall into the same AS as the CIC.  What if the range
crosses
> > the boundary of the AS?  This may seem like an implementation dependent
> > issue, but it does impact how ISUP messages are distributed based on the
> > routing key.  Any solution?
> > 
> > Joe
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Sanjeev P.J" <[email-masked]>
Date: Thu, 02 Jan 2003 20:33:27 +0530

True. But the response can have "no indication" for the CICs outside the
range defined for the AS allowing the other end to resend the group message
with the modified range.

Can't this be done??

sanjeev.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Wung, Joseph
Sent: Thursday, January 02, 2003 8:34 PM
To: [email-masked]'
Cc: [email-masked]'
Subject: RE: [Sigtran] M3UA distributing ISUP group messages

Brian,

For example,

Joe

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Friday, December 27, 2002 5:08 PM
To: Wung, Joseph
Cc: [email-masked]'
Subject: Re: [Sigtran] M3UA distributing ISUP group messages

Joseph,

--brian

Wung, Joseph wrote:
15:14:38)
in
crosses

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 08:50:31 -0700

Sanjeev,

Sanjeev P.J wrote:                                                                 (Thu, 02 Jan 2003 20:46:45)
> range defined for the AS allowing the other end to resend the group message

Yes it could, but maintenance would probably be informed, generating log
records and possibly alarms.  It would not be a good way to go about things
in the normal course of events.

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 08:49:03 -0700

Joseph,

Several ways around that:

 o always configure your ISUP switches for pre-arranged circuit groups.

 o always configure your ISUP switches for the same circuit groups on
   both ends of the trunk.

Then you won't have this spanning problem.

But, don't expect me to justify CIC routing in M3UA: I don't think it
can work for a number of other reasons.  For example, what happens when
an IAM arrives for CIC=5288?  What AS does it go to?  Who sends back
REL(Unequipped CIC) and runs that whole part of the state machine?

When a remove ISUP is unavailable, where does DUPU get sent?  Which AS
is responsible for testing the availability of the remote ISUP?

When congestion occurs, which AS is responsible for detecting it an
placing ACL parameters into REL messages?

How much of the ISUP state machines must the SG implement before it can
route on CIC?

I think that, although one can loadshare on CIC, that routing on CIC
is a bad idea.  ISUP should be routed on OPC/DPC/SI=5 at maximum
granularity.  Then if one loadshares CIC over ASPs, it makes more sense.

At any rate, there is a lot of description missing from the M3UA spec
that would allow two implementation to interoperate properly as far as CIC
routing is concerned.

--brian

Wung, Joseph wrote:                        (Thu, 02 Jan 2003 09:39:43)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 08:50:31 -0700

Sanjeev,

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 08:49:03 -0700

Joseph,

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 08:50:31 -0700

Sanjeev,

--brian