Subject: Re: [Sigtran] I-D ACTION:draft-ietf-sigtran-m3ua-implementors-guide-02.txt

From: "TOLGA ASVEREN" <[email-masked]>
Date: Wed, 15 Jan 2003 13:35:13 +0200

Brian,
> Resend...
>
> Ken Morneault wrote:
> (Thu, 02 Jan 2003 09:05:39)
> >
> >
> > Brian,
> >
> > Please address your concerns to the entire group
> as your proposed
> > change is something for all to discuss.
> >
> > Regards,
> >
> > Ken
>
>
> SIGTRAN,
>
> Section 3.2.
>
> What does it matter if the SGP sends "Unsupported
> Message Type" or
> "Unsupported Message Class"?  Acutally, if we ever
> add a message to the class,
> "Unsupport Message Class" might no longer be
> correct, whereas "Unsupported
> Message Type" survives the addition of new message
> types to the class.
[TOLGA]Although IMO not very important to send which one still just my 2
cents: Personally I would prefer "Unsupported Message Class" because it
suits better for the case, where registration procedure and so all of the
related messages in the message class is not supported.
>
> Also, as the only necessary piece of information
> given in the Error message
> is the Message Class and Type, why force an
> implementation to include the
> first 40 bytes of the message?  That's ridiculous.
> All that needs to be
> included a couple bytes of the message header.
[TOLGA] For that I agree. For those error types, reporting message class
and type should be enough.
>
> Also, there is no more need to correlate this error
> than others.  The
> ASP is obviously misconfigured (it figures it can
> register with an SGP
> that does not even supoprt registration), so it
> really doesn't matter
> what happens to it: there are many ways to
> misconfigure an ASP so that
> it will not be caught by the protocol.
>
> Please strike section 3.2.
>
> Also note that M2UA and SUA also use the same text.
> It makes no sense to
> have M3UA act differently in this regard than M2UA
> and SUA.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 15 Jan 2003 05:11:26 -0700

TOLGA,

TOLGA ASVEREN wrote:                                                                 (Wed, 15 Jan 2003 13:35:13)
> related messages in the message class is not supported.

Well, the ASP didn't send every message type in the class, it just
sent one message type.  It is easy to conceiver that an implementation
could support DEREG REQ without supporting REG REQ.  When an ASP sends
DEREG REQ, it is responded to with a DEREG RSP with a Deregistration
Result indicating "Error - Not Registered".  So it is possible that
an implementation supports DEREG REQ without supporting REG REQ.

In fact, an SGP not supporting dynamic registration could easily
send REG RSP with Registration Result "Error - Unsupported RK parameter
field" or some such.  Just because an SGP "does not suppor the
registration procedure" does not mean that it cannot respond to
any message in the class.

At best, section 3.2 of the IG needs to be reworked in light of the
above.

Comments?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/