Subject: Re: [Sigtran] m3ua- IG

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 03:17:11 -0600 (CST)

Brian,

Will this full-blown SCCP perform GTT?.Of course, it performs.
But what will happen if the result is DPC+SSN?

To avoid this problem a node should support SUA or we should
perform GTT at remote peer.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

On Fri, 10 Jan 2003, Brian F. G. Bidulock wrote:

> Samuel,
> 
> In section 1.5.3, this is a full-blown SCCP above M3UA.  I don't
> think this section needs any modification.
> 
> --brian
> 
> On Fri, 10 Jan 2003, Samuel Dur D. Jeyaseelan wrote:
> 
> > 
> > Brian,
> > 
> > Ok, new changes hold good.
> > 
> > section 1.5.3
> > 
> > SCCP layer(an instance of the SS7 SCCP protocol layer) is placed above
> > M3UA layer and even performs GTT.
> > Once GTT is performed , nobody can restrict that result should be only
> > DPC, but result can be DPC/SSN also.
> > 
> > When you use M3UA , it conveys that your user-part services are
> > (including GTT) are offered remotely. So it causes little inconvenience
> > to view SCCP layer above M3UA.
> > 
> > --Samuel
> > 
> 
> -- 
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 02:31:58 -0700

Samuel,

Huh?  This is a normal MTP-User.  When the result is DPC/SSN it
formulates a message and sends it to the DPC using a MTP-TRANSFER
primitive to the M3UA acting as MTP Level 3.  There is no need
to support SSN RKs to acheive this.  SCCP is just a normal MTP
User in this case.  M3UA already supports MTP Users.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 03:17:11)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 03:59:45 -0600 (CST)

Brian,

See the mail below you said 'full-blown SCCP' which means matured sccp.
But now you are saying normal MTP-user.

Ok.Suppose GTT results in DPC+HLR.
Say under one SPMC we have Subsystetems HLR,ALR and LNP.

Now How does SGP know to route the message(DATA) to the particular(HLR)
SSN?

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 03:49:19 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 03:59:45)
> Now How does SGP know to route the message(DATA) to the particular(HLR)

It routes on DPC.

--brian

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 04:58:34 -0600 (CST)

Brian,

DPC is not consisting of only HLR but it also has LNP(Locan Number
Portability),ALR(Application Location Register).. under one SPMC.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 04:15:54 -0700

Samuel,

When SCCP sends these messages to MTP, they get routed through the
SS7 network on DPC only.  SCCP does not need any more service than
is provided by MTP.  So, things will work fine if M3UA routes on
DPC only.  M3UA no more needs to look at SSN than MTP does (and
MTP does not need to look at SSN, it uses DPC only).  Look at Q.714
routing rules to see how MTP transfers all messages on DPC only.
Only once the message gets to the DPC is SSN or GT examined by
SCCP to determine the proper SCCP-User.

So, in the example in 1.5.3, SCCP is acting as a normal MTP-User.
It sends messages to MTP with MTP-TRANSFER primitive and expects
them to be routed by MTP on the DPC, without reference to the SSN.
To provide correct service to SCCP, M3UA must do the same.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 04:58:34)

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 07:12:22 -0600 (CST)

Brian,

So, this normal MTP-User will not perform GTT?

if it performs see the following case
 
SCCP finds SSN (say GTT resulted DPC+SSN)as prohibited, MTP can not route
this message successfully with DPC alone.This case WHEN will this SSN will
become unprohibited, until you get a message from ASP saying 'now SSN is
not prohibited' Is it not so?

if it so Which M3UA message carries this information from ASP to SG?

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 06:24:25 -0700

Samuel,

You are confused:

 - MTP routes messages on DPC.
 - SCCP runs over MTP (today in SS7 network).
 - SCCP does not need M3UA to route on SSN to support it.

Read Q.714.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 07:12:22)

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 07:34:41 -0600 (CST)

Brian,

You misinterpreted my mail.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 06:41:12 -0700

Samuel,

> > > SCCP finds SSN (say GTT resulted DPC+SSN)as prohibited, MTP can not route
                                                              ^^^^^^^^^^^^^^^^^
> > > this message successfully with DPC alone.This case WHEN will this SSN will
      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

MTP routes all messages by DPC alone.

Read Q.704.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 07:34:41)

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 07:48:42 -0600 (CST)

Brian,

Meant to say that SCCP finds SSN as prohibited and this message is being 
given to MTP3. But MTP cannot route this message successfully even though
dpc is perfect to the point of MTP3.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 10 Jan 2003 06:51:23 -0700

Samuel,

Read Q.714.  SCCP does not send messages to MTP for prohibited SSNs.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 10 Jan 2003 07:48:42)

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 10 Jan 2003 08:10:29 -0600 (CST)

Brian,
Thanks, let me go through it.

--Samuel