Subject: Re: [Sigtran] Routing Key

From: Tolga Asveren <[email-masked]>
Date: Wed, 1 Jan 2003 04:49:45 -0800 (PST)

Brian,
> > > Chak,
> > > 
> > > I said that M3UA does not *_register_* SCCP
> users.  M3UA makes no
> > > restrictions on what is used as a static routing
> key.  SSN and TID were
> > > removed from the M3UA Routing Key parameter
> because M3UA does not support
> > > SCCP or TCAP users.  To support SCCP properly
> would require doing most of
> > > the things that SUA already does.
> > > 
> > > CIC is included in the M3UA Routing Key, and
> yet, M3UA has little to no
> > > support for ISUP as anything but an MTP-User. 
> The only reason for leaving
> > > CIC was the lack of an ISUP-UA.
> > > 
> > > There is a long thread from July/Aug 2001, which
> was M3UA Issue 6 at Last
> > > Call entitled:
> > > 
> > > 	"M3UAv8: SSN in Routing Key and TCAP TID in
> example."
> > > 
> > > Concensus was to remove SSN and TID from routing
> (both examples and
> > > Routing Key parameter).  It looks like it was
> never properly removed from
> > > the examples.
> > > 
> > > I would propose that the M3UA IG say that
> > > 
> > >    "Although it is provided in several examples,
> routing keys based on SSN
> > >    is not supported by M3UA."
> > [TOLGA]Although I agree that M3UA is not very
> suitable for SSN based RKs,
> > still such a sentence would contradict with the
> statement that there is no
> > limit/restriction for RKs. If somebody can/want
> support SSN based RKs(or
> > something else) IMO they should be free to do so.
> 
> They are also free to invent their own private
> protocol, and that's what
> they'll be doing.
> 
> Unlimited routing keys and interoperability are at
> cross purposes.   It was
> agreed that M3UA routing keys should stick to MTP3
> information with the
> possible exception of CIC for ISUP/TUP (which in
> some cases overlaps with SLS
> anyway).
> 
> More embellishments of routing key will only result
> in proprietary
> implementations that don't interoperate.  The IETF
> doesn't waste its time on
> such stuff.
[TOLGA] If a node supports this just by itself -with
no additional requirement to the on the wire
protocol/procedures-, IMO this should be allowed, and
there is no need to add anything to the existing M3UA
documents. 

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 1 Jan 2003 06:00:14 -0700

Tolga,

Tolga Asveren wrote:                                                                 (Wed, 01 Jan 2003 04:49:45)
> > 
> > They are also free to invent their own private protocol, and that's what
> > they'll be doing.
> > 
> > Unlimited routing keys and interoperability are at cross purposes.   It
> > was agreed that M3UA routing keys should stick to MTP3 information with
> > the possible exception of CIC for ISUP/TUP (which in some cases overlaps
> > with SLS anyway).
> > 
> > More embellishments of routing key will only result in proprietary
> > implementations that don't interoperate.  The IETF doesn't waste its time
> > on such stuff.
> [TOLGA] If a node supports this just by itself -with no additional
> requirement to the on the wire protocol/procedures-, IMO this should be
> allowed, and there is no need to add anything to the existing M3UA
> documents. 

But that is not the case with SSN in Routing Keys.  It is also not the
case for CIC for that matter.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Wed, 1 Jan 2003 13:17:39 -0800 (PST)

Brian,
> case for CIC for that matter.
[TOLGA] Why? I would expect that necessary changes on
a SG to support SSN based routing is, to
filter/regenerate/imitate some SCCP management
messages. Those changes, I would consider as changes
to NIF not to the on the wire M3UA protocol.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 1 Jan 2003 15:00:35 -0700

Tolga,

Tolga Asveren wrote:                                   (Wed, 01 Jan 2003 13:17:39)
> [TOLGA] Why? I would expect that necessary changes on a SG to support SSN
> based routing is, to filter/regenerate/imitate some SCCP management
> messages. Those changes, I would consider as changes to NIF not to the on
> the wire M3UA protocol. 

Read the thread.

--brian

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 2 Jan 2003 05:05:43 -0800 (PST)

Brian,
--- "Brian F. G. Bidulock" <[email-masked]>
> changes to NIF not to the on
[TOLGA] Which one/time?

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 06:20:46 -0700

Tolga,

Tolga Asveren wrote:                        (Thu, 02 Jan 2003 05:05:43)
> [TOLGA] Which one/time?

See my third note on *this* thread.

--brian

---

From: "Sanjeev P.J" <[email-masked]>
Date: Thu, 02 Jan 2003 18:42:55 +0530

Couldn't the Network Appearance be used for this?

-Sanjeev.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Brian F. G. Bidulock
Sent: Thursday, January 02, 2003 4:53 AM
To: Tolga Asveren
Cc: [email-masked]
Subject: Re: [Sigtran] Routing Key

Tolga,

Tolga Asveren wrote:                                   (Wed, 01 Jan 2003
13:17:39)

Read the thread.

--brian

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 06:33:01 -0700

Sanjeev,

Sanjeev P.J wrote:                                 (Thu, 02 Jan 2003 18:56:12)
> Couldn't the Network Appearance be used for this?

No.

--brian

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 2 Jan 2003 16:23:35 -0800 (PST)

> See my third note on *this* thread.
[TOLGA] I still don't see why any change is necessary
for the on the wire M3UA protocol to support SSN based
routing for class0/class1 SCCP. One migth need to
implement most of SUA/SCCP management functiuonality
in NIF, but this is not a change to M3UA protocol
itself.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 2 Jan 2003 17:45:00 -0700

Tolga,

Tolga Asveren wrote:             (Thu, 02 Jan 2003 16:23:35)
> in NIF, but this is not a change to M3UA protocol

The client needs to know what it is a client of.

--brian