Subject: RE: [Sigtran] Re: M3UA Congestion Procedures

From: "Wung, Joseph" <[email-masked]>
Date: Thu, 27 Mar 2003 09:27:11 -0500

Brian,

> > 
> > I agree with what you said about how SCON should be used.  
> SCON should
> > only be sent in the direction from SGP to ASP.  Can you explain what
> > the protocol also says about SCON as quoted below.
> > 
> > 	"3.4.4  The SCON message MAY also be sent from the M3UA layer
> > 	of an ASP to an M3UA peer indicating that the M3UA layer of the 
> > 	ASP is congested."
> 
> This is there to accomodate the Q.704/11.2.6 nodal TFC case 
> where the ASP
> is connected to multiple SGs acting as STPs.
> 

Is not the M3UA used between MTP and MTP-users even in the case where 
the ASP is connected to multiple SGs acting as STPs?  If SCON can't be 
sent from ASP to SGP due to the buffer congestion between SGP (i.e.,MTP) 
and ASP (i.e., MTP-user), can you tell me under what condition the
ASP is supposed to send SCON?

Thanks,
Joe
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 27 Mar 2003 15:47:53 -0700

Wung,,

Wung, Joseph wrote:                                                                  (Thu, 27 Mar 2003 09:27:11)
> ASP is supposed to send SCON?

Q.704/11.2.6 doesn't say anything about direction.  It says that an SP can
generate TFC in response to congestion at the signalling point.  When the
ASP is acting as an SP connected to mutliple SGs acting as STPs, then the
ASP might need to be able to generate the equivalent of a TFC message (i.e,
SCON) due to its implementation of Q.704/11.2.6.  After all, the RFC does
way "MAY".

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/