Subject: Re: [Sigtran] Re: IUA: Error codes and misconfiguration

From: [email-masked]
Date: Mon, 10 Mar 2003 09:59:22 +0530

Hi Ken,

>Kameshwar,
>
>There is not a mismatch of states at the SG and the ASP so
>there is no reason for the SG to send Error for all IIDs.
>
>Regards,
>
>Ken

Why is this so? When the SG side stack gets ASPAC for IIDs 1 to 10, it includes
IIDs 1 to 5, so we have sent
ASPAC ACK for those IIDs. It means that at the SG side the ASP for which ASPAC
was recieved is now active, right?
Whereas at ASP side, since it is getting Errors for some IIDs, the ASP side
stack cannot assume that it has recieved an
ASPAC ack properly. So the ASP cannot go active and it will report an error to
it's SM. So the state of the ASP is active
at SG side and inactive at ASP side.

regards

kameshwar

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Mon, 10 Mar 2003 08:27:57 -0500

Kameshwar,

Pls see below.

Ken

>at SG side and inactive at ASP side.

The ASP side received ASPAC Ack for IIDs 1-5 so it knows they
are active and treats these IIDs as Active.  It also knows from the 
error messages that the SG does not have IIDs 6-10 provisioned.