Subject: RE: [Sigtran] ASP and SGP in load sharing mode

From: James Doss <[email-masked]>
Date: Mon, 17 Mar 2003 10:23:54 -0800

Hi Kartik,
Thanks for the info.I think that looks to be a good idea but I am not sure
whether the transaction Id will be stored by the SGP 1 or 2 till it receives
any response as the SGPs only route the messages.Moreover the transaction Id
is part of TCAP-Dlg portion and will the SGP be able to extract and store
for load sharing purposes.
I have not seen any referencing in the M3UA/SU spec which deals about the
proprietary algorithms in load sharing mode.
Thanks 
James

-----Original Message-----
From: Kartik Gupta [mailto:[email-masked]]
Sent: Monday, March 17, 2003 10:48 AM
To: James Doss; [email-masked]'
Subject: Re: [Sigtran] ASP and SGP in load sharing mode

Hi James,

In load sharing mode, it is assumed that both the ASP (ASP1 and ASP2) are
capable
of handling traffic for the AS (Server 1). It is responsibility of routing
entity
(SGP2) to avoid mis-sequencing. Now depending on the loadsharing algorithm
at
SGP2, the response may be sent to either of the ASP. If you need same ASP to
receive
the response, then use TCAP transaction id as one of the parameters in your
loadsharing algorithm at SGP1 and SGP2.

--Kartik
CommInventors
www.comminventors.com

> Hi,
> Can the SGP route the responses to the ASP which originated the query.
> Assuming we have ASP1 and ASP2 runs in two different servers(AS1) in a
load
> sharing mode, connected two SGPS SGP1 and SGP2.
> I want to know whether the following scenario will work:
> 
> (1) ASP1 from server 1 originates a TCAP query to a remote destination
thru
> SGP1
> 
> (2) The remote destination has two routes route 1 thru SGP1 and route 2
thru
> SGP2.
> 
> (3) The remote destination returns the Response to SGP2.
> 
>  Will the SGP2 route the message to the same application(ASP1) which
> originated the messages using Routing Key.
>   or in load sharing mode it will send to any ASPs registered with the
SGP.
> 
> Thanks and regards
> James
> Verisign Inc
> Norcross GA
> 
> 
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Mar 2003 13:23:51 -0700

James,

Use SUA, or better still TUA.

--brian

James Doss wrote:                                                                    (Mon, 17 Mar 2003 10:23:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/