Subject: [Sigtran] IUA: Error codes and misconfiguration

From: [email-masked]
Date: Thu, 6 Mar 2003 12:53:19 +0530

Hi,

   I have a couple of queries on the IUA RFC and IG. Section "3.3.3.1" of the
RFC says that:

  "The "Invalid TEI, SAPI combination" error identify errors where the TEI is
assigned and the   the SAPI is recognized, but the
    combination is not valid for the interface (e.g., on a BRI the MGC tries to
send Q.921 Management messages via IUA when Layer
   Management at the SG SHOULD be performing  this function)."

I could not appreciate the example given. Are there any other examples of
messages where TEI is assigned and the SAPI
is proper but this error needs to be transmitted.

  In the IG-01 section "3.20.2" says :

  This scenario shows the example IUA message flows for the establishment of
traffic between an SG and an ASP in which some
   of the Interface Identifiers have been misconfigured on the ASP side.  The SG
in this case has Interface Identifers 1-5
   configured for ASP1.

                SG                               ASP1
                 |                                |
                 |                                |
                 |<----ASP Active (IIDs 1-10)-----|
                 |---ASP Active Ack (IIDs 1-5)--->|
                 |-------Error (IIDs 6)---------->|
                 |-------Error (IIDs 7)---------->|
                 |-------Error (IIDs 8)---------->|
                 |-------Error (IIDs 9)---------->|
                 |-------Error (IIDs 10)--------->|
                 |                                |

In this example flow,  how will the IID be packaged in the error message? The
error message has only the error cause as the
mandatory parameter. Also what should be the recommended behaviour of the SG
side on receiving ASPAC ACK for only a subset
of the IIDs it sent ASPAC for. Should it just inform it's SM or update it's own
state that this ASP serves only the ACKed IIDs.

Thanks

kameshwar

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Thu, 06 Mar 2003 09:25:09 -0500

Kameshwar,

Pls see below.

Regards,

Ken

>is proper but this error needs to be transmitted.

For the given configuration in the example, it's not that the SAPI is
not proper, just not appropriate for the configuration.

>mandatory parameter. 

Please see Section 3.19.2 of the IG.  The Diagnostic information contains
the invalid IID.

>Also what should be the recommended behaviour of the SG

Per the RFC, the SG must consider all IIDs provisioned for that ASP to
be Active.  It is optional to notify its SM.