Subject: Re: [Sigtran] M3UA: RC in Deregistration

From: [email-masked]
Date: Fri, 14 Mar 2003 14:28:24 +0530

Sibi..

         There is no contradiction as such . This is because the ASP is
deregistering itself from a Routing key only .
But since in response to the Registration request that it sent to its peer
containing the Routing key, it was returned a unique
Routing context value , so now when it has to deregister itself from an
AS/routing key corresponding to that AS, it can send
the Routing context value (returned by the peer) only  that uniquely identifies
that Routing key at ASPs peer..

Thanks
Anjali
www.hssworld.com

"Sibi George" <[email-masked]> on 03/14/2003 02:30:46 PM

To:   Anjali Gurmukhani/HSS@HSS
cc:

Subject:  Re: [Sigtran] M3UA: RC in Deregistration

hi,
  I misinterpreted the statement ,
 The RC doesnot contain a list of integers, infact
it is the RC parameter that contains.
  I misinterpreted the statement because of the section...

3.6.3 Deregistration Request (DEREG REQ)

   The DEREG REQ message is sent by an ASP to indicate to a remote M3UA
   peer that it wishes to deregister a given Routing Key.  Typically, an
   ASP would send this message to an SGP, and expects to receive a DEREG
   RSP message in return with the associated Routing Context value.

where it says that DEREG message is sent to deregister a given routing
key.....
there is a contradiction in the explanation in the beginning of section
3.6.3
and  the format of the DEREG message where multiple RC's are shown
why this contradction??

thanks
sibi

----- Original Message -----
From: <[email-masked]>
To: "Sibi George" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, March 14, 2003 2:08 PM
Subject: Re: [Sigtran] M3UA: RC in Deregistration

SIbi..

    When a ASP sends Registration request message to SGP, it can include
multiple Routing Keys to which it wants
to register itself. So in response to such a request, SGP sends routing
context
values  unique and distinct  for each routing
key that was sent in the registration request .
Now consider this ASP wanting to remove itself from the AS's it had
registered
previously, so it sends a dereg request
with the Routing context values of the AS's it wants to remove itself from.

The list of integers refers to the routing context values and not the point
codes.

Thanks
Anjali
www.hssworld.com

"Sibi George" <[email-masked]> on 03/14/2003 11:56:22 AM

To:   [email-masked]
cc:    (bcc: Anjali Gurmukhani/HSS)

Subject:  [Sigtran] M3UA: RC in Deregistration

hi,
  in section 3.6.3,
   The Deregistration Request message contains the RC(Routing Context)
  whose functional description is as follows explained in the RFC.

    " The Routing Context parameter contains (a list of) integers
      indexing the Application Server traffic that the sending ASP is
      currently registered to receive from the SGP but now wishes to
      deregister."

      If an ASP serves more than one AS , each AS is represented by
 a RC ,
    What does it mean that RC contains a list of integers ? Does the list
of integers represent the list of DPC's which may be part of the same
routing key during registration?

somebody throw some light regarding this......

thanks
sibi

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Sibi George" <[email-masked]>
Date: Fri, 14 Mar 2003 14:57:16 +0530

hi,
  If the deregistraion is for a routing key only
then

in section 3.6.3,
    0                   1                   2                   3
       0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      |         Tag = 0x0006          |            Length             |
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
      \                                                               \
      /                       Routing Context                         /
      \                                                               \
      +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

   Routing Context   : n X 32-bit integers

   why the n when n is 1,
 the text description has to be changed to "one or
more " instead of "a" .... as mentioned in the REG req
message for multiple RK's.

thanks
sibi

----- Original Message -----
From: <[email-masked]>
To: "Sibi George" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, March 14, 2003 2:28 PM
Subject: Re: [Sigtran] M3UA: RC in Deregistration

Sibi..

the Routing context value (returned by the peer) only  that uniquely
identifies

Thanks
Anjali
www.hssworld.com

hi,

thanks
sibi

----- Original Message -----
From: <[email-masked]>
To: "Sibi George" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, March 14, 2003 2:08 PM
Subject: Re: [Sigtran] M3UA: RC in Deregistration

SIbi..

Thanks
Anjali
www.hssworld.com

To:   [email-masked]

hi,
  in section 3.6.3,

thanks
sibi