Subject: [Sigtran] M3UA IG v03

From: "Javier Pastor-Balbas (ECE)" <[email-masked]>
Date: Fri, 7 Mar 2003 08:09:03 +0100

Hi guys, 

A new version of the M3UA Implementors Guide was submitted before the cuttoff. As it will take some time in getting published, here we send the link where you can find it. 

Please note that section 3.15 has not been still modified. We are waiting for a conclusion on the n+k issue, that will hopefully come before the next version.

http://standards.ericsson.net/javier/draft-ietf-sigtran-m3ua-implementors-guide-03.txt

Waiting for your comments...

BR  // Ken and Javier.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 7 Mar 2003 01:26:24 -0700

Javier,

Javier Pastor-Balbas (ECE) wrote:                                                   (Fri, 07 Mar 2003 08:09:03)
> 
> Hi guys, 
> 
> A new version of the M3UA Implementors Guide was submitted before the
> cuttoff. As it will take some time in getting published, here we send the
> link where you can find it. 
> 
> Please note that section 3.15 has not been still modified. We are waiting
> for a conclusion on the n+k issue, that will hopefully come before the next
> version.

You "are" waiting or "were" waiting?

I thought we concluded on the thread that `n' is the maximum engineered load
number and that 3.15 is not applicable.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 7 Mar 2003 03:32:29 -0600 (CST)

Pastor,

I thought it(n+k reduntancy) was concluded with the following points

1)'n' is mandatory while system comes up.
2)when #ASPs<n (where n>0), AS state should be in AS_ACTIVE instead
  of PENDING.

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 7 Mar 2003 02:37:46 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 07 Mar 2003 03:32:29)
> 2)when #ASPs<n (where n>0), AS state should be in AS_ACTIVE instead

Sounds like the RFC...

--brian

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 7 Mar 2003 04:05:12 -0600 (CST)

Brian,

> > 2)when #ASPs<n (where n>0), AS state should be in AS_ACTIVE instead
IG says 
old text:
    AS-PENDING: An active ASP has transitioned to ASP-INACTIVE or ASP-
    DOWN  and it was the last remaining active ASP in the AS.  A recovery
    ...
new text:
    AS-PENDING: An active ASP has transitioned from ASP-ACTIVE to ASP-
    INACTIVE or ASP-DOWN and it was the number n active ASP in the AS.  A
    ...

point 1 is mentioned in RFC but point 2 should be clarified in IG.
--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 7 Mar 2003 03:18:32 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 07 Mar 2003 04:05:12)
> point 1 is mentioned in RFC but point 2 should be clarified in IG.

Huh?

Point 1 is in the RFC: (4.3.4.3)

   For the n+k redundancy case, ASPs which are in that AS should
   coordinate among themselves the number of active ASPs in the AS, and
   should start sending traffic only after n ASPs are active.

Point 2 is in the RFC: (4.3.2)

   AS-INACTIVE: The Application Server is available but no application
   traffic is active (i.e., one or more related ASPs are in the ASP-
   INACTIVE state, but none in the ASP-ACTIVE state).  The recovery
   timer T(r) is not running or has expired.

   AS-PENDING: An active ASP has transitioned to ASP-INACTIVE or ASP-
   DOWN and it was the last remaining active ASP in the AS.  A recovery
   timer T(r) SHOULD be started and all incoming signalling messages
   SHOULD be queued by the SGP. If an ASP becomes ASP-ACTIVE before T(r)
   expires, the AS is moved to the AS-ACTIVE state and all the queued
   messages will be sent to the ASP.

What did you think needed to be clarified?

--brian

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 7 Mar 2003 05:03:58 -0600 (CST)

Brian,

> What did you think needed to be clarified?
section 4.3.2 does not say anything about n ASPs.There was a thread which 
discussed that minimum 2 ASPs are required to handle the traffic for 
n+k redundancy case, when one of the ASPs goes down, then the AS state
will be moved to PENDING.But i said AS state will remain in ACTIVE and
the traffic will be rerouted to the ACTIVE ASP. When SGP transmission
buffer or re-transmission buffer or both get congested or SCON
received from ASP,SGP can send NTFY to spare ASP and change the AS state
to pending.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 7 Mar 2003 04:21:28 -0700

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 07 Mar 2003 05:03:58)
> received from ASP,SGP can send NTFY to spare ASP and change the AS state

   Section 4.3.2:

   AS-ACTIVE: The Application Server is available and application
   traffic is active.  This state implies that at least one ASP is in
   the ASP-ACTIVE state.

This says that when 1 ASP is active for the AS, the AS is considered
AS-ACTIVE, regardless of 'n'.  This is precisely your point 2 above.
It is stated in the RFC and doesn't need further clarification.

--brian