Subject: [Sigtran] Re: IUA: Error codes and misconfiguration

From: [email-masked]
Date: Fri, 7 Mar 2003 10:59:44 +0530

Hi ken,

>  "The "Invalid TEI, SAPI combination" error identify errors where the TEI is
>assigned and the   the SAPI is recognized, but the
>    combination is not valid for the interface (e.g., on a BRI the MGC tries to
>send Q.921 Management messages via IUA when Layer
>   Management at the SG SHOULD be performing  this function)."
>
>I could not appreciate the example given. Are there any other examples of
>messages where TEI is assigned and the SAPI
>is proper but this error needs to be transmitted.

For the given configuration in the example, it's not that the SAPI is
not proper, just not appropriate for the configuration.

>>>>>  Q921 says

>>>>>>>"All layer management entity PDUs used for these TEI management
procedures are transmitted to, or received from, the data link layer
>>>>>>>entity in the form of SDUs using the MDL-UNIT DATA request primitive, or
the MDL-UNIT DATA indication primitive, respectively. >>>>>>The data link layer
entity shall transmit SDUs for the support of management procedures in UI
command frames. The SAPI value shall be >>>>>>63. The TEI value shall be 127."

>>>>>Is this something related to "invalid TEI and SAPI combination" suppose IUA
gets unit data indication for SAPI 63 and TEI 2  ??

>  In the IG-01 section "3.20.2" says :
>
>  This scenario shows the example IUA message flows for the establishment of
>traffic between an SG and an ASP in which some
>   of the Interface Identifiers have been misconfigured on the ASP side.  The
SG
>in this case has Interface Identifers 1-5
>   configured for ASP1.
>
>                SG                               ASP1
>                 |                                |
>                 |                                |
>                 |<----ASP Active (IIDs 1-10)-----|
>                 |---ASP Active Ack (IIDs 1-5)--->|
>                 |-------Error (IIDs 6)---------->|
>                 |-------Error (IIDs 7)---------->|
>                 |-------Error (IIDs 8)---------->|
>                 |-------Error (IIDs 9)---------->|
>                 |-------Error (IIDs 10)--------->|
>                 |                                |
>Also what should be the recommended behaviour of the SG
>side on receiving ASPAC ACK for only a subset
>of the IIDs it sent ASPAC for. Should it just inform it's SM or update it's own
>state that this ASP serves only the ACKed IIDs.

Per the RFC, the SG must consider all IIDs provisioned for that ASP to
be Active.  It is optional to notify its SM.

>>>>>> Sorry, what i meant was that what should the ASP side stack do when it
>>>>>> gets ASPAC ACK for a subset of the IIDs it sent ASPAC for to the SG side.
>>>>>> Is it really advisable that ASP side stack update it's configuration to
>>>>>> reflect the configuration at SG side.

thanks

kameshwar

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Fri, 07 Mar 2003 09:27:22 -0500

Kameshwar,

Pls see below.

Ken

>gets unit data indication for SAPI 63 and TEI 2  ??

Yes, this would be a case of invalid TEI/SAPI combo.

>>>>>>> reflect the configuration at SG side.

I would not recommend having the ASP update its configuration to reflect
the configuration on the SG.  These errors indicate a mis-configuration so
ideally the operator would be notified so that they could fix the configuration
problem.