Subject: RE: [Sigtran] Re: M3UA Congestion Procedures

From: "Wung, Joseph" <[email-masked]>
Date: Wed, 26 Mar 2003 10:09:16 -0500

Brian,

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Wednesday, March 26, 2003 9:19 AM
> To: [email-masked]
> Cc: ksrinivas; [email-masked]
> Subject: Re: [Sigtran] Re: M3UA Congestion Procedures
> 
> 
> kakaul,
> 
> You are mistaking MTP/MTP-User interface implementation congestion for
> SS7 network congestion.  SCON is only used for SS7 network congestion.
> 
> SCON should never be used to indicate SCTP receive buffer occupancy.
> SCTP receive buffer occupancy will always translate to SCTP transmit
> buffer occupancy at the peer and no M3UA message is necessary for the
> sender to determine that the receiver is failing to service its
> receive buffer in time.
> 
> SCON must be reserved for the indication of SS7 network congestion to
> the MTP User in response to MTP-STATUS primitives from MTP.  M3UA at
> an SG should never otherwise send SCON.
>

I agree with what you said about how SCON should be used.  SCON should
only be sent in the direction from SGP to ASP.  Can you explain what
the protocol also says about SCON as quoted below.

	"3.4.4  The SCON message MAY also be sent from the M3UA layer
	of an ASP to an M3UA peer indicating that the M3UA layer of the 
	ASP is congested."

> Please see "M3UA: Route-set congestion" thread from over a year ago.
> 
> --brian
> 
>

Joe
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Mar 2003 08:21:27 -0700

Wung,,

Wung, Joseph wrote:                                                                  (Wed, 26 Mar 2003 10:09:16)
> 	of an ASP to an M3UA peer indicating that the M3UA layer of the 

This is there to accomodate the Q.704/11.2.6 nodal TFC case where the ASP
is connected to multiple SGs acting as STPs.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: ksrinivas <[email-masked]>
Date: Thu, 27 Mar 2003 10:42:42 +0530

Brian,

Can you please tell me how to get the "M3UA: Route-set congestion" thread from the mail archives?.

--Srini

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Mar 2003 23:35:10 -0700

ksrinivas,

The thread extends from Jul 26 2001 to Jul 31 2001.  You will find the
thread in:

	ftp://ftp.ietf.org/ietf-mail-archives/sigtran/2001-08.mail

--brian

ksrinivas wrote:                                                                 (Thu, 27 Mar 2003 10:42:42)

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 26 Mar 2003 23:35:10 -0700

ksrinivas,

--brian