Subject: [Sigtran] ASP and SGP in load sharing mode

From: James Doss <[email-masked]>
Date: Mon, 17 Mar 2003 06:56:35 -0800

Hi,
Can the SGP route the responses to the ASP which originated the query.
Assuming we have ASP1 and ASP2 runs in two different servers(AS1) in a load
sharing mode, connected two SGPS SGP1 and SGP2.
I want to know whether the following scenario will work:

(1) ASP1 from server 1 originates a TCAP query to a remote destination thru
SGP1

(2) The remote destination has two routes route 1 thru SGP1 and route 2 thru
SGP2.

(3) The remote destination returns the Response to SGP2.

 Will the SGP2 route the message to the same application(ASP1) which
originated the messages using Routing Key.
  or in load sharing mode it will send to any ASPs registered with the SGP.

Thanks and regards
James
Verisign Inc
Norcross GA

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "TOLGA ASVEREN" <[email-masked]>
Date: Mon, 17 Mar 2003 18:04:08 +0200

Hi James,

How messages are distributed between loadsharing ASPs serving the same AS
is implementation dependent (even if there were only one SGP in your
example, still this wouldn't change a lot regarding your question). Please
note, in that configuration, you can't use RK to decide which ASP (ASP1 or
ASP2) to choose because both of them are ACTIVE for AS1.
What you are asking for seems doable to me with a suitable loadsharing
mechanism on SG (assuming state synchronization is taken care of on ASPs to
handle failure cases and any necessary information to loadshare responses
to the correct ASP is shared between SGPs)

     Tolga

Hi,

(2) The remote destination has two routes route 1 thru SGP1 and route 2
thru
SGP2.

Thanks and regards
James
Verisign Inc
Norcross GA

---

From: James Doss <[email-masked]>
Date: Mon, 17 Mar 2003 14:50:58 -0800

Thanks a lot 
James

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, March 17, 2003 5:45 PM
To: James Doss
Cc: 'Kartik Gupta'; [email-masked]'
Subject: Re: [Sigtran] ASP and SGP in load sharing mode

James,

James Doss wrote:                                  (Mon, 17 Mar 2003
13:47:28)
> Hi Brian,
> Thanks for the info.The SUA layer routing key information talks about
> transaction Id based -Routing Key. But I am not sure our SGP vendor will
> support SUA or not. TUA is not an approved spec so far.I am left with M3UA
> as only option. If we continue using M3UA and is it possible to have
> proprietary algorithm to distribute the messages to the ASPs in different
AS
> (as per Kartik).
> Thanks 

I'm sure your SGP vendor supports SUA; but we shouldn't speak of specific
vendors on this list.  Contact your vendor and I'm sure they will be more
than willing to discuss SUA with you.

There are many problems in using SSN or TID as a RK in M3UA.  There is a
long thread starting Jul 30, 2001 entitled "M3UAv8: SSN in Routing Key and
TCAP TID in example" that discusses some of the problems.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "TOLGA ASVEREN" <[email-masked]>
Date: Tue, 18 Mar 2003 07:21:00 +0200

James,

What Kartik is proposing is not to use separete RKs but to use loadsharing
based on transactionId (your original question was about two ASPs serving
the same AS).

  Tolga

Hi Brian,

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, March 17, 2003 3:24 PM
To: James Doss
Cc: 'Kartik Gupta'; [email-masked]'
Subject: Re: [Sigtran] ASP and SGP in load sharing mode

James,

Use SUA, or better still TUA.

--brian

James Doss wrote:
(Mon, 17 Mar 2003 10:23:54)
> Hi Kartik,
> Thanks for the info.I think that looks to be a good idea but I am not
sure
> whether the transaction Id will be stored by the SGP 1 or 2 till it
receives
> any response as the SGPs only route the messages.Moreover the transaction
Id
> is part of TCAP-Dlg portion and will the SGP be able to extract and store
> for load sharing purposes.
> I have not seen any referencing in the M3UA/SU spec which deals about the
> proprietary algorithms in load sharing mode.
> Thanks
> James
>
>
>
> From: Kartik Gupta [mailto:[email-masked]]
> Sent: Monday, March 17, 2003 10:48 AM
> To: James Doss; [email-masked]'
> In load sharing mode, it is assumed that both the ASP (ASP1 and ASP2) are
> capable
> of handling traffic for the AS (Server 1). It is responsibility of
routing
> entity
> (SGP2) to avoid mis-sequencing. Now depending on the loadsharing
algorithm
> at
> SGP2, the response may be sent to either of the ASP. If you need same ASP
to
> receive
> the response, then use TCAP transaction id as one of the parameters in
your
> loadsharing algorithm at SGP1 and SGP2.
>
> --Kartik
> CommInventors
> www.comminventors.com
>
> > Hi,