Subject: Re: [Sigtran] M2PA: Revised section 4.1

From: [email-masked]
Date: Thu, 13 Mar 2003 15:07:20 -0500

Hello Tom,

>If the peer is in the PROCESSOR OUTAGE state, it enters the IN SERVICE
>state and uses the Remote Processor Recovered Indication to notify its
>MTP3 that the remote processor outage condition has ceased. M2PA SHALL
>restart timer T7 for any messages in its retransmission buffer.

I believe that this paragraph is in error. M2PA should move from
PROCESSOR_OUTAGE to IN_SERVICE upon receiving either MTP3 Flush or
MTP3 Continue when no processor outage is in effect. Receiving either
LPR or LSPOE is not sufficient for M2PA to make the transition.
(Q.703 Figure 8 sheet 13).

Regards,

Jeff

                      Tom George                                                                                                  
                      <Tom.George@alca         To:                                                                                
                      tel.com>                 cc:      [email-masked]                                                          
                      Sent by:                 Subject: Re: [Sigtran] M2PA: Revised section 4.1                                   
                      sigtran-admin@ie                                                                                            
                      tf.org                                                                                                      

                      03/13/03 02:34                                                                                              
                      PM                                                                                                          

Barry,

That sounds better. Combining this with your other comment, the last 2
paragraphs in that section would now say this:

===================
When the processor outage ceases, MTP3 sends a Local Processor
Recovered indication to M2PA. The local M2PA SHALL notify its peer by
sending a Link Status Processor Recovered message. The local M2PA
SHALL resume receiving and transmitting messages.

If the peer is in the PROCESSOR OUTAGE state, it enters the IN SERVICE
state and uses the Remote Processor Recovered Indication to notify its
MTP3 that the remote processor outage condition has ceased. M2PA SHALL
restart timer T7 for any messages in its retransmission buffer.
===================

tomG.

[email-masked] wrote:
>
> Tom,
>
> Now that we have a Processor Outage state, we should probably change the
> following paragraph of section 4.1.4 from
>
> "If the peer is in the IN SERVICE state, it uses the Remote Processor
> Recovered Indication to notify its MTP3 that the remote processor
> outage condition has ceased."
>
> to
>
> "If the peer is in the PROCESSOR OUTAGE state, it transitions to the
> IN SERVICE state and then uses the Remote Processor Recovered Indication
> to notify its MTP3 that the remote processor outage condition has
ceased."
> Barry Nagelberg
  [...]

--
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 13 Mar 2003 13:38:22 -0700

jeffrey.craig,

[email-masked] wrote:                                             (Thu, 13 Mar 2003 15:07:20)
> (Q.703 Figure 8 sheet 13).

Yes, Q.703 SDLs have the link hanging around in processor outage state
(with processor outage flags clear, and sending FISU) awaiting a primitive
from MTP3 indicating whether to go proceed or to flush buffers and proceed
or stop.  This is only a transient condition in Q.703 (processor outage
state with processor outage clear) whereas the processor outage state with
processor outage set is far from transient.

Recreating Q.703 SDLs in a single diagram will take a few more pages of
ASCII art.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Rohan" <[email-masked]>
Date: Fri, 14 Mar 2003 10:59:14 +0530

Tom,
    I do agree with Brian that it may not be feasible to represent all Q.703
SDL's with a single  M2PA state machine diagram.
But in my opinion it is worth mentioning in the text regarding this
transiton from Processor outage to INSERVICE. i.e
 "M2PA should move from PROCESSOR_OUTAGE to IN_SERVICE upon receiving either
MTP3 Flush or MTP3 Continue when no processor outage is in effect. Receiving
either LPR or LSPOE is not sufficient for M2PA to make the transition." (i
take from Jeff).
In effect M2PA will also have a  transient condition as  in Q.703. I also do
not see anything wrong in doing so. Also waiting for a indication from L3
will  avoid out of sequence messages or say  messages pertaining  to a call
which  would have already terminated.

- Rohan

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: <[email-masked]>
Cc: "Tom George" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Friday, March 14, 2003 2:08 AM
Subject: Re: [Sigtran] M2PA: Revised section 4.1