Subject: Re: [Sigtran] [m3ua]-AS-SG

From: [email-masked]
Date: Mon, 3 Mar 2003 13:08:15 -0500

"Brian F. G. Bidulock" <[email-masked]>
Sent by: [email-masked]
 03/03/2003 12:37 PM
 Please respond to bidulock

        To:     [email-masked]
        cc:     [email-masked]
        Subject:        Re: [Sigtran] [m3ua]-AS-SG

Barry.Nagelberg,

[email-masked] wrote: (Mon, 03 Mar 2003 11:18:26)
> Brian,
> 
> OK, I agree with you that a parameter to identify the SG could be 
selected 
> on an implementation-dependent basis. This, however, would destroy the 
> concept of  interoperability.

How so?

[BN] - Because both the ASP and the SGP must be aware that the chosen 
parameter is being used to identify the SG.

> 
> Furthermore, I don't understand why you say that there is a "lack of a
> practical purpose" for an SGP to serve multiple SGs. I contend that is 
the
> same reason why the RFC allows an ASP to serve mutiple ASs.

What makes the SG different from each other (particularly when the same 
set
of SGP belong to the same SGs)?

[BN] - I don't understand what you mean.

--brian

> 
> Barry Nagelberg
> 
> 
> 
> 
> 
> "Brian F. G. Bidulock" <[email-masked]>
>  03/03/2003 11:24 AM
>  Please respond to bidulock
> 
> 
>         To:     [email-masked]
>         cc:     [email-masked]
>         Subject:        Re: [Sigtran] [m3ua]-AS-SG
> 
> 
> Barry.Nagelberg,
> 
> I disagree with the statement.  There are plenty of parameters
> that an implementation could use to decide which SG:  SLS for
> example.  The purpose of SLS is even to select between
> symmetrical nodes in the SS7 network and it appears in the M3UA
> DATA message.
> 
> It is not for lack of a parameter that this would not normally
> be done.  It is for lack of a practical purpose.  It is also an
> operational consideration with no place in the RFC (unless in
> the appendix).
> 
> --brian
> 
> [email-masked] wrote: (Mon, 03 Mar 2003 09:24:56)
> > Javier and Ken,
> > 
> > I think that Tolga's explanation of why an SGP cannot be part of 
> different 
> > SGs is excellent and should be in the next version of the IG. The 
> > explanation is not trivial and is not stated anywhere in the RFC:
> > 
> > "In the messages that are exchanged between ASPs and SGPs there is no 
> > parameter with which to correlate the message to a specific SG. The 
> > Routing Context parameter in these messages indicates the source or 
> > destination AS, not the source or destination SG. The messages are 
sent 
> > to/from a specific SGP, and the SG is implicitly indicated by the 
> selected 
> > SGP."
> > 
> > Barry Nagelberg
> > 
> > 
> > 
> > 
> > 
> > 
> > Tolga Asveren <[email-masked]>
> > Sent by: [email-masked]
> >  03/01/2003 04:36 AM
> > 
> > 
> >         To:     [email-masked]
> >         cc: 
> >         Subject:        Re: [Sigtran] [m3ua]-AS-SG
> > 
> > 
> > Barry,
> > --- [email-masked] wrote:
> > > Tolga,
> > > 
> > > Please tell us where in the RFC or IG it is stated
> > > that an SGP cannot be 
> > > part of different SGs.
> > [TOLGA]from 1.2. Terminology section:
> > "Signalling Gateway Process (SGP) - A process instance
> > of a Signlling Gateway. It serves as an active,
> > backup, loadsharing or broadcasting process of a
> > Signalling Gateway."
> > Please note "of a Signalling Gateway". A comparision
> > with the definition of ASP can also make the
> > difference more clear.
> > 
> > In the messages between ASP/SGP we don't have any
> > identifier specifying with which SG the messages is
> > related. Messages are sent to a specific SGP/from a
> > specific SGP, and SG is implicityl indicated by the
> > selected SGP. And again because there is no identifier
> > for SGP in the messages, the only way to distinguish
> > between different SGPs is to use different addresses
> > for them. Please note, for AS this is different. We
> > have RC to corraleta the message with a specific AS.
> > So, that one ASP can serve multiple AS is not a
> > problem. Also I don't consider "to serve" and to be
> > part" relationships the same. Relationship between ASP
> > and AS is not the same with the relationship between
> > SGP and SG.
> > If the question is, whether it is possible to have one
> > physicall process on SG side, which handles messages
> > for multiple SGs -which acts as multiple SGPs from
> > M3UA protocol point of view- I would say yes. But this
> > is implementation dependent and IMO does not have
> > anything to do with M3UA protocol itself. Important is
> > that from M3UA point of view, one SGP can be part of
> > only one SG.
> > > 
> > > Barry Nagelberg
> > > 
> > > 
> > > 
> > > 
> > > 
> > > "TOLGA ASVEREN" <[email-masked]>
> > > Sent by: [email-masked]
> > >  02/28/2003 07:59 AM
> > > 
> > > 
> > >         To:     [email-masked]
> > >         cc: 
> > >         Subject:        Re: [Sigtran] [m3ua]-AS-SG
> > > 
> > > 
> > > 
> > > Srini,
> > > 
> > > 
> > > Tolga,
> > > 
> > > An ASP can be a part of different ASs. Similarly,
> > > Can a SGP be a part of
> > > different SGs?
> > > [TOLGA]No.
> > > 
> > > As per RFC page 115, the figure has only one
> > > Association between any two
> > > Signalling Processes(SGP/ASP). RFC (or even IG) does
> > > not say whether we 
> > > can
> > > have a single Association or multiple Association
> > > between any to 
> > > Signalling
> > > Processes. But Brain mail says we can have multiple
> > > associations. What is
> > > your
> > > comment on this?.
> > > [TOLGA]I don't think multiple associations between
> > > two signalling entities
> > > are forbidden. Just I wouldn't consider it as very
> > > usefull. For example,
> > > 5.4.1.1.1 (the section Samuel was referring to)
> > > talks about determining 
> > > the
> > > correct association to the choosen SGP.
> > > 
> > > > Srini,
> > > >
> > > > I don't think, what Brian says is the same with
> > > the first diagram of
> > > > Samuel's mail,  from the viewpoint of an ASP, one
> > > SGP belongs to one SG,
> > > > which is violated by the first diagram of Samuel's
> > > mail. Furthermore SGP
> > > > and SG are not different entities which are
> > > communicating with each
> > > other.
> > > > One SGP is part of a SG. That is the reason, why
> > > several SGP boxes are 
> > > in
> > > > one SG box (whereas in the first figure, we even
> > > have SCTP associations
> > > > between them). I think, the figure Brian has
> > > referenced in his message
> > > > (RFC page 115) is a good one to understand the
> > > realtionship between SG
> > > and
> > > > SGP.
> > > >
> > > > (And also I don't think it is a good idea to
> > > consider interpretations
> > > from
> > > > individuals -regardless of the person (Brian, no
> > > offense ;-) )-binding,
> > > > let's consider just RFC and IG).
> > > >
> > > >       Tolga
> > > >
> > > > Tolga,
> > > >
> > > >     The following mail replied by Brian says, a
> > > SGP can be part of
> > > multiple
> > > > SGs. How is this different from Samuel model?.
> > > >
> > > > --Srini
> > > >
> > > > >Srini,
> > > >
> > > > >ksrinivas
> > > > wrote:
> > > > (Thu, 30
> > > > Jan 2003 10:08:41)
> > > > >> Tolga,
> > > > >>
> > > > >> An ASP can be a part of different ASs.
> > > Similarly, Can a SGP be a part
> > > of
> > > > >> different SGs?
> > > >
> > > > >Sure.  But from the viewpoint of an ASP, the SGP
> > > belongs to one SG.  If
> > > an
> > > > >SGP were to perform the function for two SGs for
> > > the same AS, the ASP
> > > > would
> > > > >have to form two associations with the SGP: one
> > > for SG-A, the other for
> > > > SG-B.
> > > > >The SGP would also need some way of knowing (e.g.
> > > static port
> > > allocation)
> > > > >for which SG the ASP was forming an association.
> > > >
> > > > >--brian
> > > >
> > > > TOLGA ASVEREN wrote:
> > > >
> > > > > Samuel,
> > > > >
> > > > > Please find below my interpretations.
> > > > >
> > > > >    Tolga
> > > > >
> > > > > Hi,
> > > > >
> > > > > section 5.4.1.1.1
> > > > >
> > > > > ...
> > > > > - Determine the correct association to the
> > > chosen SGP;
> > > > >
> > > > > I have interpreted this statement as below.
> > > > >
> > > > > 1)ASP is selecting the correct association to
> > > the chosen SGP when SGP
> > > is
> > > > >   a member of more than one SG.
> > > > > [TOLGA]I don't think it is correct from
> > > modelling point of view to see
> > > > one
> > > > > SGP as a member of multiple SGs. I would think,
> > > choosing SCTP
> > > association
> > > > > to a given SGP is just for the case, where you
> > > have more than one SCTP
> > > > > association(for whatever reason) to a SGP from
> > > your ASP.
> > > > >
> > > > >  +----+   ASSOC-1
> > > > >  | SG1|----------+
> > > > >  +----+          |
> > > > >                  |     +-----+
> > > > >  +----+  ASSOC-2 +-----|     |------ +-----+
> > > > >  | SG2|----------------| SGP1|------ | ASP1|
> > > > >  +----+          +-----|     |------ +-----+
> > > > >                  |     +-----+
> > > > >  +----+  ASSOC-3 |
> > > > >  | SG3|----------+
> > > > >  +----+
> > > > >
> > > > > In this case SGP1 will have 3 IP addresses to
> > > have 3 SCTP associations
> > > > > with ASP1.When ASP1 wants to send a message to
> > > SG3 then ASP will 
> > > select
> > > > > ASSOC-3.
> > > > > [TOLGA]As Is aid above, I don't think it is a
> > > very good idea to see 
> > > one
> > > > SGP
> > > > > as part of multiple SGs. From ASP point of view,
> > > if there are there
> > > > > different SGs, then there should be three
> > > different SGPs:
> > > > >
> > > > >   ****SG1********
> > > > >   * +--------+  *
> > > > >   * | SGP1   +--*-----+
> > > > >   * +--------+  *     |
> > > > >   ***************     |
> > > > >   ****SG2********     |   +--------+
> > > > >   * +--------+  *     +---+        |
> > > > >   * | SGP2   +--*---------+ ASP1   |
> > > > >   * +--------+  *     +---+        |
> > > > >   ***************     |   +--------+
> > > > >   ****SG3********     |
> > > > >   * +--------+  *     |
> > > > >   * | SGP3   +--*-----+
> > > > >   * +--------+  *
> > > > >   ***************
> > > > >
> > > > >  Will the below diagram be possible?

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 3 Mar 2003 11:52:31 -0700

Barry.Nagelberg,

[email-masked] wrote:                                         (Mon, 03 Mar 2003 13:08:15)
> parameter is being used to identify the SG.

I don't think so...  Why would the ASP need to know that the SGP is
using SLS, for example, to select the SG?

> [BN] - I don't understand what you mean.

To count something normally requires cardinality based on some distinguishing
feature.  For tangible objects this is time-space coordinates.  What is it
for SG?  What is distinguishes one SG from another so that we can say that
there are two and not just one?  Fermi spin?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/