Subject: Re: [Sigtran] M2PA T7 value

From: [email-masked]
Date: Thu, 13 Mar 2003 07:38:10 -0500

Hello Tom,

The range listed for T7 is just fine, though the low end may be reduced.
One must account for high latency networks and transient IP network
anomalies.

Regards,

Jeff

                      Tom George                                                                                                  
                      <Tom.George@alca         To:      SIGTRAN e-mail list <[email-masked]>                                    
                      tel.com>                 cc:                                                                                
                      Sent by:                 Subject: [Sigtran] M2PA T7 value                                                   
                      sigtran-admin@ie                                                                                            
                      tf.org                                                                                                      

                      03/12/03 04:02                                                                                              
                      PM                                                                                                          

There might be a problem with the range for the T7 timer. We have it as
0.5 - 2 seconds, the same as MTP2. Suppose that T7 is set to 2 seconds,
and that a link is capable of sending a few thousand messages/second. By
the time T7 expired, there could be thousands of messages in M2PA's
retransmission buffer. This could make it difficult to perform
changeover within the required time (300ms, I think).

If the lack of acknowledgements is due to a network problem, SCTP should
fail the association before T7 expires. Of course, that depends on how
the SCTP parameters are set, but I think it would be reasonable to set
them that way.

Maybe someone who has experience with ATM links can help here. Is there
an analog of the T7 timer? What is its range?

--
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Fri, 14 Mar 2003 09:20:48 +0530

Hi Tom, Jeff

There is no guard timer that runs per packet in SAAL NNI (Q.2140 over Q.2110).
The timer that runs is Timer(No Resoponse) that takes the link into Out of
Service in case no STAT PDU is received during the duration of this Timer. This
STAT PDU is sent as a response to POLL PDU (which is dispatched at

 expiry of
POLL Timer(100ms)). The sender of the POLL PDU should receive a STAT PDU before
the expiry of Timer (No Response).
The default value for Timer (No Response) is 1.5 seconds. (Table 5/Q.2140).
So the difference here is that there is no per message timer in SAAL NNI, and
the link is OK as long as these STAT PDUs are being received before expiry of
Timer (No response).

Regards
Anshoo.

From: <[email-masked]>
To: "Tom George" <[email-masked]>
Cc: "SIGTRAN e-mail list" <[email-masked]>; <[email-masked]>
Sent: Thursday, March 13, 2003 6:08 PM
Subject: Re: [Sigtran] M2PA T7 value

> an analog of the T7 timer? What is its range?

DISCLAIMER: This message is proprietary to Hughes Software Systems
Limited (HSS) and is intended solely for the use of the individual
to whom it is addressed. It may contain  privileged or confidential
information  and should not be circulated or used for any purpose other
than for what it is intended. If you have received this message in error,
please notify the originator immediately. If you are not the intended
recipient, you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message. HSS accepts
no responsibility for loss or damage arising from the use of the information
transmitted by this email including damage from virus.