Subject: Re: [Sigtran] Re: M3UA DATA message

From: [email-masked]
Date: Thu, 6 Mar 2003 19:27:22 +0530

Hi
     On receiving SCON message from ASP 1. SG will handle the received SCON
message depending on the network appearance associated with AS1.For national
option with priority M3UA at SG will update the SPMC congestion status based on
the SCON level and give the notification to NIF about the changed SPMC
congestion status.SG can then send TFC to concerned SEP1.For international
option notification is given to NIF on the reception of SCON so that SG can send
TFC to concerned SEP1. To know more about congestion handling mechanisms in M3UA
refer to draft:
http://www.ietf.org/internet-drafts/draft-kamesh-m3ua-congestion-procedures-00.txt

Regards
Kamesh
Hughes Software Systems

"Brian F. G. Bidulock" <[email-masked]> on 03/06/2003 05:30:58 PM

Please respond to [email-masked]

To:   "B.Sasidhar Reddy" <[email-masked]>
cc:   [email-masked], [email-masked] (bcc: Kamesh Kaul/HSS)

Subject:  [Sigtran] Re: M3UA DATA message

B.Sasidhar,

B.Sasidhar Reddy wrote:
(Thu, 06 Mar 2003 17:21:59)
>
>    Brian
>
>                                 ----------
>
>                                 |SEP1  |
>
>                                 -----------
>
>                                     |
>
>                                     |
>
>     -------------               -------------
>    -----------
>
>     | ASP1  |---------------| SGP1  | -----------------|SEP2    |
>
>     -------------               --------------
>    ------------
>
>                                     |
>
>                                     |
>
>                               --------------
>
>                               | ASP2   |
>
>                               --------------
>
>
>
>    ASP1 and ASP2 are serving AS1.
>
>    SGP1 is serving SG1.
>
>    SEP1 and SEP2 are two SS7 nodes with different point codes.
>
>
>
>    Let us assume that SGP1 received DATA message from SEP1 for which ASP1
>    becomes congested and sends SCON with Affected PC of AS1 and concerned
>    PC of SEP1.
>
>
>
>    Now  when  SEP1 sends DATA message to AS1, Should the SGP1 forward the
>    message to AS1 though ASP2?.

No.

>
>    Now  when  SEP2 sends DATA message to AS1, Should the SGP1 forward the
>    message to AS1 either though ASP1 or ASP2?.

No.

The SGP should not alter routing between ASPs in response to SCON received
from an AS.  In fact, because of the way that SMH TFC is described in
ANSI-2000 SS7 SGP will normally ignore SCON received from the ASP altogether.

If ASP1 becomes congested it should indicate congestion at the MTP-User level.
For SCCP users this consists of sending SSC messages.  For ISUP users this
consists of sending ACL parameters in REL messages.

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Mon, 10 Mar 2003 11:42:27 +0530

Hi
     Yes it is a correct assumption to make that AS1 is undergoing congestion.
Regards
Kamesh
Hughes Software Systems

"B.Sasidhar Reddy" <[email-masked]> on 03/10/2003 11:19:35
AM

To:   "Richard Adams" <[email-masked]>, "TOLGA ASVEREN"
      <[email-masked]>, [email-masked], [email-masked]
cc:    (bcc: Kamesh Kaul/HSS)

Subject:  Re: [Sigtran] Re: M3UA DATA message

Hi
                             ----------
                             |SEP1  |
                             -----------
                                 |
                                 |
 -------------               -------------                   -----------
 | ASP1  |---------------| SGP1  | -----------------|SEP2    |
 -------------               --------------                  ------------
                                 |
                                 |
                           --------------
                           | ASP2   |
                           --------------

ASP1 and ASP2 are serving AS1.
SGP1 is serving SG1.
SEP1 and SEP2 are two SS7 nodes with different point codes.
SG1 and AS1 are having different point codes.
All the signalling points belong to the same network.
Traffic mode of AS1 is Loadshared.

Let us assume that SGP1 received DATA message from SEP1 for which ASP1
becomes congested and sends SCON with Affected PC of AS1 and concerned PC of
SEP1.

If SCON is received from ASP1 serving AS1, can i say that AS1 is congested?

thanks
Sasidhar

----- Original Message -----
From: "Richard Adams" <[email-masked]>
To: "TOLGA ASVEREN" <[email-masked]>; <[email-masked]>
Sent: Thursday, March 06, 2003 9:00 PM
Subject: RE: [Sigtran] Re: M3UA DATA message

> Tolga,
> I agree with most of what you say. But TFC CAN be sent in networks other
> than ANSI ones when a signalling point itself is experiencing congestion
> (e.g. the Netherlands, UK,....).
> Kind regards,
> Dick Adams,
> [email-masked]
>
>
>
> -----Original Message-----
> From: TOLGA ASVEREN [mailto:[email-masked]]
> Sent: 06 March 2003 16:00
> To: [email-masked]
> Subject: Re: [Sigtran] Re: M3UA DATA message
>
>
>
> Hi Kamesh,
>
> Does it really work like this according to RFC/IG? I don't think so. And
> for that specific case, it is even not said whether AS and SG do have
> the
> same PC, so how can one decide what to do so easily?
> IMO the relevant part of RFC is:
> 1.4.6 Congestion Management:
> "  The M3UA layer at an ASP or IPSP MAY indicate local congestion to an
>    M3UA peer with an SCON message.  When an SG receives a congestion
>    message (SCON) from an ASP, and the SG determines that an SPMC is now
>    encountering congestion, it MAY trigger SS7 MTP3 Transfer Controlled
>    management messages to concerned SS7 destinations according to
>    congestion procedures of the relevant MTP3 standard."
>
> So based on SCON from ASP (only sent for ANSI and when AS and SG have
> different PCs) SG decides based on an implementation dependent way when
> SPMC is congested and acts accordingly.
>
>     Tolga
>
>
>
>
>
>                     [email-masked]
>
>                     .com                 To:     "B.Sasidhar Reddy"
> <[email-masked]>
>                     Sent by:             cc:     [email-masked]
>
>                     sigtran-admin@       Subject:     Re: [Sigtran] Re:
> M3UA DATA message
>                     ietf.org
>
>
>
>
>
>                     06.03.2003
>
>                     15:57
>
>
>
>
>
>
>
>
>
>
>
> Hi
> option notification is given to NIF on the reception of SCON so that SG
> can
> send
> TFC to concerned SEP1. To know more about congestion handling mechanisms
> in
> M3UA
> refer to draft:

---

From: "Wung, Joseph" <[email-masked]>
Date: Tue, 11 Mar 2003 09:50:17 -0500

> > 
> > There is never really a case where it makes much sense for an SG
> > to act on SCON received from an ASP.  

> > --brian

Then what is it supposed to mean according to M3UA when an SCON
is received from an ASP?

Joe

---

From: [email-masked]
Date: Wed, 12 Mar 2003 09:38:51 +0530

Joseph
                   SCON received from an ASP means that ASP is suffering local
congestion due to traffic pumped by SG to ASP.So it makes sense for SG to
indicate basic generator of traffic some were in SS7 domain to reduce the flow
of traffic, which is done by sending TFC to the concerned point code.Thus it
makes sense for SG to act on the received SCON message from ASP before messages
are dicarded by ASP at worst.

Regards
Kamesh

"Wung, Joseph" <[email-masked]> on 03/11/2003 08:20:17 PM

To:   "[email-masked]'" <[email-masked]>, Kamesh Kaul/HSS@HSS
cc:   [email-masked]

Joe

---

From: "TOLGA ASVEREN" <[email-masked]>
Date: Wed, 12 Mar 2003 08:32:46 +0200

IMO, all this is not so simple. For cases where there is a pure
MTP3/MTP3-User Part relationship between SG and AS (where AS and SG do not
have different PCs), I would think it is a good idea to rely on User Part
procedures to handle congestion (Q.704 "11.2.8 User Part Congestion   There
are no specific User Part congestion control procedures defined in MTP.")

For the case where AS and SG have different PCs and where multiple SGs are
used(which IMO is better to be handled with a SG-SG relationship), ASPs
also perform some message routing functionality for outgoing traffic (they
select between SGs) so their congestion might be interpreted as signalling
point congestion. So, for such a configuration if the network allows TFC to
be generated for local signalling point congestion, SCON might be generated
from ASP to SG. Also here, IMO the final decision belongs to SG, whether to
generate TFC or not based on a received SCON.

My preference would be to have a ASPTM so that ASPs can inform SGPs about
changes of their congestion status and SG decides according to that
information what to do. For example for the case where AS and SG have the
same PC, there won't be SCON from ASP to SG. There we rely only on
detection of SCTP congestion on SG side. IMO, it might take some time till
congestion of user parts propogates to SCTP so that SCTP congestion can be
detected on SG side and also for the general case there is no 1:1 mapping
between AS and SCTP association -so AS might congest whereas SCTP doesn't,
or it might take quite some time till the congestion propogates-. (but of
course still we have user part congestion mechanisms, maybe also here it is
better to rely on them(?))

   Tolga

Joseph
                   SCON received from an ASP means that ASP is suffering
local
congestion due to traffic pumped by SG to ASP.So it makes sense for SG to
indicate basic generator of traffic some were in SS7 domain to reduce the
flow
of traffic, which is done by sending TFC to the concerned point code.Thus
it
makes sense for SG to act on the received SCON message from ASP before
messages
are dicarded by ASP at worst.

Regards
Kamesh

Joe