Subject: Re: [Sigtran] Re: IUA: Error codes and misconfiguration

From: [email-masked]
Date: Sat, 8 Mar 2003 12:13:10 +0530

Hi Ken,

>>
>>                SG                               ASP1
>>                 |                                |
>>                 |                                |
>>                 |<----ASP Active (IIDs 1-10)-----|
>>                 |---ASP Active Ack (IIDs 1-5)--->|
>>                 |-------Error (IIDs 6)---------->|
>>                 |-------Error (IIDs 7)---------->|
>>                 |-------Error (IIDs 8)---------->|
>>                 |-------Error (IIDs 9)---------->|
>>                 |-------Error (IIDs 10)--------->|
>>                 |                                |
>>>>>>> Sorry, what i meant was that what should the ASP side stack do when it
>>>>>>> gets ASPAC ACK for a subset of the IIDs it sent ASPAC for to the SG
side.
>>>>>>> Is it really advisable that ASP side stack update it's configuration to
>>>>>>> reflect the configuration at SG side.

>I would not recommend having the ASP update its configuration to reflect
>the configuration on the SG.  These errors indicate a mis-configuration so
>ideally the operator would be notified so that they could fix the configuration
>problem.

But then, in this call flow given, what i understand is that at the SG, ASP1 is
active but at ASP1 an error has occurred so it will not
consider itself active. Is that right? In this case there will be a mismatch
between the states at the SG and the ASP. So in case of
misconfiguration should it not be better for the SG to send Error for all IIDs?

thanks

kameshwar

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ken Morneault <[email-masked]>
Date: Sun, 09 Mar 2003 21:14:28 -0500

Kameshwar,

There is not a mismatch of states at the SG and the ASP so
there is no reason for the SG to send Error for all IIDs.

Regards,

Ken