Subject: Re: [Sigtran] Broadcasting mode

From: [email-masked]
Date: Fri, 14 Mar 2003 10:04:10 +0530

Hi CA

          Broadcasting is one of the traffic handling modes and this is
applicable for both an Application server and for a Signalling gateway.

When we say that the mode of an AS is broadcast this means that all the active
ASPs in that AS shall be receiving the traffic.
All the Active ASPs in an AS are synchronized in respect of receipt of the data
messages as sent from SGP is concerned.
So any time if one of the ASPs goes down, there are available ASPs which you
know had received the data last sent which is not something
as provided by the other modes override and loadshare.Depending upon how you
broadcast the messages, you can achieve some sort
of state coordination amongst the active ASPs in an AS. For this  correlation id
parameter is also used so that a newly active ASP can synchronize
its traffic flow processing with the ASPs already doing that.

 Similar thing holds true when data is being sent from ASP .
There we talk about the SG's mode which decides how the traffic is distributed
among the available SGPs in that SG and broadcast mode implies
again traffic distribution to all the active SGPs in that SG

You can refer to the RFC for M3UA/M2UA where Broadcast mode is explained .

Thanks
Anjali
www.hssworld.com

Havefun CA <[email-masked]> on 03/08/2003 05:54:49 AM

To:   [email-masked]
cc:    (bcc: Anjali Gurmukhani/HSS)

Subject:  [Sigtran] Broadcasting mode

Hi,

I want to know the broadcasting mode that was
implemented in M3UA/M2UA. Can anybody brievely tell me
what's the purpose of Broadcasting mode or give me
some reference?

Any help is highly appreciated!

CA

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - forms, calculators, tips, more
http://taxes.yahoo.com/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Sibi George" <[email-masked]>
Date: Fri, 14 Mar 2003 11:56:22 +0530

hi,
  in section 3.6.3,
   The Deregistration Request message contains the RC(Routing Context)
  whose functional description is as follows explained in the RFC.

    " The Routing Context parameter contains (a list of) integers
      indexing the Application Server traffic that the sending ASP is
      currently registered to receive from the SGP but now wishes to
      deregister."

      If an ASP serves more than one AS , each AS is represented by
 a RC , 
    What does it mean that RC contains a list of integers ? Does the list
of integers represent the list of DPC's which may be part of the same
routing key during registration?

somebody throw some light regarding this......

thanks
sibi

---

From: "Sibi George" <[email-masked]>
Date: Fri, 14 Mar 2003 14:22:01 +0530

hi,
  I misinterpreted the statement ,
 The RC doesnot contain a list of integers, infact
it is the RC parameter that contains.
  I misinterpreted the statement because of the section...

3.6.3 Deregistration Request (DEREG REQ)

   The DEREG REQ message is sent by an ASP to indicate to a remote M3UA
   peer that it wishes to deregister a given Routing Key.  Typically, an
   ASP would send this message to an SGP, and expects to receive a DEREG
   RSP message in return with the associated Routing Context value.

where it says that DEREG message is sent to deregister a given routing
key.....
there is a contradiction in the explanation in the beginning of section
3.6.3
and  the format of the DEREG message where multiple RC's are shown
why this contradction??

thanks
sibi

From: "Sibi George" <[email-masked]>
To: <[email-masked]>
Sent: Friday, March 14, 2003 11:56 AM
Subject: [Sigtran] M3UA: RC in Deregistration

hi,
  in section 3.6.3,

thanks
sibi