Subject: [Sigtran] Re: [M3UA] ASP Auditing

From: "B.Sasidhar Reddy" <[email-masked]>
Date: Mon, 24 Mar 2003 11:38:13 +0530

Brian,
    As per this thread M3UA should maintain the status of the destination
point code.
Can it be implementation dependent as maintaining the status at both the
places is redundant?  But if we maintain at only MTP3 there are not
primitives defined to request the status.

Sasidhar

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "ksrinivas" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, January 16, 2003 7:51 PM
Subject: Re: [M3UA] ASP Auditing

> Srini,
> ksrinivas wrote:
(Thu, 16 Jan 2003 19:40:28)
> > Brian,
> >
> > In Section 4.5.3 ASP Auditing,
> >
> > ..... The SGP SHOULD respond to a DAUD message with the MTP3
> > availability/congested status of the routeset associated with each
> > Destination Point Code(s) in the DAUD message.....
> >
> >
> > Does it mean that Destination Point Code(s) status be maintained by M3UA
> > of SGP?.
>
> Pretty much.
>
> --brian
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 24 Mar 2003 02:39:43 -0700

B.Sasidhar,

The RFC does not require where the status is maintained at the SG.  As
the NIF is implementation dependent, whether M3UA gets the status from
MTP3 via an implementation dependent NIF mechanism such as that
described in Q.701 Section 8.5, or whether the M3UA implementation
maintains this information internally (i.e. outside MTP3 and the NIF),
is up to the implementation.

As discussed before, one approach would be to always return DAVA to DAUD
and only send responsive DUNA/SCON/DUPU in response to MTP-PAUSE and
MTP-STATUS.

Where, however, multiple SGs are provided, the M3UA at the ASP needs to
maintain the status of destinations via each SG to properly select the
SG used for outgoing traffic.  This does not necessarily include SCON
(but may in the case of ANSI-2000) but necessarily includes
DUNA/DAVA/DRST.  This is already stated in the RFC.

--brian

B.Sasidhar Reddy wrote:                                                         (Mon, 24 Mar 2003 11:38:13)