Subject: [Sigtran] M3UA DATA message

From: "B.Sasidhar Reddy" <[email-masked]>
Date: Thu, 6 Mar 2003 17:21:59 +0530

Brian
                             ----------
                             |SEP1  |
                             -----------
                                 |
                                 |                   
 -------------               -------------                   -----------
 | ASP1  |---------------| SGP1  | -----------------|SEP2    |
 -------------               --------------                  ------------
                                 |
                                 |
                           --------------        
                           | ASP2   |
                           --------------

ASP1 and ASP2 are serving AS1.
SGP1 is serving SG1.
SEP1 and SEP2 are two SS7 nodes with different point codes.

Let us assume that SGP1 received DATA message from SEP1 for which ASP1 becomes congested and sends SCON with Affected PC of AS1 and concerned PC of SEP1.

Now when SEP1 sends DATA message to AS1, Should the SGP1 forward the message to AS1 though ASP2?.
Now when SEP2 sends DATA message to AS1, Should the SGP1 forward the message to AS1 either though ASP1 or ASP2?.

Thanks 
Sasidhar

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Mar 2003 05:00:58 -0700

B.Sasidhar,

B.Sasidhar Reddy wrote:                                                         (Thu, 06 Mar 2003 17:21:59)
>    Let us assume that SGP1 received DATA message from SEP1 for which ASP1
>    becomes congested and sends SCON with Affected PC of AS1 and concerned
>    PC of SEP1.
> 
> 
> 

No.

> 
>    Now  when  SEP2 sends DATA message to AS1, Should the SGP1 forward the
>    message to AS1 either though ASP1 or ASP2?.

No.

The SGP should not alter routing between ASPs in response to SCON received
from an AS.  In fact, because of the way that SMH TFC is described in
ANSI-2000 SS7 SGP will normally ignore SCON received from the ASP altogether.

If ASP1 becomes congested it should indicate congestion at the MTP-User level.
For SCCP users this consists of sending SSC messages.  For ISUP users this
consists of sending ACL parameters in REL messages.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran