Subject: Re: [Sigtran] M3UA IG02: ASPIA-ack changed to DUNA

From: [email-masked]
Date: Fri, 7 Mar 2003 10:11:57 +0530

Hi ,

              Yes  even I agree with Brian that DUNA and other SSNM messages are
interpreted by the ASP on per SG basis .
So sending DUNA is completely inappropriate . ASPIA-ack is good enough to inform
ASP about the partial failure .
So this should be reverted back to ASPIA-ack.

Also I have doubts about mentioning (as is given in change control part of
IG02)that it helps in inter-ASP routing.
 I am not able to appreciate why is this required and its significance.

Again can an  SGP suffering partial failure , recover for those ASs for which it
sent ASPIA-ack earlier.
If yes what procedure shall it follow?

Thanks in advance
Anjali
www.hssworld.com

Ken Morneault <[email-masked]> on 03/06/2003 08:04:48 PM

To:   [email-masked], Anjali Gurmukhani/HSS@HSS
cc:   [email-masked]

Subject:  Re: [Sigtran] M3UA IG02: ASPIA-ack changed to DUNA

Anjali,

Brian is correct that he requested a change to Section 3.4.2.  IG03
left the text the same because there has not been feedback
on the list.

I will repost Brian's proposed changes and, hopefully, there will
be some comments (Anjali - please review and respond to the
list).

Regards,

Ken

At 01:14 AM 3/6/2003 -0700, Brian F. G. Bidulock wrote:
>Anjali,
>
>This change in 3.4.2 in IG02 was the wrong thing to do.  Last I heard Ken
>was waiting for more "feedback".
>
>As an ASP receiving SSNM from one SGP interprets it as pertaining to the
>entire SG, this particular passage is in error:
>
>    If one or more SGP suffer a partial failure (where aborting the
>    association(s) would cause all active AS(es) to fail), then the SGP
>    MUST send DUNA messages for the affected SPC(es).  This is the case
>    where an SGP can continue to service one or more active AS(es), but
>    due to a partial failure it is unable to service other(s) active
>    AS(es).
>
>SSNM are not interpreted on a per-SGP basis.  Therefore, sending DUNA from
>one affected SGP will stop traffic from all SGPs.  This in inappropriate.
>Sending ASPIA-Ack for the affected AS (because ASPTM is per-SGP) will only
>stop traffic to the affected SGP and not the entire SG.
>
>So IG02 is heavily flawed in this respect (and it has the gall to say MUST).
>
>Take a look at the thread
>
>  "I-D ACTION:draft-ietf-sigtran-m3ua-implementors-guide-02.txt"
>
>for this and additional serious flaws in IG02.
>
>--brian
>
>[email-masked] wrote:
(Thu, 06 Mar 2003 12:57:58)
>>
>>
>> Hi...
>>
>>           This is corresponding to a change in   M3UA  IG02 where DUNA has
been
>> substituted inplaceof ASPIA-ack in case NIF is not available.
>> The IG mentions that this is to allow Inter-ASP routing...I am not able to
>> understand how ??
>> Also this was initially in IG00 as DUNA  then chaged to ASPIA-ack
>> could you please clarify.
>>
>>
>> Thanks in advance
>> Anjali
>> www.hssworld.com
>>
>>
>> DISCLAIMER: This message is proprietary to Hughes Software Systems
>> Limited (HSS) and is intended solely for the use of the individual
>> to whom it is addressed. It may contain  privileged or confidential
>> information  and should not be circulated or used for any purpose other
>> than for what it is intended. If you have received this message in error,
>> please notify the originator immediately. If you are not the intended
>> recipient, you are notified that you are strictly prohibited from using,
>> copying, altering, or disclosing the contents of this message. HSS accepts
>> no responsibility for loss or damage arising from the use of the information
>> transmitted by this email including damage from virus.
>>
>>
>> _______________________________________________
>> Sigtran mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/sigtran
>
>--
>Brian F. G. Bidulock
>[email-masked]
>http://www.openss7.org/
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 6 Mar 2003 22:07:02 -0700

agurmukhani,

[email-masked] wrote:                                                 (Fri, 07 Mar 2003 10:11:57)
> If yes what procedure shall it follow?

After the SGP sends the ASPIA Ack, the ASP will likely attempt to reactive for
the AS by sending ASPAC, to which the SGP can reply ERR("Refused - Management
Blocking").  When the SGP recovers it can reply with ASPAC Ack.

To facilitate recovery it helps that if the ASP receives ERR("Refused -
Management Blocking") in response to ASPAC that it inform local management and
only retry on some not too frequent interval (but that is provided for in the
RFC already).

--brian