Subject: AW: AW: [Sigtran] (M2PA) Comments on M2PA v8 - Last Call

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Wed, 7 May 2003 10:09:15 +0200

Tom,

my proposal is to just add the following text below the figure:

The field "Message Data" contains either a
	- User Data message (section 2.3.1) or a,
	- Link State message (section 2.3.2)

greetings

HannsJuergen

> -----Ursprüngliche Nachricht-----
> Von: Tom George [mailto:[email-masked]]
> Gesendet: Dienstag, 6. Mai 2003 22:11
> An: SIGTRAN e-mail list
> Betreff: Re: AW: [Sigtran] (M2PA) Comments on M2PA v8 - Last Call
> 
> 
> Hanns and Brian,
> 
> The format in section 2.3 applies to all M2PA messages. The 
> field called
> "Message Data" can either be:
> 
>    - the Data part of the User Data message (section 2.3.1), or 
> 
>    - the State part (including the optional filler) of the Link Status
> message (section 2.3.2).
> 
> The Message Data in 2.3 definitely should not be renamed User 
> Data. But
> if this is not clear, I am open to suggestions on how to clarify it.
> 
> tomG.
> 
> Schwarzbauer Hanns Juergen wrote:
>   [...]
> > > >
> > > > Comment on Section 2.3
> > > >
> > > > The M2PA message layout shows a field "Message Data".
> > > According to section
> > > > 2.3.1 this should be renamed to "User Data".
> > >
> > > In 2.3 it is illustrated that the message consists of three
> > > components:
> > > Common Message Header, M2PA-specific Message Header and 
> Message Data.
> > > The Message Data component contains User Data.  "Message
> > > Data" describes
> > > the component which contains "User Data" which contains the
> > > "Data" field.
> > 
> > [HJS] that's nowhere stated explicitly, again clarity 
> should be added.
>   [...]
> 
> -- 
> * Tom George       PB7-24001 (near B-21)      
> [email-masked]  *
> * 972-519-3168   Intranet:  
http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Thu, 08 May 2003 17:06:05 -0500

Hanns,

OK. I added that to my copy.

tomG.

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran