Subject: AW: AW: [Sigtran] (M2PA) Comments on M2PA v8 - Last Call

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Wed, 7 May 2003 09:26:44 +0200

Tom,

I know that the Ho code is identical, because the H0 code identifies the message group (section 15.3 of Q.704)
But if you look at Tabel 1/Q.704 you will find none of the extended change-over messages there. 
Furthermore Q.701 specifies the following regarding unallocated H0/H1 codes

6.1.2	Messages containing an unallocated H0/H1 code
When messages containing an unallocated H0/H1 code are received at the appropriate functional block within the MTP, they are discarded. There should be no impact on any protocol and, if required, a report should be made to management.

In consequence any MTP implementation according Q.704 (that's the vast majority) is allowed to legally discard XCO and XCA messages. 
That's the point I want be explicitly mentionned in the I-D.

greetings

HannsJuergen

> -----Ursprüngliche Nachricht-----
> Von: Tom George [mailto:[email-masked]]
> Gesendet: Dienstag, 6. Mai 2003 21:35
> An: SIGTRAN e-mail list
> Betreff: Re: AW: [Sigtran] (M2PA) Comments on M2PA v8 - Last Call
> 
> 
> Hanns,
> 
> In Q.2210 clause 9.8.1, the XCO/XCA message has the same heading code
> (H0) as the Q.704 changeover message. If I understand it 
> correctly, the
> point of this is to make the MTP3 and MTP3b work together. So it looks
> to me like this problem is solved at the MTP3 level.
> 
> Of course, the links have to be set up so that in changing 
> over from the
> M2PA link to a traditional TDM link, you don't overwhelm the 
> traditional
> link. But as far as exchanging the sequence numbers in the changeover
> messages, it looks to me like it will work.
> 
> Let me know if I am missing something. 
> 
> tomG.
> 
> Schwarzbauer Hanns Juergen wrote:
>   [...]
> > > >
> > > > Comment on section 1.6.1
> > > >
> > > > As M2PA requires the usage of XCO and XCA based on MTP3b
> > > [Q.2210] caution
> > > > has to be taken in case of changeover between M2PA and
> > > conventional MTP2
> > > > links. Sending these messages back to the TDM based SS7
> > > network must be
> > > > prohibited as long as no MTP3b functionality supported
> > > (nevertheless I doubt
> > > > that it will be supported in the future) .
> > >
> > > What caution?  Q.704 has no problems changing over 
> between MTP3b and
> > > convetional links.  The extended changeover procedure 
> (larger sequence
> > > numbers) only applies to the link from which traffic is being
> > > diverted and
> > > there is no difficulty in changing over between MTP3b and
> > > conventional links.
> > > In the same manner there is no difficultin in changing over
> > > between M2PA
> > > and conventional links.
> > 
> > [HJS] disagree, read Q.2210
>   [...]
> 
> -- 
> * Tom George       PB7-24001 (near B-21)      
> [email-masked]  *
> * 972-519-3168   Intranet:  
http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
* I actively disclaim speaking for Alcatel USA, Inc. I do not purport *
* to advertise or represent its position,  operations, or activities. *
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 May 2003 01:59:57 -0600

Schwarzbauer,

XCO/XCA are not unallocated H1 codes.  See Study Group 11 R 137
(Q.704 Implementors' Guide).  Any MTP implementation which does not
follow R 137 will have additional implementation errors as it makes
a number of other corrections to the Q.704 (07/96) document.

Under the ITU process of making corrections in Implementor's Guides
(a method followed by this WG as well), they are indeed part of Q.704.

In fact these H1 codes are reserved for SAAL links.  This is the same
as ANSI T1.111.4.

M2PA has more than sufficient reference and need no speak to MTP
implementation deficiencies which are clearly outside the scope of
M2PA.

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran