Subject: AW: [Sigtran] (M2PA) Comments on M2PA v8 - Last Call

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Fri, 9 May 2003 10:33:30 +0200

Brian,

might be a good idea, but repeating exactly the Q.700 definitions saves time and money (as ITU-T does not provide free copies of their Recommendations).

You are right that M2PA from a procedural point has to refer to Q.703, but in sections it deals with architecture something more seem adequate.

greetings

HannsJuergen

> -----Ursprüngliche Nachricht-----
> Von: Brian F. G. Bidulock [mailto:[email-masked]]
> Gesendet: Freitag, 9. Mai 2003 10:08
> An: Schwarzbauer Hanns Juergen
> Cc: 'Tom George'; SIGTRAN e-mail list
> Betreff: Re: [Sigtran] (M2PA) Comments on M2PA v8 - Last Call
> 
> 
> Hanns,
> 
> Q.700 defines a Signalling Point (SP) as an SS7 node at which 
> it is irrelevant
> whether it has a "User Function" or "STP Function".
> 
> IMO the definitions for SEP and STP could be removed and 
> Q.700 referenced.
> M2PA does not need to redefine all SS7 terms, particularly as 
> it is relying
> on Q.703 (and variants) for procedures.
> 
> --brian
> 
> On Fri, 09 May 2003, Schwarzbauer Hanns Juergen wrote:
> 
> > Tom,
> > 
> > I agree with you and would propose to add one additional 
> para to section 1.2 Terminology.
> > 
> > Signaling Point (SP) A node in an SS7 network that not only 
> originates/terminates but also routes SS7 signaling messages. 
> It comprises both, the SEP and the STP functionality.
> > 
> > I think this definition was missing nevertheless.
> > 
> > greetings
> > 
> > HannssJuergen
> > 
> > > -----Ursprüngliche Nachricht-----
> > > Von: Tom George [mailto:[email-masked]]
> > > Gesendet: Donnerstag, 8. Mai 2003 17:40
> > > Cc: SIGTRAN e-mail list
> > > Betreff: Re: AW: AW: [Sigtran] (M2PA) Comments on M2PA v8 
> - Last Call
> > > 
> > > 
> > > Hanns,
> > > 
> > > That is more than the figure is intended to show. The 
> figure is just
> > > there to show the relationship between SCTP associations and 
> > > M2PA links.
> > > There may be links between IPSP Y and IPSP Z. I would not 
> want to make
> > > any comment about what kind of network elements are 
> present in Figures
> > > 8-10. So I use the most general term, SP. 
> > > 
> > > tomG.
> > > 
> > > Schwarzbauer Hanns Juergen wrote:
> > > > 
> > > > Tom,
> > >   [...]
> > > > One additional remark: M2PA draft shows in figure 9 an IPSP 
> > > X connected
> > > > with two other IPSPs denoted Y and Z.
> > > > In case IPSP Z wants to communicate with IPSP Y, IPSP X  
> > > acts as an STP.
> > > > I could imagine to state this in an additional sentence on 
> > > page 23, e.g.
> > > > "Note that IPSP X acts as STP in case IPSP Z communicates 
> > > with IPSP Y"
> > > > 
> > > > Greetings
> > > > 
> > > > HannsJuergen
> > >   [...]
> > > 
> > > -- 
> > > * Tom George       PB7-24001 (near B-21)      
> > > [email-masked]  *
> > > * 972-519-3168   Intranet:  
> > http://www.ssd.usa.alcatel.com/~tgeorge/  *
> > * Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, 
> Texas 75075  *
> > * I actively disclaim speaking for Alcatel USA, Inc. I do 
> not purport *
> > * to advertise or represent its position,  operations, or 
> activities. *
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
> [email-masked]    ¦ world; the unreasonable one persists in  ¦
> http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
>                         ¦ Therefore  all  progress  depends on the ¦
>                         ¦ unreasonable man. -- George Bernard Shaw ¦
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 9 May 2003 03:17:30 -0600

Schwarzbauer,

On Fri, 09 May 2003, Schwarzbauer Hanns Juergen wrote:

> Brian,
> 
> might be a good idea, but repeating exactly the Q.700 definitions saves time
> and money (as ITU-T does not provide free copies of their Recommendations).

Repeating exactly could result in a breach of copyright.  Will the IETF get
permission from ITU for copying verbatim exerpts from Q.700?  Would the IETF
copyright statement then apply?  Will the resulting draft conform to  RFC 2026?

I think not to all the above.  One of the reasons for removing statements
already in Q.703 was to avoid copyright issues.

--brian

> 
> You are right that M2PA from a procedural point has to refer to Q.703, but
> in sections it deals with architecture something more seem adequate.
> 
> greetings
> 
> HannsJuergen
>