Subject: [Sigtran] RFC 3331 doubts

From: Pablo Salinas <[email-masked]>
Date: Fri, 2 May 2003 18:44:07 -0500 (CDT)

Hi there,
          I am reading the RFC 3331, and I am a bit
confused. It talks about the Layer Managment. Here's a
quote:
"Layer Managment is a nodal function in an SG or ASP
that handles the inputs and outputs between the M2UA
layer and a local managment entity".
Is the local managment entity referred here as an
Interworking Function Process(in the SG) or an ASP(in
the MG), or am I all confused here?
And, if I am rigth in the last point, will the Layer
Managment be responsible for processing the primitives
that come from the upper layer and pass them to the
M2UA and viceversa?

Please, help me out on this. There is not enough
literature on the M2UA protocol, and I am having a
hard time to understand the RFC.

                          thanks,
                                   Pablo Salinas

_________________________________________________________
Do You Yahoo!?
Información de Estados Unidos y América Latina, en Yahoo! Noticias.
Visítanos en http://noticias.espanol.yahoo.com
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Kartik Gupta <[email-masked]>
Date: Sat, 03 May 2003 11:09:41 +0630

Pablo,

Local Management Entity is the Node (ASP or SG) Administrator.
Local Management Entity provides input to the M2UA layer regarding
management functions, like requesting/handling change in ASP state etc.,
using Layer Management interface implemented for M2UA. This Layer 
Management entity is an interface between Local Management entity and 
M2UA. Layer management is an implementation dependent concept.
For interworking, NIF is implemented which is used to interwork MTP2 and
M2UA at SG. You can implement both NIF and Layer Management in the
same entity also.

-Kartik

---

From: Kartik Gupta <[email-masked]>
Date: Sat, 03 May 2003 11:11:22 +0630

Pablo,

-Kartik

---

From: [email-masked]
Date: Thu, 8 May 2003 13:39:16 +0530

Hello Pablo,
      Normally ASP's transport address would be a static one.
In such a case the ASP's static transport address would be
configured at SGP. Thus when ASP UP comes from the ASP, SGP
would be able to identify the ASP which has sent this. In such a
case the optional ASP identifier would not be used in ASP UP
messages.
      In case ASP's transport address is dynamically obtained,
it cannot publish its transport address before hand to SGP. Thus
an ASP id would be mutually understood between SGP and ASP
and configured on both. ASP needs to send this as the ASP
Identifier in the ASP UP message to SGP. SGP, on receiving ASP UP
with the particular ASP identifier, would be able to identify the ASP
from which it has come from. It should then store a map of that ASP
identifier to the SCTP association.
      Coming back to your question of what all needs to be
configured on an SGP's M2UA, some of the configuration could be
as follows:
1. In case of statically configured AS, SGP, needs to know
         a) The ASP's for each AS that it is going to cater,
         b) The traffic mode of the AS,
         c) The minimum no. of ASP's the AS would like to have them as
               active in case of a loadshare mode etc.
         d) The routing key (link id, interface identifier)
2. The SCTP association parameters (e.g. the local address,
     stream info etc.)

Regards,
- R. Ezhirpavai
Hughes Software Systems,
India.
www.hssworld.com

"Brian F. G. Bidulock" <[email-masked]>@ietf.org on 05/08/2003
07:12:01 AM

Please respond to [email-masked]

Sent by:    [email-masked]

To:    Kartik Gupta <[email-masked]>
cc:    Pablo Salinas <[email-masked]>, [email-masked]

Subject:    Re: [Sigtran] RFC 3331 doubts

Kartik,

Unless dynamic port allocation is used and there are multiple ASPs
per host for a given set of interfaces.  Then ASP Id is required to
distinguish between ASPs.

--brian

Kartik Gupta wrote:
(Thu, 08 May 2003 07:09:37)
> Pablo,
> SCTP association on which message arrives is used to determine the
> source/target ASP/SGP of the message.
>
> --Kartik
> (For M3UA Project, visit http://sourceforge.net/projects/m3ua)
> ----- Original Message -----
> From: Pablo Salinas
> To: Katik Gupta ; [email-masked]
> Sent: Thursday, May 08, 2003 2:23 AM
> Subject: Re: [Sigtran] RFC 3331 doubts
>
>
> Thanks again Kalik. I really love this mailing list. People are really
> willing to help each other here.
>
> I still don't get one little thing. Kalik, when you say:
> "...From the
> definition of ASP (it is an SCTP endpoint),
> it has a unique transport address from which it will send message to the
> SGP. You can check the source address of the
> ASPUP message and find out the ASP which originated the message."
>
> Do you mean that I can find out the ASP that sent the ASP UP message, by
> knowing the sctp association in which it arrived, because only one ASP
can
> be registered to that sctp association?,
> I am asking this because the common header of all signalling protocol
> adaptation layers don't have a source address.
> Or am I missing something here?
> I am sorry if I am being annoying, and thanks for your patience.
>
>                         greetings,
>                                        Pablo Salinas
>
> Katik Gupta <[email-masked]> wrote:
> Pablo,
>
> Check responses inline.
>
> --Kartik
> (For M3UA Project, visit http://sourceforge.net/projects/m3ua)
> ----- Original Message -----
> From: Pablo Saliinas
> To: Kartik Gupta ; [email-masked]
> Sent: Wednesday, May 07, 2003 9:12 PM
> Subject: Re: [Sigtran] RFC 3331 doubts
>
>
> Thanks Kartik for your help.
>
> Now, I am having a hard time to understand what has to be configured on
the
> RS and the MG, before they start communicating. It says in the RFC 3331
and
> I quote:
> "The ASP Identifier MUST be used where the SGP cannot identify the ASP by
> pre-configured address/port number information (e.g., where an ASP is
> resident on a Host using dynamic address/port number assignment)." Page
31
>
> And that's all the information I could find about pre-configured
parameters.
> Could anybody tell me what should to be pre-configured in the RS and the
MG!
> ?
> And examples of the configuration if you have any?
>
> KG--> ASP-SGP model followed in M2UA is very similar to M3UA. You can
check
> the my M3UA implementation
> to get more ideaa about the pre-configured parameters.
>
> Because, I cant't understand how the RS and the MG start communicating.
In
> the RFC 3331, it says that all starts with a SCTP-ASSOCIATIVE primitive
to
> the SCTP layer on the MG. And, after an ASP established an SCTP
association
> to an SGP, the SGP aits for the ASP to send an ASP UP message. But, how
can
> the RS know from wich ASP is this message comming from?
>
> KG--> ASP-SGP communication starts after SCTP level association is
> established between them. M-SCTP-ESTABLISH
> primitive is used for this purpose that will use SCTP primitives to
> establish the association. This is specific to the SCTP
> implementation used by M2UA and therefore cannot be generalised. From the
> definition of ASP (it is an SCTP endpoint),
> it! has a unique transport address from which it will send message to the
> SGP. You can check the source address of the
> ASPUP message and find out the ASP which originated the message.
>
> I have another doubt:
> Is there an error in paragraph 3, line 3, page 58? where it says:
> "...local M2UA layer. At the SGP that initiated the request, the M2UA
layer
> will send an..."
> Shouldn't it say : "...At the ASP that initiated the request,..."?
>
> KG--> yes, it is ASP and not SGP.
>
> thanks again,
> Pablo Salinas
>
>
> Pablo,
>
> Local Management Entity is tthe Node (ASP or SG) Administrator.
> M2! UA at SG. You can implement both NIF and Layer Management in the
> same entity also.
>
> -Kartik
>
>
> > Hi there,
> > la! yer and a local managment entity".
> > > > thanks,> Pablo Salinas
> > > ___________________________________ ______________________
> > Do You Yahoo!?
> > https://www1.ietf.org/ma! ilman/listinfo/sigtran
>
>
> ____________________________________ ___________
> Sigtran mailing list
> [email-masked]
> Todo lo que quieres saber de Estados Unidos, América Latina y el resto
del
> Mundo.
> Visíta Yahoo! Noticias.
>
>
>
>
>
> Do You Yahoo!?
>  Todo lo que quieres saber de Estados Unidos, América Latina y el resto
del
> Mundo.
> Visíta Yahoo! Noticias.

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/