Subject: Re: [Sigtran] ASP Identifier in an ASP UP message

From: [email-masked]
Date: Wed, 21 May 2003 09:24:04 +0530

Hi Pablo,

Yes, the ASP Identifier is an unsigned number, and the case where the SGP
can identify the ASP by pre-configured address/port the optional ASP Id
parameter is
not required to be sent. In this case the entire parameter (i.e. Tag=0x11,
Length=8 and ASP-Id)
would not exist in the ASP UP Message.

Regards,
Siddharth
www.hssworld.com

Pablo Salinas <[email-masked]>@ietf.org on 05/21/2003 01:51:36 AM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    [Sigtran] ASP Identifier in an ASP UP message

Hi there,
              In RFC 3331, Page 31, it talks about the ASP Up message and
the ASP Identifier Field. Should the ASP Identifier be an unsigned number?
And what value should it have if none ASP Identifier is sent? Or should the
field not exist?

                   thanks,
                             Pablo Salinas

Do You Yahoo!?
[IMAGE]Todo lo que quieres saber de Estados Unidos, América Latina y el
resto del Mundo.
Visíta Yahoo! Noticias.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Umesh Vats" <[email-masked]>
Date: Wed, 21 May 2003 12:06:47 -0700

Hi

How should we view an Application server from a signaling Gateway ?

Is it one Application Server per SG (Signaling Gateway) ?
         OR
Is it one Application Server per SGP (Signaling Gateway process) ?

For an application server, Pending queue is maintained for queuing 
of messages. Should there be one pending queue per AS per SG or
a separate pending queue for an AS, one for each of the SGPs on SG ?

Thanks
umesh

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 21 May 2003 13:12:14 -0600

Umesh,

That rather depends on your SG architecture.  You could have one
pending queue per AS per SGP, or you could have one pending queue
per AS per SG.

--brian

Umesh Vats wrote:                                                                    (Wed, 21 May 2003 12:06:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 21 May 2003 14:54:12 -0600

Umesh,

I agree, the statements are not very clear.  Consider that when
one SGP pends on an AS, it was always the intention that if there
is another SGP that has an ASP ASP-ACTIVE for the AS, that the SGP
which would pend should transfer messages internally in the SG to
the SGP which is still available.

But much of this depends upon internal architecture of the SG.
It is difficult to make statements like this without an architecture
in mind.

Saying "may" leaves the door open to other interpretations.

--brian

On Wed, 21 May 2003, Umesh Vats wrote:

> Hi  Brian
> 
> My doubt comes from the following statement in the description of
> AS-PENDING state(RFC 3332),
> 
> " If T(r) expires before an ASP becomes ASP-ACTIVE, and the SGP has no
>   alternative, the SGP may stops queuing messages and discards all
>   previously queued messages.  The AS will move to the AS-INACTIVE
>   state.",
> 
> shouldn't there be SG in the place of SGP ?
> 
> regards
> Umesh
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brian F. G. Bidulock
> Sent: Wednesday, May 21, 2003 12:12 PM
> To: Umesh Vats
> Cc: [email-masked]
> Subject: Re: [Sigtran] M3UA : AS view from SG
> 
> 
> Umesh,
> 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Umesh Vats" <[email-masked]>
Date: Wed, 21 May 2003 14:16:17 -0700

One more issue here,
should AS move to PENDING state :

when one of the SGPs of an SG looses communication(due to ASP Inactive
procedures) to all ASPs
serving that AS ?
             OR
when all the SGPs of an SG loose communication(due to ASP Inactive
procedures) to all the ASPs
serving that AS ?

thanks
Umesh

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Wednesday, May 21, 2003 1:54 PM
To: Umesh Vats
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA : AS view from SG

Umesh,

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 21 May 2003 16:07:10 -0600

Umesh,

Umesh Vats wrote:                           (Wed, 21 May 2003 14:16:17)
> procedures) to all the ASPs

This one.  But this too depends on the traffic mode of the SGP.
The UAs do not manage the traffic mode of the SGP: it is something
that is provisioned at the ASP; however, each SGP must be capable of
processing any message from the AS: therefore, the ASP can just shift
traffic to one of the active SGPs.  However, it would be advantageous
to pend for a brief period under some circumstances to allow the SGP
to recover before redirecting traffic in a kind of controlled-rerouting
procedure.  See draft-bidulock-sigtran-corid-01.txt for more info.

--brian