Subject: WG: [Sigtran] M2PA: T7 and dropping SCTP association after link f ailure

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Wed, 7 May 2003 16:40:52 +0200

resending...

I haven't found a thourough discussion on the list in the past on the variations we are effectively expecting in an IP network transporting SS7 messages. Variations in the 100ms range do not justify this requirement. In case of voice over IP jitter in the range of 100ms and more is also not acceptable. Are we going to send SS7 messages over an IP network worse than that used to transport voice?

Unless having real values, I see no need for having hundreds of T7 timers.

greetings

HannsJuergen

-----Ursprüngliche Nachricht-----
Von: Schwarzbauer Hanns Juergen
[mailto:[email-masked]]
Gesendet: Donnerstag, 24. April 2003 08:27
An: 'TOLGA ASVEREN'; [email-masked]
Betreff: AW: [Sigtran] M2PA: T7 and dropping SCTP association after link failure

Dear all,

see my comments below

Greetings

HannsJuergen

> -----Ursprüngliche Nachricht-----
> Von: TOLGA ASVEREN [mailto:[email-masked]]
> Gesendet: Donnerstag, 24. April 2003 08:00
> An: [email-masked]
> Betreff: [Sigtran] M2PA: T7 and dropping SCTP association after link
> failure
> 
> 
> Hi Tom,
> 
> 1) In M2PA 4.2.1
> "Because propagation delays in IP networks are more variable than in
> traditional SS7 networks, a single T7 timer (excessive delay of
> acknowledgement) is inadequate. A T7 timer SHALL be started for each
> message in the M2PA retransmit buffer."
> 
> I think this explanation might be confusing -or better said 
> not complete-
> for people, which did not follow the threads related with T7. 
> IMO, it could
> be better to mention about possibility of SCTP delaying 
> acknowledgements
> for a specific message. Furthermore, based on what it stands 
> in RFC2960 6.1
> "This document is specified as if there is a single 
> retransmission timer
> per destination transport address, but implementations MAY have a
> retransmission timer for each DATA chunk." , I would think it could be
> better to revise the above section of M2PA, reflecting that 
> based on how
> the underlying SCTP handles T3, how to use M2PA T7 might be different.

[HJS] 
in case the delay variations of an IP network used to transfer SS7 messages are so volatile to justify starting a T7 timer for every retransmitted message, then you should think about your IP network design before putting more functionality in M2PA. 
What granularity do you want to have for such a message individual T7 timer? 10 ms? 
I'm definitely not heading for the transport of SS7 messages over the public IP network. Having multiple T7 timers should be considered an option only, as Tolga proposed below.
[HJS]
---snip---
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 May 2003 10:17:17 -0600

Schwarzbauer,

There is no need to start hundreds of T7 timers.  Only one timer is required,
even if T7 is on a per-message basis.

--brian

Schwarzbauer Hanns Juergen wrote:                                             (Wed, 07 May 2003 16:40:52)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/