Subject: [Sigtran] SIGTRAN - M2PA draft 8 - T7 timer

From: "Franck Boesch" <[email-masked]>
Date: Wed, 28 May 2003 15:51:03 +0200

Hello,

I am not sure that I have well understood the M2PA draft specifications <draft-ietf-sigtran-m2pa-08.txt> when it states (page 29, paragraph 4.2.1) that :

Because propagation delays in IP networks are more variable than in
traditional SS7 networks, a single T7 timer (excessive delay of
acknowledgement) is inadequate. A T7 timer SHALL be started for each
message in the M2PA retransmit buffer.

Does it mean that if for example 50 messages are in the retransmit buffer of a link (the messages have not been ackowledged yet) then 50 T7 timers are pending (have been started) just for that link ?

Thanks,

Franck Boesch.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 28 May 2003 08:10:13 -0600

Franck,

The text has been changed.  See Tom's note from May 8:

> > Here is my reworded paragraph from 4.2.1:
> > 
> > acknowledgement) as in MTP2 is inadequate. If any message is
> > unacknowledged after a period equal to the T7 value, the T7 timer
> > SHALL expire.
> >  
> > Here is the old text for comparison:
> > 
> > tomG.

--brian

Franck Boesch wrote:                                                                (Wed, 28 May 2003 15:51:03)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/