Subject: RE: [Sigtran] FW: SUA corrections

From: [email-masked]
Date: Tue, 6 May 2003 06:05:25 +0300

Hi,

> I suggest that John use 3.7 when updating the SUA document.  

I will.

> Also
> it would be advantageous if items from the M3UA IG that have clear
> concensus at this point be incorporated into SUA to avoid having to
> reiterate them in an SUA IG following RFC release.  Can we say what
> that list would be?  Or would that be premature?

If someone (you & Ken?) came up with a list, I think I could take
them into SUA.

John

> Ken Morneault wrote:                                          
>                          (Mon, 05 May 2003 09:23:31)
> > 
> > 
> > Brian,
> > 
> > I didn't check the email you cited, but I believe this change
> > is covered in Section 3.7 of the latest M3UA IG.
> > 
> > Regards,
> > 
> > Ken
> > 
> > At 04:46 AM 5/5/2003 -0600, Brian F. G. Bidulock wrote:
> > >John, Ken
> > >
> > >I agree that Ken's changes are corrections and represent what was
> > >agreed upon regarding routing key changes.  I also stumbled on this
> > >error in the document during implementation.  I don't think that it
> > >is conceivable that an ERR("Routing Key Change Refused") could be
> > >of much use and had already considered it a REG RESP.  See 
> the thread
> > >"M3UA: Dynamic routing Key modification" of July 2002 and 
> my summary
> > >note of Jul29 17:39 on that thread.
> > >
> > >On the other hand, although on that thread it was requested by 3
> > >individuals and opposed by none that this capability be also added
> > >to the M3UA IG, it is has not yet been added.  Ken, please make the
> > >same modifications to the M3UA IG per that thread.  You 
> will find the
> > >proposal (minus the error code) on the Jul29 17:39 thread 
> cited above.
> > >(I would include it, but it is a 208k message...)
> > >
> > >--brian
> > >
> > >John Loughney wrote:                                       
>                            (Mon, 05 May 2003 12:49:32)
> > >> Hi all,
> > >> 
> > >> Going through some final edits of SUA before asking the IESG to
> > >> make a final consideration of SUA; I noticed a mail I did not
> > >> respond to.
> > >> 
> > >> This change may affect some people's implementations & I 
> wanted to 
> > >> check if the change causes anyone trouble.
> > >> 
> > >> br,
> > >> John
> > >> 
> > >> -----Original Message-----
> > >> From: ext Ken Morneault [mailto:[email-masked]]
> > >> Sent: 30 December, 2002 17:55
> > >> To: Loughney John (NRC/Helsinki)
> > >> Cc: [email-masked]
> > >> Subject: SUA corrections
> > >> 
> > >> 
> > >> 
> > >> 
> > >> John,
> > >> 
> > >> I was looking at the latest SUA draft and found a mistake related
> > >> to modifying a registered Routing Key.
> > >> 
> > >> A new error code was created for this case:  "Routing Key Change
> > >> Refused".    This error code was placed under the "Error 
> Code" text
> > >> in Section 3.9.12 instead of under the "Registration 
> Status" in Section 
> > >> 3.9.22.  This change needs to be made.
> > >> 
> > >> Further, the second to last paragraph in Section 4.4.1 discusses
> > >> when this error condition is hit.  Unfortunately, it recommends 
> > >> returning an error code in Registration Status that does 
> not exist
> > >> (it should be "Routing Key Change Refused").
> > >> 
> > >> Finally, this paragraph indicates that the Routing Context must
> > >> be in the Routing Key parameter in the REG REQ to indicate a
> > >> "modify" operation.  However, in the description of "Routing Key"
> > >> (Section 3.10.14), there is not discussion of the possibility of 
> > >> Routing Context being an optional parameter.
> > >> 
> > >> Regards,
> > >> 
> > >> Ken
> > >> 
> > >> _______________________________________________
> > >> Sigtran mailing list
> > >> [email-masked]
> > >> https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> > >-- 
> > >Brian F. G. Bidulock
> > >[email-masked]
> > >http://www.openss7.org/ 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: [email-masked]
Date: Tue, 6 May 2003 12:46:14 +0300

Hi all,

> I suggest that John use 3.7 when updating the SUA document.  

Done,

Under Section 3.9.12 Error Code, I have changed the old value to:

     0x17      Not Used in SUA

John

---

From: Ken Morneault <[email-masked]>
Date: Tue, 06 May 2003 15:08:31 -0400

John,

I don't know which items in the last M3UA IG are controversial 
(or still controversial) since I don't believe there have been any 
recent postings on this document.  I have not had time to go
back into the email archive to figure out the current status.

Maybe people on the list could provide feedback as to
which items are controversial or not fully resolved.

Regards,

Ken