Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

From: "Zannin, Francois" <[email-masked]>
Date: Thu, 31 Jul 2003 18:24:33 +0200

My response inline.

Francois Z.

> -----Original Message-----
> From: Tolga Asveren [mailto:[email-masked]] 
> Sent: Thursday, July 31, 2003 2:03 PM
> To: [email-masked]
> Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
> 
> 
> Unidirectional traffic is a general problem for
> DE-IPSP model and I think will stay to be like this,
> because it is not a real perr-to-peer model but a 2 
> client-server relationships coupled together. IMO, using 
> ASPAC-ACK to indicate availability of local AS won't do good. 

In DE, ASPAC-ACK only aknowledge the activation of a remote AS, means
LOCAL IPSP can send 
and receive data between for this remote AS and it's own Local AS that
are ACTIVE.
If no local AS is active, no local AS will be able to send or receive
traffic from a remote AS.

> What will happen for the scenarios, where one IPSP serves 
> multiple AS and when some of them are available but some of 
> them are not? Should IPSP reply with ASPAC-ACK for a received 
> ASPAC? SE model was solving this problem by corraleting two 
> AS to each other on RK level. 

We are in DOUBLE echange, an ACTIVE/ACTIE_ACK is only valid for an AS
located on the IPSP that 
Initiates this ASPTM exchange.

If An IPSP serve multiple AS, it just sends ASP_ACTIVE for its local AS
ready to operate.
Then a remote IPSP will be allowed to send traffic only for AS
activated.

> --- "Zannin, Francois" <[email-masked]> wrote:
> > If we consider that the IPSP DE is a replicated
> > SG/ASP model (as already
> > mentionned
> > Before), then SG/ASP protocol indicate that the SG cannot send AND
> > receive traffic from an ASP if the concerned AS(RC) is not
activated. 
> > 
> > When two IPSP are hosting several AS, it seem pertinent to authorize
the traffic only
> > between "ACTIVE AS" in the IPSP.
> > 
> > An active status is reported to the application ONLY if the local AS
> > (the local application) And the remote AS are activated. If the
remote OR
> > the local AS is deactivated, then A pause is reported to the
application.
> > 
> > My opinion is that only ACTIVE AS (between IPSP) can use the
association
> > to exchange messages.
> > 
> > Francois Z.
> > 
> > > -----Original Message-----
> > > From: [email-masked]
> > [mailto:[email-masked]]
> > > Sent: Thursday, July 31, 2003 6:29 AM
> > > To: Band, Richard
> > > Cc: [email-masked]; [email-masked]
> > > Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
> > > 
> > > 
> > > 
> > > 
> > > 
> > > 
> > > Hi Richard,
> > >   You are right that there is no point in
> > activating only
> > > AS1 in IPSP DE mode in the given example. Unless
> > both the AS
> > > 's AS1 and AS2 are not active user to user traffic
> > 
> > > (bidirectional) cannot be started in IPSP
> > model.Any way IPSP
> > > DE mode for that reason is kept
> > optional.Bidirectional
> > > traffic between IPSP A and IPSP B will only start
> > when both
> > > the AS's are active. In my openion let IPSP B
> > indicate
> > > availability of remote AS1as and when it sends
> > ASPAC ack for
> > > AS1 to IPSP A.If IPSP B is interested in sending
> > data for
> > > remote AS1 it can send and IPSP A will receive the
> > data, if
> > > some one wants single direction traffic.But yes i
> > do argee
> > > that there is no practical scenario in which
> > single direction
> > > traffic is desired in IPSP model.
> > > 
> > > Kamesh Kaul
> > > www.hssworld.com
> > > Hughes Software Systems
> > > 
> > > 
> > > 
> > > 
> > > "BAND,RICHARD (HP-France,ex1)"
> > <[email-masked]> on
> > > 07/30/2003 05:33:53 PM
> > > 
> > > To:    Kamesh Kaul/HSS@HSS, [email-masked]
> > > cc:    [email-masked]
> > > 
> > > Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour
> > > 
> > > 
> > > Hi Kamesh, Umesh,
> > > 
> > > I agree that the protocol allows traffic from IPSP
> > B to A
> > > without having traffic from IPSP A to B.
> > > 
> > > However, I do think that there is a problem with
> > the
> > > notifications for the AS on each side: In this
> > situation, how
> > > should the IPSPs A and B indicate the availability
> > of the
> > > remote AS to the local AS? Should IPSP A indicate
> > that AS 2
> > > is available, even though it knows AS 2 cannot
> > reply? Should
> > > IPSP B indicate that AS 1 in unavailable, as AS 2
> > cannot send
> > > any messages to AS 1? If so, what should IPSP B do
> > when AS 1
> > > sends traffic? Discard the messages, or transfer
> > the data to
> > > AS 2, which will then receive traffic from an
> > unavailable destination?
> > > 
> > > In my opinion, both IPSPs should indicate that the
> > remote AS
> > > is unavailable. I would say that the DE IPSP
> > exchange mode
> > > allows each side to indicate its readiness to
> > receive
> > > traffic, but traffic should not be started unless
> > both sides
> > > are active. It seems to me that this is the only
> > to avoid the
> > > problems described above.
> > > 
> > > Please let me know your opinion on this point.
> > > 
> > > Regards,
> > > 
> > > Richard Band
> > > 
> > > -----Original Message-----
> > > From: [email-masked]
> > [mailto:[email-masked]]
> > > Sent: Wednesday, July 30, 2003 06:17
> > > To: [email-masked]
> > > Cc: [email-masked]
> > > Subject: Re: [Sigtran] M3UA : IPSP DE behaviour
> > > 
> > > 
> > > 
> > > 
> > > Umesh
> > > 
> > >   IPSP B can send DATA messages for AS1 to IPSP A
> > only if on
> > > receiving ASPAC message from IPSP A , IPSP B sends
> > ASPAC ack
> > > for AS1 to IPSP A.Not activating AS2 means IPSP B
> > will not be
> > > able to receive any message for AS2.So in a way
> > only data for
> > > AS1 will flow from IPSP B to IPSP A.
> > > 
> > > Regards
> > > Kamesh Kaul
> > > www.hssworld.com
> > > Hughes Software Systems
> > > 
> > > 
> > > 
> > > 
> > > "Umesh Vats" <[email-masked]>@ietf.org on
> > 07/30/2003 07:44:36 AM
> > > 
> > > Please respond to <[email-masked]>
> > > 
> > > Sent by:    [email-masked]
> > > 
> > > 
> > > To:    <[email-masked]>
> > > cc:
> > > 
> > > Subject:    [Sigtran] M3UA : IPSP DE behaviour
> > > 
> > > 
> > > Suppose we have two Double Ended IPSPs A and B.
> > AS1 is
> > > application server on IPSP-A and AS2 is
> > application server on IPSP-B
> > > 
> > >      AS1 A----------B AS2
> > > 
> > > Now, IPSP-A sends ASPAC for for AS1 to B. IPSP-B
> > doesn't
> > > activate AS2. After this, can IPSP-B send DATA
> > messages for
> > > AS1 to IPSP-A in any scenario ?
> > > 
> > > Thanks
> > > Umesh Vats
> > > Sr Software Engg.
> > > extn : 8986
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]  https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > 
> === message truncated ===
> 
> 
> __________________________________
> Do you Yahoo!?
> Yahoo! SiteBuilder - Free, easy-to-use web site design 
> software http://sitebuilder.yahoo.com
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 31 Jul 2003 09:53:24 -0700 (PDT)

Francois,
> traffic from a remote AS.
[TOLGA]What I said was to show that trying to send
ASPAC-ACK only when local AS is ACTIVE to prevent
unidirectional flow for DE-IPSP (to my understanding
something which is proposed in this thread) is not
usefull.
> Initiates this ASPTM exchange.
[TOLGA]Yes, this is the point. DE-IPSP has the
potential problem of unidirectional traffic.

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com