Subject: RE: [Sigtran] M3UA IG v04 Section 3.8

From: "J.Javier Pastor (EE/EEM)" <[email-masked]>
Date: Fri, 11 Jul 2003 09:51:40 +0200

Hi Brian, 

See comments below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: jueves, 10 de julio de 2003 15:30
> To: J.Javier Pastor (EE/EEM)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA IG v04 Section 3.8
> 
> 
> Javier,
> 
> Section 3.8 says:
> 
>    5.4 Auditing examples
> 
>    5.4.1 SG State: Uncongested / Unavailable
> 
>           ASP                          SGP
>           ---                          ---
>            |  -------- DAUD --------->  |
>            |  <------ SCON(0) --------  |
>            |  <------- DUNA ----------  |
> 
> What state of a destination is Uncongested/Unavailable?  There is no
> such state in Q.704.  Uncongested routesets are by definition 
> available.
> Inaccessible routesets have no congestion state by definition.

> 
> Did you think that a routeset could be in an unavailble and 
> congested state?
> 
> What is the use of the SCON(0)?  Why is it being sent?
> 
>    5.4.4 SG state: Uncongested / Unavailable
> 
>           ASP                          SGP
>           ---                          ---
>            |  -------- DAUD --------->  |
>            |  <------- DUNA ----------  |
> 
> What is the difference between 5.4.1 and 5.4.4?  They both say
> Uncongested/Available.
> 
> 
It is a typo. In 5.4.1 it should say: SG state: "Uncongested / Available". And of course a DAVA has to be sent.

> 
>    [...]. Where the SGP maintains the congestion status of the SS7
>    destination, the SGP MUST additionally respond with an SCON message
>    before the DAVA or DRST message.  If the SS7 destination is
> 
> When is the SGP required to maintain congestion status?  

In those networks where the congestion levels are handled... There's no change there regarding the RFC. Do you think the RFC requires some additional explanation in this regard?

> What is the
> criteria for an ASP to determine that an SGP should maintain 
> congestion
> status and is violating this MUST.  Why must the ASP require the SGP
> to send SCON in this circumstance?  What interoperability 
> concern is the
> MUST addressing?
> 
It seems to me that it was not clear whether to send the SCON or not during the bakeoff.

Cheers // Javier. 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 11 Jul 2003 03:06:35 -0600

J.Javier,

J.Javier Pastor (EE/EEM) wrote:                                                   (Fri, 11 Jul 2003 09:51:40)
> > Inaccessible routesets have no congestion state by definition.

Is the above diagram in error as well?

> And of course a DAVA has to be sent.

Why then is SCON(0) sent in 5.4.1 above, and not in 5.4.4.

Perhaps you have the typo reversed?  5.4.1 should be Uncongested/Unavailable
(with DAVA instead of DUNA), and 5.4.4 should be just plain Unavailable.

Like so would be correct:

    5.4.1 SG State: Uncongested / Available
 
           ASP                          SGP
           ---                          ---
            |  -------- DAUD --------->  |
            |  <------ SCON(0) --------  |
            |  <------- DAVA ----------  |

    5.4.4 SG state: Unavailable
 
           ASP                          SGP
           ---                          ---

> In those networks where the congestion levels are handled... There's no
> change there regarding the RFC. Do you think the RFC requires some
> additional explanation in this regard?

Well, there is this change:

   Where the SGP does not maintain the congestion status of the SS7
   destination, the response to a DAUD message should always be only a
   DAVA, DRST or DUNA message as appropriate.

When does the SGP not maintain the congestion status of the SS7 destination?
When does it?  The first passage is a MUST and this is a SHOULD.  How is one
to know when an SGP is following the MUST or SHOULD and when it is not?

If it doesn't really matter, why do we say MUST and SHOULD?

> 
> 
> 
> > What is the criteria for an ASP to determine that an SGP should maintain
> > congestion status and is violating this MUST.  Why must the ASP require
> > the SGP to send SCON in this circumstance?  What interoperability concern
> > is the MUST addressing?
> > 

How is it clearer now?  One still doesn't know when an SGP MUST or SHOULD NOT
send SCON because there is no criteria for determining when an SGP maintains
congestion state (a completely undefined concept).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/