Subject: RE: [Sigtran] M3UA IG v04 Section 3.14

From: "J.Javier Pastor (EE/EEM)" <[email-masked]>
Date: Tue, 22 Jul 2003 12:54:07 +0200

Samuel, 

I agree, an AS is in DOWN state when all its ASPes are in DOWN state. As soon as the first ASP gets the ASP-INACTIVE state, the AS moves to ACTIVE. As n just refers to traffic processing we'll rely on it only for the transition IA2AC...

Then AS-DOWN is not needed for NTFY messages since this state is reached when all ASPs are in ASP-DOWN. Right?

Cheers // Javier.

> -----Original Message-----
> From: Samuel Dur D. Jeyaseelan [mailto:[email-masked]]
> Sent: martes, 22 de julio de 2003 12:45
> To: J.Javier Pastor (EE/EEM)
> Cc: [email-masked]' '
> Subject: RE: [Sigtran] M3UA IG v04 Section 3.14
> 
> 
> 
> Pastor,
>  I think,it has been decided to add AS-DOWN in NTFY message.
>  in n+k reduntancy case, When do we move the AS to DOWN state?
>  (normally an AS is in DOWN state when all its ASPes are in 
> DOWN state)
> 
> --Samuel 
> 
>   Alcatel USA, Inc.                  Internet: 
> <userid>@ssd.usa.alcatel.com
>   1000 Coit Road, Plano, Texas 75075
>   ******* The opinions expressed are not those of Alcatel 
> USA, Inc. *******
> 
> On Tue, 22 Jul 2003, J.Javier Pastor (EE/EEM) wrote:
> 
> > Samuel, 
> > 
> > In this case, I'm afraid you are not ready to handle the 
> traffic with other ASPs since all of them are in ASP_DOWN. If 
> you want to have a fail-safe configuration, you need to have 
> at least one ASP in ASP_INACTIVE state. Then you could NTFY...
> > 
> > Cheers // Javier.
> > 
> > > -----Original Message-----
> > > From: Samuel Dur D. Jeyaseelan 
> [mailto:[email-masked]]
> > > Sent: martes, 15 de julio de 2003 6:06
> > > To: [email-masked]' '
> > > Subject: Re: [Sigtran] M3UA IG v04 Section 3.14
> > > 
> > > 
> > > 
> > > Brian,
> > > 
> > >  In n=5(example) case, if 4 ASPes are in DOWN state and 1 ASP 
> > > is in ACTIVE
> > >  state and which handles the traffic.Suppose ACTIVE ASP moves 
> > > to INACTIVE 
> > >  or DOWN state so SGP tries sending NTFY(AS-DOWN) to other ASPes.
> > > 
> > >  How does an ASP process NTFY message in DOWN state?
> > > 
> > > 
> > > --Samuel
> > >   Alcatel USA, Inc.                  Internet: 
> > > <userid>@ssd.usa.alcatel.com
> > >   1000 Coit Road, Plano, Texas 75075
> > >   ******* The opinions expressed are not those of Alcatel 
> > > USA, Inc. *******
> > > 
> > > On Mon, 14 Jul 2003, Brian F. G. Bidulock wrote:
> > > 
> > > > Samuel,
> > > > 
> > > > To what end?
> > > > 
> > > > --brian
> > > > 
> > > > Samuel Dur D. Jeyaseelan wrote:                             
> > >                         (Mon, 14 Jul 2003 09:06:36)
> > > > > 
> > > > > Javier,Brian,
> > > > > 
> > > > > 
> > > > >  (i was bit late to enter into this conversation)
> > > > > 
> > > > >  Including a new status type 'AS-DOWN' in NTFY messages 
> > > is a good idea,
> > > > >  but section 4.3.4.5 in RFC says an ASP in DOWN state 
> > > will not process
> > > > >  NTFY message....?
> > > > > 
> > > > > 
> > > > >  Let me take an example of n=5, SGP needs 5 ASPes in 
> ACTIVE state
> > > > >  to declare the AS as ACTIVE(true-only for start case).
> > > > > 
> > > > >  Start-case
> > > > >  ----------
> > > > > 
> > > > >  ACTIVE ASPes    INACTIVE ASPes  DOWN ASPes    AS state   
> > >      case-#
> > > > >  
> > > 
> --------------------------------------------------------------------
> > > > >     0             0               5            DOWN       
> > >      case-1
> > > > >     0             1               4            DOWN       
> > >      case-2
> > > > >     0             2               3            DOWN       
> > >      case-3
> > > > >     .
> > > > >     .
> > > > >     .
> > > > >     0             5               0            INACTIVE   
> > >      case-4
> > > > >     1             4               0            INACTIVE   
> > >      case-5
> > > > >     .
> > > > >     .
> > > > >     .
> > > > >     5             0               0            ACTIVE     
> > >      case-6
> > > > > 
> > > > >    (assume traffic flows)
> > > > > 
> > > > >     Non-start case
> > > > >     --------------
> > > > >     4             1               0            ACTIVE     
> > >      case-7
> > > > >     3             2               0            ACTIVE     
> > >      case-8
> > > > >     .
> > > > >     .
> > > > >     .
> > > > >     1             4               0            ACTIVE     
> > >      case-8
> > > > >     0             5               0            INACTIVE   
> > >      case-9
> > > > >     0             4               1            still 
> > > INACTIVE  case-10
> > > > >     0             3               2            still 
> > > INACTIVE  case-11
> > > > >     .
> > > > >     .
> > > > >     .
> > > > >     0             1               4            still 
> > > INACTIVE  case-12
> > > > >     0             0               5            DOWN       
> > >      case-13
> > > > > 
> > > > > 
> > > > >  I think we should define the following state-conversion 
> > > definition.
> > > > > 
> > > > >  for Start-case
> > > > >  --------------
> > > > > 
> > > > >  DN2IA : One ASP moves to ASP-INACTIVE causing that n 
> ASPs are in
> > > > >          ASP-INACTIVE states.
> > > > > 
> > > > >  IA2DN : One ASP moves to ASP-DOWN causing that n ASPs are in
> > > > >          ASP-DOWN state.
> > > > > 
> > > > >  IA2AC : one ASP moves to ASP-ACTIVE, causing number of 
> > > ASPs are in 
> > > > >          ASP-ACTIVE state.
> > > > > 
> > > > > 
> > > > > Waiting for comments to go ahead.
> > > > > 
> > > > > 
> > > > > --Samuel
> > > > > 
> > > > >   Alcatel USA, Inc.                  Internet: 
> > > <userid>@ssd.usa.alcatel.com
> > > > >   1000 Coit Road, Plano, Texas 75075
> > > > >   ******* The opinions expressed are not those of Alcatel 
> > > USA, Inc. *******
> > > > > 
> > > > > On Mon, 14 Jul 2003, J.Javier Pastor (EE/EEM) wrote:
> > > > > 
> > > > > > Brian, 
> > > > > > 
> > > > > > What you say it's right, only 1 'n' transition would be 
> > > kept in the proposal: the IA2AC transition.
> > > > > > 
> > > > > > I think it makes sense since "n" refers only to the 
> > > capacity of processing traffic and in the AS-INACTIVE state 
> > > no traffic is processed.
> > > > > > 
> > > > > > Does anyone have any objection to this change?
> > > > > > 
> > > > > > 
> > > > > > Thanks // Javier.
> > > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Brian F. G. Bidulock
> > > > > > To: J.Javier Pastor (EE/EEM)
> > > > > > Cc: [email-masked]'
> > > > > > Sent: 11/07/2003 11:13
> > > > > > Subject: Re: [Sigtran] M3UA IG v04  Section 3.14
> > > > > > 
> > > > > > J.Javier,
> > > > > > 
> > > > > > J.Javier Pastor (EE/EEM) wrote:
> > > > > > (Fri, 11 Jul 2003 10:35:57)
> > > > > > > Hi Brian, 
> > > > > > > 
> > > > > > > You are right saying that there is currently no way 
> > > of notifying
> > > > > > AS-DOWN. In
> > > > > > > fact "n" only applies to the traffic case.
> > > > > > > 
> > > > > > > Then I see two options:
> > > > > > > 	1- include AS-DOWN in NTFY
> > > > > > > 	2- The AS-DOWN state is only got when all the 
> > > ASPs are in
> > > > > > ASP-DOWN state.
> > > > > > > 
> > > > > > > I would addopt 2 since it is inline what we are 
> > > having in the other
> > > > > > UALs. 
> > > > > > 
> > > > > > Yes, please go with 2 as it is also in line with the RFC.
> > > > > > 
> > > > > > That will also leave only 1 'n' transition in the 
> > > proposal: the IA2AC
> > > > > > transition, correct?
> > > > > > 
> > > > > > --brian
> > > > > > 
> > > > > > > 
> > > > > > > Thanks // Javier.
> > > > > > > 
> > > > > > > 
> > > > > > > > -----Original Message-----
> > > > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > > > Sent: jueves, 10 de julio de 2003 17:15
> > > > > > > > To: J.Javier Pastor (EE/EEM)
> > > > > > > > Cc: [email-masked]'
> > > > > > > > Subject: Re: [Sigtran] M3UA IG v04 Section 3.14
> > > > > > > > 
> > > > > > > > 
> > > > > > > > Javier,
> > > > > > > > 
> > > > > > > > Section 3.14 says:
> > > > > > > > 
> > > > > > > >    IA2DN: One ASP moves to ASP-DOWN causing that 
> > > the number of ASPs
> > > > > > in
> > > > > > > >    either ASP-ACTIVE or ASP-INACTIVE drops below n.
> > > > > > > > 
> > > > > > > > Am I correct to say that if n=5 and there are 4 
> ASPs in the 
> > > > > > > > ASP-INACTIVE
> > > > > > > > and 1 ASP in the ASP-ACTIVE state, and then the 1 
> > > active ASP moves
> > > > > > to
> > > > > > > > the ASP-DOWN state and T(r) expires that the AS is 
> > > to move to 
> > > > > > > > the AS-DOWN
> > > > > > > > state?  As follows:
> > > > > > > > 
> > > > > > > >   If T(r) expires before an ASP becomes ASP-ACTIVE, 
> > > the SGP MAY stop
> > > > > > > >   queuing messages and discards all
> > > > > > > >   previously queued messages. The AS will move to the 
> > > > > > > > AS-INACTIVE state
> > > > > > > >   if at least the number of ASPs in ASP-INACTIVE 
> > > sum n, otherwise it
> > > > > > > >   will move to AS-DOWN state.
> > > > > > > > 
> > > > > > > > Now, that is an AS state change and we must 
> send a NTFY to 
> > > > > > > > all the INACTIVE
> > > > > > > > ASPs (the 4 left inactive) of the state change. 
>  But from 
> > > > > > > > Section 3.8.2 of
> > > > > > > > the RFC, there is no message to notify of an 
> AS-DOWN state:
> > > > > > > > 
> > > > > > > >          1    reserved
> > > > > > > >          2    Application Server Inactive (AS-INACTIVE)
> > > > > > > >          3    Application Server Active (AS-ACTIVE)
> > > > > > > >          4    Application Server Pending (AS-PENDING)
> > > > > > > > 
> > > > > > > > You see, we removed it because there was never an 
> > > instance in which
> > > > > > it
> > > > > > > > would be sent.  You have inserted an instance again.
> > > > > > > > 
> > > > > > > > Aren't you going to have to define a Notify 
> message (the 
> > > > > > > > Reserved value)
> > > > > > > > for "Application Server Down (AS-DOWN)" so that the 
> > > INACTIVE ASPs
> > > > > > can
> > > > > > > > be properly notified by the SGP?
> > > > > > > > 
> > > > > > > > Particularly when the RFC says in Section 
> 4.3.4.5: (Notify
> > > > > > Procedures)
> > > > > > > > 
> > > > > > > >    A Notify message reflecting a change in the AS 
> > > state MUST 
> > > > > > > > be sent to
> > > > > > > >    all ASPs in the AS, except those in the ASP-DOWN 
> > > state, with
> > > > > > > >    appropriate Status Information and any ASP 
> > > Identifier of the
> > > > > > failed
> > > > > > > >    ASP.  At the ASP, Layer Management is informed 
> > > with an M-NOTIFY
> > > > > > > >    indication primitive.  The Notify message 
> must be sent 
> > > > > > > > whether the AS
> > > > > > > >    state change was a result of an ASP failure or 
> > > reception of an
> > > > > > ASP
> > > > > > > >    State management (ASPSM) / ASP Traffic 
> Management (ASPTM)
> > > > > > message.
> > > > > > > >    In the second case, the Notify message MUST be 
> > > sent after 
> > > > > > > > any related
> > > > > > > >    acknowledgement messages  (e.g., ASP Up Ack, ASP 
> > > Down Ack, 
> > > > > > > > ASP Active
> > > > > > > >    Ack, or ASP Inactive Ack).
> > > > > > > > 
> > > > > > > > The above tells me that I MUST send a Notify 
> > > message becase of the
> > > > > > AS
> > > > > > > > state change, but there is no message to inform 
> > > about AS-DOWN state
> > > > > > > > transition.
> > > > > > > > 
> > > > > > > > What is the purpose of doing this?  What is the 
> protocol 
> > > > > > > > difference between
> > > > > > > > the AS-DOWN state and the AS-INACTIVE state?  What 
> > > is it that the
> > > > > > SGP
> > > > > > > > does or doesn't do in the one state that it 
> doesn't or does 
> > > > > > > > do in the other?
> > > > > > > > 
> > > > > > > > I don't recall this being discussed at all.
> > > > > > > > 
> > > > > > > > Please clarify.
> > > > > > > > 
> > > > > > > > -- 
> > > > > > > > Brian F. G. Bidulock
> > > > > > > > [email-masked]
> > > > > > > > http://www.openss7.org/
> > > > > > > > 
> > > > > > 
> > > > > > -- 
> > > > > > Brian F. G. Bidulock
> > > > > > [email-masked]
> > > > > > http://www.openss7.org/
> > > > > > 
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > 
> > > > 
> > > > -- 
> > > > Brian F. G. Bidulock
> > > > [email-masked]
> > > > http://www.openss7.org/
> > > > 
> > > 
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 22 Jul 2003 13:17:29 -0600

J.Javier,

Right!

--brian

J.Javier Pastor (EE/EEM) wrote:                                                   (Tue, 22 Jul 2003 12:54:07)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/