Subject: RE: [Sigtran] M3UA IG v04 Section 3.14

From: "J.Javier Pastor (EE/EEM)" <[email-masked]>
Date: Fri, 11 Jul 2003 09:28:56 +0200

Hi Brian, 

Pls, see my comments below...

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: jueves, 10 de julio de 2003 15:21
> To: J.Javier Pastor (EE/EEM)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA IG v04 Section 3.14
> 
> 
> Javier,
> 
>    ---------
>    New text: (Section 4.3.4.3, for both loadsharing and broadcast)
>    ---------
> 
>    At start-up or re-start phases, an SGP or IPSP, upon 
> reception of an
>    ASP Active message for the first ASP in a Loadshare AS, SHOULD NOT
>    direct traffic to a newly active ASP until it determines that there
>    are sufficient resources to handle the expected load (e.g., until
>    there are "n" ASPs in state ASP-ACTIVE in the AS).  In 
> this case, the
>    SGP or IPSP SHOULD withhold the Notify (AS-ACTIVE) until there are
>    sufficient resources.
> 
> How can the SGP know when there are sufficient resources?
> 
> 'n'?  How do I count ASPs active for comparison against 'n' at one SGP
> in multiple SGs?
> 
Yes, n is a good measure and it is part of the original text. But no one forbid you using "1" if you want to be more flexible and you are also using the smooth start. 

You can know whether you have "n" counting the ASPs that are active for each AS in your SGP.

> Please provide a definition of, and criteria for, sufficient 
> resources to
> go with the recommendation.

It seems that this is a comment to the RFC, since there is no change included in the IG for that specific sentence. Do you propose any specific wording?

Cheers // Javier.

> --brian

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 11 Jul 2003 02:54:09 -0600

J.Javier,

J.Javier Pastor (EE/EEM) wrote:                                                   (Fri, 11 Jul 2003 09:28:56)
> Yes, n is a good measure and it is part of the original text. But no one
> forbid you using "1" if you want to be more flexible and you are also using
> the smooth start. 

You misunderstand.  I was not questioning 'n'.  What do I count
at the SGP to compare against 'n'.  'n' is the system-wide
number of ASPs necessary to handle the maximum engineered load.
I cannot just set it to '1'.  It is determined by the engineered
traffic handling capacity of the ASPs and the maximum engineered
offered load.

The point here is that the SGP does not know how many ASPs are
active for the AS (system wide).  And has nothing to count that
is comparable to 'n'.

On the other hand, the ASPs do have this information.  And they
SHOULD coordinate amoungst themselves that 'n' are active.
Therefore the SGP can be assured that if 1 ASP is active to it,
that 'n' ASPs will be active system-wide.  And it can activate
on the first ASP active to it.

The AS state machine is in conflict with this.  It requires an
SGP to wait when it need not.  The number of ASPs active to a
given SGP cannot be used to determine the number ASPs active for
the AS system-wide.

> You can know whether you have "n" counting the ASPs that are active for each

It is not necessary that the number of ASPs active for a given
SGP be 'n' for there to be 'n' ASPs active for the AS
systemwide.  Therefore, there can be sufficient ASPs active for
an AS system wide ('n' of them) when there are less than 'n'
ASPs active for a given SGP.

Because the ASPs are required to coordinate amoung themselves
that 'n' are active, the SGP can always be assured that 'n' will
be active and can activate on the first ASP that goes active to
it for the AS.

The recommendation is contrary to that.  It is counting apples
at the SGP an comparing it to oranges at the AS.

> It seems that this is a comment to the RFC, since there is no change
> included in the IG for that specific sentence. Do you propose any specific
> wording?

Yes, there was a change.  From MAY to SHOULD.  No criteria is
necessary when one says MAY.  When one says SHOULD, a criteria
is necessary.

Originally the SGP has the assurance that the ASPs would
coordinate that 'n' of them were active and it did not have to
worry further about it.  The option (MAY) was provided to allow
the SGP to use additional information for stronger assurances if
it would like.  How it went about doing that was its own
business.

With the change to SHOULD, you are saying the SGP cannot rely on
the assurance offered by the requirement for the ASPs to
coordinate that 'n' of them are active, but must apply some new
criteria of sufficiency.  So please define that criteria.

If you are saying that the SGP should still rely on the fact that
'n' ASPs will coordinate and become active, then the proposed AS
state machine is in conflict, because the SGP should then
activate on the first ASP.

So is the AS state machine in conflict or are you defining a new
criteria?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/