Subject: RE: [Sigtran] M3UA IG V04: Receiving REG for a RK already registered

From: "Zannin, Francois" <[email-masked]>
Date: Tue, 15 Jul 2003 10:24:31 +0200

Brian,

This is true that SCTP is a very reliable transport layer but it may
happen that a M3UA on top of SCTP not "bug free" can lost a received
message (maybe due to local congestion?). In that case, if the ASP has
lost the reg_resp, than it cannot deregister the lost RC (because it is
not known), the guilty ASP is then unable to recover the missing RC
unless maybe to send an ASP-DOWN/ASP-UP in order to allows again the AS
registration. Then, all already registered AS on the same associations
are lost!

If the Routing KEY is the same as the one already registered, isn't it
possible for the SG to repeat the same RC?

If the AS (RC) was already ACTIVE on this association, yes it is an
error, then the AS mUST return to the INACTIVE state.

Francois.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]] 
> Sent: Saturday, July 12, 2003 9:03 PM
> To: Umesh Vats
> Cc: VIvek Toky; SIGTRAN e-mail list
> Subject: Re: [Sigtran] M3UA IG V04: Receiving REG for a RK 
> already registered
> 
> 
> Umesh,
> 
> How can the REG-RSP get lost?  SCTP is reliable.
> 
> --brian
> 
> On Sat, 12 Jul 2003, Umesh Vats wrote:
> 
> > Hi  Brian,
> > 
> > This will be useful in the cases where,  REG-RSP from SGP
> > to ASP is lost. In this case, ASP will retry the reuqest 
> and SGP can 
> > send the same RC back.
> > 
> > Umesh
> > 
> > -----Original Message-----
> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf 
> > Of Brian F. G. Bidulock
> > Sent: Friday, July 11, 2003 5:54 PM
> > To: VIvek Toky
> > Cc: SIGTRAN e-mail list
> > Subject: Re: [Sigtran] M3UA IG V04: Receiving REG for a RK already 
> > registered
> > 
> > 
> > VIvek,
> > 
> > Because it is an error.  What would be acheived by sending back the 
> > already registered RC instead?
> > 
> > --brian
> > 
> > On Fri, 11 Jul 2003, VIvek Toky wrote:
> > 
> > >   I have one question related to Registration Request handling in 
> > > M3UA IG V4. I am pasting few lines from Section 3.6
> > >
> > > "If the SGP determines that the received RK was already 
> registered, 
> > > the
> > SGP
> > > returns a registration Response message to the ASP,containing a
> > Registration
> > > Result "Error - Cannot Support Unique Routing". This 
> error applies 
> > > whether the Routing Key is Active or Inactive."
> > >
> > > Is there any reason why SGP should send this error back. 
> Why should 
> > > it not send the same RC back again ?
> > >
> > > thanks,
> > > Vivek.
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> > --
> > Brian F. G. Bidulock    | The reasonable man adapts himself to the |
> > [email-masked]    | world; the unreasonable one persists in  |
> > http://www.openss7.org/ | trying  to adapt the  world  to himself. |
> >                         | Therefore  all  progress  depends on the |
> >                         | unreasonable man. -- George Bernard Shaw |
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock    | The reasonable man adapts himself to the |
> [email-masked]    | world; the unreasonable one persists in  |
> http://www.openss7.org/ | trying  to adapt the  world  to himself. |
>                         | Therefore  all  progress  depends on the |
>                         | unreasonable man. -- George Bernard Shaw |
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 15 Jul 2003 04:36:51 -0600

Francois,

Well, not quite.  Even the buggy M3UA should be able to retain the
Local-Routing-Key-Identifier from the original REG REQ.
All that the ASP need do is reissue If the M3UA cannot maintain the
state of the original REG REQ (i.e, retain the
Local-Routing-Key-Identifier used) then it cannot correlate the REG RSP
anyway.  the REG RSP with the same Local-Routing-Key-Identifier.  The
SGP uses this to determine that the REG REQ is a repeat attempt an
replies with a REG RSP.

REG RSP("Cannot support unique routing") is intended as a reply to a REG
REQ from a different AS at the ASP.  This could be identified by the
presence of a different Local-Routing-Key-Identifier than the original.

I know that this not mentioned in the IG 04, but we discussed it.

Example: an ASP sends a REG REQ and waits.  It gives up and sends
another REG REQ.  It then receives two REG RSP.  We discussed that if an
ASP were to send two REG REQ for the same registration that they should
contain the same LRK-Id.

In the case where a REG REQ contains the same LRK-Id for the same RK,
the response to the second could be the same as the response to the
first. (Successful).

Now, the objectionable lines are in IG 04:

   --------
   New text: (Section 4.4.1)
   ---------

   If the SGP determines that the received RK was already registered,
   the SGP returns a Registration Response message to the ASP,
   containing a Registration Result "Error - Cannot Support Unique
   Routing". This error applies whether the Routing Key is Active or
   Inactive.

But, this (strangely) does not change the pertinent passages in the RFC
which say:

   If the SGP determines that a unique Routing Key cannot be created,
   the SGP returns a Registration Response message to the ASP, with a
   Registration Status of "Error - "Cannot Support Unique Routing"  An
   incoming signalling message received at an SGP should not match
   against more than one Routing Key.

This error was really intended to preclude "overlapping" routing keys
which are verbodden in M3UA.  The error was never intended for attempts
at re-registration by the same AS.

How does the following change sound?

   --------
   New text: (Section 4.4.1)
   ---------

   If the SGP determines that the received RK was already registered,
   and the Local-Routing-Key-Identifier in the RK is the same as the
   Local-Routing-Key-Identifier that was used to register the RK, then
   the SGP treats the REG REQ as a duplicate and returns a Registration
   Response message to the ASP, containing a Registration Result
   "Successful" and the Routing Context associated with the RK.

   If the SGP determines that the received RK was already registered,
   and the Local-Routing-Key-Identifier in the RK does not match the
   Local-Routing-Key-Identifier that was used to register the RK, the
   the SGP treats the REG REQ as an overlapping RK request and returns
   a Registration Response message to the ASP, containing a Registration
   Result "Error - Cannot Support Unique Routing". This error applies
   whether the Routing Key is Active or Inactive.

This would only push the SGP into maintain, along with the fact that the
ASP is registered against the RK, the Local-Routing-Key-Id that was used
by the ASP to register.  4 bytes.  Not too much.

Then an AS can send as many REG REQ as it likes, as long as it uses the
same LRK-Id, it will get the same response.

Sound good?

--brian

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Umesh Vats" <[email-masked]>
Date: Tue, 15 Jul 2003 12:30:48 -0700

Whay does SG need to store the Local RK-Id ? Local RK-Id
is just like transaction id for correlating REG-REQ and REG-RSP for
one exchange of routing key registration procedure.

To find out whether the RK request from an ASP is duplicate or not,
SG can just compare the RK's already registered by the corresponding ASP.

Umesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Brian F. G. Bidulock
Sent: Tuesday, July 15, 2003 3:37 AM
To: Zannin, Francois
Cc: Umesh Vats; VIvek Toky; SIGTRAN e-mail list
Subject: Re: [Sigtran] M3UA IG V04: Receiving REG for a RK already
registered

Francois,

   --------

   --------

Sound good?

--brian

---
Incoming mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.500 / Virus Database: 298 - Release Date: 7/10/2003

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.500 / Virus Database: 298 - Release Date: 7/10/2003

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 15 Jul 2003 13:48:06 -0600

Umesh,

No, because by only comparing RK's the SG cannot distinguish between
a separate AS registering for the same RK from the same ASP.  I thought
I explained this several mails ago.

--brian

---

From: "Umesh Vats" <[email-masked]>
Date: Tue, 15 Jul 2003 13:04:21 -0700

Why will there be two Application Servers with same RK at an
ASP ? There is 1:1 releationship between RK and AS. If an
ASP is sending same RK, this in an Error case no matter
what Local RK-Id is there in the REG-REQ.

SGP can respond with unsuccessful REG-RSP with Rk-Id and RC.

Umesh

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Tuesday, July 15, 2003 12:48 PM
To: Umesh Vats
Cc: Zannin, Francois; VIvek Toky; SIGTRAN e-mail list
Subject: Re: [Sigtran] M3UA IG V04: Receiving REG for a RK already
registered

Umesh,

--brian

---

---

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 15 Jul 2003 15:16:30 -0600

Umesh,

Read back in this thread.  Do a visual grep for "RK neutral".

--brian