Subject: Re: [Sigtran] I-D ACTION:draft-ietf-sigtran-sua-15.txt

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 13:08:49 -0600

Christophe,

IPSP SE is an ASP/SGP relationship and only the ASP side need send
ASP Id.

IPSP DE both send ASPAC and the ASP Id is not needed in ASPUP Ack.

So how would the IPSP use this?

You say to include it in some messages below, but not what the
receiver of the ASPUP Ack is expected (or able) to do with the value.

What would the SE IPSP receiving the ASPUp Ack (remember, acting in ASP
mode) do with it?  There are no procedures defined for an ASP to use
an "SGP Id" if you will...

So, I'm an SE IPSP acting in ASP mode.  I send you an ASPUP and you
send me an ASPUP Ack with an ASP Id in it.  What am I to do with it?
I never send Notify (you do), so what do I do with it?  What use is it?

--brian

Anzile, Christophe wrote:                                                          (Thu, 10 Jul 2003 17:35:08)
> My proposal would be :
> 
> The optional ASP Identifier parameter is specifically useful for IPSP 
> communication. In that case the IPSP answering the ASP Up message MAY 
> include its own ASP Identifier value, so that it can give back its ASP
> Identifier to the demanding IPSP in case of a single UP/UP-Ack exchange.
> For standard AS-SG communication, this parameter MUST NOT be used. 
> 
> 
> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Thursday, July 10, 2003 3:45 PM
> To: [email-masked]
> Cc: Anzile, Christophe; [email-masked]
> Subject: Re: [Sigtran] I-D ACTION:draft-ietf-sigtran-sua-15.txt
> 
> 
> John,
> 
> We discussed this before an nobody had a real problem with it.
> 
> However, more than just adding the optional parameter to the
> ASP Up Ack, it also needs to be described how one should use it.
> Althoug a lot of uses were discussed, nobody put together a
> coherent proposal for its use.
> 
> Does someone have a simple proposal for it use?
> 
> --brian
> 
> John Loughney wrote:                                                                  (Thu, 10 Jul 2003 16:33:51)
> > Hi,
> > 
> > That could be reasonable - anyone have problems with this?
> > 
> > John
> > 
> > > -----Original Message-----
> > > From: ext Anzile, Christophe [mailto:[email-masked]]
> > > Sent: 10 July, 2003 12:26
> > > To: Loughney John (NRC/Helsinki)
> > > Cc: [email-masked]
> > > Subject: RE: [Sigtran] I-D ACTION:draft-ietf-sigtran-sua-15.txt
> > > 
> > > 
> > > 
> > > Hi John,
> > > 
> > > section 3.5.2 : 
> > > it would be judicious to add an optional ASP-ID parameter in 
> > > the UP-ACK message,
> > > especially for IPSP communication (think of single exchange).
> > > 
> > > Regards,
> > > Christophe.
> > > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Anzile, Christophe" <[email-masked]>
Date: Thu, 10 Jul 2003 17:35:08 +0200

My proposal would be :

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Thursday, July 10, 2003 3:45 PM
To: [email-masked]
Cc: Anzile, Christophe; [email-masked]
Subject: Re: [Sigtran] I-D ACTION:draft-ietf-sigtran-sua-15.txt

John,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/