Subject: [Sigtran] M3UA - RC in SSNM messages

From: "Valerie Gastaud" <[email-masked]>
Date: Thu, 10 Jul 2003 17:48:35 +0200

Is there any reason why M3UA requires to insert all the Routing Contexts in
the SSNM messages when the message applies to all the AS; while in the same
situation, M3UA allows not to insert any RC in the ASPAC and ASPIA messages.

Valerie

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 10:22:16 -0600

Valerie,

M3UA does not require one to insert RCs in all SSNM message:

Section 3.4.1 of the RFC says:

   Routing Context: n x 32-bits (unsigned integer)

      The optional Routing Context parameter contains the Routing
      Context values associated with the DUNA message.  Where a Routing
      Key has not been coordinated between the SGP and ASP, sending of
      Routing Context is not required.  Where multiple Routing Keys and
      Routing Contexts are used across a common association, the Routing
      Context(s) MUST be sent to identify the concerned traffic flows
      for which the DUNA message applies, assisting in outgoing traffic
      management and internal distribution of MTP-PAUSE indications to
      MTP3-Users at the receiver.

This is really no different than the ASPTM messages.

--brian

Valerie Gastaud wrote:                                                             (Thu, 10 Jul 2003 17:48:35)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 09:47:31 -0700 (PDT)

Brian,
--- "Brian F. G. Bidulock" <[email-masked]>
> This is really no different than the ASPTM messages.
[TOLGA] IMO it is not the same. An ASPAC with no RC
inside is applicable for configured AS -so even
multiple AS is served via the same association, one
can send ASPAC with no RC-, but RC is mandatory for
SSNM, traffic for more than one AS is carried over the
same association.
> Valerie Gastaud wrote:                              
>                               (Thu, 10 Jul 2003
> 17:48:35)

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 11:55:56 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 10 Jul 2003 09:47:31)
> >       The optional Routing Context parameter contains the Routing Context
> >       values associated with the DUNA message.  Where a Routing Key has
> >       not been coordinated between the SGP and ASP, sending of Routing
> >       Context is not required.  Where multiple Routing Keys and Routing
> >       Contexts are used across a common association, the Routing
> >       Context(s) MUST be sent to identify the concerned traffic flows for
> >       which the DUNA message applies, assisting in outgoing traffic

Section 4.3.4.3:

                    ...  In the case where an ASP wishes to process the
   traffic for more than one Application Server across a common SCTP
   association, the ASP Active message(s) SHOULD contain a list of one
   or more Routing Contexts to indicate for which Application Servers
   the ASP Active message applies. ...

How is this so different?

3.4.1 says MUST for SSNM (as it does for DATA) whereas 4.3.5.3 says SHOULD
for ASP Active (ASPTM).

Valerie asked why M3UA allowed you to not insert any RC in ASPAC and ASPIA
when it was required in SSNM.

Well, the answer is that it SHOULD be included in ASPTM as well according
to the passage above.

Also, if you are configuring multiple AS over the same SCTP association and
then activating without an RC, you are going against the SHOULD above, and
you are on your own.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 11:10:20 -0700 (PDT)

Brian,

I was referring to 4.3.4.3 ASP Active Procedures:
"In the case where an ASP Active message does not
contain a Routing Context parameter, the receiver must
know, via configuration data, which Application
Server(s) the ASP is a member."
This enables the option to send ASPAC with no RC, even
if multiple AS traffic is carried over one
association. I don't think, this is permitted for
SSNM.

    Tolga

wrote:
> Tolga Asveren wrote:                                
> 09:47:31)
> > > M3UA does not require one to insert RCs in all
> SSNM
> > > message:
> > >

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 12:58:35 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 10 Jul 2003 11:10:20)
> association. I don't think, this is permitted for

It permits a single AS in fitting with the SHOULD I quoted.  Multiple
configured AS for the same association would be against the SHOULD.
So you are still on your own.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 12:48:14 -0700 (PDT)

Brian,
wrote:
> 11:10:20)
[TOLGA]Then why does it say "Application Server(s)"
                                                ^ 
I am pretty sure, what is meant here (In fact even
just two days ago, there was a qustion related with
this)
> > >                                 (Thu, 10 Jul
> 2003
> > > > >       values associated with the DUNA
> message. 
> > > Where a Routing Key has
> > > > >       not been coordinated between the SGP
> and
> > > ASP, sending of Routing
> > > > >       Context is not required.  Where
> multiple
> > > Routing Keys and Routing
> > > > >       Context(s) MUST be sent to identify
> the
> > > concerned traffic flows for
> > > > >       which the DUNA message applies,
> assisting
> > > in outgoing traffic
> > > > >       management and internal distribution
> of
> > > MTP-PAUSE indications to
> > > > [TOLGA] IMO it is not the same. An ASPAC with
> no
> > > RC
> > > > multiple AS is served via the same
> association,
> > > one
> > > > can send ASPAC with no RC-, but RC is
> mandatory
> > > for
> > > > SSNM, traffic for more than one AS is carried
> over
> > > the
> > > > same association.
> > > 
> > > Section 4.3.4.3:
> > > 
> > >                     ...  In the case where an
> ASP
> > > wishes to process the
> > >    or more Routing Contexts to indicate for
> which
> > > Application Servers
> > > Valerie asked why M3UA allowed you to not insert
> any
> > > RC in ASPAC and ASPIA
> > > Well, the answer is that it SHOULD be included
> in
> > > ASPTM as well according
> > > to the passage above.
> > > 
> > > Also, if you are configuring multiple AS over
> the
> > > same SCTP association and
> > > then activating without an RC, you are going
> against
> > > the SHOULD above, and
> > > you are on your own.
> > > 
> > > --brian
> > > 
> > > 
> > > > > 
> > > > > --brian
> > > > > 
> > > > > Valerie Gastaud wrote:                      
>    
> > >    
> > > > >                               (Thu, 10 Jul
> 2003
> > > > > 17:48:35)
> > > > > > 
> > > > > > the SSNM messages when the message applies
> to
> > > all the AS; while in the same
> > > > > > situation, M3UA allows not to insert any
> RC in
> > > the ASPAC and ASPIA messages.
> > > > > > 
> > > > > > Valerie
> > > > > > 
> > > > > > 
> > > > > > 
> > > > > >
=== message truncated ===

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 14:26:54 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 10 Jul 2003 12:48:14)
> just two days ago, there was a qustion related with

If you recall, the (s) predates the RC in SSNM and DATA
discussion.  The SHOULD was put in after, at the same
time as the RC passages in SSNM and DATA.  If you have
multiple AS on the same association you need to put RC
in all messages.  This was one reason we changed "Optional"
to "Conditional' for RC throughout the document.  The
same condition applies in all cases.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Valerie Gastaud" <[email-masked]>
Date: Fri, 11 Jul 2003 10:27:26 +0200

Brian, Tolga,

so, the conclusion is that when there are multiple AS on the same
association, all the messages (SSNM, DATA and ASPTM) MUST contain the RC
parameter.

if this is agreed by everyone, can we remove the (s) of Application Server
in the following sentence from section 4.3.4.3 ASP Active Procedures:
                   ... In the case where an ASP Active message does not
	contain a Routing Context parameter, the receiver must know, via
configuration 	data, which Application Server(s) the ASP is a member.

and change the RC from optional to conditional in the ASPTM messages as well

and change the SHOULD in section 4.3.4.3 by a MUST:

Valerie
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Brian F. G. Bidulock
Sent: jeudi 10 juillet 2003 22:27
To: Tolga Asveren
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA - RC in SSNM messages

Tolga,

Tolga Asveren wrote:
(Thu, 10 Jul 2003 12:48:14)

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 11 Jul 2003 03:25:06 -0600

Valerie,

I would have no problems with that.  Would that firm things up for you?

Does anyone rely on the (s)?

I think that it would be quite easy to redefine 3 configured AS as
a single compound AS at the SG anyway, and still not have to send RC.

--brian

Valerie Gastaud wrote:                                                             (Fri, 11 Jul 2003 10:27:26)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Valerie Gastaud" <[email-masked]>
Date: Fri, 11 Jul 2003 18:29:40 +0200

Brian,

Yes, this makes it consistent. There is no more difference between ASPTM and
SSNM/DATA messages.

Valerie
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Brian F. G. Bidulock
Sent: vendredi 11 juillet 2003 11:25
To: Valerie Gastaud
Cc: Tolga Asveren; [email-masked]
Subject: Re: [Sigtran] M3UA - RC in SSNM messages

Valerie,

--brian

Valerie Gastaud wrote:
(Fri, 11 Jul 2003 10:27:26)

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/