Subject: RE: [Sigtran] M3UA IG v04

From: "Zannin, Francois" <[email-masked]>
Date: Thu, 10 Jul 2003 17:56:26 +0200

All,

One more question about IPSP. 
If an AS is registered only with a PC and the IPSP is able to handle
traffic 
for several SI, what could be the answer of the IPSP if it receive a
message 
for a SI that is not available. 
Is it possible for an IPSP to send a DUPU (a SSNM) for this specific SI
to 
the originating IPSP? Or is this configuration prohibited (PC Only) if
the 
IPSP serve more than one SI?

Regards,

Francois.

> -----Original Message-----
> From: Javier Pastor-Balbas (ECE) 
> [mailto:[email-masked]] 
> Sent: Thursday, July 03, 2003 10:59 AM
> To: [email-masked]
> Cc: [email-masked]'; Samuel Dur D. Jeyaseelan
> Subject: [Sigtran] M3UA IG v04
> 
> 
> 
> Hi guys,
> 
> We tried to submit the next IG version before the deadline, 
> but I got confused since I thought it ended at 12:00 instead 
> of 9:00. So the server bounced it. I'll submit the doc again 
> after the IETF meeting. In the meantime you can find it at:
> 
> http://standards.ericsson.net/javier/draft-ietf-sigtran-m3ua-i
> mplementors-guide-04.txt
> 
> We've tried to include all the different opinions in here. 
> Although it seems that the case of waiting till n ASPs is the 
> preferred one, we have included the new possibility of a 
> smooth start for those of you who want to activate the AS 
> when the first ASP gets to ACTIVE. At the end it will be the 
> operator's decission how to proceed during the activation 
> phase. Hopefully everyone agrees on this wording...
> 
> Cheers // Javier.
> 
> 
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 10:34:44 -0600

Francois,

The SS7 standards say that if an MTP-User accepts transfer traffic for
an entire point code (without associating itself with an MTP-SAP) then
it is responsible for user-part flow control.

There is, therefore, not MTP-STATUS Request primitive, just an MTP-STATUS
Indication primitive.

The MTP-User that is responsible for an entire point code must provide the
MTP-SAP (SI value) on all MTP-TRANSFER Request primitives anyway, so sending a
UPU is possible.

That is, to perform user-part flow control, rather than sending DUPU, it
should send a DATA message containing a UPU.

This permits an MTP implementation to transfer the message without
implementing some special MTP-STATUS Request primitive.  Inside the SGP
implementation, the only response to a DUPU would be sending the identical
UPU anyway, on the M3UA side of the NIF (because MTP does not have a
MTP-STATUS Indication primitive).

That is also the case for IPSP SE ASP side with Point-Code AS.

OTOH IPSP DE as defined in the IG needs to send DUPU, because both IPSPs
act as SGPs.

--brian

Zannin, Francois wrote:                                                            (Thu, 10 Jul 2003 17:56:26)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 09:57:36 -0700 (PDT)

Brian/Francois,

Just my 2 cents below....

   Tolga
--- "Brian F. G. Bidulock" <[email-masked]>
> That is also the case for IPSP SE ASP side with
[TOLGA]For SE IPSP, IMO there is no need for UPU/DUPU
etc... SE IPSP is two AS communicating each other. AS
is available or not, never partly available. If one
chooses to use PC granularity, then when on user part
goes down, IMO the whole AS is INACTIVE. If one wants
finer granularity, then AS should be defined
accordingly.
> OTOH IPSP DE as defined in the IG needs to send
[TOLGA] I think the same for DE IPSP case as defined
in IG.
> Zannin, Francois wrote:                             
>                               (Thu, 10 Jul 2003
> 17:56:26)

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 10:36:14 -0700 (PDT)

After thinking a bit more, I believe also for DE IPSP
case as defined in IG, there is no need to send DUPU.
Afterall, it behaves like 2 SGP/ASPs. Like there is no
need for DUPU from ASP to SGP, I think the same should
be true for DE IPSP. So, DE IPSP should also send
ASPIA in such a case, IMO.

DUPU makes sense for SG-SG communication, which mimics
MTP3/MTP3 communication, instead of MTP3/MTP3 user
part communication.
  
   Tolga
--- Tolga Asveren <[email-masked]> wrote:
> > implementation, the only response to a DUPU would
> be
> > sending the identical
> > UPU anyway, on the M3UA side of the NIF (because
> MTP
> > does not have a
> > > If an AS is registered only with a PC and the
> IPSP
> > is able to handle
> > > traffic 
> > > Is it possible for an IPSP to send a DUPU (a
> SSNM)
> > for this specific SI
> > > to

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 11:38:58 -0600

Tolga,

IPSP DE in the IG is defined as acting in the role of
two SGPs.  SGPs already send DUPU and it must therefore
be permitted for IPSPs in DE.

--brian

Tolga Asveren wrote:                                                                 (Thu, 10 Jul 2003 10:36:14)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 10:46:37 -0700 (PDT)

Brian,
> be permitted for IPSPs in DE.
[TOLGA] Yes, SGPs send DUPU to ASPs but to my
understanding, Francois's case would correspond
sending DUPU from ASP to SGP.
As I said, my interpretation of DE IPSP in the IG is a
combined SGP/ASP. On ASP part of IPSP, the user part
goes down, then I would expect inactivating the
corresponding AS.
> Tolga Asveren wrote:                                
> 10:36:14)
> > > > This permits an MTP implementation to transfer
> the
> > > > message without
> > > > That is also the case for IPSP SE ASP side
> with
> > > > Point-Code AS.
> > > etc... SE IPSP is two AS communicating each
> other.
> > > AS
> > > > OTOH IPSP DE as defined in the IG needs to
> send
> > > > DUPU, because both IPSPs
> > > > act as SGPs.
> > > >                               (Thu, 10 Jul
> 2003
> > > > > for several SI, what could be the answer of
> the
> > > > IPSP if it receive a
> > > > > message 
> > > > > the originating IPSP? Or is this
> configuration
> > > > prohibited (PC Only) if
> > > > > the

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 10 Jul 2003 12:00:33 -0600

Tolga,

Tolga Asveren wrote:                                                                 (Thu, 10 Jul 2003 10:46:37)
> goes down, then I would expect inactivating the

Yes, that's what we understood and agreed, however, that is
not what is presented in the IG: Read the IG again:
New text in section 3.11.2:

   In section 4.3.1: ASP/IPSP States, only the SGP-ASP and the IPSP SE
   scenarios are described. For the IPSP DE model, both IPSPs MUST
   follow the SGP side of the SGP-ASP procedures.

That looks pretty plain to me.  According to the IG, DE IPSPs can
send DUPU (they are actually required above to do so when the SGP
procedure dictates).

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 10 Jul 2003 12:46:32 -0700 (PDT)

Brian,
[..snip..]
> send DUPU (they are actually required above to do so
[TOLGA]IMO, the sentence you refer might really be
mislaeading, but I don't think it should make the SGP
send DUPU for the case we are describing. Let's say we
have IPSP1 and IPSP2. If one user part is down on
IPSP2, then it should be ASP part of IPSP2 taking some
action and sending ASPIA, not SGP part of IPSP2.

__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com