Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

From: "Vivek Toky" <[email-masked]>
Date: Thu, 31 Jul 2003 10:04:32 -0700

Please see my comments inline

> See my opigion online
> 
> > -----Original Message-----
> > From: Vivek Toky [mailto:[email-masked]] 
> > Sent: Thursday, July 31, 2003 2:42 PM
> > To: Tolga Asveren; [email-masked]
> > Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
> > 
> > 
> > Hi Tolga,
> >   "Above case" means 
> > "when AS1 has activated itself by sending
> >  ASP Active from both the IPSPs (A & B) but 
> >  AS2 has sent ASP Active just to IPSP_A."
> > 
> > In my opinion IPSP_C should loadshare the traffic
> > as it has received ASP active from both the IPSPs
> > so AS1 is accessible through both of these.
> > However, it is the responsibility of AS1 to route
> > all the traffic towards AS2 through IPSP_A.
> 
> If IPSP_B receive some traffic from IPSP_C BUT no AS is ACTIVE for 
it on
> IPSP_C can it route this traffic???
> CAN a SG send to a ss7 network a message receive from an INACTIVE 
ASP !
> I don't think so!
> IPSP DE must be considered as two ASP/SG head to tail.
> 
[Vivek]
AS is ACTIVE on IPSP_B (remember it sent ASP Active message)
As far as the SGP - ASP example see the following..

1. It is the AS which is Active or Inactive not ASP
2. ASPTM ptocedures are between SGPs and ASPs not SG and ASPs

The local AS on the ASP may be active through some other
SGP (say SGPy)to which an ACTIVE message has been sent.
So SGP (say SGPx) should route the traffic to SS7 coming from an 
ASP which is inactive for an AS, because that AS is 
Active through some other SGP and SS7 destination may still 
be able to send the traffic towards that AS through some 
other SGP

In M3UA outgoing and Incoming Traffic flows are independent,
so why restrict the traffic ?

> > 
> > In either case I think it is worth mentioning in 
> > Implementor's guide whether Unidirectional traffic
> > is possible between associations(in case of 
> > IPSP DE) or not.It will avoid any further
> > confusion or possible interoperatibility issues.
> > 
> > thanks,
> > 
> > -Vivek.
> > 
> > > Vivek,
> > > --- Vivek Toky <[email-masked]> wrote:
> > > > Hi All,
> > > >  What should be done in the following case:
> > > > 
> > > > 
> > > >       |IPSP_A                             |
> > > >   AS1 |      ---------------------- IPSP_C| AS2
> > > >       |IPSP_B                             |
> > > > 
> > > > IPSP_A and IPSP_B are in loadshare mode.
> > > > 
> > > >   when AS1 has activated itself by sending
> > > > ASP Active from both the IPSPs (A & B) but
> > > > AS2 has sent ASP Active just to IPSP_A. 
> > > > 
> > > > What should IPSP_C do on receiving traffic for AS1?
> > > > 
> > > > a) Loadshare the traffic towards IPSP_A and IPSP_B
> > > > 
> > > > or
> > > > 
> > > > b) It should send all the traffic to IPSP_A and 
> > > >    wait untill it sends ASP Active IPSP_B as well.
> > > >    In the above case IPSP_B cannot send the traffic 
> > > >    towards IPSP_C but IPSP_C can.
> > > [TOLGA]It should send all traffic to IPSPS_A. Which
> > > case do you refer as "the above case", a) or b) ?
> > > > 
> > > > thanks,
> > > > Vivek.
> > > > 
> > > 
> > > 
> > > __________________________________
> > > Do you Yahoo!?
> > > Yahoo! SiteBuilder - Free, easy-to-use web site design software 
> > > http://sitebuilder.yahoo.com
> > > 
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/sigtran
> > > 
> > > 
> > 
> > -- 
> > Continuous Computing
> > http://www.ccpu.com
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> 
> 

-- 
Continuous Computing
http://www.ccpu.com

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 31 Jul 2003 10:19:29 -0700 (PDT)

Vivek,
> AS is ACTIVE on IPSP_B (remember it sent ASP Active
[TOLGA]State of an AS is in the context of an ASP/SGP
pair. That ASP (IPSP_B) sends ACTIVE does not mean
that AS is ACTIVE for the SGP, unless SGP sends
ASPAC-ACK (IPSP_C in your example)

---

From: "VIvek Toky" <[email-masked]>
Date: Thu, 31 Jul 2003 10:49:39 -0700

Tolga,

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Tolga Asveren
Sent: Thursday, July 31, 2003 10:19 AM
To: [email-masked]
Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

Vivek,

You are right, state of AS is in context of ASP, this was
what I wanted to say. I am assuming that SGP did send
ACTIVE ack back and ASP( for that AS) is active through
the SGP from which it got the ACK back. Is it fine now...