Subject: Re: FW: [Sigtran] M2PA Last Call Comment

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 14 Jul 2003 04:36:27 -0600

Hanns Juergen,

I'll try again.  This has nothing to do with TDM or MTP3.

M2PA-09 says:

  4.  Procedures

  Since M2PA provides MTP3 with an interface and functionality like
  MTP2, its internal functioning is similar to that of MTP2. 

  Except as modified in this document, M2PA SHOULD follow the
  requirements of the applicable MTP2 specification. These may include
  [Q.703] or [T1.111].

and then later:

  The proving period MAY be omitted if this is allowed by the applicable
  MTP2 standard (e. g., [Q.2210]).

So, M2PA permits one side to follow Q.2140 procedures and the other side
to follow Q.703 procedure, with regard to proving.  This is incompatible
as I have shown.

When following the requirements of the applicable MTP2 specification, it
must be noted that the same MTP2 specification must be followed on both
sides, at least with regard to foregoing proving.  Thus the text change.

--brian

Schwarzbauer Hanns Juergen wrote:                                             (Mon, 14 Jul 2003 12:27:15)
> Bidulock,
> 
> your answer is confusing. why should one side of an M2PA link adhere to
> Q.2140 and the other o Q.703 proving procedures? 
>
> You are still assuming a direct and tight coupling between the TDM and the
> IP side.
>
> In turn the throughput of the M2PA link could NEVER exceed that of the
> corresponding TDM link: 64 kbit in case of Q.703 (excluding annex A for the
> moment). That's not what M2PA was designed for!
> 
> greetings
> 
> HannsJuergen
> 
> > -----Original Message-----
> > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > Sent: Monday, July 14, 2003 12:22 PM
> > To: Schwarzbauer Hanns Juergen
> > Cc: List: IETF sigtran (E-Mail)
> > Subject: Re: FW: [Sigtran] M2PA Last Call Comment
> > 
> > 
> > Schwarzbauer,
> > 
> > Huh?  In the diagram I gave, it is only an M2PA link.  One side is
> > following Q.2140 state machine procedures, the other is following
> > Q.703 state machine procedures.
> > 
> > This has nothing to do with MTP3.
> > 
> > --brian
> > 
> > Schwarzbauer Hanns Juergen wrote:                             
> >                 (Mon, 14 Jul 2003 12:14:56)
> > > Brian,
> > > 
> > > sorry, I can't agree. 
> > > My example scenario contains two SS7 nodes, both having 
> > only M2PA links
> > > between them. I assume that this is still a valid scenario. 
> >  Furthermore, if
> > > you have an SS7 node with more than one TDM based SS7 link 
> > feeding this M2PA
> > > link, what are you going to to there.
> > > 
> > > We are again going to the discussion we had several weeks ago: 
> > > 
> > > is there an MTP Level 3 coupling the TDM links and the M2PA 
> > links and my
> > > answer is still YES. Having that in mind, proving on one 
> > link is completely
> > > independent from proving on another link. 
> > > 
> > > 
> > > greetings
> > > 
> > > HannsJuergen
> > > 
> > > > -----Original Message-----
> > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > Sent: Monday, July 14, 2003 11:40 AM
> > > > To: Schwarzbauer Hanns Juergen
> > > > Cc: List: IETF sigtran (E-Mail)
> > > > Subject: Re: FW: [Sigtran] M2PA Last Call Comment
> > > > 
> > > > 
> > > > Hanns Juergen,
> > > > 
> > > > Consider that one side follows Q.703 and requires proving 
> > while the
> > > > other side follows Q.2140 and foregoes proving.  The 
> > following will
> > > > occur:
> > > > 
> > > >     
> > > > 
> > ___________________________________________________________________
> > > >    |                                                          
> > > >          |
> > > >    |                Q.2140                      Q.703         
> > > >          |
> > > >    |                                                          
> > > >          |
> > > >    |        OUT-OF-SERVICE  ----------------->                
> > > >          |
> > > >    |                        <-----------------  
> > > > OUT-OF-SERVICE         |
> > > >    |                :start                                    
> > > >          |
> > > >    |             ALIGNMENT  ----------------->                
> > > >          |
> > > >    |                                            :start        
> > > >          |
> > > >    |                        <-----------------  ALIGNMENT     
> > > >          |
> > > >    |                 READY  ----------------->                
> > > >          |
> > > >    |                        <-----------------  
> > > > PROVING-NORMAL         |
> > > >    |                              !                           
> > > >          |
> > > >    |                              !  T3         1.0 <= T3 <= 
> > > > 1.5       |
> > > >    |                              !                           
> > > >          |
> > > >    |                        <-----------------  
> > > > OUT-OF-SERVICE         |
> > > >    |                                                          
> > > >          |
> > > >    
> > > > 
> > |___________________________________________________________________|
> > > > 
> > > > Note that the Q.703 side must ignore the READY and await a
> > > > PROVING-NORMAL or PROVING-EMERGENCY (See Q.781 test case 
> > 2.3) and will
> > > > time out (See Q.781 test case 1.3).
> > > > 
> > > > Therefore unless both sides follow the Q.2140 procedures 
> > it will be
> > > > impossible to forego proving and successfuly align the link.
> > > > 
> > > > The issue has little to do with MTP Level 3.  It is solely an 
> > > > MTP Level
> > > > 2 compatibility issue, speaks to interoperability, and the 
> > > > keyword MUST
> > > > should be used.  So,
> > > > 
> > > >   The proving period MAY be ommitted if this is allowed by the
> > > >   applicable standard (e.g., [Q.2140]); however, the same 
> > > > standard MUST
> > > >   be followed on both sides of the M2PA link.
> > > > 
> > > > Does that clear things up for you?
> > > > 
> > > > --brian
> > > > 
> > > > Schwarzbauer Hanns Juergen wrote:                   (Mon, 14 
> > > > Jul 2003 10:31:54)
> > > > > resend, because "sigtran list" wasn't included
> > > > > 
> > > > > -----Original Message-----
> > > > > From: Schwarzbauer Hanns Juergen 
> > > > > Sent: Monday, July 14, 2003 8:46 AM
> > > > > To: [email-masked]'
> > > > > Subject: RE: [Sigtran] M2PA Last Call Comment
> > > > > 
> > > > > 
> > > > > Brian,
> > > > > 
> > > > > I don't understand your second point. There is an MTP L3 
> > > > between the TDM and
> > > > > the IP side, so both sides are decoupled. Thus I can't 
> > > > agree with this
> > > > > point.
> > > > > 
> > > > > greetings
> > > > > 
> > > > > HannsJuergen
> > > > > 
> > > > > > -----Original Message-----
> > > > > > From: Brian F. G. Bidulock [mailto:[email-masked]]
> > > > > > Sent: Saturday, July 12, 2003 7:04 AM
> > > > > > To: [email-masked]'
> > > > > > Subject: [Sigtran] M2PA Last Call Comment
> > > > > > 
> > > > > > 
> > > > > >   The proving period MAY be omitted if this is allowed by the 
> > > > > > applicable
> > > > > >   MTP2 standard (e. g., [Q.2210]).
> > > > > > 
> > > > > > The reference should be Q.2140.
> > > > > > 
> > > > > > It should also be noted that the same approach MUST be 
> > > > > > followed on both sides
> > > > > > the link.  Otherwise, one side following Q.703 will have T3 
> > > > > > timer expire
> > > > > > waiting for PROVING-NORMAL from the side foregoing proving.
> > > > > > 
> > > > > > --brian
> > > > > > 
> > > > > > -- 
> > > > > > Brian F. G. Bidulock
> > > > > > [email-masked]
> > > > > > http://www.openss7.org/
> > > > > > 
> > > > > > _______________________________________________
> > > > > > Sigtran mailing list
> > > > > > [email-masked]
> > > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > > > 
> > > > > 
> > > > > _______________________________________________
> > > > > Sigtran mailing list
> > > > > [email-masked]
> > > > > https://www1.ietf.org/mailman/listinfo/sigtran
> > > > 
> > > > -- 
> > > > Brian F. G. Bidulock
> > > > [email-masked]
> > > > http://www.openss7.org/
> > > > 
> > 
> > -- 
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> > 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Fri, 18 Jul 2003 09:06:19 +0200

Folks,

First of all we need a clarification of terms "Q.703-state-machine-based M2PA link" or "Q.2140-..." 
I'm not aware of any occurrences of these terms.

before spending more bytes on discussions, let's see what ITU-T or ANSI are doing in similiar situations:

 Question: does STP A care about the fact that STPB has links according to Q.2140? 
 Answer: NO, NOT AT ALL, STP A operator might not even know that STP B has Q.2140 links.  

        +-----------+                 +-----------+
   Q.703|           |                 |           |   Q.2140
  ------+           |                 |           +--------
        |           |       Q.703     |           |
        | STP A     +-----------------+   STP B   |
        |           |                 |           |
   Q.703|           |                 |           |   Q.2140
  ------+           |                 |           +--------
        |           |                 |           |
        +-----------+                 +-----------+

Let's go to an IP based link between STP A and STP B

Question: should STP A care about the fact that STP B has links according to Q.2140?
Answer: I see no necessity to deviate from ANSI and ITU-T.

        +-----------+                 +-----------+
   Q.703|           |                 |           |   Q.2140
  ------+           |                 |           +--------
        |           |       M2PA      |           |
        | STP A     +-----------------+   STP B   |
        |           |                 |           |
   Q.703|           |                 |           |   Q.2140
  ------+           |                 |           +--------
        |           |                 |           |
        +-----------+                 +-----------+

If STP A wants to prove, he should do that and STP B has to support STP A in that procedure and vice versa.
But I see no necessity why both sides should perform similiar. 

In all other cases STP A would have to be informed if e.g. STP-B migrates from pure Q.703 to pure Q.2140 and that's not acceptable.

greetings 

HannsJuergen

> Sent: Friday, July 18, 2003 1:55 AM
> To: Tom George
> Cc: IETF sigtran
> Tom,
> Q.703 does not give the option to talk to a Q.2140 link.  But it
> appears that M2PA allows a Q.703-state-machine-based M2PA link to
> talk to a Q.2140-state-machine-based M2PA link.  That is were the
> problem ensues.
> 
> --brian
> 
> Tom George wrote:                                             
>                          (Thu, 17 Jul 2003 17:16:54)
> > Brian,
> > 
> > In the non-IP realm, is it possible for a Q.703 to talk to 
> a Q.2140? 
> > What would be done in the scenario you described?
> > 
> > tomG.
> > 
> > Brian F. G. Bidulock wrote:
> > > Hanns Juergen,
> > > 
> >    [...]
> > * Tom George       PB7-24001 (near B-21)      
> [email-masked]  *
> > * 972-519-3168   Intranet:  
> http://www.ssd.usa.alcatel.com/~tgeorge/  *
> > * Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, 
> Texas 75075  *
> > *   I actively disclaim speaking for Alcatel.  I do not 
> purport to    *
> > *   advertise or represent its position, operations, or 
> activities.   *
> > 
> >