Subject: Re: [Sigtran] M3UA MIB Draft05: Loadsharing on CIC ,SSN

From: [email-masked]
Date: Fri, 4 Jul 2003 12:08:48 +0530

Hi Samule,
  You have not replied for my second question :
I want to know how an MTP3  user (ISUP or SCCP) selects SLS for effective
load distribution at MTP3 layer among the links available to reach a given
DPC. Is it that SLS is chosen per DPC for a logical session or globally per
each logical session irrespective of DPC for which this session is
intended.I know it is implementation dependent option but what do most of
the implementers opt for. By logical session i mean logically related data.

Regards
Kamesh Kaul
www.hssworld.com
Hughes Software Systems

"Samuel Dur D. Jeyaseelan" <[email-masked]>@ietf.org on
07/04/2003 10:58:14 AM

Sent by:    [email-masked]

To:    [email-masked]
cc:

Subject:    Re: [Sigtran] M3UA MIB Draft05: Loadsharing on CIC ,SSN

Pastor,

 MIB-05 does not have 'load-shar on dpc',i was referring mib-04 which lead
 me into confusion.

 Thanks kakaul for our mail.

Kakaul,

 As you said MTP3 does not route messages based on CIC or SSN because
 there are no standards available, i agree with it.

 Have a look, suppose SG receives an MSU with routing indicator="Route on
 PointCode/SSN", if your SG supports static configuration then it is easy
 to route these messages to the corresponding subSystems based on
 statically configured SSN-ASP table the same way CIC-ASP table can be
 used to route ISUP messages to the corresponding MGCs.Basically CIC was
 removed from RFC to avoid complex problems say a msg comes with CIC
 range,this CIC range can be split across MGCs here the problem is
 potential.

 These are the reasons caused me to say that with static configuration
 CIC or/and SSN can be supported if an SG vendor and ASP vendor has
 mutual understanding.(but this is outside the scope of M3UA RFC)

--Samuel

  Alcatel USA, Inc.                  Internet: <userid>@ssd.usa.alcatel.com
  1000 Coit Road, Plano, Texas 75075
  ******* The opinions expressed are not those of Alcatel USA, Inc. *******

On Fri, 4 Jul 2003 [email-masked] wrote:

>
>
>
>
> Hi Samule,
>   Does MTP3 use CIC or SSN for load-distribution among the available
> links.I guess only SLS parameter in MTP3 is used for load-distribution
> among the available link.I want to know how an MTP3  user (ISUP or SCCP)
> selects SLS for effective load distribution at MTP3 layer among the links
> available to reach the  a given DPC.
>
> Regards
> Kamesh Kaul
> www.hssworld.com
> Hughes Software Systems
>
>
>
>
> "Samuel Dur D. Jeyaseelan" <[email-masked]>@ietf.org on
> 07/04/2003 09:29:51 AM
>
> Sent by:    [email-masked]
>
>
> To:    [email-masked]
> cc:
>
> Subject:    Re: [Sigtran] M3UA MIB Draft05: Loadsharing on CIC ,SSN
>
>
>
>  this is just an info regarding CIC and SSN - load-sharing.
>
>  A node can load-share its traffic based on CIC or SSN with the
>  help of static configuration but this is outside of the scope of M3UA
>  rfc.When an ASP vendor and SGP vendor agrees to do load-sharing based on
>  CIC or SSN with static confiuration they are welcome to do this,
>  since this has not been standardised, taking this to interop will
>  lead to problems.So almost everybody agrees to delete CIC and SSN
>  loadsharing concept from MIB-04.
>
>
> --Samuel
>
>   Alcatel USA, Inc.                  Internet:
<userid>@ssd.usa.alcatel.com
>   1000 Coit Road, Plano, Texas 75075
>   ******* The opinions expressed are not those of Alcatel USA, Inc.
*******
>
> On Thu, 3 Jul 2003, Brian F. G. Bidulock wrote:
>
> > agurmukhani,
> >
> > I think that they should be removed from the MIB, but we did NOT agree
> > that CIC or SSN should not be used for loadsharing.  Any criteria that
> > the SG/ASP desires to use for loadsharing being congnisant of the need
> > for ordering of user part messages is allowed for loadsharing.  We DID
> > agree to remove CIC, SSN from the Routing Key, because a rational and
> > interoperable basis for splitting CICs and SSNs across AS could not be
> > decided.
> >
> > The meanse oadsharing, on the other hand, is not specified in M3UA.
> > Some examples are given, but no requirements.  Some things that could
> > clearly be used are SLS, DPC/SLS, OPC/DPC/SLS, CIC, DPC/CIC,
OPC/DPC/CIC,
> > OPC/DPC/CIC/SLS, SSN, ....  and other permutations of these and even
> > higher layer parameters such as TID.
> >
> > My argument for removing them from the MIB is not that they cannot be
> > used, but that they have not been standardized.
> >
> > --brian
> >
> > [email-masked] wrote:
> (Thu, 03 Jul 2003 10:23:35)
> > >
> > >
> > >
> > >
> > > Hi...
> > >
> > >
> > > In my understanding and  as per the discussion and consensus on the
> mailing
> > > list , everyone agreed that  CIC and SSN should not be used as
> loadsharing
> > > basis
> > > be it within streams in a particular SCTP association or for active
> > > signalling processes.
> > >
> > > So would these be removed from  the m3uaStreamLshMethod  and
> > > m3uaSpLshMethod OBJECT-TYPE s in M3UA MIB draft.
> > >
> > >
> > > Thanks and Regards
> > > Anjali
> > > www.hssworld.com
> > > Hughes Software Systems.
> > >
> > > "DISCLAIMER: This message is proprietary to Hughes Software Systems
> Limited
> > > (HSS) and is intended solely for the use of the individual to whom it
> is
> > > addressed. It may contain  privileged or confidential information and
> > > should not be circulated or used for any purpose other than for what
it
> is
> > > intended. If you have received this message in error, please notify
the
> > > originator immediately. If you are not the intended recipient, you
are
> > > notified that you are strictly prohibited from using, copying,
> altering, or
> > > disclosing the contents of this message. HSS accepts no
responsibility
> for
> > > loss or damage arising from the use of the information transmitted by
> this
> > > email including damage from virus."
> > >
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> >
> > --
> > Brian F. G. Bidulock
> > [email-masked]
> > http://www.openss7.org/
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> >
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
>  https://www1.ietf.org/mailman/listinfo/sigtran
>
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
 https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Fri, 4 Jul 2003 02:36:53 -0500 (CDT)

Kamesh,

  MTP3 layer uses SLS to route the messages(pertaining to the same
  logically  related data) to the destination node.Users(ISUP or SCCP)
  can not instruct MTP3 to do any work related with loadsharing, it is
  upto the decision of MTP3 layer to decide the field(like SLS) on which
  it is going to loadshare its traffic.

  To the point, say for example you have an IAM which has LI > 272, ISUP
  layer would split this IAM into 2 IAMs(just an example) and send it
  to STP(SG), remeber both IAMs must have the same SLS. Now STP'S MTP3
  layer finds an outgoing linkset based on the DPC received on the MSU.

  Once linkset has been selected ,SLS is used to select a particular link
  within the linkset, so the above 2 IAMs will be sent in a sequence to
  the destination, here there is no way of mis-sequencing of MSUs.

  Is this what you expect?

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Jul 2003 22:15:52 -0600

Samuel,

Samuel Dur D. Jeyaseelan wrote:                                                     (Fri, 04 Jul 2003 02:36:53)
>   it is going to loadshare its traffic.

Incorrect.  It is the MTP-User's responsibility to select SLS value to
ensure load sharing of user messages with consideration for sequence
requirements for interrelated messages.  See Q.704, Q.714, Q.764.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Sat, 5 Jul 2003 01:15:26 -0500 (CDT)

Brian,

See the underlined sentences.

                                                                        --
> >   layer would split this IAM into 2 IAMs(just an example) and send it
      ------------------------------------------------------------------
> >   to STP(SG), remeber both IAMs must have the same SLS. Now STP'S MTP3
      ------------------------------------------------------

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 5 Jul 2003 00:21:58 -0600

Samuel,

See the underlined sentences that are incorrect:

Samuel Dur D. Jeyaseelan wrote:                                                     (Sat, 05 Jul 2003 01:15:26)
> > >   can not instruct MTP3 to do any work related with loadsharing, it is
                                                                       -----
> > >   upto the decision of MTP3 layer to decide the field(like SLS) on which
        ----------------------------------------------------------------------
> > >   it is going to loadshare its traffic.
        -------------------------------------

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Sat, 5 Jul 2003 01:37:59 -0500 (CDT)

Brian,
 
 I dont know the intention of your email.In this i two paragraphs 
 2nd para says ISUP layer at MGC constructs an IAM (WITH SLS) and sends
 it to STP(SG), now STP load-shares its traffic based on received SLS.

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 5 Jul 2003 00:41:06 -0600

Samuel,

Yes, the passage I underlined was incorrect.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Sat, 05 Jul 2003 01:37:59)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Sat, 5 Jul 2003 01:54:54 -0500 (CDT)

Brian,

 If an MSU has both CIC and SLS, based on what field load-sharing 
 takesplace?

--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 5 Jul 2003 01:01:16 -0600

Samuel,

See Note 1 Table 1/Q.701 and Section 2.2 and 2.3/Q.704.  Load sharing in MTP3
Signalling Routing Function takes place on SLS only.  For ITU-T and ETSI Q.764
CIC and SLS are statically related.  For ANSI T1.113 they are related only for
the duration of a call.

--brian

Samuel Dur D. Jeyaseelan wrote:                       (Sat, 05 Jul 2003 01:54:54)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Samuel Dur D. Jeyaseelan" <[email-masked]>
Date: Sat, 5 Jul 2003 02:11:41 -0500 (CDT)

Brian,

You are not able to answer my email to the point.Please now you read my
email(2 paragraphs) from top to bottom it can easily be understood.
If you read somewhere middle of the line then you will be sending one more
emial to me.

Thanks
--Samuel

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 5 Jul 2003 01:26:34 -0600

Samuel,

This first paragraph (underlined portions) is incorrect per the
standards and sections quoted.

The second paragraph is innane because all the messages relating to
the same ISUP call have the same SLS value, regardless of whether they
are segmented or not.

--brian

Samuel Dur D. Jeyaseelan wrote:                                                     (Sat, 05 Jul 2003 02:11:41)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/