Subject: RE: FW: [Sigtran] M2PA Last Call Comment

From: Schwarzbauer Hanns Juergen <[email-masked]>
Date: Mon, 28 Jul 2003 09:56:21 +0200

Tom,

see my comments inline (soory for the late response)

greetings

HannsJuergen

> -----Original Message-----
> From: Tom George [mailto:[email-masked]]
> Sent: Friday, July 25, 2003 5:28 PM
> Cc: IETF sigtran
> Subject: Re: FW: [Sigtran] M2PA Last Call Comment
> 
> 
> Hanns,
> 
> In the 1st diagram, there is no problem.
> 
> In the 2nd diagram, the problem is this: What procedures are 
> the 2 ends 
> of the M2PA link following? If one is following a procedure 
> that omits 
> proving, and the other is following a procedure that requires 
> proving, 
> there is a problem.

[HJS] Let's think about this issue the other way round: 
both STP's only have Q.703 to the rest of the SS7 network but use Q.2140 between then. 
I don't remember any discussion in ITU-T about any dependence for proving on the SAAL links on the other Q.703 links on both sides. It was simply "another level 2 protocol". So there was no problem at all, especially as all data links are decoupled from each other by MTP L3!

> 
> You are right that what is happening on the TDM side is not an issue 
> here. And I think we agree that both ends of the M2PA link must have 
> procedures that are consistent with each other. The text I 
> proposed is 
> the best way I can think of to do that.

[HJS] I think the text is misleading: the words "if this is allowed by the applicable MTP2 standard" couple the M2PA procedure to the TDM side.
My proposal reads liks:

section 4.1.3
The proving period MAY be omitted upon bilateral agreement between the concerned peers.
                                     +------------+
                                     |            |  Q.2140
                            +--------+            +---------
                            |        |   STP B    |
        +----------+        |        |            |  Q.2140
 Q.703  |          | M2PA   |        |            +----------
 -------+          +--------+     +--+            |
        | STP A    |              |  +------------+
 Q.703  |          +--------+     |
 -------+          | M2PA   |     |
        |          |        |     |
        +----------+        |     |
                            |     |  +------------+
                            |     +--+            |  Q.703
                            |        |            +---------
                            +--------+  STP C     |
                                     |            |  Q.703
                                     |            +---------
                                     |            |
                                     +------------+
In that scenario I even doubt that your text allows STP A and STP B to omit the proving. 
The text could be interpreted to allow omission of proving only if this is applicable on both ends.
I consider this correlation as not necessary at all, as all MTP L2 have to be considered independent from each other (due to MTP3). M2PA from the beginning was considered a "new Level 2" and therefore should not be designed a way to have built in dependencies from existing level 2 protocols. 

> 
> tomG.
> 
> Schwarzbauer Hanns Juergen wrote:
> > Tom,
> > 
> > I sent an answer to your mail friday last week, albeit I 
> received it back from the exploder, I never got a response on 
> it, so I'm repeating parts of that mail.
> > 
> > ========================
> >  Question: does STP A care about the fact that STPB has 
> links according to Q.2140? 
> >  Answer: NO, NOT AT ALL, STP A operator might not even know 
> that STP B has Q.2140 links.  
> > 
> >         +-----------+                 +-----------+
> >    Q.703|           |                 |           |   Q.2140
> >   ------+           |                 |           +--------
> >         |           |       Q.703     |           |
> >         | STP A     +-----------------+   STP B   |
> >         |           |                 |           |
> >    Q.703|           |                 |           |   Q.2140
> >   ------+           |                 |           +--------
> >         |           |                 |           |
> >         +-----------+                 +-----------+
> > 
> > Let's go to an IP based link between STP A and STP B
> > 
> > Question: should STP A care about the fact that STP B has 
> links according to Q.2140?
> > Answer: I see no necessity to deviate from ANSI and ITU-T.
> > 
> > 
> >         +-----------+                 +-----------+
> >    Q.703|           |                 |           |   Q.2140
> >   ------+           |                 |           +--------
> >         |           |       M2PA      |           |
> >         | STP A     +-----------------+   STP B   |
> >         |           |                 |           |
> >    Q.703|           |                 |           |   Q.2140
> >   ------+           |                 |           +--------
> >         |           |                 |           |
> >         +-----------+                 +-----------+
> > 
> > If STP A wants to prove, he should do that and STP B has to 
> support STP A in that procedure and vice versa.
> > But I see no necessity why both sides should perform similiar. 
> > 
> > In all other cases STP A would have to be informed if e.g. 
> STP-B migrates from pure Q.703 to pure Q.2140 and that's not 
> acceptable.
> > =========================
> > 
> > My point is that using or not using the proving of M2PA is 
> independent from the flavour of MTP level 2 procedure used on 
> the TDM side of the SG. According to Figure 2 in draft 9 
> there is an MTP 3 on top, effectively decoupling both sides.
> > 
> > 
> > greetings 
> > 
> > HannsJuergen
> > 
> > 
> > 
> >>-----Original Message-----
> >>From: Tom George [mailto:[email-masked]]
> >>Sent: Thursday, July 24, 2003 10:28 PM
> >>Cc: IETF sigtran
> >>Subject: Re: FW: [Sigtran] M2PA Last Call Comment
> >>
> >>
> >>That does not seem like a good situation. I see the point 
> >>now. Instead 
> >>of your suggested text:
> >>
> >>   The proving period MAY be ommitted if this is allowed by the
> >>   applicable standard (e.g., [Q.2140]); however, the same 
> >>standard MUST
> >>   be followed on both sides of the M2PA link.
> >>
> >>would it be better to make a more general statement, in order 
> >>to avoid 
> >>this kind of problem that might exist in other procedures? 
> >>Maybe I could 
> >>  add to the 2nd paragraph in section 4:
> >>
> >>=====
> >>Except as modified in this document, M2PA SHOULD follow the
> >>requirements of the applicable MTP2 specification. These may include
> >>[Q.703] or [T1.111]. The same standard MUST be followed on 
> >>both ends of 
> >>the M2PA link.
> >>=====
> >>
> >>tomG.
>    [...]
> 
> -- 
> * Tom George       PB7-24001 (near B-21)      
> [email-masked]  *
> * 972-519-3168   Intranet:  
http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tom George <[email-masked]>
Date: Thu, 31 Jul 2003 17:39:41 -0500

Hanns,

The reference to "the applicable MTP2 standard" comes from section 4. 
The links you labelled Q.703 and Q.2140 are irrelevant to deciding which 
protocol is "applicable" to the M2PA links. But both ends have to use 
the same one.

I suspect that I am not explaining what I mean very well....

tomG.

 > [HJS] Let's think about this issue the other way round: both STP's
 > only have Q.703 to the rest of the SS7 network but use Q.2140 between
 > then. I don't remember any discussion in ITU-T about any dependence
 > for proving on the SAAL links on the other Q.703 links on both sides.
 > It was simply "another level 2 protocol". So there was no problem at
 > all, especially as all data links are decoupled from each other by
 > MTP L3!
 >
   [...]
 > [HJS] I think the text is misleading: the words "if this is allowed
 > by the applicable MTP2 standard" couple the M2PA procedure to the TDM
 > side. My proposal reads liks:
 >
 > section 4.1.3 The proving period MAY be omitted upon bilateral
 > agreement between the concerned peers.
   [...diagram snipped because my "rewrap" mangled it...]
 > In that scenario I even
 > doubt that your text allows STP A and STP B to omit the proving. The
 > text could be interpreted to allow omission of proving only if this
 > is applicable on both ends. I consider this correlation as not
 > necessary at all, as all MTP L2 have to be considered independent
 > from each other (due to MTP3). M2PA from the beginning was considered
 > a "new Level 2" and therefore should not be designed a way to have
 > built in dependencies from existing level 2 protocols.
   [...]

-- 
* Tom George       PB7-24001 (near B-21)      [email-masked]  *
* 972-519-3168   Intranet:  http://www.ssd.usa.alcatel.com/~tgeorge/  *
* Alcatel;  3400 West Plano Pkwy,  MS PB7-SWPRO;  Plano, Texas 75075  *
*   I actively disclaim speaking for Alcatel.  I do not purport to    *
*   advertise or represent its position, operations, or activities.   *