Subject: [Sigtran] SDL and SDT parameteres for M2UA stack

From: Pablo Salinas <[email-masked]>
Date: Thu, 17 Jul 2003 18:32:29 -0500 (CDT)

Brian,
        I couldn't find more info about SDL's and SDT's. So, may I ask you a few more questions:
1. Is this a SDL and SDT typical scenario?
SDLI's represent CIC's and SDTI's represent SSP's
2. From which SS7's protocol layer do SDLI and SDTI come from? I mean, wich layer is responsible for selecting this values?
3. Suppose I want to initiate a SGP and a MGC. The code for initialization in the SGP and the MGC should have to call this 
functions:
a) initiate_protocol_stack -> Initiates the M2UA protocol stack.
x) add_sg -> Receives the SG identifier (for local managment only). This function should only be called in the MGC.
b) add_sgp -> Receives the list of IP adresses:Port number attached to this SGP, the port number it should listen in order to 
support dynamic registration (default:2904), the max and min number of streams per sctp association and the SGP identifier 
(for local managment only).
c) add_asp -> Receives the ASP identifier (for local managment only), the max and min number of streams per sctp association, 
the (local and remote)IP addresses:Port number (at the ASP and at the SGP) used for the sctp association (Example: 
65.198.40.50:3005, 65.198.40.51:3005).
d) add_as -> Receives the AS identifier (for local managment only), the interface identifiers the AS responds to and the ASP 
identifiers of the ASP's associated to this AS.

At what function call, should the SDLI and SDTI parameters be specified?
I believe they should be specified in the add_as function call.
If that is the case, how can the SG and the MGC know which Interface Identifier is associated with every AS, in order
send the MAUP messages with the rigth Interface Identifier parameter?
I am thinking about a scenario where SG and MGC support dynamic registration; but at the begin there are pre-registered
ASP's and AS's.

               thanks again,
                            Pablo Salinas

---------------------------------
Do You Yahoo!?
Todo lo que quieres saber de Estados Unidos, América Latina y el resto del Mundo.
Visíta Yahoo! Noticias.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 17 Jul 2003 18:07:04 -0600

Pablo,

See Q.704 Clause 12 and particularly section 12.3, 12.4, 12.5 and 12.6.

Also see Q.751-1, section 7.1.7 (managed object class definition for a
Signalling Data Link Termination Point) and 7.1.14 (managed object class
definitionf for Signalling Terminal).

The signTermId attribute of the signTerm managed object class is the SDTI.

The signDataLinkTpId attribute of the signDataLink managed object class is
the SDLI.

For a SG that does not support automatic allocation of signalling terminals or
singalling data links (see 12.3/Q.704, 12.4/Q.704) the signDataLinkTp and
signTerm are bound at configuration.  Registration is then not necessary.
Each IID identifies a static signTerm/signDataLinkTp pair.  Registration
supports automatic allocation of signalling terminals or signalling data links
or both, by permitting, via registration, a signalling terminal (signTerm) to
be associated with a signalling data link (signDataLinkTp) and assigned an
IID.  

--brian

Pablo Salinas wrote:                                                                 (Thu, 17 Jul 2003 18:32:29)
>    2. From which SS7's protocol layer do SDLI and SDTI come from? I mean,
>    wich layer is responsible for selecting this values?
> 
>    3.  Suppose  I  want  to  initiate  a  SGP  and  a  MGC.  The code for
>    initialization in the SGP and the MGC should have to call this
> 
>    functions:
> 
>    x)  add_sg  ->  Receives the SG identifier (for local managment only).
>    This function should only be called in the MGC.
> 
>    b) add_sgp -> Receives the list of IP adresses:Port number attached to
>    this SGP, the port number it should listen in order to
> 
>    support dynamic registration (default:2904), the max and min number of
>    streams per sctp association and the SGP identifier
> 
>    c)  add_asp -> Receives the ASP identifier (for local managment only),
>    the max and min number of streams per sctp association,
> 
>    the  (local and remote)IP addresses:Port number (at the ASP and at the
>    SGP) used for the sctp association (Example:
> 
>    d)  add_as  ->  Receives the AS identifier (for local managment only),
>    the interface identifiers the AS responds to and the ASP
> 
>    If  that  is the case, how can the SG and the MGC know which Interface
>    Identifier is associated with every AS, in order
>    I  am  thinking  about  a  scenario  where  SG and MGC support dynamic
>    registration; but at the begin there are pre-registered
>    ASP's and AS's.
> 
>                   thanks again,
>                                Pablo Salinas
>      _________________________________________________________________
> 
>    Do You Yahoo!?
>    [1]  Todo  lo  que  quieres  saber  de  Estados Unidos,
>    América Latina y el resto del Mundo.
>    Visíta [2]Yahoo! Noticias.
> 
> References
> 
>    1. http://espanol.yahoo.com/mail_tagline/*http://espanol.news.yahoo.com
>    2. http://espanol.yahoo.com/mail_tagline/*http://espanol.news.yahoo.com

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran