Subject: RE: [Sigtran] SUA Question - Trasaction ID based Routing

From: [email-masked]
Date: Fri, 11 Jul 2003 11:47:29 +0300

Brian & James,

Yes, this has a long & twisted history. My original goal was to
try to get SUA finished - something that the IESG has caused
a lot of trouble with.  

The WG never could come to consensus on how to solve this.  My proposal
to you is to write a short Internet draft on how to solve this,
lets get consensus on it and publish it as a supplemental RFC.

John

> -----Original Message-----
> From: ext Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: 10 July, 2003 23:13
> To: Doss, James
> Cc: [email-masked]; Loughney John (NRC/Helsinki)
> Subject: Re: [Sigtran] SUA Question - Trasaction ID based Routing
> 
> 
> James,
> 
> Doss, James wrote:                                            
>                        (Thu, 10 Jul 2003 12:27:16)
> > 
> >    Hi John,
> > 
> > 
> > 
> >    In SUA spec draft version 15.
> > 
> > 
> > 
> >    With reference to Page 112 . SCTP Associations Fig 2 
> Signaling Gateway
> >    Architecture.
> 
> Page 112 would be the Author's Addresses...
> 
> > 
> > 
> > 
> >    Will  the  transaction  ID  based  routing  the  
> responses  to the ASP
> >    originated the transaction.
> > 
> > 
> > 
> >    Ex scenario:
> > 
> > 
> > 
> >    ASP1 from AS3 originated a transaction using SG1 towards 
> SS7 network.
> > 
> > 
> > 
> >    The  Response  for  this  QUERY  hits  SG2  (Assuming  
> SG1 and SG2 are
> >    mated).
> > 
> > 
> > 
> >    Question 1:
> > 
> > 
> > 
> >    At this condition will SG2 route this message back to ASP1.
> > 
> > 
> > 
> >    Question 2:
> > 
> > 
> > 
> >    Will  SG1  and  SG2  share  the  information  about  
> Open Transactions
> >    originated from the ASPs(1..n).
> > 
> >    Or Else how the Transaction ID based routing (key ) will work.
> > 
> > 
> > 
> >    Please correct me if I understood the routing in a wrong way.
> 
> The TID Label approach described in 4.7.2 and 4.7.3 and A.3.1 
> will work for
> simple (and correct) Query/Response pairs in protocol class 0 
> with operations
> class 3 (no return on error and no rejects or aborts) if you 
> have sufficient
> control of the TCAP application that you can control the 
> range of TIDs that
> it assigns per ASP.  Protocol class 0 or 1 and operations 
> class 1 or 2 (return
> on error, rejects and aborts) will fail because the returned 
> error does not
> have sufficient information to determine the ASP from TID 
> (because the ASP's
> TID is not present in the message), or if you cannot strictly 
> control the way
> that the TCAP layer assigns TIDs at an ASP.
> 
> So, it works for only the most trivial of applications.  For more
> sophisticated applications, see draft-bidulock-sigtran-tua-01.txt
> 
> A superior registration procedure was proposed whereby the 
> ASP could inform
> both SGs of the ASP ownership of a TID on the BEGIN/QWP/QWOP, 
> but the broken
> TID Label approach slithered its way into SUA.
> 
> The DRN Label approach is broken worse.  For serious TCAP 
> applications, use
> TUA.
> 
> The last thread was "SUA-09: SCCP Connections and TCAP 
> Transactions" from
> Jan 2002.  (At that time it was too late to make changes--hah!)
> 
> Before that there is a discussion in "SUA Decision needed - 
> handlin multiple
> SGs" where it was determined that broken procedures are ok if 
> those broken
> procedures have a couple of people to nod their heads at each other.
> 
> See especially "[SUA Issue 14] Changes and addtions required 
> for decoupled
> operation."  These problems go back to August 2001.
> 
> Perhaps Verwimp is still around to defend the Label approach, 
> or perhaps
> not.
> 
> --brian
> 
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 11 Jul 2003 03:20:34 -0600

John,

Excellent suggestion.

--brian

John Loughney wrote:                                                                  (Fri, 11 Jul 2003 11:47:29)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 29 Jul 2003 06:24:12 -0600

John,

Little problem... A draft was already submitted last January:

 draft-bidulock-sigtran-regext-01.txt .ps .pdf

that describes extensions to the registration mechanism for SUA
(addition of DRN range to RK, addition of RK to DEREG REQ, and
necessary errors) to permit this.  It also applies to M3UA (CIC
ranges) M2UA (SDL/SDT pairs), TUA, ...

The draft is about to expire, so I will resumbit it.

--brian

Brian F. G. Bidulock wrote:                                                           (Fri, 11 Jul 2003 03:20:34)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/