Subject: RE: [Sigtran] M3UA IG v04 Section 3.14

From: "J.Javier Pastor (EE/EEM)" <[email-masked]>
Date: Fri, 11 Jul 2003 10:35:57 +0200

Hi Brian, 

You are right saying that there is currently no way of notifying AS-DOWN. In fact "n" only applies to the traffic case.

Then I see two options:
	1- include AS-DOWN in NTFY
	2- The AS-DOWN state is only got when all the ASPs are in ASP-DOWN state.

I would addopt 2 since it is inline what we are having in the other UALs. 

Thanks // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: jueves, 10 de julio de 2003 17:15
> To: J.Javier Pastor (EE/EEM)
> Cc: [email-masked]'
> Subject: Re: [Sigtran] M3UA IG v04 Section 3.14
> 
> 
> Javier,
> 
> Section 3.14 says:
> 
>    IA2DN: One ASP moves to ASP-DOWN causing that the number of ASPs in
>    either ASP-ACTIVE or ASP-INACTIVE drops below n.
> 
> Am I correct to say that if n=5 and there are 4 ASPs in the 
> ASP-INACTIVE
> and 1 ASP in the ASP-ACTIVE state, and then the 1 active ASP moves to
> the ASP-DOWN state and T(r) expires that the AS is to move to 
> the AS-DOWN
> state?  As follows:
> 
>   If T(r) expires before an ASP becomes ASP-ACTIVE, the SGP MAY stop
>   queuing messages and discards all
>   previously queued messages. The AS will move to the 
> AS-INACTIVE state
>   if at least the number of ASPs in ASP-INACTIVE sum n, otherwise it
>   will move to AS-DOWN state.
> 
> Now, that is an AS state change and we must send a NTFY to 
> all the INACTIVE
> ASPs (the 4 left inactive) of the state change.  But from 
> Section 3.8.2 of
> the RFC, there is no message to notify of an AS-DOWN state:
> 
>          1    reserved
>          2    Application Server Inactive (AS-INACTIVE)
>          3    Application Server Active (AS-ACTIVE)
>          4    Application Server Pending (AS-PENDING)
> 
> You see, we removed it because there was never an instance in which it
> would be sent.  You have inserted an instance again.
> 
> Aren't you going to have to define a Notify message (the 
> Reserved value)
> for "Application Server Down (AS-DOWN)" so that the INACTIVE ASPs can
> be properly notified by the SGP?
> 
> Particularly when the RFC says in Section 4.3.4.5: (Notify Procedures)
> 
>    A Notify message reflecting a change in the AS state MUST 
> be sent to
>    all ASPs in the AS, except those in the ASP-DOWN state, with
>    appropriate Status Information and any ASP Identifier of the failed
>    ASP.  At the ASP, Layer Management is informed with an M-NOTIFY
>    indication primitive.  The Notify message must be sent 
> whether the AS
>    state change was a result of an ASP failure or reception of an ASP
>    State management (ASPSM) / ASP Traffic Management (ASPTM) message.
>    In the second case, the Notify message MUST be sent after 
> any related
>    acknowledgement messages  (e.g., ASP Up Ack, ASP Down Ack, 
> ASP Active
>    Ack, or ASP Inactive Ack).
> 
> The above tells me that I MUST send a Notify message becase of the AS
> state change, but there is no message to inform about AS-DOWN state
> transition.
> 
> What is the purpose of doing this?  What is the protocol 
> difference between
> the AS-DOWN state and the AS-INACTIVE state?  What is it that the SGP
> does or doesn't do in the one state that it doesn't or does 
> do in the other?
> 
> I don't recall this being discussed at all.
> 
> Please clarify.
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 11 Jul 2003 03:13:46 -0600

J.Javier,

J.Javier Pastor (EE/EEM) wrote:                                                   (Fri, 11 Jul 2003 10:35:57)
> Hi Brian, 
> 
> You are right saying that there is currently no way of notifying AS-DOWN. In
> fact "n" only applies to the traffic case.
> 
> Then I see two options:

Yes, please go with 2 as it is also in line with the RFC.

That will also leave only 1 'n' transition in the proposal: the IA2AC
transition, correct?

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/