Subject: RE: [Sigtran] M3UA IG v04 AS State Machine

From: "J.Javier Pastor (EE/EEM)" <[email-masked]>
Date: Fri, 11 Jul 2003 09:21:14 +0200

Hi Brian, 

In the consensus text we have not add or remove anything regarding the AS state scope. Then it remains the same.

Cheers // Javier.

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: jueves, 10 de julio de 2003 15:16
> To: [email-masked]'
> Subject: Re: [Sigtran] M3UA IG v04 AS State Machine
> 
> 
> Javier,
> 
> The AS State Machine illustrated in 3.14 is per-SGP.  Correct?
> 
> SGP can communicate with each other in an SG.  Correct?
> 
> Why should an SGP pend when the last ASP goes ASP-INACTIVE for
> an AS with a given SGP?
> 
> Cannot the SGP redirect traffic via another SGP that has ASPs
> active for the AS?
> 
> Example:
> 
>         _______                    _______
>        |       |______x    x______|       |
>        | SGP1  |         _________| ASP1  |
>        |_______|        /         |_______|
>         _______        /           _______
>        |       |______/           |       |
>        | SGP2  |__________________| ASP2  |
>        |_______|                  |_______|
> 
> 
> When ASP1 goes inactive (or down) w.r.t SGP1, cannot
> SGP1 direct traffic via SGP2?
> 
> What is the state of the AS at SGP1?
> 
> In section 3.14 AC2PN says that:
> 
>   AC2PN: the last ASP in the ASP-ACTIVE state moves to
>   ASP-INACTIVE or ASP-DOWN states, causing the number of ASPs
>   in the ASP-ACTIVE [sic] drop below 1.
> 
> Is that the number of ASPs for SGP1?  for SGP2? for the SG?
> for all (both) SGs?
> 
> In the RFC the AS state machine was per-SGP.  Is the 3.14 state
> machine per-SGP?
> 
>    IA2AC: one ASP moves to [the] ASP-ACTIVE [state], causing
>    [the] number of ASPs in the ASP-ACTIVE state to be n.
> 
> When SGP1 receives an ASP Active and sends an ASP Active Ack
> to ASP1, how many ASPs are active for the AS?   1?  2?
> 
> Please clarify.
> 
> --brian
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 11 Jul 2003 02:37:54 -0600

J.Javier,

That doesn't really answer my questions below.  Could you please
clarify the proposal by answering the questions?

--brian

J.Javier Pastor (EE/EEM) wrote:                                                   (Fri, 11 Jul 2003 09:21:14)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/