Subject: RE: [Sigtran] M3UA : IPSP DE behaviour

From: "Vivek Toky" <[email-masked]>
Date: Thu, 31 Jul 2003 05:11:03 -0700

Hi All,
 What should be done in the following case:

      |IPSP_A                             |
  AS1 |      ---------------------- IPSP_C| AS2
      |IPSP_B                             |

IPSP_A and IPSP_B are in loadshare mode.

  when AS1 has activated itself by sending
ASP Active from both the IPSPs (A & B) but 
AS2 has sent ASP Active just to IPSP_A. 

What should IPSP_C do on receiving traffic for AS1?

a) Loadshare the traffic towards IPSP_A and IPSP_B

or 

b) It should send all the traffic to IPSP_A and 
   wait untill it sends ASP Active IPSP_B as well.
   In the above case IPSP_B cannot send the traffic 
   towards IPSP_C but IPSP_C can.

thanks,
Vivek.

> If we consider that the IPSP DE is a replicated SG/ASP model (as 
already
> mentionned
> Before), then SG/ASP protocol indicate that the SG cannot send AND
> receive traffic 
> from an ASP if the concerned AS(RC) is not activated. 
> 
> When two IPSP are hosting several AS, it seem pertinent to authorize 
the
> traffic only 
> between "ACTIVE AS" in the IPSP.
> 
> An active status is reported to the application ONLY if the local AS
> (the local application)
> And the remote AS are activated. If the remote OR the local AS is
> deactivated, then
> A pause is reported to the application.
> 
> My opinion is that only ACTIVE AS (between IPSP) can use the 
association
> to exchange messages.
> 
> Francois Z.
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] 
> > Sent: Thursday, July 31, 2003 6:29 AM
> > To: Band, Richard
> > Cc: [email-masked]; [email-masked]
> > Subject: RE: [Sigtran] M3UA : IPSP DE behaviour
> > 
> > 
> > 
> > 
> > 
> > 
> > Hi Richard,
> >   You are right that there is no point in activating only 
> > AS1 in IPSP DE mode in the given example. Unless both the AS 
> > 's AS1 and AS2 are not active user to user traffic 
> > (bidirectional) cannot be started in IPSP model.Any way IPSP 
> > DE mode for that reason is kept optional.Bidirectional 
> > traffic between IPSP A and IPSP B will only start when both 
> > the AS's are active. In my openion let IPSP B indicate 
> > availability of remote AS1as and when it sends ASPAC ack for 
> > AS1 to IPSP A.If IPSP B is interested in sending data for 
> > remote AS1 it can send and IPSP A will receive the data, if 
> > some one wants single direction traffic.But yes i do argee 
> > that there is no practical scenario in which single direction 
> > traffic is desired in IPSP model.
> > 
> > Kamesh Kaul
> > www.hssworld.com
> > Hughes Software Systems
> > 
> > 
> > 
> > 
> > "BAND,RICHARD (HP-France,ex1)" <[email-masked]> on 
> > 07/30/2003 05:33:53 PM
> > 
> > To:    Kamesh Kaul/HSS@HSS, [email-masked]
> > cc:    [email-masked]
> > 
> > Subject:    RE: [Sigtran] M3UA : IPSP DE behaviour
> > 
> > 
> > Hi Kamesh, Umesh,
> > 
> > I agree that the protocol allows traffic from IPSP B to A 
> > without having traffic from IPSP A to B.
> > 
> > However, I do think that there is a problem with the 
> > notifications for the AS on each side: In this situation, how 
> > should the IPSPs A and B indicate the availability of the 
> > remote AS to the local AS? Should IPSP A indicate that AS 2 
> > is available, even though it knows AS 2 cannot reply? Should 
> > IPSP B indicate that AS 1 in unavailable, as AS 2 cannot send 
> > any messages to AS 1? If so, what should IPSP B do when AS 1 
> > sends traffic? Discard the messages, or transfer the data to 
> > AS 2, which will then receive traffic from an unavailable 
destination?
> > 
> > In my opinion, both IPSPs should indicate that the remote AS 
> > is unavailable. I would say that the DE IPSP exchange mode 
> > allows each side to indicate its readiness to receive 
> > traffic, but traffic should not be started unless both sides 
> > are active. It seems to me that this is the only to avoid the 
> > problems described above.
> > 
> > Please let me know your opinion on this point.
> > 
> > Regards,
> > 
> > Richard Band
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Wednesday, July 30, 2003 06:17
> > To: [email-masked]
> > Cc: [email-masked]
> > Subject: Re: [Sigtran] M3UA : IPSP DE behaviour
> > 
> > 
> > 
> > 
> > Umesh
> > 
> >   IPSP B can send DATA messages for AS1 to IPSP A only if on 
> > receiving ASPAC message from IPSP A , IPSP B sends ASPAC ack 
> > for AS1 to IPSP A.Not activating AS2 means IPSP B will not be 
> > able to receive any message for AS2.So in a way only data for 
> > AS1 will flow from IPSP B to IPSP A.
> > 
> > Regards
> > Kamesh Kaul
> > www.hssworld.com
> > Hughes Software Systems
> > 
> > 
> > 
> > 
> > "Umesh Vats" <[email-masked]>@ietf.org on 07/30/2003 07:44:36 AM
> > 
> > Please respond to <[email-masked]>
> > 
> > Sent by:    [email-masked]
> > 
> > 
> > To:    <[email-masked]>
> > cc:
> > 
> > Subject:    [Sigtran] M3UA : IPSP DE behaviour
> > 
> > 
> > Suppose we have two Double Ended IPSPs A and B. AS1 is 
> > application server on IPSP-A and AS2 is application server on IPSP-
B
> > 
> >      AS1 A----------B AS2
> > 
> > Now, IPSP-A sends ASPAC for for AS1 to B. IPSP-B doesn't 
> > activate AS2. After this, can IPSP-B send DATA messages for 
> > AS1 to IPSP-A in any scenario ?
> > 
> > Thanks
> > Umesh Vats
> > Sr Software Engg.
> > extn : 8986
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> >  https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> >  https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
> > 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 

-- 
Continuous Computing
http://www.ccpu.com

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Tolga Asveren <[email-masked]>
Date: Thu, 31 Jul 2003 05:21:16 -0700 (PDT)

Vivek,
>    towards IPSP_C but IPSP_C can.
[TOLGA]It should send all traffic to IPSPS_A. Which
case do you refer as "the above case", a) or b) ?
> Vivek.

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free, easy-to-use web site design software
http://sitebuilder.yahoo.com