Subject: RE: [Sigtran] ASP Capabilities value 0x2 of interworking field

From: "Prasad, Shashank S (Shashank)" <[email-masked]>
Date: Mon, 19 Dec 2005 19:17:49 +0530

Ilie,
I too have the same confusion and still continue to have. My understanding
on what the RFC 3332 said and NOT what it did NOT. And I believe that most
of the folks also have the same confusion esp. wrt IPSPs.

Even the 3GPP standards has recommended to use M3UA in a certain flavour,
which really do NOT fall in line, with the inputs from this mailing list.

And that's the reason I am pressing for the M3UA authors/contributors to
redefine IPSPs, to the least.

Hope someone is listening !!!

shashank

-----Original Message-----
From: Ilie Glib [mailto:[email-masked]]
Sent: Monday, December 19, 2005 7:09 PM
To: Prasad, Shashank S (Shashank)
Cc: [email-masked]; [email-masked]
Subject: Re: [Sigtran] ASP Capabilities value 0x2 of interworking field

Shashank, Brian,

If Brian's statement is not just a play, then why all these ASP, SGP,
IPSP definitions at all in SIGTRAN standards?

Ilie

On 12/19/05, Prasad, Shashank S (Shashank) <[email-masked]> wrote:
> Hi Brian,
> This is an important statement that defines IPSPs.
>
> And, if all of the SIGTRAN community feels the same, I feel that this
SHOULD
> be explicitly stated while defining IPSPs. This definition is completely
> missing from the specs and has led to a lot of confusion about the
> definition of IPSPs.
>
>
> The current definition states as follows, which is extremely confusing.
> The IPSP definition, from the specs, means that IPSP is similar to ASP
only
> (not SGP).
> And that it does NOT use SGPs while communicating with other IPSPs.
>
> The RFC 3332 has a seperate definition of IPSP, SGP and ASP as follows:
>
>   IP Server Process (IPSP) - A process instance of an IP-based
>   application.  An IPSP is essentially the same as an ASP, except that
>   it uses M3UA in a point-to-point fashion.  Conceptually, an IPSP does
>   not use the services of a Signalling Gateway node.
>
>   Signalling Gateway Process (SGP) - A process instance of a Signalling
>   Gateway.  It serves as an active, backup, load-sharing or broadcast
>   process of a Signalling Gateway.
>
>
> We should explicitly write that IPSP can be an ASP or an SGP.
>
>
> shashank
>
>
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Brian F. G. Bidulock
> Sent: Monday, December 19, 2005 6:07 PM
> To: Ilie Glib
> Cc: [email-masked]
> Subject: Re: [Sigtran] ASP Capabilities value 0x2 of interworking field
>
>
> Ilie,
>
> The signalling gateway capability, SS7 interworking and relay capabilities
> can be combined into any process (ASP, ISPS, SGP).
>
> --brian
>
> Ilie Glib wrote:
(Mon,
> 19 Dec 2005 13:17:19)
> > Brian,
> >
> > I am sorry I was not clear enough. My claim was
> >
> > Registration Request (REG REQ) cannot be sent from an SGP, therefore
> > the value 0x2 indicating signalling gateway capability is meaningless,
> > unless IPSP and SGP functions can be combined in one Signalling
> > Process.
> >
> > Can an SGP act as an IPSP?
> >
> >
> > Thank you
> >
> > Ilie
> >
> >
> > On 12/19/05, Brian F. G. Bidulock <[email-masked]> wrote:
> > > Ilie,
> > >
> > > Ilie Glib wrote:
> (Mon, 19 Dec 2005 12:39:07)
> > > > Brian,
> > > >
> > > > could you please answer the following questions
> > > >
> > > > 1) Can SG register via RKM? If not, why the value 0x2 that indicates
> > > > Signalling Gateway?
> > >
> > > You are confused.  0x2 indicates signalling gateway capability: i.e.,
> > > the registering node has an SS7 network interfaces and behaves as an
> > > SG when interworking to that interface.
> > >
> > > >
> > > > 2) Is there any difference between capabilities 0x0 and 0x1 in SUA
> > > >
> > > >      0x0 indicates no interworking with SS7 Networks.
> > > >      0x1 indicates IP Signalling Endpoint (ASP), interworking with
SS7
> > > >         networks.
> > >
> > > Yes, one supports interworking with SS7 networks and the other does
not.
> > >
> > > >
> > > > I was more after a definition of the Relay capability in SUA
> > > > framework. Although SUA RFC mentions Relay and describes it, the
> > > > definition of Relay is missing.
> > >
> > > See SCCP specifications for a definition of a relay node.
> > >
> > > --brian
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
>
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 19 Dec 2005 08:41:03 -0500

Shashank,

> Behalf Of Prasad, Shashank S (Shashank)
> Sent: Monday, December 19, 2005 8:48 AM
> To: 'Ilie Glib'
> Subject: RE: [Sigtran] ASP Capabilities value 0x2 of interworking field
>
>
> Ilie,
[TOLGA]There is one effort going on I am aware of. I believe we should be
able to see the initial results in a few days.