Subject: [Sigtran] Origin based routing and Sourse Addresses in Routing Key Definition

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 18:01:57 +0100

Hello Folks,

recently in "ASP Capabilities value 0x2 of interworking field" thread

On 12/20/05, Brian F. G. Bidulock <[email-masked]> wrote:
> Stanislav,
>
> Stanislav Ivanovich wrote:                                       (Tue, 20 Dec 2005 07:44:05)
> >
> >
> > ....
> >    In  xxUA networks AS/RC concept in mandatory SE model both originating
> >    and   destination   addresses   have   to   be   specified   and  only
> >    these combinations  are  allowed.  This  is  extremely  unfriendly for
> >    relay!
>
> No they don't.  Any routing key is possible.  Dynamic registration does not
> support all possible routing keys.  Provisioned routing keys can take any
> form.  Also note that SUA registration supports multiple and ranges of
> addresses in a dynamically registered routing key.  Not even M3UA restricts
> its routing keys to a single originating or destination point code.  You
> can have one destination HLR point code and 400 MSC originating point codes
> if you'd like.  Or visa versa.  Or 400 of each.
>
> >

IMO having Originating Addresses in the definition of the AS and RK
was a very nice idea. Most probably the reason for it was to off-load
the destination Signalling Processes and have finer granularity in
traffic routing and distribution via origin based routing (due to low
capacity Signalling Processes).

In case of SE-IPSP when dynamic RKM is in use, ASs and RKs shall
contain both source and destination addresses as part of RK
definition. As long as Relay is not used having source and destination
addresses as part of RK does not imply routing based on origin, where
depending on source address traffic can go to different IP
destinations although the SS7 destination address is the same.

As consequence of SE-IPSP and dynamic RKM, the definition of the AS
has drifted to the a concept of signalling relation with one or more
applications on one side of it and one or more applications on the
other side. As far as I understand there was no objective to enforce
origin based routing as a mandatory feature for relay. However, having
SE mandatory, one can draw the conclusion that origin based routing is
mandatory for Relay nodes.

Brian's statement above "Provisioned routing keys can take any form"
is fine with me, and hopefully with everybody on this list, since it
was not objected by anyone.
I interpret it as "origin based routing is optional in Relay nodes".

Please can people on the list make clear whether it is mandatory or
optional  for SUA relay to have routing based on source address.

I was not able to fine any statement in the RFC that makes routing
based on origin mandatory, except the fact that SE is mandatory.

Thank you in advance

Ilie

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Stanislav Ivanovich <[email-masked]>
Date: Thu, 22 Dec 2005 09:32:01 -0800 (PST)

Ilie,
   
  Look at Brian's answer posted to you on 6th of December in http://www1.ietf.org/mail-archive/web/sigtran/current/msg05497.html
   
  Here is the copy.
   
  -------------------------------------------------------------------------------------------
  Ilie,

An AS is a User (MTP-User, SCCP-User).  In a peer-to-peer signalling
relation without relay or transfer, there are two Users, however,
there is only one signalling relation.  Each end has an address.
the pair of addresses defines the signalling relation.  A signalling
relation is an RK, and an RC.

As Tolga puts it well, at one IPSP, there is a 1:1:1 relationship
between an AS (local concept) and RC and an RK.  Same at the other.
The RCs are the same and the RK's are symmetric (both define the
signalling relation from the view at only one end).  If you know
one RK you know the other.  Each end defines an AS (without relay)
and both form one signalling relation.

--brian
-------------------------------------------------------------------------------------------

    Even more, regardless of originating addresss which are mandatory in SE model (according to Brian's and Tolga's answers) the most relay unfriedly principle still remians:
   
  An applicatiion process (ASP or IPSP) must node SEND data within an application context (RC) for which it has not activated itself in.In aniother words an application at a process ASP/IPSP is dead (and is not allowed to send traffic) until the process activates itself for the AS.
   
  In another words (as Tolga and Brian said a couple of weeks ago) an AS is not a sink but an entitiy which both receives and generates traffic.
   
  / Stanslav

Ilie Glib <[email-masked]> wrote:
    Hello Folks,

Thank you in advance

Ilie

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 12:17:41 -0700

Ilie,

Ilie Glib wrote:                                                      (Thu, 22 Dec 2005 18:01:57)

---x---snip---x---
> based on origin mandatory, except the fact that SE is mandatory.

Read Section 3.10.14.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 12:19:12 -0700

Stanislav,

Those comments were with regard to M3UA.

--brian

Stanislav Ivanovich wrote:                                       (Thu, 22 Dec 2005 09:32:01)
> 
>    Ilie,
> 
> 
> 
>    Look   at  Brian's  answer  posted  to  you  on  6th  of  December  in
>    [1]http://www1.ietf.org/mail-archive/web/sigtran/current/msg05497.html
> 
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Stanislav Ivanovich <[email-masked]>
Date: Thu, 22 Dec 2005 11:30:31 -0800 (PST)

Brian,
   
  You change your opinions very frequently!
   
  What then "SCCP-User" means in your answer I pointed to in my first mail in this thread?
   
  In the same thread we see this very explicitly pointed to SUA:
   
  -------------------------------------------------------------------
  Brian,

I think SUA relay deserves as much (as little) network management as
M3UA relay does, because they use the same SCTP service (IP network).
Redundand relay nodes (IPSP) will provide the same connectivity to
IPSPs sitting behind them.

In addition, SUA RFC allows DUNA, DAVA, DUPU, to be sent from IPSP relay nodes.

Ilie
-------------------------------------------------------------------
  Ilie,

I disagree.

Nevertheless, SE is 1 AS with a symmetric RK.

--brian
-------------------------------------------------------------------
   
  Are you saying that SUA AS is always a sink but not an entity which both sends and receives traffic?
   
  / Stanislav

"Brian F. G. Bidulock" <[email-masked]> wrote:
  Stanislav,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---------------------------------
 Yahoo! DSL Something to write home about. Just $16.99/mo. or less

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 16:46:28 -0700

Stanislav,

It is one AS, but it is not restricted to point codes as is M3UA.
In SUA, one AS can serve an entire Network Appearance, in M3UA
only a point code.  You seem to want to apply M3UA restrictions to
SUA, but it is not the case.  See the format of a Routing Key for
dynamic registration in SUA.  There are no mandatory fields.  The
RK can be as large as the network.

--brian

Stanislav Ivanovich wrote:                                       (Thu, 22 Dec 2005 11:30:31)
>      _________________________________________________________________
> 
>    [1]Yahoo! DSL Something to write home about. Just $16.99/mo. or less
> 
> References
> 
>    1. http://pa.yahoo.com/*http://us.rd.yahoo.com/evt=37474/*http://promo.yahoo.com/broadband/

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/