Subject: RE: [Sigtran] ASP Active

From: "Prasad, Shashank S (Shashank)" <[email-masked]>
Date: Fri, 23 Dec 2005 17:29:25 +0530

Ilie,
I was trying to answer/question Tolga's and Stanislav's point, when they
said that ASPAC declares readines of the application, i.e. SCCP-User in my
example.

I am of the opinion that M3UA should NOT be check the "readiness" of
SCCP-User, before sending the ASP Active. Or for that matter, it should NOT
even be aware of the states of SCCP-User

shashank

-----Original Message-----
From: Ilie Glib [mailto:[email-masked]]
Sent: Friday, December 23, 2005 4:56 PM
To: Prasad, Shashank S (Shashank)
Cc: Stanislav Ivanovich; [email-masked]; SIGTRAN
Subject: Re: [Sigtran] ASP Active

Hello Shashank,

M3UA should not have any knowledge of SCCP-Users, perhaps you meant
something different in your statement below. M3UA knows whether SCCP
is up and running, that is made visible by SG via DUPU, but it is not
necessary to be visible on IPSP to IPSP interface (M3UA), since SI is
not mandatory part of the RK, and RC in general is optional. Handling
of SCCP-Users is up to SCCP layer, in your network scenario.

Ilie

On 12/23/05, Prasad, Shashank S (Shashank) <[email-masked]> wrote:
> Hi Stanislav, Tolga,
>
> Well, then that would mean that Layer Manager (LM) needs to keep track (or
> be aware) of SCCP and applications over SCCP to initiate the ASP Active
ie.
> LayerN needs to be "aware" of the states of Layer N+2.
>
> The applications (SCCP-User) should have inherent ways to inform the peer
if
> it's NOT ready, OR to drop the incoming message.
> And the peer -to-peer messaging between SCCP-Users, should take care of
> invalid states of one another.
>
> shashank

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 23 Dec 2005 08:13:28 -0500

Shashank,

IMO, when a node initiates ASPAC is more related with internal
implementation -also the relationship of LM with other entities and how that
functionality is implemented-, from M3UA-stack point of view it just means
that the node is ready to send/receive traffic for the coreresponding
traffic range and M3UA-stack should allow sich traffic to pass in both
directions, but practically without an application ready to process the
messages this wouldn't have much meaning.

     Thanks,
     Tolga

> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Prasad, Shashank S (Shashank)
> Sent: Friday, December 23, 2005 6:59 AM
> To: 'Ilie Glib'
> Cc: SIGTRAN; [email-masked]
> Subject: RE: [Sigtran] ASP Active
>
>
> Ilie,