Subject: [Sigtran] Re: Sigtran Digest, Vol 20, Issue 11

From: Saraswati Bose <[email-masked]>
Date: Thu, 8 Dec 2005 20:36:56 -0800 (PST)

Brian,
   
  The UA involved for the below configuration is IUA. And Traffic mode=2 (load share).
  Please suggest in the queries below.
  --Saraswati.

[email-masked] wrote:
  Send Sigtran mailing list submissions to
[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
https://www1.ietf.org/mailman/listinfo/sigtran
or, via email, send a message with subject or body 'help' to
[email-masked]

You can reach the person managing the list at
[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Sigtran digest..."

Today's Topics:

1. Re: Clarification in Loadsharing Traffic for 2+1 model
(Brian F. G. Bidulock)
2. Clarification in Loadsharing Traffic for 2+1 model
(Saraswati Bose)
3. Called Party Number in ISUA (Sergey Mikhailov)
4. RE: Clarification in Loadsharing Traffic for 2+1 model
(Barry Nagelberg)
5. Re: Called Party Number in ISUA (Brian F. G. Bidulock)
6. Re: Clarification in Loadsharing Traffic for 2+1 model
(Brian F. G. Bidulock)
7. RE: Clarification in Loadsharing Traffic for 2+1 model
(Tolga Asveren)

----------------------------------------------------------------------

Message: 1
Date: Thu, 8 Dec 2005 05:34:36 -0700
From: "Brian F. G. Bidulock" 
Subject: Re: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1
model
To: Saraswati Bose 
Cc: sigtran 
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

Saraswati,

Which UA? M3UA? SUA?

--brian

Saraswati Bose wrote: (Thu, 08 Dec 2005 04:28:20)
> 
> Hi Brian,
> 
> Help in the below for TM=2 and redundancy=2+1
> 
> 
> 
> Q1:Three ASPs (ASP1,ASP2,ASP3) in 2+1 configuration serving an AS.
> 
> ASP3 in INACTIVE state.
> 
> ASP1 and ASP2 are in active state and handling traffic.
> 
> 
> 
> Now if ASP2 moves to inactive state then notify" insufficient ASP
> resources" is sent to ASP3.
> 
> In this situation if any ULP data is received at the SG for the AS
> what the SG should do???
> 
> Option1: Send data to ASP1? 
> 
> OR
> 
> Option2: Buffer data until number of active ASPs=n?
> 
> 
> 
> Q2: What if after the above notification ("insufficieant ASP
> resources") is received at the AS end no ASP initiates ACTIVE
> procedure? The RFC is not clear about it .
> 
> 
> 
> Saraswati.
> _________________________________________________________________
> 
> Yahoo! Shopping
> Find Great Deals on Holiday Gifts at [1]Yahoo! Shopping
> 
> References
> 
> 1. http://us.rd.yahoo.com/mail_us/footer/shopping/*http://shopping.yahoo.com/;_ylc=X3oDMTE2bzVzaHJtBF9TAzk1OTQ5NjM2BHNlYwNtYWlsdGFnBHNsawNob2xpZGF5LTA1

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

------------------------------

Message: 2
Date: Thu, 8 Dec 2005 04:28:20 -0800 (PST)
From: Saraswati Bose 
Subject: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model
To: Brian Bidulock , sigtran 
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="iso-8859-1"

Hi Brian,
Help in the below for TM=2 and redundancy=2+1

Q1:Three ASPs (ASP1,ASP2,ASP3) in 2+1 configuration serving an AS.
ASP3 in INACTIVE state.
ASP1 and ASP2 are in active state and handling traffic.

Now if ASP2 moves to inactive state then notify" insufficient ASP resources" is sent to ASP3.
In this situation if any ULP data is received at the SG for the AS what the SG should do???
Option1: Send data to ASP1? 
OR
Option2: Buffer data until number of active ASPs=n?

Q2: What if after the above notification ("insufficieant ASP resources") is received at the AS end no ASP initiates ACTIVE procedure? The RFC is not clear about it . 

Saraswati.

---------------------------------
Yahoo! Shopping
Find Great Deals on Holiday Gifts at Yahoo! Shopping 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www1.ietf.org/pipermail/sigtran/attachments/20051208/9af4917a/attachment.htm

------------------------------

Message: 3
Date: Thu, 8 Dec 2005 17:07:51 +0300
From: "Sergey Mikhailov" 
Subject: [Sigtran] Called Party Number in ISUA
To: "SIGTRAN" 
Cc: "Brian F. G. Bidulock" 
Message-ID: <004a01c5fc00$d1a92550$150f0f0a@smikhailov>
Content-Type: text/plain; charset="koi8-r"

Brian,

As I understand Section 3.10.1.4 [draft-bidulock-sigtran-isua-02], Called Party Number field is 32-bit unsigned integer.
Is it true?

Regards,
Sergey Mikhailov.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www1.ietf.org/pipermail/sigtran/attachments/20051208/1460a66f/attachment.htm

------------------------------

Message: 4
Date: Thu, 8 Dec 2005 09:18:48 -0500
From: "Barry Nagelberg" 
Subject: RE: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1
model
To: "sigtran" 
Message-ID: 
Content-Type: text/plain; charset="iso-8859-1"

Saraswati,

Q1: This is an internal (or actually, a network architecture) implementation decision - you won't find an answer in the
RFC. A third option for this case, which you didn't mention, would be to send an SS7 msg back to the sender, indicating
that the destination is unavailable.

Q2: Again, the RFC is not intended to architect the entire network solution. This is an implemenation decision.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Saraswati Bose
Sent: Thursday, December 08, 2005 7:28 AM
To: Brian Bidulock; sigtran
Subject: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model

Hi Brian,
Help in the below for TM=2 and redundancy=2+1

Q1:Three ASPs (ASP1,ASP2,ASP3) in 2+1 configuration serving an AS.
ASP3 in INACTIVE state.
ASP1 and ASP2 are in active state and handling traffic.

Now if ASP2 moves to inactive state then notify" insufficient ASP resources" is sent to ASP3.
In this situation if any ULP data is received at the SG for the AS what the SG should do???
Option1: Send data to ASP1?
OR
Option2: Buffer data until number of active ASPs=n?

Q2: What if after the above notification ("insufficieant ASP resources") is received at the AS end no ASP initiates
ACTIVE procedure? The RFC is ! not clear about it .

Saraswati.

Yahoo! Shopping
Find Great Deals on Holiday Gifts at Yahoo! Shopping

------------------------------

Message: 5
Date: Thu, 8 Dec 2005 07:26:46 -0700
From: "Brian F. G. Bidulock" 
Subject: [Sigtran] Re: Called Party Number in ISUA
To: Sergey Mikhailov 
Cc: SIGTRAN 
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=iso-8859-1

Sergey,

I never got around to breaking them out. There has been little interest
in the draft.

--brian

On Thu, 08 Dec 2005, Sergey Mikhailov wrote:

> 
> Brian,
> 
> 
> 
> As I understand Section 3.10.1.4 [draft-bidulock-sigtran-isua-02],
> Called Party Number field is 32-bit unsigned integer.
> 
> Is it true?
> 
> 
> 
> Regards,
> 
> Sergey Mikhailov.

-- 
Brian F. G. Bidulock ¦ The reasonable man adapts himself to the ¦
[email-masked] ¦ world; the unreasonable one persists in ¦
http://www.openss7.org/ ¦ trying to adapt the world to himself. ¦
¦ Therefore all progress depends on the ¦
¦ unreasonable man. -- George Bernard Shaw ¦

------------------------------

Message: 6
Date: Thu, 8 Dec 2005 07:28:15 -0700
From: "Brian F. G. Bidulock" 
Subject: Re: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1
model
To: Barry Nagelberg 
Cc: sigtran 
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

Barry,

Saraswati should have mentioned that the questions apply to IUA.

--brian

Barry Nagelberg wrote: (Thu, 08 Dec 2005 09:18:48)
> Saraswati,
> 
> Q1: This is an internal (or actually, a network architecture) implementation decision - you won't find an answer in the
> RFC. A third option for this case, which you didn't mention, would be to send an SS7 msg back to the sender, indicating
> that the destination is unavailable.
> 
> Q2: Again, the RFC is not intended to architect the entire network solution. This is an implemenation decision.
> 
> Barry Nagelberg
> Adax, Inc.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of Saraswati Bose
> Sent: Thursday, December 08, 2005 7:28 AM
> To: Brian Bidulock; sigtran
> Subject: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model
> 
> 
> Hi Brian,
> Help in the below for TM=2 and redundancy=2+1
> 
> Q1:Three ASPs (ASP1,ASP2,ASP3) in 2+1 configuration serving an AS.
> ASP3 in INACTIVE state.
> ASP1 and ASP2 are in active state and handling traffic.
> 
> Now if ASP2 moves to inactive state then notify" insufficient ASP resources" is sent to ASP3.
> In this situation if any ULP data is received at the SG for the AS what the SG should do???
> Option1: Send data to ASP1?
> OR
> Option2: Buffer data until number of active ASPs=n?
> 
> Q2: What if after the above notification ("insufficieant ASP resources") is received at the AS end no ASP initiates
> ACTIVE procedure? The RFC is ! not clear about it .
> 
> Saraswati.
> 
> 
> Yahoo! Shopping
> Find Great Deals on Holiday Gifts at Yahoo! Shopping
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

------------------------------

Message: 7
Date: Thu, 8 Dec 2005 09:09:24 -0500
From: "Tolga Asveren" 
Subject: RE: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1
model
To: 
Message-ID: 
Content-Type: text/plain; charset="iso-8859-1"

Saraswati,

Replying from M3UA point of view:

Q1: SG should send DATA to ASP1.

Q2: SG continues to send DATA to ASP1.

Please have a look to M3Ua-bis document regarding those issues. The state
diagram for AS has answers to your questions.

Thanks,
Tolga
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf
Of Saraswati Bose
Sent: Thursday, December 08, 2005 7:28 AM
To: Brian Bidulock; sigtran
Subject: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model

Hi Brian,
Help in the below for TM=2 and redundancy=2+1

Q1:Three ASPs (ASP1,ASP2,ASP3) in 2+1 configuration serving an AS.
ASP3 in INACTIVE state.
ASP1 and ASP2 are in active state and handling traffic.

Now if ASP2 moves to inactive state then notify" insufficient ASP
resources" is sent to ASP3.
In this situation if any ULP data is received at the SG for the AS what
the SG should do???
Option1: Send data to ASP1?
OR
Option2: Buffer data until number of active ASPs=n?

Q2: What if after the above notification ("insufficieant ASP resources")
is received at the AS end no ASP initiates ACTIVE procedure? The RFC is !
not clear about it .

Saraswati.

----------------------------------------------------------------------------
--
Yahoo! Shopping
Find Great Deals on Holiday Gifts at Yahoo! Shopping
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www1.ietf.org/pipermail/sigtran/attachments/20051208/8f5bb568/attachment.htm

------------------------------

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

End of Sigtran Digest, Vol 20, Issue 11
***************************************

---------------------------------
Yahoo! Shopping
 Find Great Deals on Holiday Gifts at Yahoo! Shopping 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 8 Dec 2005 21:48:16 -0700

Saraswati,

Read

 http://www.ietf.org/internet-drafts/draft-ietf-sigtran-rfc3057bis-02.txt

bottom of Page 50, and the middle of Page 51.

The answers are there.

--brian

Saraswati Bose wrote:                             (Thu, 08 Dec 2005 20:36:56)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/