Subject: [Sigtran] Local interface failure detection by SCTP.

From: Prathap T <[email-masked]>
Date: Sat, 10 Dec 2005 00:38:05 +0530

How should SCTP detect Local interface failure assuming SCTP is implemented
in the user space.

For ex:
   Assume there is Endpoint A, Endpoint B
   Endpoint A has interface A1, A2.

    Endpoint B has interface B1, B2.

  Endpoint A, communicates to B using it's local interface A1. Now when A1
goes down,
  how does A, get to know this??

  This can be a problem, when A sends out heartbeat with source as A1 and
destination as B1.
  ( I think IP sends this out on A2 with source as A1)
  and the endpoint B responds with an HBeatAck with destination as A1, which
is no more existing.

  Now since A did not receive HBeatAck from B, it will consider B1 not
reachable after some retries.
  This can be a real problem when HBeat Interval time of B is very high
and HBeat interval of A is low. This can lead to breakdown of association.

   So, what is the mechanism SCTP has to employ to detect Local failure.

Regards,
Prathap.
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 9 Dec 2005 13:58:53 -0700

Prathap,

See the SCTP I-G discussed on TSVWG.  It includes some advise on
controlling the source address for user-space implementations.

--brian

Prathap T wrote:                                                   (Sat, 10 Dec 2005 00:38:05)
> 
>    How  should  SCTP  detect  Local  interface  failure  assuming SCTP is
>    implemented in the user space.
> 
> 
> 
>    For ex:
> 
>       Endpoint  A,  communicates  to B using it's local interface A1. Now
>    when A1 goes down,
> 
>       This can be a problem, when A sends out heartbeat with source as A1
>    and destination as B1.
> 
>      and the endpoint B responds with an HBeatAck with destination as A1,
>    which is no more existing.
> 
> 
> 
>       This  can  be  a real problem when HBeat Interval time of B is very
>    high  and HBeat  interval  of  A is low. This can lead to breakdown of
>    association.
> 
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/