Subject: [Sigtran] SOR/SOG in SUA

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 11:17:40 +0100

Hello Folks,

for some time SUA drafts had support for SOR/SOG messages. In the RFC
there is no support for SOR/SOG.

How Local Subsystem out-of-service Request is supported by SUA?

What was the reason to remove SOR/SOG?
Do you think ASPTM is sufficient to deal with Local Subsystem
out-of-service Request? If not, how Local Subsystem out-of-service
Request is supported by SUA?

Thank you in advance

--
Ilie

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 03:34:23 -0700

Ilie,

SOR/SOG is supported in the RFC with DRST message, see section 3.4.6.

--brian

Ilie Glib wrote:                                                                      (Thu, 22 Dec 2005 11:17:40)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 12:12:47 +0100

Hello Brian,

How an application (SCCP-User) can acknowledge the SOR via a SUA message?
Or if the application does not acknowledge SORs, what procedure
instead shall apply in the SG?

I am afraid something is underspecified in the RFC, or I have overlooked it.

Thank you in advance

Ilie

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 04:19:44 -0700

Ilie,

Read section 3.4.6!  N-COORD is an SCCP/SCCP-User primitive!

--brian

Ilie Glib wrote:                                                      (Thu, 22 Dec 2005 12:12:47)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 12:52:32 +0100

Brian,

Thank you very much for you answer.
According to the RFC the DRST copied in backward direction represents
N-COORD respose primitive (SOG message) iff SMI is not included. How
does SG populate SMI parameter of the SOG sent in response to SOR?
Although it should not be of any relevance for the requesting side,
the SMI parameter is mandatory in SOG.

Ilie

--
Ilie

---

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 12:56:56 +0100

I guess SMI in SOG shall be
00 (= affected SMI unknown)

Ilie

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 05:00:26 -0700

Ilie,

See Q.711 and Q.751.2.

--brian

Ilie Glib wrote:                                                      (Thu, 22 Dec 2005 12:52:32)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 05:09:21 -0700

Ilie,

No, it is a value known to the SCCP at the SG.

--brian

Ilie Glib wrote:                                                      (Thu, 22 Dec 2005 12:56:56)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 16:00:17 +0100

Brian,

as consequence from your statement below, SOG and SOR cannot pass
through an SG and in sequence an ASP with Relay , otherwise the SG
would not know the SMI.

Ilie

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 08:06:51 -0700

Ilie,

SOG and SOR are SCMG messages.  They are not sent through an SCCP
relay point.  They are sent between entities in an entity set by
point code.

--brian

Ilie Glib wrote:                                                      (Thu, 22 Dec 2005 16:00:17)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Ilie Glib <[email-masked]>
Date: Thu, 22 Dec 2005 16:14:29 +0100

Brian,

no doubts about that, but SUA Relay can translate SPC+SSN into an IP
destination. I agree that there is no much sense in such configuration
of redundant subsystems, but some system architectures may force it. I
believe it is then a problem to solve for this system architectures.

Ilie

--
Ilie

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 08:34:45 -0700

Ilie,

That would be relaying.  Again, the SOR and SOG are not relayed.  Ever.
Move on.

--brian

Ilie Glib wrote:                                                      (Thu, 22 Dec 2005 16:14:29)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Stanislav Ivanovich <[email-masked]>
Date: Thu, 22 Dec 2005 08:05:08 -0800 (PST)

Hello,
   
  ITU-T Q.711, Table 15/Q.711 Parameters of the primitive N-COORD:
   
  Subsystem multiplicity indicator (SMI):
  N-COORD request -> n.a.
N-COORD indication -> O
N-COORD response -> n.a.
N-COORD confirm -> O

  SUA RFC seems to have a fault in Note1 of sec. 3.4.6.:
   
  "If the SMI parameter is also included
in the message, the DRST message corresponds to the
N-COORD Request and N-COORD Indication primitives,
otherwise, the DRST message correspondence to the N-COORD
Response and N-COORD Confirm primitives."

  /stanislav

"Brian F. G. Bidulock" <[email-masked]> wrote:
  Ilie,

--brian

> On 12/22/05, Brian F. G. Bidulock wrote:
> > Ilie,
> >
> > > On 12/22/05, Brian F. G. Bidulock wrote:
> > > > Ilie,
> > > >
> > > > > On 12/22/05, Ilie Glib wrote:
> > > > > > Brian,
> > > > > >
> > > > > > On 12/22/05, Brian F. G. Bidulock wrote:
> > > > > > > Ilie,
> > > > > > >
> > > > > > > > On 12/22/05, Brian F. G. Bidulock wrote:
> > > > > > > > > Ilie,
> > > > > > > > >

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com