Subject: [Sigtran] ASP Active

From: "Prasad, Shashank S (Shashank)" <[email-masked]>
Date: Fri, 23 Dec 2005 01:04:12 +0530

I had a question related to ASP Active message and the definition of AS:

The section 3.7.1 says:

   The ASP Active message is sent by an ASP to indicate to a remote M3UA
   peer that it is ready to process signalling traffic for a particular
   Application Server.  

And I read from the specs, that an Application Server can be a a virtual
switch element handling all call processing for a unique range of PSTN
trunks, identified by an SS7 SIO/DPC/OPC/CIC_range.  Another example is a
virtual database element, handling all HLR transactions for a particular SS7
DPC/OPC/SCCP_SSN combination.

In this context, here is the question:
Let's assume that we have the following stacks at the both the ends.

         ********    IP    ********
         *IPSP-A*          *IPSP-B*
         ********          ********

         +------+          +------+
         |SCCP- |          |SCCP- |
         | User |          | User |
         +------+          +------+
         | SCCP |          | SCCP |
         +------+          +------+
         | M3UA |          | M3UA |
         +------+          +------+
         | SCTP |          | SCTP |
         +------+          +------+
         |  IP  |          |  IP  |
         +------+          +------+
             |________________|

When the IPSP-A sends an ASP Active to IPSP-B, does it mean that the SCCP
ONLY (at Node A) is ready for receiving signaling traffic or even the
SCCP-User/Application (at Node A) is ready for Signaling traffic.

I believe that ASP Active was sent to receive the SCCP (at Node A) traffic
from NodeB. However, there can be a scenario wherein, at the same time, the
SCCP-User (at Node A) is NOT ready to send and receive traffic from NodeB.

Let me know if this interpretation is fine.

shashank

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 22 Dec 2005 14:26:47 -0500

Shashank,

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Prasad, Shashank S (Shashank)
> Sent: Thursday, December 22, 2005 2:34 PM
> To: [email-masked]
> Subject: [Sigtran] ASP Active
>
>
[TOLGA]For practical purposes, I would say that ASPAC declares readines of
the application, i.e. SCCP-User in your example. OTOH, I would think from
M3UA point of view, it wouldn't matter whichever interpretation you pick but
receiving messages with no application to process them is probably not very
useful.

---

From: Stanislav Ivanovich <[email-masked]>
Date: Thu, 22 Dec 2005 12:05:11 -0800 (PST)

Shashank,
   
  Both M3UA and SUA in the same section 4.3.4.3. "ASP Active Procedures" say:
   
  "By sending an ASP Active Ack message, the SGP or IPSP is now ready to receive and send traffic for the related Routing Context(s). The ASP SHOULD NOT send 
  Data or SSNM messages for the related Routing Context(s) before receiving an ASP ! Active Ack message, or it will risk message loss."
   
  Having in mind that ASP/IPSP is a process that runs one or several applications the reference above says that process ASP/IPSP is not allowed to SEND traffic on behalf of application A1 externally represented with RC1 if the process has not activated itself in for the A1 by sending RC1 to the SGP (or IPSP).
   
  In other words the application A1 is dead within the process ASP/IPSP thus cannot send traffic until the process has activated itself for the AS1.
   
  Change of this very fundamental principle that AS is both sink and source at the same time in the xxUA specifications would cause many other changes (i.e. it is not just one paragraph I pointed to...).
   
  / Stanislav

Tolga Asveren <[email-masked]> wrote:   Shashank,

		
---------------------------------
Yahoo! Shopping
 Find Great Deals on Holiday Gifts at Yahoo! Shopping

---

From: Stanislav Ivanovich <[email-masked]>
Date: Thu, 22 Dec 2005 12:51:24 -0800 (PST)

Shashank,
   
  I forgot to say that the principle I quoted from the M3UA and SUA specifications seems to be good for your simple case of 2 IP resident applications that communicate directly. Why would you after all send traffic if the application cannot receive any reply? In practice communication normally goes in 2 ways.
  The problem is when one wants to build relay on MTP3 (for M3UA) or SCCP (for SUA) levels by using the AS/RC concept.

  However looking into other mails posted by you I fully agree with you to have this fundamental stuff explicitly clarified, explained in the specifications. I also vote for this!
   
  Especially since recently we heard many contradictory/absurd answers (especially from SUA people, e.g. "all the process types can act as ASP, IPSP, SGP"; "Defintion of processes is the matter of Operating Systems" etc...).
   
  Personally I think that (unlike M3UA) SUA paper is the (very) problematic one...
   
  / Stanislav

Stanislav Ivanovich <[email-masked]> wrote:     Shashank,

   
   
  &nb! sp;
   
  / Stanislav

>! ; peer that it is ready to process signalling traffic for a particular
> Application Server.
>
>
> | I! P | | IP |

    
---------------------------------
  Yahoo! Shopping
Find Great Deals on Holiday Gifts at Yahoo! Shopping _______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 16:49:42 -0700

Stanislav,

Stanislav Ivanovich wrote:                                       (Thu, 22 Dec 2005 12:05:11)
>    "By sending an ASP Active Ack message, the SGP or IPSP is now ready to
>    receive  and  send traffic for the related Routing Context(s). The ASP
>    SHOULD NOT send
> 
>    Data  or  SSNM  messages  for  the  related  Routing Context(s) before
>    receiving an ASP ! Active Ack message, or it will risk message loss."
> 
> 
> 
>    Having  in  mind  that  ASP/IPSP is a process that runs one or several
>    applications  the  reference  above  says that process ASP/IPSP is not
>    allowed  to  SEND  traffic  on  behalf  of  application  A1 externally
>    represented  with  RC1  if the process has not activated itself in for
>    the A1 by sending RC1 to the SGP (or IPSP).

Read the passage!  It does not disallow anything.  It makes a recommendation
with regard to message loss.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Dec 2005 16:51:13 -0700

Stanislav,

Stanislav Ivanovich wrote:                                       (Thu, 22 Dec 2005 12:51:24)
> 
> 
>    The  problem  is  when  one wants to build relay on MTP3 (for M3UA) or
>    SCCP (for SUA) levels by using the AS/RC concept.

M3UA does not support relay.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/