Subject: Re: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 8 Dec 2005 05:34:36 -0700

Saraswati,

Which UA?  M3UA?  SUA?

--brian

Saraswati Bose wrote:                                            (Thu, 08 Dec 2005 04:28:20)
> 
>    Hi Brian,
> 
>    Help in the below for TM=2 and redundancy=2+1
> 
> 
> 
>    Q1:Three ASPs (ASP1,ASP2,ASP3) in 2+1 configuration serving an AS.
> 
>    ASP3 in INACTIVE state.
> 
>    ASP1 and ASP2 are in active state and handling traffic.
> 
> 
> 
>    Now  if  ASP2  moves  to  inactive state then notify" insufficient ASP
>    resources" is sent to ASP3.
> 
>    In  this  situation  if  any ULP data is received at the SG for the AS
>    what the SG should do???
> 
>    Option1: Send data to ASP1?  
> 
>                      OR
> 
>    Option2: Buffer data until number of active ASPs=n?
> 
>    
> 
>    Q2: What   if   after the   above   notification  ("insufficieant  ASP
>    resources")  is  received at  the  AS  end  no  ASP  initiates  ACTIVE
>    procedure? The RFC is not clear about it .
> 
> 
> 
>    Saraswati.
>      _________________________________________________________________
> 
>    Yahoo! Shopping
>    Find Great Deals on Holiday Gifts at [1]Yahoo! Shopping
> 
> References
> 
>    1. http://us.rd.yahoo.com/mail_us/footer/shopping/*http://shopping.yahoo.com/;_ylc=X3oDMTE2bzVzaHJtBF9TAzk1OTQ5NjM2BHNlYwNtYWlsdGFnBHNsawNob2xpZGF5LTA1

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Saraswati Bose <[email-masked]>
Date: Thu, 8 Dec 2005 04:28:20 -0800 (PST)

Hi Brian,

  Now if ASP2 moves to inactive state then notify" insufficient ASP resources" is sent to ASP3.
  In this situation if any ULP data is received at the SG for the AS what the SG should do???
  Option1: Send data to ASP1?  
                    OR
  Option2: Buffer data until number of active ASPs=n?
   
  Q2: What if after the above notification ("insufficieant ASP resources") is received at the AS end no ASP initiates ACTIVE procedure? The RFC is not clear about it . 
   
  Saraswati.

---------------------------------
Yahoo! Shopping
 Find Great Deals on Holiday Gifts at Yahoo! Shopping

---

From: "Barry Nagelberg" <[email-masked]>
Date: Thu, 8 Dec 2005 09:18:48 -0500

Saraswati,

Q1: This is an internal (or actually, a network architecture) implementation decision - you won't find an answer in the
RFC. A third option for this case, which you didn't mention, would be to send an SS7 msg back to the sender, indicating
that the destination is unavailable.

Q2: Again, the RFC is not intended to architect the entire network solution. This is an implemenation decision.

Barry Nagelberg
Adax, Inc.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Saraswati Bose
Sent: Thursday, December 08, 2005 7:28 AM
To: Brian Bidulock; sigtran
Subject: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model

Hi Brian,

Q2: What if after the above notification ("insufficieant ASP resources") is received at the AS end no ASP initiates
ACTIVE procedure? The RFC is ! not clear about it .

Saraswati.

Yahoo! Shopping

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 8 Dec 2005 07:28:15 -0700

Barry,

Saraswati should have mentioned that the questions apply to IUA.

--brian

Barry Nagelberg wrote:                                               (Thu, 08 Dec 2005 09:18:48)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Thu, 8 Dec 2005 09:09:24 -0500

Saraswati,

Replying from M3UA point of view:

Q1: SG should send DATA to ASP1.

Q2: SG continues to send DATA to ASP1.

Please have a look to M3Ua-bis document regarding those issues. The state
diagram for AS has answers to your questions.

    Thanks,
    Tolga
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf
Of Saraswati Bose
  Sent: Thursday, December 08, 2005 7:28 AM
  To: Brian Bidulock; sigtran
  Subject: [SIGTRAN] Clarification in Loadsharing Traffic for 2+1 model

  Hi Brian,

  In this situation if any ULP data is received at the SG for the AS what
the SG should do???

  Q2: What if after the above notification ("insufficieant ASP resources")
is received at the AS end no ASP initiates ACTIVE procedure? The RFC is !
not clear about it .

  Saraswati.

----------------------------------------------------------------------------
--
  Yahoo! Shopping
  Find Great Deals on Holiday Gifts at Yahoo! Shopping
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 8 Dec 2005 12:01:43 -0700

Ramesh,

Loadsharing differs from UA to UA.

--brian

Ramesh Jha wrote:                     (Thu, 08 Dec 2005 10:39:13)
> 
> Hi Brian,
> 
> 	I think Saraswati is mentioning about IUA. That all right. But my
> question here is that for the overall Sigtran Architecture, AS-ASP model
> should be defined consistently irrespective of any UA. 
> 
> The problem of identifying a particular AS using the key can be solved by a
> generic text based key in which RK of M3UA, IID of IUA and RK of SUA can be
> mapped.
> 
> The notifications and associated procedures like the one mentioned by
> Saraswati should be true for any UA.
> 
> Please correct me if my suggestions deviates some rules.
> 
> Regards,
> --Ramesh Jha
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/