Subject: RE: [Sigtran] Query on DRN usage.

From: [email-masked]
Date: Tue, 6 Dec 2005 18:06:51 +0530

Hi Brian,
        
   Implementers Guide 2 has clarification on the usage of the TID and
DRN labels.
   It says , in case of TID label , start and end field should be within
0-31.
   In case of DRN label , start and end field should be within 0-23.

   In my opinion , start should be within 0-15 and end  should be within
16-31.

   In case of DRN , start should be within 0-7 aqnd end should be within
8-23.

   In both cases (start - end)  should be equal to 16 , simply because
the Label value is 16 bit wide.
   
   Is my understanding correct ?

Regards,
Partha.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, December 05, 2005 1:59 PM
To: Partha De (WT01 - Voice & Next Generation Networks)
Cc: [email-masked]
Subject: Re: [Sigtran] Query on DRN usage.

partha.dey,

[email-masked] wrote:                                     (Mon, 05
Dec 2005 13:02:48)
> 
>    Hi Brian,
> 
>                  As per RFC  section 3.10.5 , Destination Reference No
is
>    allocated by the SUA instance.
> 
> 
> 
>    Lets take the following scenario,
> 
>     Peer ASP has registered DRN  to the SG through ASPAC message.
> 
>     CORE  message  is being   sent  ,say  from  SG  to  peer ASP,  and
it
>    contains the Source reference No.
> 
>     ASP  sends  an COAK message in return and it contains the
Destination
>    Reference No. in it.
> 
> 
> 
>    Should  we  take  down  this  connection  if  the received
Destination
>    Reference  No. does not match with the One registered for this Peer
in
>    the SG?

Well, no, not necessarily.  It might be worth informing local management
at the SG, and then it might not.

One ASP could accept a CORE, form a connection, but hand it off to
another ASP through ASP-ASP communication or shared state, and then
reply with a DRN assigned by the ASP to which it is handed off.

DRN Labels are not necessarily symmetric.  It just means that all
messages with those DRNs sent from SG->ASP will be sent to the ASP that
registered the label.   It does not restrict what DRNs an ASP sends to
an SG.  The SG is (err, might be) perfectly capable of routing the
message regardless of what DRN it contains.

In the typical case, one would expect that the DRNs sent by an ASP would
be in the DRN label range for which they registered, but there are other
possibilities.  It might be worth (providing an option) informing local
management at the SG on a 1st-and-delta basis if this occurs.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 6 Dec 2005 06:03:39 -0700

partha.dey,

SUA I-G with regard to TID/DRN labels is very broken and needs
to be revised.

--brian

[email-masked] wrote:                                     (Tue, 06 Dec 2005 18:06:51)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/