Subject: RE: [Sigtran] Re: Traffic handling modes of SGPs

From: "Loughney John (Nokia-NRC/Helsinki)" <[email-masked]>
Date: Mon, 5 Dec 2005 11:22:29 +0200 (EET)

I agree with Brian. The section is just introductory in nature. It shouldn't have impact on implementations.
John

-- This email was sent from my Nokia phone --

> -----Original Message-----
> From: [email-masked] on behalf of ext Brian F. G. Bidulock
> Received: Mon Dec 05 10:34:35 EET 2005
> To: Ilie Glib
> Cc: [email-masked]
> Subject: Re: [Sigtran] Re: Traffic handling modes of SGPs
> 
> Ilie,
> 
> An assumption is not even close to a requirement.
> 
> An ASP that cannot accept a connection is underfeatured compared
> to one that does.
> 
> --brian
> 
> Ilie Glib wrote:                                                      (Mon, 05 Dec 2005 09:27:31)
> > Hello Brian,
> > 
> > here is a quote from RFC 3868
> > "
> > 1.3.  Signalling Transport Architecture
> > 
> > ...
> >    In general terms, the SUA architecture can be modeled as a peer-to-
> >    peer architecture.  The first section considers the SS7 to IP
> >    interworking architectures for connectionless and connection-oriented
> >    transport.  For this case, it is assumed that the ASP initiates the
> >    establishment of the SCTP association with SG.
> > "
> > 
> > I agree that the last sentence of the quoted paragraph does not say
> > "SHOULD", at the same time it looks like ASPs must act as clients for
> > establishment of SCTP associations, and there is no statement in the
> > RFC that would make ASPs to open listening sockets.
> > 
> > On 12/2/05, Brian F. G. Bidulock <[email-masked]> wrote:
> > > Ilie,
> > >
> > > Ilie Glib wrote:                             (Fri, 02 Dec 2005 12:44:35)
> > > > Brian,
> > > >
> > > > I am sorry to bore you with this, and perhaps it does not deserve too
> > > > much attention, but ASPs which act as clients (according to the RFC
> > > > they should do so) would never open a listening socket. Therefore SCTP
> > > > INIT from the SGP will be lost.
> > >
> > > Where does it say that?
> > >
> > > --brian
> > >
> > 
> > Regards
> > 
> > Ilie
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
> 
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Ilie Glib <[email-masked]>
Date: Mon, 5 Dec 2005 15:37:16 +0100

Hello Brian, John,

thank you very much indeed for your clarifications

Regards

Ilie