Subject: [Sigtran] Asymetric multi-homing configuration

From: "Trentadue, Tim" <[email-masked]>
Date: Wed, 7 Jun 2006 10:01:51 -0500

Greetings,

I have a question about this. For reference, I'll use the following from
section 7.4.2 of the SCTP Reference Guide by Steward and Xie:

Host A                                                         Host Z
+-----+                                                        +-----+
|     |              +---+      ************                   |     |
|     |--------------| R |------*          *                   |     |
|     |1.2           +---+      *          *      +---+        |     |
|     |               1.1       *   IP     *------| R |--------|     |
|     |                         *  network *      +---+     3.2|     |
|     |              +---+      *          *       3.1         |     |
|     |--------------| R |------*          *                   |     |
|     |2.2           +---+      ************                   |     |
+-----+               2.1                                      +-----+

"R" = router

Host A routing table               Host Z routing table
====================               ====================
Destination    Gateway             Destination    Gateway
-----------    -------             -----------    -------
3.0            1.1                 1.0            3.1
                                   2.0            3.1

The contraint here is that Host Z cannot have an additional address.

Assuming the route in Host A routing table is the "default" route, would
an additional "static" route help achieve multi-homing?

Host A routing table (proposed)             
====================
Destination    Gateway
-----------    -------
3.0            1.1  (default)
3.0            2.1  (static)  

Thanks,
Tim Trentadue

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Jun 2006 12:50:39 -0600

Tim,

Trentadue, Tim wrote:                   (Wed, 07 Jun 2006 10:01:51)
> an additional "static" route help achieve multi-homing?

Yes, it would.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 7 Jun 2006 21:11:03 +0200

Brian,
a question below.
Best regards
Michael

>> an additional "static" route help achieve multi-homing?
How? Doesn't it depend on the source address selection performed at  
Host A?
I would guess that it all depends on implementation details of A...

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Jun 2006 13:32:12 -0600

Michael,

Michael Tuexen wrote:                      (Wed, 07 Jun 2006 21:11:03)
> How?

Because GW 1.2 can be reachable when GW 1.1 is not.

> Doesn't it depend on the source address selection performed at  Host A?

No.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/