Subject: [Sigtran] Lossless fail-over

From: "Kolomaznik Jan" <[email-masked]>
Date: Mon, 19 Jun 2006 14:44:10 +0200

Hello everybody!

Is there any document specifying lossless fail-over or change-back
procedures in Sigtran especially in SUA?

I found out only expired draft-bidulock-sigtran-corid-03.txt. From my
point of view this draft solves what I exactly need - but it is only
expired draft. How to solve it on inter-vendor level? Does anybody know
why this draft was leaved?

Thanks

Jan Kolomaznik

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 19 Jun 2006 08:46:42 -0400

Jan,

I will try to summarize the rationale behind not having
changeover/changeback type of functionality in M3UA/SUA:
(there is an expired draft about M3UA deployment considerations, if you are
interested I can send you the relevant sections from it.)

a) Network failures are handled by SCTP + properly designed network.
b) Because of a) loss of SCTP association means peer going down.
c) When peer is down, changeover/changeback doesn't help -also not in
conventional SS7-.

   Thanks,
   Tolga

-----Original Message-----
From: Kolomaznik Jan [mailto:[email-masked]]
Sent: Monday, June 19, 2006 8:44 AM
To: [email-masked]
Subject: [Sigtran] Lossless fail-over

Hello everybody!

I found out only expired draft-bidulock-sigtran-corid-03.txt. >From my point
of view this draft solves what I exactly need - but it is only expired
draft. How to solve it on inter-vendor level? Does anybody know why this
draft was leaved?

Thanks
Jan Kolomaznik

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Jun 2006 07:15:58 -0600

Tolga,

Tolga Asveren wrote:                       (Mon, 19 Jun 2006 08:46:42)
> c) When peer is down, changeover/changeback doesn't help -also not in

Of course it does: whenever there is more than one ASP serving
an AS.  Just because one ASP is down does not mean that another
is also not available.

Also, a node failure (STP, SCCP Relay) does not preclude
lossless failover in SS7.  See Q.705.

You presume to much about specific IP network arrangements.

Protocol elements for lossless changeover for a number of UAs
are quite useful (just as they are in conventional SS7.)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Haresign Lincoln" <[email-masked]>
Date: Mon, 19 Jun 2006 09:16:53 -0400

Tolga,

It is possible that associations fail for other reasons than loss of
peer.  We see associations failures in overloaded or poorly designed IP
networks.  I don't think we can always count on properly designed
networks.

Regards,
Lincoln

-----Original Message-----
From: Tolga Asveren [mailto:[email-masked]] 
Sent: Monday, June 19, 2006 8:47 AM
To: [email-masked]
Subject: RE: [Sigtran] Lossless fail-over

Jan,

I will try to summarize the rationale behind not having
changeover/changeback type of functionality in M3UA/SUA:
(there is an expired draft about M3UA deployment considerations, if you
are interested I can send you the relevant sections from it.)

   Thanks,
   Tolga

-----Original Message-----
From: Kolomaznik Jan [mailto:[email-masked]]
Sent: Monday, June 19, 2006 8:44 AM
To: [email-masked]
Subject: [Sigtran] Lossless fail-over

Hello everybody!

I found out only expired draft-bidulock-sigtran-corid-03.txt. >From my
point of view this draft solves what I exactly need - but it is only
expired draft. How to solve it on inter-vendor level? Does anybody know
why this draft was leaved?

Thanks
Jan Kolomaznik

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Jun 2006 07:18:48 -0600

Jan,

Kolomaznik Jan wrote:                          (Mon, 19 Jun 2006 14:44:10)
> 
>    I found out only expired draft-bidulock-sigtran-corid-03.txt.

If you are interested I could resubmit the draft.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 19 Jun 2006 08:59:24 -0400

Hi Lincoln,

I am just presenting the rationale behind a conscious decision by SIGTRAN
WG. It could be that some fixes may be necessary. As my current personal
opinion, I do not think something similar to correlation Ids is necessary at
all.

In the same expired draft I mentioned, certain solutions are suggested for
cases where SCTP associations go down for reasons except host failure, e.g.
adjusting SCTP parameters.

    Thanks,
    Tolga

> From: Haresign Lincoln [mailto:[email-masked]]
> Sent: Monday, June 19, 2006 9:17 AM
> To: Tolga Asveren; [email-masked]

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Jun 2006 07:28:07 -0600

Tolga,

Tolga Asveren wrote:                                   (Mon, 19 Jun 2006 08:59:24)
> opinion, I do not think something similar to correlation Ids is necessary at

They are necessary for "lossless" failover as opposed to "lossy" failover as
detailed in the corid draft.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 19 Jun 2006 09:08:26 -0400

Brian,

> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Monday, June 19, 2006 9:16 AM
> To: Tolga Asveren
> Cc: [email-masked]
> Subject: Re: [Sigtran] Lossless fail-over
>
>
> Tolga,
>
[TOLGA]I didn't try to say when an ASP is down, one shouldn't send messages
to an alternate one. This mecanims is already present in M3UA/SUA. My
apologies for not making it clear.