Subject: [Sigtran] SCTP: SSN,TSN and data delivery mechanism

From: Saraswati Bose <[email-masked]>
Date: Mon, 19 Jun 2006 03:32:07 -0700 (PDT)

Hi Brian,
  1.As per rfc-2960 sectiopn 3.3.1, in Stream Sequence Number description its said that "when a data message is fragmented then the fragments will have same Stream Sequence Number." 
  Should not that imply that these SCTP data fragments will be transmitted over same sctp stream because stream seqence number indicates the sequence of data message within the particular stream? If not please rectify my understanding.
   
  2. Ordered Delivery:When ordered delivery is intended then SCTP must check the SSN numbers of all tsns (chunks) and then deliver the chunks in order of SSNs for the particular stream. Right or wrong? 
  Please rectify if wrong
   
  3. Unordered Delivery: For this case SCTP at the receiving end just collects all tsn corresponding to the fragmented data (identified by the same ssn value) and sends to the above user layer. Right or wrong?
  Please rectify if wrong
   
  Regards,
Saraswati

---------------------------------
How low will we go? Check out Yahoo! Messenger’s low  PC-to-Phone call rates.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Jun 2006 05:49:27 -0600

Saraswati,

Saraswati Bose wrote:                             (Mon, 19 Jun 2006 03:32:07)
> 
>    Hi Brian,
> 
>    1.As   per   rfc-2960   sectiopn  3.3.1,  in  Stream  Sequence  Number
>    description  its said that "when a data message is fragmented then the
>    fragments will have same Stream Sequence Number."
> 
>    Should  not  that  imply  that  these  SCTP  data  fragments  will  be
>    transmitted  over  same  sctp  stream  because  stream  seqence number
>    indicates  the  sequence of data message within the particular stream?
>    If not please rectify my understanding.

Data, fragmented or not, is always sent on the stream for which it is
designated.  It is never sent on a different stream.

>    2.  Ordered  Delivery:When ordered delivery is intended then SCTP must
>    check the SSN numbers of all tsns (chunks) and then deliver the chunks
>    in order of SSNs for the particular stream. Right or wrong?

Well, no: optimizations are possible.  All that is necessary is that there
be no TSNs missing between fragments and no SSNs missing for a given stream
to be able to deliver (or partial deliver) for the stream.

>    3.  Unordered  Delivery:  For this case SCTP at the receiving end just
>    collects  all  tsn corresponding to the fragmented data (identified by
>    the same ssn value) and sends to the above user layer. Right or wrong?

SSN value in unordered deliver fragments is meaningless.  Here is it necessary
that there be no TSNs missing between fragments.  (However, also note that
RFC2960 says that each fragment in an unordered message must be assigned
sequential TSNs, although I never really agreed with that because it
reintroduces head of line blocking on large unordered data.)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/