Subject: Fwd: Re: [Sigtran] What will be the handling for this scenarion ( notmentioned in DUA RFC )

From: ankur arora <[email-masked]>
Date: Sun, 18 Jun 2006 23:54:09 -0700 (PDT)

Hi Brian,
   
  Whats your view on this.
   
  Regards
  Ank Arora

ankur arora <[email-masked]> wrote:
  Date: Fri, 16 Jun 2006 04:23:09 -0700 (PDT)
From: ankur arora <[email-masked]>
Subject: Re: [Sigtran] What will be the handling for this scenarion (
notmentioned in DUA RFC )
To: [email-masked]

  Hi Brian,
   
  According to me, ASP should Return Error (Only for that particular Channel) and the status for that particular channel remains unchanged ( status remains same as before). 
   
  Regards
  Ank Arora
    
---------------------------------
  Yahoo! Sports Fantasy Football ’06 - Go with the leader. Start your league today! _______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---------------------------------
Sneak preview the  all-new Yahoo.com. It's not radically different. Just radically better. 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Jun 2006 03:07:04 -0600

ankur,

ankur arora wrote:                              (Sun, 18 Jun 2006 23:54:09)
>    Whats your view on this.
I think that's what you should do.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: ankur arora <[email-masked]>
Date: Mon, 19 Jun 2006 06:05:02 -0700 (PDT)

Hi ,
   
  The conclusion for this query is :-
   
  For DASS 2, the value 00 (Out of Service) is invalid because the DASS 2 DLC does not have this state. "
   
                         SG                                  ASP
  (DASS) DLC status confirm  --------------------------->       
   ( With status value of any channell (for ex channel D1) as 00) 
   
  What will the ASP do ?
  The Solution is :- 
  ASP should Return Error (Only for that particular Channel) and the status for that particular channel remains unchanged ( status remains same as before).
  SG                                  ASP
  <---------------------------ERROR( Invalid DLC status = 00)
   
  Hence,  new error code should be added in DUA rfc which is 
   
  Invalid DLC status 0x1e
   
  The " Invalid DLC status" error would be sent by an ASP if an SG sends DLC status confirm/Indication message (For DASS) with status value as 00.
  For this error, the Diagnostic information MUST contain enough of the offending message to identify the channel information.
   
  Is this correct or not ?
  comments invited .
  Regards
  Ank Arora

ankur arora <[email-masked]> wrote:    Hi Brian,
   
  Whats your view on this.
   
  Regards
  Ank Arora

  Hi Brian,

  Regards
  Ank Arora

    
---------------------------------
  Sneak preview the all-new Yahoo.com. It's not radically different. Just radically better. _______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---------------------------------
Do you Yahoo!?
 Next-gen email? Have it all with the  all-new Yahoo! Mail Beta.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Jun 2006 07:09:32 -0600

ankur,

>    <---------------------------ERROR( Invalid DLC status = 00)

Why not just Error("Protocol Error")?  No changes necessary.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Mon, 19 Jun 2006 17:54:29 +0530

Hi ,

For DASS 2, the value 00 (Out of Service) is invalid because the DASS 2 
DLC does not have this state. "
 
                       SG                                  ASP
 
What will the ASP do ?

The Solution is  :- 

ASP should Return Error (Only for that particular Channel) and the status 
for that particular channel remains unchanged ( status remains same as 
before).

                SG                                  ASP
                <---------------------------ERROR( Invalid DLC status = 
00)

Invalid DLC status      0x1e

The " Invalid DLC status" error would be sent by an ASP if an SG sends DLC 
status confirm/Indication message (For DASS) with status value as 00.
For this error, the Diagnostic information MUST contain enough of the 
offending message to identify the channel information.

Is this correct or not ?
comments invited .

Regards
Ank Arora

"Brian F. G. Bidulock" <[email-masked]> 
06/19/2006 02:37 PM
Please respond to
[email-masked]

To
ankur arora <[email-masked]>
cc
ietf <[email-masked]>
Subject
Re: Fwd: Re: [Sigtran] What will be the handling for this scenarion 
(notmentioned in DUA RFC )

ankur,

ankur arora wrote:                              (Sun, 18 Jun 2006 
23:54:09)

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

***********************  FSS-Private   ***********************

---

From: [email-masked]
Date: Mon, 19 Jun 2006 18:16:34 +0530

Hi ,

 
                       SG                                  ASP
 
What will the ASP do ?

The Solution is  :- 

                SG                                  ASP

Invalid DLC status      0x1e

Is this correct or not ?
comments invited .

Regards
Ank Arora

To

ankur,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Mon, 19 Jun 2006 18:34:41 +0530

Hi ,

 
                       SG                                  ASP
 
What will the ASP do ?

The Solution is  :- 

                SG                                  ASP

Invalid DLC status      0x1e

Is this correct or not ?
comments invited .

Regards
Ank Arora

To

ankur,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

***********************  FSS-Restricted   ***********************

---

From: [email-masked]
Date: Mon, 19 Jun 2006 18:34:18 +0530

Hi ,

 
                       SG                                  ASP
 
What will the ASP do ?

The Solution is  :- 

                SG                                  ASP

Invalid DLC status      0x1e

Is this correct or not ?
comments invited .

Regards
Ank Arora

To

ankur,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Mon, 19 Jun 2006 20:50:44 +0530

Brain,

>> brain wrote : Why not just Error("Protocol Error")?  No changes 
necessary.

I appreciate your suggestion.

But if you are sending ("Protocol Error") message, it means that DLC 
status confirm/ Indication message (containing status for all DLCs)
 is completely discarded at ASP side because of wrong status of only one 
or some of the DLCs in the message.

In my view, we should discard only the Status information for that 
particular channel and send error message (only for that particular 
channel : 
See my previous mail) and use the others channels status information at 
ASP side ( Why to discard the others channels status information ? ).

Regards
Ank Arora

06/19/2006 06:39 PM
Please respond to
[email-masked]

To

ankur,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Tue, 20 Jun 2006 16:24:13 +0530

Hi Brian,
 
Whats your view on this.
 
Regards
Ank Arora

sigtran_maillist@HSS 
06/19/2006 08:50 PM

To
[email-masked]
cc
ietf <[email-masked]>
Subject

Brain, 

necessary. 

Regards 
Ank Arora 

06/19/2006 06:39 PM 
Please respond to
[email-masked]

To

ankur,

--brian
 
--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/