Subject: RE: [Sigtran] Asymetric multi-homing configuration

From: "Trentadue, Tim" <[email-masked]>
Date: Wed, 7 Jun 2006 14:49:58 -0500

Brian - another question below.

Thanks........T

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]] 
> Sent: Wednesday, June 07, 2006 2:32 PM
> To: Michael Tuexen
> Cc: Trentadue, Tim; [email-masked]
> Subject: Re: [Sigtran] Asymetric multi-homing configuration
> 
> Michael,
> 
> Michael Tuexen wrote:                      (Wed, 07 Jun 2006 21:11:03)
> > How?
> 
> Because GW 1.2 can be reachable when GW 1.1 is not.

Did you mean to say "GW 2.1 can be reachable when GW 1.1 is not" ?  

> 
> > Doesn't it depend on the source address selection performed 
> at  Host A?
> 
> No.
> 
> --brian
> 
> --
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 7 Jun 2006 22:13:22 +0200

Question in-line.

Best regards
Michael

> Did you mean to say "GW 2.1 can be reachable when GW 1.1 is not" ?
I think so... But how can host 1 know this. SCTP might know that the
route to 3.2 through 1.1 does not work and might use a different source
address. But this is implementation specific.
And I think the additional route will not help in general if the path  
between 1.1 and
3.1 is broken, but the path between 2.1 and 3.1 works. It might help  
if the SCTP
layer does the source address selection and changes the source  
address, but that
is nowhere specified.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Jun 2006 14:06:57 -0600

Tim,

Trentadue, Tim wrote:              (Wed, 07 Jun 2006 14:49:58)
> Did you mean to say "GW 2.1 can be reachable when GW 1.1 is not" ?  

Yes, sorry for the typo.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Jun 2006 14:36:50 -0600

Michael,

Michael Tuexen wrote:                                              (Wed, 07 Jun 2006 22:13:22)
> I think so... But how can host 1 know this.
Such things are supported by many routing protocols.  Things that
allow Host 1 to know this are:

- loss of carrier on the interface
- information from the router that this route is no longer available
- timeout contacting the router

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tuexen <[email-masked]>
Date: Wed, 7 Jun 2006 22:43:54 +0200

> Such things are supported by many routing protocols.  Things that
Yes, if it runs a routing protocol. But that was not assumed...
> - loss of carrier on the interface
I understand this.
> - information from the router that this route is no longer available
See above.
> - timeout contacting the router
 From the link layer. I understand this.

However, my point is, that is may help for some problems, but not in  
general.

Thanks for the clarification.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Jun 2006 15:08:47 -0600

Michael,

Michael Tuexen wrote:                        (Wed, 07 Jun 2006 22:43:54)
> However, my point is, that is may help for some problems, but not in  

And the question was "would this help acheive multi-homing" and it does.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/