Subject: Re: [Sigtran] SUA: CLDT: RC Parameter

From: "Ilie Glib" <[email-masked]>
Date: Thu, 1 Jun 2006 10:05:06 +0200

Hello Tolga,

my assumption was that each AS in the picture below is defined by its
destination address only, and there is no source address in the RK
definition. For instance, I have AS1=SSN1, AS2=SSN2 on one side, and
AS3=SSN3, AS4=SSN4 on the other side. This is possible according to
SUA RFC, and it shall work in single exchange mode (M3UA RFCbis does
not allow this configuration for SE mode, and mandates that RK defines
both source and destination addresses when SE is in use), unless we
explicitly prohibit this configuration in SUA implementers' guide,
that is, make source and destination addresses mandatory parts of SUA
RK definition in SE as M3UA does.

Thank you

Ilie

On 6/1/06, Tolga Asveren <[email-masked]> wrote:
> Ilie,
>
> I may be missing something, but if you use different RC for AS1/AS# and
> AS1/AS4 relationships, would there be any problem?
>
>    Thanks,
>    Tolga
>
> > -----Original Message-----
> > From: Ilie Glib [mailto:[email-masked]]
> > Sent: Wednesday, May 31, 2006 2:45 PM
> > To: [email-masked]; May, Howard; sigtran
> > Subject: Re: [Sigtran] SUA: CLDT: RC Parameter
> >
> >
> > Hello Brian, May,
> >
> > I think, in case of IPSP to IPSP model, there are two ASes (AS1 and
> > AS2), one at each side. For SE-IPSP implies activation of both ASes
> > via one ACTIVE message, the RC exchanged in the ACTIVE message shall
> > identify both ASes. Consequently RC1 = RC2. Since RC values are
> > allocated by SGPF, SGPF shall assign RC values consistently. Probably
> > the only feasible way to assign RCs is by provisioning for SE model.
> >
> > I have some doubts about the case when an IPSP serves multiple ASes
> > and SE-IPSP model is in use. Is this situation possible, can AS1 talk
> > to AS3 and AS4
> >
> > IPSP1 ----------------------------- IPSP2
> >
> > AS1 <---------------------------------> AS3
> >                             |
> > AS2                     --------------> AS4
> >
> >
> > How can AS4 go inactive, while AS3 be active in SE model?
> >
> > Thank you in advance
> >
> > Ilie
> >
> > On 5/31/06, Brian F. G. Bidulock <[email-masked]> wrote:
> > > Hi Howard,
> > >
> > > Please see comments below...
> > >
> > > May, Howard wrote:                            (Wed, 31 May 2006
> > 10:53:12)
> > > > Hi,
> > > >
> > > > The RC parameter is mandatory in CLDT messages.  Please can
> > you check my
> > > > understanding of how this parameter should be used in the three
> > > > following situations.
> > > >
> > > > When a CLDT is sent from an SGP to an ASP the value this parameter
> > > > should be set to is the RC of the AS the message is for.  The ASP may
> > > > use this parameter for local distribution of the message.
> > >
> > > Yes.
> > >
> > > >
> > > > When a CLDT is sent from an ASP to an SGP the value this parameter
> > > > should be set to is the RC of the AS the message is from.  The SGP may
> > > > use this parameter to determine the Network Context applicable to the
> > > > CLDT.
> > >
> > > Yes, and any other restrictions or permissions that might be associated
> > > with the AS at the SGP (such as calling party address).
> > >
> > > >
> > > > When a CLDT is sent from an IPSP to an IPSP the value this parameter
> > > > should be set to is the RC of the AS the message is for.  The IPSP may
> > > > use this parameter for local distribution of the message.
> > >
> > > For SE-IPSP, the AS the message is for and the AS the message
> > is from are
> > > the same.  For DE-IPSP, because messages are essentially sent
> > from the SGPF
> > > to the ASPF in the criss-cross model, the AS is the As that the
> > message is
> > > for just as in the SGP->ASP case above.
> > >
> > > --brian
> > >
> > > --
> > > Brian F. G. Bidulock
> > > [email-masked]
> > > http://www.openss7.org/
> > >
> > > _______________________________________________
> > > Sigtran mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/sigtran
> > >
> >
> >
> > --
> > Ilie
> >
> > _______________________________________________
> > Sigtran mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/sigtran
>
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
>

-- 
Ilie

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 1 Jun 2006 02:16:55 -0600

Ilie,

That's only because M3UA IPSP does not support relay.  SUA IPSP does.
I don't think that we want to rule out relay for SUA IPSP.

--brian

Ilie Glib wrote:                           (Thu, 01 Jun 2006 10:05:06)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Saurabh Jain" <[email-masked]>
Date: Thu, 1 Jun 2006 15:44:56 +0530

Hi all,
>From the figure what i understand is AS1 is communicating with both AS3 and
AS4

However, as per my understanding, in SE mode,
AS1 on IPSP1 can communicate with only *single AS* on each peer IPSP node.
So if want AS1 to communicate with AS3 and AS4, then
       AS3 needs to be on IPSP2 &
       AS4 neesd to be on IPSP3

                              _____ AS3   (IPSP2)
(IPSP1)  AS1  -------/
                             \_____ AS4  (IPSP3)

or we can have

 (IPSP1)  AS1  ------- AS3   (IPSP2)
 (IPSP1)  AS2  ------- AS4   (IPSP2)

Is this understanding correct?

rgds
Saurabh

On 6/1/06, Ilie Glib <[email-masked]> wrote:
> > > The RC parameter is mandatory in CLDT messages.  Please can you check
> my
> > For SE-IPSP, the AS the message is for and the AS the message is from
> are
> > the same.  For DE-IPSP, because messages are essentially sent from the
> SGPF
> > to the ASPF in the criss-cross model, the AS is the As that the message
> is

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 1 Jun 2006 04:32:17 -0600

Saurabh,

Your understanding might be correct per the recent mangling of M3UA,
however, it is not correct for SUA.

In SUA, an SE AS can communicate with any other AS (or SS7 node for
that matter) by its SCCP Called Party Address (esp. via a relay node).

--brian

Saurabh Jain wrote:                                (Thu, 01 Jun 2006 15:44:56)
> 
>    Hi all,
> 
>    From  the  figure  what i understand is AS1 is communicating with both
>    AS3 and AS4
> 
> 
> 
>    AS1  on  IPSP1  can  communicate with only single AS on each peer IPSP
>    node.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 2 Jun 2006 09:33:37 -0400

Hi Ilie,

Oh O.K., I see your point. Yes, the clarification added in M3UA-IG should be
there in SUA-IG as well. SE-IPSP model is a peer-to-peer signaling
relationship where the peers are the IPSP on each side, hence it should be
identified by declaring the traffic range used for this relationship for
both AS.

    Thanks,
     Tolga

> Sent: Thursday, June 01, 2006 4:05 AM
> To: Tolga Asveren
> Cc: sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 2 Jun 2006 08:36:40 -0600

Tolga,

There is absolutely no reason to do so.

--brian

Tolga Asveren wrote:                                                 (Fri, 02 Jun 2006 09:33:37)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Tolga Asveren" <[email-masked]>
Date: Fri, 2 Jun 2006 11:22:15 -0400

Hi Saurabh,

One IPSP can host more than one AS, hence there is no such limitation.

    Thanks,
    Tolga
-----Original Message-----
From: Saurabh Jain [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 6:15 AM
To: [email-masked]
Subject: Re: [Sigtran] SUA: CLDT: RC Parameter

Hi all,
AS4

However, as per my understanding, in SE mode,
AS1 on IPSP1 can communicate with only single AS on each peer IPSP node.
So if want AS1 to communicate with AS3 and AS4, then
       AS3 needs to be on IPSP2 &
       AS4 neesd to be on IPSP3

                              _____ AS3   (IPSP2)
(IPSP1)  AS1  -------/
                             \_____ AS4  (IPSP3)

or we can have

rgds
Saurabh

Thank you in advance

Ilie

On 5/31/06, Brian F. G. Bidulock <[email-masked]> wrote:
> May, Howard wrote:                            (Wed, 31 May 2006 10:53:12)
> > Hi,
> >
> > The RC parameter is mandatory in CLDT messages.  Please can you check my
> For SE-IPSP, the AS the message is for and the AS the message is from are
SGPF
> to the ASPF in the criss-cross model, the AS is the As that the message is

--
Ilie