Subject: [Sigtran] M2PA: BSN processing when FSN out of order

From: "Davidson, Mark" <[email-masked]>
Date: Thu, 22 Jun 2006 09:03:02 -0500

"If M2PA receives a User Data message with an FSN that is out of order,
M2PA SHALL discard the message."
 
Should the BSN be processed when this occurs, as it would if it were a
retransmitted MSU in SS7?
 
Why does the above requirement exist if M2PA does not retransmit?
 
"Note that since SCTP provides reliable delivery and ordered delivery
within the stream, M2PA does not perform retransmissions."

-Mark Davidson

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Jun 2006 14:18:00 -0600

Mark,

Davidson, Mark wrote:                         (Thu, 22 Jun 2006 09:03:02)
>    Why does the above requirement exist if M2PA does not retransmit?

See "M2PA Last Call Comment - FSN" from July 14, 2003 (copied below):

| From [email-masked]  Mon Jul 14 04:05:05 2003
| From: "Brian F. G. Bidulock" <[email-masked]>
| Organization: http://www.openss7.org/
| To: "[email-masked]'" <[email-masked]>
| Date: Mon, 14 Jul 2003 04:04:30 -0600
| Subject: [Sigtran] M2PA Last Call Comment - FSN
| 
| M2PA-09 says:
| 
|   If M2PA receives a User Data message with an FSN that is out of order,
|   M2PA SHALL place the link out of service (see section 4.1.6 Link Out
|   of Service).
| 
| This conflicts with Q.703 that ignores an MSU that contains an FSN that
| is other than the next expected FSN (i.e, out of order).  This makes it
| difficult to implement (and is probably the last thing standing in the
| way of implementing) something like the following (that was requested by
| ITU):
| 
|                            _________________
|                           |                 |
|                           |       IWF       |
|                           |_________________|
|                           |        |        |
|                           |  MTP2  |  M2PA  |
|                           |________|________|
|                                |       |
|                            ____|       |___
| 
| If M2PA discards the message as Q.703 does, and the other end of the
| link was actually broken, the link will be go out of service in due
| course anyway.
| 
| Change to:
| 
|   If M2PA receives a User Data message with an FSN that is out of order,
|   M2PA SHALL discard the message.
| 
| --brian
| 
| -- 
| Brian F. G. Bidulock
| [email-masked]
| http://www.openss7.org/
| 
| _______________________________________________
| Sigtran mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/