Subject: RE: [Sigtran] M2PA: BSN processing when FSN out of order

From: "Newman, Catherine J" <[email-masked]>
Date: Thu, 22 Jun 2006 17:35:40 -0400

For MTP2, per ANSI, the BSN would still be processed in the case of a
received MSU with an invalid FSN [see T1.111.3, Section 6.2.2, or SDL
Figure 14/Sheet 2&3] even though the message is discarded.  

Can you confirm if this is the intended behavior for M2PA? I didn't see
where this specifically addressed in the M2PA RFC; if it is, please let
me know where.

Thanks,
Cathy Newman

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thursday, June 22, 2006 4:18 PM
To: Davidson, Mark
Cc: Kanode, Mark; [email-masked]
Subject: Re: [Sigtran] M2PA: BSN processing when FSN out of order

Mark,

Davidson, Mark wrote:                         (Thu, 22 Jun 2006
09:03:02)
> 
>    Why does the above requirement exist if M2PA does not retransmit?
> 

See "M2PA Last Call Comment - FSN" from July 14, 2003 (copied below):

| From [email-masked]  Mon Jul 14 04:05:05 2003
| From: "Brian F. G. Bidulock" <[email-masked]>
| Organization: http://www.openss7.org/
| To: "[email-masked]'" <[email-masked]>
| Date: Mon, 14 Jul 2003 04:04:30 -0600
| Subject: [Sigtran] M2PA Last Call Comment - FSN
| 
| M2PA-09 says:
| 
|   If M2PA receives a User Data message with an FSN that is out of
order,
|   M2PA SHALL place the link out of service (see section 4.1.6 Link Out
|   of Service).
| 
| This conflicts with Q.703 that ignores an MSU that contains an FSN
that
| is other than the next expected FSN (i.e, out of order).  This makes
it
| difficult to implement (and is probably the last thing standing in the
| way of implementing) something like the following (that was requested
by
| ITU):
| 
|                            _________________
|                           |                 |
|                           |       IWF       |
|                           |_________________|
|                           |        |        |
|                           |  MTP2  |  M2PA  |
|                           |________|________|
|                                |       |
|                            ____|       |___
| 
| If M2PA discards the message as Q.703 does, and the other end of the
| link was actually broken, the link will be go out of service in due
| course anyway.
| 
| Change to:
| 
|   If M2PA receives a User Data message with an FSN that is out of
order,
|   M2PA SHALL discard the message.
| 
| --brian
| 
| -- 
| Brian F. G. Bidulock
| [email-masked]
| http://www.openss7.org/
| 
| _______________________________________________
| Sigtran mailing list
| [email-masked]
| https://www1.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 22 Jun 2006 17:32:46 -0600

Newman,,

Newman, Catherine J wrote:                   (Thu, 22 Jun 2006 17:35:40)
> where this specifically addressed in the M2PA RFC; if it is, please let

"  Except as modified in this document, M2PA SHOULD follow the
"  requirements of the applicable MTP2 specification.  These may include
"  [Q.703] or [T1.111].  The same standard MUST be followed on both ends
"  of the M2PA link.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/