Subject: [Sigtran] M3UA optional RC parameter.

From: "Ambika Prasad" <[email-masked]>
Date: Tue, 13 Jun 2006 20:10:58 +0530

Hi

    As per the RFC3332, RC is an optional parameter.

1. Since RC  is optional parameter, can I send REG REQ message with some RK and expect corresponding RC in REG RSP message for that RK with successfully registered status?

2. If in the above case I have received RC for that RK, then should I encode optional RC parameter in M3UA payload data message?

FYI. I have configured RC as an optional parameter.

BR
Ambika Prasad

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Santiago Muñoz (E2/EEM)<[email-masked]>
Date: Tue, 13 Jun 2006 16:54:16 +0200

Hi Ambika,
Comments on line.
BR, Santi.

________________________________

From: Ambika Prasad [mailto:[email-masked]] 
Sent: martes, 13 de junio de 2006 16:41
To: [email-masked]
Cc: [email-masked]
Subject: [Sigtran] M3UA optional RC parameter.

Hi
 
    As per the RFC3332, RC is an optional parameter.
[ecesmmu] There is a new revision RFC 3332bis 
 
1. Since RC  is optional parameter, can I send REG REQ message with some RK and expect corresponding RC in REG RSP message for that RK with successfully registered status?
[ecesmmu] Yes, if the RK is dynamically configured through RKM, then it is as you describe d
 
2. If in the above case I have received RC for that RK, then should I encode optional RC parameter in M3UA payload data message?
[ecesmmu] Strictly speaking and following the RFC it is up to you to encode the the RC in the DATA msg. The RFC requires that the RC must be sent when the RC is coordinated between the signalling processes and the same association is used to transport msg. from different RCs. 
In your case the RC is coordinated but there is only one, so both to encode it or not encode it are right cases.
When the RKM defines several RK-RC pairs, then the DATA referred to each RC must include the corresponding RC.

BR
Ambika Prasad