Subject: [Sigtran] ASP vs IPSP

From: "Philippe Huvet I \(MA/ESF\)" <[email-masked]>
Date: Mon, 19 Mar 2007 18:05:14 +0100

Hello Sigtran forum,

In RFC3332, it exists the following diagram:

******************************************************************
1.5.3 Example 3: SGP Resident SCCP Layer, with Remote ASP

      ********   SS7   *****************   IP   ********
      * SEP  *---------*               *--------*      *
      *  or  *         *      SGP      *        * ASP  *
      * STP  *         *               *        *      *
      ********         *****************        ********

      +------+         +---------------+        +------+
      | SCCP-|         |     SCCP      |        | SCCP-|
      | User |         +---------------+        | User |
      +------+           |   _____   |          +------+
      | SCCP |           |  |     |  |          | SCCP |
      +------+         +------+-+------+        +------+
      | MTP3 |         | MTP3 | | M3UA |        | M3UA |
      +------|         +------+ +------+        +------+
      | MTP2 |         | MTP2 | | SCTP |        | SCTP |
      +------+         +------+ +------+        +------+
      |  L1  |         |  L1  | |  IP  |        |  IP  |
      +------+         +------+ +------+        +------+
          |_______________|         |______________|

*******************************************************************

Does it make any sense to put it this way ?

      ********   SS7   *****************   IP   ********
      * SEP  *---------*        *      *--------*      *
      *  or  *         *   SEP  * IPSP *        * IPSP *
      * STP  *         *        *      *        *      *
      ********         *****************        ********

      +------+         +---------------+        +------+
      | SCCP-|         |     SCCP      |        | SCCP-|
      | User |         +---------------+        | User |
      +------+           |   _____   |          +------+
      | SCCP |           |  |     |  |          | SCCP |
      +------+         +------+-+------+        +------+
      | MTP3 |         | MTP3 | | M3UA |        | M3UA |
      +------|         +------+ +------+        +------+
      | MTP2 |         | MTP2 | | SCTP |        | SCTP |
      +------+         +------+ +------+        +------+
      |  L1  |         |  L1  | |  IP  |        |  IP  |
      +------+         +------+ +------+        +------+
          |_______________|         |______________|

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 19 Mar 2007 12:13:34 -0500

Philippe,

I don't know whether it would make sense but I guess it is a possibility.
The only change I would suggest in your diagram would be an interworking
application on top of SEP and IPSP to bridge the two sides. Basically, this
would be "proxying" SS7 nodes in IP domain and vice versa. One could think
that in the first diagram the interworking happens on signalling layer
whereas for the second one it is more on application layer.

    Thanks,
    Tolga

> -----Original Message-----
> From: Philippe Huvet I (MA/ESF) [mailto:[email-masked]]
> Sent: Monday, March 19, 2007 12:05 PM
> To: [email-masked]
> Subject: [Sigtran] ASP vs IPSP
>
>
> Hello Sigtran forum,
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Mar 2007 11:53:32 -0600

Philippe,

Philippe Huvet I (MA/ESF) wrote:                                 (Mon, 19 Mar 2007 18:05:14)
> In RFC3332, it exists the following diagram:

RFC 3332 is obsolete.

No it does not: under M3UA, IPSP is point to point only and an IPSP does not
connect with an SS7 network, so the entire left side of the diagram is
incorrect.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/