Subject: [Sigtran] DPC in REG REQ

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 7 Mar 2007 17:22:45 +0530

Hi Brain,

       I have one doubt regarding the DPC parameter in the REG REQ message.
As per RFC-3332

Destination Point Code:

      The Destination Point Code parameter is mandatory, and identifies
      the Destination Point Code of incoming SS7 traffic for which the
      ASP is registering.  The format is the same as described for the
      Affected Destination parameter in the DUNA message (See Section
      3.4.1).  Its format is:

Should i think the DPC mean the OPC of the ASP end if the scenario is like
below.

ASP                               SG
-----------------------------------------
---------------REG REQ------------>
OPC = 2.2.2           OPC = 1.1.1
DPC = 1.1.1            DPC = 2.2.2

Then what will be the DPC value of the REG REQ message from ASP?
-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Mar 2007 05:42:27 -0700

Ambika,

In this case, DPC is used as viewed from the SG.  That is, the DPC is the
point code in the DPC portion of the MTP Routing Label in messages that the
SG will send to the ASP.  Therefore, the DPC is the point code belonging to
the ASP.

(Most things in these RFCs, such as ASP state, is as viewed from the SG).

--brian

Ambika Tripathy wrote:                          (Wed, 07 Mar 2007 17:22:45)
>    Should  i think the DPC mean the OPC of the ASP end if the scenario is
>    like below.
> 
> 
> 
>    ASP                               SG
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: [email-masked]
Date: Wed, 7 Mar 2007 18:23:56 +0530

Hi Ambika,

As per my knowledge, REG REQ is used to share Routing Information (in RK 
parameter) to Remote User. It is just like as the Capabilites Exchages b/w 
Local and Remote user (useful to take Routing decisions). So, when you 
send REG REQ to Remote user, you should set  your own PC (Local PC or 
OPC(in your terms)) in DPC parameter of Routing Key.

In your Call flow, PC of ASP will be DPC for REG REQ (ASP->SG).

--- Dheeraj

"Ambika Tripathy" <[email-masked]> 
03/07/2007 05:22 PM

To
sigtran <[email-masked]>, bidulock <[email-masked]>
cc

Subject
[Sigtran] DPC in REG REQ

Hi Brain,
 
       I have one doubt regarding the DPC parameter in the REG REQ 
message. 
As per RFC-3332 
 
Destination Point Code:

 
ASP                               SG
 
Then what will be the DPC value of the REG REQ message from ASP?
-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730 _______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran