Subject: [Sigtran] GT Routing with NULL(H'0000) PC

From: 권도형 <[email-masked]>
Date: Mon, 5 Mar 2007 21:06:28 +0900

Dear, Sir
When the following message came to SG, SG can route this message?

Sending CLDT Message from ASP to SG (SUA Layer)
Destination Address is composed of these parameters.
---
Destination Address
	+Route Indicator : Route on Global Title (1)
	+Address Indicator
		- Include GT : True
		- Include PC : False
		- Include SSN : True
	+Global Title
		- ???????????? (Some Value) (skip detail)
	+Subsystem number
		- ? (Some Value) (skip detail)
	+Point code
		- Parameter Tag: Point Code (0x8002)
		- Parameter Length: 8
		- Point code: 0 (0x00 00 00 00) <- the focus is this

The GT and SSN value is correct.
---

I know that the PC value cannot be 0.
But with our test results, in some cases, SG can route these messages (with 0 PC included) to the right Destination.
Is these
Is that message perfectly wrong?

Ps: Thank you very much Brian F. G. Bidulock.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Mar 2007 05:14:24 -0700

±ÇµµÇü,

±ÇµµÇü wrote:                                                                       (Mon, 05 Mar 2007 21:06:28)
> 	+Route Indicator : Route on Global Title (1)

It does not really matter what the PC is, with (Include PC : False) it will
not be included in the resulting SCCP message.  The SG is welcome to route the
message on global title.

It would be better form to not include the PC parameter in the message, but
the SG can be forgiving if it wants.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: 권도형 <[email-masked]>
Date: Mon, 5 Mar 2007 21:40:49 +0900

Thanks again.
I confused with "RFC 3868 / 3.10.2.2.  Address Indicator".
" For example, the PC
   parameter is present in the destination address of the CLDT sent from
   ASP->SG, but bit 2 is set to "0" meaning "do not populate this in the
   SCCP called party address".  The effect is that the SG only uses the
   PC to populate the MTP routing label DPC field, but does not include
   it in the SCCP called party address."

According to this example, wrong PC value can cause wrong MTP routing.
But I thought that SG may discard this PC value when SG cannot find right route. Am I right?

Addition to last question, the SG engineer told me that some error messages logged on SG when that message (0 PC valued) came (but I have not received the exact error message)

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, March 05, 2007 9:14 PM
To: 권도형
Cc: [email-masked]
Subject: Re: [Sigtran] GT Routing with NULL(H'0000) PC

±ÇµµÇü,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 5 Mar 2007 08:10:46 -0700

???,

??? wrote:                                                                             (Mon, 05 Mar 2007 21:40:49)
> According to this example, wrong PC value can cause wrong MTP routing.

That assumes that the SG itself does not perform GT.

> But I thought that SG may discard this PC value when SG cannot find right route. Am I right?

As I said, the SG is welcome to perform routing based on GT and come up with a
new PC.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/