Subject: [Sigtran] Couple of question regarding M2PA

From: Dario <[email-masked]>
Date: Mon, 2 Jul 2007 06:57:38 -0700 (PDT)

Hi,

I have a couple of questions regarding M2PA - precisely for section 4.1.7.
"SCTP Association Problems":
how M2PA shall act on the following cases:

- reception of Restart primitive from SCTP
- reception of Network Status Change primitive from SCTP

Should M2PA consider Link to be in  Out of Service state when those events
happen?

Another question related to SCTP used for M2PA links: how the SCTP Shutdown
fits into M2PA?

thanks!
Best regards, Dario
-- 
View this message in context: http://www.nabble.com/Couple-of-question-regarding-M2PA-tf4012360.html#a11394386
Sent from the IETF - Sigtran mailing list archive at Nabble.com.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 10 Jul 2007 05:53:08 -0600

Dario,

Dario wrote:                                                         (Mon, 02 Jul 2007 06:57:38)
> - reception of Restart primitive from SCTP

Implementation dependent.

> - reception of Network Status Change primitive from SCTP

Implementation dependent.

> Should M2PA consider Link to be in  Out of Service state when those events

Implementation dependent.

> Another question related to SCTP used for M2PA links: how the SCTP Shutdown

Same way it fits into any orderly shutdown of an association: to ensure that
all sent data reaches the other side before removing the association.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/