Subject: [Sigtran] Ali again " Brain please check this for M2PA

From: ali ovaisi <[email-masked]>
Date: Tue, 10 Jul 2007 08:37:39 -0700 (PDT)

What you need to do is to take the message format for a typical ISUP
call flow
IAM, ACM, ANM/CPG, REL, and RLC message and count up the number of
bytes for
each and then add in the overhead of the M3UA DATA message

  M2PA
> > 
> > M2PA does not carry FSN/BSN from the SS7 message, but adds its own
in the
> > User Data message whose format is given in section 2.3.1 of RFC
4165.

  Dear Brain
   
  i am sending you this with the header from m2pa added in it please check the values 

  "If we take average message length as 40 octet for an ISUP message than 
  After reaching the SG (signalling gateway), SIGTRAN’S M2PA encapsulated the SS7 message data and attached headers in it.

  The headers are of 2 type’s “Common message header” and “M2PA header”.
  The common message header is of 8 bytes and M2PA header is also of 8 bytes. 
   
  The User data or SS7 ‘Message data’ is the data from MTP3. so it don’t contains ‘flag 1 byte’, ‘BSN and BIB 1 byte’, ‘FSN and FIF 1 byte’, ‘Length indicator 1 byte’, and ‘ check sum 2 bytes’. Which all together make 6 bytes. After subtracting 6 bytes from average message length of 40 bytes we get 34 bytes.
   
  So SS7oIP for M2PA generates 34+16 bytes = 50 bytes of data per ISUP message.
  As there are 5 messages in typical ISUP call so 50 * 5= 250 bytes of SS7oIP data is generated per ISUP call."
   
  KR
   
  ali  

---------------------------------
Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on us.

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 10 Jul 2007 10:47:07 -0600

ali,

>    After reaching the SG (signalling gateway), SIGTRANS M2PA encapsulated
>    the SS7 message data and attached headers in it.
> 
>    The headers are of 2 types Common message header and M2PA header.

You are missing the DATA chunk header, SCTP packet header, IP packet header
and possibly Ethernet or IEEE 802.something header.

--brian

>    The  User  data  or SS7 Message data is the data from MTP3. so it dont
>    contains  flag  1 byte, BSN and BIB 1 byte, FSN and FIF 1 byte, Length
>    indicator  1  byte,  and  check sum 2 bytes. Which all together make 6
>    bytes.  After  subtracting  6  bytes from average message length of 40
>    bytes we get 34 bytes.
> 
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/