Subject: [Sigtran] Understanding of routing key and routing contexts in M3UA and SUA.

From: "Mohammad Arif" <[email-masked]>
Date: Tue, 10 Jul 2007 16:39:43 +0530

Hi,

I have some doubt regarding M3UA.
I think Routing key and routing context are optional parameters in M3UA
messages, because there will be only one SCCP layer above M3UA,
compaared to SUA where there can be many layers above ( like
TCAP,RANAP,RNSAP,IOS) so routing key and
routing contexts are mandatory.
I think RANAP layer will be assigned as one ASP and TCAP as another and one
ASP for RNSAP and so on,

But in M3UA how can there be more than one ASPs.? so i think routing context
is optional.

IS my understanding correct?

-- 
Regards
Mohammad Arif
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 10 Jul 2007 05:46:59 -0600

Mohammad,

The reason RC is conditional in M3UA and mandatory in SUA was due to
consensus rather than this fan-out rationale.

--brian

Mohammad Arif wrote:                                              (Tue, 10 Jul 2007 16:39:43)
>    I  think  Routing  key  and routing context are optional parameters in
>    M3UA messages, because there will be only one SCCP layer above M3UA,
>    I  think  RANAP  layer will be assigned as one ASP and TCAP as another
>    and one ASP for RNSAP and so on,
> 
> 
> 
>    But  in  M3UA how can there be more than one ASPs.? so i think routing
>    context is optional.
> 

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Haresign Lincoln" <[email-masked]>
Date: Tue, 10 Jul 2007 09:06:37 -0400

Mohammad,
 
Above M3UA, you could have ISUP, TUP/IUP, or SCCP.  You could have a
Routing key for specific OPCs.  You could have Routing Keys indicating a
specific DPC.
 
Regards,
Lincoln

________________________________

From: Mohammad Arif [mailto:[email-masked]] 
Sent: Tuesday, July 10, 2007 7:10 AM
To: [email-masked]; [email-masked]
Subject: [Sigtran] Understanding of routing key and routing contexts in
M3UAand SUA.

Hi,

I think Routing key and routing context are optional parameters in M3UA
messages, because there will be only one SCCP layer above M3UA,
compaared to SUA where there can be many layers above ( like
TCAP,RANAP,RNSAP,IOS) so routing key and 
routing contexts are mandatory.
I think RANAP layer will be assigned as one ASP and TCAP as another and
one ASP for RNSAP and so on,