Subject: [Sigtran] m3ua querry..

From: Devayya BOPAIAH <[email-masked]>
Date: Wed, 07 Nov 2007 05:41:04 -0500

Hi,

We are testing the m3ua Implementation at the ASP side.(i.e MGC)
Other side is the testing equipment.(Consider this as a AS)
Also there is only one ASP in that AS. Traffic mode is loadshare.

1) Suppose ASP is in DOWN state and If I send Notify with AS-INACTIVE 
from test equipment, what should be the state of ASP ?

2) Suppose ASP is in DOWN state and if I send Notify with AS-ACTIVE from 
test equipment, what should be the state of the ASP ?

3) Suppose ASP has recieved ASP-UP-ACK message and if I send a Notify 
with AS-ACTIVE message from test equipment what should be the state of ASP ?

Please clarify these ASAP...

Thanks and Best regards,
devayya

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: Devayya BOPAIAH <[email-masked]>
Date: Wed, 07 Nov 2007 06:52:52 -0500

Mahantesh,

Please see inline comments.

regards,
devayya

Mahantesh wrote:

> *Devayya,*
> ** 
>
>     Find my comments inline
>     If it requires (comments) further more information...guys pls
>     append to it.
>     Thanks!
>
> *Rgds,
> Mahantesh *
>  
> On 11/7/07, *Devayya BOPAIAH* <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     >>NTFY will be sent to all the ACTIVE ASPs in an AS. In your case, 
> it is the only one ASP in an  AS so state shouldn't be distrubed (It 
> 'll be droped). Since it is the last ASP which was active and  
>         moved to DOWN state, after AS-Pending timer expiry, AS will 
> automatically goes to DOWN  
>         state.

ASP is in DOWN state. It was never in ACTIVE state.

>    >>As ASP is in down state this msg will not be sent to it. No 
> change in the state.

Since the AS is simulated by using the testing equipment. We can send 
any message. What should be the behaviour of ASP regarding the state ?

>    >> As ASP is in INACTIVE state this msg will not be sen to it.No 
> change in the state.

Since the AS is simulated by using the testing equipment. We can send 
any message. What should be the behaviour of ASP regarding the state ?

>     [email-masked] <mailto:[email-masked]>
> -- 
> Rgds,
> Mahantesh | [email-masked] <mailto:[email-masked]> | 
> Call: 9945363151, 9980941127 |
> "Silence is a source of great strength"

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 7 Nov 2007 05:38:47 -0700

Devayya,

Devayya BOPAIAH wrote:                         (Wed, 07 Nov 2007 05:41:04)
> from test equipment, what should be the state of ASP ?

RFC 4666 4.3.1 ...

   ASP-DOWN: The remote M3UA peer at the ASP/IPSP is unavailable, and/or
   the related SCTP association is down.  Initially, all ASPs/IPSPs will
   be in this state.  An ASP/IPSP in this state SHOULD NOT be sent any
   M3UA messages, with the exception of Heartbeat, ASP Down Ack, and
   Error messages.

The ASP should stay in the ASP-DOWN state and send ERR(Unexpected Message).

> test equipment, what should be the state of the ASP ?

The ASP should stay in the ASP-DOWN state and send ERR(Unexpected Message).

> with AS-ACTIVE message from test equipment what should be the state of ASP ?

RFC 4666 4.3.1 ...

   ASP-INACTIVE: The remote M3UA peer at the ASP/IPSP is available (and
   the related SCTP association is up), but application traffic is
   stopped.  In this state, the ASP/IPSP SHOULD NOT be sent any DATA or
   SSNM messages for the AS for which the ASP/IPSP is inactive.

The ASP should stay in the ASP-INACTIVE state for the AS: the peer has
gone insane (it is sending AS-ACTIVE when no ASP is active for the AS),
so informing local management might be an idea.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Mahantesh <[email-masked]>
Date: Wed, 7 Nov 2007 16:18:20 +0530

*Devayya,*
**

Find my comments inline
If it requires (comments) further more information...guys pls append to it.
Thanks!

*Rgds,
Mahantesh *

    >>NTFY will be sent to all the ACTIVE ASPs in an AS. In your case,
it is the only one ASP in an  AS so state shouldn't be distrubed (It 'll be
droped). Since it is the last ASP which was active and
        moved to DOWN state, after AS-Pending timer expiry, AS will
automatically goes to DOWN
        state.

   >>As ASP is in down state this msg will not be sent to it. No change in
the state.

   >> As ASP is in INACTIVE state this msg will not be sen to it.No change
in the state.

-- 
Rgds,
Mahantesh | [email-masked] | Call: 9945363151, 9980941127 |
"Silence is a source of great strength"
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran