Subject: Re: Re: [Sigtran] M2PA: resynchronization of sequence numbers after PO

From: "chenxu" <[email-masked]>
Date: Mon, 19 Nov 2007 17:47:30 +0800

Hi Brian F. G. Bidulock,

	There is another possibility,the communication between SCTP and M2PA is lost in the endpoint which sending the first Ready message.This endpoint was once in RPO state and now in Ready message sending state. The second Ready message will not reach its M2PA  ,and its M2PA can not receive COMMUNICATIONS LOST indication either.
    According to RFC4165,' M2PA SHALL NOT resume  transmitting User Data messages until it has sent the Link Status  Ready message.' ,the peer M2PA (the one sending the second Ready message ) resumes transmitting User Data messages,and also these messages will not reach local M2PA(the one sending the first Ready message). The T7 of the peer M2PA will expire, and the link will be out of sevice.
    The local M2PA (the one sending the first Ready message) also resumes  transmitting User Data messages because it has sent the  Ready message,and when it starts, it will know the failure between SCTP and itself. 

    The sending of the first Ready message indicates the local M2PA had received the PO recover message;and the sending of the second  Ready message indicates the peer M2PA had received the Ready message.Both of them have the required information.

    So,the timer waiting for the second Ready message is needn't.

    Hope that's right.

Yours sincerely
Chen Xu
[email-masked]

>Devayya,
>
>Devayya BOPAIAH wrote:           (Thu, 15 Nov 2007 23:38:56)
>> 
>>    Brian,
>>    Just curious,
>>    What  happens suppose the second link status ready message sent by the
>>    peer  is  not  recieved  by  the  host, may be bacause of some network
>>    reasons ? I think this part is missing in rfc 4165.
>
>SCTP is a reliable transport protocol: the message will
>arrive or the association will fail.  In the later case,
>RFC 4165 provides the procedures in the event that a
>COMMUNICATIONS LOST indication is received by M2PA.
>
>--brian
>
>
>-- 
>Brian F. G. Bidulock
>[email-masked]
>http://www.openss7.org/
>
>
>_______________________________________________
>Sigtran mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/sigtran

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Nov 2007 05:37:02 -0700

chenxu,

chenxu wrote:                                    (Mon, 19 Nov 2007 17:47:30)
> Hi Brian F. G. Bidulock,
> 
> 	There is another possibility,the communication between SCTP and M2PA
> 	is lost in the endpoint which sending the first Ready message.This
> 	endpoint was once in RPO state and now in Ready message sending state.
> 	The second Ready message will not reach its M2PA  ,and its M2PA can
> 	not receive COMMUNICATIONS LOST indication either.

Nor will it receive any other message.  The implementation is seriously broken
and the link will fail.  Hopefully traffic at MTP Level 3 will reroute through
some better implementation after the link fails.

If the implementation breaks, it will break the protocol.

The rest was moot considering this premise.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/