Subject: Re: Re: [Sigtran] M2PA: resynchronization of sequence numbers after PO

From: "chenxu" <[email-masked]>
Date: Tue, 20 Nov 2007 10:09:55 +0800

Brian F. G. Bidulock,

>chenxu,
>
>chenxu wrote:                                    (Mon, 19 Nov 2007 17:47:30)
>> Hi Brian F. G. Bidulock,
>> 
>> 	There is another possibility,the communication between SCTP and M2PA
>> 	is lost in the endpoint which sending the first Ready message.This
>> 	endpoint was once in RPO state and now in Ready message sending state.
>> 	The second Ready message will not reach its M2PA  ,and its M2PA can
>> 	not receive COMMUNICATIONS LOST indication either.
>
>Nor will it receive any other message.  The implementation is seriously broken
>and the link will fail.  Hopefully traffic at MTP Level 3 will reroute through
>some better implementation after the link fails.
>
>If the implementation breaks, it will break the protocol.

>The rest was moot considering this premise.
>
>--brian

Thank you!

I agree with your analyse. In this situation,the MTP3 can reroute through  some better implementation after the link fails.
But the peer M2PA still need to find the link fails,which should not be ignored. Because there are two directions. So the rest as folloes was still useful considering this premise.

>>According to RFC4165,' M2PA SHALL NOT resume  transmitting User Data messages until it has sent the Link Status  Ready >>message.' ,the peer M2PA (the one sending the second Ready message ) resumes transmitting User Data messages,and also these messages will not reach local M2PA(the one sending the first Ready message). The T7 of the peer M2PA will expire, and the link will be out of sevice.
    
>>The local M2PA (the one sending the first Ready message) also resumes  transmitting User Data messages because it has sent
> >the  Ready message,and when it starts, it will know the failure between SCTP and itself. 

>>    The sending of the first Ready message indicates the local M2PA had received the PO recover message;and the sending of
> >the second  Ready message indicates the peer M2PA had received the Ready message.Both of them have the required >>information.

Yours sincerely
Chen Xu
[email-masked]

>-- 
>Brian F. G. Bidulock
>[email-masked]
>http://www.openss7.org/

2007-11-20

_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 19 Nov 2007 21:13:54 -0700

chenxu,

Your analysis still follows from the premise that one implementation
is broken.  It could break one or more messages earlier or one or
more message later, it makes no never mind, the link will always
continue to be blocked or fail at the "correct" implementation.

If both implementations are as poor, lack of communication will result:
but this is not suprising and is rather trivial.  It is equivalent to
saying that "broken things are broken".

--brian

chenxu wrote:                                                       (Tue, 20 Nov 2007 10:09:55)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/