Subject: RE: [Sigtran] M2PA: resynchronization of sequence numbers after P O

From: Arne van Wilgen <[email-masked]>
Date: Fri, 16 Nov 2007 13:29:47 +0100

Hello Brian,

I don't agree. SCTP may have many timers but there is just one type (rfc
4960
6.3: retransmission timer T3-rtx) for data retransmission.  So for a single
homed enpoint I expect there is just one timer for retransmission.

The timer's duration depends on the IP network -- even if you specifiy the
initial, max. and min. values for the timer.

>From the number of allowed retransmissions and the RTO.Max you can derive
the
maximum time it will take to detect COMMUNICATIONS LOST.

So either you change SCTP's parameters to achive a specific timer behaviour
with
the impact that this affects the entire association or you have to introduce
another timer (as Xiangsong mentioned).

Regards,
Arne

-- 
Arne van Wilgen
NGN Protocols
Teles AG Communication Systems
Ernst-Reuter-Platz 8
D-10587 Berlin
GERMANY

> -----Original Message-----
> From: Brian F. G. Bidulock [mailto:[email-masked]]
> Sent: Friday, November 16, 2007 11:51 AM
> To: Xiangsong Cui
> Cc: [email-masked]
> Subject: Re: [Sigtran] M2PA: resynchronization of sequence 
> numbers after
> PO
> 
> 
> Xiangsong,
> 
> Xiangsong Cui wrote:                           (Fri, 16 Nov 
> 2007 18:06:54)
> > 
> >    I  think  SCTP can ensure the messages be transferred 
> without loss and
> >    wrong  sequence( if required, in stream ), but SCTP CAN 
> NOT ensure the
> >    messages be transferred in the time as ULP wished, which 
> depend on the
> >    IP network.
> > 
> > 
> > 
> >    So,  if  the  ULP  want to do something related to the 
> time, it need a
> >    timer.
> > 
> 
> SCTP has many timers for this purpose.
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/
> 
> 
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/sigtran
> 
_______________________________________________
Sigtran mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 16 Nov 2007 10:10:34 -0700

Arne,

The RFC does not preclude you from using a local timer
for any local reason, so the point is moot.

--brian

Arne van Wilgen wrote:                                               (Fri, 16 Nov 2007 13:29:47)
> 
>    Hello Brian,
> 
>    I  don't  agree.  SCTP may have many timers but there is just one type
>    (rfc 4960
>    From  the  number  of  allowed retransmissions and the RTO.Max you can
>    derive the
>    So  either  you  change  SCTP's  parameters to achive a specific timer
>    behaviour with

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/