Subject: [Sigtran] Doubt regarding ASPID in ASP UP message

From: Padmalochan Moharana <[email-masked]>
Date: Thu, 13 Mar 2008 00:08:39 -0700 (PDT)

Hi All,

As per the discussion the ASPID is mandatory that the
SG provide the ASP-ID in the ASP Failure notification
when it is locally configured or was provided by the
ASP in the ASP-UP.

But as per the rfc-4666
   
1- The "ASP Identifier Required" error is sent by an
SGP in response to  an ASP Up message that does not
contain an ASP Identifier parameter when the SGP
requires one. The ASP SHOULD resend the ASP Up message
   with an ASP Identifier.

2-The "Invalid ASP Identifier" error is sent by an SGP
in response to an ASP Up message with an invalid
(i.e., non-unique) ASP Identifier.

which indicate that SG end should not use locally
configured  ASPID in the Notify message.

Please let me know if ASPID is optional in ASPUP( when
more than one ASP in AS) then the Error "ASP
Identifier Required" and "Invalid ASP Identifier" also
Optinal.

Br,
Padmalochan

      ____________________________________________________________________________________
Never miss a thing.  Make Yahoo your home page. 
http://www.yahoo.com/r/hs
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Thu, 13 Mar 2008 13:58:28 +0530

Padmalochan,

> configured  ASPID in the Notify message.

I think you are right.

> Identifier Required" and "Invalid ASP Identifier" also

 If both sides have the same understanding, then you are right. If ASP
considers this field(asp-id) to be optional, but SGP is expecting it to be
present, then "ASP Identifier Required" error code could be returned.

Br,

---

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 13 Mar 2008 14:46:12 +0530

Hi,

      If SG need ASP-ID then when and how it will get it? Does it mean
before processing NOTIFY message SG will take the manually configure ASPID
when ASPID is not present in ASPUP message in multiple ASP in AS case?

If Notify message is a mandatory message in case of Multiple ASP in AS then,
we should include ASPID in ASPUP to make both end synchronized  with ASPID
value.

br,
Ambika

> present, then "ASP Identifier Required" error code could be returned.

-

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Thu, 13 Mar 2008 15:14:06 +0530

Ambika,

> when ASPID is not present in ASPUP message in multiple ASP in AS case?

SG should store the  ASP-ID which is received in ASP-UP message. First
NOTIFY messages would be sent after getting the ASP-UP message, and further
notifications would be sent in case of AS state change. SG could manually
configure an ASPID, but its an implementation dependent behaviour.

> we should include ASPID in ASPUP to make both end synchronized  with ASPID

Its an conditional parameter in NOTIFY message, but it is better to use it
in a multiple ASP in an AS case.

br,
> > present, then "ASP Identifier Required" error code could be returned.

Cheers,
Ankit

---

From: "David Laight" <[email-masked]>
Date: Thu, 13 Mar 2008 09:52:34 -0000

> requires one. The ASP SHOULD resend the ASP Up message

Personally I'd replace the last sentence with:
    "The ASP should be reconfigured to include an ASP
    Identifier in ASP Up messages."

The ASP Identifier can't just be pulled out of thin air.
For it to be useful the value needs to be known to all the
ASP using the same routing context.

Also I don't believe the SG is allowed to reject an ASP Up
message because it contains an ASP Id - so an ASP that can
supply an ASP Id might as well always supply one.

	David 

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Ankit Kumar Sharma" <[email-masked]>
Date: Thu, 13 Mar 2008 16:27:08 +0530

David,

>     Identifier in ASP Up messages."

No need to replace the sentence. It is left on implementations to supply
ASP-UP with ASP-id using any available method, whether it is static
reconfiguration or dynamic reconfiguration etc.

> ASP using the same routing context.

agreed ...

> supply an ASP Id might as well always supply one.

SG rejects ASP-UP only in the case when it has invalid ASP-id. Please see
the example of invalid ASP-ID in RFC(4666) section 3.8.1

        David

Cheers,
Ankit

---

From: "Ambika Tripathy" <[email-masked]>
Date: Thu, 13 Mar 2008 16:32:40 +0530

Hi Ankit,

As per your sentence below " SG rejects ASP-UP only in the case when it has
invalid ASP-id. Please see the example of invalid ASP-ID in RFC(4666)
section 3.8.1"

My question how can SG know the ASPID id invalid, if there is no handshaking
between about ASPID in case of multiple ASP in AS.

Also if ASPID is not present in ASPUP message how can the SG validate the
ASPID locally.

Is it a manual configuration work?

Br,
Ambika

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 13 Mar 2008 05:22:25 -0600

Ambika,

Ambika Tripathy wrote:                       (Thu, 13 Mar 2008 16:32:40)
> 
>    Hi Ankit,
>    As  per  your sentence below " SG rejects ASP-UP only in the case when
>    it  has  invalid  ASP-id.  Please see the example of invalid ASP-ID in
>    RFC(4666) section 3.8.1"
>    My  question  how  can  SG  know  the ASPID id invalid, if there is no
>    handshaking between about ASPID in case of multiple ASP in AS.

Although there are many possibilities, two are:

 1) The ASP-ID does not match configuration information local to the SG.

 2) The ASP-ID is the same as that of another ASP serving the AS.

>    Also  if ASPID is not present in ASPUP message how can the SG validate
>    the ASPID locally.

If the SG requires one, and one is not present, it sends ASP-ID required
error, not invalid ASP-ID error.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/