Subject: [Sigtran] I have a question about sctp transport address and enpoint .

From: "cheng yan" <[email-masked]>
Date: Fri, 14 Mar 2008 14:50:09 +0000

Dear everyone,I have a question about the concept of "endpoint","tranport address" in  the rfc2960. Follow is the summary of "transport address,endpoit,association" in the rfc2960. sctp transport address :one ip address + sctp port,sctp endpoint:  (ipset) + port association:  local endpoint + remote endpoint(ipset is consiste of one or more ip adress) But in the definition of endpoint ,there is a description like this: "A transportaddress used by an SCTP endpoint must not be used by another SCTPendpoint."  Is this means the follow configuration is not conform to the rfc2960?             A (client)                  B(server)associ1  :ip1  + port1 --------ipa + port3associ2  :ip1  + port2 --------ipa + port3           But in fact, the local ips,local port,peer ips,peer port can unique identify a association.  Follow description is get from the rfc2960.   o  SCTP endpoint: The logical sender/receiver of SCTP packets.  On a      multi-homed host, an SCTP endpoint is represented to its peers as      a combination of a set of eligible destination transport addresses      to which SCTP packets can be sent and a set of eligible source      transport addresses from which SCTP packets can be received.  All      transport addresses used by an SCTP endpoint must use the same      port number, but can use multiple IP addresses.  A transport      address used by an SCTP endpoint must not be used by another SCTP      endpoint.  In other words, a transport address is unique to an      SCTP endpoint.     o  SCTP association: A protocol relationship between SCTP endpoints,      composed of the two SCTP endpoints and protocol state information      including Verification Tags and the currently active set of      Transmission Sequence Numbers (TSNs), etc.  An association can be      uniquely identified by the transport addresses used by the      endpoints in the association.  Two SCTP endpoints MUST NOT have      more than one SCTP association between them at any given time.   o  Transport address:  A Transport Address is traditionally defined      by Network Layer address, Transport Layer protocol and Transport      Layer port number.  In the case of SCTP running over IP, a      transport address is defined by the combination of an IP address      and an SCTP port number (where SCTP is the Transport protocol).  
_________________________________________________________________
Climb to the top of the charts! Play the word scramble challenge with star power.
http://club.live.com/star_shuffle.aspx?icid=starshuffle_wlmailtextlink_jan

_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 14 Mar 2008 11:24:50 -0600

cheng,

cheng yan wrote:                                                   (Fri, 14 Mar 2008 14:50:09)
> 
>    Is this means the follow configuration is not conform to the rfc2960?
>                 A (client)                  B(server)
>    associ1  :ip1  + port1 --------ipa + port3
>    associ2  :ip1  + port2 --------ipa + port3
> 

B(server) is one SCTP endpoint, so it is OK.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/