Subject: [Sigtran] Optional ASP-ID in M3UA

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 12 Mar 2008 11:51:26 +0530

Hi Experts,

     Can I configure ASP-ID as optional when multiple ASP's are present
within one AS with loadshare traffic mode?

-- 
Br,
Ambika Prasad Tripathy
Nethawk
Cell: +91-94375 47730
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 12 Mar 2008 00:46:55 -0600

Ambika,

Ambika Tripathy wrote:                          (Wed, 12 Mar 2008 11:51:26)
> 
>          Can  I  configure  ASP-ID  as  optional  when multiple ASP's are
>    present within one AS with loadshare traffic mode?

Yes.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 12 Mar 2008 12:19:33 +0530

Hi Brain,

      Thanks a lot for a quick answer. But this creates one doubt.

Why there is ASPID in protocol and what is need then?

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 12 Mar 2008 01:02:45 -0600

Ambika,

Ambika Tripathy wrote:                   (Wed, 12 Mar 2008 12:19:33)
>    Why there is ASPID in protocol and what is need then?

1. Two ASPs are implemetned, each as a separate process on the same host.
   Each connects to the same SGP using dynamic port allocation (e.g. binds
   to port 0).  The SGP cannot distinguish between them based on IP addresses
   (which are the same) nor port number (of which the SGP has no a priori
   knowledge).  In such a case the SGP can require an ASP-ID.

2. Four ASPs serve an AS, e.g. in loadshare mode.  The SG reports ASP
   failure in the AS.  The ASPs cannot know for certain to which ASP
   the SG refers unless they provide ASP-ID with ASP-UP.  Therefore, when
   the ASP provides ASP-ID in ASP-UP, the SG must store the value and use
   it when reporting ASP Failure in a NOTIFY message.

But both these situations are mentioned in the RFC.

--brian

---

From: "Ambika Tripathy" <[email-masked]>
Date: Wed, 12 Mar 2008 12:47:33 +0530

Hi Brain,

     This if the below statement is true  and ASPID is optionally configured
and in the loadshare mode one ASP has failed, how can the SG will notify
which ASP is failed?

 *2. Four ASPs serve an AS, e.g. in loadshare mode.  The SG reports ASP
  failure in the AS.  The ASPs cannot know for certain to which ASP
  the SG refers unless they provide ASP-ID with ASP-UP.  Therefore, when
  the ASP provides ASP-ID in ASP-UP, the SG must store the value and use
  it when reporting ASP Failure in a NOTIFY message*
**
If in loadshare mode, if we configure ASP ID is optional and Notify
procedure is optional it will be difficult to update the status of AS if I
am not wrong.

Or is there any other procedure problem to resolve it. Please let me know.

-- 
Br,
Ambika Prasad Tripathy
Nethawk Networks
Cell: +91-94375 47730

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 12 Mar 2008 01:20:25 -0600

Ambika,

The Notification Procedure is mandatory.

It is mandatory that the SG provide the ASP-ID in the ASP
Failure notification when it is locally configured or was
provided by the ASP in the ASP-UP.

Read the appropriate sections (Notify Procedure) in the RFC.

--brian