Subject: [Sigtran] NBAP over SCTP

From: "Ben Davis" <[email-masked]>
Date: Fri, 28 Mar 2008 17:56:39 +0100

Hello,

3GPP specified that NBAP protocol can be transported over SCTP.
No payload protocol identifier is currently dedicated to NBAP.
How does this work ?

Thanks
Ben
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 28 Mar 2008 11:06:30 -0600

Ben,

PPI is largely optional and mostly so that protocol sniffers
can determine the transported protocol without relying on
well-known port numbers.  A protocol does not require a PPI
to operate.  Nevertheless, applying for one from IANA is a
straightforward procedure.

--brian

Ben Davis wrote:                                (Fri, 28 Mar 2008 17:56:39)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Michael Tüxen <[email-masked]>
Date: Mon, 31 Mar 2008 08:55:12 +0200

> straightforward procedure.
Speaking as a Wireshark developer: It would be *very* useful
to have a PPID registered. Please get one.

---

From: "Ben Davis" <[email-masked]>
Date: Mon, 31 Mar 2008 14:25:44 +0200

Hello,

Thanks for your reply.
Please correct me if I mis-undertood your reply:
1) PPI is of no use for the upper protocol.
2) PPI is of no use for the upper protocol, whatever its value.
3) PPI value could, therefore, even be one of those already registered by
IANA (worst case for the sniffer..). Does it make sense ??

4) What is the procedure to register a new value by IANA ?

Ben

---

From: Michael Tüxen <[email-masked]>
Date: Tue, 1 Apr 2008 04:37:29 +0200

Hi Ben,

comments in-line.

Best regards
Michael

> 1) PPI is of no use for the upper protocol.
Not true. The PPID is passed from the user at the sending
side to the user of the receiving side without the SCTP
stack touching it.
> 2) PPI is of no use for the upper protocol, whatever its value.
Not true. The upper layer can do what it wants to do with it.
For example it can be used to discriminate between multiple
upper layers within one SCTP association.
>
> 3) PPI value could, therefore, even be one of those already  
> registered by IANA (worst case for the sniffer..). Does it make  
> sense ??
No. For determining the upper layer protocol, Wireshark uses the
- Payload protocol identifier
- the smaller value of source and destination port
- the larger value if source and destination port
in that order.
> 4) What is the procedure to register a new value by IANA ?
Go to the IANA Webpage and fill out a registration form.
>
>
> Ben
>
>
> 2008/3/28, Brian F. G. Bidulock <[email-masked]>: Ben,
>