Subject: [Sigtran] GSM-MAP to TCP gateway

From: "Pete Kay" <[email-masked]>
Date: Fri, 4 Jul 2008 15:27:42 +0800

Hi,

I am not sure if this is the right forum to this question, if not, would you
please kindly direct me to the right place?

I am working on a SMS voting system which needs to handle sending and
receving SMS in a huge amount during peak period.  I am looking for a MAP-IP
gatway so I can hangle SMS from my server.  Is there any open source
software available that can do that?  If not, how do I get started in
developing something to interact with GSM-MAP?   Any help will be greatly
appreciated.

Thanks,
Pete
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Jul 2008 02:03:43 -0600

Pete,

Although technically you could use M2PA, M2UA, M3UA or SUA for
transferring MAP messages over SCTP to an SMSC, see the open
source packages at http://www.kannel.org/ and, in particular,
for SMS voting applications.  See their mailing list
http://www.kannel.org/mailman/listinfo/users and, in particular
the "Vote-by-SMS a la "Idol"" thread from October of 2007.

--brian

Pete Kay wrote:                                (Fri, 04 Jul 2008 15:27:42)
> 
>    Hi,
> 
> 
> 
>    I am not sure if this is the right forum to this question, if not,
>    would you please kindly direct me to the right place?
> 
> 
> 
>    receving SMS in a huge amount during peak period.  I am looking for a
>    MAP-IP gatway so I can hangle SMS from my server.  Is there any open
>    source software available that can do that?  If not, how do I get
>    started in developing something to interact with GSM-MAP?   Any help
>    will be greatly appreciated.
> 
> 
> 
>    Thanks,
> 
>    Pete

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/