Subject: [Sigtran] M3UA restrictions

From: <[email-masked]>
Date: Wed, 2 Jul 2008 12:52:31 +0400

Hi Experts!

Can ASP in general send transit message through SG/SGP?

An example.
ASP1(SPC1)--SG--ASP2(SPC2)
Can ASP1 send a message with routing key DPC(SPC2)-OPC(SPC1)-SI(any) to ASP2? Must SG/SGP discard this message?

Br,
Smirnov Sergey
NW MegaFon, Russia
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 2 Jul 2008 03:10:48 -0600

smirnov.s,

Yes, it is as you expect: provided, of course,
that the SG has the SS7 "transfer function."

--brian

[email-masked] wrote:                (Wed, 02 Jul 2008 12:52:31)

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: <[email-masked]>
Date: Thu, 3 Jul 2008 10:00:48 +0400

Hi, Brian,

Excuse me I have to specify my question. Can SI (service indicator) be 0 or 1 (management subsystems)?

Br,
Smirnov Sergey
NW MegaFon, Russia
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, July 02, 2008 1:11 PM
To: Смирнов Сергей
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA restrictions

smirnov.s,

--brian

---

From: <[email-masked]>
Date: Thu, 3 Jul 2008 10:07:56 +0400

Hi, Brian,

Br,
Smirnov Sergey
NW MegaFon, Russia

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, July 02, 2008 1:11 PM
To: Смирнов Сергей
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA restrictions

smirnov.s,

--brian

---

From: <[email-masked]>
Date: Thu, 3 Jul 2008 10:09:12 +0400

Hi, Brian,

Br,
Smirnov Sergey
NW MegaFon, Russia
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, July 02, 2008 1:11 PM
To: Смирнов Сергей
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA restrictions

smirnov.s,

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 3 Jul 2008 00:31:03 -0600

smirnov.s,

SI 0 or 1 are not valid MTP User Parts and do not have
to be supported by an SG.  Various error response are
available.  AFAIK no proscribed error or procedure is
specified for dealing with these messages as different
from any other erroneously coded message.

Reference RFC 4666 p. 53 "Service Indicators",

  "... The absence of the SI parameter in the Routing
   Key indicates the use of any SI value, excluding of
   course MTP management. ..."

--brian

[email-masked] wrote:                (Thu, 03 Jul 2008 10:09:12)

---

From: <[email-masked]>
Date: Thu, 3 Jul 2008 11:51:05 +0400

Hi, Brian,

Br,
Smirnov Sergey
NW MegaFon, Russia

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Wednesday, July 02, 2008 1:11 PM
To: Смирнов Сергей
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA restrictions

smirnov.s,

--brian

---

From: <[email-masked]>
Date: Fri, 4 Jul 2008 10:51:18 +0400

Hello, Brian,

Yes, I read this comment about MTP management. But I think there is misunderstanding.
ASP sends TRANSFER message (payload data) with DPC which doesn't belong to SG. In traditional SS7 an STP must route such message to output link set without checking of parameter, e.g. SI. So, why in M3UA SG don't have to work similarly?

BR, Sergey
-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Thursday, July 03, 2008 10:31 AM
To: Смирнов Сергей
Cc: [email-masked]
Subject: Re: [Sigtran] M3UA restrictions

smirnov.s,

--brian

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 4 Jul 2008 01:52:59 -0600

smirnov.s,

Because M3UA does not transport the MTP protocol, Q.704: it
transports the MTP to MTP-User service interface as described
in Q.701 (i.e.  MTP-TRANSFER primitive of Clause 8.1) which
does not provide for L4 specified management messages.

--brian

[email-masked] wrote:                (Fri, 04 Jul 2008 10:51:18)
> Hello, Brian,
> 
> Yes, I read this comment about MTP management. But I think there is
> misunderstanding.  ASP sends TRANSFER message (payload data) with DPC
> which doesn't belong to SG. In traditional SS7 an STP must route such
> message to output link set without checking of parameter, e.g. SI. So,
> why in M3UA SG don't have to work similarly?
> 
> BR, Sergey

---

From: "David Laight" <[email-masked]>
Date: Fri, 4 Jul 2008 09:50:55 +0100

The thing to remember is that M3UA carries the MTP3 service interface.
So if there is a user-part (eg ISUP or SCCP) at one end then there is an
MTP3 at the other.  The M3UA SG (effecively) just feeds traffic into MTP3.

	David

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: 04 July 2008 07:51
> To: [email-masked]
> Cc: [email-masked]
> ASP sends TRANSFER message (payload data) with DPC which 
> doesn't belong to SG. In traditional SS7 an STP must route 
> such message to output link set without checking of 
> parameter, e.g. SI. So, why in M3UA SG don't have to work similarly?
> 
> BR, Sergey
> > Excuse me I have to specify my question. Can SI (service 
> indicator) be
> > 0 or 1 (management subsystems)?
> > 
> > Br,
> > Smirnov Sergey
> > NW MegaFon, Russia
> 
> -- 
> Brian F. G. Bidulock
> [email-masked]
> http://www.openss7.org/

Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
Registration No: 1397386 (Wales)  
P Please consider the environment and don't print this e-mail unless you really need to
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran