Subject: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

From: Santhana <[email-masked]>
Date: Mon, 06 Jul 2009 11:44:41 +0530

Hi Brian

            When an ASP is in DOWN state and if it receives ASP ACTIVE
message which of the following is most suggested handling, as the RFC does
not tell anything specific regarding this(I searched enough in RFC).

1)       Sending a DOWN ACK message

2)       Sending an ERROR (unexpected message)

Please provide your suggestion on this.

Regards

Santhanakrishnan

---

From: <[email-masked]>
Date: Mon, 6 Jul 2009 15:00:35 +0800

Hi Santhana

In case if we receive ASP-ACTIVE in ASP-DOWN state, we must discard the
message and may send Unexpected Message Error to the peer. Here is what
RFC says about unexpected messages.
 
"The "Unexpected Message" error MAY be sent if a defined and recognized
message is received that is not expected in the current state (in some
cases the ASP may optionally silently discard the message and not send
an Error message)." 
 
And in your case that is what exactly is happening, a defined and
recognized ASP-ACTIVE message is being received in ASP-DOWN state, which
is not expected in DOWN state. In case of ASP-DOWN only expected
messages are HeartBeat, ASP-DOWN Ack and Error messages.
 
Hope it clarifies your doubt.

Thanks
aamir

________________________________

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Santhana
Sent: Monday, July 06, 2009 11:45 AM
To: [email-masked]
Subject: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Hi Brian

            When an ASP is in DOWN state and if it receives ASP ACTIVE
message which of the following is most suggested handling, as the RFC
does not tell anything specific regarding this(I searched enough in
RFC).

Regards

Santhanakrishnan

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Jul 2009 01:30:47 -0600

Santhana,

===> 2)       Sending an ERROR (unexpected message)

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Santhana <[email-masked]>
Date: Mon, 06 Jul 2009 14:36:04 +0530

Hi Brian/Amir
	Thanks for your opinion and quoting from RFC.
	
	But sending a DOWN ACK in this case would correct the peer's state
also in case if it is wrong. And the message also fits this scenario. 

4.3.4.2  In ASP DOWN procedures: 5th para
"If the ASP receives an ASP Down Ack message without having sent an ASP Down
message, the ASP should now consider itself to be in the ASP-DOWN state."

	So if a DOWN Ack is sent back then the state can be corrected in the
peer. In spite of it, if we send an ERROR message the peer may just log the
error message. May not take a defined action based on this error. The Layer
Management has to sense the error and correct the state somehow.

	By this I felt sending DOWN ACK would be better. 

	Please comment. 

Regards
Santhanakrishnan

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: Monday, July 06, 2009 1:01 PM
To: Santhana
Cc: [email-masked]
Subject: Re: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Santhana,

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: <[email-masked]>
Date: Mon, 6 Jul 2009 18:29:47 +0800

Hi Santhana

What do you mean by correcting the peer's state if it is wrong? Are you
trying to say that ASP is in some different state than its state on its
associated SG.

Thanks
aamir

-----Original Message-----
From: Santhana [mailto:[email-masked]] 
Sent: Monday, July 06, 2009 2:36 PM
To: [email-masked]
Cc: [email-masked]; Khan, Amir [NETPWR/INDIA/HYDE]
Subject: RE: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Hi Brian/Amir
	
	But sending a DOWN ACK in this case would correct the peer's
state also in case if it is wrong. And the message also fits this
scenario. 

4.3.4.2  In ASP DOWN procedures: 5th para "If the ASP receives an ASP
Down Ack message without having sent an ASP Down message, the ASP should
now consider itself to be in the ASP-DOWN state."

	So if a DOWN Ack is sent back then the state can be corrected in
the peer. In spite of it, if we send an ERROR message the peer may just
log the error message. May not take a defined action based on this
error. The Layer Management has to sense the error and correct the state
somehow.

	Please comment. 

Regards
Santhanakrishnan

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, July 06, 2009 1:01 PM
To: Santhana
Cc: [email-masked]
Subject: Re: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Santhana,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Santhana <[email-masked]>
Date: Mon, 06 Jul 2009 16:39:53 +0530

Yes. So returning Down Ack will ensure the state correction in such cases
also. 

Regards
Santhanakrishnan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, July 06, 2009 4:00 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Hi Santhana

Thanks
aamir

-----Original Message-----
From: Santhana [mailto:[email-masked]] 
Sent: Monday, July 06, 2009 2:36 PM
To: [email-masked]
Cc: [email-masked]; Khan, Amir [NETPWR/INDIA/HYDE]
Subject: RE: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Hi Brian/Amir

	Please comment. 

Regards
Santhanakrishnan

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]]
Sent: Monday, July 06, 2009 1:01 PM
To: Santhana
Cc: [email-masked]
Subject: Re: [Sigtran] [M3UA] Receving ASP ACTIVE in DOWN State

Santhana,

--brian

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 6 Jul 2009 06:07:46 -0600

Santhana,

Santhana wrote:                            (Mon, 06 Jul 2009 14:36:04)
> Management has to sense the error and correct the state somehow.

1. Any implementation that does not process ERROR messages is
   simply broken.  ERROR messages are not advisory: NOTIFY
   messages are advisory.

2. An ASP cannot distinguish an ASP DOWN ACK sent in this way
   fron the way in which it was intended (NIF failure).

3. The ERROR message identifies the message that was unexpected
   and the RC value of that message.

The ERROR message is the correct response to all messages in
the ASP DOWN state with the exception of the ASP UP and ASP
DOWN message.

--brian

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/