Subject: [Sigtran] [M3UA]Broadcast Mode in M3UA

From: Kuldeep Janjua <[email-masked]>
Date: Tue, 7 Jul 2009 17:22:40 +0530

Hi All,

Why do we require BroadCast Mode in M3UA ? What is the practical
scenario when AS at M3UA will be configured in BroadCast Mode. What
exactly is the meaning of configuring local AS in BroadCast mode.

Thanks,
Kuldeep

---

From: <[email-masked]>
Date: Tue, 7 Jul 2009 20:11:39 +0800

Hi Kuldeep

In a AS there can be multiple ACTIVE ASP's, but not all ACTIVE ASP's
might be processing the incoming traffic for that AS (Loadsharing or
Override mode) but if you want all the ACTIVE ASP's for that AS to
process the traffic you need to set the AS in Broadcast mode.

Thanks
aamir

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Kuldeep Janjua
Sent: Tuesday, July 07, 2009 5:23 PM
To: [email-masked]; [email-masked]
Subject: [Sigtran] [M3UA]Broadcast Mode in M3UA

Hi All,

Thanks,
Kuldeep
_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran

---

From: Kuldeep Janjua <[email-masked]>
Date: Tue, 7 Jul 2009 18:20:37 +0530

Hi Amir,

But Why would I require all ASPs to process the same message, can you
give some practical example, and in that case how to ensure that only
one single message should be delivered to the user not the duplicate
copies.M3UA rfc does not talk about handling duplicated messages as
such.

Regards,
Kuldeep

---

From: <[email-masked]>
Date: Tue, 7 Jul 2009 22:03:51 +0800

A case would be to propagate Destination Unavailable message for a
particular SS7 destination to all the ACTIVE ASP's of an AS in Broadcast
mode. And as for handling of duplicate messages I think it will be taken
care by SCTP.

Thanks
aamir

-----Original Message-----
From: Kuldeep Janjua [mailto:[email-masked]] 
Sent: Tuesday, July 07, 2009 6:21 PM
To: Khan, Amir [NETPWR/INDIA/HYDE]
Cc: [email-masked]; [email-masked]
Subject: Re: [Sigtran] [M3UA]Broadcast Mode in M3UA

Hi Amir,

Regards,
Kuldeep

---

From: Chris Benson <[email-masked]>
Date: Tue, 7 Jul 2009 11:25:22 -0700 (PDT)

Kuldeep,

The purpose of the Broadcast Traffic Mode within M3UA
is to implement redundancy, using two or more identical
instances of ASPs or SGPs, performing the same tasks.

For example, all the ASPs in an AS could choose to request 
Broadcast Traffic Mode, and the remote peers would then
send the same message to each ACTIVE ASP. The intent is
that every ASP performs the same operation(s) with that
message. If one ASP fails in some way, then the other(s) 
continue operating, in the hope that at least one of them 
survives.

The Traffic Mode issued in M3UA messages describes how
you would like to RECEIVE messages. How you send messages
is dictated by the peer's requested Traffic Mode.

I hope this helps, from Chris.

Chris Benson,

On Tue, 7 Jul 2009, Kuldeep Janjua wrote:

>>  Date: Tue, 7 Jul 2009 17:22:40 +0530
>>  From: Kuldeep Janjua <[email-masked]>
>>  To:  <[email-masked]>,  <[email-masked]>

---

From: Kuldeep Janjua <[email-masked]>
Date: Wed, 8 Jul 2009 10:07:41 +0530

Thanks a lot Chris and Aamir!!

I got the point.