Subject: [Sigtran] SIGTRAN: Client-Server model

From: aditi someshwar <[email-masked]>
Date: Thu, 5 Apr 2012 11:15:47 +0530

Hi all,

One very fundamental question:

SIGTRAN uses "Client-Server" model.

Can anyone please tell why?

Regards,
Aditi

---

From: Elnur Atakishiyev <[email-masked]>
Date: Thu, 5 Apr 2012 11:25:06 +0500

Hi Aditi,
This is because of Sigtran is based on IP protocol and for two nodes interconnection between each other one of them must be act as "SERVER" and other one is must be acted as "CLIENT".

Best regards

Elnur Atakishiyev
Billing Engineering Senior Specialist
Billing Engineering team
Planning and Engineering Unit
Billing Department
Information Technologies Division

Tel: (+994 12) 4440730
Fax: (+994 12) 4440733
Mob: (+994 70) 2011342
E-mail: [email-masked] <mailto:[email-masked]>
Web:www.azerfon.az<http://www.azerfon.az/>

Privacy disclaimer<http://narmobile.az/en/prvdecl#content>

AZERFON LLC
Building 20 C
1240 Nobel Ave., Khatai district
Baku AZ 1025
Azerbaijan

From: [email-masked] [mailto:[email-masked]] On Behalf Of aditi someshwar
Sent: Thursday, April 05, 2012 10:46 AM
To: [email-masked]
Subject: [Sigtran] SIGTRAN: Client-Server model

Hi all,

Regards,
Aditi

________________________________
Privacy Declaration: This e-mail and its attachments contain confidential information from "Azerfon LLC" ,which is intended
only for the person or entity whose address is listed above. Any use of the information contained herein in any way
(including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than
the intended recipient(s) is prohibited. If you receive this e-mail in error, please notify the sender by phone or
email immediately and delete it!

---

From: aditi someshwar <[email-masked]>
Date: Thu, 5 Apr 2012 11:59:56 +0530

True, but does it mean that all functions of the "client" and "server" are
applicable to SIGTRAN?
Why can't they be peer to peer nodes?

On Thu, Apr 5, 2012 at 11:55 AM, Elnur Atakishiyev
<[email-masked]>wrote:

>  Hi Aditi,****
>
> This is because of Sigtran is based on IP protocol and for two nodes
> interconnection between each other one of them must be act as “SERVER” and
> other one is must be acted as “CLIENT”.****
>
> ** **
>
> ** **
>
> ****
>
> ****
>
> ****
>
> ****
>
> ****
>
> Best regards****
>
> *Elnur Atakishiyev*
> *Billing Engineering Senior Specialist*
> Billing Engineering team
> Information Technologies Division ****
>
> ****
>
> ****
>
> ****
>
> ****
>
> ****
>
> Tel: (+994 12) 4440730
> Fax: (+994 12) 4440733
> Mob: (+994 70) 2011342
> E-mail: [email-masked]
> Web:www.azerfon.az
>
> *Privacy disclaimer* <http://narmobile.az/en/prvdecl#content> ****
>
> AZERFON LLC
> Building 20 C
> Azerbaijan****
> ****
> ****
> ****
> ****
> ** **
> ** **
> *From:* [email-masked] [mailto:[email-masked]] *On
> Behalf Of *aditi someshwar
> *Sent:* Thursday, April 05, 2012 10:46 AM
> *To:* [email-masked]
> *Subject:* [Sigtran] SIGTRAN: Client-Server model****
>
> ** **
>
> Hi all,
>
> Aditi****
> ------------------------------
> Privacy Declaration: This e-mail and its attachments contain confidential
> information from "Azerfon LLC" ,which is intended
> only for the person or entity whose address is listed above. Any use of
> the information contained herein in any way
> the intended recipient(s) is prohibited. If you receive this e-mail in
> error, please notify the sender by phone or

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Thu, 5 Apr 2012 01:17:43 -0600

aditi,

See RFC 2719 for the Framework Architecture for Signaling Transport.  It is
not as simple as pure peer-to-peer or pure client-server.

--brian

aditi someshwar wrote:                                               (Thu, 05 Apr 2012 11:59:56)
>    True, but does it mean that all functions of the "client" and "server"
>    are applicable to SIGTRAN?

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: Chris Benson <[email-masked]>
Date: Thu, 5 Apr 2012 10:18:50 -0700 (PDT)

Aditi,

The function of "client" and "server" that is used by SIGTRAN
is the initiator of connections between them. The "client"
decides to connect to a "server" that is listening for such
connection requests.

In almost all real cases of SIGTRAN, the underlying transport
is provided by SCTP, where a connection is called an association
and must be initiated by just one side, with suitable responses
by the other side.

In their original guise and purpose, many SIGTRAN protocols are
inherently asymmetric, connecting user-level protocols on one 
side to provider-level protocols on the other side of a pair
of co-operating peers. So two "peers" are often not "equal 
peers" in the sense of being equivalent in operation.

Generally, the "client" and "server" label distinction only 
applies to the connection phase, and is not relevant after
connecting.  Your question refers to *all* functions of "client"
and "server". I believe the initiator and listener/responder 
roles at connection time are the only such function recognized 
in the SIGTRAN suite of protocols.

With thanks, from Chris Benson.

On Thu, 5 Apr 2012, aditi someshwar wrote:

>>  Date: Thu, 5 Apr 2012 11:59:56 +0530
>>  From: aditi someshwar <[email-masked]>
>>  To: Elnur Atakishiyev <[email-masked]>
>>  Cc: "[email-masked]" <[email-masked]>
>>  Subject: Re: [Sigtran] SIGTRAN: Client-Server model
>>

---

From: Saurabh Jain <[email-masked]>
Date: Fri, 6 Apr 2012 09:34:51 +0530

Hello,
In addition to this, in general Sigtran protocols support 2 modes
1. ASP mode -  one side is running on SG and one side is in IP network. Here, protocol at both ends are asymmetric and client server model is a direct fit
2. IPSP mode - both sides are in IP network, Here the protocol is symmetric at both sides and any side can initiate a connection.

Rgds
Saurabh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Benson
Sent: Thursday, April 05, 2012 10:49 PM
To: aditi someshwar
Cc: [email-masked]
Subject: Re: [Sigtran] SIGTRAN: Client-Server model

Aditi,

The function of "client" and "server" that is used by SIGTRAN is the initiator of connections between them. The "client"
decides to connect to a "server" that is listening for such connection requests.

In almost all real cases of SIGTRAN, the underlying transport is provided by SCTP, where a connection is called an association and must be initiated by just one side, with suitable responses by the other side.

In their original guise and purpose, many SIGTRAN protocols are inherently asymmetric, connecting user-level protocols on one side to provider-level protocols on the other side of a pair of co-operating peers. So two "peers" are often not "equal peers" in the sense of being equivalent in operation.

Generally, the "client" and "server" label distinction only applies to the connection phase, and is not relevant after connecting.  Your question refers to *all* functions of "client"
and "server". I believe the initiator and listener/responder roles at connection time are the only such function recognized in the SIGTRAN suite of protocols.

On Thu, 5 Apr 2012, aditi someshwar wrote:

>>  True, but does it mean that all functions of the "client" and
>> "server" are  applicable to SIGTRAN?
>>  > This is because of Sigtran is based on IP protocol and for two
>> nodes  > interconnection between each other one of them must be act
>> as “SERVER” and  > other one is must be acted as “CLIENT”.****  >  >
>> ** **  >  > ** **  >  > [image: Description:
>> http://azfn0359/it_sign/images/my_01.jpg]****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > Best regards****
>>  >
>>  > *Elnur Atakishiyev*
>>  > *Billing Engineering Senior Specialist*  > Billing Engineering
>> team  > Planning and Engineering Unit  > Billing Department  >
>> Information Technologies Division ****  >  > [image: Description:
>> http://azfn0359/it_sign/images/my_06.jpg]****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > Tel: (+994 12) 4440730
>>  > Fax: (+994 12) 4440733
>>  > Mob: (+994 70) 2011342
>> >  > AZERFON LLC  > Building 20 C  > 1240 Nobel Ave., Khatai district
>> > Baku AZ 1025  > Azerbaijan****  >  > [image: Description:
>> http://azfn0359/it_sign/images/my_12.jpg]****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > ****
>>  >
>>  > ** **
>>  >
>>  > ** **
>>  >
>>  > *From:* [email-masked] [mailto:[email-masked]]
>> *On  > Behalf Of *aditi someshwar  > *Sent:* Thursday, April 05, 2012
>> 10:46 AM  > *To:* [email-masked]  > *Subject:* [Sigtran] SIGTRAN:
>> Client-Server model****  >  > ** **  >  > Hi all,  >  > One very
>> fundamental question:
>>  >
>>  > Privacy Declaration: This e-mail and its attachments contain
>> confidential  > information from "Azerfon LLC" ,which is intended  >
>> only for the person or entity whose address is listed above. Any use
>> of  > the information contained herein in any way  > (including, but
>> not limited to, total or partial disclosure, reproduction,  > or
>> dissemination) by persons other than  > the intended recipient(s) is
>> prohibited. If you receive this e-mail in  > error, please notify the
>> sender by phone or  > email immediately and delete it!
>>  >
>>

===============================================================================
Please refer to http://www.aricent.com/legal/email_disclaimer.html
for important disclosures regarding this electronic communication.
===============================================================================

---

From: "Aditi Someshwar" <[email-masked]>
Date: Fri, 6 Apr 2012 05:26:29 +0000

Thanks Chris, thanks Saurabh.

Your mails have brought in a lot of clarity. Was a very fundamental question, thanks for anwering in such a lucid way.

Regards,
Aditi Nangia Someshwar

-----Original Message-----
From: Saurabh Jain <[email-masked]>
Date: Fri, 6 Apr 2012 09:34:51 
To: Chris Benson<[email-masked]>; aditi someshwar<[email-masked]>
Cc: [email-masked]<[email-masked]>
Subject: RE: [Sigtran] SIGTRAN: Client-Server model

Hello,

Rgds
Saurabh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Chris Benson
Sent: Thursday, April 05, 2012 10:49 PM
To: aditi someshwar
Cc: [email-masked]
Subject: Re: [Sigtran] SIGTRAN: Client-Server model

Aditi,

---

From: "SINGH, VIKRAMJEET (VIKRAMJEET)" <[email-masked]>
Date: Tue, 24 Apr 2012 13:03:24 +0530

Hi,

Q1: Can 2 ASPs of Same Mode (IPSP -DE) be added to 2 different AS having different RC values?

My thinking is that there should not be any restriction to add two different ASPs (IPSP DE) each of which is associated to two different ASs having same routing context. 

But in my observation restriction is observed when doing such configuration.
Is it right?

Q2: Can 2 ASPs of Same Mode (IPSP -DE) be added to 2 different AS having same RC values?

Thanks,
Vikramjeet Singh

---

From: Anand N Ilkal <[email-masked]>
Date: Tue, 24 Apr 2012 14:42:43 +0530

Hi vikram,

On 24 April 2012 13:03, SINGH, VIKRAMJEET (VIKRAMJEET) <
[email-masked]> wrote:

> My thinking is that there should not be any restriction to add two
> different ASPs (IPSP DE) each of which is associated to two different ASs
> having same routing context.
>
> Yes, ASP's can be added to different AS's with different RC's. There is no
such restriction. The restriction what you are seeing in current
configuration could be due to the stack implementation. Standard is clear
about this and there is no restriction for this type of configuration.

> This configuration is against the standard. remember standard recommends,
each RC should uniquely identify a Routing Key. In your case, you are
trying to index two different Routing keys using same RC, which is not
possible.

>
>
> Thanks,
> Vikramjeet Singh
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran
>

-- 
with regards,
Anand kumar Ilkal