Subject: [Sigtran] Number of links towards a DPC (ITU)

From: Arvind Kumar <[email-masked]>
Date: Fri, 14 Jun 2013 14:09:27 +0530

Hi All,

Would appreciate if somebody help me,
I have SS7 Stack with multiple OPC, I would like to create multiple
linksets towards a single destination (suppose 2000).

How many links are possible in all the link-sets. I know there is no
limitation of number of link-sets, but as I  understood, towards a given
destination the maximum number of links depends upon maximum value of SLS.

For ITU it could be 16.
But my doubt is I have mutiple OPCs for my SS7 Stack, could number of
links  be possible
= number of OPCs * 16

Please comment.
 Regards,

On Sun, May 5, 2013 at 12:30 AM, <[email-masked]> wrote:

> If you have received this digest without all the individual message
> attachments you will need to update your digest options in your list
> subscription.  To do so, go to
>
> https://www.ietf.org/mailman/listinfo/sigtran
>
> Click the 'Unsubscribe or edit options' button, log in, and set "Get
> MIME or Plain Text Digests?" to MIME.  You can set this option
> globally for all the list digests you receive at this point.
>
>
>
> Send Sigtran mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/sigtran
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of Sigtran digest..."
>
>
> Today's Topics:
>
>    1. Abort chunk in SCTP (Norah Jones)
>
>
> ----------------------------------------------------------------------
>
> Message: 1
> Date: Sat, 4 May 2013 06:50:12 +0000
> From: Norah Jones <[email-masked]>
> To: [email-masked]
> Subject: [Sigtran] Abort chunk in SCTP
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="utf-8"
>
> Hi,
>
> I am using LKSCTP in my project, one sometime I see that by box receives
> About chunk from the peer. Now question is what are the possibilities for
> which we can receive abort chunk from remote.
>
>
> Thanks,
> Norah Jones
>
>
>
>
> ------------------------------
>
> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran
>
>
> End of Sigtran Digest, Vol 102, Issue 1
> ***************************************
>

---

From: "David Laight" <[email-masked]>
Date: Fri, 14 Jun 2013 09:49:35 +0100

ss7 allows 16 signalling links in all linksets (for ITI and ANSI), so with multiple OPC you can

have 16 signalling links to a single destination for each OPC.

However your ss7 stack might have restrictions on the number of supported signalling links

since processing a FISU every 6 byte times isn’t for the faint hearted!

Cards that support 64 signalling links (spread over 8 E1/t1 links) are available.

                David

From: [email-masked] [mailto:[email-masked]] On Behalf Of Arvind Kumar
Sent: 14 June 2013 09:39
To: [email-masked]
Subject: [Sigtran] Number of links towards a DPC (ITU)

Hi All,

I have SS7 Stack with multiple OPC, I would like to create multiple linksets towards a single destination (suppose 2000).

How many links are possible in all the link-sets. I know there is no limitation of number of link-sets, but as I  understood, towards a given destination the maximum number of links depends upon maximum value of SLS.

For ITU it could be 16.

But my doubt is I have mutiple OPCs for my SS7 Stack, could number of links  be possible 

= number of OPCs * 16

Please comment.

Regards,

Today's Topics:

Message: 1

Hi,

I am using LKSCTP in my project, one sometime I see that by box receives About chunk from the peer. Now question is what are the possibilities for which we can receive abort chunk from remote.

Thanks,
Norah Jones

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Fri, 14 Jun 2013 15:55:03 -0600

Arvind,

ITU has a 4-bit SLS and a 4 bit SLC.  The SLS and SLC is shared under
ITU and ITU does not do SLS rotation.  Therefore, because 1 bit is used
for link-set selection, there can only be 8 links in a linkset (16 links
in a combined linkset).

ANSI has an 8-bit SLS and a 5-bit SLC.  The SLS and SLC are not shared
and ANSI does SLS rotation.  Therefore, it is possible to have 32 links
in a linkset (64 links in a combined linkset).  Using the old 5-bit SLS
it was only possible to have 16 links in a linkset and 32 links in a
combined linkset because 1 of the 5 bits was used for linkset selection
within a combined linkset.

So, there are two considerations: SLS and SLC size.  The most links in a
link set is restricted by the size of the SLC (the number of signalling
links that can be identified between two signalling point  codes);
however, the combined linkset is also restricted by the SLS size (over
how many distinct signalling links can the traffic be distributed).

That said, signalling links are identified by the 3-tuple PC-PC-SLC.
Just because you have multiple PCs on a signalling point does not
necessarily increase the number of signalling links that it can support.
So, if you have 4 PCs, it does not necessarily mean that you can support
4 times as many signalling links.  It is common, for example on a class
5 switch, to provide 1 primary PC that is used in management messages on
signalling links and 3 additional ones (in our example) that are only
aliases (that is, messages can be routed to them but they do not
participate in signalling link management messages).

Some stacks; however, are also capable of supporting multiple signalling
points.  In which case, each primary PC can act as a completely
independent signalling point with its own set of signalling links.  SS7
network operators do no like connecting to systems where multiple
independent signalling points are implemented on the same hardware.

If you need a lot of signalling links for capacity, broadband (or
better, M2PA) signalling links can be used.  In the case of M2PA, the
signalling capacity is not dependent on the number of signalling links
and only a pair of signalling links is required (and recommended).

--brian

Arvind Kumar wrote:                        (Fri, 14 Jun 2013 14:09:27)
>    limitation of number of link-sets, but as I  understood, towards a
>    given destination the maximum number of links depends upon maximum
>    value of SLS.
>    For ITU it could be 16.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "David Laight" <[email-masked]>
Date: Mon, 17 Jun 2013 10:10:52 +0100

> for link-set selection, there can only be 8 links in a linkset (16 links

In ITU each linkset can have 16 links.
Brian is right in that MTP3 only has a 4 bit SLS value to select the
destination link, so traffic to a specific destination will only use
a maximum of 16 links even if there are routes by 2 adjacents and there
are 16 links in the linkset to each.

If you have two linksets with 16 links each, the routing rules for
different destinations could be arranged to use different links
in order to utilise all 32 links.

> within a combined linkset.

ANSI only has 4 bits for the SLC (not 5), so a linkset is limited to 16 links.
However the larger SLS value (8 bits, 5 in some earlier versions)
means that MTP3 can loadshare between more links.

It also isn't quite right to say that one of the bits is used for
linkset selection. If some of the links are down, the sls that
would be assigned to the 'down' links are evenly spread across
all of the working links, not just assigned to the working links
in their original linkset (this might be a config option since
the ANSI and ITU specs differ here.)

An endsystem ITU MTP3 may have more SLS bits available, so could
loadshare between more than 16 links.

	David

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Jun 2013 04:18:28 -0600

David,

David Laight wrote:                         (Mon, 17 Jun 2013 10:10:52)
> in order to utilise all 32 links.

I don't know where you got that idea.  See Figure A.3/Q.705.  Count the
number of links possible in a linkset (not a combined linkset).
8 links per A linkset, 4 links per B/D linkset.

> means that MTP3 can loadshare between more links.

Pardon, SLC is 4 bits, but there are still 16 links per linkset,
32 links per combined linkset.

> the ANSI and ITU specs differ here.)

It is quite right to say that 1 bit is used for linkset selection,
as it says in 7.3/T1.111.5.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "David Laight" <[email-masked]>
Date: Mon, 17 Jun 2013 11:52:03 +0100

> I don't know where you got that idea.

>From deciding not to do it when fixing our mtp3 routing rules!

Q.704 section 2.3 states that the routing is based on information
from the routing label - normally the sls and dpc.
With 2 linksets of 16 links the 'normal' link assignment could use
one bit of the sls to select between the linksets and the low bit
of the dpc and the other 3 bits of the sls to select one of the
16 links in the linkset.
This would be perfectly valid.

> See Figure A.3/Q.705.  Count the

Q.705 A is only an example mesh network.
The appendix is describing the routing under fault conditions.

	David

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Jun 2013 07:01:02 -0600

David,

David Laight wrote:                                        (Mon, 17 Jun 2013 11:52:03)
> This would be perfectly valid.

Routing not linkset selection.  It is not valid because it does
not lead to an even loadsharing over links.

> The appendix is describing the routing under fault conditions.

The network in the figure (using a fixed bit position for
linkset selection) is the common practice for ITU.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "Nemana, Satya" <[email-masked]>
Date: Mon, 17 Jun 2013 15:27:13 +0000

My 2 cents.
The ITU spec may not say this, but why not do this.
1) Use the LSB to select the linkset within a combined linkset.
2) Once the Linkset is selected, use the full SLS value to select one of the links in the linkset.
In this way, we can still have 16 links in each linkset and combined linkset can have 32 links and still loadshare across all the links.
Each linkset will still have 16 of the SLS values so, there won't be any issues of un-even loadsharing even if some links go down in the route to the final destination.

Regards,
Satya

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Laight
Sent: 17 June 2013 10:11
To: [email-masked]; Arvind Kumar
Cc: [email-masked]
Subject: Re: [Sigtran] Number of links towards a DPC (ITU)

> ITU and ITU does not do SLS rotation.  Therefore, because 1 bit is 
> used for link-set selection, there can only be 8 links in a linkset 
> (16 links in a combined linkset).

In ITU each linkset can have 16 links.
Brian is right in that MTP3 only has a 4 bit SLS value to select the destination link, so traffic to a specific destination will only use a maximum of 16 links even if there are routes by 2 adjacents and there are 16 links in the linkset to each.

If you have two linksets with 16 links each, the routing rules for different destinations could be arranged to use different links in order to utilise all 32 links.

> and ANSI does SLS rotation.  Therefore, it is possible to have 32 
> links in a linkset (64 links in a combined linkset).  Using the old 
> 5-bit SLS it was only possible to have 16 links in a linkset and 32 
> links in a combined linkset because 1 of the 5 bits was used for 
> linkset selection within a combined linkset.

ANSI only has 4 bits for the SLC (not 5), so a linkset is limited to 16 links.
However the larger SLS value (8 bits, 5 in some earlier versions) means that MTP3 can loadshare between more links.

It also isn't quite right to say that one of the bits is used for linkset selection. If some of the links are down, the sls that would be assigned to the 'down' links are evenly spread across all of the working links, not just assigned to the working links in their original linkset (this might be a config option since the ANSI and ITU specs differ here.)

An endsystem ITU MTP3 may have more SLS bits available, so could loadshare between more than 16 links.

	David

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 17 Jun 2013 10:02:24 -0600

Satya,

Nemana, Satya wrote:                    (Mon, 17 Jun 2013 15:27:13)
> 1) Use the LSB to select the linkset within a combined linkset.

So, XXX0 goes to one linkset and XXX1 goes to the other.

>    of the links in the linkset.

On the first linkset, the entire SLS is XXX0.  There are only eight
values here.  On the second linkset, the entire SLS is XXX1.  There
are only eight values here.  So, 8 links per linkset, 16 links per
combined linkset.

> In this way, we can still have 16 links in each linkset and combined
> linkset can have 32 links and still loadshare across all the links.

Nope.  See above.

> Each linkset will still have 16 of the SLS values so, there won't be
> any issues of un-even loadsharing even if some links go down in the
> route to the final destination.

Each linkset has 8 values.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "David Laight" <[email-masked]>
Date: Mon, 17 Jun 2013 17:23:07 +0100

> are only eight values here.  So, 8 links per linkset, 16 links per

That just means that the traffic to that destination can only use 8 of
the links in the linkset - even if there are more.
So it might not make much sense to have 16 links in both linksets,
but that doesn't mean that it isn't allowed.

Consider the following network fragment:
Endpoint A has a linksets with 16 links to both B and C (SEP + STP).
Additionally A has routes to SEP D via both B and C.
Traffic to B will use all 16 direct links (backup route via C).
Traffic to D will loadshare between B and C, but will only use
16 of the 32 possible links (ideally 8 via B and 8 via C).

(Wonders what our MTP3 does when configured to evenly distribute
the sls across all the links ...)

	David

---

From: "Nemana, Satya" <[email-masked]>
Date: Mon, 17 Jun 2013 16:32:38 +0000

Yeah, I got it wrong.
My idea was to use the SLS but still generate enough SLS for the linkset locally.
But this would cause the problem of mis-sequencing when links go down.
But that seems to be the only other alternative of using the entire 32 links.

-----Original Message-----
From: Brian F. G. Bidulock [mailto:[email-masked]] 
Sent: 17 June 2013 17:02
To: Nemana, Satya
Cc: David Laight; Arvind Kumar; [email-masked]
Subject: Re: [Sigtran] Number of links towards a DPC (ITU)

Satya,

>    of the links in the linkset.

On the first linkset, the entire SLS is XXX0.  There are only eight values here.  On the second linkset, the entire SLS is XXX1.  There are only eight values here.  So, 8 links per linkset, 16 links per combined linkset.

Nope.  See above.

--
Brian F. G. Bidulock
[email-masked]
http://www.openss7.org/

---

From: "David Laight" <[email-masked]>
Date: Tue, 18 Jun 2013 09:57:30 +0100

> But that seems to be the only other alternative of using the entire 32 links.

For locally generated traffic the local ISUP/SCCP could generate
more than 4 bits of sls (it probably generates 8 bits for ANSI
and mtp3 masks them for ITU) so MTP3 could loadshare over all
32 links - but your mtp3 is unlikely to behave that way.

If the traffic is TCAP/SCCP and 'route on GT' and you have
2 (or more) 'next hop' destination SCCP systems you can get
the TCAP traffic to use all 32 links.

Similarly 'class 0' SCCP traffic (order not guaranteed)
probably has an SLS assigned sequentially by SCCP.
The local MTP3 could safely reassign the SLS so that it
could use all 32 (or more) links in a combined linkset.

We have some other configurations that can loadshare over
32 links.

	David