Subject: [Sigtran] How to identify which TCAP user a PDU belongs to

From: prabath weerasinghe <[email-masked]>
Date: Wed, 17 May 2017 14:47:02 +0530

Hi All,

This is regarding SCCP subsystem number and TCAP users.

If we have a SCP which supports both INAP and CAMEL, is SSN the only way to
distinguish INAP and CAMEL calls in the TCAP layer ?

Thanks and Regards,

-- 
Prabath Weerasinghe
_________________________________________________________________________________
Confidentiality and Disclaimer

This email and any attachments are intended only for the person or entity
to whom it is addressed. Its contents may be privileged, confidential or
otherwise protected from disclosure. If you are not the intended recipient,
please do not read, disclose, distribute or copy this email or use the
information therein or act or omit to act in reliance thereof. Please also
inform the sender of erroneous receipt and delete the material from your
system.

---

From: Deepak Gunjal <[email-masked]>
Date: Wed, 17 May 2017 10:02:34 +0000

The SSN does indicate which functionality to be invoked at receiver but it should not be the only source to decide this. TCAP in my opinion should not have notion of INAP or CAMEL call but based on the SSN received in Called Party Address, it will forward the message to right stack layer which has registered with TCAP for desired SSN handling it can process. The message decoding can fail if the message is sent at wrong layer.

Regards
Deepak
From: Sigtran [mailto:[email-masked]] On Behalf Of prabath weerasinghe
Sent: Wednesday, May 17, 2017 2:47 PM
To: [email-masked]
Subject: [Sigtran] How to identify which TCAP user a PDU belongs to

Hi All,

If we have a SCP which supports both INAP and CAMEL, is SSN the only way to distinguish INAP and CAMEL calls in the TCAP layer ?

Thanks and Regards,

This email and any attachments are intended only for the person or entity to whom it is addressed. Its contents may be privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient, please do not read, disclose, distribute or copy this email or use the information therein or act or omit to act in reliance thereof. Please also inform the sender of erroneous receipt and delete the material from your system.
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: Vance Shipley <[email-masked]>
Date: Wed, 17 May 2017 12:09:53 +0200

> distinguish INAP and CAMEL calls in the TCAP layer ?

The application context in the dialogue portion provides more "context". :)

-- 
     -Vance

---

From: Deepak Gunjal <[email-masked]>
Date: Wed, 17 May 2017 10:17:10 +0000

But I think the dialog portion is not mandatory in different protocols but yes if present in can be more contextual.

-Deepak
-----Original Message-----
From: Sigtran [mailto:[email-masked]] On Behalf Of Vance Shipley
Sent: Wednesday, May 17, 2017 3:40 PM
To: prabath weerasinghe <[email-masked]>
Cc: [email-masked]
Subject: Re: [Sigtran] How to identify which TCAP user a PDU belongs to

On Wed, May 17, 2017 at 11:17 AM, prabath weerasinghe <[email-masked]> wrote:
> If we have a SCP which supports both INAP and CAMEL, is SSN the only
> way to distinguish INAP and CAMEL calls in the TCAP layer ?

--
     -Vance

_______________________________________________
Sigtran mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sigtran
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

---

From: prabath weerasinghe <[email-masked]>
Date: Wed, 17 May 2017 16:05:50 +0530

Hi Deepak and Vance,

What if the SSN doesn't indicate CAMEL or INAP like with the pcap found
here ?
INAP-pcap <https://www.cloudshark.org/captures/028324459536?filter=inap>

As Vance mentioned, the application context implies of a INAP PDU though.

Is there a proper procedure to follow when identifying the correct TCAP
user ?
I mean like first checking the SSN, then checking the application context.

Thanks and Regards,

On Wed, May 17, 2017 at 3:47 PM, Deepak Gunjal <[email-masked]>
wrote:

> But I think the dialog portion is not mandatory in different protocols but
> yes if present in can be more contextual.
>
> -Deepak
> "DISCLAIMER: This message is proprietary to Aricent and is intended solely
> for the use of the individual to whom it is addressed. It may contain
> privileged or confidential information and should not be circulated or used
> for any purpose other than for what it is intended. If you have received
> this message in error, please notify the originator immediately. If you are
> not the intended recipient, you are notified that you are strictly
> prohibited from using, copying, altering, or disclosing the contents of
> this message. Aricent accepts no responsibility for loss or damage arising
> from the use of the information transmitted by this email including damage
> from virus."
>

-- 
Prabath Weerasinghe
Department of Electrical Engineering
University of Moratuwa
Blog-*psawtech*talks.blogspot.com <http://psawtechtalks.blogspot.com/>

---

From: Deepak Gunjal <[email-masked]>
Date: Wed, 17 May 2017 10:51:34 +0000

That seems to be custom solution if something of this sort happens. The standards provide these mechanisms to enable interoperability between different implementation but if that is not followed then it falls to private agreement between different partners on how these kind of scenarios shall be handled.

From: prabath weerasinghe [mailto:[email-masked]]
Sent: Wednesday, May 17, 2017 4:06 PM
To: Deepak Gunjal <[email-masked]>
Cc: Vance Shipley <[email-masked]>; [email-masked]
Subject: Re: [Sigtran] How to identify which TCAP user a PDU belongs to

Hi Deepak and Vance,

What if the SSN doesn't indicate CAMEL or INAP like with the pcap found here ?
INAP-pcap<https://www.cloudshark.org/captures/028324459536?filter=inap>

Is there a proper procedure to follow when identifying the correct TCAP user ?
I mean like first checking the SSN, then checking the application context.

Thanks and Regards,

On Wed, May 17, 2017 at 3:47 PM, Deepak Gunjal <[email-masked]<mailto:[email-masked]>> wrote:
But I think the dialog portion is not mandatory in different protocols but yes if present in can be more contextual.

-Deepak
-----Original Message-----
From: Sigtran [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Vance Shipley
Sent: Wednesday, May 17, 2017 3:40 PM
To: prabath weerasinghe <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Sigtran] How to identify which TCAP user a PDU belongs to

--
     -Vance
_______________________________________________
Sigtran mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sigtran
"DISCLAIMER: This message is proprietary to Aricent and is intended solely for the use of the individual to whom it is addressed. It may contain privileged or confidential information and should not be circulated or used for any purpose other than for what it is intended. If you have received this message in error, please notify the originator immediately. If you are not the intended recipient, you are notified that you are strictly prohibited from using, copying, altering, or disclosing the contents of this message. Aricent accepts no responsibility for loss or damage arising from the use of the information transmitted by this email including damage from virus."

--
Prabath Weerasinghe
Department of Electrical Engineering
University of Moratuwa
Blog-psawtechtalks.blogspot.com<http://psawtechtalks.blogspot.com/>

---

From: prabath weerasinghe <[email-masked]>
Date: Wed, 17 May 2017 16:44:07 +0530

Hi Deepak/Vance,

Thanks again for the help.

Thanks and Regards,

On Wed, May 17, 2017 at 4:21 PM, Deepak Gunjal <[email-masked]>
wrote:

> That seems to be custom solution if something of this sort happens. The
> standards provide these mechanisms to enable interoperability between
> different implementation but if that is not followed then it falls to
> private agreement between different partners on how these kind of scenarios
> shall be handled.
>
>
>
> *From:* prabath weerasinghe [mailto:[email-masked]]
> *Sent:* Wednesday, May 17, 2017 4:06 PM
> *To:* Deepak Gunjal <[email-masked]>
> *Cc:* Vance Shipley <[email-masked]>; [email-masked]
>
> *Subject:* Re: [Sigtran] How to identify which TCAP user a PDU belongs to
>
>
>
> Hi Deepak and Vance,
>
>
>

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Wed, 17 May 2017 04:53:58 -0600

prabath,

Yes, SSN identifies the SCCP-User which is either INAP or CAMEL,
but not both.

Brian

prabath weerasinghe wrote:                  (Wed, 17 May 2017 14:47:02)
>    Hi All,Â
>    way to distinguish INAP and CAMEL calls in the TCAP layer ?Â
>    Thanks and Regards,
>    --
>    Prabath Weerasinghe
>    This email and any attachments are intended only for the person or
>    entity to whom it is addressed. Its contents may be privileged,
>    confidential or otherwise protected from disclosure. If you are not the
>    intended recipient, please do not read, disclose, distribute or copy
>    this email or use the information therein or act or omit to act in
>    reliance thereof. Please also inform the sender of erroneous receipt
>    and delete the material from your system.

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.com/