Subject: [Sigtran] M3UA Recovery after Heart beat loss detection

From: Suchetha P <[email-masked]>
Date: Tue, 23 Jan 2018 04:24:33 +0000 (UTC)

Hi,
When M3UA Heart beat loss is detected at local node due BEAT ack  not received for the BEAT message sent and Heart beat timer times out it makes the ASP  down locally.Currently there seems to be no action take when the M3UA layer makes the ASP  down. The local node does not  send any message towards the core network for bringing up the ASP.So I would like to know once ASP is down due to HB lost at M3UA layer then how does the local node recover the M3UA layer ? 
Best Regards,Suchetha

---

From: Suchetha P <[email-masked]>
Date: Tue, 23 Jan 2018 06:20:20 +0000 (UTC)

Hi,
Could some one please reply as soon as possible.Appreciate your help.
Best Regards,Suchetha

    On Tuesday, January 23, 2018 9:54 AM, Suchetha P <[email-masked]> wrote:

Hi,

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Jan 2018 08:03:35 -0700

Suchetha,

Suchetha P wrote:                       (Tue, 23 Jan 2018 06:20:20)
>    Best Regards,
>    Suchetha
>    When M3UA Heart beat loss is detected at local node due BEAT ack  not
>    received for the BEAT message sent and Heart beat timer times out it
>    makes the ASP  down locally.
>    Currently there seems to be no action take when the M3UA layer makes
>    the ASP  down. The local node does not  send any message towards the
>    core network for bringing up the ASP.
>    So I would like to know once ASP is down due to HB lost at M3UA layer
>    then how does the local node recover the M3UA layer ?
> 

Nobody uses M3UA BEAT much, because it is optional and ETSI
prescribes against it.

However, don't you think that the "local" system should either
send an ASP UP or drop the SCTP association and start again?

>    Best Regards,
>    Suchetha

> _______________________________________________
> Sigtran mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sigtran

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.com/

---

From: Suchetha P <[email-masked]>
Date: Tue, 23 Jan 2018 15:37:13 +0000 (UTC)

Hi Brian,
Thanks for your response.I see that the "local" system is not initiating ASP UP message nor aborting the association.Inorder to recover  from the ASP down state the "local system" expects M3UA BEAT,ASP UP messages from the peer which the peer is not initiating.The M3UA Heat beat mechanism needs to be enabled at both the ends isn't it ?I see that the M3UA Heart beat is disabled at the remote end resulting in no response from the peer for the BEAT message sent by the "local system".If M3UA Heart beat was enabled at the remote end then on receiving BEAT from the remote node "loca system" would have responded with BEAT ACK resulting in ASP UP.

Best Regards,Suchetha 

    On Tuesday, January 23, 2018 8:33 PM, Brian F. G. Bidulock <[email-masked]> wrote:

 Suchetha,

-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.com/

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Tue, 23 Jan 2018 08:41:54 -0700

Suchetha,

Suchetha P wrote:                     (Tue, 23 Jan 2018 15:37:13)
>    Hi Brian,
>    Thanks for your response.
>    I see that the "local" system is not initiating ASP UP message nor
>    aborting the association.
>    Inorder to recover  from the ASP down state the "local system" expects
>    M3UA BEAT,ASP UP messages from the peer which the peer is not
>    initiating.
>    The M3UA Heat beat mechanism needs to be enabled at both the ends isn't
>    it ?
>    I see that the M3UA Heart beat is disabled at the remote end resulting
>    in no response from the peer for the BEAT message sent by the "local
>    system".
>    If M3UA Heart beat was enabled at the remote end then on receiving BEAT
>    from the remote node "loca system" would have responded with BEAT ACK
>    resulting in ASP UP.

Just turn it off on both ends.
.
-- 
Brian F. G. Bidulock
[email-masked]
http://www.openss7.com/