Subject: [Simple] mobile IM interoperability

From: "Paul Golding" <[email-masked]>
Date: Fri, 09 Sep 2005 16:09:49 +0000 (UTC)

Dear SIMPLE Experts,

I am conducting an analysis of IM interoperability between mobile network operators. I am looking at XMPP/SIMPLE/IMPS and assessing possible levels of interoperability from a services perspective (i.e. which feature set is possible and that would satisfy minimal operator commercial requirements). This work is being carried out for a global operator consortium in order to identify gaps that could be addressed to ensure a smooth path for interoperability, which is key to widespread adoption.

I have already looked at basic interoperability, but some issues remain unclear. Perhaps some of you can help.

I would like to know how a "typical" SIMPLE implementation works in terms of "adding contacts" i.e. User A adds User B as a contact. I have the following questions:

1. Is presence subscription (SIP SUBSCRIBE) usually an integral part of such a process (along with putting User B in a contact list somewhere)?
2. Is this (SIP SUBSCRIBE) actually how User B is informed of User A's interest in establishing future IM communications?
3. Will User B's acceptance (manual or automatic) of the subscription request usually trigger a reciprocal subscription (to User A's presence)?
4. Is there any way to validate that User B actually exists on the target server without performing a SIP SUBSCRIBE?
5. Does SIMPLE directly support a means by which User B could be found via his/her mobile (cell) number and then subsequently dealt with via his/her SIP URI?
6. In addition to the above process, is there a way to (one-time) poll a user's presence state without subscribing to it?

Thank you in advance
Kind Regards
Paul G.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 22 Sep 2005 13:40:09 -0400

Sorry for the delay; some answers inline.

Paul Golding wrote:

> Dear SIMPLE Experts,
> 
> I am conducting an analysis of IM interoperability between mobile
> network operators. I am looking at XMPP/SIMPLE/IMPS and assessing
> possible levels of interoperability from a services perspective (i.e.
> which feature set is possible and that would satisfy minimal operator
> commercial requirements). This work is being carried out for a global
> operator consortium in order to identify gaps that could be addressed
> to ensure a smooth path for interoperability, which is key to
> widespread adoption.
> 
> I have already looked at basic interoperability, but some issues
> remain unclear. Perhaps some of you can help.
> 
> I would like to know how a "typical" SIMPLE implementation works in
> terms of "adding contacts" i.e. User A adds User B as a contact. I
> have the following questions:
> 
> 1. Is presence subscription (SIP SUBSCRIBE) usually an integral part
> of such a process (along with putting User B in a contact list
> somewhere)? 

No. This is done through xcap and the resource lists XML schemas:

http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-07.txt
http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-list-usage-05.txt

2. Is this (SIP SUBSCRIBE) actually how User B is
> informed of User A's interest in establishing future IM
> communications?

Presence and IM are not combined together in the SIMPLE model. A 
subscribe from user A to user B indicates to user B that user A wishes 
to find out about user B's availability for a variety of communications, 
not just IM.

  3. Will User B's acceptance (manual or automatic) of
> the subscription request usually trigger a reciprocal subscription
> (to User A's presence)?

That is an implementation choice. The protocols do not require it.

> 4. Is there any way to validate that User B
> actually exists on the target server without performing a SIP
> SUBSCRIBE?

SUBSCRIBE is the best way; it will be rejected witha  404 if the user 
doesn't exist.

  5. Does SIMPLE directly support a means by which User B
> could be found via his/her mobile (cell) number and then subsequently
> dealt with via his/her SIP URI?

This is the realm of technologies like enum. There is an enum service 
that allows a phone number to be looked up in the DNS, in order to find 
a presence server for that number. See:

http://www.ietf.org/rfc/rfc3953.txt

  6. In addition to the above process,
> is there a way to (one-time) poll a user's presence state without
> subscribing to it?

Yes, that is done with a SUBSCRIBE that contains an Expires header field 
with value 0.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com