Subject: Re: [Simple] contact blocking

From: Paul Kyzivat <[email-masked]>
Date: Thu, 29 Sep 2005 09:37:27 -0400

Paul Golding wrote:
> Dear Paul,
> 
> Thanks for your reply. I realise that my email was ambiguous (with the word
> "contact")....
> 
> The need is for a roaming IM user to block selectively any (or all) of his
> buddies (who may or may not be roaming themselves, but that is not the
> issue). The motivation is to control costs where the roaming user is
> required to pay roaming charges to send/receive mobile data from his device.
> In effect, when roaming, the user would appear "offline" to those buddies
> who were marked as "block whilst I roam" (for want of a better state name).
> 
> Assume that the PS would know that the user is roaming via some kind of
> back-end interface (which might be to an HLR or some other core-network
> apparatus in a mobile network).

As long as something can publish status indicating the roaming status of 
the device, this should be straightforward. The presence tuple for the 
UA, with its contact, indicates the device. The device status indicates 
roaming or not. The compositor puts that altogether, and then the 
filtering of the output, conditioned by who it is going to and the 
roaming state of the device, constrains what the watcher gets.

All you need is your "roaming" status as a device attribute.

(Actually, it sounds like what you really need is an "expensive calls" 
status. Maybe it will also apply when you have exceeded your allotted 
minutes for the month.)

	Paul

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: 26 September 2005 16:15
> To: Paul Golding
> Cc: [email-masked]
> Subject: Re: [Simple] contact blocking
> 
> 
> 
> Paul Golding wrote:
> 
>>In the case of mobile users, it would be desirable to have a flag to
>>indicate contact blocking is required whenever the user is roaming (to
>>control IM usage where roaming charges might otherwise be prohibitive).
>>
>>This flag "block contact when roaming" should be settable on a per user
>>basis, or globally.
> 
> 
> Block when *who* is roaming? The device whose contact it is? Or the watcher?
> 
> How would the PS know?
> 
> If you don't want your contact given to people when you are roaming, you 
> can just not publish it.
> 
> Or is it that when roaming, you only want to publish your contact to 
> certain people - those that you are willing to pay a premium to talk to?
> 
> You could publish your contact with an attribute indicating that you are 
> roaming. And then you could have rules, based on that attribute, about 
> who to publish it to.
> 
> 	Paul K
> 
> 
>>Am I right in thinking that one solution would be an additional state in
> 
> the
> 
>><sub-handling> field for processing presence rules?
>>
>>-Paul G
>>
>>-----Original Message-----
>>From: [email-masked] [mailto:[email-masked]] On Behalf
> 
> Of
> 
>>Jonathan Rosenberg
>>Sent: 22 September 2005 18:36
>>To: Qian Sun
>>Cc: [email-masked]
>>Subject: Re: [Simple] contact blocking
>>
>>Right now, you cannot. This is a capability we have been discussing 
>>within the context of advanced composition policies, and is not 
>>something you can currently control via the authroization document 
>>format. I just posted on this in a separate thread.
>>
>>-Jonathan R.
>>
>>Qian Sun wrote:
>>
>>
>>
>>>But  how can I appear "happy" to a particular contact, and appear "angry"
>>
>>to others?
>>
>>
>>>Best Regards     
>>>Qian Sun
>>>Application & Software Dept.
>>>Huawei Technologies Co., Ltd
>>>
>>>--------------------------------------------------
>>>Phone: +86 755 28979564
>>>Email: [email-masked]
>>>--------------------------------------------------
>>>
>>>----- Original Message ----- 
>>>From: "Jonathan Rosenberg" <[email-masked]>
>>>To: "Paul Golding" <[email-masked]>
>>>Cc: <[email-masked]>
>>>Sent: Monday, September 19, 2005 9:16 PM
>>>Subject: Re: [Simple] contact blocking
>>>
>>>
>>>
>>>
>>>
>>>>You would use xcap to manipulate a presence authorization document 
>>>>(http://www.ietf.org/internet-drafts/draft-ietf-simple-presence-rules-03.
> 
> t
> 
>>xt) 
>>
>>
>>>>and include a rule that matches that particular watcher. The rule would 
>>>>have a <sub-handling> of polite-block.
>>>>
>>>>-Jonathan R.
>>>>
>>>>Paul Golding wrote:
>>>>
>>>>
>>>>
>>>>>Hi All,
>>>>>
>>>>>Could anyone tell me how contact blocking is achieved with SIMPLE? In
>>
>>other
>>
>>
>>>>>words, how can I appear "offline" to a particular contact, but not to
>>>>>everyone?
>>>>>
>>>>>Many thanks
>>>>>Paul G.
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>_______________________________________________
>>>>>Simple mailing list
>>>>>[email-masked]
>>>>>https://www1.ietf.org/mailman/listinfo/simple
>>>>>
>>>>
>>>>-- 
>>>>Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
>>>>Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
>>>>Cisco Systems
>>>>[email-masked]                              FAX:   (973) 952-5050
>>>>http://www.jdrosen.net                         PHONE: (973) 952-5000
>>>>http://www.cisco.com
>>>>
>>>>_______________________________________________
>>>>Simple mailing list
>>>>[email-masked]
>>>>https://www1.ietf.org/mailman/listinfo/simple
>>>
>>>
> 
> 

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Dean Willis <[email-masked]>
Date: Thu, 29 Sep 2005 17:00:15 -0500

On Sep 29, 2005, at 8:37 AM, Paul Kyzivat wrote:

> (Actually, it sounds like what you really need is an "expensive  
> calls" status. Maybe it will also apply when you have exceeded your  
> allotted minutes for the month.)

Remember Dr. McCoy's sick bay on Star Trek?

When he had somebody on the operating table, he had this nifty little  
bar graph he could point to and say "But Jim, he's experiencing 437%  
of the human capacity for pain right now!"

That's what we need.

I think we can solve a lot of this by having a pain threshold  
indicator in RPID.

"Don't bother me, kid. I hurt all over, and it might be caused by  
those damnable roaming charges. Or the bottle of Jose Cuervo I drank  
last night. Whatever. But I'm at a 50% pain threshold and if you  
call, it'd better be important".

The next thing to do is build a service that automatically notifies  
other carriers that you're ripe for poaching when your pain threshold  
hits 98% . . . and legislation that justifies you killing them in  
self defense.

--
Dean (not in an official capacity)