Subject: Re: [Simple] Merging PIDF documents from multiple sources

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 01 May 2006 15:26:24 -0400

Right. It was agreed also to revive this draft as a new SIMPLE item; 
I'll be updating and resubmitting before the next meeting.

To answer your specific questions, see inline:

Drage, Keith (Keith) wrote:

> I believe this was intended to be covered by:
>  
> draft-rosenberg-simple-presence-processing-model-01.txt
>  
> which expired in February and is therefore no longer on the i-d area.
>  
> It can however be found here:
>  
> http://www.softarmor.com/wgdb/docs/draft-rosenberg-simple-presence-processing-model-01.txt
>  
> regards
>  
> Keith
> 
>     -----Original Message-----
>     *From:* Noga Tor [mailto:[email-masked]]
>     *Sent:* 27 April 2006 12:52
>     *To:* [email-masked]
>     *Subject:* [Simple] Merging PIDF documents from multiple sources
> 
>     Hi
> 
>     Im trying to understand what should be the strategy when merging
>     doucments that were published from different sources.
> 
>     Should all published person\tuple\device elements be sent to the
>     Watcher as received?

You are free to do whatever you like. You can merge them, or you can 
send each piece of information without modifying it at all. The presence 
data model allows for multiple tuple, person or device elements to refer 
to the same thing, in which case they are differentiated with the 
instance ID. The primary application of that is presence servers which 
do not perform composition.

> 
>     Or should a merge strategy be implemented?

Generally I think thats a better idea, but its an implementation choice.

> 
>     How should the Notify message look like? (assuming the watcher did
>     not add any filters to the subscription)

Depends on your composition policy.

> 
>     Should it contain all the published elements? (multiple
>     person/device elements)

Again see above. If you do decide not to merge, you MUST ensure that all 
tuples, person and devices referring to the same thing have different 
instance ID.

>      
>     Or should it contain merged publish elements? (one person/device
>     element)
> 
>     Or should it contain just the last published elements? (one
>     person/device element)

Again, local choice. The data model draft talks about the fact that, 
when multiple elements are preent which refer to the same thing, a 
common and reasonable strategy at the watcher is to take the most 
recently published one (based on timestamp).

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

ly when dealing with
>>>>>>     "multipart" MIME messages (i.e. documents which have been split
>>>>>>     up into multiple messages), so check your local documentation on
>>>>>>     how to manipulate these messages.
>>>>>>        Below is the data which will enable a MIME compliant mail 
>>>>>> reader
>>>>>> implementation to automatically retrieve the ASCII version of the
>>>>>> Internet-Draft.
>>>>>> Content-Type: text/plain
>>>>>> Content-ID: <[email-masked]>
>>>>>>
>>>>>> _______________________________________________
>>>>>> Simple mailing list
>>>>>> [email-masked]
>>>>>> https://www1.ietf.org/mailman/listinfo/simple
>>>>>
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Simple mailing list
>>>>> [email-masked]
>>>>> https://www1.ietf.org/mailman/listinfo/simple
>>>>
>>>>
>>>>
>>>> _______________________________________________
>>>> Simple mailing list
>>>> [email-masked]
>>>> https://www1.ietf.org/mailman/listinfo/simple
>>>
>>>
>>> -- 
>>> =====================================================================
>>> Josh Littlefield                                  Cisco Systems, Inc.
>>> [email-masked]                             1414 Massachusetts Avenue
>>> tel: 978-936-1379  fax: 978-936-2226       Boxborough, MA  01719-2205
>>>
>>> _______________________________________________
>>> Simple mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/simple 
> 
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 01 May 2006 15:26:24 -0400

Thanks,
Jonathan R.

---

From: "Noga Tor" <[email-masked]>
Date: Tue, 2 May 2006 12:25:13 +0300

Thanks for the answers.

Although the draft document does not contain the answers to my question
(what should be the server's default policy) since in the specific chapter
that interested me it said: "TODO: place default policy here"

I did undertand though from Jonathan's reply that there is no answer and
that it is open to various types of implementation.