Subject: [Simple]Two questions about MSRP REPORT's byte range.

From: "Xiang Ting" <[email-masked]>
Date: Mon, 29 May 2006 22:09:12 +0800

In recent MSRP draft: draft-ietf-simple-message-sessions-14, page 25:
   If the Success-Report header field was set to "yes", then when a
   complete message has been received, the receiver MUST send a success
   REPORT with a byte range covering the whole message.  If the Success-
   Report header field is set to "yes", then the receiver MAY generate
   incremental success REPORTs as the chunks are received.  These can be
   sent periodically and cover all the bytes that have been received so
   far, or they can be sent after a chunk arrives and cover just the
   part from that chunk.

Question 1:
The statement force a REPORT need include a Byte-Range header, but the
REPORT example (page 41) in this draft does not include such a header,
as following:
   MSRP dkei38sd REPORT
   To-Path: msrp://alicepc.example.com:7777/iau39;tcp
   From-Path: msrp://bob.example.com:8888/9di4ea;tcp
   Message-ID: 12339sdqwer
   Status: 000 200 OK
   -------dkei38sd$
Is it conflict with protocol?

Question 2:
If a Byte-Range header is a must, how to send REPORT to an SEND
requeste with empty body, such as:
MSRP tid1234 SEND
From-Path: msrp://alice.exampel.com:7777/dfafw3r34;tcp
To-Path: msrp://bob.example.com:8888/e4w3rw34;tcp
Message-ID: sfwe4rw3sdf
Successful-Report: yes
-------tid1234$

I think the REPORT maybe like following:
   MSRP dkei38sdw REPORT
   From-Path: msrp://alice.exampel.com:7777/dfafw3r34;tcp
   To-Path: msrp://bob.example.com:8888/e4w3rw34;tcp
   Message-ID: sfwe4rw3sdf
   Byte-Range: 0-0/0
   Status: 000 200 OK
   -------dkei38sdw$
but the protocol say that the byte-range must start from 1, how to
solve this conflict?

Any reply is appreciated.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 29 May 2006 08:07:10 -0700

Adam - question for you inline ...

Xiang - good questions - thanks.

> Is it conflict with protocol?

This looks like a mistake - I think the example needs a Byte-Range  
header. Thanks for finding this.

> but the protocol say that the byte-range must start from 1, how to

I suspect this should be
Byte-Range: 1-0/0

Adam, can you confirm this looks right to you?