Subject: [Simple]How does MSRP support NAT traversal?

From: "Xiang Ting" <[email-masked]>
Date: Tue, 23 May 2006 23:18:19 +0800

In IPv4 based IMS core network, how does an UE communicate with
another UE which behind a NAT?
Does some MSRP relay need?
Which one act as a active connection role?

Thanks.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 23 May 2006 08:41:25 -0700

See draft-ietf-simple-msrp-relays-07.txt

thanks,
-rohan

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 24 May 2006 07:53:00 -0700

> See draft-ietf-simple-msrp-relays-07.txt

Isn't possible to use draft-ietf-mmusic-ice-tcp-00 for this?

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 24 May 2006 08:59:01 -0700

Hi Marc,

It was specifically a non-goal of MSRP to use a TURN server for MSRP 
traffic.

thanks,
-rohan

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 24 May 2006 11:02:07 -0700

> It was specifically a non-goal of MSRP to use a TURN server for MSRP

I understand, but what technically prevent doing NAT traversal for MSRP
with a TCP TURN server?

---

From: <[email-masked]>
Date: Wed, 24 May 2006 21:29:17 +0300

Hi, 

>-----Original Message-----
>From: ext Marc Petit-Huguenin [mailto:[email-masked]] 
>Sent: 24 May, 2006 21:02
>To: Rohan Mahy
>Cc: Cullen Jennings; Paul Kyzivat; simple
>Subject: Re: [Simple]How does MSRP support NAT traversal?
>
>Rohan Mahy wrote:
>> Hi Marc,
>> 
>I understand, but what technically prevent doing NAT traversal 
>for MSRP with a TCP TURN server?
>

Good question, I have been wondering the same. If TURN relays start to be available (I hope they do, although I haven't heard about such a thing), it would make sense to run MSRP through TURN instead of introducing separate MSRP specific relays. There may be other reasons to use MSRP relays, but the pure NAT traversal should be based on something more generic.  

Regards,
	Markus

----------------------------
Markus Isomäki
[email-masked]
----------------------------

---

From: Cullen Jennings <[email-masked]>
Date: Wed, 24 May 2006 16:54:51 -0700

I can imagine that it might be possible to set up a MSRP session over  
TURN or over STUNT. I've not checked the details of this being  
possible but seems like it might work. Keep in mind TLS won't work  
very well with TURN.

On May 24, 2006, at 11:29 AM, <[email-masked]>  
<[email-masked]> wrote:

> Good question, I have been wondering the same. If TURN relays start  
> to be available (I hope they do, although I haven't heard about  
> such a thing), it would make sense to run MSRP through TURN instead  
> of introducing separate MSRP specific relays. There may be other  
> reasons to use MSRP relays, but the pure NAT traversal should be  
> based on something more generic.
>
> Regards,
> 	Markus
>