Subject: [Simple] IM rules

From: "Alexeitsev, D" <[email-masked]>
Date: Tue, 28 Nov 2006 11:47:56 +0100

Hello All

Can anyone comment on the SIMPLE way of policing the IM communication?

Different organisations, foras are currently defining their own
solutions for the issue, that obviously leads to the interoperability
problems.

Which one of the listed or not listed options is the SIMPLE IM policing?

A) use of the consent framework

B) extension of the common policy, as OMA does: 

<?xml version="1.0" encoding="UTF-8"?>
<ruleset xmlns="urn:ietf:params:xml:ns:common-policy"
xmlns:poc="urn:oma:xml:poc:poc-rules"
   xmlns:ocp="urn:oma:xml:xdm:common-policy">
   xmlns:cme="urn:oma:xml:xdm:commonpol-media-ext">
  <rule id="m3s47b0">
    <conditions>
      <identity>
        <one id="tel:+1-212-555-1234"/>
        <one id="sip:[email-masked]"/>
      </identity>
      <cme:media>
->     <cme:message-session/> 
->     <cme:pager-mode-message/>
        <cme:file-transfer/>
        <cme:group-advertisement/>
      </cme:media>
    </conditions>
    <actions>
      <poc:allow-invite>accept</poc:allow-invite>      
    </actions>
  </rule>

C) use of CPL to police 

Greetings,
Denis Alexeitsev
_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 28 Nov 2006 07:51:43 -0600

The SIMPLE wg has not defined any standard rules for policing IM per  
se. There has been a lot of work on defining rules for presence.

The difference is that presence, by it's nature, is assumed to be  
often delivered by an element in the network, and there must be a way  
for a presentity to express policy to that element about what  
presence to deliver to whom. While this may be the case in certain  
particular networks for IM, it is not assumed to be true in the  
general sense.

On Nov 28, 2006, at 4:47 AM, Alexeitsev, D wrote:

> solutions for the issue, that obviously leads to the  
> interoperability problems.
>