Subject: Re: [Simple] WGLC MSRP ACM Security Considerations [was: RE: WGLC of msrp-acm and msrp-sessionmatch - Ben's comments]

From: Ben Campbell <[email-masked]>
Date: Tue, 2 Feb 2010 15:25:29 -0600

On Jan 26, 2010, at 3:19 AM, Christer Holmberg wrote:

> 
> What about the following text?
> 
> ---------
> 
> According to the connection model defined in [RFC4975], the MSRP UA which sends the SDP offer is the "active", ", and it is responsible for creating the MSRP transport
> connection towards the remote UA if a new connection is required. The "active" UA also takes the role as TLS client, if TLS is used to protect the MSRP messages.
> 
> When COMEDIA is used, either the sender or the receiver of the SDP offer can become "active", and therefor also take the role as TLS client. However, there are no procedures in
> [RFC4975] that would break in case the receiver of the SDP offerer takes the role as TLS client, and the level of security provided by TLS is not affected."

I think that's a good start. I propose adding the following sentence between the first and second sentence of your second paragraph:

"The TLS client is responsible for matching the server's certificate to the peer's MSRP URI regardless of whether the it acted as the SDP offerer or answerer."

I also suggest this additional paragraph, either before or after the TLS parts:

"RFC 4975 requires the active party to immediately issue a SEND request once the connection is established. This allows the passive party to bind the inbound TCP connection to the message session identified by its MSRP URI. The use of COMEDIA does not change this requirement. However, the active party is no longer assumed to be the SDP offerer. "

> 
> ---------
> 
> Regards,
> 
> Christer
> 
> 
> 
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of Christer Holmberg
>> Sent: 25. tammikuuta 2010 15:45
>> To: Ben Campbell
>> Cc: Simple WG
>> Subject: [Simple] WGLC MSRP ACM Security Considerations [was: 
>> RE: WGLC of msrp-acm and msrp-sessionmatch - Ben's comments]
>> 
>> 
>> Hi,
>> 
>> Sorry, forgot to remove some text, in order to make it more clear.
>> 
>>>> If we don't use COMEDIA-TLS, but simply refer to 4975 for 
>> TLS, I guess there shouldn't be any issues. Or?
>>>> 
>>> I think there may be some language in the security consideration 
>>> section of 4975 concerning how you match the certificate to 
>> the server 
>>> that we need to check to make sure it does not contain assumptions 
>>> about which party is client or server.
>>> 
>> 
>> I was reading the security considerations of 4975, and didn't 
>> find any such assumptions.
>> 
>> The text generally talks about sending the fingerprint in 
>> SDP, but I can't find any specific assumptions.
>> 
>> Regards,
>> 
>> Christer
>> _______________________________________________
>> Simple mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/simple
>> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 2 Feb 2010 22:57:12 +0100

Hi,

Your text looks ok, but let's get back to this one once we've figured out whether we need to reference 4572 or not (see other thread).

Regards,

Christer

________________________________________
From: Ben Campbell [[email-masked]]
Sent: Tuesday, February 02, 2010 11:25 PM
To: Christer Holmberg
Cc: Simple WG
Subject: Re: [Simple] WGLC MSRP ACM Security Considerations [was: RE: WGLC of msrp-acm and msrp-sessionmatch - Ben's comments]