Subject: Re: [Simple] Fwd: New Version Notification for draft-ietf-simple-chat-07

From: Ben Campbell <[email-masked]>
Date: Tue, 10 Aug 2010 14:41:46 -0500

Hi all,

This version was submitted back in May, but we've had no further list discussion on it. For those who commented in, or since, the last WGLC, does this version address your feedback?

Thanks!

Ben.

On May 31, 2010, at 2:51 AM, Miguel A. Garcia wrote:

> I have just submitted a new version of the MSRP chat draft. These are the changes:
> 
> - Clarified that acquisition of anonymous URIs is outside the scope of the document.
> 
> - Clarified that private messages can only be sent to one and only one recipient. It implies a single To header in the CPIM wrapper.
> 
> - Clarified that one SIP dialog maps to a one MSRP session that in turn maps to one chat room.
> 
> - Clarified that the sender of regular messages can choose the reporting model.
> 
> - Procedures for the MSRP switch to reject messages containing more than a single To header in the CPIM wrapper.
> 
> - Changed the report model in private message to make it equal to regular messages (so, the report considers only the leg from the user to the MSRP switch).
> 
> - Procedures for the MSRP switch to verify that the recipient of a private message is still a participant in the conference.
> 
> - Clarified that if an intermediary modifies the To header of the CPIM wrapper, the MSRP switch will discard the message.
> 
> - Improved IANA Considerations section.
> 
> - A number of editorial changes.
> 
> 
> Please review it and comment it.
> 
> /Miguel
> 
> 
> 
> -------- Original Message --------
> Subject: New Version Notification for draft-ietf-simple-chat-07
> Date: Mon, 31 May 2010 09:38:08 +0200
> From: IETF I-D Submission Tool <[email-masked]>
> To: Miguel Garcia A <[email-masked]>
> CC: [email-masked] <[email-masked]>, [email-masked] <[email-masked]>
> 
> 
> A new version of I-D, draft-ietf-simple-chat-07.txt has been successfully submitted by Miguel Garcia and posted to the IETF repository.
> 
> Filename:	 draft-ietf-simple-chat
> Revision:	 07
> Title:		 Multi-party Chat Using the Message Session Relay Protocol (MSRP)
> Creation_date:	 2010-05-31
> WG ID:		 simple
> Number_of_pages: 32
> 
> Abstract:
> The Message Session Relay Protocol (MSRP) defines a mechanism for
> sending instant messages within a peer-to-peer session, negotiated
> using the Session Initiation Protocol (SIP) and the Session
> Description Protocol (SDP).  This document defines the necessary
> tools for establishing multi-party chat sessions, or chat rooms,
> using MSRP.
> 
> 
> 
> The IETF Secretariat.
> 
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 24 Aug 2010 16:45:03 -0500

Hi All, 

There's been no response or comments on this SIMPLE list in the last two weeks. Is the work group still interested in this draft?

Thanks!

Ben.

---

From: Adrian Georgescu <[email-masked]>
Date: Wed, 25 Aug 2010 01:36:16 +0200

The draft seem to address all relevant concerns raised so far. It looks very good.

Regards,
Adrian

---

From: "Geir Arne Sandbakken" <[email-masked]>
Date: Wed, 25 Aug 2010 10:17:51 +0200

Miguel's last revision addressed all the open issues that I was aware of
from version 6.

Thanks,
Geir A

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: 24. august 2010 23:45
> To: Ben Campbell; Simple WG
> Cc: Miguel A. Garcia; Geir Arne Sandbakken; Hisham Khartabil; Gonzalo
> Camarillo
> Subject: Re: [Simple] Fwd: New Version Notification for draft-ietf-
> simple-chat-07
> 
> Hi All,
> 
> There's been no response or comments on this SIMPLE list in the last
> two weeks. Is the work group still interested in this draft?
> 
> Thanks!
> 
> Ben.
> 
> > This version was submitted back in May, but we've had no further
list
> discussion on it. For those who commented in, or since, the last WGLC,
> does this version address your feedback?
> >
> > Thanks!
> >
> > Ben.
> >
> >> - Clarified that private messages can only be sent to one and only
> one recipient. It implies a single To header in the CPIM wrapper.
> >>
> >> - Procedures for the MSRP switch to reject messages containing more
> than a single To header in the CPIM wrapper.
> >>
> >> - Changed the report model in private message to make it equal to
> regular messages (so, the report considers only the leg from the user
> to the MSRP switch).
> >>
> >> - Procedures for the MSRP switch to verify that the recipient of a
> private message is still a participant in the conference.
> >>
> >> - Clarified that if an intermediary modifies the To header of the
> CPIM wrapper, the MSRP switch will discard the message.
> >>
> >> CC: [email-masked] <[email-masked]>,
> [email-masked] <[email-masked]>
> >>
> >>
> >> A new version of I-D, draft-ietf-simple-chat-07.txt has been
> successfully submitted by Miguel Garcia and posted to the IETF
> repository.
> >>
> >> Title:		 Multi-party Chat Using the Message Session
Relay
> Protocol (MSRP)