Subject: Re: [sip-clf] sipclf-problem-statement-03 released

From: Cullen Jennings <[email-masked]>
Date: Fri, 9 Jul 2010 07:33:06 -0600

Looks like this is getting close to done.

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Sat, 10 Jul 2010 18:54:28 -0400

All - 

I have uploaded the -01 version of the indexed-ASCII draft. 

This primary addition to this version is the addition of an Example Record section.

The -01 version is available at:

http://www.ietf.org/internet-drafts/draft-salgueiro-sipclf-indexed-ascii-01.txt

Regards,

Gonzalo

On Jun 29, 2010, at 7:10 PM, Gonzalo Salgueiro wrote:

> All - 
> 
> I have uploaded the initial version of the indexed-ASCII implementation draft. 
> This draft attempts to line up with the data model proposed in the SIPCLF Problem Statement draft.
> 
> Please note that this work was expedited in an attempt to get this draft submitted prior to the -00 draft cutoff deadline.
> I intend to add a section with an example record using the syntax proposed in the draft. 
> 
> The -00 version is available at:
> http://www.ietf.org/id/draft-salgueiro-sipclf-indexed-ascii-00.txt
> 
> Thanks,
> 
> Gonzalo
> 
> On Jun 29, 2010, at 1:59 PM, Vijay K. Gurbani wrote:
> 
>> All: Based on the comments in the list discussion [1], I
>> have released a new version of the sipclf problem-statement.
>> 
>> The editor of the indexed-ASCII draft will be releasing an
>> initial version of the indexed-ASCII draft shortly using the
>> data model in the problem-statement.  I would like to draw
>> the attention of the IPFIX community to the data model
>> section of the sipclf-problem-statement draft so they can
>> produce a comparable draft for IPFIX as well.
>> 
>> The following are highlights of the changes in -03:
>> 
>> 1) Each SIP CLF line has the same canonical format (see
>> S8 of the draft.)
>> 
>> 2) Added a table (Table 1) that outlines how the mandatory
>> fields are logged by SIP entities.
>> 
>> 3) Added record length, type of message (request or response)
>> and directionality (send or receive) to the SIP CLF record.
>> 
>> 4) Various nits found by Peter Musgrave.
>> 
>> Peter had indicated that he would like to include a discussion
>> of message sizes in the document.  This version does not include
>> message size discussion (as yet.)
>> 
>> The -03 version is available at:
>> http://www.ietf.org/internet-drafts/draft-ietf-sipclf-problem-statement-03.txt
>> 
>> A diff between -02 and -03 is at the following URL:
>> http://tools.ietf.org/rfcdiff?url2=draft-ietf-sipclf-problem-statement-03.txt
>> 
>> Thanks,
>> 
>> [1] http://www.ietf.org/mail-archive/web/sip-clf/current/msg00181.html
>> 
>> - vijay
>> -- 
>> Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
>> 1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
>> Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
>> Web:   http://ect.bell-labs.com/who/vkg/
>> _______________________________________________
>> sip-clf mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sip-clf
>

---

From: Benoit Claise <[email-masked]>
Date: Sun, 25 Jul 2010 19:00:11 +0200

Dear all,

I read this draft again, and I see a kind of discrepancy between
- the charter;

    - A problem statement enunciating the motivation,
    and use cases for a SIP Common Log Format. This analysis
    will identify the required minimal information that must
    appear in any record.

- the draft name, i.e "problem-statement"
- the draft title, which doesn't specify "problem statement" or 
"requirement"
- the draft content, with sentences such as:
     * "We propose a common log file format..."
     * "We limit our specification ..."

So this draft looks like a beginning of specifications to me.

Regards, Benoit.

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Sun, 25 Jul 2010 20:11:24 -0500

> - the draft title, which doesn't specify "problem statement" or

Benoit: If it helps to insert the phrase "Problem Statement", in
the title, I can certainly do that.  But I doubt that will
change substantively the content of the draft.  The main
contributions of the draft --- just as the charter says --- are
the motivation, use cases and the identification of the
required minimal information that must appear in any record.

> * "We propose a common log file format..."

I can change that to "We propose the need for a common
log file format and the required minimum data elements ...",
but again, I doubt that will substantially change the
contents of the draft.

> So this draft looks like a beginning of specifications to me.

I think we may have a different understanding of the term
"specification".  I believe you are interpreting this term
to mean a "solution", as in the draft is providing a solution
to the SIP CLF problem.  Rest assured, it is not.  In fact,
in the very same paragraph from which the above is quoted,
there occurs a sentence: "This document, however, does not
prescribe a specific representation format and it limits the
discussion to the mandatory data elements described above."

Thanks,

- vijay