Subject: Re: [sip-clf] [dispatch] Updated: draft-kaplan-dispatch-session-id-02

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 13 Jul 2010 13:24:46 -0500

On 07/13/2010 11:37 AM, Hadriel Kaplan wrote:
> There is a need for having a globally unique session identifier for the
> same SIP session, which can be consistently maintained across Proxies,
> B2BUAs and other SIP middle-boxes, for the purpose of Troubleshooting.
> This draft proposes a new SIP header to carry such a value: Session-ID.

 > A URL for this Internet-Draft is:
 > 
http://www.ietf.org/internet-drafts/draft-kaplan-dispatch-session-id-02.txt

Hadriel: I know are aware of this, but to point this work
out to the broader audience in the sipclf WG ... another use of
the Session-ID header can conceivably include the end-to-end
tracing of sessions that cross administrative domains.  We have
talked about this in the sipclf WG.

Session-ID can appear as one of the extension headers in the
SIP CLF record.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 13 Jul 2010 15:07:38 -0400

Yup, and we have it indicated as one of the recorded fields in the Ipfix-based sipclf I-D, in the draft-niccolini-sipclf-ipfix-03. (though of course that's just a strawman list of fields right now anyway)

-hadriel

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Tuesday, July 13, 2010 2:25 PM
> To: Hadriel Kaplan
> Cc: [email-masked]; [email-masked]
> Subject: Re: [dispatch] Updated: draft-kaplan-dispatch-session-id-02
>