Subject: [sip-clf] draft-ietf-sipclf-problem-statement-05 Reason-Phrase

From: Anders Nygren <[email-masked]>
Date: Tue, 15 Mar 2011 15:10:24 -0600

Hi
The list of mandatory fields includes Status-Code but not Reason-Phrase.
Wouldn't it be useful to have Reason-Phrase also since RFC3261

21.1.5 183 Session Progress

   The 183 (Session Progress) response is used to convey information
   about the progress of the call that is not otherwise classified.  The
   Reason-Phrase, header fields, or message body MAY be used to convey
   more details about the call progress.

21.4.1 400 Bad Request

   The request could not be understood due to malformed syntax.  The
   Reason-Phrase SHOULD identify the syntax problem in more detail, for
   example, "Missing Call-ID header field".

So at times Reason-Phrase gives some additional information that can not be
obtained from just the Status-Code. Maybe as an optional field.

/Anders

---

From: Peter Musgrave <[email-masked]>
Date: Tue, 15 Mar 2011 17:23:27 -0400

I think as a predefined option field Reason Phrase makes sense.

It may be worth thinking about other optional header fields people might want...Refer, History-Info, Session-ID - might become a bit of a long list. Would this be viewed as useful?

Peter (as individual)

On 2011-03-15, at 5:10 PM, Anders Nygren wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf

---

From: Anders Nygren <[email-masked]>
Date: Tue, 15 Mar 2011 15:32:01 -0600

> It may be worth thinking about other optional header fields people might want...Refer, History-Info, Session-ID - might become a bit of a long list. Would this be viewed as useful?

I don't have a list of header fields that I want to add, but I think
it may be good
to define most SIP headers as optional field just to prevent too many
vendors from
defining their own extensions for standard sip headers.

/Anders

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 15 Mar 2011 16:41:26 -0500

> Wouldn't it be useful to have Reason-Phrase also since RFC3261
[...]
> obtained from just the Status-Code. Maybe as an optional field.

Anders: I believe for the vast majority of the uses, a status-code
suffices (it gives you an accurate idea where in the transaction
machine a certain transaction is).

Reason-phrase is additional information, for sure, but it does
not detract from the knowledge gained earlier.

At this point, I don't see the need for it as an optional field
simply for the reason that this list could grow without bounds.

If an implementation wanted to produce a reason-phrase, the
vendor extension may be the best.  At least it will be visible and
a tool can parse and use the extension as intended.

If this is not agreeable, then we will have to rethink the
optional field logging to make it extensible to handle any SIP
header that an implementation may want to log instead of
picking and choosing some fields like Reason-phrase.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60566 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web:   http://ect.bell-labs.com/who/vkg/

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 15 Mar 2011 17:55:28 -0400

> It may be worth thinking about other optional header fields people might want...Refer, History-Info, Session-ID - might become a bit of a long list. Would this be viewed as useful?

I had it as one of the discussion topics for Prague. I think we fundamentally need to decide what fields we want as Pre-defined Optional Fields IF that list a reasonable one. If we want to open it up (as Anders suggest) to ALL SIP fields, then this would likely require a different mechanism entirely.

Gonzalo

---

From: Eric Burger <[email-masked]>
Date: Fri, 18 Mar 2011 14:33:09 -0400

Smells like an IANA registry...