Subject: [sip-clf] draft-ietf-sipclf-format-01, TLV Start Pointer

From: Anders Nygren <[email-masked]>
Date: Tue, 15 Mar 2011 12:02:41 -0600

Hi
When extracting the mandatory fields the length of one parameter can normally be
calculated by
Length = <Pointer To Next Parameter> - <Pointer To This Parameter> -1

However if there are no optional fields
"If the OPTIONAL TLV groups are not implemented, then the "TLV Start Pointer"
field MUST be set to zero (0x0000)."

But to calculate the length of <Client-Txn> You first have to check if
<TLV Start Pointer> = 0x0000 in which case the <Client-Txn> length
is
Length = <Record Length> - <Pointer To Client-Txn> -1

Similarly when extracting the TLVs it is necessary to do an extra test if
the <TLV Start Pointer> = 0x0000.

I would like to propose that in the case when there are no optional fields that
the <TLV Start Pointer> points to the 0x0A at the end of the record.

It is not a big complication but it will remove a couple of tests in a parser.

/Anders

---

From: Gonzalo Salgueiro <[email-masked]>
Date: Tue, 15 Mar 2011 15:15:02 -0400

If this simplifies getting the length of the final mandatory field (i.e Client-Txn), then I'm not opposed to having "TLV Start Pointer" point to the terminating line feed, rather than being set to all zeroes in the case of no optional fields.

Are others OK with this logic?

Gonzalo

On Mar 15, 2011, at 2:02 PM, Anders Nygren wrote:

> _______________________________________________
> sip-clf mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-clf

---

From: Peter Musgrave <[email-masked]>
Date: Tue, 15 Mar 2011 16:58:26 -0400

Works for me

Peter Musgrave
(as individual)