Subject: [sip-overload] Query

From: RahulSrivastava 71616 <[email-masked]>
Date: Mon, 19 Jul 2010 12:25:16 +0500

Hi All,
       Do we consider following sort of scenarios in this group? (From charter I got a bit of confusion)

Assume:
    PXY               UAS1                            UAS2
    -------INVITE---->
                    (UAS1 is overloaded and now call should go to UAS1)
    <-----3xx-------
         (UAS2 is not overloaded)

   --------------------------INVITE-------------------->
                            (Some inforamtion in INVITE is transferred reason being overloaded.)

Now UAS1 always knows UAS2 is not overloaded due to some internal mechanisms (non SIP mechanism). 
Query 1:
Will this group determine how UAS1 is overloaded and this information is going to be shared to UAS2 using a clean SIP mechanisms? (

Query 2:
A policy can be configured/passed (through SIP) among a group of SIP SERVERS (UAS) and a PXY so that each knows what sort of POLICY it supports.

Regards,
Rahul

******************************************************************************************
 This email and its attachments contain confidential information from HUAWEI, which is intended only for the person or entity whose address is listed above. Any use of the information contained here in any way (including, but not limited to, total or partial disclosure, reproduction, or dissemination) by persons other than the intended recipient(s) is prohibited. If you receive this email in error, please notify the sender by phone or email immediately and delete it!
 *****************************************************************************************

---

From: "Parthasarathi R (partr)" <[email-masked]>
Date: Fri, 23 Jul 2010 12:33:19 +0530

Hi Rahul,
 
Please read inline.
 
Thanks
Partha

________________________________

From: [email-masked] on behalf of RahulSrivastava 71616
Sent: Mon 7/19/2010 12:55 PM
To: [email-masked]
Subject: [sip-overload] Query

Hi All,

Assume:
    PXY               UAS1                            UAS2
    -------INVITE---->

<Partha> The proposed redirection callflow works only in case of few UAS. It is prepared to pass the overload feedback to Proxy and let proxy decide where to foward based on the load information in different UAS. This will simplify the solution and also scalable for load balancing based solution wherein the number of UAS in two digits. </Partha>

Query 2:

Regards,
Rahul

_______________________________________________
sip-overload mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sip-overload

---

From: RahulSrivastava 71616 <[email-masked]>
Date: Fri, 23 Jul 2010 15:46:28 +0500

One more doubt:

This requires UAS/proxy to be aware of source of incoming messages. But this topology might fit in if source of INVITEs are not known or can be huge.
Consider an example: P-CSCF which caters to so many PC terminals. How it informs clients its overloaded and forward it somewhere else?(or drop it) (Though 3xx-Contact which is arbiratry).
Does this WG addresses these problems or its fixed for a particular topoloy.

Regards,
Rahul

----- Original Message -----
From: "Parthasarathi R (partr)" <[email-masked]>
Date: Friday, July 23, 2010 12:34 pm
Subject: RE: [sip-overload] Query
To: RahulSrivastava 71616 <[email-masked]>, [email-masked]

>                    (UAS1 is overloaded and now call should go to 
> UAS1)    <-----3xx-------
>         (UAS2 is not overloaded)
> 
> Will this group determine how UAS1 is overloaded and this 
> information is going to be shared to UAS2 using a clean SIP 
> mechanisms? (
> 
> <Partha> The proposed redirection callflow works only in case of 
> few UAS. It is prepared to pass the overload feedback to Proxy and 
> let proxy decide where to foward based on the load information in 
> different UAS. This will simplify the solution and also scalable 
> for load balancing based solution wherein the number of UAS in two 
> digits. </Partha>
> 
> 
> Query 2:
> A policy can be configured/passed (through SIP) among a group of 
> SIP SERVERS (UAS) and a PXY so that each knows what sort of POLICY 
> it supports.
> 
> 
> Regards,
> Rahul
> 
> 
> 
> 
> This email and its attachments contain confidential information 
> from HUAWEI, which is intended only for the person or entity whose 
> address is listed above. Any use of the information contained here 
> in any way (including, but not limited to, total or partial 
> disclosure, reproduction, or dissemination) by persons other than 
> the intended recipient(s) is prohibited. If you receive this email 
> in error, please notify the sender by phone or email immediately 
> and delete it!
>

---

From: Volker Hilt <[email-masked]>
Date: Fri, 23 Jul 2010 14:09:33 +0200

The following draft seems to be applicable in the case you are describing:

http://tools.ietf.org/html/draft-shen-sipping-avalanche-restart-overload-00

Thanks,

Volker

On 7/23/2010 12:46 PM, RahulSrivastava 71616 wrote:
> From: "Parthasarathi R (partr)"<[email-masked]>
> To: RahulSrivastava 71616<[email-masked]>, [email-masked]
>
>> Hi Rahul,
>>
>> Please read inline.
>>
>> Thanks
>> Partha
>>
>> UAS1)<-----3xx-------
>> digits.</Partha>