Subject: [sip-overload] WGLC: draft-ietf-soc-overload-design

From: Salvatore Loreto <[email-masked]>
Date: Wed, 8 Dec 2010 15:49:17 +0200

[as chair]

the draft-ietf-soc-overload-design has been update to address all the 
concerns/suggestions
that have been raised  during the previous WGLC we run in September.

No one has raised new issues during the Interim we had on December 1st,
neither in the ml till now.

Today we are starting a short one-week working group last call.
This call ends on Wednesday, December 15th.

the last version of the document can be retrieved here:
http://tools.ietf.org/html/draft-ietf-soc-overload-design-03

comments are really appreciate

cheers
/Sal

-- 

Salvatore Loreto
www.sloreto.com

---

From: Salvatore Loreto <[email-masked]>
Date: Tue, 14 Dec 2010 08:58:21 +0200

just to remind people that this call will end tomorrow Wednesday, 
December 15th

cheers
/Sal

---

From: "Bharrat, Shaun" <[email-masked]>
Date: Tue, 14 Dec 2010 09:21:12 -0500

Sal:

No meaningful issues remaining. Thanks.

Some nits below. 

Cheers,
Shaun

> Section 1
> In addition, 503 is used for other situations (with or without Retry-
   After), not just SIP Server overload.  

In addition, 503 (with or without Retry-After) is used for other
situations,
not just SIP overload.  (??)

> A SIP Overload Control process based on 503 would have to specify
exactly 
> which cause values trigger the Overload Control. 

Don't quite understand what this means. If you are using 503, that's
your
status code. What additional cause values? IMO, the paragraph stands
alone fine 
without this sentence anyway.

> Section 2
> Regenerative behavior under overload should ideally be avoided by any
   protocol as this would lead to stable operation under overload.

unstable

>   For a SIP INVITE transaction to be successful[,] a minimum of three
   messages need to be forwarded by a SIP server.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Salvatore Loreto
> Sent: Tuesday, December 14, 2010 1:58 AM
> To: [email-masked]
> Subject: Re: [sip-overload] WGLC: draft-ietf-soc-overload-design
> 
> just to remind people that this call will end tomorrow 
> Wednesday, December 15th
> 
> cheers
> /Sal
> 
> 
> > concerns/suggestions that have been raised  during the 
> previous WGLC 
> > we run in September.
> >
> > No one has raised new issues during the Interim we had on December 
> > 1st, neither in the ml till now.
> >
> _______________________________________________
> sip-overload mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sip-overload
>

---

From: Janet P Gunn <[email-masked]>
Date: Tue, 14 Dec 2010 10:26:19 -0500

In line
Janet

From:
"Bharrat, Shaun" <[email-masked]>
To:
"Salvatore Loreto" <[email-masked]>, 
<[email-masked]>
Date:
12/14/2010 09:24 AM
Subject:
Re: [sip-overload] WGLC: draft-ietf-soc-overload-design

Sal:

Some nits below. 

Cheers,
Shaun

exactly 

<JPG> For instance, a SIP/PSTN gateway which runs out of circuit switched 
trunks may send a SIP 503 Service Unavailable response which includes a 
Reason header field with a Q.850 cause value of 34 (no circuit available). 
 This indicates congestion on the PSTN, but should not be used to trigger 
SIP overload controls.

Janet

---

From: Volker Hilt <[email-masked]>
Date: Tue, 14 Dec 2010 15:24:36 -0500

Shaun,
> not just SIP overload.  (??)
Here is a citation from RFC3162 for the 503 code that should answer your 
question:
    "The server is temporarily unable to process the request due to a
    temporary overloading or maintenance of the server."

> without this sentence anyway.
As mentioned, 503 can be used for server maintenance as well.

>     protocol as this would lead to stable operation under overload.
Thanks for catching this. Fixed.

>     messages need to be forwarded by a SIP server.
Fixed.

I'll submit a new version with those two bug fixes soon.

Volker

---

From: "Bharrat, Shaun" <[email-masked]>
Date: Tue, 14 Dec 2010 15:29:20 -0500

Volker:

> >> Section 1
> >> In addition, 503 is used for other situations (with or 
> without Retry-After), not just SIP Server overload.
> >
> > situations, not just SIP overload.  (??)

Sorry. I was just trying to say that moving the parenthetical 
directly after the "503" would make the sentence more readable (IMHO). 

Cheers,
Shaun

> [mailto:[email-masked]] On Behalf Of Volker Hilt
> Sent: Tuesday, December 14, 2010 3:25 PM
> > situations, not just SIP overload.  (??)
> >
> > your status code. What additional cause values? IMO, the paragraph 
> > stands alone fine without this sentence anyway.
> >

---

From: Janet P Gunn <[email-masked]>
Date: Wed, 15 Dec 2010 12:01:51 -0500

Looks OK to me.
 
My  wordsmithing comment (about computational complexity) has been 
addressed.

Janet

From:
Salvatore Loreto <[email-masked]>
To:
[email-masked]
Date:
12/14/2010 01:58 AM
Subject:
Re: [sip-overload] WGLC: draft-ietf-soc-overload-design

cheers
/Sal