Subject: Re: [sip-overload] draft-ietf-soc-overload-control-13

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 06 Aug 2013 17:02:13 -0500

On 07/31/2013 01:05 PM, Yu, James wrote:
> I agree with the change.

James, Christer: I went through the minor change you are suggesting to
the ABNF.  Essentially, you want to change two things:

   - s/algo-list/algo-value/
   - change the variable repetition rule such that it applies to
     the production definition of other-algo

In terms of actual change, this is:

OLD:

    oc-algo     = "oc-algo" EQUAL DQUOTE algo-list *(COMMA algo-list)
                  DQUOTE
    algo-list   = "loss" / *(other-algo)
    other-algo  = %x41-5A / %x61-7A / %x30-39

NEW:

    oc-algo     = "oc-algo" EQUAL DQUOTE algo-value *(COMMA algo-value)
                  DQUOTE
    algo-value  = "loss" / other-algo
    other-algo  = 1*(%x41-5A / %x61-7A / %x30-39)

Note that this change does perturb the intent of the old production
rule (as far as I can see it, at least).  Either of the above grammars
produce the following valid token sequence:

   oc-algo="loss"
   oc-algo="loss,rate"
   oc-algo="loss,rate,window"

However, if the new change appears to read better, I am happy to change
it as suggested.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
1960 Lucent Lane, Rm. 9C-533, Naperville, Illinois 60563 (USA)
Email: vkg@{bell-labs.com,acm.org} / [email-masked]
Web: http://ect.bell-labs.com/who/vkg/  | Calendar: http://goo.gl/x3Ogq

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 7 Aug 2013 06:26:50 +0000

Hi Vijay,

Your suggestion (NEW) is what I had in mind :)

Just one more thing, as you are going to update the ABNF: why not also simply define other-algo as:

	other-algo =  1*(ALPHA / DIGIT)

I think it would make the syntax even more clear. And, you don't need to define ALPHA and DIGIT, but simply refer to the ABNF core spec :)

Regards,

Christer

-----Alkuperäinen viesti-----
Lähettäjä: Vijay K. Gurbani [mailto:[email-masked]] 
Lähetetty: 7. elokuuta 2013 1:02
Vastaanottaja: Yu, James; Christer Holmberg
Kopio: [email-masked]; [email-masked]; [email-masked]
Aihe: Re: [sip-overload] draft-ietf-soc-overload-control-13

> I agree with the change.

James, Christer: I went through the minor change you are suggesting to the ABNF.  Essentially, you want to change two things:

OLD:

NEW:

Note that this change does perturb the intent of the old production rule (as far as I can see it, at least).  Either of the above grammars produce the following valid token sequence:

   oc-algo="loss"
   oc-algo="loss,rate"

However, if the new change appears to read better, I am happy to change it as suggested.

Thanks,

- vijay