Subject: More than one message in one SIP message

From: "ANIRBAN ROY" <[email-masked]>
Date: Tue, 07 Dec 1999 17:34:47 +0530

hi,

Can we have more then one message in one SIP message. e.g can there be
TRYING and RINGING in one sip message

SIP/2.0 100 Trying
Via: SIP/2.0/UDP kton.bell-tel.com
From: A. Bell <sip:[email-masked]>
To: T. Watson <sip:[email-masked]> ;tag=37462311
Call-ID: [email-masked]
CSeq: 1 INVITE
Content-Length: 0

SIP/2.0 180 Ringing
Via: SIP/2.0/UDP kton.bell-tel.com
From: A. Bell <sip:[email-masked]>
To: T. Watson <sip:[email-masked]> ;tag=37462311
Call-ID: [email-masked]
CSeq: 1 INVITE
Content-Length: 0

Just like MGCP with some difference.

regards
Anirban

---

From: [email-masked]
Date: Tue, 7 Dec 1999 13:04:12 -0000

Hi,

I assume you mean in UDP packets? the bit of RFC 2543 dealing with this (1.5
protocol properties) doesnt specifically allow or disallow it, but the old
draft SIP specs (IIRC) said UDP SIP software should cope with one or more
SIP messages in one packet.

My SIP code (proxy server, plus several clients) is written to handle this,
if that helps.  :o)

regards ... Phil