Subject: Multiple header instances...

From: Shail Bhatnagar <[email-masked]>
Date: Thu, 16 Dec 1999 09:58:48 -0500

Is a SIP server/client supposed to handle messages like this :

Via:...
Via:...
Record-Route:...
Via:...

I mean - multiple instances of a same header and non-contiguous .

-- 
Best regards,
Shail

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 16 Dec 1999 10:01:55 -0500

> I mean - multiple instances of a same header and non-contiguous .

Yes.

-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 29 Dec 1999 11:31:44 +0200

Hi,

I'm doing a little research on parser tools for SIP. Tools like lex and
yacc don't seem to be very suitable, and implementations I've seen use
pure C (C++, Java, whatever...) code for the parsing. Do you have any
experience of this?

Regards,

Christer 

----------------------------------------
Christer Holmberg
Advanced Signalling Reserach Laboratory
Ericsson Finland
----------------------------------------