Subject: Re: Multiple header instances...

From: [email-masked]
Date: Thu, 16 Dec 1999 20:33:59 +0530

yes, indeed.
This is very legal - and _should_ be implemented.
I think the RFC somewhere states that the ordering is not fixed and should
not be assumed so.
Also, this is a part of the 'torture tests' list in 2nd bakeoff.

Regds
Arjun
--
Arjun Roychowdhury @ Hughes Software Systems

Shail Bhatnagar <[email-masked]> on 12/16/99 08:28:48 PM

To:   [email-masked]
cc:

Subject:  Multiple header instances...

Is a SIP server/client supposed to handle messages like this :

Via:...
Via:...
Record-Route:...
Via:...

I mean - multiple instances of a same header and non-contiguous .

--
Best regards,
Shail

---

From: Shail Bhatnagar <[email-masked]>
Date: Thu, 16 Dec 1999 10:34:22 -0500

Arjun, Ordering of hop by hop fields matters - I was not sure if they
could be non-contiguous. 
Shail