Subject: The value of CSeq

From: "Masanori Inui" <[email-masked]>
Date: Wed, 1 Dec 1999 21:39:18 +0900

Hi,

I have a simple question.

Does the specification of the SIP allow to increase the value of CSeq every
time
 where the UAC originates a new INVITE request?

ex)
I assume that the request is from A to B and the response is from B to A.

INVITE(CSeq:1) -> 180 -> 200 -> ACK -> BYE(CSeq:2) -> INVITE(CSeq:3) ->
       ^^^^^^                              ^^^^^^            ^^^^^^
Thanks,

===========================
Masanori Inui
IWATSU Electric CO.,LTD
Project Team No.2
Solution Engineering Dept.
Engineering Division
---------------------------
1-7-41 Kugayama Suginami-ku
Tokyo, 168-8501, Japan
---------------------------
Tel.+81-3-5370-5211
Fax.+81-3-5370-5193
Email [email-masked]
===========================

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 01 Dec 1999 08:42:53 -0500

I'm not sure I understand your flow below. The CSeq space is defined
within the Call-ID, To and From fields. For each request from a UAC to a
UAS, the CSeq must increment. The CSeq values are different in the
reverse direction. So, if A invites B, it might use CSeq 1, and then to
hang up, it must increment the CSeq when it sends a BYE. If A invites B,
but B hangs up, the first CSeq can be any value in the BYE from B to A.

-Jonathan R.

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: "Masanori Inui" <[email-masked]>
Date: Thu, 2 Dec 1999 13:05:02 +0900

I assume that two person caller is A and callee is B.
Both A and B have their own sip-telephone.

A invites B and they are talking. And A hang up. Then this conversation is
finished.
A invites B without a break, is the CSeq value in this INVITE request
increased to before?

When the UAC originates new request, I intend to implement the CSeq value
increases every time.
Is it usual?

Thanks,
Masanori I.

----- Original Message -----
'-MŽÒ : Jonathan Rosenberg <[email-masked]>
^¶æ : Masanori Inui <[email-masked]>
Cc: SIP-MailingList <[email-masked]>
'-M"úŽž : 1999"N12OŽ1"ú 22:42
O-¼ : Re: The value of CSeq

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 02 Dec 1999 01:10:04 -0500

> A invites B without a break, is the CSeq value in this INVITE request

If this is a new call, it has a new Call-ID, so it doesn't matter what
the CSeq is compared to the previous call. For a re-INVITE within a
call, the CSeq is always incremented from the previous.

-Jonathan R.