Subject: Question about Call comparaison

From: Marc Petit-Huguenin <[email-masked]>
Date: Wed, 15 Dec 1999 19:31:56 +0000

Hi all,

Is the two following requests belongs to the same call or not (please
notes the difference in the port)

 INVITE sip:[email-masked] SIP/2.0
 From: Isabelle <sip:[email-masked]:5060>
 To: Marc <sip:[email-masked]>
 Call-Id: [email-masked]
 CSeq: 1 INVITE
 Via: SIP/2.0/UDP tarantula.8x8.com
 Content-Length: 0

[some other message...]

 INVITE sip:[email-masked] SIP/2.0
 From: Isabelle <sip:[email-masked]>
 To: Marc <sip:[email-masked]>
 Call-Id: [email-masked]
 CSeq: 2 INVITE
 Via: SIP/2.0/UDP tarantula.8x8.com
 Content-Length: 0

At least two implementations at the last bake-off does not like this.

Thank you for your help.

-- 
Marc Petit-Huguenin
Home: mailto:[email-masked]
Work: mailto:[email-masked]
"Everything I love is either immoral, illegal or makes you fat"

---

From: [email-masked]
Date: Fri, 17 Dec 1999 11:33:08 +0530

Jonathan Rosenberg <[email-masked]> on 12/17/99 11:30:29 AM

To:   Henning Schulzrinne <[email-masked]>
cc:   archow, Marc Petit-Huguenin <[email-masked]>, IETF SIP
      <[email-masked]>

Subject:  Re: Question about Call comparaison

Actually, Id say even messier than that is the equivalence of %HEX %HEX to
the character conterparts.
Which means no more sweet strcasecmp or strcmp (for passwd) anymore -
people will have to pass the uri through a
conversion routine before comparison.
Agreed that its being compliant to the respective http rfcs, but is it
really worth it ?
Regds
Arjun
--
Arjun Roychowdhury @ Hughes Software Systems

Hmm, so this means that comparisons on the user and password are case
SENSITIVE, and that comparisons on parameters are also case SENSITIVE.
Its a bit yucky with these special cases, but I guess we should be
consistent with http and rfc2396. In that case, I think we should
explicitly say that the username, password, and parameters comparisons
are case sensitive.

-Jonathan R.
--
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Sean Olson <[email-masked]>
Date: Fri, 17 Dec 1999 09:16:30 -0600 (CST)

> Agreed that its being compliant to the respective http rfcs, but is it

It's essential to be able to handle escaped characters transparently.
I don't expect to see the password portion of a URL to be used that often, 
but eventually I would expect you might see a lot of "static" SIP URLs
embedded in web pages, e-mail, etc. and to support this you will need to
support the headers and method parameters of the SIP URL (which will very
often need to contain %HEX %HEX sequences)

sean
-----------------------------------------------------------------
Sean Olson            E-mail: [email-masked]
Ericsson Inc.         Voice: (972) 583-5472 
                      FAX: (972) 669-0154