Subject: RE: question about sip grammar

From: "Vakil, Mohammad (c)" <[email-masked]>
Date: Fri, 10 Dec 1999 13:56:07 +0000

Yes, and I think it goes back to RFC822. It's Header requirement, that's how
you know that it's end of headers. It is MUST. An empty line (CRLF with
nothing preceding) terminates SIP headers (sip message) even if there's no
body.

Mohammad Vakil

	----------
	From:  Taji Rachid [SMTP:[email-masked]]
	Sent:  Friday, December 10, 1999 1:45 AM
	To:  [email-masked]
	Subject:  question about sip grammar

	must I put a "\r\n" (CRLF) after sip part of sip message even if
there is no
	message body.

	Thanks.

	Rachid.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 10 Dec 1999 09:46:36 -0500

Yes, thats right. There MUST be an empty line even without a body. From
the BNF in section 4:

> The Request message format is shown below:
> 
> 
> 
>         Request  =  Request-Line       ;  Section 4.1
>                     *( general-header
>                     | request-header
>                     | entity-header )
>                     CRLF
>                     [ message-body ]   ;  Section 8

Note that CRLF is not mandatory, and is present even if there is no
message body.

-Jonathan R.

> "Vakil, Mohammad (c)" wrote:
> 
> Yes, and I think it goes back to RFC822. It's Header requirement,
> that's how you know that it's end of headers. It is MUST. An empty
> line (CRLF with nothing preceding) terminates SIP headers (sip
> message) even if there's no body.
> 
> Mohammad Vakil
> 
>      ----------

-- 
Jonathan D. Rosenberg                       200 Executive Drive
Chief Scientist                             Suite 120 
dynamicsoft                                 West Orange, NJ 07052
[email-masked]                     FAX:   (732) 741-4778
http://www.cs.columbia.edu/~jdrosen         PHONE: (732) 741-7244
http://www.dynamicsoft.com

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 10 Dec 1999 10:03:54 -0500

Oops! Thanks to Henning for noting that my email is inconsistent:

> Note that CRLF is not mandatory, and is present even if there is no
                    ^^^
                    strike this word