Subject: [SIP] Clarification on sdp usage sought

From: "Manish S. Jalan" <[email-masked]>
Date: 23 Apr 2001 12:08:41 -0000

Hello,

I am back to seek some more clarifications.

Is the following sdp description ok:  (the order of attribute definitions especially)

m=audio 1234 RTP/AVP 4 0
a=rtpmap:4 G723/8000
a=rtpmap:0 PCMU/8000
a=ptime:20
a=fmtp:4 bitrate=6300

or it should be,

m=audio 1234 RTP/AVP 4 0
a=rtpmap:4 G723/8000
a=fmtp:4 bitrate=6300
a=rtpmap:0 PCMU/8000
a=ptime:20

Is the ptime definition ok?
the ptime is media specific or format specific?

Please help me in clarifying the concepts.
Any help is highly appreciated.

Regards,
-Manish S. Jalan

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Manoj Bhatia <[email-masked]>
Date: Wed, 25 Apr 2001 15:46:50 -0400

Manish

See comments inline.

thanks
-manoj

> Is the following sdp description ok:  (the order of attribute definitions especially)

This may not be illegal (given how loose the RFC is )
but I would think that it is  not the preferred way.

> a=ptime:20

This is the right definition.
The ptime parameter would correspond to G.711ulaw (payload 0) .

--
Manoj Bhatia                           |        |         |
[email-masked]                       |       :|:       :|:
7025 Kit Creek Road, RTP, NC - 27709   |     :|||||:   :|||||:
Ph: 919-392-3873  Fax:919-392-6801     |  C i s c o S y s t e m s

---

From: Ovidiu Sas <[email-masked]>
Date: Fri, 27 Apr 2001 11:46:07 -0400 (EDT)

Hello,

 I have a question related to SDP. See comments inline.

____________________
 > The ptime parameter would correspond to G.711ulaw (payload 0) .

 I could't find any statement about the order of the media attributes
inside a media announcement in the RFC. In this context, how about
this definition:

  m=audio 1234 RTP/AVP 4
  a=rtpmap:4 G723/8000
  a=fmtp:4 bitrate=6300
  m=audio 1234 RTP/AVP 0
  a=rtpmap:0 PCMU/8000
  a=ptime:20

     => no information about the G723's packetization and 20ms
        packetization for PCMU.

 > > Any help is highly appreciated.

  Regards,
    Ovidiu Sas