Subject: Fw: [SIP] Delivering Caller-ID through SIP

From: "Dean Willis" <[email-masked]>
Date: Tue, 10 Apr 2001 17:02:14 -0500

whoops, forgot to copy the list here . . .

Sorry!

--
Dean

----- Original Message -----
From: "Dean Willis" <[email-masked]>
To: "Sharath Rajasekar" <[email-masked]>
Sent: Tuesday, April 10, 2001 11:56 AM
Subject: Re: [SIP] Delivering Caller-ID through SIP

> Personally, I set my From: field to: sip:[email-masked]
when
> placing a call through a gateway. All the gateway's I've worked with
happily
> strip off the domain part and copy 9724735455 into the Calling Party ID.
>
> This is facilitated by the phone on my desk, which supports multiple user
> profiles (lines). I have the line1 button set up to use my phone number in
> the From:, and line 2 set to use my username in the From:. I pick the
> appropriate "line" for an outbound call manually. Works dandy with no new
> headers.
>
> One might also envision a user outbound proxy or application server (or a
> smart UA) performing this service automatically on behlaf of the user.
>
> --
> Dean
>
>
> ----- Original Message -----
> From: "Sharath Rajasekar" <[email-masked]>
> To: "sip list" <[email-masked]>; <[email-masked]>
> Sent: Monday, April 09, 2001 8:15 PM
> Subject: [SIP] Delivering Caller-ID through SIP
>
>
> >
> > Consider a SIP UA with a SIP URL [email-masked] which is associated
> > with a SIP Phone. This SIP Phone has a public number (444-555-6666).
> >
> > When a call is initiated by the phone, to a PSTN number, the following
> > INVITE will be sent out...
> >
> > INVITE sip:[email-masked] SIP/2.0
> >       From : UserA <sip:[email-masked]>
> > To : Unknown <sip:[email-masked]>
> >       ...
> >
> > How can one deliver the calling public number(444-555-6666 in this case)
> > to the PSTN as caller-id through the gateway ?
> >
> > Some generic tag may be used say..."pstn-number: 444-555-6666" in the
> > >From header, but this will mean that all gateways must support this
tag.
> > Is there some other solution to this problem.
> >
> >
> > Regards
> > Sharath
> >
> >
> >
> > _______________________________________________
> > This list is for continuing development of the SIP protocol.
> > The sip-implementor's list is the place to discuss implementation,
> > and to receive advice on understanding existing sip.
> > To subscribe to it, send mail to
> > [email-masked] with "subscribe" in the body.
> >
>

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Fairlie-Cuninghame, Robert" <[email-masked]>
Date: Wed, 11 Apr 2001 09:08:23 -0700

These issues are addressed in
http://www.cs.columbia.edu/~hgs/sip/drafts/draft-dcsgroup-sip-privacy-02.txt
<http://www.cs.columbia.edu/~hgs/sip/drafts/draft-dcsgroup-sip-privacy-02.tx
t> 

Robert.

-----Original Message-----
From:	Parolkar, Satish [mailto:[email-masked]]
Sent:	Wednesday, April 11, 2001 3:51 PM
To:	'Medhavi'; Sharath Rajasekar; sip list; [email-masked]
Subject:	RE: [SIP] Delivering Caller-ID through SIP

I wonder if one could use the optional Display Name to deliver the public
number associated with the SIP phone.

When a call is initiated by the SIP phone with public number 444-555-6666,
to a PSTN number 4085551111, the following
INVITE will be sent out...

	INVITE sip:[email-masked] SIP/2.0
      From : 4445556666 <sip:[email-masked]>
	To : Unknown <sip:[email-masked]>
      ...

However, the issue remains 
Who is responsible to authenticate the number delivered to the PSTN?
A user can put any number desired. Is the IP/PSTN gateway responsible to
authenticate the Delivered Number?

Comments.

Satish

-----Original Message-----
From: Medhavi [mailto:[email-masked]]
Sent: Monday, April 09, 2001 8:38 PM
To: Sharath Rajasekar; sip list; [email-masked]
Subject: RE: [SIP] Delivering Caller-ID through SIP

I think you can use the p= in SDP, as one option.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Sharath Rajasekar
Sent: Monday, April 09, 2001 9:16 PM
To: sip list; [email-masked]
Subject: [SIP] Delivering Caller-ID through SIP

  
>From header, but this will mean that all gateways must support this tag.

Regards
Sharath

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 18 Apr 2001 11:18:18 +0100

Part of the answer to this depends on who owns the gateway.

If the gateway is essentially part of a PBX, then you will be presenting the
call, and the called id, to the network using the procedures of ITU-T
Recommendations Q.931 and Q.951.3. At this point you have two options,
special arrangement or no special arrangement. In the first, the public
network relies on the private network infrastructure to ensure that it is a
meaningful number. How this is dones is outside the scope of the ITU-T
Recommendations, and in many countries this option is not readily available.
In the no special arrangement, the public network will screen the supplied
number to see if it believes it is meaningful.

If the gateway is part of the public network, then the rules for any
screening that is performed are implementation dependent, but the public
network is looking to transport either one fully screened number which it
knows it can trust, or two numbers, one of which is generated at the input
port to the public network (which could be in the SIP domain) and is
trusted, and another which was generated by user equipment. The trusted
number is used for emergency calls, and malicious call identification, and
charging, and so on. The user equipment generated one may be used
additionally for the above, and is used for calling line identification
presentation.

While it is possible to use the From header in SIP to give very basic caller
id, only use of the privacy draft will give you all the capabilities that
also exist in the PSTN, and therefore can be readily mapped into the PSTN
capabilities.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Mart Nurmet[SMTP:[email-masked]]
> Sent: 	11 April 2001 16:08
> To: 	Parolkar Satish
> Cc: 	'Medhavi'; Sharath Rajasekar; sip list; [email-masked]
> <<File: mart.nurmet.vcf>>
> Further, how will the PSTNs treat this if it was a possibly ported number
> when
> presented to them?  And let's not forget, that Area 1, dialing plans don't
> necessarily hold for the rest of the world.  Will 15 digit dialing be
> standardized soon?  Or other plans.
> 
> "Parolkar, Satish" wrote:
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 18 Apr 2001 14:09:01 +0100

Alternatively use the privacy draft, which gives all the capabilities for
this support.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Steve Levy[SMTP:[email-masked]]
> Sent: 	11 April 2001 17:36
> To: 	[email-masked]; Dean Willis
> Cc: 	IETF SIP (E-mail)
> Subject: 	Re: Fw: [SIP] Delivering Caller-ID through SIP
> 
> 
> Check Section 6.26 (From Header) of 2543.bis-02. There it states:
> 
> A system SHOULD use the display name "Anonymous" if the
>    identity of the client is to remain hidden.
> 
> The 'Anonymous' should be converted into presentation restricted for
> ISUP/ISDN
> 
> Steve
> 
> At 06:22 PM 4/10/01 -0400, [email-masked] wrote:
> >
> >
> >How does SIP convey the "privacy indicator" (presentation restriction
> >information) to the ISUP/ISDN implementation
> >on the gateway when the outgoing IAM/SETUP is built ?  What if I dial *67
> >and want to supress my Caller-ID ?
> >
> >/somit
> >
> >
> >
> >
> >
> >"Dean Willis" <[email-masked]> on 04/10/2001 06:02:14 PM
> >
> >To:   "IETF SIP (E-mail)" <[email-masked]>
> >cc:    (bcc: Somit Ghosh/Telcordia)
> >Subject:  Fw: [SIP] Delivering Caller-ID through SIP
> >
> >
> >