Subject: RE: [SIP] Hop to Hop forwarding of Invite responses in the call f lows docum ent

From: Sekhar Banerjee <[email-masked]>
Date: Tue, 24 Apr 2001 15:13:52 -0700

Bret,
	Thanks for the response. The other question would be is the 200 OK
response to the CANCEL supposed to be generated by the proxy too without
waiting for a response to the CANCEL that was forwarded to the next hop.

Thanks

Sekhar

> 	I was going through the call flows in
> http://www.cs.columbia.edu/~hgs/sip/drafts/draft-ietf-sip-call
> -flows-03.txt
> and the falure scenario under 3.2.1 is where I have a question. The
> Unsuccssful SIP to SIP no answer call flow seems to imply 
> that not only is
> the CANCEL a hop to hop request but also the 487 response and 
> the ACK are
> hop to hop. I thought that 487 and ACK were end to end. Am I missing
> something here ?

As stated in third paragraph section 10.3.1 
of rfc2543bis-02 November 24, 2000,
"a proxy generates an ACK for non-2xx final 
responses."

Similar text is in section 12.4.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 25 Apr 2001 14:26:47 -0400

> -----Original Message-----
> From: Sekhar Banerjee [mailto:[email-masked]]
> Sent: Tuesday, April 24, 2001 6:14 PM
> To: [email-masked]'; [email-masked]
> Subject: RE: [SIP] Hop to Hop forwarding of Invite responses 
> in the call
> f lows docum ent
> 
> 
> Bret,

Yes. From Section 10.2.1 (which is not the most intuitive place for this):

Each server in a proxy chain generates its own final response to a CANCEL
request. The server responds
immediately upon receipt of the CANCEL request rather than waiting until it
has received final responses
from the CANCEL requests it generates.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com