Subject: RE: [SIP] Response if user not registered?

From: "Roy, Radhika R, ALCOO" <[email-masked]>
Date: Sun, 1 Apr 2001 17:26:50 -0400

For SIP, that means you have no control over who I
use for the outbound proxy. There's no reason to
modify SIP to enforce something that is
unenforcible.

[RRR] Still an association (e.g., registration/INVITE-authentication etc.)
needs to be provided how charging can be made for service offerings. (It is
not about control per se.)

Radhika R. Roy

Roy, Radhika R, ALCOO writes:
 > Folks:
 > 
 > Let us not forget the reality in offering the VoIP services. As Brian has
 > explained, there has to be charging. That is, there need to be an
 > association between the caller (person) and the device/location/address.
 > 
 > (No one is disputing the fact that calls can always be made is the IP
 > addresses are known and routers can route the calls to the destination IP
 > addresses, and IP addresses can be assigned dynamically.)
 > 
 > Best regards,
 > 
 > Radhika R. Roy
 > AT&T
 > 
 > -----Original Message-----
 > From: Brian F. G. Bidulock [mailto:[email-masked]]
 > Sent: Friday, March 30, 2001 2:40 PM
 > To: Michael Thomas
 > Cc: Drage, Keith (Keith); [email-masked]; 'Juha Heinanen';
 > [email-masked]
 > Subject: Re: [SIP] Response if user not registered?
 > 
 > 
 > Michael,
 > 
 > I don't have an IP address tatooed on my forhead and
 > my left hand.
 > 
 > Also, some like to charge for calls based on where you
 > are calling from.  They often like to charge you, not
 > your terminal.
 > 
 > --Brian
 > 
 > Michael Thomas wrote:                     (Fri, 30 Mar 2001 10:46:32)
 > > Brian F. G. Bidulock writes:
 > >  > Michael,
 > >  > 
 > >  > Sorry Mike, registration is for personal mobility as
 > >  > well, not just terminal mobility.
 > > 
 > >    And this contradicts what I said... how?
 > >    It certainly doesn't make a case for linkage
 > >    of incoming and outgoing calls to some HLR-like
 > >    entity. Location is only important on the
 > >    incoming call side. The outgoing side is
 > >    completely separate. Likewise, data
 > >    connectivity is completely separate from
 > >    call/SIP presence. This is the fundamental
 > >    conflation that Q.931-like schemes get 
 > >    completely wrong in the IP world.
 > > 
 > > 	      Mike
 > 
 > -- 
 > Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
 > [email-masked]    ¦ world; the unreasonable one persists in  ¦
 > http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
 >                         ¦ Therefore  all  progress  depends on the ¦
 >                         ¦ unreasonable man. -- George Bernard Shaw ¦
 > 
 > _______________________________________________
 > This list is for continuing development of the SIP protocol.
 > The sip-implementor's list is the place to discuss implementation,
 > and to receive advice on understanding existing sip.
 > To subscribe to it, send mail to 
 > [email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: [email-masked]
Date: Wed, 4 Apr 2001 20:43:46 +0300

Hi,

Jonathan Rosenberg:
> 
> That aside, I still find the process of assigning an S-CSCF 
> at registration
> to be a funny thing. I agree completely that you will 
> ultimately want to
> segment the servers in your domain, with users being assigned 
> to a specific
> server. THis segmentation is a common practice today, even, in email
> systems. However, there, they make the segmentations 
> algorithmic in nature.
> I believe its common to assign users to mail servers based on 
> the first
> letter of their username. The algorithmic mappings are a lot 
> easier to deal
> with, and don't require any of these additional databases to 
> hold the "user
> to S-CSCF" mappings themselves.
> 
> Perhaps someone can clarify for me why it was decided to do 
> it this way in
> 3gpp.
>

I agree that "user to S-CSCF" mapping based on first letter etc. would be
much easier than the current process. I have heard of two reasons for why it
is done the way it is now:
- If S-CSCFs have different capabilities (I guess this relates to service
execution) and users have different preferences, these have to be mapped
together, so static provisioning (at least a simple one) would not be
enough. 
- Reliability: I'm not sure if there is any benefit from dynamic mapping,
but it probably makes load balancing and failure recovery easier. (I don't
know how e-mail systems do it, perhaps they just have some redundancy to
keep the one statically mapped server up.)
 
> -Jonathan R.

Markus