Subject: [SIP] Delivering Caller-ID through SIP

From: "Sharath Rajasekar" <[email-masked]>
Date: Mon, 9 Apr 2001 18:15:42 -0700

Consider a SIP UA with a SIP URL [email-masked] which is associated 
with a SIP Phone. This SIP Phone has a public number (444-555-6666). 

When a call is initiated by the phone, to a PSTN number, the following
INVITE will be sent out...

	INVITE sip:[email-masked] SIP/2.0
      From : UserA <sip:[email-masked]>
	To : Unknown <sip:[email-masked]>
      ...

How can one deliver the calling public number(444-555-6666 in this case) 
to the PSTN as caller-id through the gateway ?
  
Some generic tag may be used say..."pstn-number: 444-555-6666" in the 
From header, but this will mean that all gateways must support this tag.
Is there some other solution to this problem.

Regards
Sharath

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Medhavi" <[email-masked]>
Date: Mon, 9 Apr 2001 21:38:21 -0400

I think you can use the p= in SDP, as one option.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Sharath Rajasekar
Sent: Monday, April 09, 2001 9:16 PM
To: sip list; [email-masked]
Subject: [SIP] Delivering Caller-ID through SIP

  

Regards
Sharath

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 10 Apr 2001 13:43:32 -0400

> Is there some other solution to this problem.

The following draft deals with Caller-ID 
and privacy:
http://www.ietf.org/internet-drafts/draft-ietf-sip-privacy-01.txt

The remote party ID would contain 
rpi-id-type="term" for the PSTN number 
associated with the terminal.  The remote 
party ID would contain rpi-id-type="user" 
when identifying the user making the call.