Subject: [SIP] Cseq with call stateful proxies

From: "Keith Robinson" <[email-masked]>
Date: Thu, 26 Apr 2001 12:04:27 +0100

In section 3.1.2 of the SIP Call Flows document, the BYE that is originated by
the
called party has a CSEQ of 1; the note states that this is not 2 because each UA
maintains its own CSEQ count. However, if the intermediate proxy is call
stateful, then
it is going to receive a subsequent message (BYE in this case) with an old CSEQ
number on this
call leg, albeit in the opposite direction to the previous CSEQ with value 1.
The RFC states
that CSEQ must increment monotonically within a call leg, it does not state
anything about
the direction of the message within that call leg. I think there is some
conflict here that requires
clarification.

Regards,

K. Robinson

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: [email-masked]
Date: Thu, 26 Apr 2001 16:56:54 +0530

CSeq spacing is independant in the two directions of the call leg. Not sure
if this is explicity written in the draft,
but its there in the SIP FAQ.

http://www.cs.columbia.edu/~hgs/sip/faq/cache/23.html (last para)

regds
arjun
--
Arjun Roychowdhury @ Hughes Software Systems

"Keith Robinson" <[email-masked]> on 04/26/2001 04:34:27 PM

To:   [email-masked]
cc:   [email-masked]

Subject:  [SIP] Cseq with call stateful proxies

In section 3.1.2 of the SIP Call Flows document, the BYE that is originated
by
the
called party has a CSEQ of 1; the note states that this is not 2 because
each UA
maintains its own CSEQ count. However, if the intermediate proxy is call
stateful, then
it is going to receive a subsequent message (BYE in this case) with an old
CSEQ
number on this
call leg, albeit in the opposite direction to the previous CSEQ with value
1.
The RFC states
that CSEQ must increment monotonically within a call leg, it does not state
anything about
the direction of the message within that call leg. I think there is some
conflict here that requires
clarification.

Regards,

K. Robinson