Subject: Re: [SIP] Informing UA after network initiated deregistration?

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Sat, 31 Mar 2001 18:48:13 -0600

Dean,

People on this WG say how SIP is so different from
PSTN; yet, you cling to this artificial distinction
between inbound and outbound call?  These are circuit
switched network concepts.

Clinging to the concept of inbound and outbound is
why the PSTN had so much difficulty with services
like Meet-Me conferencing, Call Waiting and other
such stuff.

Consider that the user is a participant in a
communications session whose establishment is
independent of its participants.

Being able to give out invitations without also being
able to receive them severly limits the scope of
dependencies between sessions which can be expressed
by the protocol.  Proxies wishing to provide this
wider scope of service offering should be permitted
to track registration and deregistration as it affects
the offering of this wider service range than just
incoming and outgoing.

--brian

Dean Willis wrote:                              (Sat, 31 Mar 2001 17:58:45)
>
> I really don't think I understand this whole argument.
> 
> When I turn on the SIP phone on my desk, it sends register messages to three
> different registrars.
> 
> Optionally, each registration could be authenticated with separate
> credentials. None of those credentials has anything whatsover to do with
> authorizing my phone to talk to the network.
> 
> And NONE of those registrations have anything whatsoever to do with whether
> that phone can make a call. They influence only INBOUND calls to the
> identities associated with the registrations.
> 
> Whether or not the phone has registered HAS ABSOLULTELY NO IMPACT on whether
> that phone has "access" to the network. In fact, it has to have access to
> the network BEFORE it can register. Registration is an application, not an
> access control mechanism.
> 
> I think we're getting layer 2, 3, and 4 horribly confused.
> 
> --
> Dean
> 

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Dean Willis" <[email-masked]>
Date: Sat, 31 Mar 2001 19:29:15 -0600

Interesting point. One might take it even further --  the user may be
represented by multiple identities, each of which may be participating in
one or more sessions, each of which may have been instantiated by the user,
another participant in the session, or by a non-participating third party.

Some devices may be only be able to originate invitations. Some may be able
only to respond to invitations. Some may do both, or their abilities may be
dictated by the set of identities involved in the given context. Some
devices will support multiple identities simultaneously. Others will not.

One might choose to model the "meet me call" as a unique identity,
instantiated for the duration of the "call", which participates in numerous
"call legs" on a pairwise basis with each of the other participants. I
believe a similar technique can be applied to all multiparty calling modes.
In fact, I think Sparks and Campbell did an internet-draft illustrating that
point.

But "inbound" vs "outbound" is still a useful distinction, inasmuch as one
or the other of the parties at each end of each call leg performed the
signaling that instantiated that leg -- and the other party reacted to that
signal. To paraphrase Einstein, I refuse to embrace a conceptuality without
causality . . .

--
Dean

----- Original Message -----
From: "Brian F. G. Bidulock" <[email-masked]>
To: "Dean Willis" <[email-masked]>
Cc: "Baniel Uri-CUB001" <[email-masked]>; "'Bob Penfield'"
<[email-masked]>; "Sriram Parameswar"
<[email-masked]>; "'Romeo Zwart'" <[email-masked]>;
"'Stephen Terrill'" <[email-masked]>; "'Igor Slepchin'"
<[email-masked]>; "'William Marshall'" <[email-masked]>;
"Chen Bonnie-BCHEN1" <[email-masked]>; "Xu Lang-LXU1"
<[email-masked]>; "sip" <[email-masked]>
Sent: Saturday, March 31, 2001 6:48 PM
Subject: Re: [SIP] Informing UA after network initiated deregistration?