Subject: RE: [SIP] Questions about session timer

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Tue, 24 Apr 2001 16:31:07 +0100

But what the proxy is going to do if it wants to disconnect a call in a case
that the user has run out of credit in his account during a call. What sip
message will be sent to caller or callee by this proxy?

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

-----Original Message-----
From: Brett Tate [mailto:[email-masked]]
Sent: 24 April 2001 15:07
To: [email-masked]
Subject: RE: [SIP] Questions about session timer

> Thanks for your answer. In the session timer draft, it says 
> "a proxy MUST
> NOT send a BYE request once the session
> expires." Why? What do I miss here?

A proxy should not trample on the CSeq of a UA.  
Thus on a given call-leg, a proxy can only 
generate responses, ACKs and CANCELs.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 24 Apr 2001 12:36:32 -0400

> message will be sent to caller or callee by this proxy?

The following FAQ link addresses such a question.
http://www.cs.columbia.edu/sip/faq/cache/13.html

---

From: "Dean Willis" <[email-masked]>
Date: Tue, 24 Apr 2001 14:56:58 -0500

Nothing.

Conformant proxies can't enforce prepaid functions. You need an application
that implements a back-to-back user agent to do this. I believe it is
possible for a proxy to switch from proxy to B2BUA mode if it so desires,
but it is a bit tricky. Switching BACK to proxy mode for a call is much
harder.

I believe this is addressed by the FAQ that Brett mentioned. If anyone
wishes to discuss this further, I'll be happy to do so, but would rather not
do so on the SIP list.

--
Dean