Subject: RE: [SIP] I-D ACTION:draft-ietf-sip-service-examples-01.txt

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 25 Apr 2001 11:01:13 +0100

The initial enquiry and Brett's response assume that the result of hold is
asymmetrical. While the service examples draft is an attempt to emulate PSTN
services, the service result in this case is not the same.

The service-examples draft contains the following key words

.  Note that either party can take the other party off
   of hold.  

SIP hold removes the media stream(s). They are removed at both ends. If A
holds B, then both parties are in the state of having no media stream.
Neither side is particularly holding or held. If B holds A, then both
parties are still in the state of having no media stream, and therefore,
while such a request is not invalid, it has zero impact on the overall state
of the session. 

The process of coming out of hold requires merely adding a media stream and
therefore either end can invoke this function. The only note I would make is
that if A held B, then A presumably did it to release resources to perform
some other function (this is the purpose of hold in both the PSTN and ISDN).
If B tries to resume the call before A is ready, then those resources may
still be unavailable, and A may reject the request (e.g. with "busy here" or
"busy everywhere"). 

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Brett Tate[SMTP:[email-masked]]
> Reply To: 	[email-masked]
> Sent: 	23 April 2001 23:34
> To: 	[email-masked]
> Subject: 	RE: [SIP] I-D ACTION:draft-ietf-sip-service-examples-01.txt
> 
> <snip>
> 
> > what is the proper SIP signaling for A to 
> > initiate a hold to B after B holds A first?
> 
> The flow looks the same as a normal re-INVITE 
> to put a call on hold; however both re-INVITE 
> and 200 will contain hold SDP.
>  
> > What is the proper SIP call flows for one 
> > party to re-establish the media stream 
> > when both parties are in hold / held states? 
> 
> A party can only offer itself off hold, the 
> receiver can stay on hold if it desires.
> 
> For instance if A put B on hold, A would 
> likely want to return a 200 with hold SDP 
> for a re-INVITE from B.
> 
> Thus if two parties have really put each 
> other on hold, it will most likely require
> a re-INVITE sequence initiated by A and
> a re-INVITE sequence initiated by B to 
> actually get the call fully off hold.
> 
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 25 Apr 2001 13:59:43 -0400

> .  Note that either party can take the other party off

Then the text needs to be updated.  

Either party can send re-INVITE with 
non-hold SDP, however the receiver can 
return hold SDP if the party doesn't 
wish to come off hold.

> holds B, then both parties are in the state of having no media stream.

This isn't necessarily true in SIP.
  
If A sends a re-INVITE with hold SDP to B, 
B can/should reply with non-hold SDP if B 
is willing to listen while on hold.

> still be unavailable, and A may reject the request (e.g. with 

If the receiver accepts the re-INVITE but wishes 
to currently have the call on hold, returning a 
200 with held SDP seems most appropriate.