Subject: [SIP] Problem with ACK through proxy

From: "Hrishikesh Saria" <[email-masked]>
Date: Thu, 26 Apr 2001 23:47:28 +0530

hi,
    i am receiving a Record-Route header in the 200 OK response. The Route header in the ACK  is being constructed using this. But the ACK is not reaching the callee , though it is reaching the proxy. But if the other person sends a Contact header in the 200 OK and that is added at the end of the Route header in ACK  , the ACK  is reaching the callee. If the Contact header is not present, what is being done ... this is wrong, i agree... (but it works) ... is that i am extracting the IP address of the callee's system from the 'c=...' of the SDP. 
    So , i have 2 questions:
    is the contact header mandatory in 200 OK for invite?
    if not , what is the proper solution to the above problem? i,e,. without having to look at SDP header...

thanks in advance.

regards
hrishikesh

---

From: "Brett Tate" <[email-masked]>
Date: Thu, 26 Apr 2001 16:55:28 -0400

> is the contact header mandatory in 200 OK for invite?

Yes. The Contact header is mandatory in 2xx for 
INVITE as mentioned in section 6.15 and shown 
in table 4 rfc2543bis-02.

Note: older UAs might not add a Contact.  
In this case, it is up to the supporting 
record-routing Proxy to remember how to route to 
the final location.  (I assume that some proxies 
might attach Contact for the old UA to keep from 
having to store it.)  If there is no record-route,
the originating UA would send subsequent requests 
where it sent the previous on the call-leg.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: [email-masked]
Date: Mon, 30 Apr 2001 13:46:08 -0500

> From: Brett Tate [mailto:[email-masked]]
>

Ummm... I thought that 2543 made the assumption that,
if no "Contact" header is present, the "From" field
is to be used for future contacts. If you're trying
to interop with older clients, I'd say that this is
still the most appropriate behavior.

/a

---

From: "Brett Tate" <[email-masked]>
Date: Mon, 30 Apr 2001 16:13:46 -0400

> still the most appropriate behavior.

Yes, the From is used to help build the Route from 
called to caller if there was no Contact in original 
INVITE.  The From is not used in build route from 
caller to called.

The question and answer dealt with building Route
for ACK/etc from INVITE's 200 that contained 
Record-Route and no Contact, and what the proxy 
needs to do when receiving ACK without Route that 
needs to be delivered to the same called UA 
(that didn't add its Contact in 200).