Subject: Re: [SIP] I-D ACTION:draft-ietf-sip-service-examples-01.txt

From: Henry Chen <[email-masked]>
Date: Mon, 23 Apr 2001 16:39:07 -0500

Hello,

    I have question about Call Hold in SIP signaling.
    I assume that A and B are in different call control states after B holds A as as
section 2.1 Call Hold of
    draft-ietf-sip-service-examples-01.txt. B is in hold state and ready to switch to
operation on other sessions
    while A is in held state and waits for B to re-establish the media stream.
    Based on this,  what is the proper SIP signaling for A to initiate a hold to B after B
holds A first?
    What is the proper SIP call flows for one party to re-establish the media stream when
both parties are in hold / held states?

    Thanks,

    Henry

[email-masked] wrote:

> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> This draft is a work item of the Session Initiation Protocol Working Group of the IETF.
>
>         Title           : SIP Service Examples
>         Author(s)       : A. Johnston, R. Sparks, C. Cunningham,
>                           S. Donovan, K. Summers
>         Filename        : draft-ietf-sip-service-examples-01.txt
>         Pages           : 96
>         Date            : 02-Mar-01
>
> This informational document gives examples of SIP (Session Initiation
> Protocol) services.  This covers most features offered in so-called
> Centrex offerings from local exchange carriers and PBX (Private
> Branch Exchange) features.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-sip-service-examples-01.txt
>
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
>         "get draft-ietf-sip-service-examples-01.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-ietf-sip-service-examples-01.txt".
>
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
>
>   ------------------------------------------------------------------------
> Content-Type: text/plain
> Content-ID:     <[email-masked]>

---

From: "Brett Tate" <[email-masked]>
Date: Mon, 23 Apr 2001 18:34:53 -0400

<snip>

> what is the proper SIP signaling for A to 
> initiate a hold to B after B holds A first?

The flow looks the same as a normal re-INVITE 
to put a call on hold; however both re-INVITE 
and 200 will contain hold SDP.
 
> What is the proper SIP call flows for one 
> party to re-establish the media stream 
> when both parties are in hold / held states? 

A party can only offer itself off hold, the 
receiver can stay on hold if it desires.

For instance if A put B on hold, A would 
likely want to return a 200 with hold SDP 
for a re-INVITE from B.

Thus if two parties have really put each 
other on hold, it will most likely require
a re-INVITE sequence initiated by A and
a re-INVITE sequence initiated by B to 
actually get the call fully off hold.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.