Subject: Re: Fw: [SIP] Delivering Caller-ID through SIP

From: [email-masked]
Date: Tue, 10 Apr 2001 18:22:05 -0400

How does SIP convey the "privacy indicator" (presentation restriction
information) to the ISUP/ISDN implementation
on the gateway when the outgoing IAM/SETUP is built ?  What if I dial *67
and want to supress my Caller-ID ?

/somit

"Dean Willis" <[email-masked]> on 04/10/2001 06:02:14 PM

To:   "IETF SIP (E-mail)" <[email-masked]>
cc:    (bcc: Somit Ghosh/Telcordia)
Subject:  Fw: [SIP] Delivering Caller-ID through SIP

whoops, forgot to copy the list here . . .

Sorry!

--
Dean

----- Original Message -----
From: "Dean Willis" <[email-masked]>
To: "Sharath Rajasekar" <[email-masked]>
Sent: Tuesday, April 10, 2001 11:56 AM
Subject: Re: [SIP] Delivering Caller-ID through SIP

> Personally, I set my From: field to: sip:[email-masked]
when
> placing a call through a gateway. All the gateway's I've worked with
happily
> strip off the domain part and copy 9724735455 into the Calling Party ID.
>
> This is facilitated by the phone on my desk, which supports multiple user
> profiles (lines). I have the line1 button set up to use my phone number
in
> the From:, and line 2 set to use my username in the From:. I pick the
> appropriate "line" for an outbound call manually. Works dandy with no new
> headers.
>
> One might also envision a user outbound proxy or application server (or a
> smart UA) performing this service automatically on behlaf of the user.
>
> --
> Dean
>
>
> ----- Original Message -----
> From: "Sharath Rajasekar" <[email-masked]>
> To: "sip list" <[email-masked]>; <[email-masked]>
> Sent: Monday, April 09, 2001 8:15 PM
> Subject: [SIP] Delivering Caller-ID through SIP
>
>
> >
> > Consider a SIP UA with a SIP URL [email-masked] which is associated
> > with a SIP Phone. This SIP Phone has a public number (444-555-6666).
> >
> > When a call is initiated by the phone, to a PSTN number, the following
> > INVITE will be sent out...
> >
> > INVITE sip:[email-masked] SIP/2.0
> >       From : UserA <sip:[email-masked]>
> > To : Unknown <sip:[email-masked]>
> >       ...
> >
> > How can one deliver the calling public number(444-555-6666 in this
case)
> > to the PSTN as caller-id through the gateway ?
> >
> > Some generic tag may be used say..."pstn-number: 444-555-6666" in the
> > >From header, but this will mean that all gateways must support this
tag.
> > Is there some other solution to this problem.
> >
> >
> > Regards
> > Sharath
> >
> >
> >
> > _______________________________________________
> > This list is for continuing development of the SIP protocol.
> > The sip-implementor's list is the place to discuss implementation,
> > and to receive advice on understanding existing sip.
> > To subscribe to it, send mail to
> > [email-masked] with "subscribe" in the body.
> >
>

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to
[email-masked] with "subscribe" in the body.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Steve Levy <[email-masked]>
Date: Wed, 11 Apr 2001 09:36:08 -0700

Check Section 6.26 (From Header) of 2543.bis-02. There it states:

A system SHOULD use the display name "Anonymous" if the
   identity of the client is to remain hidden.

The 'Anonymous' should be converted into presentation restricted for ISUP/ISDN

Steve