Subject: RE: [SIP] transfer call flows

From: "Tom-PT Taylor" <[email-masked]>
Date: Tue, 10 Apr 2001 19:35:11 -0400

The accepted solution is to include an Accept_Contact: header in the INVITE,
(i.e. as a parameter to the URI in the Refer-To:) indicating the detailed
contact address to reach.  For an invitation to another party to join a
conference call on a bridge server, for instance, the Accept-Contact would
identify not only the bridge server but also the specific bridge serving the
conference.

-----Original Message-----
From: Zonoun, Mo [SC2:4K02:EXCH] 
Sent: Monday, April 09, 2001 5:00 PM
To: [email-masked]
Subject: RE: [SIP] transfer call flows

I posted the following question while back but I didn't get any response. 
How do you make sure that a new INVITE in a Call Transfer gets to the
correct UA-C when there are multiple UA candidates, including the case where
the UA-C is a gateway to another network.

Mo Zonoun

---

From: "Brett Tate" <[email-masked]>
Date: Wed, 11 Apr 2001 16:26:08 -0400

> (i.e. as a parameter to the URI in the 
> Refer-To:) indicating the detailed contact 
> address to reach.  For an invitation to 
> another party to join a conference call on 
> a bridge server, for instance, the 
> Accept-Contact would identify not only 
> the bridge server but also the specific 
> bridge serving the conference.

The above solution works when only a single 
Request-URI change is involved in delivery 
of the INVITE to the final UA.

A Refer-To with pre-loaded Route is needed 
when multiple proxies (potentially changing 
Request-URI) are involved in reaching the 
final destination UA.

> > but I didn't get any response.

See 
http://lists.bell-labs.com/pipermail/sip/2001q1/006480.html
 
> > How do you make sure that a new INVITE in 
> > a Call Transfer gets to the correct UA-C 
> > when there are multiple UA candidates, 
> > including the case where the UA-C is a 
> > gateway to another network.

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.