Subject: [SIP] 400 bad request

From: "Agboh, Charles" <[email-masked]>
Date: Thu, 19 Apr 2001 22:34:37 +0200

Hi,

For what reasons other than failed codec nogotiation will a UA send a 400
bad request without some appropriate warning?
 
gw-to-7960
---------------

INVITE sip:[email-masked];user=phone SIP/2.0 
Via: SIP/2.0/UDP  10.1.1.90:52918 From: <sip:10.1.1.90> 
To: <sip:[email-masked];user=phone> Date: Mon, 03 Jan 2000 04:30:14 GMT 
Call-ID: [email-masked] Cisco-Guid:
2416467364-982057087-0-185416476 User-Agent: Cisco-SIPGateway/IOS-12.x 
CSeq: 101 INVITE 
Max-Forwards: 6 
Timestamp: 946870214
Contact: <sip:10.1.1.90:5060;user=phone> 
Expires: 180
Content-Type: application/sdp 
Content-Length: 133 

v=0 
o=CiscoSystemsSIP-GW-UserAgent 5057 1112 IN IP4 10.1.1.90 
s=SIP Call
c=IN IP4 10.1.1.90 t=0 0
m=audio 20486 RTP/AVP 8 0 18 

7960-to-gw
-----------------

SIP/2.0 400 Bad Request 
Via: SIP/2.0/UDP  10.1.1.90:52918
 From: <sip:10.1.1.90> 
To: <sip:[email-masked];user=phone> 
Call-ID: [email-masked]
 Server: Cisco IP Phone/ Rev. 1/ SIP enabled 
CSeq: 101 INVITE
Content-Length: 0

gw-to-7960
-----------------

ACK sip:[email-masked];user=phone SIP/2.0 
Via: SIP/2.0/UDP  10.1.1.90:52918 
From: <sip:10.1.1.90> 
To: <sip:[email-masked];user=phone> 
Date: Mon, 03 Jan 2000 04:30:14 GMT Call-ID:
[email-masked] 
Max-Forwards: 6 Content-Length: 0
CSeq: 101 ACK

Best Regards, 
Charles 
============== 
Charles Agboh  
Ebone 
M: +32 495 58 52 67 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brierre, Jean Joseph" <[email-masked]>
Date: Fri, 20 Apr 2001 14:17:03 +0000

Charles,

In your below trace, if 3000 does not match a valid dial peer translation
in your gateway, it will return 400 response.

-----Original Message-----
From: Agboh, Charles [mailto:[email-masked]]
Sent: Thursday, April 19, 2001 3:35 PM
To: [email-masked]
Subject: [SIP] 400 bad request

Hi,

gw-to-7960
---------------

v=0 

7960-to-gw
-----------------

SIP/2.0 400 Bad Request 

gw-to-7960
-----------------

Best Regards, 
Charles 
============== 
Charles Agboh  
Ebone 
M: +32 495 58 52 67