Subject: [SIP] Retransmission of responses in TCP, but not in UDP?

From: "T.Sunil Kumar" <[email-masked]>
Date: Tue, 17 Apr 2001 21:16:00 +0530

Hi,

Can someone help me understand why is it that requests need not be
retransmitted while using TCP, but responses need to be.

--
Thanks,
--Sunil
_____________________________________
T.SUNIL KUMAR
Net Brahma Technologies
Internext Networking Software
A Microland Group Venture
[email-masked]
http://www.netbrahma.com
Tel :  91.80. 552 1451/5011/5012/5014
              Ext : 269/270
Fax :  91.80. 553 7233

e-card: http://www.ecardfile.com/tskr
_____________________________________

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Sunitha Kumar <[email-masked]>
Date: Tue, 17 Apr 2001 10:23:24 -0700

First of all, we still need retransmissions in TCP, since, the messages
may traverse through unreliable links.
However, we only need to perform for responses, and not for requests.
This is because, if the request goes through an unreliable link, the
proxies b/w those unreliable link, will
take care of retransmission. (retransmission of INVITE stops, once the
proxy gets an informational
response, which is hop by hop)
But, this cannot be said for final responses, since these are end to end,

so, it is the responsibility of the caller and the callee to perform
retransmission.

Hope that helps
sunitha

--
Sunitha Kumar
http://www.cisco.com