Subject: RE: [SIP] Response if user not registered?

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 2 Apr 2001 04:07:49 -0400

I have to agree with Dean that this thread is awfully confused and sometimes
frightening.

People want to charge for outgoing calls through proxies. Whether I think
thats a good idea or not is irrelevant. To do that, these people need to
identify the person or phone making the call. Thats OK. In SIP, we have
mechanisms for allowing outbound proxies to authenticate the caller, and
determine exactly who they are. Just dandy. I am totally baffled as to what
this has to do with SIP registrations. SIP registrations don't establish
identity, they don't upload authorizations, or anything like that. They
create address bindings. Creating address bindings has nothing to do with
making outbound calls.

I believe this issue in 3gpp arises because for them, they have "extended"
register to do more than create bindings. They use it to assign the proxy
which will handle both incoming and outgoing calls for the user, and
basically do not allow outgoing calls until such a selection is made. So,
we're really not talking about registrations in the sip sense. We are
talking about a new function. As the function is one of policy, its also one
which, arguably, is an implementation decision, not a protocol one. There is
no reason why I cannot build proxies that refuse outgoing calls unless this
assignment function has taken place. Again, whether or not this is a good
thing, is an entirely separate question.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

> -----Original Message-----
> From: Roy, Radhika R, ALCOO [mailto:[email-masked]]
> Sent: Sunday, April 01, 2001 5:27 PM
> To: Michael Thomas
> Cc: [email-masked]
> Subject: RE: [SIP] Response if user not registered?
> 
> 
> For SIP, that means you have no control over who I
> use for the outbound proxy. There's no reason to
> modify SIP to enforce something that is
> unenforcible.
> 
> [RRR] Still an association (e.g., 
> registration/INVITE-authentication etc.)
> needs to be provided how charging can be made for service 
> offerings. (It is
> not about control per se.)
> 
> Radhika R. Roy
> 
> Roy, Radhika R, ALCOO writes:
>  > Folks:
>  > 
>  > Let us not forget the reality in offering the VoIP 
> services. As Brian has
>  > explained, there has to be charging. That is, there need to be an
>  > association between the caller (person) and the 
> device/location/address.
>  > 
>  > (No one is disputing the fact that calls can always be 
> made is the IP
>  > addresses are known and routers can route the calls to the 
> destination IP
>  > addresses, and IP addresses can be assigned dynamically.)
>  > 
>  > Best regards,
>  > 
>  > Radhika R. Roy
>  > AT&T
>  > 
>  > -----Original Message-----
>  > From: Brian F. G. Bidulock [mailto:[email-masked]]
>  > Sent: Friday, March 30, 2001 2:40 PM
>  > To: Michael Thomas
>  > Cc: Drage, Keith (Keith); [email-masked]; 'Juha 
> Heinanen';
>  > [email-masked]
>  > Subject: Re: [SIP] Response if user not registered?
>  > 
>  > 
>  > Michael,
>  > 
>  > I don't have an IP address tatooed on my forhead and
>  > my left hand.
>  > 
>  > Also, some like to charge for calls based on where you
>  > are calling from.  They often like to charge you, not
>  > your terminal.
>  > 
>  > --Brian
>  > 
>  > Michael Thomas wrote:                     (Fri, 30 Mar 
> 2001 10:46:32)
>  > > Brian F. G. Bidulock writes:
>  > >  > Michael,
>  > >  > 
>  > >  > Sorry Mike, registration is for personal mobility as
>  > >  > well, not just terminal mobility.
>  > > 
>  > >    And this contradicts what I said... how?
>  > >    It certainly doesn't make a case for linkage
>  > >    of incoming and outgoing calls to some HLR-like
>  > >    entity. Location is only important on the
>  > >    incoming call side. The outgoing side is
>  > >    completely separate. Likewise, data
>  > >    connectivity is completely separate from
>  > >    call/SIP presence. This is the fundamental
>  > >    conflation that Q.931-like schemes get 
>  > >    completely wrong in the IP world.
>  > > 
>  > > 	      Mike
>  > 
>  > -- 
>  > Brian F. G. Bidulock    ¦ The reasonable man adapts 
> himself to the ¦
>  > [email-masked]    ¦ world; the unreasonable one 
> persists in  ¦
>  > http://www.openss7.org/ ¦ trying  to adapt the  world  to 
> himself. ¦
>  >                         ¦ Therefore  all  progress  
> depends on the ¦
>  >                         ¦ unreasonable man. -- George 
> Bernard Shaw ¦
>  > 
>  > _______________________________________________
>  > This list is for continuing development of the SIP protocol.
>  > The sip-implementor's list is the place to discuss implementation,
>  > and to receive advice on understanding existing sip.
>  > To subscribe to it, send mail to 
>  > [email-masked] with "subscribe" 
> in the body.
> 
> _______________________________________________
> This list is for continuing development of the SIP protocol.
> The sip-implementor's list is the place to discuss implementation,
> and to receive advice on understanding existing sip.
> To subscribe to it, send mail to 
> [email-masked] with "subscribe" in the body.
> 

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Brian F. G. Bidulock" <[email-masked]>
Date: Mon, 2 Apr 2001 05:21:48 -0500

Jonathan,

Good points.  However, moving this exended registration function
outside of SIP reduces SIP to no better than a connection establishment
protocol which is ignorant of the service which is being provided
by it.  In that case, why not move SIP's inbound registration function
outside the protocol as well...

--Brian

Jonathan Rosenberg wrote:                      (Mon, 02 Apr 2001 04:07:49)

-- 
Brian F. G. Bidulock    ¦ The reasonable man adapts himself to the ¦
[email-masked]    ¦ world; the unreasonable one persists in  ¦
http://www.openss7.org/ ¦ trying  to adapt the  world  to himself. ¦
                        ¦ Therefore  all  progress  depends on the ¦
                        ¦ unreasonable man. -- George Bernard Shaw ¦

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 3 Apr 2001 23:49:44 -0400

> thing, is an entirely separate question.

For outbound proxies in general, it would be 
nice to communicate that a call is being 
rejected because the calling party is unknown.

Currently the 403 Forbidden appears to be 
the best SIP response.  However it doesn't 
specify if the response is being rejected 
by the called party or outbound proxy.  
[Note: modifying the 403 reason 
phrase or including the Warning header with 
warn-text would be useful to the user; 
however the actual devices could not really 
act upon the text unless standardized.  The
same would be true if a Contact contained 
a link to web page or it the call was 
connected to treatments.]  
The 401 Unauthorized sounds like a 
potential candidate, but it has the same 
ambiguity as the 403 and may actually be 
interpreted as being from the called party.

When a REGISTER is desired and target 
is unknown, another solution would 
be to send REFER with method=REGISTER 
if Refer-To without a host was valid.
However since a 3GPP gateway would most 
likely drop the host address anyway, 
I assume that the Refer-To could be 
"sip:localhost;method=REGISTER". 
[  :) That wasn't a stab, I was 
referring to the fact that translations 
or something from the mobile would 
actually be used to identify the real 
target address of the REGISTER.]