Subject: RE: [SIP] Response if user not registered?

From: "Sean Olson (EUS)" <[email-masked]>
Date: Wed, 4 Apr 2001 09:20:16 -0500

>> I believe this issue in 3gpp arises because for them, they 
>> have "extended"
>> register to do more than create bindings. They use it to 
>> assign the proxy
>> which will handle both incoming and outgoing calls for the user, and
>> basically do not allow outgoing calls until such a selection 
>> is made.

This is incorrect. The REGISTER process in 3GPP is used
for address bindings. The selection of a local outbound
proxy is done BEFORE the registration occurs. Barring
an outbound request because a terminal is not registered
at the local outbound proxy is a reasonable thing to do.
Letting the user know that this is the case is also 
a reasonable thing to do. 403 seems appropriate.

/sean

---

From: Juha Heinanen <[email-masked]>
Date: Wed, 4 Apr 2001 18:59:04 +0300 (EEST)

Sean Olson (EUS) writes:

 > Barring

no it isn't.  as has been mentioned many times, sip registration is not
for that kind of purpose.  it must be enough that the outboud proxy is
(a) able to authenticate the calling sip ua and that (b) the
authenticated (and thus known) user has via subscription or otherwise
the right to make outboud calls via this outbound proxy.

-- juha

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Michael Thomas <[email-masked]>
Date: Wed, 4 Apr 2001 11:10:47 -0700 (PDT)

> the right to make outboud calls via this outbound proxy.

  That's not what Sean actually wrote though,
  or at least that's not the way I interpreted
  what he wrote. I interpreted him to mean that
  it needs to authenticate (register) with the
  outbound proxy first, then do a SIP REGISTER.
  If that's what he meant, I think we're all in
  violent agreement.

		Mike

---

From: Sean Olson <[email-masked]>
Date: Wed, 4 Apr 2001 17:40:08 -0500 (CDT)

> the right to make outboud calls via this outbound proxy.

This is 100% an application policy decision. It is not
an issue with the SIP protocol. You might as well tell
me that it is illegal for a SIP proxy to use time of day
to route a SIP request. We are not using the SIP REGISTER
for this purpose. We are using registration state. This is
a big difference. Part of this registration state has to
do with whether or not the user is authenticated to make
outbound calls. 

-- 
-----------------------------------------------------------------
Sean Olson            mailto:[email-masked]
Ericsson Inc.

---

From: Juha Heinanen <[email-masked]>
Date: Thu, 5 Apr 2001 07:41:14 +0300 (EEST)

> do with whether or not the user is authenticated to make

fine, but then there is no need to a new error code (registration
required) for this (we don't have an error code for wrong time of the
day either).

-- juha

---

From: "Dean Willis" <[email-masked]>
Date: Mon, 9 Apr 2001 17:54:24 -0500

RE: [SIP] Response if user not registered?I disagree that barring a terminal from sending an INVITE through a proxy because that terminal has not sent an INVITE through that proxy is a reasonable thing to do. That is -- I don't think its a good idea, and I don't think the 3GPP model technically requires it. Certainly you might wish to refuse to transit messages for a device that doesn't have a layer-2 registration, as such a message would rather obviously be a spoof of some kind. So, there's sort of a layer 2/3 confusion in the concept of registration in 3GPP, which I believe can be traed back to the semantics of the GSM registration process.

But in any case, the main problem here is that the 3GPP visited proxy, or P-CSCF, is attempting to discover the home edge proxy (I-CSCF or S-CSCF) that will process future INVITEs from the mobile terminal by analyzing the target of the terminal's REGISTER message. Practically speaking, the P-CSCF is deducing an outbound proxy rule for the mobile terminal by observing the target of RESGISTERs from that terminal. In other words, this approach uses REGISTER to force source routing for INVITEs -- and it's all a means for forcing INVITES to be processed by both local and remote proxies BEFORE applying the usual INVITE destination resolution algorithm. It's a source-routing kludge, and there's GOT to be a better way. At least I hope there is.

--
Dean

  ----- Original Message ----- 
  From: Sean Olson (EUS) 
  To: [email-masked]' ; [email-masked]' 
  Sent: Wednesday, April 04, 2001 9:20 AM
  Subject: RE: [SIP] Response if user not registered?

  /sean