Subject: RE: [SIP] Informing UA after network initiated deregistration?

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 2 Apr 2001 03:36:59 -0400

> -----Original Message-----
> From: Baniel Uri-CUB001 [mailto:[email-masked]]
> Sent: Sunday, April 01, 2001 9:34 AM
> To: 'Dean Willis'; [email-masked]
> Cc: Baniel Uri-CUB001; 'Bob Penfield'; Sriram Parameswar; 
> 'Romeo Zwart';
> 'Stephen Terrill'; 'Igor Slepchin'; 'William Marshall'; Chen
> Bonnie-BCHEN1; Xu Lang-LXU1; sip
> Subject: RE: [SIP] Informing UA after network initiated 
> deregistration?
>
> [4]My understanding is that in Minneapolis it has been 
> decided/approved to
> Inform a UA after network initiated deregistration. My 
> questions to you guys
> are:
> [4.1] Has it been decided to go for implicit subscription for 
> notification
> in the Registration request? or to specify it in a dedicated header?

More headers in registrations. I love it. When are we going to get the "by
the way, I am interested in knowing when I have exactly  15 dollars left in
my account, the one I set up with Mastercard". I propose:

Mastercard-Balance-Subscription: 15;currency=dollar

Just in case there are those who like this idea (and since sarcasm by email
is sometimes missed) - no, we are NOT having a new header in registrations.

Some have debated whether or not the presence spec allows or disallows
"implicit" registrations. This fits into the growing category of things that
"the SIP spec doesn't, nor shouldn't, say". SIP for presence specifies a way
to create subscriptions, and a way to generate notifications for
subscriptions. It does not say that when you build a system, the ONLY way to
get subscriptions in there is to use the SUBSRIBE method. I think a web form
is a perfectly fine way to create subscriptions. We then use our
notification mechanisms to generate notifies for them. How the lifetimes of
these subscriptions are managed is also an implementation issue.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Bob Penfield" <[email-masked]>
Date: Mon, 2 Apr 2001 13:45:59 -0400

I don't think that it is necessary to add more headers. The Event header
should be used for implicit subscription just like it is used for explicit
subscriptions.

Bob
d:-)

Robert F. Penfield
Chief Software Architect
Acme Packet, Inc.
130 New Boston Street
Woburn, MA 01801
(781) 933-6166
[email-masked]

----- Original Message -----
From: "Jonathan Rosenberg" <[email-masked]>
To: "'Baniel Uri-CUB001'" <[email-masked]>; "'Dean Willis'"
<[email-masked]>; <[email-masked]>
Cc: "'Bob Penfield'" <[email-masked]>; "Sriram Parameswar"
<[email-masked]>; "'Romeo Zwart'" <[email-masked]>;
"'Stephen Terrill'" <[email-masked]>; "Igor Slepchin"
<[email-masked]>; "'William Marshall'" <[email-masked]>;
"Chen Bonnie-BCHEN1" <[email-masked]>; "Xu Lang-LXU1"
<[email-masked]>; "sip" <[email-masked]>
Sent: Monday, April 02, 2001 3:36 AM
Subject: RE: [SIP] Informing UA after network initiated deregistration?