Subject: RE: [SIP] Further editorial nit in the bis draft

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 27 Apr 2001 11:20:54 -0400

-----Original Message-----
From: Sean Olson (EUS) [mailto:[email-masked]]
Sent: Friday, April 27, 2001 11:02 AM
To: 'Vijay Gurbani'; Jonathan Rosenberg
Cc: Christer Holmberg (LMF); [email-masked]'
Subject: RE: [SIP] Further editorial nit in the bis draft

>>Jonathan: 
>> 
>>I misinterpret many thing, but definitely not this one :-)  In 
>>some earlier 
>>posting, I made the same point: a BYE should be sent after a 
>>CANCEL iff 
>>the 200 OK (INVITE) from the UAS and the CANCEL pass each 
>>other on the wire. 
>
>This is not what Jonathan is saying. He is referring to the 
>possibility of sending a BYE *instead* of a CANCEL, not sending 
>a BYE in the event a CANCEL crosses on the wire. 

Everyone loves to put words into my mouth...

I was saying that the preferred approach is to send CANCEL first, and then
iff you get a 200 OK anyway (which happens if the CANCEL and 200 OK pass on
the wire) then send BYE. I was also saying we should keep "just send BYE" as
a MAY. Vijay seems to be saying we should not even mention that possibility.

-Jonathan R.
---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: Vijay Gurbani <[email-masked]>
Date: Fri, 27 Apr 2001 10:48:04 -0500

Jonathan Rosenberg wrote:
[...]
> sean>This is not what Jonathan is saying. He is referring to the
> sean>possibility of sending a BYE *instead* of a CANCEL, not sending
> sean>a BYE in the event a CANCEL crosses on the wire.
> 
> iff you get a 200 OK anyway (which happens if the CANCEL and 200 OK pass 
> on the wire) then send BYE. 

Right on!

I could spend some time and come up with time-line diagrams if anyone is
interested (or if you want them to go in the -04 bis).  But it is simple 
really: If after sending CANCEL, a UAC gets a 200 OK (INVITE), ACK it and 
send a BYE (remember: CANCEL has no effect on a UAS state machine if it has 
already sent a final response).

If after sending a CANCEL, a UAC gets a non-2xx response to the INVITE,
just ACK it; no need to send the BYE -- session was never established.

> I was also saying we should keep "just send BYE" as a MAY. Vijay seems to 
> be saying we should not even mention that possibility.

Right.  We should not even mention it; a MAY will lead to the same ambiguity 
we are facing now.

Regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Internet Software and eServices Group 
Lucent Technologies/Bell Labs Innovations 263 Shuman Blvd., Rm 1A-413
Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713 0184