Subject: [SIP] A question about Cancel request

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Mon, 2 Apr 2001 11:48:41 +0100

I have a basic question about sip.
Cancel request is used to cancel a pending INVITE.
In sip signalling establishment procedure, if the callee agent for some
reason fails, it can't receive anything from its proxy, after the proxy
server of the callee retransmittes 6 times INVITE messges, it should give up
sending INVITE. My quesiton is whether the Cancel request is needed to send
out by the proxy server to the callee, if so, it will cause another 11 times
cancle request beeing sent.

Thanks

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

_______________________________________________
This list is for continuing development of the SIP protocol.
The sip-implementor's list is the place to discuss implementation,
and to receive advice on understanding existing sip.
To subscribe to it, send mail to 
[email-masked] with "subscribe" in the body.

---

From: "Mayank Sharma" <[email-masked]>
Date: Tue, 3 Apr 2001 11:15:36 +0530

> cancle request beeing sent.

The Cancel is required to be sent to the callee. Simple reason being that the

proxy does not know weather the callee UA is down or is simply not responding
for the time being. Sending Cancel ensures that in case UA is not down this
Cancel
will cancel the previous Invite, and the UA is not supposed to respond to
that Invite
at a later stage.

Regards,
Mayank Sharma
Mindtree Consulting Pvt. Ltd.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 4 Apr 2001 02:30:40 -0400

> -----Original Message-----
> From: Mayank Sharma [mailto:[email-masked]]
> Sent: Tuesday, April 03, 2001 1:46 AM
> To: Chen, Xin (Xin); [email-masked]
> Subject: RE: [SIP] A question about Cancel request
> 
> 

Actually, I have debated whether or not CANCEL is useful in the case where
you never received any provisional response at all, not even a 100. This is
likely a sign that the device or the network has failed, in which case the
CANCEL is not useful. 

I would tend to think that the best answer is to say that if you never
receive a provisional response, you MAY send a CANCEL, but its not
mandatory. If you do get a provisional response, you SHOULD CANCEL upon
timeout.

-Jonathan R.

---
Jonathan D. Rosenberg                       72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.cs.columbia.edu/~jdrosen         PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Wed, 18 Apr 2001 11:10:28 +0100

I couldn't find a way in sip rfc that a proxy can initate disconnect to a
call if the call is established. UAS will ignore Cancel becuase it has sent
200 OK. And Bye can only been sent by UA not by proxy. So it seems that
there is no way for the network to release a call if it is established
already. Please point out what I missed in that rfc.

Thanks

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

-----Original Message-----
From: Yu, James [mailto:[email-masked]]
Sent: 17 April 2001 19:36
To: 'Alan Johnston'
Cc: [email-masked]'
Subject: RE: [SIP] A question about Cancel request

Alan,

CANCEL is to cancel a pending a request.  If the call has been established
and there is no pending request to be cancelled, sending a cancel will not
result in call termination.  A 3G wireless caller may be put on hold (e.g.,
call to service center) but mobile phone is out of radio contact with the
network (e.g., in the tunnel or outside coverage area).  The 3G network
knows about the situation; therefore, may need a way to terminate the call
(instead of waiting for the UA at the other side to terminate the call).

There is also a potential fraud case where the proxy servers want to stay in
the signaling path by using the record-route and route mechanism but the UAs
ignore the route and one of them sends the BYE directly to the other side to
terminate the call (the UAs can ignore the protocol rules if they are
programmed to do so).  A mechanism may be needed for the proxies in the
"route" to terminate the call - something like "proxy initiated disconnect."

James  

> From: Alan Johnston [mailto:[email-masked]]
> Sent: Tuesday, April 17, 2001 2:57 PM
> To: Drage, Keith (Keith)
> Cc: [email-masked]'
> Subject: Re: [SIP] A question about Cancel request
> 
> 
> Keith,
> 
> Of course nothing in the Call Flows draft is normative - in 
> any conflict between
> it and the RFC, the RFC holds.
> 
> Having said that, I'm not sure I understand your concern 
> here.  How many
> retransmissions the stateful proxy 2 does is an 
> implementation issue - it could
> choose to give up at any time.  Also, if the proxy wishes to 
> terminate the call,
> its only option is to send a CANCEL - it can not originate a 
> BYE.  The caller
> User A could send either a BYE or a CANCEL to terminate the call.
> 
> How and when a proxy initiates a CANCEL doesn't seem to need 
> to be spelled out
> in the SIP standard.
> 
> Thanks,
> Alan Johnston
> sip:[email-masked]
> 
> "Drage, Keith (Keith)" wrote:
> 
> > We have a clear incompatibility in the SIP drafts here.
> >
> > While draft-ietf-sip-call-flows-03.txt section 3.2.3 
> implies that the
> > expected action is to send a CANCEL, we have been unable to 
> find any text in
> > the bis-02 draft indicating any special use of CANCEL from 
> a proxy in this
> > case.
> >
> > The only text we have found is text that says anybody can 
> send a CANCEL at
> > any time.
> >
> > Whether it is MUST, MAY or MUST NOT I believe we do need 
> some text on this
> > subject.
> >
> > My view is that it would say MAY, possibly followed by some guidance
> > comments on conditions when it might be more appropriate 
> than others.
> >
> > by the way, the signalling flows draft says the CANCEL is 
> sent 7 times. I
> > thought 11 was the more appropriate number in this case, 
> using both T1 and
> > T2.
> >
> > Keith
> >
> > Keith Drage
> > Lucent Technologies
> > Tel: +44 1793 776249
> > Email: [email-masked]
> >
> > > ----------
> > > From:         Jonathan Rosenberg[SMTP:[email-masked]]
> > > Sent:         04 April 2001 7:30
> > > To:   'Mayank Sharma'; Chen, Xin (Xin); [email-masked]
> > > you never received any provisional response at all, not 
> even a 100. This
> > > is

---

From: "Yu, James" <[email-masked]>
Date: Wed, 18 Apr 2001 07:57:35 -0500

Xin,

Only the UA can send BYE, not the proxy server.  That is why in my earlier
e-mail I indicated that there might be a need for a "proxy initiated
disconnect."

James

> From: Chen, Xin (Xin) [mailto:[email-masked]]
> Sent: Wednesday, April 18, 2001 6:10 AM
> To: [email-masked]'
> > > > > > reason fails, it can't receive anything from its 
> proxy, after
> > > > > > the proxy
> > > > > > server of the callee retransmittes 6 times INVITE 
> messges, it
> > > > > > should give up

---

From: "Agboh, Charles" <[email-masked]>
Date: Wed, 18 Apr 2001 15:04:13 +0200

The proxy could use a session timeout of zero with an invite (re-invite)
request for the same session.

-Charles
Hi james;-)

> Sent: Wednesday, April 18, 2001 2:58 PM
> To: 'Chen, Xin (Xin)'
> > > > > > > sending INVITE. My quesiton is whether the Cancel 
> request is
> > > > > > > needed to send
> > > > > > > out by the proxy server to the callee, if so, it 
> will cause
> > > > > > > another 11 times
> > > > > > for the time being. Sending Cancel ensures that in 
> case UA is
> > > > > > not down this
> > > > > > Cancel

---

From: "Chen, Xin (Xin)" <[email-masked]>
Date: Wed, 18 Apr 2001 15:45:21 +0100

James,
Yes, I agree that we need "proxy iniated disconnct". But how?

Charles,
Is this standardized in sip bis? What happens if the UA donesn't support
session timer header? If proxy can send invite, so it actually acts as a
B2BUA, so why not just sends a Bye to caller and callee both?

Thanks

Xin Chen

Lucent Technologies
Tel: +44 1793 883137
Mobile: +44 7799 034668

-----Original Message-----
From: Agboh, Charles [mailto:[email-masked]]
Sent: 18 April 2001 13:04
To: 'Yu, James'; 'Chen, Xin (Xin)'
Cc: [email-masked]'
Subject: RE: [SIP] A question about Cancel request

-Charles
Hi james;-)

---

From: "Agboh, Charles" <[email-masked]>
Date: Wed, 18 Apr 2001 21:04:10 +0200

My description was not quiet clear;  The SIP FAQ explains that better....

http://www.cs.columbia.edu/~hgs/sip/faq.cgi?_highlightWords=timer&file=40

.....However, state might be useful for certain applications (e.g., when
billing is involved, when firewall permissions need to be set etc.). Session
timer extension has been defined to solve this. The draft can be found at
http://www.cs.columbia.edu/~hgs/sip/drafts/draft-ietf-sip-session-timer-01.t
xt and it basically allows the servers indicate a desired refresh interval.
The call is considered terminated if a re-INVITE is not received within that
interval

It is not a standard way of terminating a session.

-Charles
> Sent: Wednesday, April 18, 2001 4:45 PM
> To: Agboh, Charles; 'Yu, James'; Chen, Xin (Xin)
> > > > > > > will cancel the previous Invite, and the UA is 
> not supposed
> > > > > > > to respond to
> > > > > > > that Invite
> > > > > > > at a later stage.
> > > > > >

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 27 Apr 2001 05:17:41 -0400

> From: Vijay Gurbani [mailto:[email-masked]]
> Sent: Thursday, April 26, 2001 10:15 AM
> To: Jonathan Rosenberg
> Cc: 'Drage, Keith (Keith)'; 'Mayank Sharma'; Chen, Xin (Xin);
> [email-masked]'
> Jonathan Rosenberg wrote:
> [...]
> > I agree that it is worthwhile discussing the usage of 
> CANCEL in a proxy in
> > more detail. Unless anyone objects, I will add some text 
> (for -04) that 
> > says that a proxy SHOULD NOT send a CANCEL for a timed-out 
> request for 
> > which it has not received any provisional response. The 
> proxy is supposed 
> > to have gotten a 100 if the final response can't be 
> answered within 500ms. 
> > So, the absence of a provisional response after 32s implies 
> that there is 
> > either a malfunctioning, or non-existent server at the 
> receiving end of 
> > the request. In either case, sending CANCEL is useless.
> 
> Sounds good to me.  I always thought it was pointless sending 
> a CANCEL to
> the same destination that has not responded to re-transmitted INVITEs.
> 
> BTW, you mention -04 bis, what happened to -03?  As far as I 
> know, -02 is
> the latest on the SIP web site at Columbia...

What I meant is that I won't include this in -03, since I want to get that
submitted shortly. -04 will end up being a more extensive update.

-Jonathan R.

---
http://www.jdrosen.net                      PHONE: (973) 952-5000