Subject: [Sip] Question: Timer for Proceeding

From: "Fuxbruner, Amihay" <[email-masked]>
Date: Wed, 10 Apr 2002 17:17:48 +0300

Hi,

Bis 09 section 17.1.1.2 does not include timer for proceeding state.
The protocol also says one SHOULD NOT retransmit in proceeding state.
Should we need a timer or is it application decision ?

Thanks,

Amihay Fuxbruner
System Engineering - Signaling R&D
Comverse

---

From: [email-masked]
Date: Wed, 10 Apr 2002 20:14:26 +0530

Hi Amihay,
     The client transaction does start timer C
when sending the INVITE request. This timer is
reset on receiving any provisional response. On
timeout, the client transaction moves to Terminated
state.

     In bis-05, this was described in Section 17,
and also indicated in the "INVITE client transaction"
diagram. But in bis--9, this description has been moved
to Sec 16.6, bullet 11. As an aside, it seems to have been
missed out in the INVITE client transaction diagram....

Subhash Nayak.
Hughes Software Systems.
http://www.hssworld.com

"Fuxbruner, Amihay" <[email-masked]> on 04/10/2002 07:47:48
PM

To:   [email-masked]
cc:   "Ivanov, Elena" <[email-masked]> (bcc: Subhash Ullal
      Nayak/HSSBLR)

Subject:  [Sip] Question: Timer for Proceeding

Hi,

Thanks,

Amihay Fuxbruner

---

From: Alexandre Charest <[email-masked]>
Date: Wed, 10 Apr 2002 11:26:56 -0400

Timer C is for proxies.
In a UAC, if you want to wait forever in the proceeding state you are free
to do so. This is application specific.

Alexandre Charest

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: April 10, 2002 10:44 AM
To: Fuxbruner, Amihay
Cc: [email-masked]; Ivanov, Elena
Subject: Re: [Sip] Question: Timer for Proceeding

Hi Amihay,

Subhash Nayak.
Hughes Software Systems.
http://www.hssworld.com

To:   [email-masked]

Hi,

Thanks,

Amihay Fuxbruner

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip