Subject: RE: [Sip] Revised Service Route Discovery Draft

From: [email-masked]
Date: Tue, 23 Apr 2002 10:28:37 +0300

Hi AC!

> -----Original Message-----
> From: ext AC Mahendran [mailto:[email-masked]]
> Sent: 22 April, 2002 19:49
> To: Dean Willis; [email-masked]
> Cc: 3GPP_TSG_CN_WG1
> Subject: Re: [Sip] Revised Service Route Discovery Draft
> 
> Dean:
> 
> The Record-Route headers in section 5.6 (in transactions F3 & 
> F5) are in the wrong order.

Well spotted! And the same thing happened to all the Via headers...
Will be corrected in the next update. Thanks for pointing this out.

> Also, doesn't the "Path" header provide the same functionality as the 
> "P-Service-Route" ?

In IETF SIP WG is was impossible to reach consensus on using
Path for both - originated and terminated - session cases.
Thus, the Path header will be used for terminated session
cases only, whereas the P-Service-Route header only affects
the originated session cases.

cheers,
 Bernie 

> thanks,
> AC
> 
> 
> At 06:15 PM 4/19/2002 -0500, Dean Willis wrote:
> 
> >I've submitted draft-willis-sip-svcrtdisco-01.txt to the 
> Internet Drafts
> >queue. This version includs refinements made by Bernie 
> Hoeneisen to my
> >earlier draft.
> >
> >The draft should be announced shortly on ietf-announce.
> >
> >In the meantime, please review:
> >
> >http://www.softarmor.com/sipwg/drafts/draft-willis-sip-svcrtd
isco-01.txt
>
>or
>
>http://www.softarmor.com/sipwg/drafts/draft-willis-sip-svcrtdisco-01.htm
>l
>
>or
>
>http://www.softarmor.com/sipwg/drafts/draft-willis-sip-svcrtdisco-01.xml
>
>
>This is a "P-header" draft addressing 3GPP's required header for
>reporting a service proxy assignment in the REGISTER response.
>
>
>Please review ASAP. We need to get this to IETF last call by the end of
>the month if at all possible.
>
>--
>Dean
>
>
>_______________________________________________
>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>This list is for NEW development of the core SIP Protocol
>Use [email-masked] for questions on current sip
>Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: AC Mahendran <[email-masked]>
Date: Tue, 23 Apr 2002 13:39:43 -0700

Bernhard:

Thanks for the clarification. I have a few more questions regarding the draft.

1) You have mentioned that P-Service-Route header is optional in REGISTER 
requests; How will the header, if present, be interpreted by the Registrar ?
2) How should the UAC interpret the order of proxies in the P-Service-Route 
header ? For eg: The UAC inverts the order of proxies in the Record-Route 
header to form a route set.
3) Also, you have mentioned that the UAC should add the P-Service-Route 
header information to the existing route set to form a new Route header 
value, which needs to be included in all origination requests. Should this 
header information be added to the beginning or the end of the route set ?
4) Should the UAC over write its existing P-Service-Route value if if gets 
a new value for P-Service-Route in 2XX response ?

It would be great if you can clarify all this information in the draft too.

thanks,
AC

---

From: [email-masked]
Date: Wed, 24 Apr 2002 11:17:06 +0300

Hi AC!

Thanks for your feedback, and pointing out these issues!
We certainly will consider those for the next version.

More comments inline.

cheers,
 Bernie

> Sent: 23 April, 2002 23:40
> To: Honeisen Bernhard (NET/Helsinki)
> Cc: [email-masked]
> Subject: RE: [Sip] Revised Service Route Discovery Draft
> 
> 
> 
> Bernhard:
> 
> 1) You have mentioned that P-Service-Route header is optional 
> in REGISTER requests; How will the header, if present,
> be interpreted by the Registrar ?

This is wrong in the draft (a typical copy-paste-modify
mistake...;-| ). Will be fixed in the next version.

> 2) How should the UAC interpret the order of proxies in the 
> P-Service-Route  header ? For eg: The UAC inverts the order
> of proxies in the Record-Route header to form a route set.

I guess you mean here the case where more than one
P-Service-Route header entry is present, and how the order
will be in the preloaded Route.

This issue is already in the process of beeing fixed.

> 3) Also, you have mentioned that the UAC should add the
> P-Service-Route header information to the existing route
> set to form a new Route header value, which needs to be
> included in all origination requests. Should this 

In section 5.1. (Procedures at the UA) it reads:
   "The UA MAY choose to exercise a service route for future messages
   associated with a given address-of-record for which a service route
   is known.  If so, it appends the given service route to any local
   required Route headers, and uses the result as a preloaded Route
   header in outgoing messages."!

The order for constructing the route-set in case there
are local Routes AND P-Service-Route should be more clarified.

> 4) Should the UAC over write its existing P-Service-Route 
> value if if gets a new value for P-Service-Route in 2XX response ?

I guess you are talking about re-registration.
The idea is, that the P-Service-Route of latest 200 OK
(for REGISTER) will be used. Will be clarified in the next version.

> It would be great if you can clarify all this information in 

I agree...

> >http://www.softarmor.com/sipwg/drafts/draft-willis-sip-svcrtd
isco-01.htm