Subject: RE: [Sip] REFER security options - removing Referred-By

From: "Ben Campbell" <[email-masked]>
Date: Mon, 22 Apr 2002 10:56:55 -0500

But of course there are other standard mechanisms by which you can
authenticate the caller. I was under the impression that is not currently
the case for the referror. If we _had_ a strong, agreed upon approach for
doing that, then referred-by would not be a big deal.

Robert did _not_ suggest making referred-by go away forever, just that we
link it to the effort of figuring out how to authenticate referrors, and
letting the refer draft move forward without blocking on that effort. Robert
had proposed some potential mechansism in Minneapolis, but I was under the
impression that it would take more work to complete them to the satisfaction
of the security guys.

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Monday, April 22, 2002 10:43 AM
> To: 'Michael Thomas'
> Cc: 'Ben Campbell'; [email-masked]; Adam Roach; 'Elwell, John';
> [email-masked]; Robert Sparks; [email-masked]
> Subject: RE: [Sip] REFER security options - removing Referred-By
>
>
> Well, since it's okay to put George Bush's name in the FROM header,
> it's got to be okay to put Kofi Anann's admin's name in the Referred-By
> header.  If Mr. Annan accepts the forged FROM, he will accept the
> forged referral.
>
> These headers are (presently) un-authenticated.  We don't DO anything
> with them (presently) other than show them in a GUI.  It's useful to
> do that.  I'll accept an authentication mechanism some day, but
> an un-authenticated field is useful.
>
> Brian
>
> > -----Original Message-----
> > From: Michael Thomas [mailto:[email-masked]]
> > Sent: Monday, April 22, 2002 11:31 AM
> > To: Rosen, Brian
> > Cc: 'Ben Campbell'; [email-masked]; Adam Roach; 'Elwell, John';
> > [email-masked]; Robert Sparks; [email-masked]
> > Subject: RE: [Sip] REFER security options - removing Referred-By
> >
> >
> > Rosen, Brian writes:
> >  > Y'know, sometimes I (personally, not as chair) think we take
> >  > the security argument just a little too far.
> >  >
> >  > Sure, I can finagle the From, but Referred-By is the header
> >  > I want to use in my GUI.  I'll attach no more credence to it
> >  > then I get from FROM unless it's authenticated, but it's damn
> >  > useful to display to a user.
> >
> >    So you're saying that it's OK for me to be able
> >    to just put Kofi Anann's admin's name in the
> >    Referred-by header, so that I can get through
> >    his screening so we can chat about my thoughts
> >    on San Francisco annexing Canada?
> >
> >    Groovy.
> >
> > 		    Mike
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 22 Apr 2002 11:42:47 -0400

Brian

---

From: [email-masked]
Date: Mon, 22 Apr 2002 19:37:16 +0300

Rosen, Brian writes:

 > These headers are (presently) un-authenticated.  

not in my service.  as i have said many times, we do check that the from
header matches with ones that my user is supposed to be using.  i don't
think there is any statement in the specs that says that we can't do so.
this is the same things as checking the source ip address, which we also
do.  internet would be much more user friendly if everybody would do so.

-- juha

---

From: Michael Thomas <[email-masked]>
Date: Mon, 22 Apr 2002 09:33:54 -0700 (PDT)

> an un-authenticated field is useful.

   A trip back to first principles might be a good
   idea here. Back in the 50's when my secretary
   Gladys would get me my coffee, she would also buzz
   me in my spacious office when I had an incoming call
   that I should take. Since Gladys was the source of
   my morning caffeine, her voice imprinted at very
   deep level. Thus, when I had an incoming call I
   could be quite sure that an imposter wasn't
   taking away valuable time from my helm of the
   Department of Loafing.

   Fast forward 50 years. Gladys is by and large
   history, and most assuredly the morning coffee
   she used get me is no more. Along with it went
   the deep imprinting, and the spacious office. Now I
   have to rely on a little LCD display that
   doesn't bring me coffee and now you're telling
   me that unimportant people will be able make
   their way through my screening and reach the
   inner sanctum of Loafing decision making with
   complete impunity?

   Progress. Gotta love it.

		   Mike