Subject: [Sip] Poll: interest in Reason header work

From: "Dean Willis" <[email-masked]>
Date: Tue, 2 Apr 2002 22:38:43 -0600

It looks like UPDATE and Manyfolks are likely to be dependent on the
Reason header mechanism (imho). Given this (and the other requirements
discussions that we've heard), how do you people feel about proposing
this as a SIP WG effort? And yes, the SIP WG can identify work that
needs to be done to support other SIP WG efforts without having a
third-party generate a requirements RFC.

--
Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 3 Apr 2002 07:12:38 -0500

Works for me (of course I'm not exactly un-involved in this little
effort :-) )

Dave.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Dean Willis
> Sent: Tuesday, April 02, 2002 11:39 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Sip] Poll: interest in Reason header work
> 
> 
> It looks like UPDATE and Manyfolks are likely to be dependent 
> on the Reason header mechanism (imho). Given this (and the 
> other requirements discussions that we've heard), how do you 
> people feel about proposing this as a SIP WG effort? And yes, 
> the SIP WG can identify work that needs to be done to support 
> other SIP WG efforts without having a third-party generate a 
> requirements RFC.
> 
> --
> Dean
> 
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: "Bob Penfield" <[email-masked]>
Date: Wed, 3 Apr 2002 09:01:44 -0500

----- Original Message ----- 
From: "Dean Willis" <[email-masked]>

> third-party generate a requirements RFC.
I think the SIP WG should do the Reason header.

Are you suggesting that it would be added it to Bundle 2?

cheers,
(-:bob

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Wed, 03 Apr 2002 14:24:41 -0600

> third-party generate a requirements RFC.

Fine with me.  Update (155) and Manyfolks (183) are the two responses
identified in my previous emails as benefitting mostly from the
Reason method.

I have not heard from the authors yet, but it would be good to limit
the Reason header in responses to the above two, as opposed to
making it a general header field for all responses.  Otherwise,
there'll be too many ways to propogate reasons in responses -- the
normal SIP response codes and the Warning header in responses
already exist.

Regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and eServices
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216