Subject: [Sip] ACK for 4xx in response to OPTIONS

From: Hatice ORBAY <[email-masked]>
Date: Fri, 19 Apr 2002 11:27:47 +0300

Hello,
If a response to  OPTIONS request is an 4xx message (420 or 486 etc...),
then does the UAS wait for an ACK from Proxy ? Or not, ACK is only a
part of the INVITE transaction?

Thanks in advance,
Hatice S. Orbay

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Ajit Kalele <[email-masked]>
Date: Fri, 19 Apr 2002 15:01:36 +0530

For 3xx+ responses ACK is part of the INVITE transaction, only for 2xx
response its not a part of INVITE transaction.

Also, for responses to requests other than INVITE, ACK is not sent.

Ajit

> part of the INVITE transaction?

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 19 Apr 2002 12:40:57 +0300

Hi,

ACK is used with INVITEs ONLY. It may, or may not, depending on the status
code in the response, be part of the INVITE transaction itself, or a
separate transaction.

See the spec for more details...

Regards,

Christer Holmberg
Ericsson Finland