Subject: RE: [Sip] Thoughts on the reason header field scope

From: "Tom-PT Taylor"<[email-masked]>
Date: Wed, 3 Apr 2002 08:17:21 -0500

You can get early media as a normal part of call setup (e.g. ringing
provided at the terminating end), in preparation for moving you to a new
destination ("Your call is being forwarded to ..."), or as part of a call
failure sequence (e.g. "That number has changed.  Youc can now reach your
party at ...").  It might be useful for the caller's application to be able
to display the difference.

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Wednesday, April 03, 2002 2:27 AM
To: Taylor, Tom-PT [CAR:B800:EXCH]
Cc: 'Vijay K. Gurbani'; Sean Olson; Gonzalo Camarillo; sip
Subject: Re: [Sip] Thoughts on the reason header field scope

Tom-PT Taylor wrote:
> 
> 183 responses are a key element of early media too.  It might not hurt
> to
> have a way to indicate why one of these has been generated.

There is nothing special about 183. If you want to say "early media",
then let us just define a 1xx for it, rather than overloading 183. I
really don't get why everyone loves 183. The only provisional resposne I
think Reason makes sense for is 155.

-Jonathan R.

> 
> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> Sent: Wednesday, March 27, 2002 2:56 PM
> To: Sean Olson
> Cc: Gonzalo Camarillo; sip
> Subject: Re: [Sip] Thoughts on the reason header field scope
> 
> Sean Olson wrote:
> 
> >>There
> >>are already elaborate response codes in SIP; why add
> >>one more way of
> >>propagating responses.  155 is a special provisional
> >>response which
> >>elicits a further request (UPDATE), so the Reason
> >>header does add some
> >>value to a generic 155 response.  I think that The
> >>I-D should state that
> >>155 is the only response to which the Reason header
> >>can be applied to.
> >>
> >
> > Would a Reason: header be allowed in a 183?
> 
> I don't speak for the authors of course, but my feeling is that 183 as a
> 
> response code is associated with QoS preconditions.  It has a well
> defined profile, so to speak.  So carrying a Reason phrase in it
> probably does not add too much.
> 
> 155 on the other hand is a response code for solving the early media,
> HERFP, as well as repairable error responses.  So there is some good to
> further qualifying the 155 response for the UAC.
> 
> Regards,
> 
> - vijay
> --
> Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
> Internet Software and eServices Group
> Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
> Naperville, Illinois 60566     Voice: +1 630 224 0216   Fax: +1 630 713
> 0184
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "David R. Oran" <[email-masked]>
Date: Wed, 3 Apr 2002 08:17:18 -0500

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Tom-PT Taylor
> Sent: Wednesday, April 03, 2002 8:17 AM
> To: 'Jonathan Rosenberg'
> Cc: sip
> Subject: RE: [Sip] Thoughts on the reason header field scope
> 
> 
> You can get early media as a normal part of call setup (e.g. 
> ringing provided at the terminating end), in preparation for 
> moving you to a new destination ("Your call is being 
> forwarded to ..."), or as part of a call failure sequence 
> (e.g. "That number has changed.  Youc can now reach your 
> party at ...").  It might be useful for the caller's 
> application to be able to display the difference.
>
Uh, if the failure/redirection is known in the signaling, then you
should be sending back a 3xx or whatever. The *only* purpose I know of
for early media is to deal with cases where you are talking to something
that CAN'T tell you via the signaling and instead sends you media.

Color me super confused.

Dave.