Subject: RE: [Sip] Cookies or State

From: "Zmolek, Andrew (Andrew)" <[email-masked]>
Date: Wed, 17 Apr 2002 15:02:05 -0600

> In my personal (biased) opinion we are better off with Cookies.
> If anyone did want to fight the IP claim, you would clearly
> be better off with 75% same language as HTTP cookies.

There are some good reasons to stick with an HTTP cookies approach, although I don't have a strong preference as long as we pick one. IANAL, but I'm sure the IPR issue won't go away by copying HTTP cookie language. On the other hand, appropriate substitution of normative references might deflect the claim. In any case, kludge-free SIP state mechanisms are long overdue.

--Andy Zmolek 
    Technology & Standards Engineer 
      CTO Standards 
        Avaya Inc. 

            [email-masked] 
              +1 720 444 4001 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Andrew Allen <[email-masked]>
Date: Wed, 17 Apr 2002 19:56:20 -0400

My vote is for cookie as well - it is more generic and might be used for
other applications other than those in the DCS state draft.

Andrew 

> -----Original Message-----
> From: Rosen, Brian [mailto:[email-masked]]
> Sent: Wednesday, April 17, 2002 2:28 PM
> To: [email-masked]'
> Subject: [Sip] Cookies or State
> 
> 
> There are two drafts that define how to save state in a UA 
> for subsequent
> use by a Proxy Server - State and Cookies.
> 
> State is part of the DCS work.  Cookies arose when IP assertions were 
> made against State.  Cookies attempted to get around the IP issues
> by defining it as exactly like HTTP cookies.  To our consternation,
> the same IP claims were then made against Cookies!
> 
> We need to get this capability.  The question is, should we
> base it on State or Cookies?
> 
> Brian

---

From: William Marshall <[email-masked]>
Date: Thu, 18 Apr 2002 15:27:51 -0400 (EDT)

I don't think the question should be one vs. the other.  More a matter
of merging the contents.

If state is chosen, then the syntax should be changed to be
consistent with http cookies, as is recommended in the cookies draft.
Also, requirements about sending state tokens for associated calls
need to be thought through more carefully.

If cookies is chosen, then the "Requires" mechanisms needs to be added, 
so that a proxy will know whether its cookies will be returned.  Also, 
the rules for UA inserting cookies into requests and responses need to be 
more carefully defined - the state draft deals with privacy (that ugly word 
again) concerns about sending cookies when the proxy that needs them
is not on the path of the request or response.

So I think the real question is which of two paths should be taken, since
the destination is the same for both.

Bill Marshall
[email-masked]

-----original message-----
From: "Rosen, Brian" <[email-masked]>
To: "[email-masked]'" <[email-masked]>
Date: Wed, 17 Apr 2002 15:27:37 -0400
Subject: [Sip] Cookies or State

There are two drafts that define how to save state in a UA for subsequent
use by a Proxy Server - State and Cookies.

Brian