Subject: RE: [Sip] Header name in draft-willis-sip-path-02.txt, was: I-D A CTION:draft-illis...

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Tue, 2 Apr 2002 20:35:30 +0100

See below

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

> ----------
> From: 	Dean Willis[SMTP:[email-masked]]
> Sent: 	02 April 2002 15:39
> To: 	'Drage, Keith (Keith)'; [email-masked]
> Subject: 	RE: [Sip] Header name in draft-willis-sip-path-02.txt, was:
> I-D ACTION:draft-illis...
> 
> 
> 
> Keith said:
> 
> > I would prefer to keep Path, or at least something shorter 
> > that the mouthfull that is currently proposed.
> 
> I suspect RRR would get used a lot . . .
> 
If it is allowed to be defined. Surely I remember a discussion on the list
some time back saying that no new short form codings would be defined? Also
none of them are more than one character, so do we now start inventing 3
character ones? Certainly none of the recent headers added seem to have
short forms.
>  
> > If you really must change it, then it should at least be 
> > hyphenated (twice) for consistency with the other headers.
> 
> Register-Record-Route ?
> 
Yes, this is consistent with other headers.
>  
> > Note also that it no longer does the same as Record-Route, as 
> > Record-Route is a bidirectional capability, and it was the 
> > same strong suggestions in Minneapolis that precluded it 
> > having that one and same functionality.
> 
> Actually, Record-Route entries are NOT changed in the response, just
> copied back towards the source. That is, they accumulate on the INVITE
> message, and are returned to the UA on the 200OK response. I think the
> text in "path" now has exactly the same behaviour. If it doesn't, I did
> something wrong, so please verify . . .
> 
The piece of funtionality I was referring to is the UA handling of the
response. At that point things do get different. Up to that point, I believe
the handling is identical.

> --
> Dean

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Apr 2002 01:17:19 -0400

"Drage, Keith (Keith)" wrote:

> character ones? Certainly none of the recent headers added seem to have

Short forms are still allowed, but restricted to one character. THe idea
is that they are allocated to headers used frequently. It may all be
moot with compression, but I agree with Anders not to use a long name if
we can avoid it.

> the handling is identical.

There is a major difference in handling right now. In the Path draft,
the proxy adds its URI as the BOTTOM-MOST entry in the Route header, and
the registrar inverts it before using. WIth record-route, its added as
the topmost entry. I would personally prefer to keep things consistent,
and have proxies add new values at the top. This also avoids the need to
invert them at the registrar.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 11 Apr 2002 12:53:50 -0500

> Short forms are still allowed, but restricted to one 
> character. THe idea is that they are allocated to headers 
> used frequently. It may all be moot with compression, but I 
> agree with Anders not to use a long name if we can avoid it.

So how about we just name it RRR?

> There is a major difference in handling right now. In the 
> Path draft, the proxy adds its URI as the BOTTOM-MOST entry 
> in the Route header, and the registrar inverts it before 
> using. WIth record-route, its added as the topmost entry. I 
> would personally prefer to keep things consistent, and have 
> proxies add new values at the top. This also avoids the need 
> to invert them at the registrar.

This has been pointed out to me several times, and will be fixed in next
draft rev.

Thanks!

--
Dean

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 11 Apr 2002 21:49:57 -0400

> So how about we just name it RRR?

I don't really care what we call it; not even sure why Path is no longer
OK.... 

-Jonathan R.