Subject: RE: [Sip] Cookies or State

From: Henry Sinnreich <[email-masked]>
Date: Wed, 17 Apr 2002 15:07:00 -0500

>The question is, should we 
> base it on State or Cookies?

I like the cookies better, since they mirror a successful web approach.

>To our 
> consternation, the same IP claims were then made against Cookies!
Consternation is the right word.

Henry

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Rosen, Brian
> Sent: Wednesday, April 17, 2002 2:28 PM
> To: [email-masked]'
> Subject: [Sip] Cookies or State
> 
> 
> There are two drafts that define how to save state in a UA 
> for subsequent use by a Proxy Server - State and Cookies.
> 
> State is part of the DCS work.  Cookies arose when IP assertions were 
> made against State.  Cookies attempted to get around the IP 
> issues by defining it as exactly like HTTP cookies.  To our 
> consternation, the same IP claims were then made against Cookies!
> 
> We need to get this capability.  The question is, should we 
> base it on State or Cookies?
> 
> In my personal (biased) opinion we are better off with 
> Cookies. If anyone did want to fight the IP claim, you would 
> clearly be better off with 75% same language as HTTP cookies.
> 
> Brian
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ben Campbell" <[email-masked]>
Date: Wed, 17 Apr 2002 15:26:49 -0500

Cookie!! (says the blue furry guy...)

> From: [email-masked] [mailto:[email-masked]]On Behalf Of Rosen,
> Brian
> There are two drafts that define how to save state in a UA for subsequent
> use by a Proxy Server - State and Cookies.
> 
> made against State.  Cookies attempted to get around the IP issues
> by defining it as exactly like HTTP cookies.  To our consternation,
> the same IP claims were then made against Cookies!
> 
> In my personal (biased) opinion we are better off with Cookies.
> If anyone did want to fight the IP claim, you would clearly
> be better off with 75% same language as HTTP cookies.
> 
> Brian
>

---

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 17 Apr 2002 15:27:37 -0400

Brian