Subject: RE: [Sip] UA running on TCP

From: "Vijay S Kamath" <[email-masked]>
Date: Fri, 28 Jun 2002 10:43:17 +0530

It is mandatory to support TCP,UDP.
Quoting bis09, section 18 line 3563:-
 "All SIP elements MUST implement UDP and TCP. SIP elements MAY
implement other protocols."

Rgds... Vijay

-----Original Message-----
From: Ranjit Avasarala [mailto:[email-masked]] 
Sent: Friday, June 28, 2002 9:26 AM
To: Li Li; [email-masked]
Subject: Re: [Sip] UA running on TCP

Hi
    Currently our sip stack runs on UDP, but TCP support is yet to be
implemented. DOes that mean the sip stack is not confirming to
standards?

Ranjit
----- Original Message -----
From: Li Li <[email-masked]>
To: <[email-masked]>
Sent: Thursday, June 27, 2002 2:08 AM
Subject: [Sip] UA running on TCP

> In the new bis, it is mandatory that UA should support
> TCP transport. Assume a UA with a TCP connection 1 sending to the 
> proxy, and a TCP connection 2 for receiving from the proxy. Now assume

> that the TCP connection 1 and 2 go down/timed out. This may due to a 
> temporary failure. The proxy recovers asap and sets up a new TCP 
> connection for sending to the UA. What should the UA do? Should the UA

> try to set up a connection to the proxy so that requests can be 
> sent/resent? Or the UA would just release all the calls it has with 
> the proxy and try for another proxy if available?
>
>
> Li
>
> > -----Original Message-----
> > From: Andre Poulin (LMC) [mailto:[email-masked]]
> > Sent: Wednesday, June 26, 2002 2:21 PM
> > To: [email-masked]'
> > Subject: [Sip] Authentication-Info header
> >
> >
> >
> >
> >    I have a question regarding Authentication headers.
> >
> >    What is the reason to have only one Authentication-Info header 
> > instead of having both www-Authentication-Info and proxy-
> >    Authentication-Info headers? This does not seem to be
> > consistent with the
> > other related authentication headers which have both
> >    cases (www and proxy)
> >
> >    Thanks,
> >    /Andre
> >
> >
> >
> >
> >
> >
> >
> >
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> >
>
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

---

From: Li Li <[email-masked]>
Date: Fri, 28 Jun 2002 09:02:09 -0400

I agree with you that the TCP support is mandatory. But 
I'm not quite sure the behavior of a UA running on TCP
when the TCP connection has a temporary problem. Anything
in the bis describes this?

Thanks,

Li

> From: Vijay S Kamath [mailto:[email-masked]]
> Sent: Friday, June 28, 2002 1:13 AM
> To: [email-masked]
> Subject: RE: [Sip] UA running on TCP
> 
> 
> proxy, and a TCP connection 2 for receiving from the proxy. 
> Now assume that the TCP connection 1 and 2 go down/timed out. This may 
> due to a temporary failure. The proxy recovers asap and sets up a new TCP 
> connection for sending to the UA. What should the UA do? 
> Should the UA try to set up a connection to the proxy so that requests can
be 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip