Subject: [Sip] UAC behavior: Final Reponse received before completion of PRACK

From: "Gokhale, Nandini" <[email-masked]>
Date: Mon, 24 Jun 2002 09:56:15 -0400

Hello, 

A Question about UAC behavior when Final response for Invite is received
before,
PRACK for the previously received 18x is not yet complete. 

If the UAS and UAC have agreed to support PRACK, but for some reason, 
UAS does not send a 200 OK in response to PRACK, The UAC is in the 
state of retransmitting PRACK. In this state, if the UAS sends a 200 OK 
(Final response) for the Invite:
 
should the UAC accept this 200 OK (final response) , and connect the 
call, and continue with PRACK. 
Or 
should the UAC wait till the PRACK method is completed and then accept 
the 200 OK (Final response) for Invite. 

I can think of two scenarios: 
--------------------------------
Case 1:

SIP UAS                  SIP-UAC        
--------------------------------

                 <------- Invite         
100 Trying ---> 
18x ---------->         
(No SDP)
                 <------- PRACK
18x ---------->
(No SDP)
                 <------- PRACK
                 <------- PRACK (retransmission)
200 OK ------->
(Final Response with SDP)
                 <------- PRACK (retransmission)

--------------------------------
Case 2:

SIP UAS                  SIP-UAC        
--------------------------------

                 <------- Invite         
100 Trying ---> 
18x ---------->         
(with SDP)
                 <------- PRACK
18x ---------->
(with SDP)
                 <------- PRACK
                 <------- PRACK (retransmission)
200 OK ------->
(Final Response No SDP)
                 <------- PRACK (retransmission)
--------------------------------
Thanks, 
Nandini Gokhale
Convergent Networks.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 24 Jun 2002 20:14:39 +0300

Hi,

Chapter 3 in draft-ietf-sip-100rel-06 says:

"The UAS MAY send a final response to the initial request before
having recevied PRACKs for all unacknowleged reliable provisional
responses, unless the final response is 2xx and any of the
unacknowleged reliable provisional responses contained a session
description."

If the UAC doesn't receive a final response for a PRACK I would say it's an
implementation issue what the UAC does, depending on if the PRACK contained
a session description, if the PRACK response is supposed to contain a
session description, etc etc etc. If the UAC doesn't receive any response at
all for the PRACK, something is obviously very wrong, since the UAC DOES
receive responses (provisional and final) to the INVITE...

Regards,

Christer Holmberg
Ericsson Finland