Subject: Re: [Sip] Reason version 01 - Q.850 Location and diagnostics

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 25 Jun 2002 09:09:22 +0300

Adam,

As you pointed out in a later mail, this draft has been already
approved, so we will not have the opportunity to include motivational
text any more (although a small clarification would be always possible).

Anyway, the idea behind including a name space in this header (Q.850,
SIP, etc...) is to make debugging easier. Sometimes it is useful to know
what is going on in the gateway. As you pointed out as well, for a
complete mapping, encapsulating the ISUP REL message seems like a much
better idea.

It is also useful to include the Q.850 cause value in CANCELs, where it
is not ensured that the REL in the body will be transmitted end-to-end.

Regards,

Gonzalo

Adam Roach wrote:
> 
> > -----Original Message-----
> > From: Cullen Jennings [mailto:[email-masked]]
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]On
> > Behalf Of Adam
> > > Roach
> > >
> > > The idea behind including Q.850 in the reason draft is certainly
> > > not to push ISUP semantics like this into the SIP network. For
> > >
> >
> > I agree with Adam but just out of curiosity, why is the Q.850
> > stuff in the
> > SIP network?
> 
> Cullen has a good point -- one that has occured to me before. The
> draft needs some motivating text around this. If there isn't a
> really compelling motivation, it probably needs to be removed.
> 
> /a

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Mon, 24 Jun 2002 17:46:47 -0400

/a