Subject: [Sip] CANCEL in Bis-09

From: "George Foti (LMC)" <[email-masked]>
Date: Thu, 6 Jun 2002 07:09:03 -0400

Hi,
Section 9.1 lines 1448 states that a CANCEL  request SHOULD NOT be sent to
cancel a request other than INVITE (due to race conditions).

Following that lines 1464-1465 state that if no provisional response has
been received, the CANCEL request MUST NOT be sent.

Since provisional responses are only used with INVITES, it looks like the
strength on line 1448 needs to be changed to MUST NOT fo consistency.

Rgds/
George Foti
Ericsson Research Canada

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: 06 Jun 2002 09:37:58 -0500

This is not an inconsistency.

The strength of the requirement to not send provisional
responses to non-INVITE requests is SHOULD NOT.

See line 1348 of the pdf.

RjS