Subject: [Sip] Compact forms questions

From: Kosta Koeman <[email-masked]>
Date: Wed, 5 Jun 2002 18:16:00 -0700 (PDT)

I've noted the following list from http://www.iana.org/assignments/sip-parameters that summarizes the compact forms defined for SIP (note: I have removed all header names without a compact form).

Allow-Events         u       [RFCevents] <draft-ietf-sip-events-05.txt>
Call-ID              i       [RFC2543], draft-ietf-sip-rfc2543bis
Contact              m       [RFC2543], draft-ietf-sip-rfc2543bis
Content-Encoding     e       [RFC2543], draft-ietf-sip-rfc2543bis
Content-Length       l       [RFC2543], draft-ietf-sip-rfc2543bis
Content-Type         c       [RFC2543], draft-ietf-sip-rfc2543bis
Event                o       [RFCevent] <draft-ietf-sip-events-05.txt>
From                 f       [RFC2543], draft-ietf-sip-rfc2543bis
Subject              s       [RFC2543], draft-ietf-sip-rfc2543bis
Supported            k       draft-ietf-sip-rfc2543bis
To                   t       [RFC2543], draft-ietf-sip-rfc2543bis
Via                  v       [RFC2543], draft-ietf-sip-rfc2543bis

So the compact forms u & o are defined in the SIP-Specific Event Notification draft; i, m, e, l, c, o, f, s, t, & v are defined in the SIP spec/draft.  I could not find the exact document where the compact form k was defined (besides the list, of course).

What about the compact forms, r (Refer-To) and b (Referred-By), respectively defined in "The Refer Method" draft (draft-ietf-sip-refer-04) and "The Referred-By Mechanism" draft (draft-ietf-sip-referredby-00)?  Are these compact forms not included in the list above due to the fact that their respective documents have not been submitted to be published as proposed standards?  Since these compact forms have been defined in drafts, are these letters/compact forms reserved for the proposed usage?  If not, is it likely that these letters/compact 
forms will be reserved in the future and included in the list above?  I 
did note that both of these drafts state that the compact forms should be added to the list above.

Thanks,
Kosta

_____________________________________________________________
Are you a Techie? Get Your Free Tech Email Address Now! Visit http://www.TechEmail.com

_____________________________________________________________
Promote your group and strengthen ties to your members with [email-masked] by Everyone.net  http://www.everyone.net/?btn=tag

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: 06 Jun 2002 09:52:18 -0500

Yes - "r" and "b" were in that registry for awhile, but were removed
during recent updates based on a decision to only reflect drafts that
have made it to proposed standard. The "r" and "b" will reappear when
their respective drafts pass that bar.

RjS