Subject: [Sip] Local vs Remote ringback on 180

From: Christer Holmberg <[email-masked]>
Date: Tue, 11 Jun 2002 11:27:05 +0300

Hi,

Bis-09 only talks about local ringback tone generation when 180 is
received. The ISUP-SIP draft defines that a remote ringback tone is
generated if the 180 contains an SDP message body.

However, with the new answer/offer rules, direction indicators
(sendrecv, inactive etc) manyfolks model etc, I wonder if such
assumption really works. There may be situations where a node must/must
not/want/doesn't want to include SDP in 180 - no matter the ringback
tone.

Bis-09 defines two headers, Alert-Info and Content-Disposition, but the
way they are currently defined I don't think they can be used for this
purpose either.

There probably are some ways to get around this, eg by using re-INVITEs
and/or UPDATEs, but I really don't think that's what we want to do....

Comments?

Regards,

Christer Holmberg
Ericsson Finland

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Mon, 17 Jun 2002 12:09:24 -0400

> -----Original Message-----
> From: Flemming Andreasen [mailto:[email-masked]]
>
> > If you know there is user alerting going on, use 180.
> >
> > Sending 183 and playing in-band ringback is not a
> > generally acceptable solution; you're overriding
> > the calling party's user interface's rendering of
> > "remote party is being alerted." Their client may
> > very well not render this using audio at all.
> 
> Could you point me to where in SIP this is stated ? 

21.1.5 183 Session Progress

   The 183 (Session Progress) response is used to convey information
   about the progress of the call that is not otherwise classified.

Alerting *is* otherwise classified -- as a 180.

Keep in mind that the issue of sending SDP in a provisional
response is orthagonal to the response used.

/a