Subject: [Sip] Authentication-Info header

From: "Andre Poulin (LMC)" <[email-masked]>
Date: Wed, 26 Jun 2002 14:21:12 -0400

I have a question regarding Authentication headers.

   What is the reason to have only one Authentication-Info header instead of
having both www-Authentication-Info and proxy-
   Authentication-Info headers? This does not seem to be consistent with the
other related authentication headers which have both 
   cases (www and proxy)

   Thanks,
   /Andre

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Thu, 27 Jun 2002 09:23:48 +0530

Hi Andre,
     Proxy-Authentication-Info header syntax does not allow
a proxy to identify itself to the endpoint. It will work fine
if there is a single proxy, but in a chain of proxies, if each
proxy inserts a Proxy-Authentication-Info header, the endpoint
would find it hard to figure out which username/password is to
be used with each header. This was an open issue, and more
details/resolution can be found at:

http://www.sipwg.org/bugzilla/show_bug.cgi?id=164

Regards,
Subhash Nayak
Hughes Software Systems
http://www.hssworld.com

"Andre Poulin (LMC)" <[email-masked]> on 06/26/2002 11:51:12 PM

To:   "[email-masked]'" <[email-masked]>
cc:    (bcc: Subhash Ullal Nayak/HSSBLR)

Subject:  [Sip] Authentication-Info header

   What is the reason to have only one Authentication-Info header instead
of
having both www-Authentication-Info and proxy-
   Authentication-Info headers? This does not seem to be consistent with
the
other related authentication headers which have both
   cases (www and proxy)

   Thanks,
   /Andre