Subject: [Sip] Empty Allow header

From: [email-masked]
Date: Mon, 10 Jun 2002 11:41:51 +0300

Is an Allow-header allowed to be empty?

The syntax in bis-09 suggests that this is not allowed.

Allow  =  "Allow" HCOLON Method *(COMMA Method)

If it is allowed, does it mean that the UAS does not support any methods?

Regards,
Hisham

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Fri, 14 Jun 2002 14:41:30 +0300

Hi,

> If it is allowed, does it mean that the UAS does not support any methods?

It is NOT allowed.

And, if there is no header at all, it means that the UA doesn't indicate
which methods it supports (chapter 20.5 in bis-9).

Regards,

Christer Holmberg
Ericsson Finland

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 18 Jun 2002 18:00:33 -0400

Christer is correct, although I am not sure this is as it should be. It 
is allowed for a UA to JUST be a UAC, and have no UAS capabilities. 
There are legitimate uses cases for that, I suppose, although its not 
common I would expect. In such a case, the UA would support no methods.

-Jonathan R.

Christer Holmberg wrote:
>>If it is allowed, does it mean that the UAS does not support any
> 
> methods?
> 
> It is NOT allowed.
> 

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 19 Jun 2002 01:05:22 -0400

There may well be legitimate cases for your example, such as one-time 
(anonymous) identifiers that can't be called back or "don't call us, 
we'll call you" SIP phones operated by movie moguls. In general, unless 
there's a really strong reason, the empty set should always be legal for 
these types of headers.

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 19 Jun 2002 08:52:13 +0300

To have a look at the HEADERS, that is...

Christer Holmberg
Ericsson Finland

> Hi,
>
> Would it be a good idea to have a look at the heards, and see for which
> headers an empty value (like Allow) really has a specific meaning, and define
> that specific meaning? Also, for those headers the ABNF should also be
> changed to allow that.
>
> Regards,
>
> Christer Holmberg
> Ericsson Finland
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 19 Jun 2002 08:50:43 +0300

Hi,

Regards,

Christer Holmberg
Ericsson Finland

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 19 Jun 2002 02:18:31 -0400

From a quick inspection, the candidate headers are at least

Via: empty list doesn't make sense
Allow-*: debatable, probably similar to "Allow"
*-Info: harmless, probably equivalent to no header
Contact: not sure what that would mean - in an INVITE (where Contact is 
'm') would this occur for a UAC-only UA?

This is a bit of a stretch, but