Subject: RE: [Sip] Transport Layer

From: Adam Roach <[email-masked]>
Date: Fri, 21 Jun 2002 16:02:50 -0400

Honor the stated transport. That is, if you receive a message
via TCP with a topmost via starting with "SIP/2.0/UDP", you don't
modify it in any way -- and, when it comes time to send the response,
you use UDP.

Note, however, that this shouldn't really happen much, if at all,
in practice.

/a

> -----Original Message-----
> From: Salva Rey [mailto:[email-masked]]
> Sent: Friday, June 21, 2002 6:54
> To: [email-masked]
> Subject: [Sip] Transport Layer
> 
> 
> 
> 
> Hi,
> 
> what should do the transport layer if it receives a messages 
> on a different 
> transport than the one stated in the topmost via Header? I 
> havent read 
> anywhere that the received parameter can contain a transport.
> 
> best regards,
> Salva
> 
> _________________________________________________________________
> MSN Photos is the easiest way to share and print your photos: 
> http://photos.msn.com/support/worldwide.aspx
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 24 Jun 2002 16:14:18 -0400

It should never happen. It is disallowed in the spec.

Let me also add this. I've said it countless times, but it is worth 
continuously repeating.

The spec *does not* specify handling procedures for every error case, 
where error case is defined as a situation that is expressly prohibited 
by the spec. The set of such error cases is far larger than the set of 
normal operating cases. Under these cases, the behavior is 
implementation specific. I generally recommend being as gratious as you 
can, in order to recover.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com