Subject: RE: [Sip] Re: draft-ietf-sip-refer-05.txt

From: [email-masked]
Date: Fri, 7 Jun 2002 17:18:45 +0300

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: Friday, June 07, 2002 5:12 PM
> To: Robert Sparks
> Cc: [email-masked]
> Subject: Re: [Sip] Re: draft-ietf-sip-refer-05.txt
> 
> 
> 
> 
> Robert Sparks wrote:
> > 
> > I know what you're trying to say, but I cant follow the description
> > of the scenario you lay out.
> 
> Never mind. You got the point.
> 
> > REFER creates a subscription just like SUBSCRIBE does. That 
> means the
> > subscription can be refreshed with a resubscribe as in 3265 or
> > terminated with an unsubscribe.
> 
> It was clear that the subscription is created, but not that 
> it can be refreshed with resubscribe.
> 

What about implicit unsubscribe? If I get a NOTIFY with a body of 2xx,4xx-6xx. Does that warrant an implicit unsubscribe? or do I still have to unsubscribe?

/Hisham

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 07 Jun 2002 13:04:37 -0400

> What about implicit unsubscribe? If I get a NOTIFY with a body of 2xx,4xx-6xx. Does that warrant an implicit unsubscribe? or do I still have to unsubscribe?

I believe normally the NOTIFY that carries the final response would also terminate the subscription. However that isn't required, so if it doesn't, then I suppose you would
need to explicitly unsubscribe, or just wait.

	Paul