Subject: [Sip] Question on draft-ietf-sip-digest-aka-03.txt

From: "Rob Phillips" <[email-masked]>
Date: Tue, 11 Jun 2002 15:51:28 -0500

Is it the intention of draft-ietf-sip-digest-aka-03 to replace the definitions of "algorithm" and "nonce" that are already defined in bis-09?  Or merely to extend the definitions?

- rob

--
Rob Phillips, Sr. Software Engineer                 Netrake Corporation
mailto: [email-masked]                           3000 Technology Drive
voice: (214) 291-1096                                         Suite 100
fax:   (214) 291-1010     http://www.netrake.com     Plano, Texas 75074

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 12 Jun 2002 10:43:05 +0300

Hi Rob,

Digest-aka doesn't replace the algorithm and nonce definitions of bis-09, but extends them. More specifically, the draft talks about overloading of the algorithm definition by adding an AKA prefix to the token values; and extending of the nonce which in bis-09 is simply a quoted string. 

Cheers,
Aki

> -----Original Message-----
> From: ext Rob Phillips [mailto:[email-masked]]
> Sent: Tuesday, June 11, 2002 11:51 PM
> To: [email-masked]
> Subject: [Sip] Question on draft-ietf-sip-digest-aka-03.txt
> 
> 
> Is it the intention of draft-ietf-sip-digest-aka-03 to 
> replace the definitions of "algorithm" and "nonce" that are 
> already defined in bis-09?  Or merely to extend the definitions?
> 
> - rob
> 
> --

---

From: "Rob Phillips" <[email-masked]>
Date: Wed, 12 Jun 2002 07:07:39 -0500

So shouldn't the definitions be:

	algorithm           =  "algorithm" EQUAL (aka-namespace / algorithm-value)
	nonce               =  "nonce" EQUAL (aka-nonce / nonce-value)

in order to be compatable with both bis-09 and sip-digest-aka-03?

- rob

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, June 12, 2002 2:43 AM
To: Rob Phillips; [email-masked]
Subject: RE: [Sip] Question on draft-ietf-sip-digest-aka-03.txt

Hi Rob,

Cheers,
Aki

---

From: [email-masked]
Date: Thu, 13 Jun 2002 11:48:39 +0300

Rob,

I guess you're right, although I think this is implicitly mentioned in the text although the  definitions don't show it. The problem is also that the document is already in the RFC Editor's queue, so changes aren't possible at this point. It would've been really good to get these comments in during the WG/IETF last calls...

Cheers,
Aki

> Sent: Wednesday, June 12, 2002 3:08 PM
> To: [email-masked]
> Digest-aka doesn't replace the algorithm and nonce 
> definitions of bis-09, but extends them. More specifically, 
> the draft talks about overloading of the algorithm definition 
> by adding an AKA prefix to the token values; and extending of 
> the nonce which in bis-09 is simply a quoted string. 
> 
> Cheers,
> Aki
> 
>

---

From: [email-masked]
Date: Thu, 13 Jun 2002 13:53:58 +0200

Digest-aka does change the definition of the "nonce" field. A "nonce" is 
an opaque value from the client's perspecfive, and it is completely 
server-implementation-specific. 
however, "aka-nonce" is a set of specific fields. Why not define those 
fields explicitly?
e.g. rand=<val>, autn=<val>
(the server-specific data IS the original intent of the "nonce" field...)

--Original Message

To:        <[email-masked]>; <[email-masked]>
From:        [email-masked]

Hi Rob,

Digest-aka doesn't replace the algorithm and nonce definitions of bis-09, 
but extends them. More specifically, the draft talks about overloading of 
the algorithm definition by adding an AKA prefix to the token values; and 
extending of the nonce which in bis-09 is simply a quoted string. 

Cheers,
Aki

Mailing-List:        Session Initiation Protocol <sip.ietf.org>

---

From: [email-masked]
Date: Mon, 17 Jun 2002 10:04:04 +0300

Hi,

This was considered at one point along with defining a new HTTP authentication method for AKA. The reason digest-aka is reusing the nonce param is that, the AKA material is then also included in the calculation of the credentials. Basically, digest-aka specifies one particular server implementation of the nonce (plus server specific data can still be appended to the AKA parameters inside the nonce).

Cheers,
Aki

> From: ext [email-masked] [mailto:[email-masked]]
> Sent: Thursday, June 13, 2002 2:54 PM
> To: Niemi Aki (NET/Espoo)
> Cc: [email-masked]
> definitions of bis-09,

---

From: Adam Roach <[email-masked]>
Date: Mon, 17 Jun 2002 12:14:47 -0400

We've fixed *exactly* these kinds of nits in the Author's 48 hours on
pending drafts. You can too.

/a

> Sent: Thursday, June 13, 2002 3:49
> To: [email-masked]; [email-masked]
> I guess you're right, although I think this is implicitly 
> mentioned in the text although the  definitions don't show 
> it. The problem is also that the document is already in the 
> RFC Editor's queue, so changes aren't possible at this point. 
> It would've been really good to get these comments in during 
> the WG/IETF last calls...
> 
> Cheers,
> Aki
>