Subject: RE: [Sip] Asserted-Identity - new hint proposal

From: Adam Roach <[email-masked]>
Date: Mon, 17 Jun 2002 12:36:54 -0400

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]

>I agree that "long term" probably means "never implemented".
>Or it means that there is never any short-term attempt to
>achieve what is really needed. I have to suspect that one
>of the purposes of this focus on "long-term" is to avoid
>any useful identification service in the near future. What
>is needed is to realize that, unless the means are defined
>to provide the currently required identification services,
>SIP can not be used to provide a commercial service which
>might replace the current (inferior?) telephone system. 

Actually, the "long-term" solution isn't some fuzzy "oh, we'll
do that later; we don't want to think about it" solution. What
has been called the "long-term" solution is actively being
worked on, and will be done in however much time is necessary
to do it right. We're not dragging our feet on this.

The only reason the "short-term" solution exists is because
3GPP dumped a pile of requirements on the IETF and said
"we need all of these requirements fulfiled by your protocol
in a ludicrously short period of time." So, we hemed and
hawed a bit, and eventually cranked out a ridiculous mechanism
with extremely limited applicablity.

So, I think that your confusion arises more from the use of
the terms "short-term" and "long-term", not from a good understanding
of the situation. A more accurate set of terms which would be
less prone to misinterpretation would be "the stopgap solution"
and "the real solution".

>As a long time participant in the development of the US standards
>for identification/privacy, and watching the discussion here,
>it occurs to me that there is a fundamental difference between the two
approaches: 
>
>PSTN (US standards) - the goal was to provide a useful
>identification service, while recognizing the need for privacy 
>
>IETF - the goal is to provide foolproof privacy, while maybe
>providing identification in some cases. 

If you disagree with the *requirements*, I propose that you take
the concerns to the SIPPING list, where the document that outlines
those requirements is supposed to be discussed. Note well that
"the real solution" (to use my coined term) is being described
in two drafts -- one for privacy, and the other for identity.
Based on your comments above, I suspect that you might have only
read the one that addresses privacy.

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Thomas <[email-masked]>
Date: Mon, 17 Jun 2002 10:22:04 -0700 (PDT)

> less prone to misinterpretation would be "the stopgap solution"

Adam,

I think there is a real and well founded reason to
believe that "stopgap" and "real" have no meaning
outside of IETF mailing lists and that only
"solution" will be ceased upon. If this *really*
is a 3GPP hack as it's being advertised, the best
possible solution may be to let 3GPP define some
X- headers themselves where IETF gives no blessing
of any kind at all. Thus when the "real" header
comes out, there won't be any room for
equivocation about whether it is an IETF standard.
With P- headers, there's plenty of room and it's
not clear whatsoever that the "real" header will
have any chance of adoption, assuming that it is
ever finished -- which is the real problem here.

I'm probably in la-la land, but given the amount
of effort we're gone to polishing this turd, maybe
we could have gotten the "real" solution finished.
It's not like there is a lot of new ground here
from the last several years...

	      Mike

---

From: "Dean Willis" <[email-masked]>
Date: Mon, 17 Jun 2002 13:31:55 -0500

> the terms "short-term" and "long-term", not from a good 
> understanding of the situation. A more accurate set of terms 
> which would be less prone to misinterpretation would be "the 
> stopgap solution" and "the real solution".

I'd take it a little further and call the two "the 3GPP Release 5
kludge" and "the solution". It's not even completely out of the question
to incorporate the real solution into Release 5 via the change request
process later this year.

Or, as Douglas Adams said, "Don't Panic!"

Say, that might be a good definition of P-header -- "panic headers". Or
maybe not.

--
Dean