Subject: RE: [Sip] Draft-willis-sip-path revised to -08

From: Tan Ya-Ching ICM N PG U ID A 1 <[email-masked]>
Date: Wed, 5 Jun 2002 18:35:45 +0200

Hi Dean,

Some REALLY final comments:

- Section 3 third paragraph
  "... whereas the vector established by Path applies to future 
  dialogs" is not very correct. It only applies to future requests
  outside of a dialog - requests that are addressed to the AOR 
  of the user, to be precise. Requests within future dialogs 
  are still bound to the vector established by Record-Route 
  mechanism.

- Section 4.1 second paragraph
  "The UA ... should include a Supported header field in
  all requests."  I think you mean "all REGISTER requests". 
  I don't see the Supported header in the INVITE in your
  example.

A few nits:

- Section 4.2 last paragraph
  "alterany" => "alter any"

- Section 4.3
  "addres-of-record" => "address-of-record"

- Section 5.1 last paragraph
  "...such as request..." => "such a request"

Regards,
Ya-Ching

| -----Original Message-----
| From: Dean Willis [mailto:[email-masked]]
| Sent: 30 May 2002 02:54
| 
| Bernie and I just released what we hope is the REALLY final version of
| the Path draft. This includes all feedback (mostly nits) so far from
| IETF Last Call. 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 5 Jun 2002 16:25:34 -0500

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Tan Ya-Ching ICM N PG U ID A 1
> Sent: Wednesday, June 05, 2002 11:36 AM
> To: 'Dean Willis'
> Cc: [email-masked]
> Subject: RE: [Sip] Draft-willis-sip-path revised to -08
> 
> 
> Hi Dean,
> 

I had tried to resist the temtation to insert an entire tutorial on SIP
request/response riuting methodologies into one sentence, but if you
wish to suggest specific text, I'll happily consider it.
 
>   I don't see the Supported header in the INVITE in your

A bug in the example? The way Supported supposedly works, it's "All
Requests", or a least "All Requests for which the UA is willing to use
this extension". One might argue that this second usage is more
reasonable, but it conflicts with the way many people think Supported
works. We probably need a consensus call on this point.

I think some Bad Things happened with my examples. I started by
attempting to use a schematic representation of SIP messages, such that
only the Important Things mentioned in the draft would stand out. Then
people started insisting on adding more and more detail, until the
examples are almost but not quite photorealistic. I believe this
approach is a Bad Idea: the actual topic gets obscured behind peculiar
intricacies of "just how is it we're formatting messages this week?". 
 
>   "...such as request..." => "such a request"
 
Excellent observation. Thanks.

--
Dean