Subject: [Sip] subscribe - event package

From: "Ranjit Avasarala" <[email-masked]>
Date: Tue, 25 Jun 2002 15:59:47 +0530

Hi

    This is with ref to draft-ietf-sip-events-05.txt

    I have a doubt in the implementation of events template package. What should this package contain. Say I am implementing the call waiting feature on Server 

Now A calls B and B is busy. So i get a Busy Here msg to A. Then I can SUBSCRIBE a event on my server and ask it to NOTIFY me when B is Free. 

so any suggestions?

Thanks
Ranjit

---

From: "Dean Willis" <[email-masked]>
Date: Tue, 25 Jun 2002 15:50:23 -0500

Perhaps the "presence" event package (see SIMPLE wg)  would suffice for
your needs?
 
really, what you want to subscribe to is the availability of B, which is
probably not known by your server but may be known by B's server.
 
--
dean

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ranjit
Avasarala
Sent: Tuesday, June 25, 2002 5:30 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Sip] subscribe - event package

Hi

    I have a doubt in the implementation of events template package.
What should this package contain. Say I am implementing the call waiting
feature on Server 
 
Now A calls B and B is busy. So i get a Busy Here msg to A. Then I can
SUBSCRIBE a event on my server and ask it to NOTIFY me when B is Free. 
 
so any suggestions?
 
Thanks
Ranjit