Subject: [Sip] Conflict(?) between sip-reason-01 and sip-events-05

From: "Rob Phillips" <[email-masked]>
Date: Wed, 12 Jun 2002 06:41:15 -0500

I noticed that there's a rule name conflict between sip-reason-01 and sip-events-05.  Both define BNF rules for "reason-value" and "reason-extension", but the definitions are certainly not compatable.  While the guideline for writing SIP extensions does not explicitly deal with this issue, it seems to me that, to avoid confusion, BNF rules should have unique names.

Thoughts?

- rob

--
Rob Phillips, Sr. Software Engineer                 Netrake Corporation
mailto: [email-masked]                           3000 Technology Drive
voice: (214) 291-1096                                         Suite 100
fax:   (214) 291-1010     http://www.netrake.com     Plano, Texas 75074

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Thu, 13 Jun 2002 16:48:18 -0400

That's a really good point. I'd offer to change sip-events,
but we're pushing out the RFC Real Soon Now.

Henning?

/a

> -----Original Message-----
> From: Rob Phillips [mailto:[email-masked]]
> Sent: Wednesday, June 12, 2002 6:41
> To: [email-masked]
> Subject: [Sip] Conflict(?) between sip-reason-01 and sip-events-05
> 
> 
> I noticed that there's a rule name conflict between 
> sip-reason-01 and sip-events-05.  Both define BNF rules for 
> "reason-value" and "reason-extension", but the definitions 
> are certainly not compatable.  While the guideline for 
> writing SIP extensions does not explicitly deal with this 
> issue, it seems to me that, to avoid confusion, BNF rules 
> should have unique names.
> 
> Thoughts?
> 
> - rob
> 
> --

---

From: Adam Roach <[email-masked]>
Date: Fri, 14 Jun 2002 11:25:23 -0400

We've taken care of this problem. In the events draft, they are
now called "event-reason-value" and "event-reason-extension",
respectively.

Thanks for catching this!

/a