Subject: RE: [Sip] Draft-willis-sip-path revised to -08

From: Tan Ya-Ching ICM N PG U ID A 1 <[email-masked]>
Date: Thu, 6 Jun 2002 08:51:06 +0200

Dean,

| > 
| > - Section 3 third paragraph
| >   "... whereas the vector established by Path applies to future 
| >   dialogs" is not very correct. 
| 
| I had tried to resist the temtation to insert an entire 
| tutorial on SIP request/response riuting methodologies 
| into one sentence, but if you wish to suggest specific text, 
| I'll happily consider it.

My suggestion in one sentence :

...whereas the vector established by Path applies to all future
requests addressed to the user outside of a dialog.

| > - Section 4.1 second paragraph
| >   "The UA ... should include a Supported header field in
| >   all requests."  I think you mean "all REGISTER requests". 
| >   I don't see the Supported header in the INVITE in your
| >   example.
| 
| A bug in the example? The way Supported supposedly works, it's "All
| Requests", or a least "All Requests for which the UA is willing to use
| this extension". One might argue that this second usage is more
| reasonable, but it conflicts with the way many people think Supported
| works. We probably need a consensus call on this point.
| 

No bug in the example, it's my fault. The INVITE in your example 
is sent from UA2, which has nothing to do with UA1 who supports 
Path. But the original question remains, do we need the 
Supported:path if UA1 sends requests other than REGISTER? I 
support your "All requests for which the UA is willing to use this 
extension". An INVITE from UA1 with Supported:path serves 
absolutely no purpose when it reaches UA2.

- Ya-Ching

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dean Willis" <[email-masked]>
Date: Thu, 6 Jun 2002 15:48:01 -0500

> ...whereas the vector established by Path applies to all 
> future requests addressed to the user outside of a dialog.

Thanks!

> absolutely no purpose when it reaches UA2.

I think there's probably a need for a sort of meta-discssion about what
Allowed, Supported, and Required REALLY mean and when they should be
used . . .

--
Dean