Subject: RE: [Sip] Local vs. Remote ringback on 180

From: David Oliver <[email-masked]>
Date: Fri, 21 Jun 2002 08:52:48 -0500

Ranjit,

By "press this button", I was referring to Christer's description of
traversing a PBX menu system.

Regarding how long to wait for a reply, there are several scenarios:

o The called IP phone may issue a 480 Temporarily Unavailable or 484 Busy
Here after the initial 180 Ringing, due either to policy or user action
(e.g. pressing the DND button).
o The called IP phone might cease sending 180 Ringing, due to equipment
failure or extreme user action (e.g. "yanking the cord") and the switch
times out.

In these cases, the switch should change from sending ringback to either
 Send a number unavailable tone, with a 480 Temporarily Unavailable/486 Busy
Here message, or
 Return the caller to the voice mail system.

o The called IP phone sends 180 Ringing indefinitely.

In this case, the switch will wait indefinitely, or until local policy
overrides, or the caller takes action, such as hanging up, or dialing DTMF
digits to try another extension.

Regards,

David C. Oliver
Principal Engineer
SecureLogix Corp
Email: [email-masked] <mailto:[email-masked]>
Tel:   210.402.9669
Fax:   210.402.6996 

-----Original Message-----
From: Ranjit Avasarala [mailto:[email-masked]]
Sent: Friday, June 21, 2002 1:06 AM
To: David Oliver; 'Christer Holmberg'
Cc: [email-masked]
Subject: RE: [Sip] Local vs. Remote ringback on 180

Hi David

  I have a query on ur suggestion: like how long are u
goin gto wait i.e "press this button" until phone
answers. say if the person is on phone for a long
time, then what should be the solution

Ranjit
--- David Oliver <[email-masked]> wrote:
> An interesting feature of this scenario is that for
> incoming calls from the
> PSTN, the company IP-switch/PBX will need to
> generate ringback on behalf of
> the callee's no-early-media phone until it answers
> the call. This would
> reasonably be generated by the same subsystem which
> provides the "press this
> button" features, until the IP phone is answered. If
> the phone is not
> answered, the subsystem would provide the
> opportunity to redirect the caller
> to voice-mail, etc.
> 
> It seems appropriate to use exactly the same
> mechanism for IP calls, as this
> would simplify the implementation (the PSTN GW would
> be handled like IP-only
> calls), and prevent confusing the caller.
> 
> Regards,
> 
> David C. Oliver
> Principal Engineer
> SecureLogix Corp
> Email: [email-masked]
> <mailto:[email-masked]>
> Tel:   210.402.9669
> Fax:   210.402.6996 
> 
> 
> -----Original Message-----
> From: Christer Holmberg
> [mailto:[email-masked]]
> Sent: Wednesday, June 19, 2002 2:19 AM
> To: Jonathan Rosenberg
> Cc: Flemming Andreasen; Mark Watson; [email-masked]
> Subject: Re: [Sip] Local vs Remote ringback on 180
> 
> Hi,
> 
> <...>
> 
> I am not sure how it will work on the PSTN side, but
> let's assume the
> following SIP scenario.
> 
> I try to call my boss. I reach the company "switch"
> (which, I guess, in this
> case has be implemented as some kind of SIP B2BUA)
> which sends me a 183
> (with
> SDP) and start transmitting early media telling me
> that I have now reached
> this company, please wait, press this button for
> this, press that button for
> that etc etc etc. Then, the switch "forwards" the
> INVITE to the actual SIP
> phone I'm calling to. Now, this SIP phone is not
> able to generate any early
> media at all, so it sends a 180 (without SDP). Now I
> assume the switch could
> only forward the 180 to the caller (via the PSTN
> GW), stop transmitting the
> early media, and expect the PSTN GW to generate a
> local ringback tone, since
> the called party has been reached.
> 
> Now, one can argue that this is a complicated
> scenario, which has nothing to
> do with the basic SIP etc etc. BUT, from the
> caller's point of view this is
> a
> normal session setup. It receives the 183 (with SDP)
> and 180 (without SDP)
> within the same dialog, and has no idea what is
> happening at the remote
> site.
> 
> Regards,
> 
> Christer Holmberg
> Ericsson Finland
> 
> 
> 
> _______________________________________________
> Sip mailing list 
> https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP
> Protocol
> Use [email-masked] for questions
> on current sip
> Use [email-masked] for new developments on the
> application of sip

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "uy do" <[email-masked]>
Date: Thu, 27 Jun 2002 08:34:36 -0700

Hello,
As soon as the UAS receives an INVITE, it sends back to the client a TRYING.
My question is the UAS only send one TRYING, or it keeps sending TRYING at a
regular time? If the latter is correct, how long does it take the UAS to
resend the TRYING?

Thanks,
Uy