Subject: RE: [Sip] QoS for complete session

From: Henry Sinnreich <[email-masked]>
Date: Thu, 27 Jun 2002 20:56:02 -0500

> How 'bout making use of RSVP if possible ?

Though I worked on RSVP validation in a coast to coast network some time
ago, lately I don't like it any more because of cost, complexity and
added call setup delay. I like PRACK even less, since it is a close
emulation if the circuit switched network. These are just personal
biases.

Using SIP phones for most of the calls in the office, from home and
travel, QoS is the least of the problems. Even when using dial-access,
the G.723.1 in Windows Messenger 4.6 provides business quality voice in
transatlantic calls. Except when e-mail kicks in and produces voice
clipping because it takes over all the dial-up link bandwidth. That's
where MCML PPP or the TCP windows based control comes in for TCP
applications. In conclusion, there are better approaches than RSVP IMHO.

Henry

> -----Original Message-----
> From: Prabhas Sinha [mailto:[email-masked]] 
> Sent: Thursday, June 27, 2002 3:11 PM
> To: Henry Sinnreich; 'Shane McCormack'; [email-masked]
> Cc: [email-masked]
> Subject: Re: [Sip] QoS for complete session
> 
> 
> How 'bout making use of RSVP if possible ?
> I am attaching a small picture to illustrate the same. What 
> will fit the scenario depends upon the network infrastructure 
> being used in his case. In simplistic case, I second your approach.
> 
> Prabhas
> Research Assistant
> Dept of Computer Engineering
> North Carolina State University
> Raleigh, NC 27695
> 
> 
> 
> ----- Original Message -----
> From: "Henry Sinnreich" <[email-masked]>
> To: "'Shane McCormack'" <[email-masked]>; <[email-masked]>
> Cc: <[email-masked]>
> Sent: Thursday, June 27, 2002 3:27 PM
> Subject: RE: [Sip] QoS for complete session
> 
> 
> > >How I provide a level of QoS from Call setup,
> > >duration of call to call teardown.
> >
> > The non-PC answer is QoS is a non-issue except on bandwidth starved 
> > access lines. In such cases I personally like the approach 
> using SIP 
> > session counting for RTP voice packets and manage the remaining TCP 
> > traffic with a QoS appliance, see:
> >
> > http://www.nwfusion.com/reviews/2002/0603rev.html
> >
> > The edge-to-edge TCP control by QoS appliances seems to be pretty 
> > architecturally correct.
> >
> > This is admittedly a simplistic approach and I look forward 
> for other 
> > approaches people may suggest.
> >
> > Henry
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]] On Behalf Of 
> > > Shane McCormack
> > > Sent: Wednesday, June 26, 2002 8:37 AM
> > > To: [email-masked]
> > > Subject: [Sip] QoS for complete session
> > >
> > >
> > > Hi there,
> > > I have been trawlling through various archives for a while but 
> > > nothing specifically answers my question which is:
> > >
> > > Q.Say I use Sip to set up a VoIP call between to PC user 
> agents. How 
> > > I provide a level of QoS from Call setup, duration of 
> call to call 
> > > teardown. Anybody. Sorry if this is a bit obvious to some 
> people but 
> > > I am just wondering.
> > >
> > > Regards
> > >
> > > Shane
> > >
> > >
> > >
> > > _______________________________________________
> > > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > > This list is for NEW development of the core SIP Protocol Use 
> > > [email-masked] for questions on current sip Use 
> > > [email-masked] for new developments on the application of sip
> > >
> >
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chris Martin <[email-masked]>
Date: Thu, 27 Jun 2002 23:23:06 -0500

Henry Sinnreich wrote:
> clipping because it takes over all the dial-up link bandwidth. 

This most likely also produces cpu and memory resource starvation during
the exchange (especially the way many individuals run dozens of apps in
memory, as often seen by largely populated taskbars)...some of the
percieved quality issues in PC scenarios are often associated at this
level before the bandwidth even comes into play (whether dial up or
network based) ...just my opinion. An analyzer could indicate more
accurately which is which. Then again, as you said, email does take up
quite a bit of bandwidth all by itself.

:^)

Chris

>That's