Subject: RE: [Sip] Asserted-Identity - new hint proposal

From: Adam Roach <[email-masked]>
Date: Mon, 17 Jun 2002 12:23:38 -0400

Chris, I think you're missing a major point here:

The "long-term" solution isn't incompatible with the PSTN
model. It's just *also* applicable to the Internet at large
and models with multiple domains involved.

The short-term solution is applicable only to an idealized
single-domain-of-trust model that doesn't even exist in
the PSTN today.

/a

> -----Original Message-----
> From: Chris Martin [mailto:[email-masked]]
> Sent: Wednesday, June 12, 2002 22:09
> To: [email-masked]
> Cc: Michael Thomas; Peterson, Jon; Cullen Jennings; [email-masked]
> Subject: Re: [Sip] Asserted-Identity - new hint proposal
> 
> 
> [email-masked] wrote:
> > 
> > Michael Thomas writes:
> > 
> >  > What happened to the mindset of doing the
> >  > necessary engineering to generalize what the PSTN
> >  > did badly instead of slavishly reproducing its
> >  > misfeatures, bug for bug?
> > 
> > this is exactly what 3gpp is doing.  they are trying to re-implement
> > their existing walled garden with new set of protocols (ip, 
> sip, radius,
> > etc).  ietf should have no part in such a madness.
> 
> I cant speak for 3GPP (I dont know enough about it) but walled gardens
> exist and will continue to exist, out of necessity, for reasons of
> security or lack of resources...yada..yada, within many  carrier,
> corporate, and SOHO networks. The concepts that I have seen discussed
> regarding asserted identity, hints, etc....are valid for any or all of
> these infrastructures as well as those that join with one or more
> infrastructures to offer enhancements or share resources. 
> Sure maybe the
> names could be worked on but the concepts are valid.
> 
> From what I have seen 3GPP is adopting SIP and, just as the enterprise
> and carriers are trying to fit SIP into their infrastructures while
> maintaining the policies that they must enforce in order to meet legal
> and protective requirements, and I have seen some very good 
> thoughts and
> opinions pour out into this list that will become a necessity 
> for SIP as
> well. I am grateful that the topics have been brought out 
> into the open
> for discussion now than later.
> 
> It is one thing to not desire the re-invention of the PSTN, but
> legalities and business policies must be met in the real world by the
> entities that will provide the services, whether for profit or not.
> These issues exist in the PSTN world but that does not make them
> products of the PSTN world. It makes them products of the 
> communications
> world that must be met by all communications solutions that are
> developed with the goal of attempting to provide the types of 
> solutions
> that SIP will be capable of providing now and in the future 
> to everyone. 
> 
> To continue to perform nothing more than name calling because "they"
> dont conform to your way of thinking is ludicrous. All of these
> discussions and attempts to integrate existing architecture (at least
> those based on IP for our requirements) furthers the 
> development of SIP
> and aids in the devlopment of new ideas.
> 
> I want to hear and read more about this and offer what I can 
> when I can,
> and hope you will too.
> 
> Chris
> 
> > 
> > -- juha
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Chris Martin <[email-masked]>
Date: Mon, 17 Jun 2002 17:37:28 -0500

> single-domain-of-trust model that doesn't even exist in

I can agree with that, to the extent of my experience with the PSTN. I
merely wanted to emphasize that the use of this mechanism (NAI) is
applicable to other architectures than just 3GPP, as had been argued
back and forth for some time now, and that the requirement wasnt a
re-creation of the PSTN or a by-product of the PSTN (Since some of the
mechanisms argued about often are blamed on the PSTN from what I can
see), or a mechanism that benefits only 3GPP, rather that it is a
communications problem related to security, laws and business policies,
etc, for all archtectures planning on offering communitations, of any
kind, at large.

Thanks for your response.

Chris