Subject: [Sip] Questions on sip-guidelines

From: [email-masked]
Date: Fri, 12 Jul 2002 16:12:02 +0300

- Is defining a new sip-uri parameter considered to be an extension. This also applies to headers that allow extension params. If so, should this be mentioned in the draft?

- Should the draft also mention something about registering new sip headers, methods, option-tags with IANA?

- "Extensions that define new methods SHOULD use all capitals for the method name". Why not a MUST?

Regards,
Hisham

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 14 Jul 2002 23:49:01 +0900

[email-masked] wrote:
> - Is defining a new sip-uri parameter considered to be an extension.

Yes.

> This also applies to headers that allow extension params.

Yes.

> If so, should
> this be mentioned in the draft?

Yes. Its mentioned up front that these are extensions, but there is no 
real dsicussion of it. I will add it.

> headers, methods, option-tags with IANA?

I think its worth mentioning, yes.

> method name". Why not a MUST?

Because, technically, they can be lowercase. Its just that we haven't 
had any, historically.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com