Subject: [Sip] [SIP, Transport] Does sent on TCP (when msg too big) also occurs on server side?

From: "Gilles Compienne" <[email-masked]>
Date: Thu, 4 Jul 2002 15:16:39 +0100

Hello,

I have a question about the fact that we should send a message through TCP if its size is too big for UDP. This is specified for the client side (point 18.1.1), however no comment about it is made for the server side.

Does it means that, if we receive a request through UDP, the response (point 18.2.2) should be done through UDP even if the message is too big for UDP (so ignoring the rule given in 18.1.1). 

I agree that it implies that our response is bigger than the resquest but I think nothing forbide these kind of situations

Thanks for your help.

Regards,

Gilles Compienne.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 04 Jul 2002 18:49:00 +0300

Hi,

The transaction should use the same transport (that's my understanding, at least), which means the response uses the same transport as the response.

It is true that the response may be bigger than the request (eg if the 200 response to a INVITE without SDP), but bis-09 DOES take that into consideration, saying that the maximum size for a request is smaller than the
actual maximum size for a SIP UDP message, so that there is "room" for the response to use UDP too, even if the response is bigger than the request.

IF, however, the response becomes too big for UDP, I guess that COULD be indicated to the UAC in an error response to the request, but I currently don't remember which error code (if such even exists...) should be used to
indicate that. It was discussed once, but you may want to check the archieve for details...

Regards,

Christer Holmberg
Ericsson Finland