Subject: RE: [Sip] P- headers vs. requirements in sip change process

From: Adam Roach <[email-masked]>
Date: Sun, 14 Jul 2002 20:15:12 -0500

Catching up on old mail...

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
>
> also, nai is and in fact MUST be used also within a single 
> trust domain
> if the user has specified anonymous from header and the 
> request goes to
> a sip/pstn gw..  so the nai header is not just some "nice to know"
> thing, but an integral part of the sip specification.

Why? The user's identity can be ascertained from the credentials
(the username, in particular) provided at authentication time.

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Mon, 15 Jul 2002 07:19:52 +0300

> (the username, in particular) provided at authentication time.

because one user may have many sip identities.  this should have been
clear based on several earlier emails about this topic.

-- juha