Subject: [Sip] Question on SIP

From: Saroj Kumar <[email-masked]>
Date: Tue, 2 Jul 2002 01:58:48 -0700 (PDT)

I have the following data.

User name: 	5088855003
Password: 	5088855003
Realm :  	BroadWorks
Uri: 	 	sip:10.15.66.133
Algorithm:	MD5
Nonce:		1024027759288

I am using the following code for calculation of
Response.
  char * pszNonce = "1024027759288";
  char * pszCNonce = "";	
  char * pszUser = "5088855003";
  char * pszRealm = "BroadWorks";
  char * pszPass = "5088855003";
  char * pszAlg = "md5";
  char szNonceCount[9] = "";
  char * pszMethod ="Get;
  char * pszQop ="";
  char * pszURI ="sip:10.15.66.133";
  HASHHEX HA1;
  HASHHEX HA2 = "";
  HASHHEX Response;

 DigestCalcHA1(pszAlg, pszUser, pszRealm, pszPass,
pszNonce,pszCNonce, HA1);
 DigestCalcResponse(HA1, pszNonce, szNonceCount,
pszCNonce, pszQop,
 pszMethod, pszURI, HA2, Response);
  printf("Response = %s\n", Response);

and getting the out put as
725a9146fa0eb8bd8fd709086f190c01
but I am expecting the result as
b0f6dbce82b1fe5f9adf5d124179ec2a.

Whatever examples I got in the net cNonce value is
used, but in this case I don't have the cNonce as
there is no qop.

__________________________________________________
Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup
http://fifaworldcup.yahoo.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Eiji Tomimura <[email-masked]>
Date: Wed, 03 Jul 2002 18:10:06 +0900

Dear all,

I have a question regarding ABNF for SIP.

In bis-09, it defines that :
    rfc1123-date = wkday "," date1 SP time SP "GMT"

Though, in RFC2616 "HTTP/1.1", it defines that:
    rfc1123-date = wkday "," SP date1 SP time SP "GMT"

Is it intentional? Or, is it a bug of either side?

Becauses our SIP layer is based on RFC2616 format, it reject Date header
follows the format of bis-09 as syntax error. So I'm wondering which format
should we use.

Thanks in advance.

Regards,
- Eiji Tomimura

-- 
Eiji Tomimura 
Senior Engineer 
Communications Technology Dept., Information Technology R&D Laboratories
Sumitomo Electric Industries, Ltd.
Phone: +81-6-6466-5643  Fax: +81-6-6466-5732  Email: [email-masked]