Subject: Re: [Sip] Local vs Remote ringback on 180

From: "Alexeitsev, D" <[email-masked]>
Date: Mon, 1 Jul 2002 13:17:13 +0200

Hello All,

Some comments/questions inline

Greetings,
Denis Alexeitsev

-----Ursprüngliche Nachricht-----
Von: Christer Holmberg [mailto:[email-masked]]
Gesendet am: Freitag, 28. Juni 2002 18:53
An: Chris Hogg
Cc: Flemming Andreasen; Jonathan Rosenberg; Mark Watson; [email-masked];
Bob Penfield
Betreff: Re: [Sip] Local vs Remote ringback on 180

[CHH] The UAS may still send early media, but since it sends 180 without
SDP it allows the UAC to generate local ringback tone, so the UAC now
can assume that it can "cut" the early media from the caller during that
time. If the UAS does NOT want the UAC to generate local ringback, the
180 would also contain SDP (the same SDP which was used in the 183 to
establish the early dialog, ie the SDP is not a new offer/answer -
simply a ringback "indicator").

[DA]I have a question about the need to receive the SDP in any responses in order to play remote ringback. As the offer/answer draft says:
"Once the offerer has sent the offer, it MUST be prepared to receive media"

The SDP coming from the other side is used to send the media, that is unimportant in the ringback case. Am I missing something here?

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 01 Jul 2002 14:26:09 +0300

Hi,

> The SDP coming from the other side is used to send the media, that is unimportant in the ringback case. Am I missing something here?

[CHH] For the specific ringback tone case one can argue that an SDP is not needed for the media itself (unless you need it for RTCP purpose,
or something).

However, there is no specific "remote ringback session" in SIP. You establish a generic early dialiog, by sending an offer and receiving an
answer, which can then be used for any kind of early media (ringback tone, announcement,...), in any direction (depending on the "direction"
indicators - sendrecv, sendonly, inactive etc etc).

Regards,

Christer Holmberg
Ericsson Finland