Subject: RE: [Sip] REFER: Who has implemented REFER without creating subsc riptions?

From: "Sriram Parameswar" <[email-masked]>
Date: Mon, 15 Jul 2002 00:14:01 -0500

I am afraid I do not agree with the rather general statement you have made
below. Implicit subscription created by REFER for all REFERs is does not
rate as a generality. It is a special use of Implicit Subscriptions. There
are applications that could 'refer' the recipient to a resource, but not
care to receive a notification. 

Thx,

Sriram 

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: Sunday, July 14, 2002 8:15 PM
To: Parameswar, Sriram [NGC:B615:EXCH]; 'Adam Roach'; 'Rosen, Brian';
Robert Sparks
Cc: [email-masked]
Subject: RE: [Sip] REFER: Who has implemented REFER without creating
subsc riptions?

>-----Original Message-----
>From: Sriram Parameswar [mailto:[email-masked]]
>
>I think there is definite value to having REFER without NOTIFYs.
>There are several non transfer applications that benefit from
>REFER, without having the overhead of the NOTIFY(s).

In particular, this reasoning flies in the face of the principle
of selecting "generality over efficiency" that has been established
for the SIP protocol and its extensions.

/a

---

From: Robert Sparks <[email-masked]>
Date: 15 Jul 2002 14:39:51 +0900

Going with a mandatory creation of a subscription for the base
REFER document really simplifies the spec and implementation of it.

If you have an application that truly cannot stomach getting exactly
one notify, I suggest we work out an extension later.

Note that as a REFERor, if you don't care about the notifies, all
you have to do is reject the first one. That terminates the
subscription.

If you are a REFERee and you don't want to deal with holding onto
subscription state, send exactly one NOTIFY with a terminated
subscription-state.

RjS

On Mon, 2002-07-15 at 14:14, Sriram Parameswar wrote:
> I am afraid I do not agree with the rather general statement you have
> made below. Implicit subscription created by REFER for all REFERs is
> does not rate as a generality. It is a special use of Implicit
> Subscriptions. There are applications that could 'refer' the recipient
> to a resource, but not care to receive a notification. 
> 
> Thx, 
> 
> Sriram 
> 
> 
> From: Adam Roach [ mailto:[email-masked]
> <mailto:[email-masked]> ] 
> >From: Sriram Parameswar [ mailto:[email-masked]
> <mailto:[email-masked]> ] 
> > 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip