Subject: [Sip] query on NOTIFY syntax

From: "Ranjit Avasarala" <[email-masked]>
Date: Tue, 2 Jul 2002 09:55:09 +0530

Hi
     as per draft-ietf-sip-refer-05.txt , the Content Type in NOTIFY is
message/sipfrag and contains the header Subscription-State

But as per draft-rosenberg-sip-reg-00)1).txt, the Content Type in NOTIFY is
application/reginfo+xml

which one should be used?

Actually my requirement is while implementing the feature of automatic
callback by user A. user A subscribes to this feature and user A should be
notified by the server when user B is free.

I use Event: autoCallBackUserB

In NOTIFY: subscription-state: "init" / "active"

TIA
Ranjit

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Tue, 2 Jul 2002 14:52:51 -0400

The content type depends on the package being used. draft-ietf-sip-refer-05
defines one package; draft-rosenberg-sip-reg-01 defines a different one.

Your proposal to use a brand-new and feature-specific event package
of "autoCallBackUserB" is unlikely to get any traction at all.
There is, however, an event package that is being defined that
includes all the functionality you need for an auto-callback feature.
See draft-ietf-sipping-dialog-package-00.

/a

> -----Original Message-----
> From: Ranjit Avasarala [mailto:[email-masked]]
> Sent: Monday, July 01, 2002 23:25
> To: sip-ietf
> Subject: [Sip] query on NOTIFY syntax
> 
> 
> Hi