Subject: [Sip] Authentication for re-INVITE.

From: "ShavinderPal Singh" <[email-masked]>
Date: Mon, 8 Jul 2002 17:21:49 +0530

Is a SIP proxy supposed to Authenticate a re-INVITE also? If no, then if
some proxy in Authenticating and it asks for Auth Info from the UA, what
is the UA supposed to do? Is it mandatory that it should send the Auth
Info?

Please suggest!

Thanks & Regards
s

Ph.: 091-124-6383474 (e 250)
__________________________________________
I had a good grip on life, but then the handle broke.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Mon, 8 Jul 2002 18:30:00 +0530

I don't think proxy needs to authenticate re-invite, as re-invite is used
for changing session parameters of an existing call

Ranjit

---

From: Chris Martin <[email-masked]>
Date: Mon, 08 Jul 2002 21:52:21 -0500

> for changing session parameters of an existing call

For this very reason you should reauthenticate...so that someone doesnt
spoof a forged INVITE with bad parameters within it back to the client.