Subject: [Sip] BYE race and re-INVITE doubt

From: "Sp.Raja" <[email-masked]>
Date: Thu, 18 Jul 2002 09:57:08 +0530

Hi,

Please clear my doubts on the following

1. What is expected out of the SIP element when it receives BYE after
sending a BYE?
Ex. Let UA1 and UA2 be two user agents and P1, P2 be proxies

       UA1    P1      P2      UA2
       |\      |       |      /|
       | \     |       |     / |
       |  \    |       |    /  |
       |   \   |       |   /   |
       |BYE \  |       |  / BYE|
       |     \>|\     /|</     |
       |       | \   / |       |
       |       |  \ /  |       |
       |       |   \   |       |
       |       |  / \  |       |
       |       *</   \>*       |
       |       |       |       |
       |       |       |       |

What will P1 and P2 do now after receiving BYE? They have already received
BYE from the opposite side and yet to receive the response for it.

2. When can re-INVITE be send?
I assume it can be send only after receiving ACK or sending ACK accordingly.
What is expected out of the proxy in the following cases? Does it simply
drops the re-INVITE?

UAC sending re-INVITE after sending INVITE and yet to receive final response
UAC sending re-INVITE instead of ACK after sending INVITE, received final
response
UAS sending re-INVITE after receiving INVITE
UAS sending re-INVITE after sending final response to INVITE and before
receiving ACK

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Matthias Konrad" <[email-masked]>
Date: Fri, 19 Jul 2002 13:14:58 +0200

Hi,
I think that a stateful proxy doesn't care about any of the cases
you described. A proxy, as far as I know, shouldn't hold any dialog states.
He just knows about INVITE and nonINVITE transaction states. If that is
true, he doesnt even know, that the two BYE Requests belongs to the same
dialog.