Subject: RE: [Sip] REFER: Who has implemented REFER without creating subsc riptions?

From: "Rosen, Brian" <[email-masked]>
Date: Wed, 10 Jul 2002 17:21:16 -0400

Of course we observe that "at least one" means some implementations
send one NOTIFY upon completion of REFER.  The new spec requires at
least two, an immediate one, and the one upon completion.

I agree we don't need the Required/Supported mechanism however.
All of us with "exactly one" will have to upgrade, but that's the
cost of implementing a draft.

Brian

> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Wednesday, July 10, 2002 4:15 PM
> To: Robert Sparks
> Cc: [email-masked]
> Subject: Re: [Sip] REFER: Who has implemented REFER without creating
> subscriptions?
> 
> 
> I've received no responses indicating someone has implemented
> accepting REFER and not sending NOTIFY. As sip-events matured,
> the perceived potential need for that behavior has diminished.
> 
> So, I am changing REFER to require the implicit subscription,
> so at least one NOTIFY will always be sent. (An implementation
> that needs to be extremely lightweight can send just one NOTIFY
> terminating the subscription). This change makes the 
> Required/Supported mechanics discussed in 
> draft-sparks-sip-refer-3265disc-00 unnecessary. I will remove
> them.
> 
> When the submission blackout is listed, I will submit the
> revised 3265disc draft as draft-ietf-sip-refer-06.
> 
> RjS
> 
> On Thu, 2002-06-27 at 09:46, Robert Sparks wrote:
> > This was part of the last message I sent, but it was buried
> > pretty deep.
> > 
> > When we made the decision to go with implicit subscriptions
> > work around the finite length non-INVITE transaction, we made
> > serving that subscription SHOULD strength to allow for 
> implementations
> > that couldn't deal with the weight of serving subscriptions.
> > 
> > Do the original proponents of allowing implementations to never
> > send a notify still see this need? Are there any implementations
> > out there that accept a REFER but don't send NOTIFYs?
> > 
> > The subscription concept has substantially matured (in particular,
> > Subscription-State is explicitly communicated). As Dan points out
> > in his last note, an implementation that needed to be very 
> lightweight
> > could send exactly one NOTIFY terminating the subscription. If
> > serving the subscription (even if it involved sending just that
> > one NOTIFY) were strictly mandatory, the error space is 
> much smaller.
> > 
> > RjS
> > 
> > 
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Adam Roach <[email-masked]>
Date: Wed, 10 Jul 2002 17:31:07 -0400

> From: Rosen, Brian [mailto:[email-masked]]
>
> The new [REFER] spec requires at least two [NOTIFYs],
> an immediate one, and the one upon completion.

As Dan pointed out and Robert reiterated, this isn't
precisely true. You can get away with just one
NOTIFY: the immediate one. As long as the "Subscription-
State" header indicates "terminated," this behavior
complies with the draft. The distinction is important,
since it doesn't require recipients of REFER to implement
the full event mechanism.

/a

---

From: "Sriram Parameswar" <[email-masked]>
Date: Fri, 12 Jul 2002 09:35:19 -0500

Hi All,

I think there is definite value to having REFER without NOTIFYs. There are
several non transfer applications that benefit from REFER, without having
the overhead of the NOTIFY(s).

To this end, I suggest that we include an option-tag "nosubscription" to the
REFER method. Thus if a UA wants to send a REFER but does not care for
notification of success of failure - it puts in Require: nosubscription. The
inclusion of the 'nosubscription' option-tag causes the REFER to complete
upon receiving the 202, without the need for NOTIFY(s). This is also
backwards compatible - because a regular REFER (without this option-tag)
continues to show standard behavior with atleast one NOTIFY.

Comments are welcome,

Sriram
__________________________________________
Sriram Parameswar              Phone: 972-685-8540
Interactive Multimedia Server (IMS) Fax: 972-684-3986
Nortel Networks, Richardson USA  Email: [email-masked]

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: Wednesday, July 10, 2002 4:31 PM
To: 'Rosen, Brian'; Robert Sparks
Cc: [email-masked]
Subject: RE: [Sip] REFER: Who has implemented REFER without creating
subsc riptions?

/a

---

From: Adam Roach <[email-masked]>
Date: Sun, 14 Jul 2002 20:15:07 -0500

>From: Sriram Parameswar [mailto:[email-masked]]
>
>I think there is definite value to having REFER without NOTIFYs.
>There are several non transfer applications that benefit from
>REFER, without having the overhead of the NOTIFY(s).

In particular, this reasoning flies in the face of the principle
of selecting "generality over efficiency" that has been established
for the SIP protocol and its extensions.

/a