Subject: [Sip] refer-06 question

From: [email-masked]
Date: Fri, 26 Jul 2002 11:18:06 +0200 (MEST)

Sir,

In 2.4.5 § of refer-06 draft It is stated that a "A minimal, but complete, 
implementation can respond with a single NOTIFY containing either ...the body: 
SIP/2.0 200 OK if the reference was successful".

It seems to be in contradiction with § 3.10 saying that "Alternatively, the 
subscription might only result in two NOTIFY requests, the immediate NOTIFY and 
the NOTIFY carrying the final result of the reference".

Do we need 1 or 2 NOTIFY in a minimal implementation?

Best Regards,

Patrick

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vijay S Kamath" <[email-masked]>
Date: Fri, 26 Jul 2002 17:54:41 +0530

Patrick,

You cannot delay the notification until the referenced request completes.
Quoting Sec 2.4.4: "The creation of a subscription as defined by [1] always results in an
immediate NOTIFY. "

So I suggest you follow your second suggestion.

Vijay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 26, 2002 5:24 PM
To: Vijay Kamath
Cc: [email-masked]
Subject: RE: [Sip] refer-06 question

vsk,

Thanks for the answer.
I understand both cases; but this does not light my way.
Let me put it in other words.

can i delay the notification until the referenced request completes? leading to send only 1 notification???? (assuming timers are OK).

Or am i oblige to send a 1rst notification, wait for completion of the 
referenced request and send a final notification ?

What is mandatory?

Patrick

Quoting Vijay S Kamath <[email-masked]>:

> It can be either 1 or more, but at least 1.
> Qouting Section 2.4.7: "Each NOTIFY must contain a Subscription-State 
> header field as defined
>    in [2].  The final NOTIFY sent in response to a REFER MUST indicate
>    the subscription has been "terminated" with a reason of 
> "noresource"."
> 
> The final NOTIFY can also be the first NOTIFY.
> 
> Regards... Vijay
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, July 26, 2002 2:48 PM
> To: [email-masked]
> Subject: [Sip] refer-06 question
> 
> 
> Sir,
> 
> 
> In 2.4.5 § of refer-06 draft It is stated that a "A minimal, but 
> complete, implementation can respond with a single NOTIFY containing 
> either ...the
> body:
> It seems to be in contradiction with § 3.10 saying that 
> "Alternatively, the subscription might only result in two NOTIFY 
> requests, the immediate NOTIFY and
> Use [email-masked] for questions on current sip Use 
> [email-masked] for new developments on the application of sip
>