Subject: [Sip] CANCEL FAQs

From: "Sp.Raja" <[email-masked]>
Date: Tue, 16 Jul 2002 15:55:36 +0530

Please help me out by answering these questions.

1. Can CANCEL be used to cancel a bye ?

2. Can CANCEL be send by the called entity (UAS) ? If yes then under what
circumstances

- Sp.Raja

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Tue, 16 Jul 2002 23:50:46 -0400

This stuff generally belongs to the implementor's list: sip-implementors
<[email-masked]>

Generally CANCEL should not be used for transactions which are bound to
complete
quickly, and never for transactions for which you havent received a
provisional (1xx)
response. So the answer for (1) would be: probably not. Also the UAS cannot
cancel
a transaction started by the UAC (I guess that's what you meant), so it
cannot generate
the CANCEL ever.

----- Original Message -----
From: "Sp.Raja" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, July 16, 2002 6:25 AM
Subject: [Sip] CANCEL FAQs

> 2. Can CANCEL be send by the called entity (UAS) ? If yes then under what

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Suresh Arora" <[email-masked]>
Date: Wed, 17 Jul 2002 18:14:33 +0530

I think UAS can send CANCEL to UAC for a re-INVITE (if requested session
characteristics are not supported by Server).

-Suresh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Medhavi
Bhatia
Sent: Wednesday, July 17, 2002 9:21 AM
To: [email-masked]
Subject: Re: [Sip] CANCEL FAQs

---

From: "Ranjit Avasarala" <[email-masked]>
Date: Thu, 18 Jul 2002 10:04:46 +0530

u cannot send CANCEL for re-invite as u won't be getting any ringing tone as
response

Ranjit

---

From: Robert Sparks <[email-masked]>
Date: 18 Jul 2002 18:26:18 +0900

I'm going to respond to this on the sip-implementors list.

That is the right forum to ask these kind of questions (and to
answer them). This list focuses on the SIP working groups
current design issues.

If you haven't subscribed to sip-implementors (and are interested),
the information you need to do so can be found at
http://www.cs.columbia.edu/~hgs/sip/list.html

RjS