Subject: RE: [Sip] Re: [Simple] -05 MESSAGE and Expires header

From: Adam Roach <[email-masked]>
Date: Mon, 22 Jul 2002 10:10:04 -0500

> -----Original Message-----
> From: Vijay K. Gurbani [mailto:[email-masked]]
> 
> Adam has proposed the 'Urgency' header

No, I didn't.

I attempted to outline that what we're talking about isn't
priority in any sense of the word.

We're talking about urgency.

I asked Hisham whether he was making a proposal for a new
header -- but it was asked with a certain amount of irony.
I didn't expect that he was doing so, and crafted the rest
of my message with the assumption that his answer would be
"no".

My argument remains that "Expires" is the most appropriate
header for this purpose.

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Mon, 22 Jul 2002 10:38:12 -0500

>>Adam has proposed the 'Urgency' header

Okay; my apologies.  I did detect the irony, but absent a face-
to-face conversation, I wasn't sure if you were being serious or
flippant.  Glad to know we won't be making up a new header.

> We're talking about urgency.

If I may, I think we are imparting urgency to an IM based on the
*content* of the IM.  In other words, to use one of your examples:

> High Priority, Low Urgency:
>   Note to new residents: failure to file income taxes by April
>   15th can lead to substantial penalties.

Absence other information (like the date that this IM was sent),
urgency is meaningless.  For example, if this IM was sent on April
14th, I would think that it would be classified with high urgency.
If, OTOH, it was sent on April 16th, its urgency is extremely low.
And a relay should not be put in position to use many heuristics
for figuring out which IMs should get immediate attention.

> My argument remains that "Expires" is the most appropriate

Right; I see I haven't convinced you yet :-)

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

---

From: Ben Campbell <[email-masked]>
Date: Mon, 22 Jul 2002 11:18:59 -0500

> for figuring out which IMs should get immediate attention.

OK, let me extend Adam's example: The message is sent on March 15. It 
has high priority, but low urgency. (And I assume that Adam was not 
suggesting that the relay understand the content of the note to 
determine urgency and priority--he was simply suggesting a situation 
where a sender might mark the message as high priority but low urgency.)

---

From: Sean Olson <[email-masked]>
Date: Mon, 22 Jul 2002 10:06:45 -0700 (PDT)

So we have three things we might want to 
represent:

1) Priority -- we use the Priority header for this
2) Timeliness of content -- we use Expires: header
   for this
3) Urgency -- we don't currently have a way to 
   represent this

Obviously 2 & 3 are related but not identical.
The message doesn't have to be urgent in order
for you to request immediate delivery. I think
solving (2) is enough for now. It is the more
interesting case for gateways and other
intermediaries that have to decide between a 
store-and-forward or immediate delivery approach.
In other words, stick with what we have today in
the draft.

/sean

__________________________________________________
Do You Yahoo!?
Yahoo! Health - Feel better, live better
http://health.yahoo.com