Subject: RE: [Sip] refer-06 question

From: "Vijay S Kamath" <[email-masked]>
Date: Fri, 26 Jul 2002 16:36:43 +0530

It can be either 1 or more, but at least 1.
Qouting Section 2.4.7: "Each NOTIFY must contain a Subscription-State header field as defined
   in [2].  The final NOTIFY sent in response to a REFER MUST indicate
   the subscription has been "terminated" with a reason of "noresource"."

The final NOTIFY can also be the first NOTIFY.

Regards... Vijay

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 26, 2002 2:48 PM
To: [email-masked]
Subject: [Sip] refer-06 question

Sir,

In 2.4.5 § of refer-06 draft It is stated that a "A minimal, but complete, 
implementation can respond with a single NOTIFY containing either ...the body: 
SIP/2.0 200 OK if the reference was successful".

It seems to be in contradiction with § 3.10 saying that "Alternatively, the 
subscription might only result in two NOTIFY requests, the immediate NOTIFY and 
the NOTIFY carrying the final result of the reference".

Do we need 1 or 2 NOTIFY in a minimal implementation?

Best Regards,

Patrick

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Fri, 26 Jul 2002 13:53:50 +0200 (MEST)

vsk,

Thanks for the answer.
I understand both cases; but this does not light my way.
Let me put it in other words.

can i delay the notification until the referenced request completes?
leading to send only 1 notification???? (assuming timers are OK).

Or am i oblige to send a 1rst notification, wait for completion of the 
referenced request and send a final notification ?

What is mandatory?

Patrick

Quoting Vijay S Kamath <[email-masked]>:

> Use [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
>

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 26 Jul 2002 12:02:29 -0700

> leading to send only 1 notification???? (assuming timers are OK).

hi,

not really.  its almost impossible to be sure that you can make sure the 
timers are OK.

> referenced request and send a final notification ?

the later.

so a minimal implementation would send first an immediate NOTIFY with 
the following body

SIP/2.0 100 Trying

and then upon success/failure a 200, 501, etc.. as described in the 
draft now.

thanks,
-rohan

>> implementation can respond with a single NOTIFY containing either 
>> ...the
>> body:

---

From: Pekka Pessi <[email-masked]>
Date: 27 Jul 2002 19:06:50 +0300

>leading to send only 1 notification???? (assuming timers are OK).

	No. You have to send the initial notification request. The
	initial NOTIFY request is needed in order to establish the
	dialog. Also, if the party sending does not care about the
	eventual result, it can respond with an error message to the
	initial NOTIFY and get the notification dialog terminated.

>referenced request and send a final notification ?

	That is the current interpretation, I think.

						Pekka