Subject: [Sip] Can INVITE overlap SUBSCRIBE

From: [email-masked]
Date: Wed, 8 Jan 2003 11:47:47 +0200

If a dialog is already established with a SUBSCRIBE, that SUBSCRIBE is being refreshed (SUBSCRIBE in progress). Can an INVITE, within the same dialog, be sent while the SUBSCRIBE refresh is in progress?

Another question: Can SUBSCRIBEs overlap in the following 2 scenarios?

Scenario 1:

   (1) SUBSCRIBE event:presence
---------------------------->

   (2) SUBSCRIBE event:presence
---------------------------->

(1) and (2) are requests within the same dialog and are the same association with the dialog.
Can (2) be sent before (1) completes. This is like INVITEs overlapping.

Scenario 2:

   (3) SUBSCRIBE event:presence
---------------------------->

   (4) SUBSCRIBE event:winfo
---------------------------->

(3) and (4) are requests within the same dialog but are in different associations with the dialog.
Can (4) be sent before (3) completes. This is like INVITE and SUBSCRIBE overlapping, I think.
A similar example of this is 2 SUBSCRIBEs with the same event package but different event ids.

Thanks,
Hisham
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Fri, 10 Jan 2003 19:59:12 -0500

> If a dialog is already established with a 
> SUBSCRIBE, that SUBSCRIBE is being refreshed 
> (SUBSCRIBE in progress). Can an INVITE, within 
> the same dialog, be sent while the SUBSCRIBE 
> refresh is in progress?

Yes.  However the requests might be received
out of order.  Thus it might lead to a 500 
response for the subscribe.

However caution should be observed when 
overlapping requests towards devices that
authenticate each request with a new nonce
and only remember the last nonce.  Such a
situation can lead to a continual challenge
situation where UAC appears to keep sending 
non-latest nonce.
 
> (1) and (2) are requests within the same dialog 
> and are the same association with the dialog.

Yes, assuming the dialog has already been establish.  
However the requests might be received out of order.  
Thus it might lead to a 500 response for 1.

> (3) and (4) are requests within the same dialog 
> but are in different associations with the dialog.
> Can (4) be sent before (3) completes. This is like 
> INVITE and SUBSCRIBE overlapping, I think.

I'm not positive about what you mean by different 
associations.  Thus I'll assume you mean different 
event types.

Assuming the dialog has already been establish,
yes it is legal to send.  However the requests might 
be received out of order.  Thus it might lead to a 
500 response for 3.

> A similar example of this is 2 SUBSCRIBEs with the 
> same event package but different event ids.

Yes it is legal to send.  However the requests might 
be received out of order.  Thus it might lead to a 
500 response for 3.