Subject: [Sip] target set

From: Gao Qing <[email-masked]>
Date: Fri, 24 Jan 2003 17:49:47 +0800

Dear Sirs,

Who can explain me what exactly is "target set" in RFC3261? Is there a
definition of it somewhere?

Thanks in advance!

Gao Qing

---

From: "Nataraju A.B.(huawei)" <[email-masked]>
Date: Fri, 24 Jan 2003 15:55:09 +0530

target setHi, 
I guess the target set (contact addressses) means the set of URI's returned by the redirect server.
these are the request uri for the next request send by teh UAC to reach the intended user.
Regards,
-------------------------------------------
Nataraju A.B.
Huawei Technologies India Pvt. Ltd.,
Tel : +91-80-5217152 / 4 Xtn 142
-------------------------------------------
  ----- Original Message ----- 
  From: Gao Qing 
  To: [email-masked] 
  Sent: Friday, January 24, 2003 3-19
  Subject: [Sip] target set

  Dear Sirs,

  Who can explain me what exactly is "target set" in RFC3261? Is there a definition of it somewhere? 

  Thanks in advance! 

  Gao Qing

---

From: "Ranjit Kumar Avasarala" <[email-masked]>
Date: Fri, 24 Jan 2003 17:06:35 +0530

target setHI

'target set' is a set of uris which the client sets to try incase it
receives a 3xx response.
so to start with the client will have only one uri in the target set ile the
target it intends to reach.

now say it receives 3xx (300 Moved) response then it receives a new URI in
the contact header. so it can place this URI in its target set and send the
request to that URI.

so this way the target set grows.

-Ranjit
  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Gao Qing
  Sent: Friday, January 24, 2003 3:20 PM
  To: [email-masked]
  Subject: [Sip] target set

  Dear Sirs,

  Thanks in advance!

  Gao Qing

---

From: "Nataraju A.B.(huawei)" <[email-masked]>
Date: Fri, 24 Jan 2003 18:09:32 +0530

target set----- Original Message ----- 
  From: Ranjit Kumar Avasarala 
  To: Gao Qing ; [email-masked] 
  Sent: Friday, January 24, 2003 5-06
  Subject: RE: [Sip] target set

  HI

  'target set' is a set of uris which the client sets to try incase it receives a 3xx response. 
  so to start with the client will have only one uri in the target set ile the target it intends to reach.

  This sentance is quiet confusing. In the initial request what the UAC tries out is not the target set (there is only one URI). its the URI which UAC intends to reach out. the target set (contact addresses in 3xx response ) implies the URI's where the target user could be reached. these addresses can be contacted in either linear or parallel search technique.

  now say it receives 3xx (300 Moved) response then it receives a new URI in the contact header. so it can place this URI in its target set and send the request to that URI.

  -Ranjit
    -----Original Message-----
    From: [email-masked] [mailto:[email-masked]]On Behalf Of Gao Qing
    Sent: Friday, January 24, 2003 3:20 PM
    To: [email-masked]
    Subject: [Sip] target set

    Dear Sirs,

    Thanks in advance! 

    Gao Qing 

    Regards,

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 24 Jan 2003 17:11:52 -0500

The target set is a set of URIs, used by proxies or UAC, which represent 
a set of destinations that are to be tried. A proxy creates such a set 
by contacting location services, but it can be changed by many factors 
through the duration of a transaction, such as a redirect response. A 
UAC creates a target set when it is redirected to multipicity of contacts.

-Jonathan R.

Nataraju A.B.(huawei) wrote:
>     *From:* Ranjit Kumar Avasarala <mailto:[email-masked]>
>     *To:* Gao Qing <mailto:[email-masked]> ; [email-masked]
>     <mailto:[email-masked]>
>     *Sent:* Friday, January 24, 2003 5-06
>     *Subject:* RE: [Sip] target set
> 
>     HI
>      
>     This sentance is quiet confusing. In the initial request what the
>     UAC tries out is not the target set (there is only one URI). its the
>     URI which UAC intends to reach out. the target set (contact
>     addresses in 3xx response ) implies the URI's where the target user
>     could be reached. these addresses can be contacted in either linear
>     or parallel search technique.
>      
>     now say it receives 3xx (300 Moved) response then it receives a new
>     URI in the contact header. so it can place this URI in its target
>     set and send the request to that URI.
>      
>         *From:* [email-masked] [mailto:[email-masked]]*On Behalf
>         Of *Gao Qing
>         *Sent:* Friday, January 24, 2003 3:20 PM
>         *To:* [email-masked]
>         *Subject:* [Sip] target set
> 
>         Dear Sirs,
> 

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip