Subject: RE: [Sip] any restrictions on characters in user part of sip uri?

From: [email-masked]
Date: Fri, 17 Jan 2003 17:20:10 -0600

Juha and all:

Comment:

What about using escaped is %hexhex for support to unicode which can be used for languages such as Japanese.

Regards

-- Jean-Luc
-----Original Message-----
From: ext [email-masked] [mailto:[email-masked]]
Sent: Friday, January 17, 2003 5:29 AM
To: [email-masked]
Subject: [Sip] any restrictions on characters in user part of sip uri?

the syntax of user part of sip uri is:

user = 1*( unreserved / escaped / user-unreserved )
user-unreserved = "&" / "=" / "+" / "$" / "," / ";" / "?" / "/"

escaped is %hexhex and can thus be used to include any character in
user.  is it really so that there is no restrictions on what chars may
be include in user using escaped?  for example, is %0000 valid in user?
if so, it makes implementations "interesting".

-- juha

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 24 Jan 2003 17:26:05 -0500

Well, the spec is currently quiet on this point. According to rfc2396, 
definitions of URI schemes are supposed to define the character set that 
is used to map from the octet sequence to the original character 
sequence. SIP doesn't say what this is. It ought to, though, and clearly 
UTF-8 is the appropriate choice. That would allow you to escape-encode 
Japanese characters, for example.

This has been logged in bugzilla for some time:
http://www.sipwg.org/sipwg/show_bug.cgi?id=678

Concerning Juha's example, UTF-8 has the property that 00 never occurs 
in a UTF-8 sequence except to represent NULL, so you shuoldn't be seeing 
it except in the "normal" US-ASCII way.

-Jonathan R.

[email-masked] wrote:
 > -- Jean-Luc -----Original Message----- From: ext [email-masked]
 > [mailto:[email-masked]] Sent: Friday, January 17, 2003 5:29 AM
 > To: [email-masked] Subject: [Sip] any restrictions on characters in
 > user part of sip uri?
 >
 >
 > user = 1*( unreserved / escaped / user-unreserved ) user-unreserved =
 > "&" / "=" / "+" / "$" / "," / ";" / "?" / "/"
 >
 > user.  is it really so that there is no restrictions on what chars
 > may be include in user using escaped?  for example, is %0000 valid in
 > user? if so, it makes implementations "interesting".
 >
 > -- juha
 >
 > _______________________________________________ Sip mailing list
 > https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
 > development of the core SIP Protocol Use
 > [email-masked] for questions on current sip Use
 > [email-masked] for new developments on the application of sip
 > _______________________________________________ Sip mailing list
 > https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
 > development of the core SIP Protocol Use
 > [email-masked] for questions on current sip Use
 > [email-masked] for new developments on the application of sip
 >

-- 
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com