Subject: RE: [Sip] INFO considered harmful

From: "Mark Watson" <[email-masked]>
Date: Mon, 6 Jan 2003 18:07:18 -0000

Looks at first glance like the Generic Transparency Descriptor which has
been proposed within ITU-T Study Group 11 and ANSI T1S1. Just out of
interest, what would be the MIME type for carrying this in SIP ?

Is recoding of ISUP into text format exactly in the scope of the IETF SIP
group ? 

...Mark

> -----Original Message-----
> From: Frank W. Miller [mailto:[email-masked]]
> Sent: 04 January 2003 00:02
> To: Dean Willis
> Cc: [email-masked]
> Subject: Re: [Sip] INFO considered harmful
> 
> 
> 
> 
> Well, any illusion of reasonableness I may have garnered in 
> the past is
> about to be shattered.  I would refer folks to:
> 
> http://www.ietf.org/internet-drafts/draft-miller-sip-isup-annex-00.txt
> 
> This draft is about to receive a major -01 update that 
> recodes the entire
> syntax in XML.  In addition, we (I) have another draft that 
> does something
> very similar for ANSI TCAP that I'll be submitting in short 
> order.  I guess
> its only appropriate that I bring peoples attention to these 
> drafts under
> the current subject heading...
> 
> FM
> 
> Frank W. Miller, Ph.D.
> Chief Technical Officer
> sentitO Networks, Inc.
> [email-masked]
> 
> ----- Original Message -----
> From: "Dean Willis" <[email-masked]>
> To: "'Neil Deason'" <[email-masked]>; "'Adam Roach'"
> <[email-masked]>
> Cc: <[email-masked]>
> Sent: Friday, January 03, 2003 6:13 PM
> Subject: RE: [Sip] INFO considered harmful
> 
> 
> > > What I was actually advocating here was ppl wanting to keep
> > > INFO around write up something to illuminate INFO packages
> > > and provide example usage.
> > >
> > > The MESSAGE cf INFO was just an attempt to highlight an
> > > apparent limitation with the ban INFO approach. Every MIME
> > > type in an INFO can be moved into MESSAGE rather than go
> > > away. Maybe through exploring INFO packages we evolve the
> > > collective understanding that this is/isn't a necessary thing.
> > >
> > > Cheers,
> > > Neil.
> >
> > This is an excellent suggestion, and very similar to the 
> one Jonathan made
> > to me on the phone yesterday (actually, I think he more 
> tersely worded it
> as
> > "Send Text!")
> >
> > --
> > Dean
> >
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on current sip
> > Use [email-masked] for new developments on the application of sip
> >
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

---

From: "Frank W. Miller" <[email-masked]>
Date: Mon, 6 Jan 2003 13:36:38 -0500

RE: [Sip] INFO considered harmfulWe just arbitarily picked:

Content-type: applicaton/isupxml

That is in the -01 version of this document that I referred to earlier.  Sorry, I'll get it up on the IETF site as quick as I can, hopefully within the week.

It is explictly outside the scope of the group, by choice I believe.  But this and the TCAP stuff are good examples of what I've been advocating, the need for some mechanism to allow stuff thats "related" but not necessarily appropriate (and in this case explictly shunned) for the mainline standard.  We actually looked at using SOAP for this (as was suggested by Adam) and decided against it for simple expedience (read development cost) reasons.  The mechanism present in our (third-party) SIP implementation was so compelling coupled with an off the shelf XML parser, that it didnt make sense to do anything else...

Furthermore, I would argue that you really never want anything like this to be included in the mainline standard for a couple of reasons.  First, it is very application specific.  Second, hopefully as SIP gains momentum and SS7 loses momentum with the large carriers, this stuff will just fade away...

FM

Frank W. Miller
Chief Technical Officer
sentitO Networks, Inc.
[email-masked]

  ----- Original Message ----- 
  From: Mark Watson 
  To: 'Frank W. Miller' ; Dean Willis 
  Cc: [email-masked] 
  Sent: Monday, January 06, 2003 1:07 PM
  Subject: RE: [Sip] INFO considered harmful

  Looks at first glance like the Generic Transparency Descriptor which has been proposed within ITU-T Study Group 11 and ANSI T1S1. Just out of interest, what would be the MIME type for carrying this in SIP ?

  Is recoding of ISUP into text format exactly in the scope of the IETF SIP group ?