Subject: [Sip] Multiple SDP descriptions for conferencing

From: "Seonman Kim" <[email-masked]>
Date: Wed, 22 Jan 2003 13:43:19 -0800

Hi,

I am trying to implement a SIP-based multi-point conferencing based on
"Centralized Signaling, Distributed Media" model
(draft-ietf-sipping-conferencing-models-01.txt). In this model, each
participant  UA gets updated SDP descriptions using "re-INVITE" whenever a
user enters to (or exits from) the conference. If the number of participants
becomes more than two,
then the re-INVITE message should contain two or more SDP descriptions.
For example, if user A, B and C are in the conference, then a re-INVITE to
user A should contain two SDP description, one for user B and the other for
user C.

My question here is: how to describe multiple SDP descriptions in the
content body
of INVITE (or 200 OK) message? Do we just concatenate them?
For example, if the conference server sends re-INVITE to user A with SDPs of
user B and C, the content body will look like this:

v=0
o=user-b 0 0 IN IP4 192.168.1.100
s=session
c=IN IP4 192.168.1.100
b=CT:1000
t=0 0
m=audio 30001 RTP/AVP 0
a=rtpmap:0 PCMU/8000
v=0
o=user-c 0 0 IN IP4 192.168.1.101
s=session
c=IN IP4 192.168.1.101
b=CT:1000
t=0 0
m=audio 30002 RTP/AVP 0
a=rtpmap:0 PCMU/8000

Is this correct implementation for multiple SDP sessions?
I could not find any descriptions in RTF 3261 that say UA should handle
multiple SDP sessions.

Thanks,
Seonman

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Johnston <[email-masked]>
Date: Thu, 23 Jan 2003 15:59:52 -0600

Hi Seonman,

You will find more updated work on SIP conferencing with the SIPPING 
Conferencing Design Team:

      http://www.softarmor.com/sipping/teams/conf/

The framework document includes a discussion of the this model:

      http://www.ietf.org/internet-drafts/draft-rosenberg-sipping-conferencing-framework-00.txt

Instead of multiple SDP message bodies, the re-INVITE would add an extra 
media line for each participant that enters the conference.  See below for 
an example.

For other valid offer/answer examples of SDP, see:

      http://www.ietf.org/internet-drafts/draft-johnston-mmusic-offer-answer-examples-00.txt

Thanks,
Alan Johnston
WorldCom
sip:[email-masked]

>Is this correct implementation for multiple SDP sessions?

No, I think it would look like this:

v=0