Subject: Re: [Sip] A simple query...

From: "Nataraju A.B." <[email-masked]>
Date: Thu, 02 Jan 2003 11:16:41 +0530

Hi, 

Server           =  "Server" HCOLON server-val *(LWS server-val)
 server-val       =  product / comment
product          =  token [SLASH product-version]

product-version  =  token

both product and product version are of type tokens.
if two tokes are in the input what should be considered. I mean product an dprod version OR two product values.

 for ex : Server: HomeServer HS v2
in this case HS is prod version or product2.

Regards,
-------------------------------------------
Nataraju A.B.
Huawei Technologies India Pvt. Ltd.,
Tel : +91-80-5216824/6/7 Xtn 142
-------------------------------------------
  ----- Original Message ----- 
  From: Jonathan Rosenberg 
  To: Nataraju A.B. 
  Cc: [email-masked] 
  Sent: Tuesday, 31 December 2002 20-06
  Subject: Re: [Sip] A simple query...

  inline.

  Nataraju A.B. wrote:
  > Hi,
  > I have a query regarding the server/user-agent coding format:
  > The ABNF encoding specifies it as : 
  >  
  > Server           =  "Server" HCOLON server-val *(LWS server-val)
  > server-val       =  product / comment
  > product          =  token [SLASH product-version]
  > product-version  =  token
  >  
  > whereas teh SIP-rfc says it should be
  >  Server: HomeServer v2
  > CanI know the correct format to be used.

  The above is just an example of the server header. It is a valid value 
  according to the BNF, since the BNF allows a series of lws-separated 
  tokens, without any slashes. Thus, either of these is valid:

  Server: HomeServer v2
  Server: HomeServer/v2

  >  
  > If the SIP format is to be used then is it product version is a 
  > mandatory argument.

  Version is not mandatory according to the BNF.

  -Jonathan R.
  -- 
  Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
  Chief Scientist                             First Floor
  dynamicsoft                                 East Hanover, NJ 07936
  [email-masked]                     FAX:   (973) 952-5050
  http://www.jdrosen.net                      PHONE: (973) 952-5000
  http://www.dynamicsoft.com

  _______________________________________________
  Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
  This list is for NEW development of the core SIP Protocol
  Use [email-masked] for questions on current sip
  Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 02 Jan 2003 11:26:45 -0500

inline.

Nataraju A.B. wrote:
>  for ex : Server: *HomeServer HS v2*

Its a second product. Version requires a slash. As a result, the example 
in the SIP spec which you quoted would have v2 parse as a product, not a 
version. Thats fine. This field is only useful for display to humans or 
for string comparison, in which case it doesnt matter whether the "v2" 
is interpreted as a product version or a product.

-Jonathan R.

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 02 Jan 2003 12:52:47 -0500

One additional comment here. I do appreciate that the example is 
probably confusing, since you would think that "v2" is a version, but 
its not. I've logged that into bugzilla.

-Jonathan R.

Jonathan Rosenberg wrote:
>> if two tokes are in the input what should be considered. I mean 
>> product an dprod version OR two product values.
>>

---

From: Michael Thomas <[email-masked]>
Date: Fri, 3 Jan 2003 10:41:35 -0800 (PST)

Juha Heinanen writes:
 > Michael Thomas writes:
 > 
 >  > The problem is that AAA's expect either a CHAP or
 >  > PAP formated authenticator. Digest, while it
 >  > doesn't chip the cleartext password ain't the same
 >  > format so you have a problem. Basic allows you to
 >  > hack up an authenticator at the proxy. Maybe
 >  > EAP+digest is our friend. Or maybe not.
 > 
 > what is wrong with draft-sterman-aaa-sip-00.txt?  we use it with digets
 > authentication without any problems.  leading radius servers support it
 > as well as all good sip proxies.

   Well, it seems to be expried for one... is the jist
   that AAA's have been hacked to deal with digest auth
   types directly (or, say, as an EAP type)? If
   so, that's certainly a possibility, and would
   have the obvious benefit of being useable for
   the web as well. 

       Mike

---

From: [email-masked]
Date: Fri, 3 Jan 2003 21:03:26 +0200

Michael Thomas writes:

 >    types directly (or, say, as an EAP type)? 

i made draft-sterman-aaa-sip-00.txt available as

ftp://lohi.eng.song.fi/tmp/draft-sterman-aaa-sip-00.txt

the directory is not listable.

-- juha

---

From: Rohan Mahy <[email-masked]>
Date: Tue, 14 Jan 2003 11:46:41 -0800

thanks juha,
i also reposted in the morgue on softarmor

http://kevlar.softarmor.com/sipping/drafts/morgue/draft-sterman-aaa- 
sip-00.txt

thx,
-r