Subject: [SIP] Authentication based on SIP request

From: "Roberto Tealdi" <[email-masked]>
Date: Thu, 9 Jan 2003 18:57:34 +0100

Hi to All

I'm new in SIP and I have a question:

In draft "draft-ietf-sipping-aaa-req-01" is specified that the Home AAA server must be able to authenticate a user based on any SIP Request (except CANCEL): this means that ANY SIP request message (from client to sip proxy) must contains a user's credentials, for example an authentication token? 

Thanks a lot.
Roby.

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 21 Jan 2003 13:16:32 +0200

Roberto,

It means that you can challenge any request (but CANCEL) in order to get
credentials for the UAC.

Gonzalo

Roberto Tealdi wrote:
> In draft "draft-ietf-sipping-aaa-req-01" is specified that the Home
> AAA server must be able to authenticate a user based on any SIP
> Request (except CANCEL): this means that ANY SIP request message (from
> client to sip proxy) must contains a user's credentials, for example
> an authentication token?
> 
> Thanks a lot.
> Roby.
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip