Subject: RE: [Sip] INFO Packaging -- draft-willis-sip-infopackage-00

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 15 Jan 2003 14:34:31 -0000

I nearly made the same comment as Henning when I made my comments, but decided I did not know enough about Content-Type etc usage to make the comment sensibly.

I would like to see some more discussion on this as I am not yet convinced either way.

If we end up following Deans proposal for a new header Info-Type, then at least we will need to capture some of this discussion in order that:

-	specifiers of new packages make sensible choices of values for Info-Type
-	implementers choose values of Content-* that are consistent with the Info-Type value.

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Dean Willis [mailto:[email-masked]]
> Sent: 14 January 2003 23:40
> To: 'Henning Schulzrinne'
> Cc: 'Christer Holmberg'; [email-masked]
> Subject: RE: [Sip] INFO Packaging -- draft-willis-sip-infopackage-00
> 
> 
> > could replace 
> > > INFO usage with a Content-Indirected MIME type?
> > 
> > No. We currently negotiate above-SIP content with Content-Type, 
> > Content-Language and all the other Content-Headers, just like 
> > HTTP, SMTP 
> > and other MIME users. If the body contains message/isup, it 
> > is an ISUP 
> > message. It is not clear to me what value an additional, 
> > semi-orthogonal 
> > negotiation mechanism offers. (Semi-orthogonal, since most 
> INFO types 
> > will have exactly one valid Content-Type.)
> 
> Ah. Actually, that is the direction that I initially started 
> taking things
> in the draft -- basically, I associated MIME content-types 
> with usages, and
> didn't have the Info-Type. Then I briefly talked it over with 
> Adam, and he
> talked me into the separate semantic indicator. 
> 
> I believe that the assertion that "most INFO types will have 
> exactly one
> valid Content-Type" is the breaker. Let's look at text. Is 
> the text I just
> sent you indicative of a move in the chess game we are playing? Is it
> something I want you to post on a web page for me? Should you 
> just read it?
> Is it a javascript that you should use to remap your 
> keyboard? Is it C code
> that you should compile and execute? Is it a credit card 
> number that you
> should debit for the price of this call? Why the heck AM I 
> sending it to
> you? 
> 
> There are probably much better examples, but I think that a one-to-one
> mapping between content-type and expected function is more 
> constraining than
> the way I think people are trying to use INFO, perhaps overly 
> constraining.
> 
> --
> dean
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 15 Jan 2003 10:12:47 -0500

>>that you should compile and execute? Is it a credit card 

The mistake would be specifying all of them as text/plain. They should 
be specified as the correct media type to begin with. After all, I may 
want to save the content and saving a C file as .txt instead of .c is 
not very helpful.

If this is application data, it should be labeled as application/chess.

In addition, there is Content-Disposition to look at.

---

From: "Dean Willis" <[email-masked]>
Date: Wed, 15 Jan 2003 14:04:59 -0600

> In addition, there is Content-Disposition to look at.

Consider XML. Do we end up with a different MIME registration for every
different XML schema? Or would we have to re-extend INFO to say "If the data
you've gotten is XML, then you must parse the schema declaration to know
which application reistered on this dialog gets the data?"

--
Dean

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 15 Jan 2003 16:26:51 -0500

> which application reistered on this dialog gets the data?"

I thought we used things like application/xml+cpl for different schema?