Subject: [Sip] Handling for ACK for 400 Response

From: Vijay Gaur <[email-masked]>
Date: Thu, 9 Jan 2003 10:03:42 -0500

Hi,
  When a UAS received a malformed Invite Request,
  it would send back a 400 Response after parsing
  the message. It would not (or may not be able to) 
  create a Transaction for the same.
  The Client on recieving this Response would respond
  with an ACK.

  The UAS would drop this ACK as an unhandled message,
  and would be reflected as an error on the same.

  The question is - Do we need a particular response code
  which would tell the client that an ACK for this should
  not be sent? 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Bob Penfield" <[email-masked]>
Date: Fri, 10 Jan 2003 17:41:41 -0500

inline
----- Original Message -----
From: "Vijay Gaur" <[email-masked]>

>   and would be reflected as an error on the same.

The ACK is just dropped, there is no error.

>   which would tell the client that an ACK for this should
I don't think that is necessary. The ACK is really harmless. The UAS can
respond statelessly (as described in section 8.2.7) for the malformed
request.

As far as the unhandled ACK, the UAS could form the to-tag of the response
such that the UAS could recognize it in the ACK and just ignore the ACK.