Subject: RE: [Sip] resource reservation

From: "Mark Watson" <[email-masked]>
Date: Wed, 8 Jan 2003 11:50:15 -0000

Well, for the avoidance of confusion:

1) GPRS terminals need to perform a GPRS-specific resource reservation
mechanims to get resources on the radio network/GPRS core network. This is
known as a PDP Context. 3GPP IMS uses the "Integration of Resource
Management and SIP" mechanisms to delay completion of the SIP session
establishment until this GPRS-specific procedure has been completed.

2) Various mechanism can be used within the GPRS network/RAN to ensure that
the traffic receives the QoS agreed in the PDP Context establishment
negotiation. This could include Diffserv/MPLS but is internal to the GPRS
network and not visible to the terminal

3) The Go interface is COPS-PR, not Diameter. It is used to authorise PDP
Context establishements which are related to SIP sessions.

4) The terminal is free to attempt RSVP reservations, but these will have no
effect on the GPRS network, unless the Layer 2 in the terminal is trapping
them and firing off appropriate PDP Context requests. The RSVP may of course
affect 'downstream' networks outside GPRS.

...Mark

> -----Original Message-----
> From: Pianigiani, Jacopo (Jacopo) [mailto:[email-masked]]
> Sent: 07 January 2003 17:15
> To: 'Jonathan Rosenberg'; Mukul Purohit
> Cc: [email-masked]
> Subject: RE: [Sip] resource reservation
> 
> 
> Jonathan & Mukul,
> as far as I know, referring to 3GPP, Rel.5 (frozen) and rel. 
> 6 (being written almost now) specs the following QoS 
> alternatives mechanisms to pure RSVP reservation mechanism 
> will be available:
> a) Go Diameter interface on the GGSN (traffic gating & 
> shaping + CAC) + conditioning of the Radio Access Bearer
> b) Diffserv and E/L-LSP QoS transport across RAN (but not for 
> reservation, just for PHB treatment)
> c) as you correctly stated, end to end RSVP signalling 
> (inheritance of Signalled SIP QoS parameters)
> 
> Jac
> 
> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]]
> Sent: Monday, December 30, 2002 5:37 PM
> To: Mukul Purohit
> Cc: [email-masked]
> Subject: Re: [Sip] resource reservation
> 
> 
> 
> 
> Mukul Purohit wrote:
> > hi,
> > I have a basic question after going through RFC 3312, 
> "Integration of 
> > Resource Management and SIP".
> > 
> > Has the actual resource reservation mechanism been 
> specified (mandated 
> > or suggested) by IETF?
> 
> There is no mandatory resource reservation scheme. The primary one 
> specified so far is RSVP. nsis is another one under 
> development. Groups 
> like packetcable have specified their own QoS protocols.
> 
> > Also, has it been specified by any other body like 3GPP 
> which has chosen 
> > SIP for signaling?
> 
> Yes, 3gpp has its own mechanisms that are specific to 3gpp. As I 
> understand they are built into the GPRS procedures, and reservation 
> occurs only on the wireless link.
> 
> -Jonathan R.
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
> Chief Scientist                             First Floor
> dynamicsoft                                 East Hanover, NJ 07936
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

---

From: Henry Sinnreich <[email-masked]>
Date: Wed, 08 Jan 2003 09:08:29 -0600

>3) The Go interface is COPS-PR, not Diameter.
yes, and RADIUS in wireline systems. Also not DIAMETER.

Thanks, Henry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Mark
Watson
Sent: Wednesday, January 08, 2003 5:50 AM
To: 'Pianigiani, Jacopo (Jacopo)'; 'Jonathan Rosenberg'; Mukul Purohit
Cc: [email-masked]
Subject: RE: [Sip] resource reservation

Well, for the avoidance of confusion: 
1) GPRS terminals need to perform a GPRS-specific resource reservation
mechanims to get resources on the radio network/GPRS core network. This
is known as a PDP Context. 3GPP IMS uses the "Integration of Resource
Management and SIP" mechanisms to delay completion of the SIP session
establishment until this GPRS-specific procedure has been completed.
2) Various mechanism can be used within the GPRS network/RAN to ensure
that the traffic receives the QoS agreed in the PDP Context
establishment negotiation. This could include Diffserv/MPLS but is
internal to the GPRS network and not visible to the terminal
3) The Go interface is COPS-PR, not Diameter. It is used to authorise
PDP Context establishements which are related to SIP sessions.
4) The terminal is free to attempt RSVP reservations, but these will
have no effect on the GPRS network, unless the Layer 2 in the terminal
is trapping them and firing off appropriate PDP Context requests. The
RSVP may of course affect 'downstream' networks outside GPRS.
...Mark

---

From: Jiri Kuthan <[email-masked]>
Date: Wed, 08 Jan 2003 22:25:00 +0100

>yes, and RADIUS in wireline systems. Also not DIAMETER.

Let my add my two cents: quite many our users are interesterd
in use of RADIUS for SIP accounting, and there is zero interest
in diameter. The reason is there is a widely deployed RADIUS
base. To operators, diameter benefits are apparently less
compelling than the upgrade inconvenience. I'm sort of
surprised, that the WG has ignored this situation and has
not produced any document on use of RADIUS for SIP.

-Jiri

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 08 Jan 2003 20:58:41 -0500

There is a long-expired document on this topic; 
draft-schulzrinne-sipping-radius-accounting-00.txt

You can find it in the musty corners of 
http://www.cs.columbia.edu/sip/drafts/

By reading it, you will lose all your political correctness points.

---

From: Jiri Kuthan <[email-masked]>
Date: Thu, 09 Jan 2003 10:40:50 +0100

Actually, we have implemented it and it is fine. I'm just 
concerned about lack of a standard -- that makes interaction
of accounting apps with SIP servers difficult. I would really
like to see it as a WG item.

-Jiri

At 02:58 AM 1/9/2003, Henning Schulzrinne wrote:
>There is a long-expired document on this topic; draft-schulzrinne-sipping-radius-accounting-00.txt
>
>You can find it in the musty corners of http://www.cs.columbia.edu/sip/drafts/
>

---

From: Henry Sinnreich <[email-masked]>
Date: Thu, 09 Jan 2003 13:33:34 -0600

>I would really 

Yes, it would be a good idea to start with
>draft-schulzrinne-sipping-radius-accounting-00.txt> and make it a WG
item. This is very useful.

Thanks, Henry

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jiri Kuthan
> Sent: Thursday, January 09, 2003 3:41 AM
> To: Henning Schulzrinne; Jiri Kuthan
> Cc: [email-masked]
> Subject: radius (was Re: [Sip] resource reservation
> 
> 
> >>Let my add my two cents: quite many our users are 
> interesterd in use 
> >>of RADIUS for SIP accounting, and there is zero interest in 
> diameter. 
> >>The reason is there is a widely deployed RADIUS base. To operators, 
> >>diameter benefits are apparently less compelling than the upgrade 
> >>inconvenience. I'm sort of surprised, that the WG has ignored this 
> >>situation and has not produced any document on use of 
> RADIUS for SIP.
> >>-Jiri  
> >Use [email-masked] for questions on 
> current sip Use 
> >[email-masked] for new developments on the application of sip
> 
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>