Subject: RE: [Sip] INFO Packaging -- draft-willis-sip-infopackage-00

From: "Tom-PT Taylor" <[email-masked]>
Date: Wed, 15 Jan 2003 10:36:12 -0500

I really agree with Henning's viewpoint.  The mechanisms are already there.
Quite frankly, I don't want to have to redo my SIP-T implementation of INFO
unless a really good case can be made for it.

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]] 
> Sent: Wednesday, January 15, 2003 10:13 AM
> To: Drage, Keith (Keith)
> Cc: 'Dean Willis'; [email-masked]
> Subject: Re: [Sip] INFO Packaging -- draft-willis-sip-infopackage-00
> 
> 
> 
> >>Ah. Actually, that is the direction that I initially started
> >>taking things
> >>in the draft -- basically, I associated MIME content-types 
> >>with usages, and
> >>didn't have the Info-Type. Then I briefly talked it over with 
> >>Adam, and he
> >>talked me into the separate semantic indicator. 
> >>
> >>I believe that the assertion that "most INFO types will have
> >>exactly one
> >>valid Content-Type" is the breaker. Let's look at text. Is 
> >>the text I just
> >>sent you indicative of a move in the chess game we are 
> playing? Is it
> >>something I want you to post on a web page for me? Should you 
> >>just read it?
> >>Is it a javascript that you should use to remap your 
> >>keyboard? Is it C code
> >>that you should compile and execute? Is it a credit card 
> 
> The mistake would be specifying all of them as text/plain. 
> They should 
> be specified as the correct media type to begin with. After 
> all, I may 
> want to save the content and saving a C file as .txt instead of .c is 
> not very helpful.
> 
> If this is application data, it should be labeled as 
> application/chess.
> 
> In addition, there is Content-Disposition to look at.
> 
> 
> >>number that you
> >>should debit for the price of this call? Why the heck AM I
> >>sending it to
> >>you? 
> >>
> >>There are probably much better examples, but I think that a 
> one-to-one 
> >>mapping between content-type and expected function is more 
> >>constraining than the way I think people are trying to use INFO, 
> >>perhaps overly constraining.
> >>
> >>--
> >>dean
> >>
> >>
> >>_______________________________________________
> >>Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> >>This list is for NEW development of the core SIP Protocol
> >>Use [email-masked] for questions on 
> current sip Use 
> >>[email-masked] for new developments on the application of sip
> >>
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol
> > Use [email-masked] for questions on 
> current sip Use 
> > [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current 
> sip Use [email-masked] for new developments on the 
> application of sip
>

---

From: "Adam Roach" <[email-masked]>
Date: Wed, 15 Jan 2003 17:36:02 -0600

RE: [Sip] INFO Packaging -- draft-willis-sip-infopackage-00
You don't have to re-do it, as long as we grandfather its usage like we did
with
PINT in RFC 3265.

/a

----- Original Message -----
From: Tom-PT Taylor
To: 'Henning Schulzrinne' ; Drage, Keith (Keith)
Cc: 'Dean Willis' ; [email-masked]
Sent: Wednesday, January 15, 2003 9:36
Subject: RE: [Sip] INFO Packaging -- draft-willis-sip-infopackage-00

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip