Subject: RE: [Sip] Re: Callerprefs: Mobility tag

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 23 Apr 2003 11:32:57 +0100

I think I agree with Paul on this one.

Unless someone comes up with a single set of semantics of what it means, it should go away.

What makes it useless is that the explanation below gives two, possibly mutually incompatible, semantics for the same parameter.

I would also point out that the charging characteristics (in Europe) for mobile and fixed line calls are so completely different that it is difficult to conclude on the basis of a single call whether one is cheaper or not. Yes, roaming will maked the roaming user (who could either be calling or called) incur call charges, but the roaming user makes a personal choice to turn their phone on when they are roaming. And the bulk of subscribers making lots of calls are not roaming.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked] 

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: 23 April 2003 02:51
> To: Paul Kyzivat
> Cc: Mary Barnes; Jonathan Rosenberg; [email-masked]'
> Subject: [Sip] Re: Callerprefs: Mobility tag
> 
> 
> I think this is useful. Yes, having something like "don't call if it 
> costs extra" or "don't call if the person is in a car or 
> meeting" would 
> be better, but until everybody uses RPIDS, 'no mobile phone' 
> is a pretty 
> good approximation and actually implementable. (In European 
> countries, 
> the *caller* pays more for mobile calls, so this is a real 
> concern. And 
> mobile is indeed the distinction that matters, not something else.)
> 
> Paul Kyzivat wrote:
> 
> > I've always had trouble with the semantics of this feature. All the 
> > examples I can think of for using it really depend of coincidental 
> > association between mobility and other features.
> > 
> > For instance, *why* would I prefer to call someone on their 
> fixed phone 
> > rather than their mobile phone?
> > 
> > - because use of the mobile phone is expensive?
> > 
> > - because I know the fixed phone is in a particular location
> >   and I only want to reach them if they are there.
> > 
> > Neither of these are really directly related to the fixed 
> nature of the 
> > phone.
> > 
> > I think I asked Jonathan about this and he felt it should be kept 
> > because it had been around for a long time and we didn't have 
> > justification for removing it. Personally I think it could 
> just go away.
> > 
> >     Paul
> > 
> > Mary Barnes wrote:
> > 
> >> In section 9.9, the mobility tag is described as 
> "indicates whether the
> >> device is fixed, wireless or somewhere in-between", 
> however, there is no
> >> definition for the somewhere in-between. 
> >> So, my initial reaction would be to reword this as 
> "indicates whether the
> >> device is fixed or wireless", but then I got to thinking 
> about what could
> >> have been meant by some in-between and I think there might be some 
> >> value in
> >> defining some of those now. 
> >> One term I had considered was "nomadic" as the 
> "in-between".  But, then I
> >> also got to thinking that perhaps "WiFi" is a good example of the
> >> "in-between".  The usefulness of these really depends upon how they
> >> would/could be used.  The one example I saw in the 
> usecases draft was 
> >> around
> >> wanting to contact someone only on their mobile phone.  
> The inverse of 
> >> this
> >> could be that you absolutely don't want to contact them on 
> their mobile
> >> phone, but would want to contact them on anything else or 
> perhaps only if
> >> they're "fixed" or "WiFi". "Nomadic" might be useful for scenarios 
> >> whereby
> >> one's network connectivity is via tunneling, thus it's 
> indicative not 
> >> being
> >> reachable at the "fixed" device (eg. the hard SIP client), 
> but you are
> >> available on your soft SIP client working from home.   I 
> haven't thought
> >> this all the way through, but I do think additional terms could be 
> >> extremely
> >> useful.
> >>
> >> Mary H. Barnes
> >> [email-masked]
> >>
> >>
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Mary Barnes" <[email-masked]>
Date: Wed, 23 Apr 2003 08:31:38 -0500

I think there is still some value in just keeping it at "Fixed" and "Mobile"
(per my initial reaction that the "or somewhere in between" needed to be
deleted).  My original posting had been to perhaps expand, but I've been
thinking about that further and clearly there is no compelling reason.  

I think it is still useful for the specific context whereby I as a caller
don't want my calls to go to people's mobiles (even if they do want them to)
OR I only want to go to their mobile or fixed contacts.  Given the current
24/7 reachability empowered by SIP, I think this is useful functionality.  I
also think this is useful given that it's difficult to attach a "personal"
vs. "business" association to mobiles, since most folks use them for both.
Now, this is all predicated on folks registering their contacts with these
tags, but I know that for our system we have implemented the "mobile" tag
and do find it useful. 

Mary.

-----Original Message-----
From: Drage, Keith (Keith) [mailto:[email-masked]]
Sent: Wednesday, April 23, 2003 5:33 AM
To: 'Henning Schulzrinne'; Paul Kyzivat
Cc: Barnes, Mary [NGC:B602:EXCH]; Jonathan Rosenberg; [email-masked]'
Subject: RE: [Sip] Re: Callerprefs: Mobility tag

Unless someone comes up with a single set of semantics of what it means, it
should go away.

What makes it useless is that the explanation below gives two, possibly
mutually incompatible, semantics for the same parameter.

I would also point out that the charging characteristics (in Europe) for
mobile and fixed line calls are so completely different that it is difficult
to conclude on the basis of a single call whether one is cheaper or not.
Yes, roaming will maked the roaming user (who could either be calling or
called) incur call charges, but the roaming user makes a personal choice to
turn their phone on when they are roaming. And the bulk of subscribers
making lots of calls are not roaming.

Keith

Keith Drage
Lucent Technologies
Tel: +44 1793 776249
Email: [email-masked]

---

From: "Mary Barnes" <[email-masked]>
Date: Wed, 23 Apr 2003 08:37:08 -0500

Per my response to Keith's posting, I agree with this proposal (retracting
my suggestion to add other definitions). 

Mary.

-----Original Message-----
From: Jonathan Rosenberg [mailto:[email-masked]]
Sent: Wednesday, April 23, 2003 1:59 AM
To: Henning Schulzrinne
Cc: Paul Kyzivat; Barnes, Mary [NGC:B602:EXCH]; [email-masked]'
Subject: Re: Callerprefs: Mobility tag

Well, practically speaking, people tell me all the time to "call me on 
my mobile". Caller preferences would allow me to do that without needing 
to have two numbers for that person.

Now, addressing Mary's main point, about adding other definitions for 
mobility. I don't want this to be a technology definition - i.e., 3g 
being different than 2g being different that WiFi. I think the essential 
aspect of it is whether there is a fixed poitn of attachment to the 
network or not As such, it is my preference to just remove the "in 
between" bit. Here is the new text:

\item[Summary of the media feature indicated by this tag:] The
mobility feature tag indicates whether the device is fixed (meaning
that it is associated with a fixed point of contact with the network),
or mobile (meaning that it is not associated with a fixed point of
contact). Note that cordless phones are fixed, not mobile, based on
this definition.

-Jonathan R.

Henning Schulzrinne wrote:
> costs extra" or "don't call if the person is in a car or meeting" would 
> be better, but until everybody uses RPIDS, 'no mobile phone' is a pretty 
> good approximation and actually implementable. (In European countries, 
> the *caller* pays more for mobile calls, so this is a real concern. And 
>> For instance, *why* would I prefer to call someone on their fixed 
>> phone rather than their mobile phone?
>>
>> Neither of these are really directly related to the fixed nature of 
>> the phone.
>>
>> justification for removing it. Personally I think it could just go away.
>>
>>     Paul
>>
>> Mary Barnes wrote:
>>
>>> In section 9.9, the mobility tag is described as "indicates whether the
>>> device is fixed, wireless or somewhere in-between", however, there is no
>>> definition for the somewhere in-between. So, my initial reaction 
>>> would be to reword this as "indicates whether the
>>> device is fixed or wireless", but then I got to thinking about what 
>>> could
>>> defining some of those now. One term I had considered was "nomadic" 
>>> as the "in-between".  But, then I
>>> would/could be used.  The one example I saw in the usecases draft was 
>>> around
>>> wanting to contact someone only on their mobile phone.  The inverse 
>>> of this
>>> could be that you absolutely don't want to contact them on their mobile
>>> phone, but would want to contact them on anything else or perhaps 
>>> only if
>>> one's network connectivity is via tunneling, thus it's indicative not 
>>> being
>>> reachable at the "fixed" device (eg. the hard SIP client), but you are
>>> available on your soft SIP client working from home.   I haven't thought

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com