Subject: [Sip] Presence architecture for fixed line network

From: "Ashish Naik" <[email-masked]>
Date: Mon, 14 Apr 2003 12:27:29 +0530

Can someone point me to an architecture documents of SIP based presence
architecture in fixed line network ?

I want to know which network elements will be part of this as compared to
presence server in 3G networks.
Ashish

*********************************************************
Disclaimer

This message (including any attachments) contains 
confidential information intended for a specific 
individual and purpose, and is protected by law. 
If you are not the intended recipient, you should 
delete this message and are hereby notified that 
any disclosure, copying, or distribution of this
message, or the taking of any action based on it, 
is strictly prohibited.

*********************************************************
Visit us at http://www.mahindrabt.com

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Thu, 17 Apr 2003 14:58:42 -0500

Ashish Naik wrote:
> I want to know which network elements will be part of this as compared 
> to presence server in 3G networks.

Take a look at some of the work in the SPIRITS WG:

http://www.ietf.org/internet-drafts/draft-gurbani-spirits-implementation-00.txt
http://www.ietf.org/internet-drafts/draft-ietf-spirits-protocol-04.txt

Regards,

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Wireless Networks Group/Internet Software and Services
Lucent Technologies/Bell Labs Innovations, 2000 Lucent Lane, Rm 6G-440
Naperville, Illinois 60566     Voice: +1 630 224 0216

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 18 Apr 2003 02:14:10 -0400

Vijay, I'm confused.

Last I checked, draft-ietf-simple-presence discussed presence, and to my 
knowledge it wasnt specific to wireline or wireless, but to any network 
that used IP. I am not sure what relation spirits has. I certainly hope 
you are not proposing that spirits represents a presence protocol 
specific for wireline?

-Jonathan R.

Vijay K. Gurbani wrote:
> Ashish Naik wrote:
> 
>> Can someone point me to an architecture documents of SIP based 
>> presence architecture in fixed line network ?
>>  

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Scientist                             Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Fri, 18 Apr 2003 10:39:31 -0500

> you are not proposing that spirits represents a presence protocol 

Heavens, no.  The original poster wanted to know which network
elements may contribute to the derivation of presence information
for fixed-line networks; and that's where the tie-in to SPIRITS
comes in.

Rest assured, I am not proposing yet another presence protocol for
wireline networks.  In fact, if you skim over my implementation
I-D, I reuse the application/cpim+pidf MIME type and all the other
work in IMPP and SIMPLE WGs.

Regards,

- vijay