Subject: [Sip] Backward compatibility of expires header

From: murali <[email-masked]>
Date: Mon Apr 28 14:56:52 2003

In RFC 2543 Expires header is defined as "Expires" ":" ( SIP-date | delta-seconds ), whereas in RFC 3261 it is only "Expires" HCOLON delta-seconds.

Will it not create backward compatibility issues if somebody is using SIP-date to specify the expires duration?

Rgds,
Murali

-------
Murali Voleti,
#503,Maheswari complex,
Masab Tank,
Hyderabad
Tele:(040) 6502272 ext:211

_____________________________________________________________
Get Your Free ScanMail and Email At http://mail.ttkbharatplanet.com
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Brett Tate" <[email-masked]>
Date: Tue, 29 Apr 2003 11:26:31 -0400

> In RFC 2543 Expires header is defined as 
> "Expires" ":" ( SIP-date | delta-seconds ), 
> whereas in RFC 3261 it is only 
> "Expires" HCOLON delta-seconds.
> 
> Will it not create backward compatibility 
> issues if somebody is using SIP-date to 
> specify the expires duration?

Polls and comments were taken prior to
removing the backward compatibility.

If I recall correctly, the Contact expires 
parameter of a 200 response to a REGISTER was 
the only location that vendors had previously 
chose to send SIP-date instead of delta-seconds.

Those using SIP-date within Expires and
and various other headers agreed to change
their implementations start sending delta-seconds.