Subject: RE: [Sip] Relationship between Dialog and Call-ID

From: "Vishal Phirke" <[email-masked]>
Date: Wed, 9 Apr 2003 09:41:29 -0400

I don't think the re-invite will be forked. The re-invite most likely will
travel directly end-to-end or using route header. The forking is done only
for the first invite. Correct me if I am wrong.
-Vishal

                      "Patrick Lam"                                                                        
                      <[email-masked]        To:       "'Phil Reynolds'" <[email-masked]> 
                      rg>                      cc:       <[email-masked]>                                    
                      Sent by:                 Subject:  RE: [Sip] Relationship between Dialog and Call-ID 
                      <[email-masked]                                                                    
                      rg>                                                                                  

                      04/09/2003 05:27                                                                     
                      AM                                                                                   

Phil:

Thanks for your answer.  Just a little more to clarify: when I send an
re-INVITE for a particular dialog, I have to use the same Call-ID, To/From
tag for that particular dialog?  Would the re-INVITE be forked as well?  If
so, what would I do with the re-INVITE?

Thanks again.

Patrick

-----Original Message-----
From: Phil Reynolds [mailto:[email-masked]]
Sent: Wednesday, April 09, 2003 4:52 PM
To: Patrick Lam
Subject: RE: [Sip] Relationship between Dialog and Call-ID

A dialog is identified by the Call-ID, to-tag and from-tag. The Call-ID
itself is insufficient as the same INVITE may have been forked to several
different recipients that may all create dialogs.

              -----Original Message-----
             From:             [email-masked]
[mailto:[email-masked]]  On Behalf Of
Patrick Lam
             Sent:             09 April 2003 09:01
             To:         [email-masked]
             Subject:          [Sip] Relationship between Dialog and
Call-ID

             Dear all:

             I am a little confused about the relationship between a dialog
and
the Call-ID:

             1.          Do requests "within the same dialog" use identical
Call-ID,
while requests "outside of a dialog" use different Call-ID than those
"within"?
             2.          In the last paragraph on p.16 in RFC 3261:

             "This re-INVITE references the existing dialog so that the
other
party knows that it is to modify an existing session instead of
establishing
a new session."

             What does the re-INVITE use to refer to the existing dialog?
Call-ID?

             Thanks very much in advance.

             Regards,

             Patrick
(See attached file: winmail.dat)

---

From: Michael Georgiades <[email-masked]>
Date: Wed, 09 Apr 2003 15:10:16 +0100

"Unlike an INVITE, which can fork, a re-INVITE will never fork...."
pg 87 RFC 3261

Vishal Phirke wrote:

>   ------------------------------------------------------------------------
>                   Name: winmail.dat
>    winmail.dat    Type: unspecified type (application/octet-stream)
>               Encoding: base64

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip