Subject: [Sip] [Fwd: CSPS v2.0 - Register problem]

From: Paraskevopoulos Pavlos <[email-masked]>
Date: Tue, 15 Apr 2003 20:55:09 +0300

Hi all,

I have a problem considering Registration while I' m working with Cisco 
SIP Proxy Server ver.2.0 (CSPS).

My REGISTER message is the following

REGISTER sip:VOICE.SPDOP.RU SIP/2.0
Max-Forwards: 70
Via: SIP/2.0/UDP 10.100.1.165:5060
From: <sip:[email-masked]>;tag=14713
To: <sip:[email-masked]>
Call-ID: [email-masked]
CSeq: 1 REGISTER
Contact: <sip:[email-masked]:5060>
Expires: 180
User-Agent: netPhone-010107A
Content-Length: 0

And the Proxy responds the following

SIP/2.0 100 Trying
Via: SIP/2.0/UDP 10.100.1.165:5060;received=10.100.1.165
Call-ID: [email-masked]
From: <sip:[email-masked]>;tag=14713
To: <sip:[email-masked]>
CSeq: 1 REGISTER
Content-Length: 0

SIP/2.0 200 OK
Via: SIP/2.0/UDP 10.100.1.165:5060;received=10.100.1.165
Call-ID: [email-masked]
From: <sip:[email-masked]>;tag=14713
To: <sip:[email-masked]>
CSeq: 1 REGISTER
Contact: <sip:[email-masked]:5060>;expires="Thu, 10 Apr 2003 
23:53:57 GMT"
Expires: 180
Content-Length: 0

SIP/2.0 400 Error in Headers
Via: SIP/2.0/UDP 10.100.1.165:5060;received=10.100.1.165
Call-ID: [email-masked]
From: <sip:[email-masked]>;tag=14713
To: <sip:[email-masked]>
CSeq: 1 REGISTER
Contact: <sip:[email-masked]:5060>;expires="Thu, 10 Apr 2003 
23:53:57 GMT"
Expires: 180
Content-Length: 0

Could anyone help me?
I have used several other proxies including  ser and everything was fine.

Thanks in advance.

Pavlos Paraskevopoulos (www.intracom.gr)

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A.B." <[email-masked]>
Date: Fri, 18 Apr 2003 14:50:29 +0530

Can This be possible ???

What I understood is UAS reply back with 200 OK only after all the necessay steps have been taken against that registration request. 

I feel this can happen only when you send a REGISTER request to multicast server (not in case of Unicast servers) . 
In that case the 1st final response will be considered and later ones will be discardeed.

Regards,
-Nataraju A.B.
  ----- Original Message ----- 
  From: Paraskevopoulos Pavlos 
  To: [email-masked] 
  Sent: Tuesday, April 15, 2003 11:25 PM
  Subject: [Sip] [Fwd: CSPS v2.0 - Register problem]

  Hi all,

  SIP/2.0 100 Trying

  SIP/2.0 200 OK

  Could anyone help me?

  Thanks in advance.

---

From: Cullen Jennings <[email-masked]>
Date: Sat, 19 Apr 2003 22:35:59 -0700

Nope, sending two final responses for one transaction is definitely 
wrong. Since it's just a bug in Cisco's proxy, let's move the 
discussion off this email list.

On Friday, April 18, 2003, at 02:20 AM, Nataraju A.B. wrote:

> Can This be possible ???
>  
> What I understood is UAS reply back with 200 OK only after all the 
> necessay steps have been taken against that registration request.
>  
> I feel this can happen only when you send a REGISTER request to 
> multicast server (not in case of Unicast servers) .