Subject: RE: [Sip] Updated gruu mechanism spec

From: "Christian Jansson" <[email-masked]>
Date: Thu, 11 Dec 2003 16:18:53 +0100

> Christian Stredicke wrote:
>
> The client usually closes the TCP connection 
> after the transaction or a short timeout. 

That is just your assumption on how a client works. In my mind
it is usually better for the client to keep the TCP connection up
for much longer.

/ Christian Jansson

> That is not ok with 
> a REGISTER transaction when gruu and NAT is involved.
> 
> CS
> 
> > -----Ursprüngliche Nachricht-----
> > Von: [email-masked] [mailto:[email-masked]] Im Auftrag von 
> > Jonathan Rosenberg
> > Gesendet: Dienstag, 9. Dezember 2003 13:45
> > An: Christian Stredicke
> > Cc: 'Chris Boulton'; [email-masked]
> > Betreff: Re: AW: [Sip] Updated gruu mechanism spec
> > 
> > 
> > 
> > Christian Stredicke wrote:
> > 
> > > Hi Chris,
> > >
> > > well usually it is a good idea for the UAC to close the TCP
> connection
> > > in order to keep the load on the server low. But in the specific
> case of
> > > obtaining a GRUU (behind NAT) this is not a good 
> practice; therefore
> I
> > > think it fits well into the GRUU draft.
> > 
> > Keeping the connection open to the server is a necessary 
> practice for 
> > SIP to work through nat, independently of whether you are 
> using gruus 
> > or not. As such, I agree with Chris that this kind of 
> behavior belongs 
> > in the tcp bcp document that has been discussed on the list.
> > 
> > -Jonathan R.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Sean Olson" <[email-masked]>
Date: Thu, 11 Dec 2003 08:26:04 -0800

Ditto 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Christian
Jansson
Sent: Thursday, December 11, 2003 7:19 AM
To: Christian Stredicke; Jonathan Rosenberg
Cc: [email-masked]
Subject: RE: [Sip] Updated gruu mechanism spec

> The client usually closes the TCP connection after the transaction or 
> a short timeout.

That is just your assumption on how a client works. In my mind it is usually
better for the client to keep the TCP connection up for much longer.

/ Christian Jansson

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip