Subject: [Sip] PUBLISH-ing through a proxy

From: OKUMURA Shinji <[email-masked]>
Date: Wed, 24 Dec 2003 18:28:43 +0900

Hi folks: 

The only example (section 10) present in draft-ietf-sip-publish-01 
illustrates as: 

       PUA                     PA                    WATCHER 
      (EPA)                   (ESC) 
        |                       |                       | 
        |                       |                       | 
        | ---- M5: PUBLISH ---> |                       | 
        |                       |                       | 
        | <--- M6: 200 OK ----  |                       | 
        |                       |                       | 
        |                       |                       | 
 
where, 

   M5:  PUBLISH sip:[email-masked] SIP/2.0 

Now, if we consider the existence of a proxy between PUA & PA as 
illustrated below, I'm afraid that M5 might be forwarded back to 
PUA (sip:[email-masked]). 

       PUA                          proxy                    PA 
      (sip:[email-masked])    |                       | 
        | ---- M5: PUBLISH ---------> |                       | 
        |                             |                       | 
        | <--- M5': PUBLISH --------- |                       | 

Therefore, I believe that the appropriate Request-URI of M5 in 
this case should be 

sip:presence.example.com 
or
sip:[email-masked] 

It looks also reasonable if we consider that PUBLISH is analogous 
to REGISTER as mentioned in the main draft.

Am I right or missing something? 

Thanks in advance. 
_________________________________________________
OKUMURA Shinji        E-mail:[email-masked]

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Mon, 29 Dec 2003 11:31:08 +0200

Hi,

Inline. 

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
 > OKUMURA Shinji
 > Sent: 24 December, 2003 11:29
 > To: [email-masked]
 > Subject: [Sip] PUBLISH-ing through a proxy
 > 
 > 
 > Hi folks: 
 > 

Actually, there is a bug in sip-publish-01, in that it is still not crystal clear about what should go into the Request-URI, and what should go into the To, and how they are used.

As far as addressing a request is concerned, PUBLISH is analogous to a SUBSCRIBE. The Request-URI indicates the resource that the PUBLISH is targeting. The scenario you describe above can also happen for SUBSCRIBE, if there is no PA configured for the resource in the Request-URI. In fact, when a PA/ESC is located at the UA, this is exactly what should happen, i.e., all PUBLISH and SUBSCRIBE requests are serviced by that UA.

 > Am I right or missing something? 

I put some additional text into "sip-publish-02" that will hopefully be able to clarify this issue, and the relationship between PUBLISH, REGISTER and SUBSCRIBE.

Thanks,
Aki