Subject: RE: [Sip] Query on PRACK

From: [email-masked]
Date: Mon, 1 Dec 2003 10:41:25 +0530

Gokul,
 
PRACK is just like any other non-INVITE transaction and hence does not
require an ACK by UAC.
 
1. UAC sends an INVITE
2. UAS responds with a reliable provisional response
3. UAC sends a PRACK
4. UAS responds to PRACK with a 200 OK
5. UAS sends 200 OK for INVITE
6. UAC sends ACK for the original INVITE transaction
 
Thanks
Kowsalya

-----Original Message-----
From: Gokul Krishnan [mailto:[email-masked]]
Sent: Saturday, November 29, 2003 5:44 PM
To: [email-masked]
Subject: [Sip] Query on PRACK

Hi All,
 
Does PRACK trigger another 2XX response ? If yes, does that mean UAC should
send an ACK? Can any one please provide a message sequence flow?
 
  If a PRACK request is received by the UA core that does not
  match any unacknowledged reliable provisional response, the 
  UAS MUST respond to the PRACK with a 481 response.  If the
  PRACK does match an unacknowledged reliable provisional
  response, it MUST be responded to with a 2xx response.  
  (RFC 3262, Page 5)

Thanks and Regards
Gokul

  _____  

Do you Yahoo!?
Free  <http://us.rd.yahoo.com/slv/mailtag/*http://companion.yahoo.com/>
Pop-Up Blocker - Get it now

---

From: "Tolga Asveren" <[email-masked]>
Date: Mon, 1 Dec 2003 09:18:56 -0500

(due to no response in sip-implementors list switching to sip list)

If a reINVITE with target refresh rejected, should remote target reverted
back to its original value before that reINVITE is received?

  Tolga

---

From: Jonathan Rosenberg <[email-masked]>
Date: Fri, 05 Dec 2003 14:53:55 -0500

In particular, see:

> 8.2 UAS Behavior
> 
>    When a request outside of a dialog is processed by a UAS, there is a
>    set of processing rules that are followed, independent of the method.
>    Section 12 gives guidance on how a UAS can tell whether a request is
>    inside or outside of a dialog.
> 
>    Note that request processing is atomic.  If a request is accepted,
>    all state changes associated with it MUST be performed.  If it is
>    rejected, all state changes MUST NOT be performed.

Thanks,
Jonathan R.

Paul Kyzivat wrote:

> Tolga Asveren wrote:
>> If a reINVITE with target refresh rejected, should remote target 
>> reverted back to its original value before that reINVITE is received?
> 
> 
> Yes, 3261 seems pretty clear on this.
> 
>     Paul
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

-- 
Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
Chief Technology Officer                    Parsippany, NJ 07054-2711
dynamicsoft
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip