Subject: [Sip] Contact header in PUBLISH

From: Cullen Jennings <[email-masked]>
Date: Sat, 06 Dec 2003 09:15:05 -0800

Right now the draft says "The PUBLISH request MUST NOT contain a Contact
header." 

Why? Does it do any harm? The paragraph before this makes if fairly clear
that PUBLISH does create a new Dialog.

The AIB strongly encourages including the Contact header in the sipfrag as
correlating material. Clearly we want to use the AIB with PUBLISH. Don't
know if this really helps the AIB stuff or not.

Anyways, I understand why the Contact header doesn't mean much in a PUBLISH.
I don't understand why such strong MUST NOT language.

Cullen

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Wed, 10 Dec 2003 13:31:45 +0200

You never know what us geniuses might come up with in the future as a possible use for contact-header in PUBLISH. why eliminate this possibility. Including a contact- header in PUBLISH does not break the protocol, so no need to explicitly disallow it. I vote for Aki's original suggestion of using MAY with a slight modification:

	PUBLISH request MAY include a Contact header field, although doing so
	has no meaning in the PUBLISH context **as defined in this specification**.

Regards,
Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf 
> Of ext Aki
> Niemi
> Sent: 09.December.2003 18:49
> To: ext Paul Kyzivat
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Sip] RE: Contact header in PUBLISH
> 
> 
> 
> 
> ext Paul Kyzivat wrote:
> > [email-masked] wrote:
> > 
> >>
> >> PUBLISH is generally never sent in the "other" direction, 
> so I don't 
> >> see any reason not to say:
> >>
> >>     PUBLISH request MAY include a Contact header field, 
> although doing so
> >>     has no meaning in the PUBLISH context.
> >>
> >> Any other opinions?
> > 
> > 
> > How about another phrasing that says the same thing but 
> emphasizes the 
> > desired behavior?
> > 
> >        PUBLISH request SHOULD NOT include a Contact header field.
> >        Including one has no meaning in the PUBLISH context.
> 
> I'm OK with that, although my understanding is that if we use SHOULD 
> NOT, we should be attaching some description of the 
> circumstances where 
> it would be OK to include it.
> 
> Cheers,
> Aki
> 
> > 
> > Paul
> > 
>

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Wed, 10 Dec 2003 11:39:07 -0000

If we identify another usage for this header in the future, then presumably we need to write another RFC to do it superceding the current PUBLISH RFC either fully or in part.

The question we therefore need to ask is whether either text has compatibility problems with such a future extension, and I believe the answer is no.

I therefore prefer Paul's text, as it leaves fewer unanswered questions as to whether I put it in now or not. As regards Hisham's current text, I am left with the question of whether I should put it in just in case.

regards

Keith

> From: [email-masked] [mailto:[email-masked]]
> Sent: 10 December 2003 11:32
> To: [email-masked]; [email-masked]
> Subject: RE: [Sip] RE: Contact header in PUBLISH
> 
> 
> You never know what us geniuses might come up with in the 
> future as a possible use for contact-header in PUBLISH. why 
> eliminate this possibility. Including a contact- header in 
> PUBLISH does not break the protocol, so no need to explicitly 
> disallow it. I vote for Aki's original suggestion of using 
> MAY with a slight modification:
>