Subject: [Sip] RE: Contact header in PUBLISH

From: [email-masked]
Date: Tue, 9 Dec 2003 16:19:31 +0200

Hi Cullen,

Inline.

 > -----Original Message-----
 > From: ext Cullen Jennings [mailto:[email-masked]]
 > Sent: 06 December, 2003 19:15
 > To: [email-masked]
 > Cc: Niemi Aki (NMP/Helsinki)
 > Subject: Contact header in PUBLISH
 > 
 > 
 > 
 > Right now the draft says "The PUBLISH request MUST NOT 
 > contain a Contact
 > header." 
 > 
 > Why? Does it do any harm? The paragraph before this makes if 
 > fairly clear
 > that PUBLISH does create a new Dialog.

(I suspect you meant "does *not* create a dialog"?)

Actually, the language in PUBLISH is pretty much equivalent to what MESSAGE has -- it too says MUST NOT. The only difference is that PUBLISH doesn't talk about sending PUBLISH inside an existing dialog. I actually don't see harm in allowing that also for PUBLISH, although it needs to explain why quite often that may not result to what you usually want to do with PUBLISH.
 
 > The AIB strongly encourages including the Contact header in 
 > the sipfrag as
 > correlating material. Clearly we want to use the AIB with 
 > PUBLISH. Don't
 > know if this really helps the AIB stuff or not.
 > 
 > Anyways, I understand why the Contact header doesn't mean 
 > much in a PUBLISH.
 > I don't understand why such strong MUST NOT language.

I tend to agree. Such strong language makes sense for MESSAGE, in that we don't want UAs sending response IMs to any Contact addresses, thus establishing a dialog of sorts.

PUBLISH is generally never sent in the "other" direction, so I don't see any reason not to say:

	PUBLISH request MAY include a Contact header field, although doing so
	has no meaning in the PUBLISH context.

Any other opinions?

Cheers,
Aki

 > Cullen

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 09 Dec 2003 09:34:33 -0500

> 	has no meaning in the PUBLISH context.

How about another phrasing that says the same thing but emphasizes the 
desired behavior?

        PUBLISH request SHOULD NOT include a Contact header field.
        Including one has no meaning in the PUBLISH context.

Paul

---

From: Cullen Jennings <[email-masked]>
Date: Tue, 09 Dec 2003 08:41:22 -0800

> (I suspect you meant "does *not* create a dialog"?)
Oops - what a bad typo. Yes, I meant "does *not* create"

---

From: Aki Niemi <[email-masked]>
Date: Tue, 09 Dec 2003 18:49:05 +0200

>        Including one has no meaning in the PUBLISH context.

I'm OK with that, although my understanding is that if we use SHOULD 
NOT, we should be attaching some description of the circumstances where 
it would be OK to include it.

Cheers,
Aki