Subject: RE: [Sip] SCTP and TLS

From: Adam Roach <[email-masked]>
Date: Tue, 2 Dec 2003 14:34:06 -0600

Dean Willis [mailto:[email-masked]] writes:

> > However, this leaves the issue of Via headers.
> > 
> > I can say:
> > 
> >   Via: SIP/2.0/SCTP pc33.example.com;branch=z9hG4bK776asdhds
> > 
> > Or:
> > 
> >   Via: SIP/2.0/TLS pc33.example.com;branch=z9hG4bK776asdhds
> > 
> > But there is no standardized syntax that allows me to say
> > both at the same time.
> > 
> 
> Record-in, record out. Use two Via header fields, one for each
> interface. Just like a dual-homed proxy.

I think you're confused. I'm talking about the case in which I'm
sending over a TLS connection that rides on top of SCTP, not
bridging between the two kinds of connections (which would require
only one via header, anyway).

/a

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Dean Willis <[email-masked]>
Date: Thu, 04 Dec 2003 14:33:37 -0600

On Tue, 2003-12-02 at 14:34, Adam Roach wrote:

Adam said:
> Dea nSaid:

ah yes, you're right. However, the bridging case does still have the
reversible-route problem for Path and Service-Route, so double-recording
is still nice to do.

--
Dean