Subject: [Sip] Query on Extensions

From: Gokul Krishnan <[email-masked]>
Date: Mon, 1 Dec 2003 08:43:35 -0800 (PST)

Hi All,
 
What is the difference between "Allow" and "Supported" header from a usage perspective?  

As an example, for PRACK an UAC sends Supported:100rel (RFC 3262) and for UPDATE, the UAC is supposed to send Allow: UPDATE (RFC 3311). 
 
What is the advantage/disadvantage of each approach?
 
Thanks and Regards
Gokul

---------------------------------
Do you Yahoo!?
Free Pop-Up Blocker - Get it now

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 01 Dec 2003 12:49:45 -0500

Gokul Krishnan wrote:
> Hi All,
>  
> What is the difference between "Allow" and "Supported" header *from a 
> usage perspective*?
>  
> As an example, for PRACK an UAC sends Supported:100rel (RFC 3262) and 
> for UPDATE, the UAC is supposed to send Allow: UPDATE (RFC 3311).

"Allow" identifies sip *methods* that the UA supports. "Supported" 
identifies named "packages" that the UA supports. The values are drawn 
from different namespaces.

> What is the advantage/disadvantage of each approach?

They aren't substitutes for one another. A package listed as Supported 
may require the use of certain methods. Those methods should also be 
listed in an Allow header.

An example of this is 100rel. You need to specify both Allow: UPDATE and 
Supported: 100rel to use reliable provisional responses.

	Paul

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Gokul Krishnan <[email-masked]>
Date: Tue, 2 Dec 2003 00:27:45 -0800 (PST)

Thanks for the reply Paul.
 
Suppose I add a new method to SIP, say REMOVEPARTY. Now,
(1) if my UAC want to force this on UAS, is the only way to define a package, say pRem, and use "Require: pRem" ??
(2) if my UAC want just to let know the UAS, should I use "Supported: pRem" ? 
Can I only use "Allow: REMOVEPARTY" in Case2 ?

Paul Kyzivat <[email-masked]> wrote:

Paul