Subject: RE: [Sip] Session timer question

From: "Rosen, Brian" <[email-masked]>
Date: Mon, 1 Dec 2003 09:34:46 -0500

You send 420  - Bad Extension, because you don't understand the
timer option in the Require.  See section 8.2.2.3 in RFC3261.

Brian
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, November 28, 2003 9:13 PM
To: [email-masked]
Subject: [Sip] Session timer question

Hi:
I have a question on session timer message flow.

 If a UA does not support session timer and if it receives 

Require: timer
Session Expires: 3600 

in the 200 OK to re-INVITE what is the correct way to process this response?

Should UAC Ack the 200 OK and then send a bye or ignore the Require and
session Expires: headers and continue with rest of the processing?

Veda

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 01 Dec 2003 10:36:30 -0500

Brian,

The question was about a Require in a 200 response to an invite. The UAC 
clearly can't return a 420 in that case.

I don't think any valid usage of session timer will ever result in this 
case. The only cases where Require: timer is validly put into the 
response are when the request contained Supported: timer.

So this can only result from a broken proxy or UAS. In this case I think 
the UAC is justified in either sending an ACK and then BYE as you 
suggest, or else just ignoring the Required: timer.

	Paul

---

From: "Veda Hegde" <[email-masked]>
Date: Mon, 1 Dec 2003 10:27:24 -0800

Hi:
I don't think it says in the draft that a proxy/UAS can not put Require:
timer in 2xx, if UAC did not include Supported: timer in the request.
May be this should be specified in the draft.
Veda