Subject: [Sip] about call waiting using SUBSCRIBE/NOTIFY!

From: "jack zhao" <[email-masked]>
Date: Tue, 25 Mar 2003 10:12:38 +0800

Dear all,

What I expect is like this:
Assume: There are 2 UAs, A and B.

1. A is busy, (In IP2006, that means both 2 lines has a connection with somebody)
2. B call A and got a 486 BUSY reply.
3. B decide to wait for A. B send a SUBSCRIBE to A and hang up. 
4. After certain period of time, A finally close one of it's connection and has a free
    line. 
5. A send a NOTIFY to B indicate that he is free to accept connection.
6. B receive this NOTIFY and start to ring. B UNSUBSCRIBE the event also.
7. After user pickup B, B send a INVITE to A try to establish a connection.
8. A start ringing when it receive INVITE. From now on, it is the same as the
    regular call out.

If you have got the IETF draft or RFC about call-waiting please tell me or send it to me.

Best Regards,
jack zhao

---

From: Rohan Mahy <[email-masked]>
Date: Wed, 18 Feb 2004 04:32:38 -0800

Hi,

I don't think most folks on the list would describe this feature as 
"call waiting", but a similar feature is described in 
draft-ietf-sipping-dialog-package

thanks,
-rohan