Subject: RE: [Sip] Call transfer using SIP

From: [email-masked]
Date: Thu, 5 Feb 2004 07:35:56 -0000

Maybe the author of "Draft-ietf-sipping-service-examples-05.txt" could
confirm how definitive the message flows regarding call transfer are
therein. (Or point out a preferred document of reference).

-----Original Message-----
From: Conroy, Lawrence (SMTP) [mailto:[email-masked]]
Sent: 04 February 2004 17:23
To: Chris Boulton
Cc: Paul Kyzivat; [email-masked]; [email-masked]
Subject: Re: [Sip] Call transfer using SIP

Hi Chris, folks,
   That's what I said - the SIP/SIPPING groups will not produce normative
teleservice definitions - we're in TSV and a teleservice is in/above 
APPs.

I do sympathise with those folks who want a definition so they can 
interwork
with other vendor's kit in implementing those teleservices.

Short answer is - yup - it would be a good idea, but not by the IETF.

I note in passing that Alan Johnston works for a fine Telecom Service 
Provider
that might be expected to have an interest in the way teleservices are 
implemented
by different vendors.

all the best,
   Lawrence

On 4 Feb 2004, at 4:35 pm, Chris Boulton wrote:

> Lawrence - remember that SIP is a transport protocol which allows an
> objective to be reached in many differing ways.  There is no correct
> behavior in many scenarios as long as they fall between the guidelines
> set out.  It would be wrong to define normative behavior for such
> scenarios and so a push in the right direction towards preferred 
> methods
> is the best approach.
>
> Chris.
>
>
>> -----Original Message-----
>> From: Conroy, Lawrence (SMTP) [mailto:[email-masked]]
>> Sent: 04 February 2004 16:10
>> To: Paul Kyzivat
>> Cc: [email-masked]; [email-masked]
>> Subject: Re: [Sip] Call transfer using SIP
>>
>> Hi folks,
>>   It's an interesting point.
>> Paul's comment seems to be "there are many different ways of skinning 
>> a
>> cat, and the
>> only normative definition is of the knife".
>> The IETF defines the details of knife behaviour, and it's up to
>> everyone else to sort
>> out how to use it for their purpose.
>>
>> My understanding is that the IETF (and the SIP WG in particular) will
>> not produce normative
>> definitions of these (or any other) teleservices, only definitions of
>> protocol elements that
>> might be used for these (or other) purposes.
>> SIPPING will consider such services and decide on the protocol 
>> elements
>> they think are needed
>> (that don't exist already) and then SIP grinds through the details.
>>
>> Thus the only teleservice examples are in the service-examples 
>> document
>> (collected together
>> as a convenience), these are non-normative, and there will never BE
>> normative teleservice
>> definitions produced by these groups. Is this correct?
>>
>> all the best,
>>   Lawrence
>>
>> On 4 Feb 2004, at 3:07 pm, Paul Kyzivat wrote:
>>
>>>
>>>
>>> [email-masked] wrote:
>>>> Could somebody please confirm that if I am writing a call control
>>>> application offering call hold and transfer then the definitive
>>>> document to follow is draft-ietf-sipping-service-examples-05.txt?
>>>
>>> No. The *definitive* document is RFC3261 and related documents. The
>>> details of call control are derivative from that in somewhat the same
>>> way the much of physics is derivative from F=MA.
>>>
>>> Draft-ietf-sipping-service-examples-05.txt is (not surprisingly) an
>>> *example*. It is not normative.
>>>
>>> However, that draft is certainly helpful and educational. You would
> do
>>> well to understand what is in there before completing your task.
>>>
>>> 	Paul
>>>
>>>
>>> _______________________________________________
>>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>>> This list is for NEW development of the core SIP Protocol
>>> Use [email-masked] for questions on current sip
>>> Use [email-masked] for new developments on the application of sip
>>>
>>
>> _______________________________________________
>> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
>> This list is for NEW development of the core SIP Protocol
>> Use [email-masked] for questions on current sip
>> Use [email-masked] for new developments on the application of sip
>
>
> This message has been scanned for viruses by MailControl - 
> www.mailcontrol.com
>
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

-- 
Registered Office: Roke Manor Research Ltd, Siemens House, Oldbury,
Bracknell,
Berkshire. RG12 8FZ

The information contained in this e-mail and any attachments is confidential
to
Roke Manor Research Ltd and must not be passed to any third party without
permission. This communication is for information only and shall not create
or
change any contractual relationship.

For Aculab's privacy policy and E-Mail disclaimer, Click Here :
http://www.aculab.com/company/legal_notice.htm.

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 5 Feb 2004 11:27:54 -0000

Two points:

-	Standardisation of protocol by information flow is not a good idea.

-	The underlying IETF protocol standards (REFER etc) must be complied with, and with creation of a separate set of standards, this may well be bypassed.

regards

Keith

> From: Dean Willis [mailto:[email-masked]]
> Sent: 04 February 2004 19:28
> To: Conroy, Lawrence (SMTP)
> Cc: Chris Boulton; Paul Kyzivat; [email-masked];
> [email-masked]
> Mathew asked:
> and Lawrence said:
> So, I might ask, would it be worth encouraging our friends at 
> SIP Forum 
> to publish some "best practices" in this regard?
> 
> --
> Dean
> 
>