Subject: Re: [Sip] Session timer question

From: Hiroaki Hata <[email-masked]>
Date: Thu, 5 Feb 2004 14:52:16 +0900

Hi
Even if UAC does not support timer and ignores sesssion expires header
in a 2xx response, a session could be refreshed in case that UAC can response
a 2xx to re-INVITE from UAS. If UAC is not able to recongize a difference between
INVITE and re-INVITE and responds 4xx to the request of the refresh, a session
would be terminated. It depends just upon the implementation of UAC, doesn't it?

PS.The table 2 Jonathan mentioned below is the Figure 3 in draft-13 but it is still 
called table 3 in text page20.

Hiro
--
Hiroaki Hata
NTTPC Communications,Inc.
+81-3-5212-2101

> inline.
> 
> Veda Hegde wrote:
> 
> > Keith: Thanks for pointing this out and I will go with this in my
> > implementation.
> > 
> > I think, the 2nd paragraph in "Overview of operation" in the draft
> > should be reworded. It says, 
> > ----------------------------------------------------------------------------
> >  --------- This extension has the property that it works even when
> > only one UA in a dialog supports it. The processing steps differ
> > for handling each of the four cases (UAC supports it, or doesn't,
> > and UAS supports it, or doesn't). 
> > ----------------------------------------------------------------------------
> >  --------
> > 
> > Doesn't this mean even if UAC does not support timer, UAS could
> > support it?
> 
> Yes, and this mode is supported. In such a case, the INVITE from the 
> UAC would lack a Supported header field. Proxies insert 
> Session-Expires headers. The UAS receives it. Based on table 2 in the 
> session timer spec, since the UAS supports the extension, it sets the 
> refresher parameter to "uas", and generates a 2xx with the final 
> session timer in the session expires header. This header is ignored by 
> the UAC. The called party will generate refresh requests for the 
> remainder of the call.
> 
> Note that there is no Require in the 2xx in this case.
> 
> -Jonathan R.
> 
> 
> -- 
> Jonathan D. Rosenberg, Ph.D.                600 Lanidex Plaza
> Chief Technology Officer                    Parsippany, NJ 07054-2711
> dynamicsoft
> [email-masked]                     FAX:   (973) 952-5050
> http://www.jdrosen.net                      PHONE: (973) 952-5000
> http://www.dynamicsoft.com
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 05 Feb 2004 02:48:24 -0500

> would be terminated. It depends just upon the implementation of UAC, doesn't it?

Why would the caller reject the re-INVITE?

> called table 3 in text page20.

Thanks for pointing this out.

-Jonathan R.

---

From: Hiroaki Hata <[email-masked]>
Date: Mon, 9 Feb 2004 12:10:07 +0900

Jonathan
I thought that a response to re-INVITE was a part of spec of session timer.
That is independent on session timer specification. I understood the reason
why the session timer works even if a peer doesn't support it.
--
Hiro

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 10 Feb 2004 15:35:06 -0500

> I thought that a response to re-INVITE was a part of spec of session timer.

re-INVITEs are part of rfc3261. Thus, an rfc3261 compliant UA will 
respond to a reinvite, and it shouldn't reject it for no reason.

-Jonathan R.