Subject: [Sip] Updated History-Info draft submitted

From: "Mary Barnes" <[email-masked]>
Date: Sun, 15 Feb 2004 12:27:24 -0600

I have submitted an updated version of the History-Info draft.  Until it
becomes available in the respository, you can pick it up at:
http://home.comcast.net/~mary.barnes/IETF/draft-ietf-sip-history-info-02.txt

The primary changes are as follows:
o Merged the SIPPING WG requirements draft into this document. 
   Also, removed redirect server from ISSUER-req since the 
   solution identified this as not being required (or desirable).
  
o Added an explicit privacy requirement (PRIV-req-3) for the 
  proxy's role in recognizing and maintaining privacy associated 
  with a Request-URI being captured in History-Info due to local 
  policy. (Note, that the text was already there, it just wasn't 
  highlighted as an explicit requirement).  

o Removed the compact form for the header since unknown headers 
  with multiple entries would not be recognized.

o Added a summary of Application Considerations to address 
  concerns about the optional usage of History-Info. 

There are 2 open issues identified in the draft:
o Issue 1 is around the privacy issue that has been discussed 
  recently on the list:
http://www.ietf.org/mail-archive/working-groups/sip/current/msg09401.html
http://www.ietf.org/mail-archive/working-groups/sip/current/msg09371.html

  It has been suggested that adding an additional field to the 
  History-Info header (or extending the priv-values defined in 
  RFC 3323) would facilitate the implementation of a local privacy 
  policy associated with specific Request-URIs. 

o Issue 2 is around whether there needs to be some bounds on the size 
  or number of History-Info entries.  And if so, what's the mechanism
  for defining the bounds (e.g. limit the depth and breadth of the 
  tree by putting upper limits on the Index? )  

Regards,
Mary H. Barnes
[email-masked]
972-684-5432

---

From: "Aders, David I" <[email-masked]>
Date: Mon, 16 Feb 2004 09:51:21 +1100

Will interworking with and maintaining ISUP diversion information when making a PSTN to SIP call be part of the scope of any future work for the history-info draft?

-----Original Message-----
From: Mary Barnes [mailto:[email-masked]]
Sent: Monday, 16 February 2004 5:27 AM
To: [email-masked]'
Subject: [Sip] Updated History-Info draft submitted

I have submitted an updated version of the History-Info draft.  Until it becomes available in the respository, you can pick it up at:

  

Regards, 
Mary H. Barnes

---

From: "Mary Barnes" <[email-masked]>
Date: Mon, 16 Feb 2004 08:51:53 -0600

No, this draft will not address ISUP interworking.  The draft provides some
example applications in order to highlight how the History-Info header could
be used, but there's nothing normative about any of those examples.   John
Elwell had put out a draft on how to do diversion for QSIG interworking,
which does make use of History-Info that you might find useful (note the
draft itself has expired and I'll let John address how or whether he plans
to progress that; my understanding is that this work is being done in ECMA).
So, I would think the functionality you're describing might be something the
ITU or another SDO would want to define.  

Regards,
Mary.

-----Original Message-----
From: Aders, David I [mailto:[email-masked]]
Sent: Sunday, February 15, 2004 4:51 PM
To: [email-masked]
Subject: RE: [Sip] Updated History-Info draft submitted

Will interworking with and maintaining ISUP diversion information when
making a PSTN to SIP call be part of the scope of any future work for the
history-info draft?