Subject: [Sip] SIP for controlling user to website interactions via http

From: "Khare, Anir" <[email-masked]>
Date: Sun, 8 Feb 2004 12:15:16 +1100

I have a general query:

Stateless HTTP protocol is currently used beyond its original purpose i.e. ad-hoc access of information on web without any access-control restrictions etc. Variety of techniques are used like cookies, http redirects for mimicking user session with web site as well as for identity management and SSO (Liberty).

SIP seems to be a fit for streamlining majority of these issues around user-web site http interactions. i.e. a scenario could be described as: user opens a SIP session with web site, negotiates preferences etc. using SDP. Then the session between user-website can consist of http, RTP and other streaming protocols as necessary.  SIP can be mediated by the service provider/telcos (similar to telcos providing SIP based signalling infrastructure for establishment of VoIP/MoIP services)  for establishing trust relationships between the user and the web-site, for charging  as well as for providing QoS for the transport of traffic in the SIP session (using appropriate QoS signalling).

Is SIP directly or indirectly used in this space? If not, was it considered before and rejected? If rejected, what were the issues?

Is there any other session control protocol under development for this space? When Http used for SOAP in web services interactions, does the notion of session gets formalised via any of the related web services protocols? 

Regards,
Anir Khare
Telstra Research Labs, Australia
+61-3-6323 2659

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Scott Lawrence <[email-masked]>
Date: Tue, 10 Feb 2004 00:51:57 -0500

> SIP seems to be a fit for streamlining majority of these issues around user-web site http interactions. i.e. a scenario could be described as: user opens a SIP session with web site, negotiates pre…

SIP is no more suited to providing a session for those purposes than
HTTP already is.

-- 
Scott Lawrence        
  Pingtel Corp.