Subject: [Sip] Call transfer using SIP

From: [email-masked]
Date: Wed, 4 Feb 2004 10:04:49 -0000

Could somebody please confirm that if I am writing a call control
application offering call hold and transfer then the definitive document to
follow is draft-ietf-sipping-service-examples-05.txt?

Matthew Gardiner
Software Engineer
Aculab 
Tel: +44 (0) 1908 273 911
Fax: +44 (0) 1908 273 801
Email: mailto:[email-masked]
Website: <http://www.aculab.com>

For Aculab's privacy policy and E-Mail disclaimer, Click Here :
http://www.aculab.com/company/legal_notice.htm.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 04 Feb 2004 10:07:14 -0500

[email-masked] wrote:
> application offering call hold and transfer then the definitive document 
> to follow is draft-ietf-sipping-service-examples-05.txt?

No. The *definitive* document is RFC3261 and related documents. The 
details of call control are derivative from that in somewhat the same 
way the much of physics is derivative from F=MA.

Draft-ietf-sipping-service-examples-05.txt is (not surprisingly) an 
*example*. It is not normative.

However, that draft is certainly helpful and educational. You would do 
well to understand what is in there before completing your task.

	Paul

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Conroy, Lawrence (SMTP)" <[email-masked]>
Date: Wed, 4 Feb 2004 16:09:52 +0000

Hi folks,
   It's an interesting point.
Paul's comment seems to be "there are many different ways of skinning a 
cat, and the
only normative definition is of the knife".
The IETF defines the details of knife behaviour, and it's up to 
everyone else to sort
out how to use it for their purpose.

My understanding is that the IETF (and the SIP WG in particular) will 
not produce normative
definitions of these (or any other) teleservices, only definitions of 
protocol elements that
might be used for these (or other) purposes.
SIPPING will consider such services and decide on the protocol elements 
they think are needed
(that don't exist already) and then SIP grinds through the details.

Thus the only teleservice examples are in the service-examples document 
(collected together
as a convenience), these are non-normative, and there will never BE 
normative teleservice
definitions produced by these groups. Is this correct?

all the best,
   Lawrence

On 4 Feb 2004, at 3:07 pm, Paul Kyzivat wrote:

>> application offering call hold and transfer then the definitive 
>> document to follow is draft-ietf-sipping-service-examples-05.txt?
>