Subject: RE: [Sip] Question on offer-answer during establishment

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Tue, 28 Sep 2004 15:55:54 +0200

Hi,

>RFC3261 states (13.2.1, second bullet):
> 
>"The UAC MUST treat the first session description it receives 
>as the answer, and MUST ignore any session descriptions in subsequent 
>responses to the initial INVITE."
> 
>Suppose SDP answer is received in a reliable provisional 
>response. This would complete the offer-answer sequence.

Correct.

>The behaviour mandated here would seem to preclude the UAS sending a further offer in a 
>subsequent reliable provisional response or 2xx.

Exactly.

>Is this intended, and if so for what reason?

There has been discussions about this before, but I guess to put it short the answer is that you can only have at-most (sometimes you only send a single offer, or answer, within one transaction, but never more than one complete offer/answer exchange) one offer/answer exchange per SIP transaction.

>Obviously the UAS can send an UPDATE request (or re-INVITE 
>request after answer) if it wishes to re-negotiate the session,

Correct, but that is within a separate SIP transaction.

>but this would involve additional messages.

C'est la vie.

Please also note, that you are only allowed to send SDP (offer or answer) in the FIRST PRACK, so even if you would send new offers in provisional responses you would still have to use a non-PRACK mechanism to send the answers.

Sending SDPs in PRACK then causes other problems, ie how you would reject those, but that's another issue...

Regards,

Christer Holmberg
Ericsson Finland

> 
> John Elwell ([email-masked])
> 
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Michael Zhou <[email-masked]>
Date: Tue, 28 Sep 2004 10:11:17 -0400

Christer,

Can you point me to the RFC(s) (probably in 3262?) that says a UA is 
only allowed to send SDP in the first PRACK? Thanks

Michael

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 28 Sep 2004 11:07:43 -0400

Christer,

I have to quibble with the above.

If the INVITE is offerless, then an offer must be present in the first 
reliable response. If that is a reliable 1xx, then the 1xx must be 
answered with a PRACK, and that prack must contain the answer. So in 
that case the answer would be in the first PRACK.

I believe that is the *only* case in which an answer can be in a PRACK, 
and that there are *no* cases where an offer can be in a prack.

	Paul