Subject: Re: [Sip] Contact: headers in SIP REGISTER 200 OK responses

From: Rayees Khan <[email-masked]>
Date: Tue, 21 Sep 2004 00:31:12 -0700 (PDT)

I think that the REGISTER messages from both the UAs would be taken by registrar to be from same UA. As a result the second REGISTER would be taken as re-REGISTER. Now the validity of the contacts in the two would depend on the expires parameter in the contact header. 
These contacts can be overlapping too. 
In any case the response to the REGISTER message would be sent to the Via address mentioned in the REGISTER rathar than the address specified in contact.

regards
Rayees

"Gerke, Tom" <[email-masked]> wrote:
Hello,

If two different UAs (in the same domain) happen to register a user using the same AOR (but different Contact addresses), to the same Registrar, what would be in their respective REGISTER 200 OK responses from that Registrar?   i.e. Would they be notified of each others’ bindings?  

Section 10.3, step 8, of the SIP spec states that the 200 OK response will contain “all current bindings”.  It doesn’t mention anything about the Call-IDs for those bindings having to match up or anything.

So, let’s say:

First, UA 1 decides to register AOR sip:[email-masked] with the Contact address sip:[email-masked] to a Registrar.

Then sometime later UA 2 decides to register AOR sip:[email-masked] with the Contact address sip:[email-masked]:5070 to that same Registrar.

Assuming both of these UAs used unique Call-IDs, and there were no authorization issues, what Contact: headers would be in the REGISTER 200 OK response message from this Registrar:

1) When UA 2 received its initial REGISTER response?

2) Sometime later when UA 1 then refreshes its binding for AOR sip:[email-masked]?

Thanks in advance for any clarification on this matter,

-Tom

_______________________________________________
Sip mailing list https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 28 Sep 2004 11:22:50 -0400

Rayees Khan wrote:
>  
> I think that the REGISTER messages from both the UAs would be taken by 
> registrar to be from same UA.

I disagree. It seems pretty clearcut that these are independent and that 
the registrar should accept them both. This is exactly how you get 
multiple contacts associated with an AOR.

More below.

 > As a result the second REGISTER would be
> taken as re-REGISTER. Now the validity of the contacts in the two would 
> depend on the expires parameter in the contact header.
> In any case the response to the REGISTER message would be sent to the 
> Via address mentioned in the REGISTER rathar than the address specified 
> in contact.
>  
>  
> regards
> Rayees
>  
> 
> 
> */"Gerke, Tom" <[email-masked]>/* wrote:
> 
>     Hello,
> 
>      
> 
>     If two different UAs (in the same domain) happen to register a user
>     using the same AOR (but different Contact addresses), to the same
>     Registrar, what would be in their respective REGISTER 200 OK
>     responses from that Registrar?   i.e. Would they be notified of each
>     others’ bindings? 
> 
>     Section 10.3, step 8, of the SIP spec states that the 200 OK
>     response will contain “all current bindings”.  It doesn’t mention
>     anything about the Call-IDs for those bindings having to match up or
>     anything.
> 
>      
> 
>     So, let’s say:
> 
>     First, UA 1 decides to register AOR sip:[email-masked]
>     <mailto:[email-masked]>

I don't understand the <mailto...> in the above. You have two URLs, and 
the mailto seems entirely inappropriate. I'm assuming it isn't there.

The presence of this suggests that you have some kind of 
misunderstanding, but I can't tell what it is.

 >     with the Contact address
>     sip:[email-masked] to a Registrar.
> 
>     Then sometime later UA 2 decides to register AOR
>     sip:[email-masked] <mailto:[email-masked]> with the Contact

again ignoring <mailto...>

>     address sip:[email-masked]:5070 to that same Registrar.
> 
>      
> 
>     Assuming both of these UAs used unique Call-IDs, and there were no
>     authorization issues, what Contact: headers would be in the REGISTER
>     200 OK response message from this Registrar:
> 

It would see both registered contacts. Each should show the remaining 
time till expiration in the expires parameter.

>     2) Sometime later when UA 1 then refreshes its binding for AOR
>     sip:[email-masked] <mailto:[email-masked]>?

Assuming the contact from UA2 hasn't expired, there should again be two 
contacts, as above. If the contact from UA2 had expired without refresh, 
then only the refreshed contact would be seen.

> ------------------------------------------------------------------------
>