Subject: RE: [Sip] PING/PONG

From: "Steve Langstaff" <[email-masked]>
Date: Wed, 17 Nov 2004 16:58:11 -0000

Should point 2 read "The user agent server indicates if it can respond to client refresh requests"?

--
Steve Langstaff.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Jonathan Rosenberg
Sent: 17 November 2004 16:40
To: Christian Stredicke
Cc: [email-masked]
Subject: Re: [Sip] PING/PONG

Christian Stredicke wrote:

> So my understanding is:
> 
> 1. We should use *only* STUN for refreshing bindings (either UDP or TCP,
> what about TLS)

Yes, TLS too. TLS runs ontop of TCP after all.

> 
> 2. The user agent indicates if it can do it (no negotiation on
> capabilities)
> 
> 3. Refreshing must be done from the client
> 
> Can we agree on that?

Yes.

Server originating refreshing is in the wrong direction. It is the 
client utilizing the service; if it wishes to make use of that service, 
it has to be responsible for refreshing the connection.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 17 Nov 2004 23:46:03 -0500

There isn't a UAS involved here; these requests go from the client (UAC) 
to its proxy.

How the proxy indicates to the UAC that it is capable of processing 
these keepalives is a good question. My first thought is that this would 
be something in DNS; a new service in the NAPTR record for indicating 
the sip+stun combination.

-Jonathan R.