Subject: [Sip] Please Help

From: [email-masked]
Date: Wed, 24 Nov 2004 10:06:49 +0530

Hi,
 
let me know if a following scenario is correct.
 
Caller-A        Proxy-A      Proxy-B     Callee-B1          Callee-B2
       --INVITE-->
                      --INVITE-->
                                   --INVITE-->
                                                       (1)
                                              <--180 with To-tag1
                            <--180 with To-tag1
    <--180 with To-tag1
                                                       (2)
                                              <--302 with Contact :
Callee-B2
                                                 -----INVITE------->
             
                                        (3)
                              <--180 with To-tag2------------------- 
      <--180 with To-tag2
 
(1) Callee-B1's phone is ringing.
(2) Callee-B1 decides to forward this call to Callee-B2 without
accepting call. and send a 302 response with a Contact: Callee-B2
(3) Callee-B2's phone is ringing.
 
As you see, at the above flow, Proxy-A and Caller-A receive two 180
responses with a different To-tag.  Caller-A created a early-dialog when
it received the first 180 response and then, it received the second 180
response with a difference To-tag from the first one. at that case, what
happens? should a early-dialog be updated with new To-tag?  or can't
Callee-B1 send a 302 response after sending a 180 response?
 
Regards

Gautam Chaudhry

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Nataraju A B" <[email-masked]>
Date: Wed, 24 Nov 2004 12:01:51 +0530

Best Regards,
Nataraju A.B.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, November 24, 2004 10:07 AM
To: [email-masked]
Subject: [Sip] Please Help
 
Hi,

             
                                        (3)

 
 [ABN] if callee-B1 is retrying on 302 then 302 must not be sent to the
caller. Only the response for the retried invite will be sent to caller.
Caller must be prepared to receive responses with diff to-tags which
lead to multiple early dialogs as part of the session. Then its SIP
application logic to retain one of the confirmed dialogs. This is one of
the major change from 2543 to 3261 implementation.

Regards
Gautam Chaudhry