Subject: RE: [Sip] RFC 3261: BUG or clarification is needed

From: "Orit Levin" <[email-masked]>
Date: Wed, 17 Nov 2004 15:29:08 -0800

Paul,
Thanks!
As long as it is accepted by everyone - it definitely works for me.
More inline.

Orit.

> -----Original Message-----
> From: Paul Kyzivat [mailto:[email-masked]] 
> Sent: Wednesday, November 17, 2004 2:49 PM
> To: Orit Levin
> Cc: [email-masked]
> Subject: Re: [Sip] RFC 3261: BUG or clarification is needed
> 
> 
> 
> Orit Levin wrote:
> > Guys,
> > I would like to get a clarification on the properties of 
> the Contact 
> > header in requests and responses different from REGISTER.
> > Is there a common understanding, that a Contact header can 
> contain any 
> > valid SIP URI that, especially when used outside the 
> original dialog, 
> > needs to be resolved according to RFC 3263 (i.e. including 
> the SRV lookup) ?
> 
> Yes.
Great.
> 
> > I couldn't find any statement along these lines in any of 
> the relevant RFCs.
> 
> Why would any special statement be required? The address in 
> the contact gets included in some message, and then the rules 
> for how to resolve it are spelled out. It doesn't matter 
> where it came from.
Because I am not sure at all that many implementations actually do it
today and we need to encourage them to do so.
> 
> > For example, in Redirect requests, we are reusing the 
> Contact header 
> > in order to point to an alternative destination which can 
> have nothing 
> > in common with the original domain.
> 
> BTW, in some contexts (such as 3xx) the contact addresses 
> need not even be ones used by sip. You are allowed to 
> redirect to an http uri if you like.
Yes, I know :-)
> 
> > Yet another example, the current GRUU draft is silent about the 
> > ability of resolving GRUU using RFC 3263 procedures. >From 
> the draft:
> > "the GRUU MUST exhibit the following properties:
> > 
> >    o  The domain part of the URI is an IP address present on the 
> > public
> > 
> >       Internet, or, if it is a host name, exists in the 
> global DNS and
> > 
> >       corresponds to an IP address present on the public Internet."
> >  
> >  
> > For the interoperability sake, I believe that it is very 
> important to 
> > file this clarification against RFC 3261 and also point to RFC 3263 
> > for GRUU properties/location procedures.
> 
> I think this requirement is implicit.
Yes, most probably, but since this case is left out from the section
above - the reader can be mislead by the current text.
> 
> 	Paul
> 
> > Thanks,
> > Orit.
> > 
> > 
> > 
> ----------------------------------------------------------------------
> > --
> > 
> > _______________________________________________
> > Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> > This list is for NEW development of the core SIP Protocol Use 
> > [email-masked] for questions on current sip Use 
> > [email-masked] for new developments on the application of sip
> 
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Thu, 18 Nov 2004 00:31:01 -0500

I agree with Paul here.

-Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com