Subject: RE: [Sip] GRUU Comments and interaction with outbound-connection

From: [email-masked]
Date: Tue, 9 Nov 2004 15:24:29 +0200

That's exactly what I was thinking. The Proxy/registrar can add the actual contact of the recipient as the first entry in the target set. That gets placed in the request-URI. Proxy routes to first route header (EP) in this case. EP routes to end point.

/Hisham

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On 
> Behalf Of ext
> Alan Hawrylyshen
> Sent: 09.November.2004 00:18
> To: Jonathan Rosenberg
> Cc: Cullen Jennings; [email-masked]
> Subject: [Sip] GRUU Comments and interaction with outbound-connection
> 
> 
> Re: the Edge Proxy, Reg/Prox RR problems....
> 
> Johnathan;
> 
> It strikes me that the EP can directly route the GRUU since it is 
> (except in the 3GPP case) in the same administrative / security / 
> policy domain as the registrar and SHOULD be capable of detecting the 
> GRUU's applicability when the initial request hits the EP.  An 
> appropriately constructed (encoded) GRUU could be decoded and dealt 
> with as soon as it reaches the UA's EP, no?
> 
> And as I write this, Cullen has just proposed the same thing.
> 
> Alan
> 
> 
> 
> a l a n a t j a s o m i d o t c o m
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Alan Hawrylyshen <[email-masked]>
Date: Tue, 9 Nov 2004 16:52:20 -0500

On Nov 9, 2004, at 08:24, [email-masked] wrote:

> That's exactly what I was thinking. The Proxy/registrar can add the 
> actual contact of the recipient as the first entry in the target set. 
> That gets placed in the request-URI. Proxy routes to first route 
> header (EP) in this case. EP routes to end point.
>
> /Hisham

Johnathan pointed out (verbally to myself when I mentioned this) that 
there are problems with the EP routing the request instead of sending 
it back to the 'registrar /  proxy' that affect separation of services 
and that having the EP route to the endpoint directly breaks one of the 
reasons that you would want to separate the EP role and registrar role 
in the first place.  I have to admit that due to room noise and having 
not written it down at that moment; I no longer recall specifics, but 
it strikes me as plausible and I would request that Johnathan add some 
text to this thread to help raise awareness of what breaks when the EP 
forwards the request directly to the end UA instead of spiralling.

Thanks
Alan