Subject: Re: [Sip] Update to draft-ietf-sip-resource-priority section 4.2

From: Janet P Gunn <[email-masked]>
Date: Wed, 1 Jun 2005 14:35:11 -0400

Henning,

In fixing section 4.2 (by removing the former step 1 about ignoring the RPH
if there is no congestion), you have gone slightly too far the other way.

The way step 3 reads now, it sounds as if you "preempt or queue" every
time, even when there is no congestion.

Perhaps you could reword 3 as "If the request is authorized, and the
resources are available (no congestion), serve as usual.  If the request is
authorized, but resources are not available (congestion), either premept
other current sessions, or insert the request into a priority queue, as
described in 4.5."

Janet

----------------------------------------------------------------------------------------

This is a PRIVATE message. If you are not the intended recipient, please
delete without copying and kindly advise us by e-mail of the mistake in
delivery. NOTE: Regardless of content, this e-mail shall not operate to
bind CSC to any order or other contract unless pursuant to explicit written
agreement or government initiative expressly permitting the use of e-mail
for such purpose.
----------------------------------------------------------------------------------------

                      Henning                                                                                    
                      Schulzrinne <hgs         To:      [email-masked]                                             
                      @cs.columbia.edu         cc:                                                               
                      >                        Subject: [Sip] Update to draft-ietf-sip-resource-priority         
                      Sent by:                                                                                   
                      sip-bounces                                                                                

                      05/31/2005 06:36                                                                           
                      PM                                                                                         

http://www.ietf.org/internet-drafts/draft-ietf-sip-resource-priority-09.txt

addresses the working group and IETF last-call comments, at least where
the authors and the commenter were in agreement (see the flood of
messages from the weekend). Hopefully, this update can speed up the
resolution of any remaining issues by avoiding discussion of items that
have been resolved already.

I would appreciate if astute readers could alert me to any omissions or
misunderstandings of comments offered.

Henning

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Henning Schulzrinne <[email-masked]>
Date: Wed, 01 Jun 2005 21:07:15 -0400

> other current sessions, or insert the request into a priority queue, as

Good point; I'll change the wording.