Subject: [Sip] RE: Timer G for reliable responses

From: "Sun Xian Peng, SLC COM CD/MN R&D SE (BJ)" <[email-masked]>
Date: Wed, 22 Jun 2005 10:13:31 +0800

Hi Rajeev,
 All the timers relevant to retransmition, I think, is valid in UDP transport only.
 So not only Timer G, but also Timer I,J,K..., are only set to non-zero in UDP.
 E.g. when using reliable transports, retransmitted ACK packets will be absorbed by TCP layer ,but not by SIP transactions.

Rgds
Sun Xianpeng

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 22 Jun 2005 01:10:38 -0400

Not all timers. The timers for retransmitting of the 200 OK to INVITE 
are still applicable for tcp, as they are end-to-end.

The text in section 17 is normative on these timers. The table in the 
appendix is inconsistent in that it mentions the exception for TCP only 
for some of them. That is an error, and I'll log a bug against it.

-Jonathan R.

Sun Xian Peng, SLC COM CD/MN R&D SE (BJ) wrote:

> Hi Rajeev, All the timers relevant to retransmition, I think, is
> valid in UDP transport only. So not only Timer G, but also Timer
> I,J,K..., are only set to non-zero in UDP. E.g. when using reliable
> transports, retransmitted ACK packets will be absorbed by TCP layer
> ,but not by SIP transactions.
> 
> Rgds Sun Xianpeng
> 
> _______________________________________________ Sip mailing list
> https://www1.ietf.org/mailman/listinfo/sip This list is for NEW
> development of the core SIP Protocol Use
> [email-masked] for questions on current sip Use
> [email-masked] for new developments on the application of sip
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com