Subject: RE: [Sip] querry about 481

From: Chadha Retesh-A19894 <[email-masked]>
Date: Mon, 13 Jun 2005 16:39:46 +0530

Yes, if the SUBSCRIBE/INVITE contains a to tag, not matching any dialog.

Rgds
Retesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ayan
Sent: Monday, June 13, 2005 3:59 PM
To: [email-masked]
Subject: [Sip] querry about 481

Hi,

Is it possible to receive a 481, Call Leg/transaction Does Not Exist, for a
dialog initiating request? For egs. can we get a 481, for a first SUBSCRIBE
which initiates a new dialog?

Thnx in advnce.
/ayan

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Manish Joshi <[email-masked]>
Date: Mon, 13 Jun 2005 10:45:19 -0700 (PDT)

Since it is a new Dialog creation request, there is no question of it matching any dialog. So ideally you should not get 481 for a new SUBSCRIBE initiated with a brand new call id and
from tag. You can get this response usually for (RE)SUBSCRIBE or NOTIFY.
 
Regards,
Manish

Chadha Retesh-A19894 <[email-masked]> wrote:
Yes, if the SUBSCRIBE/INVITE contains a to tag, not matching any dialog.

Rgds
Retesh

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ayan
Sent: Monday, June 13, 2005 3:59 PM
To: [email-masked]
Subject: [Sip] querry about 481

Hi,

Thnx in advnce.
/ayan

---------------------------------
Discover Yahoo!
 Get on-the-go sports scores, stock quotes, news & more. Check it out!

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 13 Jun 2005 22:05:38 -0400

Yes, you should never see a 481 for an initial request.

However, in the interests of being strict on what you send and liberal 
on what you receive, I would advise against an implementation getting 
particularly upset at the receipt of a 481 to a dialog-initiating 
request; it should be treated as any other 4xx response in such a case.

-Jonathan R.

Manish Joshi wrote:

> Since it is a new Dialog creation request, there is no question of it 
> matching any dialog. So ideally you should not get 481 for a new 
> SUBSCRIBE initiated with a brand new call id and
> */Chadha Retesh-A19894 <[email-masked]>/* wrote:
> 
> ------------------------------------------------------------------------
> Discover Yahoo!
> <http://us.rd.yahoo.com/evt=32661/*http://discover.yahoo.com/mobile.html>
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com