Subject: RE: [Sip] The logic behind the From tag?

From: "Cunningham, Stuart, VF-Group" <[email-masked]>
Date: Tue, 14 Jun 2005 10:08:45 +0200

Hi Frank,

The From Tag is used for routing purposes. The From TAG is the sip
address after it uses the via or route.  

Br,
Stuart 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Frank Derks
Sent: Dienstag, 14. Juni 2005 10:02
To: [email-masked]
Subject: [Sip] The logic behind the From tag?

RFC 3261 specifies that a dialog is identified by a local tag, a remote
tag and a call identifier, each of which should be "globally unique".
The sender of an INVITE adds both the Call-ID and the local tag. The
recipients of that INVITE each add their own remote tag (the To tag) to
their responses. 

It is clear that the remote tag is necessary to be able to distinguish
the responses from the different recipients. However, there is no
obvious need 

for the From tag: the INVITE already contains a unique Call-ID. 

So why is the From tag needed?

Cheers,

Frank

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol Use
[email-masked] for questions on current sip Use
[email-masked] for new developments on the application of sip

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Frank Derks <[email-masked]>
Date: Tue, 14 Jun 2005 11:02:39 +0200

Hi Stuart,

I don't quite see how this would work. The Via header is there to route 
a response and the Route header is there to route a request, in both 
cases based on their own contents and not based on the contents of the 
>From and To headers respectively. 

Could you elaborate on what you have in mind?

Cheers,

Frank

"Cunningham, Stuart, VF-Group" 
2005-06-14 10:08 AM

To
Frank Derks/HVS/BE/PHILIPS@PHILIPS
<[email-masked]>
cc

Subject
RE: [Sip] The logic behind the From tag?
Classification

Hi Frank,

Br,
Stuart 

-----Original Message-----

Cheers,

Frank