Subject: RE: [Sip] WGLC for draft-ietf-sip-target-dialog-01.txt

From: Elwell John <[email-masked]>
Date: Sat, 23 Jul 2005 15:35:10 +0100

Jonathan,

Minor comments:

1. Section 3, item 2, "The user agent client believes that the request will
not be authorized by the user agent server unless the user agent client can
prove that it is aware of the dialog identifiers for some other dialog.
Call this dialog the target dialog."

Should we change "will not" to "might not"? Even if the UAC does not know
for certain, use of target-dialog should be applicable.

2. Section 3, examples of use cases in which conditions are not met. There
seems to be a cut-and-paste error in the second bullet - the dialog package
does not show key presses.

3. Typo "speific" after last bullet.

4. Section 4, penultimate paragraph: "and thus the authorization strength is
reduced to MAY". It is the strength of the requirement for authorization,
not the authorization strength, that is reduced. I would propose to say
instead "and thus authorization is optional".

John

> -----Original Message-----
> From: Rohan Mahy [mailto:[email-masked]] 
> Sent: 22 July 2005 22:48
> To: SIP WG
> Cc: Rohan Mahy; Dean Willis
> Subject: [Sip] WGLC for draft-ietf-sip-target-dialog-01.txt
> 
> Hi Folks,
> 
> I'd like to begin an abbreviated WGLC for 
> draft-ietf-sip-target-dialog-01.txt.  This WGLC will end on August 
> 15th.
> 
> thanks,
> -rohan
> Rohan Mahy
> co-chair SIP WG
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 31 Jul 2005 09:52:19 -0400

Thanks for the comments, John. Responses inline.

> for certain, use of target-dialog should be applicable.

OK, changed.

> does not show key presses.

oops, fixed.

> 3. Typo "speific" after last bullet.

fixed.

> instead "and thus authorization is optional".

fixed.

Thanks,
Jonathan R.

-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Director, Service Provider VoIP Architecture   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com