Subject: Re: [Sip] comment on draft-ietf-sip-sctp-06.txt

From: Rohan Mahy <[email-masked]>
Date: Sun, 3 Jul 2005 08:58:45 -0700

Juha,

It is there for backwards compatibility with implementations that sent
it in the past.

thanks,
-rohan

On 6/26/05, Juha Heinanen <[email-masked]> wrote:
> draft-ietf-sip-sctp-06.txt has a note:
> 
> Note that the value "tls", defined by RFC 3261, is intended for TLS over
> TCP.
> 
> on the other hand 26.2.2 of rfc3261 has a note:
> 
> The use of transport=tls has consequently been deprecated, partly
> because it was specific to a single hop of the request.
> 
> so if a transport parameter indicating tls over tcp has been deprecated,
> why do we now need a transport parameter indicating tls over sctp?  what
> makes sctp in this regards special as compared to tcp?
> 
> -- juha
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Juha Heinanen <[email-masked]>
Date: Sun, 3 Jul 2005 20:44:41 +0300

> It is there for backwards compatibility with implementations that sent

what is for backwards compatibility?  indication of tls over tcp has
been deprecated and now people are proposing indication of tls over
sctp.  why is the latter now needed if the former is not anymore needed?
makes no sense to me.

if uri scheme is sips, then transport=tcp and transport=sctp are enough,
because sips requires tls.  on the other hand, if uri scheme is sip AND
sip entity wants to specify that tls is used anyhow, then we need some
other transport parameter to tell if tls is to be implemented over tcp or
sctp.

i suggest that draft-ietf-sip-sctp-06.txt is changed to cover BOTH tcp
and sctp case.  in case of tls/tcp, the parameter could be tls-tcp and
in case of tls/sctp, the parameter could be tls-sctp.

-- juha

---

From: Gonzalo Camarillo <[email-masked]>
Date: Tue, 19 Jul 2005 20:28:50 +0300

Hi Juha,

this is a good point. My suggestion is that we remove the transport 
value for TLS over SCTP from the draft in AUTH48.

Thanks for the comment,

Gonzalo

Dean Willis wrote:
> On Jun 26, 2005, at 11:31 AM, Juha Heinanen wrote:
> 
> I wish I knew.
> I'd like to ask Jon Peterson to comment, as I think he contributed that 
> line of deprecation to 3261. Then again, it was debated during a 
> conference call at 3:00 AM as I was attending a 3GPP meeting in Sophia 
> Antipolis, so I might remember wrong.
> 
> But in any case, it's a good question.
> 
> -- 
> Dean
> 
> 

-- 
Gonzalo Camarillo         Phone :  +358  9 299 33 71
Oy L M Ericsson Ab        Mobile:  +358 40 702 35 35
Telecom R&D               Fax   :  +358  9 299 30 52
FIN-02420 Jorvas          Email :  [email-masked]
Finland                   http://www.hut.fi/~gonzalo