Subject: RE: [Sip] INFO method used for ISUP to SIP IW

From: "Christer Holmberg (JO/LMF)" <[email-masked]>
Date: Wed, 6 Jul 2005 17:37:24 +0200

Hi,

If I remember correctly, INFO follows the rules of BYE. And, a BYE cannot be sent in the backword direction for an early dialog, I think.

So, I believe that Q.1912.5 uses 18x responses for ISUP sent backward during early dialogs.

Regards,

Christer 
LM Ericsson

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> GARCIN Sebastien RD-CORE-ISS
> Sent: 6. heinäkuuta 2005 16:08
> To: xupeili; Li, Bourne Bao (Bourne); Sip (E-mail)
> Subject: RE: [Sip] INFO method used for ISUP to SIP IW
> 
> 
> Hi,
> 
> You should follow ITU-T recommendation Q.1912.5 in this respect.
> 
> Regards,
>  
> 
> 
> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la 
> part de xupeili
> Envoyé : mercredi 6 juillet 2005 04:11
> À : 'Li, Bourne Bao (Bourne)'; 'Sip (E-mail)'
> Objet : RE: [Sip] INFO method used for ISUP to SIP IW
> 
> INFO can be sent after early-dialog is established. 
> So that INR/INF should be encapsulated in INFO after early dialog.
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Li, Bourne Bao (Bourne)
> Sent: Wednesday, July 06, 2005 9:13 AM
> To: Sip (E-mail)
> Subject: [Sip] INFO method used for ISUP to SIP IW
> 
> 
> 
> I got one question of INFO method usage for ISUP to SIP IW. 
> 
> Per RFC 2976 said INFO is used to convey the mid-call 
> information between 2 UA without impacting the existing call 
> state, which may be used for ISUP to SIP IW.  
> 
> My question is can INFO method be sent before the dialog has 
> been established, or it is only allowed to be sent after a 
> confirmed dialog.
> Because some ISUP message such as INR/INF, will be sent 
> before ACM/ANM, which maps to SIP will establish the confirmed dialog.
> 
> Thanks,
> Bao
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dale Worley" <[email-masked]>
Date: Wed, 6 Jul 2005 13:17:21 -0400

> From: Christer Holmberg (JO/LMF)
>
> If I remember correctly, INFO follows the rules of BYE. And,
> a BYE cannot be sent in the backword direction for an early
> dialog, I think.

The text of RFC 2976 is rather ambiguous on this point.  It says that
various headers are to be handled "as defined for the BYE request" (section
2.4), but it doesn't say that *when it can be sent* is as for the BYE
request.  It does envision that INFO requests can be forked (section 4),
which can only happen if an INFO is sent not only in an early dialog, but
before a 1xx response has established a to-tag.  (A request with a to-tag is
within an established route set and can't fork.)

My guess is that INFO can be sent at any time (and proxies should handle it
correctly), but if it is sent before a dialog has been confirmed, due
consideration should be given toward ensuring that it will be routed to the
destination(s) you intend and interpreted correctly by them.  A lot of this
probably depends on the details of your particular use of INFO, which may be
different from other uses of INFO.

Dale