Subject: RE: [Sip] Comment on draft-ietf-sip-location-conveyance-00

From: "PROUVOST Sebastien RD-CORE-ISS" <[email-masked]>
Date: Fri, 1 Jul 2005 11:45:39 +0200

Hi, 

I fully agree with John.

The solution presented in the draft that says that if the UAC do not insert the location in the INVITE and if its outbound proxy has the info and wants to have it included it into the INVITE, it returns it in a 4xx "Retry Location Body" has several drawbacks :

- What if the UAC issues the new INVITE that does not contains the location object (because it does not support this draft for example). If the call does not go through, this is a very big issue when the call is an emergency call. As a service provider we cannot rely on the capacity of the UAC to allow emergency calls to go through.

- What if the UAC issues a new INVITE that contains the location object but that does not correspond to the one the proxy gave.

- This solution introduces a supplementary exchange between the UA and its proxy which introduces an additional delay to the call establishement (especially important if the UA is over a radio access). 

If the draft stays as it is, this is one more reason why service providers would need an SBC : in order to be able to insert location information to an INVITE request without requiring any UA intervention.

It is necessary for a proxy to be able to insert this location info without having to rely on the UA's intervention. 

Sebastien.

________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Elwell, John
Envoyé : mercredi 29 juin 2005 11:19
À : [email-masked]; [email-masked]
Cc : [email-masked]
Objet : [Sip] Comment on draft-ietf-sip-location-conveyance-00

James, Brian, 

In section 9 (special provisions for emergency calls) it states: 

"In the case where the Proxy knows the location of the UAC and does not detect the UAC's location information message body in the message (or determines the LO is bad), the Proxy generates a new 4XX (Retry Location Body) error message that includes a location information message body for that UAC to include in the subsequent message.  The user agent MUST include this message body in the subsequent emergency message."

This places a new requirement on the UAC, which will not be met by UACs that are not compliant to this document. It seems emergency calls from such UACs will fail.

Regards, 

John 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: David R Oran <[email-masked]>
Date: Fri, 1 Jul 2005 07:47:32 -0400

I wonder if we can use a Supported:location header to distinguish the  
case of a UA who understands the new rules for handling location from  
a UA that will be confused by receiving a 4xx and abandon the call.

On Jul 1, 2005, at 5:45 AM, PROUVOST Sebastien RD-CORE-ISS wrote:

> Hi,
>
> I fully agree with John.
>
> The solution presented in the draft that says that if the UAC do  
> not insert the location in the INVITE and if its outbound proxy has  
> the info and wants to have it included it into the INVITE, it  
> returns it in a 4xx "Retry Location Body" has several drawbacks :
>
> - What if the UAC issues the new INVITE that does not contains the  
> location object (because it does not support this draft for  
> example). If the call does not go through, this is a very big issue  
> when the call is an emergency call. As a service provider we cannot  
> rely on the capacity of the UAC to allow emergency calls to go  
> through.
>
> - What if the UAC issues a new INVITE that contains the location  
> object but that does not correspond to the one the proxy gave.
>
> - This solution introduces a supplementary exchange between the UA  
> and its proxy which introduces an additional delay to the call  
> establishement (especially important if the UA is over a radio  
> access).
>
> If the draft stays as it is, this is one more reason why service  
> providers would need an SBC : in order to be able to insert  
> location information to an INVITE request without requiring any UA  
> intervention.
>
> It is necessary for a proxy to be able to insert this location info  
> without having to rely on the UA's intervention.
>
> Sebastien.
>
>
> "In the case where the Proxy knows the location of the UAC and does  
> not detect the UAC's location information message body in the  
> message (or determines the LO is bad), the Proxy generates a new  
> 4XX (Retry Location Body) error message that includes a location  
> information message body for that UAC to include in the subsequent  
> message.  The user agent MUST include this message body in the  
> subsequent emergency message."
>
> This places a new requirement on the UAC, which will not be met by  
> UACs that are not compliant to this document. It seems emergency  
> calls from such UACs will fail.
>
> Regards,
>
> John
>