Subject: [Sip] query about IMS in SIP

From: Sudhir Kumar Reddy <[email-masked]>
Date: Thu, 14 Jul 2005 10:33:19 +0530

Hi All
 I would like to know about the IMS i.e. what is the actually role of SIP in 
IMS.
 warmest regards
-- 
Sudhir Kumar Reddy Thumma
0986060751
_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Warren, Dan, VF UK - Technology \(TS\)" <[email-masked]>
Date: Thu, 14 Jul 2005 08:53:05 +0100

Just a quick clarification.  IMS is not just about wireless technology, even though it is primarily defined in 3GPP.  In 3GPP R6, IMS specs were altered to make them access agnostic and thus allow IMS to be utilised by any access (DSL, WLAN, FTTx) in such a way that an end user should receive common service and common touch and feel regardless of how they get to the IMS domain itself.

This paradigm is being used by the ETSI TISPAN work on NGN, where new service requirements are driving further extensions of IMS to allow for the deployment of a PSTN-like voice service using IMS.  There is also NGN work based on IMS taking place in ATIS, ITU-T, MSF and others.

Also, to clarify the references, 3GPP TS 24.229 defines the SIP profile used in IMS between CSCF's, AS's and other devices, but there is a lot more to IMS than just the SIP components - for example the Diameter-SIP-Application work in AAA WG was originally driven by IMS - so for an overview of the architecture and signalling flows, you may be better of looking at 3GPP TS 23.228.  You might also like to look at draft-jesske-sipping-tispan-requirements-01.txt and draft-jesske-sipping-tispan-analysis-00.txt for some detail of what is being proposed in terms of new services in TISPAN.

Cheers

Dan Warren

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Prabhas Sinha
> Sent: 14 July 2005 06:52
> To: Avasarala Ranjit-A20990
> Cc: [email-masked]
> Subject: Re: [Sip] query about IMS in SIP
> 
> 
> At a very high level:
> ------------------------------
> IMS specifications have been laid to harness the 3G network's access
> technology and also provide multimedia services to wireless
> devices. IMS subsystem would be aware of the
> characteristics of the real-time data to be transported,
> codec to be used, IP addresses alongwith the port numbers,
> apply error correction, header compression, required QoS
> etc. beyond what can be achieved over the packet-switched
> domain.
> IMS subsystem consists of various SIP proxies referred to
> as Call Session Control Functions (CSCF). The IMS
> specifications describes three types of CSCFs:
> i) Proxy- CSCF: connects wireless device to IMS subsystem
> ii) Serving - CSCF: provides services to the users, which they
> subscribe to. Each wireless device is associated with an S-CSCF on SIP
> registration. The
> incoming and outgoing sessions passes through it. Home
> Subscriber Server (HSS) maintains the information
> about S-CSCF and user's association. HSS knows the
> users location and subscribed services.
> iii) Interrogating - CSCF:  locates the associated S-CSCF for a user
> and routes the request to it.
> 
> For details, please refer to what Ranjit has mentioned.
> 
> regards,
> Prabhas
> 
> 
> 
> 
> On 7/14/05, Avasarala Ranjit-A20990 <[email-masked]> wrote:
> > Hi
> >     IMS uses SIP to setup multimedia calls over IP.  Refer 
> 3GPP standard TS
> > 24.229 for more details
> > 
> > Regards 
> > Ranjit 
> > 
> >  
> > ________________________________
> > From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Sudhir
> > Kumar Reddy
> > Sent: Thursday, July 14, 2005 10:33 AM
> > To: [email-masked]
> > Subject: [Sip] query about IMS in SIP
> > 
> > 
> > 
> > Hi All
> >  
> > Sip mailing list 
> > https://www1.ietf.org/mailman/listinfo/sip

---

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Thu, 14 Jul 2005 09:57:50 -0400

Inline [RRR]

From: [email-masked] on behalf of Warren, Dan, VF UK - Technology (TS)
Sent: Thu 7/14/2005 3:53 AM
To: Prabhas Sinha; Avasarala Ranjit-A20990
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

.......

[RRR] It seems to be confusing so far 3GPP works are conerned. The idea that 3GPP's IMS is propgating the following: The access is specific to cellular wireless, however, cellular wireless users need to have services that IMS is defining. So, IMS may have some aspects that may be used for other kinds of access technologies like Cable, DSL, Wireless LANs, FTTx, and others, but 3GPP has NEVER defined any criteria that it has NOW transformed itself to be access agnostic. 

[RRR] If 3GPP does so, it will be a mountain shfit for 3GPP in its charter, architecture, and requirements to propel in the IETF for SIP, SIPPING, AAA, and related WGs. In fact, in another thread in NSIS for a contribution on behalf of 3GPP, I mentioned that they should focus on access agnostic aspects of QOS in terms of mobility instead of just cellular wireless access.

[RRR] The question is this: Let us involve 3GPP as a whole to make clear (instead of individual contributions here and thers assuming that they do NOT respresent 3GPP) what is their actual motivation for providing contributions in IETF for creating standards? Is it only specific to cellular wireless access? Or, is it access agnostic?

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 14 Jul 2005 15:15:52 +0100

As part of its cooperation with ETSI TISPAN, 3GPP may place information in its specifications that enable reuse by other organisations, as well as those that are requirements for 3GPP operation.
 
Thus while the overall scope of 3GPP specifications will not change, you may find requirements in individual specifications that are not intended to be implemented by networks belonging to operators with GERAN or UTRAN attachments only. These requirements may be endorsed in the specifications of ETSI TISPAN, or other organisations.
 
Thus for example in 3GPP TR 24.819, you will find some proposed amendments to 3GPP TS 24.229 which specify attachment of terminals to an IMS through an XDSL system. These are still work in progress.
 
Finally note that most people in 3GPP participate in IETF as individuals and not as representatives of 3GPP, see RFC 3113. There is only one 3GPP liaison representative appointed by 3GPP TSG SA (along with IETF representation in the oppposite direction).
 
regards
 
Keith
 
Keith Drage 
Lucent Technologies 
[email-masked] 
tel: +44 1793 776249 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 14:58
To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

Inline [RRR]

  _____  

.......

---

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Thu, 14 Jul 2005 10:34:12 -0400

OK, Good.
 
The question is this: Is 3GPP working for access agnostic specifications in the IETF?
 
If not, kindly summarize this to us as you seem to be working on behalf of 3GPP in coordination with 3GPP- IETF liaison as we are NOT aware of those 3GPP specs (unlike IETF, access to final specs are limited to 3GPP members only).
 
Best regards,
Radhika

From: Drage, Keith (Keith) [mailto:[email-masked]]
Sent: Thu 7/14/2005 10:15 AM
To: Roy, Radhika (AEAD)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

 

regards
 
Keith
 
Keith Drage 
Lucent Technologies 
[email-masked] 
tel: +44 1793 776249 

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
	Sent: 14 July 2005 14:58
	To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
	Cc: [email-masked]
	Subject: RE: [Sip] query about IMS in SIP

	Inline [RRR]

	.......

---

From: "Warren, Dan, VF UK - Technology \(TS\)" <[email-masked]>
Date: Thu, 14 Jul 2005 15:47:55 +0100

First thanks to Keith for summarising what I was about to post very long windedly.
 
Second, 3GPP specs ARE available in their final versions without the need for 3GPP membership.  Go to www.3gpp.org, click specifications and you can download all and any (including drafts of specs being worked on).  
 
Last, 3GPP is working for extensions and definitions in IETF that enable IMS to support all and any access type.  There will be some access dependent elements in the specification but they will not be mandatory requirements.  The variations will depend on the nature of the service being provided.  For example the current debate on the SIPPING list with regard to the regulatory requirements on voice services is in some cases not applicable to a mobile voice service but is of very real concern to fixed line voice service providers.  One only needs to see what is happening between Skype and the FCC to see what can happen when regulatory considerations are not adhered to by voice providers.
 
Cheers
 
Dan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 15:34
To: Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

OK, Good.

 
Best regards,
Radhika

  _____  

 

 
regards
 
Keith
 
Keith Drage 
Lucent Technologies 
[email-masked] 
tel: +44 1793 776249 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 14:58
To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

Inline [RRR]

  _____  

.......

---

From: "Warren, Dan, VF UK - Technology \(TS\)" <[email-masked]>
Date: Thu, 14 Jul 2005 15:58:41 +0100

Got carried away there... TISPAN is working for extensions in IETF.  Those extensions will then ultimately be incorporated in new versions of existing 3GPP specifications.
 
But then we're all one big happy family in ETSI land.
 
Dan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Warren, Dan, VF UK - Technology (TS)
Sent: 14 July 2005 15:48
To: Roy, Radhika (AEAD); Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

 
 
Cheers
 
Dan

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 15:34
To: Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

OK, Good.

 
Best regards,
Radhika

  _____  

 

 
regards
 
Keith
 
Keith Drage 
Lucent Technologies 
[email-masked] 
tel: +44 1793 776249 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 14:58
To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

Inline [RRR]

  _____  

.......

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Thu, 14 Jul 2005 16:52:22 +0100

I referred in my original mail to RFC 3113, which I assume you can gain access to without further subscription or payment.
 
This tells you exactly how you gain access to 3GPP documents, and that they are available to everybody with IP access.
 
Indeed if you look in the right place you can gain access to every version of every specification (bar about 3 on the security algorithms) that has existed electronically. Similarly you can also gain access to the vast majority of the internal working documents that have existed since 3GPP was created, if you really have the patience to work through them.
 
Obviously 3GPP specifications are published by the member SDOs, but as far as I understand, none of the publishing SDOs amend the contents of those 3GPP specifications from those appearing on the 3GPP site, and indeed the ETSI ones are also available free of charge for the minor pain of giving your name and email address before you obtain them.
 
regards
 
Keith

-----Original Message-----
From: Roy, Radhika (AEAD) [mailto:[email-masked]]
Sent: 14 July 2005 15:34
To: Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

OK, Good.

 
Best regards,
Radhika

  _____  

 

 
regards
 
Keith
 
Keith Drage 
Lucent Technologies 
[email-masked] 
tel: +44 1793 776249 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 14:58
To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

Inline [RRR]

  _____  

.......

---

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Thu, 14 Jul 2005 15:37:30 -0400

Excellent!
 
In fact, let me summarize as follows:
 
1. Contributions are being made (or will be made) keeping the big picture in mind that include the entire ETSI family including 3GPP.
 
2. Primary focus of standardization in the IETF from ETSI point of view is "Access Independent." These contributions will generally be along the line of the standard track RFCs.
 
3. Some contributions many be "access-specific (e.g., cellular wireless, Wireless LANs, others)," and may have some optional features. Most likely, they will be "Informational RFCs."
 
4. Regulatory features might also influence some aspects standardization.
 
Now, it will help us to review the contributions (ETSI/3GPP) focusing the above.
 
Many thanks for clarifications.
 
Best regards,
Radhika

From: Warren, Dan, VF UK - Technology (TS) [mailto:[email-masked]]
Sent: Thu 7/14/2005 10:58 AM
To: Warren, Dan, VF UK - Technology (TS); Roy, Radhika (AEAD); Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

 
Dan

	-----Original Message-----
	From: [email-masked] [mailto:[email-masked]]On Behalf Of Warren, Dan, VF UK - Technology (TS)
	Sent: 14 July 2005 15:48
	To: Roy, Radhika (AEAD); Drage, Keith (Keith)
	Cc: [email-masked]
	Subject: RE: [Sip] query about IMS in SIP

	 
	 
	Cheers
	 
	Dan

		-----Original Message-----
		From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
		Sent: 14 July 2005 15:34
		To: Drage, Keith (Keith)
		Cc: [email-masked]
		Subject: RE: [Sip] query about IMS in SIP

		OK, Good.

		 
		Best regards,
		Radhika

		 

		 
		regards
		 
		Keith
		 
		Keith Drage 
		Lucent Technologies 
		[email-masked] 
		tel: +44 1793 776249 

			-----Original Message-----
			From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
			Sent: 14 July 2005 14:58
			To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
			Cc: [email-masked]
			Subject: RE: [Sip] query about IMS in SIP

			Inline [RRR]

			.......

---

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Thu, 14 Jul 2005 15:57:52 -0400

You are right that I can access to all 3GPP working documents. In fact, I have been accessing many of those documents since the inception of 3GPP. It seems to me that the scope of 3GPP works is very big and it is not so easy to keep track for all of them for all those years with so many versions.
 
However, the access to the standardized documents is very limited. One can access only 3 times. More than this, the access is not provided unless one is the member of 3GPP.
 
That is OK for the closed forum like 3GPP that does not provide unlimited access like that of the IETF.
 
Recently, I proposed to contributors of closed forums (e.g., 3GPP) in NSIS WG as follows:
 
1. Any standard documents of the closed forums that cannot be accessed publicly and referred by authors to place in the website (preferably by the author or by liaison member) that can be accessed freely by IETF members.
 
2. Items that I mentioned in response to Dan's email.
 
Thanks for helping us to know about 3GPP/ETSI.
 
Best regards,
Radhika

From: Drage, Keith (Keith) [mailto:[email-masked]]
Sent: Thu 7/14/2005 11:52 AM
To: Roy, Radhika (AEAD)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

 

regards
 
Keith

	-----Original Message-----
	From: Roy, Radhika (AEAD) [mailto:[email-masked]]
	Sent: 14 July 2005 15:34
	To: Drage, Keith (Keith)
	Cc: [email-masked]
	Subject: RE: [Sip] query about IMS in SIP

	OK, Good.

	 
	Best regards,
	Radhika

	 

	 
	regards
	 
	Keith
	 
	Keith Drage 
	Lucent Technologies 
	[email-masked] 
	tel: +44 1793 776249 

		-----Original Message-----
		From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
		Sent: 14 July 2005 14:58
		To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
		Cc: [email-masked]
		Subject: RE: [Sip] query about IMS in SIP

		Inline [RRR]

		.......

---

From: "Drage, Keith (Keith)" <[email-masked]>
Date: Fri, 15 Jul 2005 14:07:55 +0100

I can only assume that you are referring to the versions of 3GPP documents published by ETSI, although I am not aware of any limitation there, although you do have to access it one document at the time. While the ETSI and 3GPP sites are hosted on common platforms, they have different domain names and you should be able to tell the difference.
 
On the 3GPP site there is no access limitation, and never has been. No 3GPP participants have accounts in order to access the 3GPP areas. I agree these are the copies before publication, but to be honest, this is what people implement from, and not the versions published by the SDOs. None of the SDOs make technical changes to the documents in publication.
 
So to repeat - go to one of the following:
 
www.3gpp.org <http://www.3gpp.org> 
http://www.3gpp.org/ftp/Specs/html-info/status-report.htm <http://www.3gpp.org/ftp/Specs/html-info/status-report.htm> 
 
and so on there should be no limitation.
 
If you have trouble, there are helpdesk contacts at both ETSI and 3GPP sites.
 
regards
 
Keith

-----Original Message-----
From: Roy, Radhika (AEAD) [mailto:[email-masked]]
Sent: 14 July 2005 20:58
To: Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

 

 

Best regards,
Radhika

  _____  

 

 
regards
 
Keith

-----Original Message-----
From: Roy, Radhika (AEAD) [mailto:[email-masked]]
Sent: 14 July 2005 15:34
To: Drage, Keith (Keith)
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

OK, Good.

 
Best regards,
Radhika

  _____  

 

 
regards
 
Keith
 
Keith Drage 
Lucent Technologies 
[email-masked] 
tel: +44 1793 776249 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Roy, Radhika (AEAD)
Sent: 14 July 2005 14:58
To: Warren, Dan, VF UK - Technology (TS); Prabhas Sinha; Avasarala Ranjit-A20990
Cc: [email-masked]
Subject: RE: [Sip] query about IMS in SIP

Inline [RRR]

  _____  

.......