Subject: RE: [Sip] GRUU and Anonymity

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 12 Sep 2006 17:12:27 -0400

Dale,

I didn't understand the Public-Private Key pair aspect and the statement
of one private key per domain?

Isn't that one private key per user?

Mike 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, September 12, 2006 3:25 PM
> To: [email-masked]
> Subject: Re: [Sip] GRUU and Anonymity
> 
>    From: Paul Kyzivat <[email-masked]>
> 
>    I'm not sure I follow all the details, but I get the gist. 
> I gather the 
>    proxy isn't expected to have any idea which sequence 
> numbers are/aren't 
>    valid. If so, then it seems that the sequence number is 
> analogous to the 
>    grid parameter. It may be possible align the two 
> approaches closely.
> 
>    For instance, perhaps the normal gruu is of form:
> 	   sip:user@domain;gruu;opaque=xyz;grid=abc
> 
>    Then an anonymous form of it could be
> 	   sip:PublicKey(user,opaque,grid)@domain;gruu
> 
>    and as you suggest, the proxy could turn this back into the 
>    non-anonymous form and then process it normally. 
> Ultimately the UA would 
>    receive the grid.
> 
> The reason that the pseudo-grid's are numbers is so that the 
> UA can store a threshold, before which all pseudo-grid's are 
> known to be invalid.  If they didn't form an ordered 
> sequence, the UA would have to record in non-volatile memory 
> all invalid ones.  Or all valid ones.
> 
> Uh, yes, the number of valid ones at any given moment is 
> expected to be small.  So you don't really need them to be 
> numbers, as long as there is some way to avoid using the same 
> one twice (very often).
> 
>    But a piece I am missing in the above and below is how the proxy 
>    determines what private key to apply to the incoming truu. 
> It could 
>    potentially get the one currently assigned to a registered 
> contact, but 
>    to do so it would need to know what user, and then which contact.
> 
>    I guess the anonymous form of the gruu could be:
> 	   sip:PublicKey(user,opaque,grid)@domain;gruu;key=foo
> 
> There's only one private key for the domain.
> 
>    Another messy aspect of this is that it couples the UA and 
> the proxy 
>    regarding the details of the format of the URI, and that 
> might cause 
>    some difficulties.
> 
> Yeah, it's a pretty tight coupling between the processing in 
> the proxy and in the UA.  In particular, they have to 
> implement opposite halves of the encryption operation.
> 
>    For instance, one problem I have encountered with IMS (and 
> which may 
>    apply to other large domains) is that the user space is 
> partitioned, 
>    with a different home proxy handling each partition. In 
> the kind of 
>    scheme you have proposed, it becomes necessary to guarantee that 
>    anonymous gruus are routed to the proper home proxy.
> 
> Not really.  Since there is only one private key, any proxy 
> can open any TRUU for the domain.  Once it does that, it has 
> the GRUU for the UA, but we already assume that any proxy can 
> route any GRUU for the domain.
> 
> This scheme seems to have a problem in that it's not too hard 
> to forge TRUUs that might get partially routed before they 
> are rejected.
> 
> Dale
> 
> _______________________________________________
> Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip 
> Use [email-masked] for new developments on the application of sip
> 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: [email-masked]
Date: Tue, 12 Sep 2006 17:52:55 -0400

From: "Michael Hammer \(mhammer\)" <[email-masked]>

In what way?

In this case, no.

Dale