Subject: [Sip] GRUU and SIPS

From: Jonathan Rosenberg <[email-masked]>
Date: Wed, 27 Sep 2006 23:02:53 -0400

During the GRUU call today, the topic of SIPS was discussed. The 
question is what should or should not the GRUU spec say on SIPS, given 
we are revising the mechanism. I had previously wanted to more or less 
say what it says now, but have recently changed my mind on this. Given 
that we are producing a document to clarify sips, and given that, no 
matter what we do say in gruu, implementors would have to reconcile the 
two, it is easier I think to leave the problem in its entirety to the 
sips document.

So, my proposal is to remove all discussion of sips from gruu, with the 
exception of a sentence that says applicability and usage with sips is 
out of scope for this document and is to be treated elsewhere. Then the 
sips document will handle gruu, outbound and rfc3261 implications of sips.

Thoughts?

-Jonathan R.
-- 
Jonathan D. Rosenberg, Ph.D.                   600 Lanidex Plaza
Cisco Fellow                                   Parsippany, NJ 07054-2711
Cisco Systems
[email-masked]                              FAX:   (973) 952-5050
http://www.jdrosen.net                         PHONE: (973) 952-5000
http://www.cisco.com

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Thu, 28 Sep 2006 12:05:28 -0500

I agree with this approach.

I will point out that the latest version of the sips-guidelines draft is
very 
much in line with what was in GRUU-10. I have used the same model as
GRUU for the 
Registration procedure. 

Draft is at:
http://www.ietf.org/internet-drafts/draft-audet-sip-sips-guidelines-03.t
xt

I'm just about ready to issue an -04 update with the consolidated
agreements from
the list.

> -----Original Message-----
> From: Jonathan Rosenberg [mailto:[email-masked]] 
> Sent: Wednesday, September 27, 2006 8:03 PM
> To: IETF SIP List
> Subject: [Sip] GRUU and SIPS
> 
> During the GRUU call today, the topic of SIPS was discussed. 
> The question is what should or should not the GRUU spec say 
> on SIPS, given we are revising the mechanism. I had 
> previously wanted to more or less say what it says now, but 
> have recently changed my mind on this. Given that we are 
> producing a document to clarify sips, and given that, no 
> matter what we do say in gruu, implementors would have to 
> reconcile the two, it is easier I think to leave the problem 
> in its entirety to the sips document.
> 
> So, my proposal is to remove all discussion of sips from 
> gruu, with the exception of a sentence that says 
> applicability and usage with sips is out of scope for this 
> document and is to be treated elsewhere. Then the sips 
> document will handle gruu, outbound and rfc3261 implications of sips.
> 
> Thoughts?
> 
> -Jonathan R.
> -- 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "Samir Srivastava" <[email-masked]>
Date: Thu, 28 Sep 2006 17:40:28 -0500

Hi,

I already posted enough on ugliness of SIPS on the list. I think in
Montreal people were only thinking of retargeting. There are new issues
with TELL URI etc within 3261 itself. 
 
Only DNS service providers will love SIPS, TELLS,etc :-)

In the age of design patterns, nice medicine of non-modularity. 

Cheers
Samir

PS: No more cries from this baby. Others wake up or enjoy kill -9 getpid
().

> From: Audet, Francois (SC100:3055)
> Sent: Thursday, September 28, 2006 10:05 AM
> To: Jonathan Rosenberg; IETF SIP List
> Subject: RE: [Sip] GRUU and SIPS
>