Subject: [Sip] P-Asserted Value syntax

From: Maheswari D <[email-masked]>
Date: Wed, 13 Sep 2006 03:47:59 -0700 (PDT)

Hello All,

Can you please clarify if the following P-Asserted
value are according to the RFC standard.

1)P-Asserted-Identity:<sip:[email-masked]:5061;user=phone>
2)P-Asserted-Identity:sip:[email-masked]:5061 

RFC shows examples only for the mail address with the
tag like follows:
P-Asserted-Identity: <sip:[email-masked]>

If the above 2 syntax are wrong, can you please guide
with the correct syntax.

Thanks & Regards,
Maheswari.D

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Francois Audet" <[email-masked]>
Date: Wed, 13 Sep 2006 10:53:37 -0500

First one is wrong as it would require a phone-context or a "+"
parameter to
be RFC 3966 compliant (which is what user=phone means).

So Assuming your intent was for 213 == Algeria's country code, it would
look
like:

P-Asserted-Identity:<sip:[email-masked]:5061;user=phone>

If on the othe hand, this was a private 9-digit number used inside
an enterprise (say, example.com), it could look like:

P-Asserted-Identity:<sip:213106404;phone-context=[email-masked]:
5061;user=phone>

---

Second one is technically correct. However, instead of being a phone 
number it means a user name (there is no user=phone parameter) which may

not make much sense outside one's network. If you send it to me and we 
are in different domains, to me the number is just a user-name that only
make sense at 10.9.34.10.

For both case, it would normally make more sense to use a domain name
instead of an IP address.

> -----Original Message-----
> From: Maheswari D [mailto:[email-masked]] 
> Sent: Wednesday, September 13, 2006 3:48 AM
> To: [email-masked]
> Subject: [Sip] P-Asserted Value syntax
> 
> Hello All,
> 
> Can you please clarify if the following P-Asserted value are 
> according to the RFC standard.
> 
> RFC shows examples only for the mail address with the tag 
> like follows:
> If the above 2 syntax are wrong, can you please guide with 
> the correct syntax.
> 
> Thanks & Regards,
> Maheswari.D
> 
> 
> Tired of spam?  Yahoo! Mail has the best spam protection 
> around http://mail.yahoo.com 
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "adi" <[email-masked]>
Date: Thu, 14 Sep 2006 22:34:43 +0300

In the first case you may use the "tel:" with the phone number

-----Original Message-----
From: Francois Audet [mailto:[email-masked]] 
Sent: Wednesday, September 13, 2006 6:54 PM
To: Maheswari D; [email-masked]
Subject: RE: [Sip] P-Asserted Value syntax

---