Subject: [Sip] IPv6 Changes in SIP UA

From: amitsoni <[email-masked]>
Date: 05 Sep 2006 15:54:47 +0530

Hi All,

I need to support IPv6 in UA. What I have got from preliminarily
analysis, is that I'll have to change transport support, IP addresses in
SIP header as well as in SDP.

I just wanted to know If one UA supports IPv4/IPv6 and other one/proxy
supports only IPv4, then which address to fill in the SIP header, in
case i'm using IP addresses in header. 

-Do I need to get the information(DNS query) about other UA or is there
some other method?

-Do I need to keep some configurable parameter in case of proxy or get
the info from DNS?

Thanks In Advance,
amit

The information contained in this e-mail message and/or attachments to it may
contain confidential or privileged information. If you are not the intended recipient, any dissemination, use, review, distribution, printing or copying of the information contained in this e-mail message and/or attachments to it are strictly prohibited. If you have received this communication in error, please notify us by reply e-mail immediately and permanently delete the message and any attachments.

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: <[email-masked]>
Date: Tue, 5 Sep 2006 18:35:14 +0530

Hi Amit,

Look at the draft-ietf-sipping-v6-transition-03.txt draft. It answers
many of your questions.

Regards,
Ravi.

--
 
Ravishankar. G. Shiroor
Wipro Technologies, Bangalore.
 
[email-masked]
--

> -----Original Message-----
> From: amitsoni [mailto:[email-masked]] 
> Sent: Tuesday, September 05, 2006 3:55 PM
> To: IETF SIP List
> Subject: [Sip] IPv6 Changes in SIP UA
> 
> Hi All,
> 
> I need to support IPv6 in UA. What I have got from 
> preliminarily analysis, is that I'll have to change transport 
> support, IP addresses in SIP header as well as in SDP.
> 
> I just wanted to know If one UA supports IPv4/IPv6 and other 
> one/proxy supports only IPv4, then which address to fill in 
> the SIP header, in case i'm using IP addresses in header. 
> 
> -Do I need to get the information(DNS query) about other UA 
> or is there some other method?
> 
> -Do I need to keep some configurable parameter in case of 
> proxy or get the info from DNS?
> 
> Thanks In Advance,
> amit
> 
> 
> 
> The information contained in this e-mail message and/or 
> attachments to it may contain confidential or privileged 
> information. If you are not the intended recipient, any 
> dissemination, use, review, distribution, printing or copying 
> of the information contained in this e-mail message and/or 
> attachments to it are strictly prohibited. If you have 
> received this communication in error, please notify us by 
> reply e-mail immediately and permanently delete the message 
> and any attachments.
> 
> 
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 05 Sep 2006 08:50:41 -0500

> Look at the draft-ietf-sipping-v6-transition-03.txt draft. It answers

Right; the -04 version should be out soon -- the last set of
edits are going through the final review by the co-authors of
the draft.

You may also want to eyeball
http://www.ietf.org/internet-drafts/draft-gurbani-sipping-ipv6-sip-03.txt,
which provides you a set of IPv6-specific torture test cases.

Ciao.

- vijay
-- 
Vijay K. Gurbani  vkg@{lucent.com,research.bell-labs.com,acm.org}
Bell Laboratories, Lucent Technologies, Inc.
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)