Subject: [Sip] Resource Priority Header namespaces

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 01 Nov 2007 14:23:09 -0400

I read over the draft in last call requesting new RPH namespace assignments.
In and of itself it looks non-objectionable.  While I don't 
understand the need for that many name spaces, or those specific 
values, my first reaction is to say "okay" anyway.

However, I went and looked at RFC4412, which defines the header 
namespace registration.
That RFC calls for a standard track RFC for defining namespaces.
And the text is quite explicit that one should not create a 
multiplicity of namespaces, but should try to use existing spaces first.

So, unless we want to check RFC4412, it seems that the request for 32 
namespaces in
	draft-ietf-sip-rph-new-namespaces-00.txt
really needs more explanation / justification.

Yours,
Joel M. Halpern

_______________________________________________
Sip mailing list  https://www1.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Sun, 4 Nov 2007 15:22:09 +0100

I will leave James to respond to this as it impacts the draft, but
assuming we reach that stage, I will remember this point for the PROTO
writeup.

Regards

Keith 

> -----Original Message-----
> From: Joel M. Halpern [mailto:[email-masked]] 
> Sent: Thursday, November 01, 2007 6:23 PM
> To: [email-masked]
> Subject: [Sip] Resource Priority Header namespaces
> 
> understand the need for that many name spaces, or those 
> specific values, my first reaction is to say "okay" anyway.
> 
> However, I went and looked at RFC4412, which defines the 
> header namespace registration.
> So, unless we want to check RFC4412, it seems that the 
> request for 32 namespaces in
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: Hannes Tschofenig <[email-masked]>
Date: Sun, 04 Nov 2007 17:13:34 +0100

This document seems to have its origin in a single or a small number of 
customers.

 From the text in the draft it seems the priority values for each 
namespace are used totally independently. I wonder whether someone has 
actually thought what this means for a real system when priority values 
of 50+ namespaces are used together.
Does anyone know how the use cases are going to look like?

Ciao
Hannes