Subject: [Sip] Question regarding SDP 'M' Line

From: "Jayantheesh Srimushnam" <[email-masked]>
Date: Wed, 16 Apr 2008 15:27:36 +0530

Hi All,

While adding a new media stream is it MUST to add a new 'M' line in the
SDP or existing 'M' line can be replaced with the new one. 

Please go through the below specified example and clarify me which is
the correct way of implementing? 

Example 1:

========

Initial INVITE:

m=audio 7100 RTP/AVP 0 101

a=rtcp:7101

a=sendonly

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

Re-Invite:

m=image 20112 udptl t38

a=T38FaxVersion:0

a=T38MaxBitRate:1440

Example 2:

========

Initial INVITE:

m=audio 7100 RTP/AVP 0 101

a=rtcp:7101

a=sendonly

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

Re-Invite:

m=audio 7100 RTP/AVP 0 101

a=rtcp:7101

a=sendonly

a=rtpmap:0 PCMU/8000

a=rtpmap:101 telephone-event/8000

m=image 5080 udptl t38

c=IN IP4 10.101.210.30

a=T38FaxVersion:0

Thanks,

Jayantheesh

DISCLAIMER:
-----------------------------------------------------------------------------------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification, distribution and / or publication of 
this message without the prior written consent of the author of this e-mail is strictly prohibited. If you have
received this email in error please delete it and notify the sender immediately. Before opening any mail and 
attachments please check them for viruses and defect.

-----------------------------------------------------------------------------------------------------------------------

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Guangwu.He" <[email-masked]>
Date: Wed, 16 Apr 2008 20:47:12 +0800

see my comments inline.
 
Thanks & Regards,

Guangwu.He

----------------------------------------------------------------------------
---------------------------------------------------------
This e-mail and its attachments contain confidential information from
HUAWEI, which
is intended only for the person or entity whose address is listed above. Any
use of the
information contained herein in any way (including, but not limited to,
total or partial
disclosure, reproduction, or dissemination) by persons other than the
intended
recipient(s) is prohibited. If you receive this e-mail in error, please
notify the sender by
phone or email immediately and delete it!

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Jayantheesh Srimushnam
Sent: Wednesday, April 16, 2008 5:58 PM
To: [email-masked]
Subject: [Sip] Question regarding SDP 'M' Line

Hi All,

While adding a new media stream is it MUST to add a new 'M' line in the SDP
or existing 'M' line can be replaced with the new one. 

Please go through the below specified example and clarify me which is the
correct way of implementing? 

Example 1:

========

Initial INVITE:

a=rtcp:7101

a=sendonly

a=rtpmap:0 PCMU/8000

Re-Invite:

m=image 20112 udptl t38

a=T38FaxVersion:0

a=T38MaxBitRate:1440

[Guangwu]:the example is wrong;RFC3264 8.1

New media streams are created by new additional media descriptions
below the existing ones, or by reusing the "slot" used by an old
media stream which had been disabled by setting its port to zero.

in you example 1,the port is not zero;

Example 2:

========

Initial INVITE:

a=rtcp:7101

a=sendonly

a=rtpmap:0 PCMU/8000

Re-Invite:

a=rtcp:7101

a=sendonly

a=rtpmap:0 PCMU/8000

m=image 5080 udptl t38

c=IN IP4 10.101.210.30

a=T38FaxVersion:0  

Thanks,

Jayantheesh

DISCLAIMER:
----------------------------------------------------------------------------
-------------------------------------------

The contents of this e-mail and any attachment(s) are confidential and
intended for the named recipient(s) only.
It shall not attach any liability on the originator or HCL or its
affiliates. Any views or opinions presented in 
this email are solely those of the author and may not necessarily reflect
the opinions of HCL or its affiliates.
Any form of reproduction, dissemination, copying, disclosure, modification,
distribution and / or publication of 
this message without the prior written consent of the author of this e-mail
is strictly prohibited. If you have
received this email in error please delete it and notify the sender
immediately. Before opening any mail and 
attachments please check them for viruses and defect.

----------------------------------------------------------------------------
-------------------------------------------

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 16 Apr 2008 09:27:03 -0400

This probably should have been posted to sip-implementors, and certainly 
not cross-posted to both sip and sipping. I'm replying here only because 
there has been one reply here.

I can't remember where right now, but somewhere there has been a 
clarification to the point that Guangwu raises. I believe it is now 
considered ok to reuse an existing and active m-line for a different 
media type.

Its illogical not to allow that. Since you could do it by first doing an 
o/a to set the port to zero, and then another to reuse the line with the 
zero port, why waste the bandwidth and processing to exchange those 
meaningless messages?

	Paul

Guangwu.He wrote:
> see my comments inline.
>  
> Thanks & Regards,
> 
> Guangwu.He
> 
> 
> -------------------------------------------------------------------------------------------------------------------------------------
> is intended only for the person or entity whose address is listed above. 
> Any use of the
>     ------------------------------------------------------------------------
>     *From:* [email-masked] [mailto:[email-masked]] *On
>     Behalf Of *Jayantheesh Srimushnam
>     *Sent:* Wednesday, April 16, 2008 5:58 PM
>     *To:* [email-masked]
>     *Subject:* [Sip] Question regarding SDP 'M' Line
> 
>     Hi All,
> 
>      
> 
>     While adding a new media stream is it MUST to add a new ‘M’ line in
>     the SDP or existing ‘M’ line can be replaced with the new one.
> 
>     Please go through the below specified example and clarify me which
>     is the correct way of implementing?
> 
>      
> 
>     Example 1:
> 
>     ========
> 
>      
> 
>     Initial INVITE:
> 
>      
> 
>     *[Guangwu]:the example is wrong;RFC3264 8.1*
> 
>     *New media streams are created by new additional media descriptions
>     *
>     *in you example 1,the port is not zero;*
> 
>     ** 
> 
>     Example 2:
> 
>     ========
> 
>      
> 
>     Initial INVITE:
> 
>      
> 
>     a=T38FaxVersion:0* * 
>     The contents of this e-mail and any attachment(s) are confidential
>     and intended for the named recipient(s) only.
>     this email are solely those of the author and may not necessarily
>     reflect the opinions of HCL or its affiliates.
>     Any form of reproduction, dissemination, copying, disclosure,
>     modification, distribution and / or publication of
>     this message without the prior written consent of the author of this
>     e-mail is strictly prohibited. If you have
> ------------------------------------------------------------------------
>