Subject: [Sip] SIP deployment

From: "ajay thakur" <[email-masked]>
Date: Mon, 14 Apr 2008 17:14:42 +0530

Hi all,
I have few doubts about SIP deployment.

(1) Given that NAT/firewall creates problem for SIP calls. How these
problems
are solved in the practical deployment. IS it by using STUN or by using
SIP-alg.

(2) Also i guess not all phones support STUN. How does it work. ?

Any idea?

Ajay
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 14 Apr 2008 12:54:48 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of ajay thakur
> Sent: Monday, April 14, 2008 4:45 AM
> To: [email-masked]
> Subject: [Sip] SIP deployment
> 
> Hi all,
> (1) Given that NAT/firewall creates problem for SIP calls. 
> How these problems
> are solved in the practical deployment. IS it by using STUN 
> or by using SIP-alg.

It is solved by ICE (draft-ietf-mmusic-ice), and/or SIP-ALGs in the NATs,
and/or a Session Border Controller doing "hosted NAT traversal" -- depending
on the environment.

RFC3489 (STUN), by itself, has proven to be unsufficient as a solution by
itself.  Instead, the MMUSIC working group created ICE (draft-ietf-mmusic-ice)
and the BEHAVE working group revised RFC3489 (draft-ietf-behave-rfc3489bis).

Hope this helps,
-d