Subject: [Sip] Doubt in Invite client transaction - proceeding state

From: gaurav khurana <[email-masked]>
Date: Thu, 3 Apr 2008 10:52:50 -0700 (PDT)

Hi,

I looked into the previous threads too but couldn't clarify my doubt, so posting the question again.

My question is that how long will the client transaction be alive once we enter in proceeding state.

Previous threads suggest transaction will terminate when timer B, i.e. 64*T1 expires. But, what I see in RFC3261 - 17.1.1.2 fig. 5 (INVITE Client transaction) that timer B fires only in Calling state. There's no timer shown for proceeding state.

Does it mean that in proceeding state, the transaction will not terminate until the caller disconnects the call manually? 
 
GAURAV KHURANA 
# 91-9886646104

      ____________________________________________________________________________________
You rock. That's why Blockbuster's offering you one month of Blockbuster Total Access, No Cost.  
http://tc.deals.yahoo.com/tc/blockbuster/text5.com

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Rockson Zhengyu Li <[email-masked]>
Date: Sun, 6 Apr 2008 20:17:17 -0700 (PDT)

Gaurav,

I think it's totally up to TU to determine to cancel the call or not in 
early dialog stage,
you cannot mandate all UA cancel the in call in 5 mins, can you??

-Rockson

On Fri, Apr 4, 2008 at  1:52 AM, gaurav khurana wrote:

Hi,

I looked into the previous threads too but couldn't clarify my doubt, so 
posting the question again.

My question is that how long will the client transaction be alive once 
we enter in proceeding state.

Previous threads suggest transaction will terminate when timer B, i.e. 
64*T1 expires. But, what I see in RFC3261 - 17.1.1.2 fig. 5 (INVITE 
Client transaction) that timer B fires only in Calling state. There's no 
timer shown for proceeding state.

Does it mean that in proceeding state, the transaction will not 
terminate until the caller disconnects the call manually?

GAURAV KHURANA
# 91-9886646104

___________________________________

You rock. That's why Blockbuster's offering you one month of Blockbuster 
Total Access 
<http://us.rd.yahoo.com/evt=47523/*http://tc.deals.yahoo.com/tc/blockbuster/text5.com> 
, No Cost.

------------------------------

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip 
<https://www.ietf.org/mailman/listinfo/sip>   
<https://www.ietf.org/mailman/listinfo/sip>
This list is for NEW development of the core SIP Protocol
Use [email-masked] 
<mailto:[email-masked]>   
<mailto:[email-masked]>  for questions on current sip
Use [email-masked] <mailto:[email-masked]>   
<mailto:[email-masked]>  for new developments on the application of 
sip
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip