Subject: [Sip] Defining a References header to assist with diagnostics

From: [email-masked]
Date: Mon, 7 Jul 2008 17:32:36 -0400

In the sipX open-source PBX, we've started adding a "References"
header to messages so that they can point to the messages/dialogs that
created them.  This makes it easier to extract from message logs all
the messages that are related to one phone call.  I've written up an
I-D to describe the References header:

Filename:	 draft-worley-references
Revision:	 00
Title:		 The References Header for SIP
Creation_date:	 2008-07-06
WG ID:		 Independent Submission
Number_of_pages: 19

Abstract:
This document defines a SIP extension header, References, to be used
within SIP messages to signify that the message (and by extension,
the dialog containing it) is related to one or more other dialogs.
It is expected to be used largely for diagnostic purposes.

Dale
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Tue, 8 Jul 2008 15:43:42 +0200

Any requirements work in existence? I do not see any drafted in this
document.

RFC 3427 applies!

Regards

Keith 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, July 07, 2008 10:33 PM
> To: [email-masked]
> Subject: [Sip] Defining a References header to assist with diagnostics
> 
> header to messages so that they can point to the 
> messages/dialogs that created them.  This makes it easier to 
> extract from message logs all the messages that are related 
> to one phone call.  I've written up an I-D to describe the 
> References header:
> 
> This document defines a SIP extension header, References, to 
> be used within SIP messages to signify that the message (and 
> by extension, the dialog containing it) is related to one or 
> more other dialogs.
> This list is for NEW development of the core SIP Protocol Use 
> [email-masked] for questions on current sip

---

From: [email-masked]
Date: Tue, 8 Jul 2008 11:40:49 -0400

From: "DRAGE, Keith \(Keith\)" <[email-masked]>

No, this is purely experimental.

Dale