Subject: [Sip] Question on format of retention-expiry (absolute time) in RFC4119 (Presence-based GEOPRIV Location)

From: "Rajeev Narang (ranarang)" <[email-masked]>
Date: Sun, 27 Jul 2008 20:52:39 +0530

Hi,
 
RFC3261 specifies Date header in the following format:- 
Date: Fri, 18 Jul 2008 12:01:08 GMT
 
RFC4119 specifes retention-expiry in the following format:-
   <gp:retention-expiry>2007-07-27T18:00:00Z</gp:retention-expiry>
 
This seems like another format for representing absolute time. 
 
Could somebody provide me info, on which RFC is this absolute time based
on.
 
Any idea how this can be implemented in Linux for sending and parsing.
 
Thanks.
Regards,
Rajeev
 
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Winterbottom, James" <[email-masked]>
Date: Sun, 27 Jul 2008 16:19:33 -0500

Hi Rajeev,

The retention-expiry field in 4119 is an xml dateTime:
<xs:element name="retention-expiry" type="xs:dateTime"

The XMl dateTime is a standard XMl type defined in "W3C XML Schema Part 2: Datatypes Second Edition
W3C Recommendation 28 October 2004".

The link for this document can be found here: http://www.w3.org/TR/xmlschema-2/

The link to the dateTime definition can be found here http://www.w3.org/TR/xmlschema-2/#dateTime

When you sending and parsing, do you really mean creating?

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Rajeev Narang (ranarang)
Sent: Sun 7/27/2008 10:22 AM
To: [email-masked]
Subject: [Sip] Question on format of retention-expiry (absolute time) inRFC4119 (Presence-based GEOPRIV Location)
 
Hi,

 

 
Thanks.
Regards,
Rajeev

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: "Rajeev Narang (ranarang)" <[email-masked]>
Date: Mon, 28 Jul 2008 15:16:46 +0530

Hi James,

Thanks for this good info. 

Sending (the endpoint sending the XML to another SIP UA) - Any Linux OS
system calls (C/C++) available which can be used for constructing the
date in the xs:dateTime format expected by retention-expiry field.

Receiving- Any Linux system calls which can be used to parse the
xs:dateTime format.

Regards,
Rajeev

-----Original Message-----
From: Winterbottom, James [mailto:[email-masked]] 
Sent: Monday, July 28, 2008 2:50 AM
To: Rajeev Narang (ranarang); [email-masked]
Subject: RE: [Sip] Question on format of retention-expiry (absolute
time) inRFC4119 (Presence-based GEOPRIV Location)

Hi Rajeev,

The XMl dateTime is a standard XMl type defined in "W3C XML Schema Part
2: Datatypes Second Edition W3C Recommendation 28 October 2004".

The link for this document can be found here:
http://www.w3.org/TR/xmlschema-2/

The link to the dateTime definition can be found here
http://www.w3.org/TR/xmlschema-2/#dateTime

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Rajeev Narang (ranarang)
Sent: Sun 7/27/2008 10:22 AM
To: [email-masked]
Subject: [Sip] Question on format of retention-expiry (absolute time)
inRFC4119 (Presence-based GEOPRIV Location)
 
Hi,

 

 
Thanks.
Regards,
Rajeev

------------------------------------------------------------------------
------------------------
This message is for the designated recipient only and may contain
privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender immediately
and delete the original.  Any unauthorized use of this email is
prohibited.
------------------------------------------------------------------------
------------------------
[mf2]

---

From: "Winterbottom, James" <[email-masked]>
Date: Mon, 28 Jul 2008 05:08:33 -0500

Rajeev,

There are heaps of standard C libraries that deal with time to strings and vice versa, do a little hunting.

Cheers
James

-----Original Message-----
From: Rajeev Narang (ranarang) [mailto:[email-masked]]
Sent: Mon 7/28/2008 4:46 AM
To: Winterbottom, James; [email-masked]
Subject: RE: [Sip] Question on format of retention-expiry (absolute time) inRFC4119 (Presence-based GEOPRIV Location)
 
Hi James,

Regards,
Rajeev

-----Original Message-----
From: Winterbottom, James [mailto:[email-masked]] 
Sent: Monday, July 28, 2008 2:50 AM
To: Rajeev Narang (ranarang); [email-masked]
Subject: RE: [Sip] Question on format of retention-expiry (absolute

Hi Rajeev,

Cheers
James

-----Original Message-----
From: [email-masked] on behalf of Rajeev Narang (ranarang)
Sent: Sun 7/27/2008 10:22 AM
To: [email-masked]
Subject: [Sip] Question on format of retention-expiry (absolute time)
 
Hi,

 

 
Thanks.
Regards,
Rajeev