Subject: [Sip] Route header and transport

From: Andrey Kovalenko <[email-masked]>
Date: Thu, 31 Jul 2008 11:35:07 +0400

Hello.

I have following problem:

For example, UAC decides to send INVITE via TCP transport and does
it like so:

INVITE sip:[email-masked] SIP/2.0
Call-ID: e271e3d45ca69c0a
CSeq: 1 INVITE
From: "user" <sip:[email-masked]>;tag=1e5f7ab5
To: <sip:[email-masked]>
Via: SIP/2.0/TCP 192.168.1.4:5060;branch=z9hG4bKce32ffc97438620028ba85a78311d3cb
Max-Forwards: 70
Contact: <sip:[email-masked]:5060>
Content-Type: application/sdp
Content-Length: 227

Then OK is receivied and it looks like so

SIP/2.0 200 OK
Via: SIP/2.0/TCP
192.168.1.4:5060;branch=z9hG4bKce32ffc97438620028ba85a78311d3cb;received=192.168.1.4
Record-Route: <sip:88447-212.53.40.72.dialog.cgatepro;lr>,<sip:212.53.40.72:5060;lr>,<sip:212.53.40.40:5060;lr>
From: "user" <sip:[email-masked]>;tag=1e5f7ab5
To: <sip:[email-masked]>;tag=000000000518036-57737A9D_lnqxjfk-660DE7A8
Call-ID: e271e3d45ca69c0a
CSeq: 1 INVITE
Contact: <sip:[email-masked]>
Supported: 100rel,timer,replaces,histinfo
User-Agent: CommuniGatePro-callLeg/5.2.6
Allow: INVITE,ACK,BYE,CANCEL,OPTIONS,INFO,MESSAGE,SUBSCRIBE,NOTIFY,PRACK,REFER
Content-Type: application/sdp
Content-Length: 193

Then ACK is sent to URI that is defined in Contact header:

ACK sip:[email-masked];transport=tcp SIP/2.0
Via: SIP/2.0/TCP 192.168.1.4:5060;branch=z9hG4bKca9dbdeb9f803d0cdba2c2124abd9440
CSeq: 1 ACK
From: "user" <sip:[email-masked]>;tag=1e5f7ab5
To: <sip:[email-masked]>;tag=000000000518036-57737A9D_lnqxjfk-660DE7A8
Call-ID: e271e3d45ca69c0a
Supported: 100rel,timer,replaces,histinfo
User-Agent: CommuniGatePro-callLeg/5.2.6
Allow: INVITE,ACK,BYE,CANCEL,OPTIONS,INFO,MESSAGE,SUBSCRIBE,NOTIFY,PRACK,REFER
Max-Forwards: 70
Route: <sip:212.53.40.40:5060;lr>,<sip:212.53.40.72:5060;lr>,<sip:88447-212.53.40.72.dialog.cgatepro;lr>
Contact: <sip:[email-masked]:5060>
Content-Length: 0

Should this ACK be sent via TCP or UDP, whether URI in Route header
does not explicitly defines transport?

-- 
Best regards,
 Andrey                          mailto:[email-masked]

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Theo Zourzouvillys" <[email-masked]>
Date: Thu, 31 Jul 2008 08:50:06 +0100

> does not explicitly defines transport?

Andrey,

An ACK for a 2xx INVITE response should be sent out in the same way as
any other in-dialog request - meaning in this case it would be direct
to the IP address over UDP unless "rules of SIP define otherwise" (per
rfc3623) for example because of MTU.

 ~ Theo