Subject: [Sip] INVITE message error!!

From: "JAIN VIPUL" <[email-masked]>
Date: Tue, 15 Jul 2008 09:44:55 +0200

Hi All,

I am doing some robustness testing of my SIP stack/service. During this
I have encountered an issue and a bit doubtfull about the action.

Problem description: I injected an INVITE method with a C-style format
string error added in the request line. The message looks like

20080711 16:42:28 INVITE sip%999d:[email-masked] SIP/2.0
20080711 16:42:28 To: <sip:[email-masked]:7072>
20080711 16:42:28 From: "+33711428102"
<sip:[email-masked]:7072>;tag=00000190
20080711 16:42:28 Via: SIP/2.0/UDP
172.21.183.55:7072;branch=z9hG4bK190t1215774748676
20080711 16:42:28 Call-ID: [email-masked]
20080711 16:42:28 Contact: "+33711428102"
<sip:[email-masked]>;transport=udp
20080711 16:42:28 Content-Length: 189
20080711 16:42:28 Content-Type: application/sdp
20080711 16:42:28 CSeq: 191 INVITE
20080711 16:42:28 Max-Forwards: 70
20080711 16:42:28
20080711 16:42:28 v=0
20080711 16:42:28 o=+33711428102 1 1 IN IP4 172.21.183.55
20080711 16:42:28 c=IN IP4 172.21.183.55
20080711 16:42:28 t=0 0
20080711 16:42:28 m=audio 49152 RTP/AVP 0
20080711 16:42:28 a=rtpmap:0 PCMA/8000

As per my understaning the call should have failed with 480 response and
time out. But to my astonishment, the call completed successfully with

The discussed diagram is a success call w.r.t to my test bed. Can anyone
please explain this kind of behavior.

Thanks & Regards, 
                                       Alcatel-Lucent India Ltd.
Vipul Jain
Senior Engineer
DID: (0124) 4753540 Extn: 3540
Mobile: 09911492132 

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Tue, 15 Jul 2008 18:18:10 +0800

The req-uri has violated the syntax rule of RFC3261
 
scheme         =  ALPHA *( ALPHA / DIGIT / "+" / "-" / "." )
 
I think UAS might need to return 
 
400 Bad Request or 416 Unsupported URI Scheme.
 
BTW, this sort of question should go to 
[email-masked]
 
-Rockson 
________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
JAIN VIPUL
Sent: Tuesday, July 15, 2008 3:45 PM
To: [email-masked]
Subject: [Sip] INVITE message error!!

Hi All,

 

Thanks & Regards,