Subject: [Sip] Bug in "17.2.2 Non-INVITE Server Transaction" (RFC 3261)

From: "Iñaki Baz Castillo" <[email-masked]>
Date: Mon, 14 Jul 2008 11:06:30 +0200

Hi, "17.2.2 Non-INVITE Server Transaction" doesn't consider the case in which
the transaction state is "Trying" and the transaction receives from the TU a
final response, this is:
  - state = "Trying"
  - response from TU = final response

The only case considered is:
   "If the TU passes a final response (status
   codes 200-699) to the server while in the "Proceeding" state, the
   transaction MUST enter the "Completed" state..."

This doesn't make sense since it's totally possible that TU sends a final
response without sending before a provisional response. It's also considered
in the diagram of page 139.

PD: Is here the best place to report it?

-- 
Iñaki Baz Castillo
<[email-masked]>
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Iñaki Baz Castillo" <[email-masked]>
Date: Mon, 14 Jul 2008 11:19:19 +0200

>  PD: Is here the best place to report it?

I've reported the bug in "SIP Errata" web page:
  http://www.rfc-editor.org/errata_search.php?rfc=3261