Subject: [Sip] Current SIP status

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Wed, 9 Jul 2008 15:28:14 +0200

This is an attempt to summarise where we thing the current SIP WG items
are. Comments welcome if you think it is wrong.

Documents in RFC editor's queue (5)
===================================

draft-ietf-sip-gruu-14 (Proposed standard)
Keith Drage is document shepherd
Currently in state: In RFC Editor's Queue - MISSREF (waiting for
draft-ietf-sip-outbound).

draft-ietf-sip-consent-framework-04 (Proposed standard)
Keith Drage is document shepherd
Currently in state: In RFC Editor's Queue - MISSREF (waiting for
draft-ietf-sipping-uri-services, draft-ietf-sipping-
consent-format, draft-ietf-sipping-pending-additions)

draft-ietf-sip-uri-list-conferencing-02  (Proposed standard)
Keith Drage is document shepherd
Currently in state: In RFC Editor's Queue - MISSREF (waiting for
draft-ietf-sipping-uri-services, draft-ietf-sipping-capacity-attribute)

draft-ietf-sip-uri-list-subscribe-02  (Proposed standard)
Keith Drage is document shepherd
Currently in state: In RFC Editor's Queue - MISSREF (waiting for
draft-ietf-sipping-uri-services)

draft-munakata-sip-privacy-guideline (Informational)
Individual submission to RFC editor. Not from SIP WG.

Documents with IESG (10)
========================

draft-ietf-sip-answermode-07 (Proposed standard)
Keith Drage is PROTO document shepherd
IESG last call initiated 10th July 2007 to complete 5th August 2007.
Currently in state: IESG Evaluation :: AD Followup.

draft-ietf-sip-ice-option-tag-02 (Proposed standard)
Keith Drage is PROTO document shepherd
IESG last call initiated 2nd August 2007 to complete 16th August 2007. 
Currently in state: Approval-announcement to be sent :: External Party
Currently held by AD pending approval of draft-ietf-behave-rfc3489bis-12
and draft-ietf-behave-turn-04: "This draft is ref blocked by
ICE/STUN/TURN. There is a slight possible that a small change may be
needed here to negotiation things once TURN / STUN are all done. It is
waiting for theses to be complete to check that no change is needed here
before sending it on"

draft-ietf-sip-certs-06 (Proposed standard)
Candidate: Proposed standard
Dean Willis is PROTO document shepherd
Publication requested 1st February 2008.
Jon Peterson is responsible AD.
Currently in state: Publication requested

draft-ietf-sip-multiple-refer-03  (Proposed standard)
Keith Drage is document shepherd
IESG last call initiated 19th November 2007 to complete 10th December
2007
Currently in state: IESG Evaluation:: AD Followup

draft-ietf-sip-uri-list-message-03  (Proposed standard)
Keith Drage is document shepherd
IESG last call initiated 19th November 2007 to complete 10th December
2007
Currently in state: IESG Evaluation:: AD Followup

draft-ietf-sip-sips-08 (Proposed standard)
Dean Willis is PROTO document shepherd
Publication requested 30th April 2008.
Currently in state: Publication Requested

draft-ietf-sip-hitchhikers-guide-05 (Informational)
Keith Drage is PROTO document shepherd
Publication requested 3rd July 2008
Currently in state: Publication Requested

draft-ietf-sip-rph-new-namespaces-03 (Proposed standard)
Keith Drage is PROTO document shepherd
Publication requested 30th June 2008
Currently in state: Publication Requested

draft-ietf-sip-fork-loop-fix-07 (Proposed standard)
Keith Drage is document shepherd
IESG last call completed 14th May 2007. 
Returned to WG due to security issues 5th October 2007. WGLC initiated
7th December 2007 to complete 21st December 2007 on -06 version. 
Agreed at IETF#69 that will incorporate
draft-sparks-sipping-max-breadth-01
Publication requested 8th July 2008
Currently in state: Publication requested

draft-ietf-sip-xcapevent-03 (Proposed standard)
OMA liaison - interaction with draft-ietf-simple-xcap-diff
Publication requested 2nd July 2008
Currently in state: Publication requested

Documents returned to the WG from IESG (1)
==========================================

draft-ietf-sip-e2m-sec-06 (Proposed standard)
Dean Willis is document shepherd 
IESG last call completed 14th May 2007. No last call comments. Problems
with proposed standard status
See draft-draft-rai-sip-header-process for possible process changes to
allow progressing as experimental
Current status: Dead

Documents finished in the WG, awaiting submission to IESG (3)
=============================================================

draft-ietf-sip-session-policy-framework-03
Candidate: Proposed standard
SIPPING WG review initiated 4th August 2006 to complete 25th August 2006
WGLC initiated 21st May 2007 to complete 11th June 2007. 
Keith Drage is PROTO document shepherd
Token currently with PROTO shepherd
Milestone for submission to IESG September 2007

draft-ietf-sip-connect-reuse-10
Candidate: Proposed standard
Milestone to IESG August 2007
WGLC began 26th October 2005. WGLC announced 23rd October 2007 to
complete 6th November 2007 on -08 version. WGLC continuation announced
23rd October 2007 to complete 6th November 2007. Extended until 24th
November 2007.
Has some dependency on: 
draft-ietf-sip-domain-certs-00.txt
draft-ietf-sip-eku-00.txt
Keith Drage is PROTO document shepherd
Token currently with PROTO shepherd

draft-ietf-sip-outbound-15
Candidate: Proposed standard
Milestone for WGLC is March 2007
WGLC initiated 9th July 2007 to complete 6th August 2007. WGLC initiated
24th March 2008 to complete 21st April 2008 on -13 version. 
Milestone for sending to IESG is June 2007
Dean Willis is PROTO document shepherd
Token currently with PROTO shepherd

Documents in working group last call (6)
========================================

draft-ietf-sip-location-conveyance-10
Candidate: Proposed standard
Milestone for submission to IESG is July 2007
Review team assembled: Authors, WG chairs, Shida Schubert, Joszef Varga,
Henning Schulzrinne, Richard Barnes, Hannes Tschofenig
Waiting on GEOPRIV decision on
draft-ietf-geopriv-sip-lo-retransmission-00.txt before further WGLC
Keith Drage is PROTO document shepherd

draft-ietf-sip-subnot-etags-02
Agreed as WG item (subject to AD) at IETF#67
Candidate: proposed standard
September 2007 -- Extension for use of etags in conditional notification
to WGLC
WGLC initiated 4th September 2007 to complete 18th September 2007
Token: Waiting on resolution of WGLC comments from editor then expected
to be finished in WG - WG asked to review
Dean Willis is PROTO document shepherd
December 2007 -- Extension for use in etags in conditional notification
to IESG (PS)

draft-ietf-sip-domain-certs-00
Candidate: Informational (subject to some more discussion)
Milestone for WGLC November 2007
WGLC initiated 22nd February 2008 to complete 7th March 2008
Keith Drage is PROTO document shepherd
Milestone for submission to IESG January 2008

draft-ietf-sip-eku-01
Candidate: Proposed standard
Milestone for WGLC November 2007
WGLC initiated 22nd February 2008 to complete 7th March 2008
Keith Drage is PROTO document shepherd
Milestone for submission to IESG January 2008

draft-ietf-sip-media-security-requirements-07
Candidate: Informational
Milestone for WGLC September 2007
WGLC initiated 22nd March 2008 to complete 7th April 2008 on -04 version
Dean Willis is PROTO document shepherd
Milestone for submission to IESG November 2007

draft-ietf-sip-body-handling-02
Candidate: Proposed standard
Milestone for WGLC January 2008
WGLC initiated 5th June 2008 to complete 11th July 2008
Dean Willis is PROTO document shepherd
Milestone for submission to IESG April 2008

Documents still in discussion in working group (7)
==================================================

draft-ietf-sip-sec-flows-01
Candidate: Informational
Milestone for WGLC is July 2007
Milestone for submission to IESG is September 2007
To a certain extent dependent on resolution of ideas in (and therefore
waiting on them):
draft-ietf-sip-sips-02  
draft-gurbani-sip-domain-certs-04 
Draft expired and removed from drafts directory 

draft-ietf-sip-saml-03
Candidate: Proposed standard
Milestone for WGLC is September 2007
Milestone for submission to IESG is December 2007
Need milestone revision to post IETF#72

draft-rosenberg-sip-ua-loose-route-00
Agreed as WG item at IETF#67
Candidate: proposed standard
December 2007: Delivering request-URI and parameters to UAS via proxy to
WGLC
February 2008: Delivering request-URI and parameters to UAS via proxy to
IESG (PS)
 
draft-ietf-sip-ua-privacy-01
Candidate: Best Current Practice (we may downgrade / upgrade this based
on discussion of the contents)
Milestone for WGLC May 2008
Milestone for submission to IESG July 2008
Needs discussion of what we really need to say in such a document

draft-ietf-sip-dtls-srtp-framework-01
Candidate: Proposed standard
Milestone for WGLC December 2007
Dean Willis is PROTO document shepherd
Milestone for submission to IESG February 2008
 
draft-ietf-sip-record-route-fix-02
Candidate: Proposed standard
Milestone for WGLC May 2008
Milestone for submission to IESG Aug 2008

draft-ietf-sip-199-00
Candidate: Proposed standard
Milestone for WGLC Sep 2008
Milestone for submission to IESG Nov 2008

Essential corrections
======================

Milestone: 1st batch to IESG in April 2008
Robert Sparks to be lead editor
Process in draft-drage-sip-essential-correction-03
Will roll in RFC 3420 and draft-ietf-sip-fork-loop-fix in first
published version of RFC 3261 update
See:
http://www.softarmor.com/mediawiki/index.php/Essential_Corrections_Track
ing
Current documents under consideration:
draft-ietf-sip-ipv6-abnf-fix-02 (WGLC complete)
draft-sparks-sip-invfix-02 (WGLC in progress)

Identify requirements for test matrix to move SIP to Draft Standard
===================================================================

Milestone Feb 2008
Robert Sparks coordinating input
draft-sparks-sip-steps-to-draft-00 contains a proposal
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Thomas Froment <[email-masked]>
Date: Wed, 09 Jul 2008 15:33:12 +0200

Hi Keith,
> Candidate: Proposed standard
This one is "Candidate: Best current practice" and not "Proposed standard".
Thomas

---

From: Robert Sparks <[email-masked]>
Date: Wed, 9 Jul 2008 09:51:39 -0500

> Draft expired and removed from drafts directory

This should be resurrected already (that is, in the repository).

This draft _is_ getting cycles, but I do not anticipate a revision  
before Dublin at this time.

RjS

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 9 Jul 2008 09:26:30 -0700

draft-ietf-sip-media-security-requirements-07 has accurate text describing it,
but it is in the wrong section -- it should be in the "Documents finished in
the WG, awaiting submission to IESG" section.

-d

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of DRAGE, Keith (Keith)
> Sent: Wednesday, July 09, 2008 6:28 AM
> To: [email-masked]
> Subject: [Sip] Current SIP status
>