Subject: [Sip] SDP in 200 OK?

From: Thomas george <[email-masked]>
Date: Wed, 20 Aug 2008 06:35:39 -0700 (PDT)

What will be SDP in the 200 OK to INVITE, if PRACK with Answer and UPDATE transaction happened before the INVITE's 200 is sent?
rgds,
Thomas

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Jagan Mohan" <[email-masked]>
Date: Wed, 20 Aug 2008 19:38:13 +0530

Assuming that Offer-Answer has completed before sending 200 OK to INVITE,
it's recommended not to send SDP in the 200 OK. Even if the UAS sends SDP in
200 OK to INVITE, UAC should be able to accept the response, ignore the SDP
and send ACK to the UAS.

Regards,
Jagan

On Wed, Aug 20, 2008 at 7:05 PM, Thomas george <[email-masked]>wrote:

>  What will be SDP in the 200 OK to INVITE, if PRACK with Answer and UPDATE
> transaction happened before the INVITE's 200 is sent?
>
>
>
> rgds,
>
> Thomas
>
>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 20 Aug 2008 10:15:55 -0400

See 
http://www.ietf.org/internet-drafts/draft-ietf-sipping-sip-offeranswer-08.txt

In short, its legal for it to either be absent, or same as the first 
answer. Absent is preferred.

	Thanks,
	Paul

Thomas george wrote:
>  What will be SDP in the 200 OK to INVITE, if PRACK with Answer and 
> UPDATE transaction happened before the INVITE's 200 is sent?
> 
>  
> 
> rgds,
> 
> Thomas
> 
> 
> 
> ------------------------------------------------------------------------
>