Subject: [Sip] draft-ietf-sip-fork-loop-fix-07: is the second part of branch of present when req forked?

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Sun, 17 Aug 2008 21:22:42 +0800

Hi folks,
 
One question on draft-ietf-sip-fork-loop-fix-07,
 
sec 4.2.2
 
This second part
   will not be present if the message was not forked when that Via
   header field value was added.
 
I am not sure why?
from sec 4.2.1, I  do NOT see there's any constraints that the second
party would be added only when the msg is forked.
 
thanks
 
Regards,
-Rockson
_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Robert Sparks <[email-masked]>
Date: Mon, 18 Aug 2008 11:10:38 -0500

What you are looking for is in this paragraph in 4.2.1:

    Proxies required to perform loop-detection by RFC XXXX (RFC-Editor:
    replace XXXX with the RFC number of this document) have an  
additional
    constraint on the value they place in the Via header field.  Such
    proxies SHOULD create a branch value separable into two parts in any
    implementation dependent way.  The first part MUST satisfy the
    constraints of Section 8.1.1.7.  The second part is used to perform
    loop detection and distinguish loops from spirals.

On Aug 17, 2008, at 8:22 AM, Rockson Li (zhengyli) wrote:

> from sec 4.2.1, I  do NOT see there's any constraints that the  
> second party would be added only when the msg is forked.
>
> thanks
>
> Regards,
> -Rockson

---

From: "Rockson Li (zhengyli)" <[email-masked]>
Date: Tue, 19 Aug 2008 11:07:03 +0800

Robert,
 
yes, 4.2.1 just says Proxies required to perform loop-detection SHOULD
create a branch value separable into two parts ,
 
it does not say only when proxy need fork the req , it will add the
second part.
 
So I don't see it means as sec 4.2.2,
 
   This second part
 
Thanks
 
-Rockson

________________________________

From: Robert Sparks [mailto:[email-masked]] 
Sent: Tuesday, August 19, 2008 12:11 AM
To: Rockson Li (zhengyli)
Cc: [email-masked]
Subject: Re: [Sip] draft-ietf-sip-fork-loop-fix-07: is the second part
of branch of present when req forked?

   replace XXXX with the RFC number of this document) have an additional

	Hi folks,

	sec 4.2.2
	 
	This second part
	   will not be present if the message was not forked when that
Via
	   header field value was added.
	 
	I am not sure why?
	 
	thanks
	 
	Regards,
	-Rockson
	_______________________________________________
	Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
	This list is for NEW development of the core SIP Protocol
	Use [email-masked] for questions on current
sip
	Use [email-masked] for new developments on the application of
sip

---

From: Robert Sparks <[email-masked]>
Date: Mon, 18 Aug 2008 22:29:31 -0500

Well, that's a direct consequence of the "have an additional  
constraint" clause.
But since that's not making immediate sense to you, I'll see if  
there's a better way to phrase it.

RjS

On Aug 18, 2008, at 10:07 PM, Rockson Li (zhengyli) wrote:

> Robert,
>
> yes, 4.2.1 just says Proxies required to perform loop-detection  
> SHOULD create a branch value separable into two parts ,
>
> Subject: Re: [Sip] draft-ietf-sip-fork-loop-fix-07: is the second  
> part of branch of present when req forked?
>