Subject: Re: [Sip] draft-ietf-sip-location-conveyance - Question about potential usage of the Geolocation header

From: "Brian Rosen" <[email-masked]>
Date: Wed, 13 Aug 2008 16:24:26 -0400

You can use the "HELD" protocol, rather than a SIP SUBSCRIBE/NOTIFY for the
dereference, if that makes it seem simpler to you.  SUBSCRIBE/NOTIFY is
quite simple, and most devices and services implement it for other reasons.

We have discussed using cell-id as a representation mechanism, but have been
told, many times, that operators will not divulge location of cell ids
beyond the immediate network, which makes this form of location entirely
unsuitable for the range of applications we envisioned.   If you have
different information, please share it.

On the other hand, even if we did allow cell id as a form of location, it
would be inside a PIDF-LO, and thus would need to be in a body.

I don't think putting actual location in the header is a good idea, as it
cannot be protected against inadvertent disclosure.  That would be a problem
in the IETF.

Brian
________________________________________
From: Bartłomiej Kołakowski [mailto:[email-masked]] 
Sent: Wednesday, August 13, 2008 10:04 AM
To: [email-masked]; [email-masked]
Subject: draft-ietf-sip-location-conveyance - Question about potential usage
of the Geolocation header

Hello, 
I have got such concern regarding location conveyance in SIP messages: I am
designing IMS Appilcation Server, acting as a proxy, that would query
network elements for location information. As you wrote proxies cannot
insert message body, so the only way is to provide location by reference.
This requires appling SUBSCRIBE-NOTIFY mechanism, which makes the
architecture of the solution quit complex.
In order to make it simpler I thought about including location information
as locationValue inside the Geolocation header. In fact we do not need
location represented with coordinates, but with cell-id (that's mobile
network). PIDF-LO does not support it, but maybe inside a header that would
be possible? There would be also an issue in indicating loaction target
whose location is included (we plan to include both A and B parties
location). Geolocation header would look like this:
Geolocation: {cell-id-3gpp}
;location-target="[email-masked]";inserted-by="[email-masked]" 
What do you think about souch a usage of Geolocation header, maybe you could
give us some other solution? 
Thank you in advance, 
Bartłomiej Kołakowski 
Service Solutions Architect 
Service Development Support Department 
Polkomtel S.A 
tel. 601131509 

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Bartłomiej Kołakowski <[email-masked]>
Date: Wed, 13 Aug 2008 16:03:54 +0200

Hello,

I have got such concern regarding location conveyance in SIP messages: I am designing IMS Appilcation Server, acting as a proxy, that would query network elements for location information. As you wrote proxies cannot insert message body, so the only way is to provide location by reference. This requires appling SUBSCRIBE-NOTIFY mechanism, which makes the architecture of the solution quit complex.

In order to make it simpler I thought about including location information as locationValue inside the Geolocation header. In fact we do not need location represented with coordinates, but with cell-id (that's mobile network). PIDF-LO does not support it, but maybe inside a header that would be possible? There would be also an issue in indicating loaction target whose location is included (we plan to include both A and B parties location). Geolocation header would look like this:

Geolocation: {cell-id-3gpp} ;location-target="[email-masked]";inserted-by="[email-masked]"

What do you think about souch a usage of Geolocation header, maybe you could give us some other solution?

Thank you in advance,

Bartłomiej Kołakowski

---

From: Dean Willis <[email-masked]>
Date: Mon, 18 Aug 2008 12:00:09 -0500

On Aug 13, 2008, at 9:03 AM, Bartłomiej Kołakowski wrote:

> Hello,
>
> I have got such concern regarding location conveyance in SIP  
> messages: I am designing IMS Appilcation Server, acting as a proxy,  
> that would query network elements for location information. As you  
> wrote proxies cannot insert message body, so the only way is to  
> provide location by reference. This requires appling SUBSCRIBE- 
> NOTIFY mechanism, which makes the architecture of the solution quit  
> complex.
>
> In order to make it simpler I thought about including location  
> information as locationValue inside the Geolocation header. In fact  
> we do not need location represented with coordinates, but with cell- 
> id (that's mobile network). PIDF-LO does not support it, but maybe  
> inside a header that would be possible? There would be also an issue  
> in indicating loaction target whose location is included (we plan to  
> include both A and B parties location). Geolocation header would  
> look like this:
>

have you looked at RC 3455? This defines IMS headers for cell-ID based  
location.

--
Dean

---

From: Bartłomiej Kołakowski <[email-masked]>
Date: Tue, 19 Aug 2008 14:58:48 +0200

Yes, I have, namely the P-Access-Network-Info header.
There are two problems with it:
1. I cannot included called (B) party cell-id in it.
2. RFC says that proxy cannot insert this header, however I guess 3GPP allows P-CSCF to do it. Anyway in my case it will be an IMS AS retrieving location, acting as a proxy.

So I doubt it would be a suited solution.

Bartek

-----Original Message-----
From: Dean Willis [mailto:[email-masked]] 
Sent: Monday, August 18, 2008 7:00 PM
To: Bartłomiej Kołakowski
Cc: [email-masked]; [email-masked]
Subject: Re: [Sip] draft-ietf-sip-location-conveyance - Question about potential usage of the Geolocation header

On Aug 13, 2008, at 9:03 AM, Bartłomiej Kołakowski wrote:

> provide location by reference. This requires appling SUBSCRIBE- NOTIFY 
> mechanism, which makes the architecture of the solution quit complex.
>
> information as locationValue inside the Geolocation header. In fact we 
> do not need location represented with coordinates, but with cell- id 
> (that's mobile network). PIDF-LO does not support it, but maybe inside 
> a header that would be possible? There would be also an issue in 
> indicating loaction target whose location is included (we plan to 
> include both A and B parties location). Geolocation header would look 
> like this:
>

---

From: Dean Willis <[email-masked]>
Date: Wed, 20 Aug 2008 13:03:21 -0500

> 1. I cannot included called (B) party cell-id in it.

How do you know the B-party's cell ID in advance of a response coming  
back from them? The usual way to do this in SIP is to have the B-party  
information in a message coming from the B-party terminal, because  
until the call resolves into a response (or a request coming from the  
B-party), one doesn't know which of potentially many B-party terminals  
might answer.

Of course, your proxy might be prescient, in which case I'd like to  
ask for its help in managing my stock portfolio . . .

>
> 2. RFC says that proxy cannot insert this header, however I guess  
> 3GPP allows P-CSCF to do it. Anyway in my case it will be an IMS AS  
> retrieving location, acting as a proxy.
>

Theoretically the mobile inserts it, but I'm not currently cognizant  
of any technical reason why a proxy (such as P-CSCF) couldn't do it.

--
Dean

---

From: "Brian Rosen" <[email-masked]>
Date: Thu, 28 Aug 2008 13:03:39 -0400

There is no standard to include a cell-id in a PIDF-LO.  It has been
discussed 2-3 times and the consensus was that it's a bad idea.

Brian

> Sent: Thursday, August 28, 2008 10:32 AM
> To: Brian Rosen; [email-masked];
> [email-masked]
> Subject: RE: draft-ietf-sip-location-conveyance - Question about potential
> usage of the Geolocation header
> 
> Thanks for reply Brian.
> Probably we'll go for the SUBSCRIBE/NOTIFY option. We'd rather keep cell
> ids inside our network, but anyway it's not really possible (see Google's
> My Location). So far we won't have any 3rd parties connected to IMS
> though.
> 
> Do you know if there is any standard to include a cell-id into PIDF-LO?
> 
> Bartek
> 
> 
> From: Brian Rosen [mailto:[email-masked]]
> Sent: Wednesday, August 13, 2008 10:24 PM
> To: Bartłomiej Kołakowski; draft-ietf-sip-location-
> [email-masked]; [email-masked]
> Subject: RE: draft-ietf-sip-location-conveyance - Question about potential
> usage of the Geolocation header
> 
> You can use the "HELD" protocol, rather than a SIP SUBSCRIBE/NOTIFY for
> the dereference, if that makes it seem simpler to you.  SUBSCRIBE/NOTIFY
> is quite simple, and most devices and services implement it for other
> reasons.
> 
> We have discussed using cell-id as a representation mechanism, but have
> been told, many times, that operators will not divulge location of cell
> ids beyond the immediate network, which makes this form of location
> entirely
> cannot be protected against inadvertent disclosure.  That would be a
> problem in the IETF.
> 
> Brian
> Subject: draft-ietf-sip-location-conveyance - Question about potential
> usage of the Geolocation header
> 
> Hello,
> I have got such concern regarding location conveyance in SIP messages: I
> am designing IMS Appilcation Server, acting as a proxy, that would query
> network). PIDF-LO does not support it, but maybe inside a header that
> would be possible? There would be also an issue in indicating loaction
> target whose location is included (we plan to include both A and B parties

---

From: "Winterbottom, James" <[email-masked]>
Date: Thu, 28 Aug 2008 20:01:01 -0500

Depending on you application, providing a location by reference does not require a subscribe notification, though it does require a dereference.
http://tools.ietf.org/html/draft-winterbottom-geopriv-deref-protocol-02 is one example of how you can do this without a SUBSCRIBE/NOTIFY.

Cheers
James

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Brian Rosen
> Sent: Friday, 29 August 2008 3:04 AM
> To: 'Bartłomiej Kołakowski'; draft-ietf-sip-location-
> Subject: Re: [Sip] draft-ietf-sip-location-conveyance - Question
> aboutpotential usage of the Geolocation header
> 
> information

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]

---

From: Bartłomiej Kołakowski <[email-masked]>
Date: Thu, 28 Aug 2008 16:31:37 +0200

Thanks for reply Brian.
Probably we'll go for the SUBSCRIBE/NOTIFY option. We'd rather keep cell ids inside our network, but anyway it's not really possible (see Google's My Location). So far we won't have any 3rd parties connected to IMS though.

Bartek

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Wednesday, August 13, 2008 10:24 PM
To: Bartłomiej Kołakowski; [email-masked]; [email-masked]
Subject: RE: draft-ietf-sip-location-conveyance - Question about potential usage of the Geolocation header

You can use the "HELD" protocol, rather than a SIP SUBSCRIBE/NOTIFY for the dereference, if that makes it seem simpler to you.  SUBSCRIBE/NOTIFY is quite simple, and most devices and services implement it for other reasons.

We have discussed using cell-id as a representation mechanism, but have been told, many times, that operators will not divulge location of cell ids beyond the immediate network, which makes this form of location entirely
unsuitable for the range of applications we envisioned.   If you have
different information, please share it.

On the other hand, even if we did allow cell id as a form of location, it would be inside a PIDF-LO, and thus would need to be in a body.

I don't think putting actual location in the header is a good idea, as it cannot be protected against inadvertent disclosure.  That would be a problem in the IETF.

Brian
Subject: draft-ietf-sip-location-conveyance - Question about potential usage of the Geolocation header

Hello,
I have got such concern regarding location conveyance in SIP messages: I am designing IMS Appilcation Server, acting as a proxy, that would query network elements for location information. As you wrote proxies cannot insert message body, so the only way is to provide location by reference.
This requires appling SUBSCRIBE-NOTIFY mechanism, which makes the architecture of the solution quit complex.
In order to make it simpler I thought about including location information as locationValue inside the Geolocation header. In fact we do not need location represented with coordinates, but with cell-id (that's mobile network). PIDF-LO does not support it, but maybe inside a header that would be possible? There would be also an issue in indicating loaction target whose location is included (we plan to include both A and B parties location). Geolocation header would look like this:
Geolocation: {cell-id-3gpp}
;location-target="[email-masked]";inserted-by="[email-masked]" 
What do you think about souch a usage of Geolocation header, maybe you could give us some other solution? 
Thank you in advance,
Bartłomiej Kołakowski
Service Solutions Architect
Service Development Support Department
Polkomtel S.A
tel. 601131509

---

From: Bartłomiej Kołakowski <[email-masked]>
Date: Fri, 29 Aug 2008 17:05:44 +0200

In that case we will try to extend PIDF-LO and add a cell-id tag under <location-info>.

Best wishes,
Bartek 

-----Original Message-----
From: Brian Rosen [mailto:[email-masked]] 
Sent: Thursday, August 28, 2008 7:04 PM
To: Bartłomiej Kołakowski; [email-masked]; [email-masked]
Subject: RE: draft-ietf-sip-location-conveyance - Question about potential usage of the Geolocation header

There is no standard to include a cell-id in a PIDF-LO.  It has been discussed 2-3 times and the consensus was that it's a bad idea.

Brian

> Subject: RE: draft-ietf-sip-location-conveyance - Question about 
> potential usage of the Geolocation header
> 
> Thanks for reply Brian.
> Probably we'll go for the SUBSCRIBE/NOTIFY option. We'd rather keep 
> cell ids inside our network, but anyway it's not really possible (see 
> Google's My Location). So far we won't have any 3rd parties connected 
> to IMS though.
> 
> Subject: RE: draft-ietf-sip-location-conveyance - Question about 
> potential usage of the Geolocation header
> 
> You can use the "HELD" protocol, rather than a SIP SUBSCRIBE/NOTIFY 
> for the dereference, if that makes it seem simpler to you.  
> SUBSCRIBE/NOTIFY is quite simple, and most devices and services 
> implement it for other reasons.
> 
> We have discussed using cell-id as a representation mechanism, but 
> have been told, many times, that operators will not divulge location 
> of cell ids beyond the immediate network, which makes this form of 
> location entirely
> On the other hand, even if we did allow cell id as a form of location, 
> it would be inside a PIDF-LO, and thus would need to be in a body.
> 
> I don't think putting actual location in the header is a good idea, as 
> it cannot be protected against inadvertent disclosure.  That would be 
> a problem in the IETF.
> 
> Brian
> I have got such concern regarding location conveyance in SIP messages: 
> I am designing IMS Appilcation Server, acting as a proxy, that would 
> query network elements for location information. As you wrote proxies 
> cannot insert message body, so the only way is to provide location by reference.
> do not need location represented with coordinates, but with cell-id 
> include both A and B parties location). Geolocation header would look like this:
> Service Development Support Department Polkomtel S.A tel. 601131509