Subject: [Sip] rfc3261: default contact q-value

From: Brett Tate <[email-masked]>
Date: Wed, 11 Feb 2009 16:00:09 -0800

Greetings,

Within RFC 3261, I was unable to find a default q-value for Contact.

Versions 2 through 4 of draft-ietf-sip-rfc2543bis indicated 0.5 as default.  It looks like it was unintentionally removed; however I'm not certain.

What is the default Contact q-value and where is it documented?

Thanks,
Brett

---

From: "Kanumuri, Sreeram" <[email-masked]>
Date: Wed, 11 Feb 2009 16:11:38 -0800

Hi Brett,

The default value of q-value is 1.

I am not sure when but there was discussion in sip implementers list some time back on this.

It takes from HTTP where it is mentioned default is 1 when not specified.

HTH,
Sreeram

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Brett Tate
Sent: Wednesday, February 11, 2009 4:00 PM
To: SIP
Subject: [Sip] rfc3261: default contact q-value

Greetings,

Thanks,
Brett

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: Victor Pascual Ávila <[email-masked]>
Date: Thu, 12 Feb 2009 11:00:47 +0100

> The default value of q-value is 1.

https://lists.cs.columbia.edu/pipermail/sip-implementors/2005-November/011237.html

> It takes from HTTP where it is mentioned default is 1 when not specified.

https://lists.cs.columbia.edu/pipermail/sip-implementors/2005-November/011238.html

Regards,
-- 
Victor Pascual Ávila

---

From: Brett Tate <[email-masked]>
Date: Thu, 12 Feb 2009 05:42:14 -0800

Thanks for the responses, especially the reference to RFC 3841.

I guess the working group agreed to remove it from being "0.5" (or documented within the rfc2543bis) when creating draft-ietf-sip-rfc2543bis-05 and agreed to start documenting it as "1.0" within draft-ietf-sip-callerprefs-06.

Including the default value for "q" within the base specification sounds better to me; however documenting the default within RFC 3841 (or non SIP RFCs as some have indicated) might be adequate.

> Sent: Wednesday, February 11, 2009 7:00 PM
> To: SIP
> Versions 2 through 4 of draft-ietf-sip-rfc2543bis indicated 0.5 as
> default.  It looks like it was unintentionally removed; however I'm not
> certain.
>