Subject: [Sip] Is Contact Header mandatory in REFER message?

From: <[email-masked]>
Date: Mon, 2 Feb 2009 11:50:39 +0530

Hi,

Is it mandatory to have a Contact Header field in REFER message?

RFC 3261            SIP: Session Initiation Protocol           June 2002

8.1.1.8 Contact
 
   The Contact header field provides a SIP or SIPS URI that can be used
   to contact that specific instance of the UA for subsequent requests.
   The Contact header field MUST be present and contain exactly one SIP
   or SIPS URI in any request that can result in the establishment of a
   dialog.  For the methods defined in this specification, that includes
   only the INVITE request.  For these requests, the scope of the
   Contact is global.  That is, the Contact header field value contains
   the URI at which the UA would like to receive requests, and this URI
   MUST be valid even if used in subsequent requests outside of any
   dialogs.
 
   If the Request-URI or top Route header field value contains a SIPS
   URI, the Contact header field MUST contain a SIPS URI as well.

 

RFC 3515                  The SIP Refer Method                April 2003

2. The REFER Method
 
   REFER is a SIP method as defined by RFC 3261 [1].  The REFER method
   indicates that the recipient (identified by the Request-URI) should
   contact a third party using the contact information provided in the
   request.
 
   Unless stated otherwise, the protocol for emitting and responding to
   a REFER request are identical to those for a BYE request in [1].  The
   behavior of SIP entities not implementing the REFER (or any other
   unknown) method is explicitly defined in [1].
 
   A REFER request implicitly establishes a subscription to the refer
   event.  Event subscriptions are defined in [2].
 
   A REFER request MAY be placed outside the scope of a dialog created
   with an INVITE.  REFER creates a dialog, and MAY be Record-Routed,
   hence MUST contain a single Contact header field value.  REFERs
   occurring inside an existing dialog MUST follow the Route/Record-
   Route logic of that dialog.

Regards,

Sunil

_______________________________________________
Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
This list is for NEW development of the core SIP Protocol
Use [email-masked] for questions on current sip
Use [email-masked] for new developments on the application of sip

---

From: "Sanjay Sinha (sanjsinh)" <[email-masked]>
Date: Mon, 2 Feb 2009 03:47:50 -0500

Yes

________________________________

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of [email-masked]
	Sent: Monday, February 02, 2009 11:51 AM
	To: [email-masked]
	Subject: [Sip] Is Contact Header mandatory in REFER message?

	Hi,

	 

	RFC 3261            SIP: Session Initiation Protocol
June 2002

	8.1.1.8 Contact
	 
	   The Contact header field provides a SIP or SIPS URI that can
be used
	   to contact that specific instance of the UA for subsequent
requests.
	   The Contact header field MUST be present and contain exactly
one SIP
	   or SIPS URI in any request that can result in the
establishment of a
	   dialog.  For the methods defined in this specification, that
includes
	   only the INVITE request.  For these requests, the scope of
the
	   Contact is global.  That is, the Contact header field value
contains
	   the URI at which the UA would like to receive requests, and
this URI
	   MUST be valid even if used in subsequent requests outside of
any
	   dialogs.
	 
	   If the Request-URI or top Route header field value contains a
SIPS
	   URI, the Contact header field MUST contain a SIPS URI as
well.

	 

	RFC 3515                  The SIP Refer Method
April 2003

	2. The REFER Method
	 
	   REFER is a SIP method as defined by RFC 3261 [1].  The REFER
method
	   indicates that the recipient (identified by the Request-URI)
should
	   contact a third party using the contact information provided
in the
	   request.
	 
	   Unless stated otherwise, the protocol for emitting and
responding to
	   a REFER request are identical to those for a BYE request in
[1].  The
	   behavior of SIP entities not implementing the REFER (or any
other
	   unknown) method is explicitly defined in [1].
	 
	   A REFER request implicitly establishes a subscription to the
refer
	   event.  Event subscriptions are defined in [2].
	 
	   A REFER request MAY be placed outside the scope of a dialog
created
	   with an INVITE.  REFER creates a dialog, and MAY be
Record-Routed,
	   hence MUST contain a single Contact header field value.
REFERs
	   occurring inside an existing dialog MUST follow the
Route/Record-
	   Route logic of that dialog.

	Regards,

	Sunil

---

From: <[email-masked]>
Date: Wed, 4 Feb 2009 15:07:30 +0530

Thanks Sanjay.

So, is the Contact Header mandatory for all SIP messages (Response and
Requests)?

Regards,

Sunil

From: Sanjay Sinha (sanjsinh) [mailto:[email-masked]] 
Sent: Monday, February 02, 2009 2:18 PM
To: Sunil Bhagat (WT01 - Telecom Equipment); [email-masked]
Subject: RE: [Sip] Is Contact Header mandatory in REFER message?

Yes

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Monday, February 02, 2009 11:51 AM
To: [email-masked]
Subject: [Sip] Is Contact Header mandatory in REFER message?

Hi,

 

 

8.1.1.8 Contact

 

2. The REFER Method

 

 

Regards,

Sunil