Subject: Re: [Sip] Reuse of Sip Call-Id question...

From: "Attila Sipos" <[email-masked]>
Date: Fri, 5 Jun 2009 16:15:33 +0100

you will get the same response here as on sip-core.
 
SIP call-id should be unique for each call, it cannot be re-used
 
Regards,

Attila

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Cahall, Glenn
Sent: 04 June 2009 17:46
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked]
Subject: [Sip] Reuse of Sip Call-Id question...

Folks,

I work for a VoIP company, Level3 Communications, and have been doing
some research on the internet about 

a specific condition that has arisen here dealing with the Sip protocol.
Your names came up during my research.

Was hoping I could get some feedback about the reuse of Sip Call-Id.

We have customer UAs that are reusing the same Sip Call-Id for multiple
call attempts into our network.  

After reviewing the Sip RFC 3261, both myself and my team concluded that
this was a clear violation of the spec.  based 

on the following verbiage...

8.1.1.4 Call-ID

   The Call-ID header field acts as a unique identifier to group

   together a series of messages.  It MUST be the same for all requests

   and responses sent by either UA in a dialog.  It SHOULD be the same

   in each registration from a UA.

   In a new request created by a UAC outside of any dialog, the Call-ID

   header field MUST be selected by the UAC as a globally unique

   identifier over space and time unless overridden by method-specific

   behavior.  All SIP UAs must have a means to guarantee that the Call-

   ID header fields they produce will not be inadvertently generated by

   any other UA.  Note that when requests are retried after certain

However, some voice engineers are stating that the definition of
"globally unique over time and space"  means only during the 

context of a given call.  Therefore, once this context is over....Sip
Call-Id can in fact be reused in the very next context.

What is your take on this?

Thanks,

Glenn E. Cahall

Sr. Architect

Level3 Communications

---

From: Martin Larochelle <[email-masked]>
Date: Fri, 5 Jun 2009 11:45:36 -0400

This is right, although it does not mean that each call attempt must use a
new call-id.You wrote that "We have customer UAs that are reusing the same
Sip Call-Id for multiple call attempts into our network.", if by attempt,
you mean trying to make a call that fails with a error that can be retried
(as 407, 422) then in that case, it is acceptable to use the same call-id (
with an incremented C-Seq and empty to-tag)

-- 
Martin Larochelle
Software Architect

On Fri, Jun 5, 2009 at 11:15 AM, Attila Sipos
<[email-masked]>wrote:

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Cahall,
> Glenn
> *Sent:* 04 June 2009 17:46
> *To:* [email-masked]; [email-masked]; [email-masked];
> *Subject:* [Sip] Reuse of Sip Call-Id question...
>
>  Folks,
>
> I work for a VoIP company, Level3 Communications, and have been doing some
> research on the internet about
>
> “globally unique over time and space”  means only during the
>
> .
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>