Subject: [Sip] Usage of the 'Route' header.

From: Yoav Gaziel <[email-masked]>
Date: Sun, 9 Aug 2009 09:36:17 +0300

Hi,

Regarding the usage of the Route header. Must this header also appear in the
RESPONSE to a request in which this header appeared, or we can rely on the
'Via' header for routing the response back to the sender?

I've read the relevant RFC's and couldn't find an explicit reference for
this matter. If someone can point me to the exact clause and RFC I'll be
grateful. Also, an explicit authoritative answer would be much appreciated.

(Note that i'm talking about the 'Route' field, and not the 'Record-Route'
field for which there are alot of references in the RFCs)

Thanks,
Yoav.

---

From: "Christer Holmberg" <[email-masked]>
Date: Sun, 9 Aug 2009 13:07:56 +0200

Hi,
 
You always rely on the Via for routing responses back to the sender. You
never rely on the Route header for routing responses.
 
Regards,
 
Christer

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Yoav Gaziel
Sent: Sunday, August 09, 2009 9:36 AM
To: [email-masked]
Subject: [Sip] Usage of the 'Route' header.

Hi,
 
Regarding the usage of the Route header. Must this header also appear in
the RESPONSE to a request in which this header appeared, or we can rely
on the 'Via' header for routing the response back to the sender?
 
I've read the relevant RFC's and couldn't find an explicit reference for
this matter. If someone can point me to the exact clause and RFC I'll be
grateful. Also, an explicit authoritative answer would be much
appreciated.
 
(Note that i'm talking about the 'Route' field, and not the
'Record-Route' field for which there are alot of references in the RFCs)
 
Thanks,
Yoav.

---

From: Tomasz Zieleniewski <[email-masked]>
Date: Sun, 9 Aug 2009 22:12:56 +0200

Hi Yoav,

Route header is used only for request routuing,
responses have different procedures which utilize the Via header values.
BTW some time ago I wrote a short post about Route header, might give u some
more info.
http://ictbackyard.com/?p=10

Kind regards,
- Tomasz Zieleniewski

2009/8/9 Yoav Gaziel <[email-masked]>

> the RESPONSE to a request in which this header appeared, or we can rely on
> the 'Via' header for routing the response back to the sender?
>
> _______________________________________________
> Sip mailing list  https://www.ietf.org/mailman/listinfo/sip
> This list is for NEW development of the core SIP Protocol
> Use [email-masked] for questions on current sip
> Use [email-masked] for new developments on the application of sip
>