Subject: [Sip] Contact header in 200 OK

From: sandip gangakhedkar <[email-masked]>
Date: Thu, 6 Aug 2009 20:15:51 +0530

Hi all,

I'd like to know if the Contact header is mandatory for a 200 OK response to
an INVITE request.

The RFC doesnt explicitly mention anything in this regard although a 200 OK
is mandatory for a REGISTER request.

If the originating endpoint receives the Contact header in the 180 Ringing
response (which I assume is mandatory), then it knows the location of the
remote endpoint, in which case the Contact header would be redundant in the
200 OK response.

Waiting for some expert intervention.. :)

Regards,
-- 
Sandip Gangakhedkar
Mobile:+91-97396-99916
Office: +91-80-4363-3899
Profile: http://www.linkedin.com/in/sandipg

---

From: "T Satyanarayana-A12694" <[email-masked]>
Date: Fri, 7 Aug 2009 21:47:32 +0800

The RFC does mention this. In table 2, on page 162.
 
      Header field          where   proxy ACK BYE CAN INV OPT REG
      ___________________________________________________________
      Contact                2xx           -   -   -   m   o   o

regards
Satya T

________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf Of
sandip gangakhedkar
Sent: Thursday, August 06, 2009 8:16 PM
To: [email-masked]
Subject: [Sip] Contact header in 200 OK

Hi all,

I'd like to know if the Contact header is mandatory for a 200 OK
response to an INVITE request. 

The RFC doesnt explicitly mention anything in this regard although a 200
OK is mandatory for a REGISTER request.

If the originating endpoint receives the Contact header in the 180
Ringing response (which I assume is mandatory), then it knows the
location of the remote endpoint, in which case the Contact header would
be redundant in the 200 OK response.

Regards,

---

From: "Goyal, Devki" <[email-masked]>
Date: Fri, 7 Aug 2009 10:36:04 -0400

Hello Sandip
Why do you say that RFC doesn't talk about Contact for 200 OK response of INVITE?
It says that Contact header is mandatory for INVITE response only.

Contact                2xx           -   -   -   m   o   o

For OPTIONS, REGISTER it is optional and for rest of the messages (BYE, CANCEL ) it is forbidden.

Regards

Devki

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of sandip gangakhedkar
Sent: Thursday, August 06, 2009 10:46 AM
To: [email-masked]
Subject: [Sip] Contact header in 200 OK

Hi all,

I'd like to know if the Contact header is mandatory for a 200 OK response to an INVITE request.

The RFC doesnt explicitly mention anything in this regard although a 200 OK is mandatory for a REGISTER request.

If the originating endpoint receives the Contact header in the 180 Ringing response (which I assume is mandatory), then it knows the location of the remote endpoint, in which case the Contact header would be redundant in the 200 OK response.

Regards,

________________________________
This e-mail message is for the sole use of the intended recipient(s)and may
contain confidential and privileged information of Transaction Network Services.
Any unauthorised review, use, disclosure or distribution is prohibited. If you
are not the intended recipient, please contact the sender by reply e-mail and destroy all copies of the original message.

---

From: sandip gangakhedkar <[email-masked]>
Date: Fri, 7 Aug 2009 19:20:46 +0530

Hi Satya,

Thanks for the reply..didn't locate that table at first :)

Regards,

Sandip

On Fri, Aug 7, 2009 at 7:17 PM, T Satyanarayana-A12694 <
[email-masked]> wrote:

>  ------------------------------
> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *sandip
> gangakhedkar
> *Sent:* Thursday, August 06, 2009 8:16 PM
> *To:* [email-masked]
> *Subject:* [Sip] Contact header in 200 OK
>
> Hi all,
>